Subject: [Sigtran] SUA: No MTP Routing label in CLDT?

From: Andrew Booth <[email-masked]>
Date: Mon, 06 Jun 2005 13:09:57 -0400

Hi Lode,

I just noticed that there is no MTP Routing label in the CLDT message.  
In normal SCCP procedures there are some cases where OPC and/or DPC from 
the MTP Routing label may be used.  Normally, the SCCP takes care of all 
such cases before sending information to the user part, but in SUA there 
seems to be some ambiguity.

If an SG sends a segmented XUDT over SUA to an ASP, the OPC is no longer 
present to uniquely identify the sender.  In this case the segmentation 
parameter may be ambiguous e.g. if two remote nodes send segmented XUDTs 
to an ASP with the same segmentation reference.
Conclusion: the SG must reassemble XUDTs before sending to an ASP to 
avoid ambiguity.  Is this an appropriate comment to add to the 
Implementor's guide?

Andrew

-- 
Andrew Booth
Signaling Systems Group
Performance Technologies
www.pt.com
+1-613-237-4344
fax: +1-613-237-5277

Visit www.pt.com/mailing.html to subscribe to our Packets & Signals eLetter. 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 6 Jun 2005 14:22:26 -0600

Andrew,

MTP OPC and DPC are propagated to (and obtained from) the SUA
Souce and Destination addresses.  There is not a problem in this
case as the Source address is present in the segmented CLDT.
Also, see SUA section 4.7.1.

--brian

Andrew Booth wrote:                            (Mon, 06 Jun 2005 13:09:57)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/