Subject: RE: [Sigtran] Re: When would ASP send SCON

From: "Haresign Lincoln" <[email-masked]>
Date: Thu, 2 Jun 2005 11:57:29 -0400

To whom it may concern:

I think that an application behind a GW (an ASP) may detect a situation
where it is congested and it may want to take preemptive action and send
an SCON to the gateway.  This is just one of many scenarios where SCON
could be used.

Regards,
Lincoln Haresign

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Brian F. G. Bidulock
Sent: Thursday, June 02, 2005 2:47 AM
To: Jarek Mazur
Cc: [email-masked]
Subject: [Sigtran] Re: When would ASP send SCON

Jarek,

The ASP may send SCON.  The SGP is not required to do anything with the
message.  As you put, the SGP is fully capable of determining congestion
from its side and acting in an appropriate manner toward the SS7 network
or other ASPs.

The ASP being permitted to send SCON was viewed by some as a possible
way to support a mechanism similar to nodal TFC in SS7, which is, of
course, optional and implementation dependent even in SS7.  Also, not
all national variants permit it.

I made numerous attempts at having it removed from the RFC, but to no
avail.  Perhaps someone who actually believed it was important could
offer some justification for it.  I doubt that anyone can.

Unfortunately the document has no authors: perhaps you could ask one of
the numerous editors of the document why it could possibly be necessary.
You will find their contact information toward the end of the document.

--brian

Jarek Mazur wrote:                                    (Thu, 02 Jun 2005
15:47:52)
> 
>    Hi Brian,
> 
>    A  while  ago  you  have  kindly  provided me with the responses
which
>    enhanced my understanding about IPSP.
>    I include them here because they relate to a new concern/question
that
>    I have.
> 
>    Since the IPSP is not supposed to send either DAUD or SCON, and
relies
>    on  the  status directly from the underlying SCTP, then why could
this
>    behavior be different for the ASP in ASP-SGP communication in the
case
>    when  ASP  gets  congested.  The  SGP  can  detect ASP's congestion
in
>    exactly  the  same  manner as the IPSP its peer's, and also the SGP
in
>    the  similar  fashion  to the IPSP is not supposed to send DAUD to
its
>    peer.
> 
>    Hence  under  what  circumstances  would an ASP send the SCON
message?
>    (the spec says ASP may send SCON)
> 
>    Once again I would appreciate your expert opinion,
>    Regards,
>    Jarek
> 

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran
______________________________________________________________________
  This email message has been scanned by PineApp Mail-Secure and has
been found clean.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Kamesh Kaul <[email-masked]>
Date: Sat, 4 Jun 2005 01:24:59 -0700 (PDT)

Hi Haresign,

SCON from ASP was added in the specs to give more
flexibility to the ASP implementations to handle a
case in which explicit congestion indication (through
SCON message)can be send to Signalling gateway about
the congestion situation occuring at ASP, about which
SG has no clue.

Detection of congestion at ASP is implementation
dependent but propogation of congestion situation to
SG from ASP can be achieved through SCON if desired.
Sending of SCON from ASP is optional for the
implementations in which SCTP below M3UA can handle
the congestion situation occuring at ASP.

SG can then as you have said take some regulatory
actions by sending TFC to the concerned SS7 node.

Regards
Kamesh 
--- Haresign Lincoln <[email-masked]>

>   This email message has been scanned by PineApp

__________________________________ 
Yahoo! Mail Mobile 
Take Yahoo! Mail with you! Check email on your mobile phone. 
http://mobile.yahoo.com/learn/mail