Subject: [Sigtran] (no subject)

From: vinaym <[email-masked]>
Date: Thu, 23 Jun 2005 16:04:35 +0530

Hi All,

The sequence control parameter in SUA rfc - 3868 is not clearly specified ;
I have doubt that weather Seq Cntrl is 1 byte or is it 4 bytes ; if one byte
then weather 4th byte contains seq cntrl value and first  3 bytes are padded
to zero ???

The RFC description is as follows 

    0                   1                   2                   3

    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |         Tag = 0x0116          |             Length = 8        |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                        Sequence  Control         |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   Sequence Control (6.2.2.2.2/Q.711)

   The field is coded with the value of the sequence control parameter

   associated with a group of messages and are chosen so as to ensure

   proper loadsharing of message groups over SLS values while ensuring

   that sequence control values within message groups have the sequence

   control value coded with the same value as the initial message of the

   message group.

Please help me in this matter as soon as possible.

Thanks in Advance 

Regards

-Vinay

 

 HUAWEI

Vinay Murudi

Huawei Technologies India Pvt. Ltd.

Leela Galleria, 4th Floor

Leela Palace, No: 23, Airport Road

Bangolore - 560008

Ph: 080-5217152  Ext :1521

Mob :9880770605 

Email: [email-masked]

The greatest danger for most of us is not that our aim is too high, and we
miss it , But that our aim is too low and we reach it.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 23 Jun 2005 12:56:48 +0200

Hi Vinay,

the sequence control field is a uint32 in network byte order. This
is at least the interpretation ethereal uses...

Best regards
Michael

On Jun 23, 2005, at 12:34 Uhr, vinaym wrote:

> Hi All,
>  
> The sequence control parameter in SUA rfc – 3868 is not clearly 
> specified ; I have doubt that weather Seq Cntrl is 1 byte or is it 4 
> bytes ; if one byte then weather 4th byte contains seq cntrl value and 
> first  3 bytes are padded to zero ???
>  
> Bangolore – 560008
> The greatest danger for most of us is not that our aim is too high, 
> and we miss it , But that our aim is too low and we reach it.
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 23 Jun 2005 05:50:11 -0600

Michael,

Yes it is a unsigned 32-bit integer value that identifies a stream
of unit data requiring sequence control (Class 1 operation).  The
SG and ASP can use this to select a stream in the SCTP association
and the SG can use this to generate an SLS for SS7.  For SCTP stream
selection, the 32 bit value can be hashed to 16 bits.  For SS7 SLS,
it can be hashed to 8 bits.

--brian

Michael Tuexen wrote:                                                              (Thu, 23 Jun 2005 12:56:48)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: liubod <[email-masked]>
Date: Fri, 24 Jun 2005 10:12:04 +0800

brian,
for itu-t, SS7 SLS is 4 bits. some variations define SLS as 8 bits. is it changed?

----- Original Message ----- 
From: "Brian F. G. Bidulock" <[email-masked]>
To: "Michael Tuexen" <[email-masked]>
Cc: <[email-masked]>; "vinaym" <[email-masked]>
Sent: Thursday, June 23, 2005 7:50 PM
Subject: Re: [Sigtran] (no subject)

Michael,

--brian

> > The sequence control parameter in SUA rfc - 3868 is not clearly 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 23 Jun 2005 21:12:31 -0600

liubod,

For ITU-T SS7 you can can hash the 32 bits down to 4 (or down to 3 bits
and set the "fixed" bit appropriately).

--brian

liubod wrote:                                         (Fri, 24 Jun 2005 10:12:04)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/