Subject: [Sigtran] RE: No MTP Routing label in CLDT?

From: Coene Lode <[email-masked]>
Date: Wed, 8 Jun 2005 16:04:03 +0200

Hello Andrew,

The SG may take the MTP routing label OPC & DPC and include it in the CLDT
source and destination address.
So it is a configuration issue in the SG.

Yours sincerly,
Lode

Siemens COM
atealaan 34          2200 Herentals, Belgium
E-mail: [email-masked]
Tel: +32-14-252081
Fax: +32-14-253212

> -----Original Message-----
> From: Andrew Booth [mailto:[email-masked]] 
> Sent: maandag 6 juni 2005 19:10
> To: [email-masked]; Coene Lode
> Subject: SUA: No MTP Routing label in CLDT?
> 
> 
> Hi Lode,
> 
> I just noticed that there is no MTP Routing label in the CLDT 
> message.  
> In normal SCCP procedures there are some cases where OPC 
> and/or DPC from 
> the MTP Routing label may be used.  Normally, the SCCP takes 
> care of all 
> such cases before sending information to the user part, but 
> in SUA there 
> seems to be some ambiguity.
> 
> If an SG sends a segmented XUDT over SUA to an ASP, the OPC 
> is no longer 
> present to uniquely identify the sender.  In this case the 
> segmentation 
> parameter may be ambiguous e.g. if two remote nodes send 
> segmented XUDTs 
> to an ASP with the same segmentation reference.
> Conclusion: the SG must reassemble XUDTs before sending to an ASP to 
> avoid ambiguity.  Is this an appropriate comment to add to the 
> Implementor's guide?
> 
> Andrew
> 
> -- 
> Andrew Booth
> Signaling Systems Group
> Performance Technologies
> www.pt.com
> +1-613-237-4344
> fax: +1-613-237-5277
> 
> Visit www.pt.com/mailing.html to subscribe to our Packets & 
> Signals eLetter. 
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Andrew Booth <[email-masked]>
Date: Wed, 08 Jun 2005 12:02:34 -0400

Hi Lode,

Thanks for the response.  Brian mentioned this also.  I had forgotten 
that SUA can indicate whether the PC in the CLDT came from the OPC or 
the CLG Party Address.

I still have a concern though: can there be multiple PCs in the Source 
Address Parameter of the CLDT message?  If there can be only one then we 
might lose information if the OPC and CLG PC are both included but not 
the same.  I don't know if there is a reasonable case where this lost 
information could cause problems, but consider the following case (in 
the following, CLG PA = calling party address, CLD PA = called party 
address).

- SEP A sends out a query to STP B for GTT by alias PC D.  CLG PA PC is 
included and indicates A, CLD PA is route on GT.
- STP B translates the query, replaces the OPC with B, leaves CLG PA PC 
as A and sends the message to SEP E (the destination).  The outgoing 
message gets segmented.
At about the same time:
- SEP A sends out one query to STP C for GTT by alias PC D.  CLG PA PC 
is included and indicates A, CLD PA is route on GT.
- STP B translates the query, replaces the OPC with C, leaves CLG PA PC 
as A and sends the message to SEP E (the destination).  The outgoing 
message gets segmented.

Now when the segmented messages are passed up to SUA, which PC is in the 
CLDT?  Presumeably the CLG PA PC that is needed to get back to A.  
However, the segmentation parameters are going to be chosen 
independently by B and C.  The OPC + segmentation parameter are required 
in order to reliably reassemble the message.

I see two solutions:
- force the SCCP to reassemble before sending to SUA
- include both PCs in the CLDT Source Address parameter, with 
appropriate flags to distinguish the OPC and CLG PA PC.

Thoughts?
Andrew

-- 
Andrew Booth
Signaling Systems Group
Performance Technologies
www.pt.com
+1-613-237-4344
fax: +1-613-237-5277

Visit www.pt.com/mailing.html to subscribe to our Packets & Signals eLetter.