Subject: RE: [Sigtran] RE: No MTP Routing label in CLDT?

From: "Haresign Lincoln" <[email-masked]>
Date: Wed, 8 Jun 2005 12:19:03 -0400

To whom it may concern:

I'm a little confused. In a Gateway, the SS7 SCCP layer should be
completely reassembling the XUDT packets in to one message prior to
delivering the completed packet to the user.  The gateway would then
convert the reassembled message to a SUA CLDT message to deliver to the
ASP.

Isn't this always the case?

Regards,
Lincoln

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Andrew Booth
Sent: Wednesday, June 08, 2005 12:03 PM
To: Coene Lode; [email-masked]; [email-masked]
Subject: Re: [Sigtran] RE: No MTP Routing label in CLDT?

Hi Lode,

Thanks for the response.  Brian mentioned this also.  I had forgotten
that SUA can indicate whether the PC in the CLDT came from the OPC or
the CLG Party Address.

I still have a concern though: can there be multiple PCs in the Source
Address Parameter of the CLDT message?  If there can be only one then we
might lose information if the OPC and CLG PC are both included but not
the same.  I don't know if there is a reasonable case where this lost
information could cause problems, but consider the following case (in
the following, CLG PA = calling party address, CLD PA = called party
address).

- SEP A sends out a query to STP B for GTT by alias PC D.  CLG PA PC is
included and indicates A, CLD PA is route on GT.
- STP B translates the query, replaces the OPC with B, leaves CLG PA PC
as A and sends the message to SEP E (the destination).  The outgoing
message gets segmented.
At about the same time:
- SEP A sends out one query to STP C for GTT by alias PC D.  CLG PA PC
is included and indicates A, CLD PA is route on GT.
- STP B translates the query, replaces the OPC with C, leaves CLG PA PC
as A and sends the message to SEP E (the destination).  The outgoing
message gets segmented.

Now when the segmented messages are passed up to SUA, which PC is in the
CLDT?  Presumeably the CLG PA PC that is needed to get back to A.  
However, the segmentation parameters are going to be chosen
independently by B and C.  The OPC + segmentation parameter are required
in order to reliably reassemble the message.

I see two solutions:
- force the SCCP to reassemble before sending to SUA
- include both PCs in the CLDT Source Address parameter, with
appropriate flags to distinguish the OPC and CLG PA PC.

Thoughts?
Andrew

Coene Lode wrote:

>Hello Andrew,
>
>The SG may take the MTP routing label OPC & DPC and include it in the 
>CLDT source and destination address.
>So it is a configuration issue in the SG.
>
>Yours sincerly,
>Lode
>
>Siemens COM
>atealaan 34          2200 Herentals, Belgium
>E-mail: [email-masked]
>Tel: +32-14-252081
>Fax: +32-14-253212
>
>
>
>  
>
>>-----Original Message-----
>>From: Andrew Booth [mailto:[email-masked]]
>>Sent: maandag 6 juni 2005 19:10
>>To: [email-masked]; Coene Lode
>>Subject: SUA: No MTP Routing label in CLDT?
>>
>>
>>Hi Lode,
>>
>>I just noticed that there is no MTP Routing label in the CLDT message.
>>In normal SCCP procedures there are some cases where OPC and/or DPC 
>>from the MTP Routing label may be used.  Normally, the SCCP takes care

>>of all such cases before sending information to the user part, but in 
>>SUA there seems to be some ambiguity.
>>
>>If an SG sends a segmented XUDT over SUA to an ASP, the OPC is no 
>>longer present to uniquely identify the sender.  In this case the 
>>segmentation parameter may be ambiguous e.g. if two remote nodes send 
>>segmented XUDTs to an ASP with the same segmentation reference.
>>Conclusion: the SG must reassemble XUDTs before sending to an ASP to 
>>avoid ambiguity.  Is this an appropriate comment to add to the 
>>Implementor's guide?
>>
>>Andrew
>>
>>-- 
>>Andrew Booth
>>Signaling Systems Group
>>Performance Technologies
>>www.pt.com
>>+1-613-237-4344
>>fax: +1-613-237-5277
>>
>>Visit www.pt.com/mailing.html to subscribe to our Packets & 
>>Signals eLetter. 
>>
>>    
>>
>
>_______________________________________________
>Sigtran mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/sigtran
>  
>

-- 
Andrew Booth
Signaling Systems Group
Performance Technologies
www.pt.com
+1-613-237-4344
fax: +1-613-237-5277

Visit www.pt.com/mailing.html to subscribe to our Packets & Signals
eLetter. 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran
______________________________________________________________________
  This email message has been scanned by PineApp Mail-Secure and has
been found clean.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Andrew Booth <[email-masked]>
Date: Wed, 08 Jun 2005 12:43:28 -0400

I think it makes sense for the SCCP to do reassembly, but I don't see it 
written anywhere.  I think it would be approriate to add such text to 
the implementor's guide, it seems to me like the only sensible approach.

The waters are a little unclear though since a CLDT can include a 
segmentation parameter.  I'm not sure when that would get used (IPSP? 
Relay mode?) or what scope a segmentation parameter has (when 
reassembling an XUDT the segmentation reference and OPC are used 
together to identify a reassembly transaction, but OPC need not be 
present when doing reassembly at an SUA boundary).

Andrew

-- 
Andrew Booth
Signaling Systems Group
Performance Technologies
www.pt.com
+1-613-237-4344
fax: +1-613-237-5277

Visit www.pt.com/mailing.html to subscribe to our Packets & Signals eLetter.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 8 Jun 2005 12:08:32 -0600

Andrew,

Did I not already mention section 4.7.1?

--brian

Andrew Booth wrote:                           (Wed, 08 Jun 2005 12:43:28)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Andrew Booth <[email-masked]>
Date: Wed, 08 Jun 2005 14:39:15 -0400

Yes, you did.  It says reassembly could be performed at the SG, ASP or IPSP.

For segmentation and reassembly of XUDTs over the SS7 network, the SG 
seems like the only sensible place.  In this case, the ASP is not an 
appropriate place to reassemble.

What am I missing?

Andrew

-- 
Andrew Booth
Signaling Systems Group
Performance Technologies
www.pt.com
+1-613-237-4344
fax: +1-613-237-5277