Subject: [Sigtran] MAUP Rx on SCTP stream 0

From: Sunita Bhagwat <[email-masked]>
Date: 27 Jun 2005 18:09:21 +0530

Hi,
M2UA rfc explicitly mentions that MAUP msgs cannot be sent on SCTP
stream 0. However, if a peer does send data on stream 0, does the
receiving side send an 'invalid stream id' msg or does it simply discard
the data? Should this error msg be sent for every data chunk - else how
often is it sent in the face of continuous data from the peer?

Thanks!
Regards,
Sunita
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Ken Morneault <[email-masked]>
Date: Mon, 27 Jun 2005 15:46:04 -0400

Sunita,

The M2UA rfc says that the MAUP msgs should not be sent on SCTP
stream zero.  Since it does not say "must not", you can accept the
these messages.   You could also send a Error though, as you note,
it probably would not be prudent to send it for every message received
unless you were throwing them away.

Regards,

Ken

At 06:09 PM 6/27/2005 +0530, Sunita Bhagwat wrote:
>Hi,
>M2UA rfc explicitly mentions that MAUP msgs cannot be sent on SCTP stream 0. However, if a peer does send data on stream 0, does the receiving side send an 'invalid stream id' msg or does it simply discard the data? Should this error msg be sent for every data chunk - else how often is it sent in the face of continuous data from the peer?
>
>Thanks!
>Regards,
>Sunita