Subject: [Sigtran] IUA Interface IDs

From: "Nitin Tomar" <[email-masked]>
Date: Tue, 6 Sep 2005 14:27:17 -0700

Hi,

 I have a basic question on following text from IUA RFC (section 3.2):

 "The Tag value for the Integer-based Interface Identifier is 0x1.  The
   length is always set to a value of 8"

 Question is -
 Does above statement is valid for only IUA message header or
 it is applicable to all the messages in which Interface ID is used
(e.g., ASPAC etc),

 In other words:
 If I have to send two Interface IDs - 2 and 5 (not the range) in ASPAC
message,
 correct message encoding should be -

 A) tag - 0x1, length - 12, IID - 2 and 5
 
 OR
  
 B) tag - 0x1, length - 8 , IID - 2
   & tag - 0x1, length - 8, IID - 5

 Thanks,
 - Nitin

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Ken A Morneault \(kmorneau\)" <[email-masked]>
Date: Wed, 7 Sep 2005 16:29:14 -0400

Nitin,

The statement in Section 3.2 only applies to the IUA message
header.  Given your example for ASPAC, both (a) and (b) are
acceptable.

Regards,

Ken 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Nitin Tomar
Sent: Tuesday, September 06, 2005 5:27 PM
To: [email-masked]
Subject: [Sigtran] IUA Interface IDs

Hi,

 Question is -
 Does above statement is valid for only IUA message header or  it is
applicable to all the messages in which Interface ID is used (e.g., ASPAC
etc),

 In other words:
 If I have to send two Interface IDs - 2 and 5 (not the range) in ASPAC
message,  correct message encoding should be -

 OR

 Thanks,
 - Nitin