Subject: [Sigtran] LS ready message in case of LPO and LSPO

From: Devayya <[email-masked]>
Date: Mon, 05 Sep 2005 16:58:26 +0530

Hi ...
According to draft-ietf-sigtran-m2pa-13.txt when LS PO END is received
the receiving end will send a Ready message to the peer end and the peer
end will respond with a Ready message.
Consider a case where in both sides are experiencing Local Processor
Outage condition, and when the Outage ends at both the ends, Each of the
sides sends LS PO End message to the other end.
On getting LS PO End message each of the end responds with a Ready message.
Now how does the receiving end know that the Ready message is to be
responded with the Ready message OR not , because either side has
already sent a Ready message in response to LS PO End and is waiting for
  Ready message. Please suggest a solution.
In other words the case of collision of Ready message(after processor
outage), how to handle in m2pa.

diagramatically

     MTP3         m2pa                   m2pa         MTP3
                LPO End           LSPO END
      | -------------------->|------------->|
      |                      |              | 

      |                      |   Ready      | 

      |                      |<-------------|            |
      |                      |    LSPO END      LPO End  | 

      |                      |<-------------|<-----------|
      |                      |    Ready     |            | 

      |                      |------------->|

regards,
devayya

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 5 Sep 2005 20:05:42 -0600

Devayya,

After you send LSPO END always respond to Ready with ready.
(That is essentially what the RFC says.)

Because the purpose of the Ready messages is sequence number
resynchronization, it does not matter that it is occurring
simultaneously at both ends.  Indeed, that was the purpose of
the messages, to coordinate sequence number syncrhonization at
both ends before transmission resumes.  Extra Ready messages
do not affect the resynchronization, so always send the response
so that the state machine at the peer can complete.

BTW, LPO End is not an MTP3 to MTP2 signal: Flush-Buffers and
Resume (or Continue) are.  MTP3 never allows MTP2 to leave the
local processor outage state without addressing the disposition
of receive buffers in the MTP2 RB.

--brian

Devayya wrote:                                      (Mon, 05 Sep 2005 16:58:26)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 6 Sep 2005 02:36:33 -0600

Devayya,

Ready messages are only otherwise normally received immediately following
Alignment or proving.  If you receive one outside of these contexts, it
is pretty much up to you what action you wish to take.  Stopping the link
is one approach (and possibly the best approach for many applications).

--brian

On Tue, 06 Sep 2005, Devayya wrote:

> 
>    Brian,
>    Thanks for that clarification.
>    Also,  Consider  one more case where a stray Ready message is received
>    in  In-service  state  of the link (and there is no processor outage).
>    Does it mean that we have to reply with a ready message? Or should the
>    link  be  placed  out  of   service?  or  just  ignore the stray ready
>    message?
>    Best regards,
>    devayya
>    Brian F. G. Bidulock wrote:
> 
> Devayya,
> 
> [1][email-masked]
> [2]https://www1.ietf.org/mailman/listinfo/sigtran
> 
> References
> 
>    1. mailto:[email-masked]
>    2. https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦