Subject: RE: [Sigtran] Recommendation for SUA modifications

From: "Haresign Lincoln" <[email-masked]>
Date: Fri, 14 Oct 2005 11:28:50 -0400

Tolga,

I agree with you.  There are many scenarios where it is not a good idea
to shutoff all data flow between ASP and SG.  We want to shut off or
reduce peer to peer data messages associated with a specific ASP.  Only
a peer-to-peer message will handle that scenario.

Regards,
Lincoln 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Tolga Asveren
Sent: Friday, October 14, 2005 11:02 AM
To: [email-masked]
Subject: RE: [Sigtran] Recommendation for SUA modifications

Brian,

As far as I can see, SCTP congestion may not be good enough for cases:
a)Where there are I/O bound operations on ASP as part of application
logic -depending on latency on I/O operation, application can declare
itself congested, rather than waiting SCTP to detect it- b)If ASP-M3UA
and ASP-Service Logic are on different hosts/cards/blades etc..

For both of those cases, congestion will probably propogate down to the
SCTP level eventually, but it can be detected and SG can take proper
action earlier. Actually I believe even for the generic case,
application can detect congestion earlier than SCTP for most of the
situations and I think to have the option to communicate this as early
as possible is a nice thing to have.

    Thanks,
    Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Brian F. G. Bidulock
> Sent: Friday, October 14, 2005 10:46 AM
> To: Tolga Asveren
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Sigtran] Recommendation for SUA modifications
>
>
> Tolga,
>
> What were the scenarios where SCTP flow control (arwnd) do not work?
>
> Could you detail them?
>
> I would like to capture them in my congestion draft.
>
> --brian
>
> Tolga Asveren wrote:                            (Fri, 14 Oct 2005
> 09:34:42)
> > Brian,
> >
> > On the big picture I agree with you that SSNM is meant to be
> used for SS7
> > network management, hence SCON is supposed to be used for SS7 
> > congestion procedures. OTOH, there is a need to notify congestion 
> > status
> of ASPs to SG
> > and right now it seems like we don't have a solution -actually
> till now the
> > supposed solution was relying on SCTP congestion but there are 
> > scenarios where this is not enough/does not work well-. I believe
> something needs to
> > be done to address that issue.
> > a)Either a new ASPTM
> > b) or overloading SCON
> >
> >     Thanks,
> >     Tolga
> >
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
>

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 14 Oct 2005 11:17:29 -0400

Lincoln,

Yes, actually the reason you mentioned is really an important one. Once we
go down to SCTP level mechanisms, all M3UA messages will be handled equal
from congestion point of view. OTOH, a M3UA mechanism would enable us to act
based on the importance/semantics of different M3UA messages.

     Thanks,
     Tolga

> From: Haresign Lincoln [mailto:[email-masked]]
> Sent: Friday, October 14, 2005 11:29 AM
> To: Tolga Asveren; [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 14 Oct 2005 09:55:28 -0600

Tolga,

Your right!  SS7 MTP's method of setting 4 levels of onset and abatement
thresholds to buffer occupancy is completely inapplicable to SCTP.  It
can't possible work correctly, even in the SS7 network.  We need to assign
a completely new set of M3UA message priortities to MTP messages so that
we can improve upone MTP.

Four levels is way to coarse.  We have a full 32-bits in the ASP Congestion
field, let's use them!  4G worth of levels.  Can you help my draft by assiging
these new priorities to messages?  How are we going to get ISUP to assign
an M3UA priority to is messages?

--brian

Tolga Asveren wrote:                                                                  (Fri, 14 Oct 2005 11:17:29)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/