Subject: [Sigtran] M3UA User Part's Management

From: David Santos <[email-masked]>
Date: Mon, 10 Oct 2005 19:00:28 +0200 (CEST)

Hi, we are having problems with M3UA User Part’s
management, specially in a IPSP communication.

We have two AS, both with two Users Parts (one with
SI=A and another one with SI=B). Each AS has only one
RK, serving a unique PC.

When User1 get connected to AS1, AS1 becames ACTIVE
and communication is established with AS2. If User2 is
not already connected but his AS is in ACTIVE state,
how can User4 know when to start sending messages to
User2?

How can we manage M3UA User Part’s connections and
disconnections? Could we use SSNM messages for this
purpose in a IPSP communication?

  ________   ________         ________    ________
 |        | |        |       |        |  |        |
 | User1  | | User2  |       | User3  |  | User4  |
 | SI = A | | SI = B |       | SI = A |  | SI = B |
 |________| |________|       |________|  |________|
       |          |              |            |
       |          x <== (Not     |            |
       |____   ___|  Connected   |_____   ____|
            | |         yet)           | |
           _|_|____                  __|_|___
          |        |                |        |
          |  AS1   |                |  AS2   |
          | PC = X |                | PC = Y |
          |________|                |________|
              |                          |
           ___|____                  ____|___
          |        |                |        |
          |  ASP   |                |  ASP   |
          |________|                |________|
               |                         |
               |________< M3UA >_________|

Thank you.

______________________________________________ 
Renovamos el Correo Yahoo! 
Nuevos servicios, más seguridad 
http://correo.yahoo.es

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 10 Oct 2005 13:00:01 -0400

David,

IMO, the architecturally correect solution for your problem is using two
RKs, one for each user part.

     Thanks,
     Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of David Santos
> Sent: Monday, October 10, 2005 1:00 PM
> To: [email-masked]
> Subject: [Sigtran] M3UA User Part's Management
>
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 10 Oct 2005 11:33:43 -0600

David,

To provide M3UA with information about the availability
of an MTP User Part requires that the AS be no larger
than a User part.  You are runnign into difficulties
because your AS is too large.  Define an AS per user
and your difficulties should go away.

Otherwise, only use user parts that manage their own
availability and do not rely on MTP to do so for them.
(E.g. SCCP does this.  Without an SSA, no message other
than an SST will be sent.  ISUP has UPT.)

--brian

David Santos wrote:                                                                  (Mon, 10 Oct 2005 19:00:28)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/