Subject: [Sigtran] Error code for a specific case in UA

From: "Sergey Mikhailov" <[email-masked]>
Date: Mon, 17 Oct 2005 18:56:01 +0400

Hi,

Let's suppose a message with at least one mandatory parameter is received. But the message has Length = 8 in common message header.

What error code must be specified in ERROR message to be sent in response?
Is "Missing Parameter" the correct code for this case?

Regards,
Sergey Mikhailov.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 18 Oct 2005 01:37:37 -0600

Sergey,

Yes.  Even if a parameter follows the message header, it is not
included in the message length and is therefore not really part
of the message, is it?  If the message requires a parameter,
then "Missing Parameter" sounds reasonable to me.

--brian

On Mon, 17 Oct 2005, Sergey Mikhailov wrote:

> 
>    Hi,
> 
> 
> 
>    Let's  suppose  a  message  with  at  least one mandatory parameter is
>    received. But the message has Length = 8 in common message header.
> 
> 
> 

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: "Sergey Mikhailov" <[email-masked]>
Date: Tue, 18 Oct 2005 11:59:45 +0400

Brian,

Thank you for this reply. I completely agree with your explanation.

Sergey Mikhailov.