Subject: RE: [Sigtran] Congestion in M3UA/SUA and the use of the SCON

From: "Haresign Lincoln" <[email-masked]>
Date: Mon, 10 Oct 2005 08:56:29 -0400

Brian,

With regards to SUA, I believe you might be mistaken.  There is no
requirement to have a point code in the message recevied by SUA.  The
message received will have a called and calling address.  These
addresses could be global titles with no point code.

So again, if the ASP wants to indicate congestion back to the GW, it has
no way to specify the affected PC.

Regards,
Lincoln

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Friday, October 07, 2005 2:00 PM
To: Haresign Lincoln
Cc: Tolga Asveren; [email-masked]
Subject: Re: [Sigtran] Congestion in M3UA/SUA and the use of the SCON

Lincoln,

Haresign Lincoln wrote:
(Fri, 07 Oct 2005 09:03:57)
> 
> The SUA layer at the ASP also has immediately at its disposal all the 
> addresses necessary to complete the mandatory address fields in the 
> SCON.
> 
> [lincoln]: It doesn't.  The SUA layer only knows source address which 
> may be a GT.

Yes it does, both for M3UA and SUA they are contained in the message
that triggered congestion.

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

______________________________________________________________________
  This email message has been scanned by PineApp Mail-Secure and has
been found clean.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 10 Oct 2005 11:20:41 -0600

Haresign,

Haresign Lincoln wrote:                                                           (Mon, 10 Oct 2005 08:56:29)
> addresses could be global titles with no point code.

Only at a relay node.  Which is an SG or IPSP.  No ASP.  An ASP is
an end-point.

> no way to specify the affected PC.

An ASP always has a point code because final GTT has always been
performed at an ASP.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/