Subject: RE: [Sigtran] RE: Message loss in SIGTRAN networks

From: "Haresign Lincoln" <[email-masked]>
Date: Tue, 4 Oct 2005 11:48:01 -0400

Tolga,

In theory, what you are saying may be true.  In practice, associations
are failing without remote host failure.  We are seeing it in the
networks (multihomed) that we are dealing with.  If you fail to
acknowledge this fact, then there is no point to this discussion any
further and we should just agree to disagree on this point.  

Regards,
Lincoln

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Tolga Asveren
Sent: Tuesday, October 04, 2005 11:24 AM
To: [email-masked]
Subject: RE: [Sigtran] RE: Message loss in SIGTRAN networks

Lincoln,

> -----Original Message-----
> From: Haresign Lincoln [mailto:[email-masked]]
> Sent: Tuesday, October 04, 2005 11:33 AM
> To: Tolga Asveren; [email-masked]
> Subject: RE: [Sigtran] RE: Message loss in SIGTRAN networks
>
>
> Tolga,
>
> Let's take this one step at a time.
>
> OK, so you accepted my premise that theoretically (and practically), 
> associations will fail.
[TOLGA]No, I just said theoretically. Practically an SCTP association
failure should indicate a host failure with a very very high probability
from M3UA point of view where this is high enough to satify the needs of
SS7. And as said below, SCTP with multihoming should deliver this by
preventing single-point of failures with multihoming -one can even have
more than 2 interfaces/networks multihomed to prevent even n-point of
failures-.

Just on the more philosophical side of the things, I believe for any
system/mechanism it could be argued that it could fail theoretically
(and practically with a certain probability). Important is that
reliability is above a certain threshold for practical usability of that
system/mechanism.
>
> The next question is do you want to live with the potential data loss,

> or do you want to design something in to the M3UA protocol to try to 
> reduce or eliminate the message loss when the lower layer transport 
> fails.
>
> Regards,
> Lincoln
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Tolga Asveren
> Sent: Tuesday, October 04, 2005 10:36 AM
> To: [email-masked]
> Subject: RE: [Sigtran] RE: Message loss in SIGTRAN networks
>
> Lincoln,
>
> > -----Original Message-----
> > From: Haresign Lincoln [mailto:[email-masked]]
> > Sent: Tuesday, October 04, 2005 10:45 AM
> > To: Tolga Asveren; [email-masked]
> > Subject: RE: [Sigtran] RE: Message loss in SIGTRAN networks
> >
> >
> > Tolga,
> >
> > Just to be clear....are you saying that the ONLY way that a 
> > multihomed
>
> > association can fail is through peer host failure?
> [TOLGA]Theoretically no, but from M3UA point of view the expectation 
> is that this holds true with a very very high probability. I believe, 
> we also need to consider that no mechanism is fully failure safe, i.e.

> if we avoid single-point of failures we usually consider this as an 
> acceptable solution.
> My understanding is that SCTP multihoming can avoid single-point of 
> failures for transport layer services.
> >
> > Regards,
> > Lincoln
> >
>

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 4 Oct 2005 11:39:22 -0400

Lincoln,

> Sent: Tuesday, October 04, 2005 11:48 AM
[TOLGA] No, no I am not trying to keep my eyes closed, just thinking there
may be something to do -adjusting SCTP parmaeters etc..- to make the
situation acceptable, without adding some procedures with sequence numbers
and such kind of things -and I may be wrong-. OTOH, yes, for now we have
different opinions about how to tackle the problem but I believe Lyndon's
suggestion is a really good one. Let's try to document things in a draft and
then let's see where it is going to lead.