Subject: [Sigtran] Encoding of IP address in SUA(section 3.10.2.6)

From: [email-masked]
Date: Thu, 27 Oct 2005 10:20:58 +0530

Hi All,
 
I have a question about the encoding of the IP address in SUA.
 
should the Ip address be encoded in network byte order ?
 
Thanks,
Arijit
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 26 Oct 2005 23:17:44 -0600

arijit.dilip,

Yes, it should be network byte order.

The RFC should have a statement that all fields are Network Byte Order
unless otherwise stated, but it doesn't.  It is just an oversight (we
went to the trouble of defining Network Byte Order and then missed the
statement.)

One for the I-G.

--brian

[email-masked] wrote:                                                 (Thu, 27 Oct 2005 10:20:58)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/