Subject: RE: [Sigtran] Re: [Fwd: M3UA- handling of multiple Routing Context's(SGP <-> ASP)]

From: "Ken A Morneault \(kmorneau\)" <[email-masked]>
Date: Tue, 15 Nov 2005 13:58:09 -0500

Brian, Bhanu,

I would say it should process the valid RCs and
return an Error "Invalid RC" for the invalid RCs.

For instance, the SGP receives an ASP Active with
multiple RCs.  The SGP would send ASP Active Ack for
all valid RCs and an Error "Invalid RC" for the
invalid RCs.  

Regards,

Ken  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Brian F. G. Bidulock
Sent: Tuesday, November 15, 2005 1:03 PM
To: Bhanu Prakash
Cc: [email-masked]
Subject: [Sigtran] Re: [Fwd: M3UA- handling of multiple Routing
Context's(SGP <-> ASP)]

Bhanu,

Bhanu Prakash wrote:
(Tue, 15 Nov 2005 20:07:04)
> 
>    -------- Original Message --------
> 
>    Subject: M3UA- handling of multiple Routing Context's (SGP <-> ASP)
>       Date: Tue, 15 Nov 2005 10:04:30 +0530
>       From: Bhanu Prakash [1]<[email-masked]>
>         To: [2][email-masked]
> 
> Hai all
> I need clarification on this issue:
> 
> Consider a case where an SGP is using the AS number as routing
context.
> If an SGP receives an M3UA message with multiple routing context's, If

> some of the routing context's are invalid (i.e. not configured in 
> SGP), an error message is sent to ASP indicating the same.
> 
> Q1-What about the other valid routing context's.?
> Q2-Should the SGP has to process the valid ones.?

It does not have to: the message is invalid.

--brian

> If yes..
>      If the ASP is not in expected state for some routing 
> context's(i.e
> AS) and
>      ASP is in expected state for routing context's(i.e AS), what is 
> the procedure
>      to handle the same.
> 
> Thanks,
> Bhanuprakash.
> 
> References
> 
>    1. mailto:[email-masked]
>    2. mailto:[email-masked]

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 15 Nov 2005 12:03:54 -0700

Ken,

Yes you could, but my point is that you are not required to.

--brian

Ken Morneault wrote:                                                                   (Tue, 15 Nov 2005 13:58:09)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/