Subject: [Sigtran] RE: ASP configuration in AS

From: Saraswati Bose <[email-masked]>
Date: Mon, 7 Nov 2005 23:35:10 -0800 (PST)

Hi Brian,
 
The AS is uniquely identified by RK value. 
The multiple ASPs within the AS will have unique ASPID values.
 
Suggest what conditions apply for the below.
 
1. Should NA  when present in RK uniquely identify the AS and be same across the three ASPs? Or is the parameter specific to the ASPs?
 
2. The dynamic registration feature (registering ASPs within a AS) support apply to the AS or individual ASP? Means can we configure such that 1 ASP supports dynamic registration while other two don't.
 
3. The dynamic configuration (registering of ASP to a new AS) support apply to AS or individual ASP?
 
4. For traffic mode override can only ASP strictly stay in ACTIVE state? If true what error can be encoded in response to active request received from the other ASP when one ASP is already in active state? "unexpected message"/ "protocol error"?
 
5. How can we indicate to the peer SG the ASPs that belong to the particular AS? Is it the statically configured RK for the AS? But RK is exchanged during registration procedure only which is a optional procedure? 
 
6. You said we may keep the NA +RC/IID combination same for multiple ASPs load sharing traffic. Do the same apply for override also?
 
7. Can we opt for multiple ASPs configured within AS with completely different set of routing parameters for both override/load share modes and yet successfully route traffic as per routing information set.
 
--Saraswati

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 8 Nov 2005 02:00:44 -0700

Saraswati,

Saraswati Bose wrote:                        (Mon, 07 Nov 2005 23:35:10)

>    1. Should  NA  when present in RK uniquely identify the AS and be same
>    across the three ASPs? Or is the parameter specific to the ASPs?

NA is agreed upon between SGP and ASP.  Only necessary when the SGP
supports more than one.  Typically the same assignment for each SGP in
an SG.  Could be managed to be the same across more than one SG or
across an entire administrative domain.

>    2.  The  dynamic  registration  feature (registering ASPs within a AS)
>    support apply to the AS or individual ASP? Means can we configure such
>    that 1 ASP supports dynamic registration while other two don't.

Dynamic regsitration by an ASP is optional.  You can provision the ASP
with an RC value (agreed upon between ASP and SGP) instead.

>    apply to AS or individual ASP?

I would say it applies to an SGP.  The ASP can regsiter or not as it
choses regardless of whether the ASP supports it or not.

>    4.  For  traffic  mode  override  can only ASP strictly stay in ACTIVE
>    state? If true what error can be encoded in response to active request
>    received  from  the other ASP when one ASP is already in active state?
>    "unexpected message"/ "protocol error"?

The activating ASP takes over from the other.  SGP sends NTFY(alternate
ASP active for AS).

>    5. How  can  we  indicate  to  the peer SG the ASPs that belong to the
>    particular  AS?  Is it the statically configured RK for the AS? But RK
>    is  exchanged  during  registration procedure only which is a optional
>    procedure?

An RK is provisioned at the SGP if the ASP does not register.

>    6.  You  said we may keep the NA +RC/IID combination same for multiple
>    ASPs load sharing traffic. Do the same apply for override also?

Yes.

>    7.  Can  we opt for multiple ASPs configured within AS with completely
>    different set of routing parameters for both override/load share modes
>    and yet successfully route traffic as per routing information set.

I don't know what you mean by that, but I think the answer is no.

Much of this information is in the RFC: have you read it?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 8 Nov 2005 04:24:27 -0700

Saraswati,

I'm sorry, I still don't understand the question.

--brian

On Tue, 08 Nov 2005, Saraswati Bose wrote:

> 
>    Hi brian,
> 
> 
> 
>    U  mean  to  say  irrespective  of the AS that multiple ASPs serve the
>    registration  procedure  is specific to ASP-SG just like the UP/ACTIVE
>    procedures and not AS_SG,  right...
> 
> 
> 
>    Suppose  I  have  one  AS with 3 ASPs serving it. These three ASPs are
>    communicating with the peer end SG.
> 
> 
> 
>    When  multiple ASPs serve a particular AS then is there any parameters
>    that is  manadtory to be kept common to allow traffic flow from the SG
>    in case of override or load share traffic?
> 
> 
>    --Saraswati
> 

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 8 Nov 2005 22:40:25 -0700

Saraswati,

On Tue, 08 Nov 2005, Saraswati Bose wrote:

> 
>    Brian,
> 
> 
> 
>    I  think like an AS is uniquely identified by its RK value in SUA/M3UA
>    similarly in IUA AS is identified by Interface Identifier value.
> 
> 
> 
>    1.For  an  ASP serving in more than one AS the Routing Context is used
>    to  identify  the  ASP for each unique AS that it serves in SUA/ M3UA.
>    What parameter can we use for IUA case?

IID is closer to RC than RK.

> 
>    2. In rfc 3057--IUA ASPID parameter is not defined. In that case which
>    other parameter can be used to identifying the multiple ASPs serving a
>    AS?

I believe it was defined in rfc3057bis.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 8 Nov 2005 23:38:00 -0700

Saraswati,

In M3UA and SUA, there is a 1:1:1 relationship between RK:RC:AS.

In IUA and M2UA, there is a 1:1 relationship between IID:AS (with
the exception that any of several IIDs within the same AS can
identify the AS).

But this should be obvious from the RFCs.

--brian

On Tue, 08 Nov 2005, Saraswati Bose wrote:

> 
>    Brian,
> 
>     This  is  confusing.  If  for SUA /M3UA I use RK as also specified in
>    RFCs  to  uniquely  identify  the  AS  then  for  IUA case as says the
>    rfc-3057  I  have  to use IID. Suggest if there is any other parameter
>    used for the purpose?
> 
> 
> 
>    Now  the  question  is  if  I use IID for identifying the AS then what
>    parameter  may  I use to identify the same ASP that serves multiple AS
>    (with  unique  IID)  like  we have one to one correspondance for RC:RK
>    combination defined for SUA/M3UA.
> 
> 
> 
>    --Saraswati