Subject: [Sigtran] Traffic handling modes compatibility

From: "Sergey Mikhailov" <[email-masked]>
Date: Mon, 28 Nov 2005 19:07:46 +0300

Hi,

What traffic handling modes are considered compatible by an SGP when performing registration procedure?

Section 4.3.4.3 says: "If the SGP determines that the mode indicated in an ASP Active message is unsupported or incompatible with the mode currently configured for the AS, the SGP responds with an Error message ("Unsupported / Invalid Traffic Handling Mode")."

Section 3.7.1 says: "Within a particular Routing Context, Override, Loadshare and Broadcast SHOULD NOT be mixed."
This means that [according to RFC2119 (BCP14)] there may exist valid reasons to mix different traffic handling modes.

Sergey Mikhailov.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Barry Nagelberg" <[email-masked]>
Date: Mon, 28 Nov 2005 11:18:01 -0500

Sergey,

1. Here is an example of an incompatibility:

ASP1 sends a REG_REQ msg for RK x will Traffic Mode = Override
ASP2 sends a REG_REQ msg for RK x will Traffic Mode = Loadshare

This means that ASP2 is trying to join an existing AS, but wants to use a different traffic mode that what has already
been established for the AS.

2. I can't think of any valid reason to mix traffic modes.

Barry Nagelberg
Adax, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Sergey Mikhailov
Sent: Monday, November 28, 2005 11:08 AM
To: SIGTRAN
Subject: [Sigtran] Traffic handling modes compatibility

Hi,

Section 4.3.4.3 says: "If the SGP determines that the mode indicated in an ASP Active message is unsupported or
incompatible with the mode currently configured for the AS, the SGP responds with an Error message ("Unsupported /
Invalid Traffic Handling Mode")."

Sergey Mikhailov.