Subject: RE: [Sigtran] M3UA: 1IPSP - multiple IPSPs traffic flow

From: "Prasad, Shashank S (Shashank)" <[email-masked]>
Date: Mon, 7 Nov 2005 20:07:22 +0530

Hi Brian,
Not really trying to "mogrify" Brian. I am ONLY trying to discuss some
changes which shall greatly help to take advantage of the SE mode in the
IPSP-IPSP (Point to Point) scenario.

Except for the Traffic Mode, there is nothing that stops IPSPs to talk to
each other using SE mode in a point to point fashion. One can use the local
configuration of Traffic Modes and start to work in the SE mode.

However, we should take the advantage of ASPAC and ASPAC-Ack messages
exchanges to set the Traffic Modes (overriding the local configuration). A
change in concepts will set the IPSPs talking to each other in the SE mode.

That's what Tolga and I were discussing with :)
I cannot expect the peer IPSPs to always support an optional DE mode..

Also, I did NOT quite understand why one would like an IPSP behave like an
SGP.

shashank

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, November 07, 2005 6:17 PM
To: Prasad, Shashank S (Shashank)
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA: 1IPSP - multiple IPSPs traffic flow

Shashank,

I don't think that you understand SE mode.   Take a look back in the mail
archives for long discussions of the differences between SE and DE modes.
SE mode uses the same semantics as an ASP/SGP connection, where one IPSP
acts like an ASP in the exchange and the other acts like an SGP.

I find it strange that you refuse to use DE mode, yet seem to want to
mogrify SE into DE.

--brian

Prasad, Shashank S (Shashank) wrote:            (Mon, 07 Nov 2005 17:39:22)
> Brian,
> 
> Replies embedded.
> 
> 
> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Monday, November 07, 2005 4:24 PM
> To: Prasad, Shashank S (Shashank)
> Cc: [email-masked]
> Subject: Re: [Sigtran] M3UA: 1IPSP - multiple IPSPs traffic flow
> 
> 
> Shashank,
> 
> The RFC is clear: the TM in the ASP Active Ack is the value that was sent
> in the ASP Active.
> 
> In SE mode, the peer does not have a traffic mode.  It is acting like an
> SGP.
> Again, see A.2.2.
> 
> [SHASHANK] U are putting a lot of constraints by this statement. Ur
> statement means that IPSP-IPSP cannot have a SE mode. This is NOT really
> correct. Here I am trying to make some minor improvements in the M3UA
specs
> so that IPSPs can also use the SE effectively.
> 
> 
> If you want both IPSPs to each have an AS an traffic mode, use DE instead
> of SE.
> 
> [SHASHANK] This is a big contraint and not acceptable :)
> IPSPs can surely use SE mode too between themselves (IPSPs). Moreover DE
is
> optional. 
> --brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 7 Nov 2005 11:42:38 -0700

Prasad,,

Prasad, Shashank S (Shashank) wrote:                                               (Mon, 07 Nov 2005 20:07:22)
> IPSP-IPSP (Point to Point) scenario.

What would greatly help IPSP would be an SG-SG IPSP instead of SE or DE.
There were long ladders of discussion at LC on RFC 3332 and Tolga even
wrote a draft.

I would far rather discuss the SG-SG model for IPSP rather than trying to
make "enhancements" to SE or DE models, which are inferior.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/