Subject: Re: [Sigtran] RFC3332: RC in DAVA Message

From: [email-masked]
Date: Wed, 02 Nov 2005 14:07:09 +0530

Hi Samuel,

Thanks for reply.Currently an error is generated for this parameter
& links are set to unavailable.

But the definition for parameter in RFC states,

Parameter Length: 16 bits (unsigned integer)

The Parameter Length field contains the size of the parameter in

bytes, including the Parameter Tag, Parameter Length, and

Parameter Value fields.  Thus, a parameter with a
zero-length

Parameter Value field would have a Length field of 4.
The

Parameter Length does not include any padding bytes."

In this case, RC
parameter is received complying to above. For this an ERROR is reported
from AS as you have stated below. The links are unavailable due to
this communication in loop.

Kind Regards,Madhavan

Samuel Dur D. Jeyaseelan wrote:

Madhavan,

pls see my comments inline.

--Samuel

Alcatel USA, Inc. Internet: <userid>@ssd.usa.alcatel.com
1000 Coit Road, Plano, Texas 75075
******* The opinions expressed are not those of Alcatel USA, Inc. *******

On Mon, 31 Oct 2005 [email-masked] wrote:

Hi !!

I am currently involved in configuration of SGW to AS(doing this type of
configuration for first time) & need following clarification as I cannot
pick this out in clear way from RFC.

Scenario:

- AS sends DAUD to SGW without Routing Context
- AS receives DAVA with routing context parameter.The contents are tag
id & length of the parameter without any value.In this case the length
is 4 bytes (2 bytes for tag id & 2 bytes for length field itself)

Question:

Since AS has not sent a RC in DAUD, i assume the field should not be
received in DAVA.Is my assumption inline with RFC ?

RC is a 'conditional' parameter that means it is very much needed when an
ASP serves more than one AS. In your case if the received RC does not find
any match in the static or dynamic databases then it is appropriate to
send an ERROR msg to SGW.

Thank you in advance,

Kind Regards,Madhavan

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Wed, 2 Nov 2005 02:54:39 -0600 (CST)

Madhavan,

Hope  SGW might have received the ERROR msg with "Invalid Routing
Context" but links should not go down.

--Samuel

On Wed, 2 Nov 2005 [email-masked] wrote:

> Hi Samuel,
> 
> Thanks for reply.Currently an error is generated for this parameter &
> links are set to unavailable.
> 
>       Parameter Value fields.  Thus, a parameter with a zero-length
>       Parameter Value field would have a Length field of 4.  The
> In this case, RC parameter is received complying to above. For this an
> ERROR is reported from AS as you have stated below. The links are
> unavailable due to this communication in loop.
> 
> Kind Regards,Madhavan
>