Subject: [SIGTRAN]: Clarification On load sharing and Sequence control value

From: Saraswati Bose <[email-masked]>
Date: Wed, 30 Nov 2005 04:54:59 -0800 (PST)

Hi Brian,
  Please check the below text from RFC-3868.
     
  3.10.22. Sequence Control
  The field is coded with the value of the sequence control parameter
  associated with a group of messages and are chosen so as to ensure
  proper loadsharing of message groups over SLS values while ensuring
  that sequence control values within message groups have the sequence
  control value coded with the same value as the initial message of the
  message group.
   
  Please suggest in the below:
   
  1. I think SSN is a single value unique across the AS? PLease suggest if I am wrong.
   
  2. If SSN is a single value unique across the AS then how to apply the round robin alg. on SSN value?
   
  3. In SUA no SLS is involved. So how to handle the sequence control parameter value during load sharing among ASPs using round robin algorithm over SSN?
   
  4. Is TID/DRN value unique across AS?
   
  Regards,
  Saraswati.

		
---------------------------------
 Yahoo! Music Unlimited - Access over 1 million songs. Try it free.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 30 Nov 2005 07:09:49 -0700

Saraswati,

Saraswati Bose wrote:                                            (Wed, 30 Nov 2005 04:54:59)
>    1. I  think SSN is a single value unique across the AS? PLease suggest

What do you mean by "single value unique across the AS"?

>    round robin alg. on SSN value?

SSN would be a poor choice for loadsharing.

> 
>    3.  In  SUA  no SLS is involved. So how to handle the sequence control
>    parameter  value  during  load  sharing  among  ASPs using round robin
>    algorithm over SSN?

SLS (from the receive MTP message) is the only rational basis on which an SG
can loadshare.

>    4. Is TID/DRN value unique across AS?

What do you mean by "unique across AS"?

--brian

> 
>    Regards,
>    Saraswati.
> 
> 
>      _________________________________________________________________
> 
>    [1]Yahoo! Music Unlimited - Access over 1 million songs. Try it free.
> 
> References
> 
>    1. http://pa.yahoo.com/*http://us.rd.yahoo.com/evt=36035/*http://music.yahoo.com/unlimited/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/