Subject: [Sigtran] M3UA - AS-PENDING with IPSP-IPSP

From: David Santos <[email-masked]>
Date: Mon, 7 Nov 2005 16:06:21 +0100 (CET)

Hi, we have the following configuration depicted
below. It’s an IPSP-IPSP communication. We have AS1
served by ASP1. ASP2 and ASP3 are in the same
Application Server (AS2). Every ASP is operating in
Override traffic mode, where ASP1 and ASP2 are
configured to be in the ASP-ACTIVE state and ASP3 is
acting as backup.

   ________           ________     ________ 
  |        |         |        |   |        |
  |  AS1   |         |  AS2   |   |  AS2   |
  | PC = X |         | PC = Y |   | PC = Y |
  |________|         |________|   |________|
      |                  |            |     
   ___|____           ___|____     ___|____ 
  |        |         |        |   |        |
  |  ASP1  |         |  ASP2  |   |  ASP3  |
  |  IP@1  |         |  IP@2  |   |  IP@3  |
  |Override|         |Override|   |Override|
  |(Active)|         |(Active)|   |(Backup)|
  |________|         |________|   |________|
       |                  |            |    
       |__________________|____________|    

When ASP2 turns Inactive, is the following scenario
correct? Or shouldn’t ASP2 send AS-PENDING? Which
would be the correct sequence? Could be correct that
just the ASP receiving ASP-Inactive sends AS-PENDING
messages as a SGP would do?

 ASP1                     ASP2                   ASP3
   |                        |                      |
   |-------------------ASP Active----------------->|
   |<----------------ASP Active Ack----------------|
   |                        |                      |
   |-------ASP Active------>|                      |
   |<------ASP Active Ack---|                      |
   |                        |                      |
   |----------------NTFY(Alt ASP-Act)------------> |
   |                        |                      | 
   |<-----ASP Inactive------|                      |
   |----ASP Inactive Ack--->|                      |
   |                        |                      |
   |----NTFY(AS-PENDING)--->|                      |
   |----------------NTFY(AS-PENDING)-------------->|
   |                        |                      |
   |<----NTFY(AS-PENDING)---| <== Is this correct? |  
   |                        |                      |
  ...                      ...                    ...
  ...                      ...                    ...
  ...                      ...                    ...

Thank you all.

______________________________________________ 
Renovamos el Correo Yahoo! 
Nuevos servicios, más seguridad 
http://correo.yahoo.es

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 7 Nov 2005 10:09:12 -0500

David,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of David Santos
> Sent: Monday, November 07, 2005 10:06 AM
> To: [email-masked]
> Subject: [Sigtran] M3UA - AS-PENDING with IPSP-IPSP
>
>
[TOLGA]I wouldn't use a very strong language like "correct/incorrect"
considering the advisory nature of NTFYs but for the scenario you described,
it does not make sense to me IPSP2 to send NTFY(AS-PENDING), because it was
IPSP2 which has issued the ASPIAC -probably due to an operator activity-.
OTOH, sending it wouldn't be wrong either, it probably would trigger ASPAC
to be sent from IPSP1 to IPSP2 and IPSP2 wouldn't reply back ASPAC-ACK -it
probably would send ERR(ManagementBlocking)-