Subject: RE: [Sigtran] M3UA: 1IPSP - multiple IPSPs traffic flow

From: "Prasad, Shashank S (Shashank)" <[email-masked]>
Date: Mon, 7 Nov 2005 15:26:07 +0530

Tolga,
I picked up an old discussion thread that I had with u.

What specifically did u mean, when u said - implementation dependent ?
Did u mean local configuration ?

And what did u mean by Traffic Type ?
Did u mean that IPSP1 can send ASPAC to the 2 IPSPs with Traffic Type as
Loadshared ?
If YES, then this would really not help because IPSP2 and IPSP3 (illustrated
below) are different entities by themselves.

shashank

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Tolga Asveren
Sent: Friday, November 04, 2005 8:51 PM
To: [email-masked]
Subject: RE: [Sigtran] M3UA: 1IPSP - multiple IPSPs traffic flow

This is implementation/traffic type dependent and is not something
standardized by M3UA.

> -----Original Message-----
> From: Prasad, Shashank S (Shashank) [mailto:[email-masked]]
> Sent: Friday, November 04, 2005 10:28 AM
> To: 'Tolga Asveren'; [email-masked]
> Subject: RE: [Sigtran] M3UA: 1IPSP - multiple IPSPs traffic flow
>
>
> Thanx Tolga. U are right in understanding my question.
>
> Followup Question:
> Since IPSP2 and IPSP3 are serving the same AS, what would determine at
> NodeB, if the traffic to IPSP1 is
> to be sent via IPSP2 or IPSP3 ?
>
>
> shashank
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Tolga Asveren
> Sent: Friday, November 04, 2005 8:13 PM
> To: [email-masked]
> Subject: RE: [Sigtran] M3UA: 1IPSP - multiple IPSPs traffic flow
>
>
> Shashank,
>
> As far as I understand your question:
>
> You have IPSP1, IPSP2, IPSP3. You have one RK. IPSP sends ASPAC
> for this RK
> to IPSP2 and IPSP3. IPSP2 and IPSP3 are working in loadsharing
> mode. You are
> wondering whether IPSP1 will receive traffic from both IPSP2 and IPSP3.
>
> Yes, it can, but I wouldn't call it traffic being loadshared to
> IPSP1. IPSP2
> and IPSP3 are not the same entities. OTOH it makes sense to speak of
> loadharing traffic from IPSP1 to IPSP2 and IPSP3 because traffic from a
> single source is distrubuted to multiple peers.
>
>    Tolga
>
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On
> > Behalf Of Prasad, Shashank S (Shashank)
> > Sent: Friday, November 04, 2005 9:48 AM
> > To: [email-masked]'
> > Subject: [Sigtran] M3UA: 1IPSP - multiple IPSPs traffic flow
> >
> >
> > Hi,
> > I had a specific question related to a specific scenario explained below
> > (Single Exchange scenario)
> >
> > NodeA supports 1 PS with 1 IPSP
> > NodeB supports 1 PS with 2 IPSPs in Loadshared mode.
> >
> >
> > There are two associations between NodeA and NodeB.
> > The first association is between IPSP1 (NodeA) and IPSP2 (NodeB).
> > The second association is between IPSP1 (NodeA) and IPSP3 (NodeB).
> >
> > The IPSP2 and IPSP3, which are serving loadshared for the PS2 on NodeB,
> > send an ASP Up to IPSP1 serving for PS1 on NodeA. Which means
> > that IPSP2 and
> > IPSP3,
> > serving a loadshared PS2, are essentially telling NodeA to
> > loadshare all the
> > traffic
> > for PS2, between IPSP2 and IPSP3.
> >
> > The above concepts are also illustrated below....(I have purposefully
> > avoided AS-ACTIVE notification)
> >
> >
> >
> >          NodeA                   <------------NodeB------------>
> >
> >          PS1-IPSP1               PS2-IPSP2                 PS2-IPSP3
> >           |                        |                          |
> >           |<-----ASP Up------------|                          |
> >           |-------ASP Up Ack------>| (Assoc #1)               |
> >           |                        |                          |
> >           |                        |                          |
> >           |<--------------------ASP Up------------------------|
> (Assoc #2)
> >           |----------------------------ASP Up Ack------------>|
> >           |                        |                          |
> >           |                        |                          |
> >           |                        |                          |
> >           |<--ASP Active(Ldshr)----|                          |
> >           |------ASP Active Ack--->|                          |
> >           |                        |                          |
> >           |                        |                          |
> >           |                        |                          |
> >           |<--------------------ASP Active(Ldshr)-------------|
> >           |----------------------------ASP Up Ack------------>|
> >           |                        |                          |
> >           |                        |                          |
> >           |---NOTIFY(AS-ACTIVE)--->|                          |
> >           |--------------------------NOTIFY(AS-ACTIVE)------->|
> >           |                        |                          |
> >
> >
> >
> > Questions:
> > Assuming a single exchange scenario, would the traffic towards
> > PS1 on NodeA,
> >
> > be also loadshared across 2 associations ?
> >
> > I thought it would and hence another follow-up question:
> > It looks like a loadshared peer (NodeB in our case) with
> multiple IPSPs,
> > is putting a constraint on the NodeA, to ALSO be ready to
> receive data on
> > multiple associations and possibly loadshared. Is this a fair
> > understanding
> > ?
> >
> >
> > shashank
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> >
>
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
>

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 7 Nov 2005 09:07:24 -0500

Shashank,

> Sent: Monday, November 07, 2005 4:56 AM
> To: [email-masked]
> Cc: 'Tolga Asveren'
[TOLGA]Not really. In your example, it was the M3UA-user which was
performing loadsharing, i.e. deciding to use IPSP2 or IPSP3. So, loadsharing
will be done based on an implementation dependent mechanism in M3UA-User, it
has nothhing to do with M3UA itself.
> below) are different entities by themselves.
[TOLGA]I was referring to type of traffic, e.g. SCCP class1, 800-number
lookup query etc.. The characteristics of traffic type would determine the
implementation dependent message routing mechanims in M3UA-User.