Subject: RE: [Sigtran] SE-IPSP definition

From: "Holland, Peter Michael (Peter)" <[email-masked]>
Date: Thu, 10 Nov 2005 09:50:12 -0000

Brian,
....

> > 
> > Reading this thread the problem I see with SE procedures was
> > identified in a mail where Brian said:
> > >If you want both IPSPs to each have an AS an traffic mode, 
> use DE instead
> > of SE.
> > Thus I understand there are situations where SE mode cannot be
> > used. This is not clear in RFC.
> 
> No, there are not situations where SE mode cannot be used.  What I was
> saying was that if one pedantically requies that both peers have and
> exchange a traffic mode (which they don't need in the first 
> place) that
> one should use the DE mode.
> 
> SE can work quite fine in all situations with one side not 
> having an ASP
> traffic mode.  No change is required.
> 

So you agree that it does not work so well when both ASs have a redundant 
architecture - loadshare or override?
I don't understand why you refer to this as a pedantic requirement - it is
an architectural/implementation robustness requirement in some situations.

Pete

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 10 Nov 2005 03:22:51 -0700

Peter,

Holland, Peter Michael (Peter) wrote:            (Thu, 10 Nov 2005 09:50:12)

--X--snip--X--
> an architectural/implementation robustness requirement in some situations.
--X--snip--X--

It is pedantic because an IPSP does not need an ASP Traffic Mode to be
redundant.  When acting like an SGP, the peer IPSP can distribute
traffic in accordance with the way that an ASP distributes messages to
the SGP that make up an SG.  The SE-IPSP acting in SGP mode does not
require an "ASP Traffic Mode".

Traffic Mode (the parameter) is an ASP concept.  Is is only useful to an
SE-IPSP in so much as the SE-IPSP is behaving like an ASP.  In SE mode,
it was never intended that both sides behave like an ASP at the same
time.  That is DE mode.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 10 Nov 2005 07:54:04 -0500

Please see below for comments.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, November 10, 2005 5:23 AM
> To: Holland, Peter Michael (Peter)
> Cc: 'Tolga Asveren'; [email-masked]
> Subject: Re: [Sigtran] SE-IPSP definition
>
>
> Peter,
>
[TOLGA]SE-IPSP is an IPSP not an ASP not an SGP. For certain message
transactions, it follows the same message sequence but conceptually it is
not equal to ASP not to SGP. So, I 100% agree with Peter, traffic mode is
necessary bothways for SE-IPSP case. Traffic mode is an attribute associated
with application logic and for IPSP case, there is application logic present
at both ends.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 10 Nov 2005 06:22:58 -0700

Tolga,

Tolga Asveren wrote:                                                                 (Thu, 10 Nov 2005 07:54:04)
> with application logic and for IPSP case, there is application logic present

It is not even necessary that there be application logic present at the IPSP.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/