Subject: [Sigtran] Ordering within RK parameter of M3UA

From: "Sergey Mikhailov" <[email-masked]>
Date: Mon, 16 Jan 2006 12:36:52 +0300

Hi,

It seems quite open to interpretation (from 3.2 and 3.6.1 of 3332bis05), whether Destination Point Code, Service Indicators and Originating Point Code List parameters (which may be repeated as a grouping) must follow in exactly this order or not.

>From 3.6.1:

      Note: The Destination Point Code, Service Indicators, and
      Originating Point Code List parameters MAY be repeated as a
      grouping within the Routing Key parameter, in the structure shown
      above.

It think that there is now requirement to their ordering inside a grouping, but have to admit that this is just my interprertation.
Any opinions?

Best Regards,
Sergey Mikhailov.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 16 Jan 2006 03:06:02 -0700

Sergey,

Read Section 3.2:

  ...

  Where more than one parameter is included in a message, the
  parameters may be in any order, except where explicitly mandated.  A
  receiver SHOULD accept the parameters in any order.
  ...

--brian

On Mon, 16 Jan 2006, Sergey Mikhailov wrote:

> 
>    Hi,
> 
> 
> 
>    It   seems quite   open  to  interpretation (from  3.2  and  3.6.1  of
>    3332bis05),  whether  Destination  Point  Code, Service Indicators and
>    Originating  Point  Code  List  parameters (which may be repeated as a
>    grouping) must follow in exactly this order or not.
> 
> 
> 
>    From 3.6.1:
> 
> 
> 
>    It  think  that  there  is  now requirement to their ordering inside a
>    grouping, but have to admit that this is just my interprertation.
> 
>    Any opinions?
> 
> 
> 
> 
> 
>    Best Regards,
> 
>    Sergey Mikhailov.

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: "Sergey Mikhailov" <[email-masked]>
Date: Mon, 16 Jan 2006 13:24:29 +0300

Brian,

thank you for your reply.

Do you mean that the phrase "MAY be repeated as a grouping within the
Routing Key parameter, in the structure shown above" (in that Note from
3.6.1) explicitly mandates (like mentioned in 3.2) the ordering? Or it has
just illustrative meaning?

Regards,
Sergey Mikhailov.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 16 Jan 2006 04:20:35 -0700

Sergey,

Logically, the repeated structure only needs to start with Destination
Point Code (to identify a new group of parameters).  The order of
the parameters other than DPC within the repeated structure is
unimportant.  Likely, Local-RK-Identifier and Traffic Mode should come
first, but they don't have to.

So, one would expect to find Local-RK-Identifier somewhere within the list
of parameters, and, optionally, a Traffic Mode somewhere within the list of
parameters, an at least one Destination Point Code somewhere within the list
of parameters.  The optional parameters associated with a given DPC would
occur between the DPC and either the next DPC or the end of the Routing Key.

Is this not obvious to you?

--brian

---

From: "Sergey Mikhailov" <[email-masked]>
Date: Mon, 16 Jan 2006 14:51:35 +0300

Brian,
thank you for this explanation.

If we accept this limitation (DPC always starts the repeated structure), 
then the following Routing Key parameter, containing parameters in the 
specified order, is incorrect (and receiver must reply with ERROR message), 
even though it can be read unambiguously:

Local-RK-Identifier
Routing Context
Traffic Mode Type
DPC
OPC List
OPC List
DPC

Is it obvious for receiver to consider this message incorrect rather than to 
accept it (since the second OPC List is clearly related to the second DPC)?
To say generally, is it incorrect in this particular situation for a 
receiver to judge on the message correctness by ability to read it 
unambiguously? (Because it seems there is no explicitly mandated ordering 
specified regarding DPC, is there?)

Thank you very much,
Sergey Mikhailov.

----- Original Message ----- 
From: "Brian F. G. Bidulock" <[email-masked]>
To: "Sergey Mikhailov" <[email-masked]>
Cc: "SIGTRAN" <[email-masked]>
Sent: Monday, January 16, 2006 2:20 PM
Subject: Re: [Sigtran] Ordering within RK parameter of M3UA

>> >>           grouping  within  the  Routing  Key parameter, in the 
>> >> structure
>> >>    shown
>> >>          above.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 16 Jan 2006 06:01:13 -0700

Sergey,

You are welcome to accept it.

--brian