Subject: RE: [Sigtran] (M2PA) M2PA Implementor's Guide Kickoff

From: "Craig, Jeffrey" <[email-masked]>
Date: Thu, 12 Jan 2006 12:41:49 -0600

Hello Brian,

Both Figures 15 and 16 are defective in that they fail
to accurately depict the L3L2 and L2L3 primitives that
are essential to the procedures being described.

The processor outage section is defective in that it
fails to adequately address the aligned not ready state.
It also fails to adequately address the ambiguity in
treatment of received LSR based upon stream.

I am working on detailed problem descriptions and 
proposed new text and new figures that addresses 
my concerns. Stay tuned.

As far as you not seeing any defects in the document,
I am not surprised, since you were an author. I think
the RFC can better serve its audience by being clear
to everyone, not just the authors.

Regards,

Jeff 

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Wednesday, January 11, 2006 4:53 PM
To: Craig, Jeffrey
Cc: [email-masked]
Subject: Re: [Sigtran] (M2PA) M2PA Implementor's Guide Kickoff

Jeffrey,

Perhaps you could start by formulating at least a problem statement for
each item that you think presents a problem.  It might also be an idea
to consult the authors of the RFC.

Maybe start with PO and Figure 16.  What problem is there with the text
or the example?  I don't see any problem.

Also, I don't believe that there are any outstanding problems with the
document at all.

--brian

Craig, Jeffrey wrote:                   (Wed, 11 Jan 2006 15:32:17)
> Hello Brian,
> 
> > and should not be the editor's personal pet peeve list for the
> specification
> 
> Personal pet peeves? Many of the defects I listed I obtained straight 
> from other's posts on the SIGTRAN listserv. I posted them as a 
> proposal to kickoff discussion.
> 
> I look forward to other's comments. If the community agrees to your 
> strict definition of 'defect' and that there are no M2PA 'defects', 
> then there won't be a M2PA IG. If the only 'defect' is the processor 
> outage text, then that is what the M2PA IG will address and nothing 
> else.
> 
> Regards,
> 
> Jeff

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 12 Jan 2006 11:57:29 -0700

Craig,

I hope your descriptions are less vague than they are
in this note.  I look forward to commenting on your
draft.  Perhaps you should call it draft-craig-m2pa-ig
because it is already far from consensus.  The RFC _is_
the current consensus.

--brian

Craig, Jeffrey wrote:                                               (Thu, 12 Jan 2006 12:41:49)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/