Subject: [Sigtran] no of segments limit on CODT

From: [email-masked]
Date: Wed, 4 Jan 2006 10:47:39 +0530

Hi, 

While segmenting CLDT message there is a limit on number of segments a
message can be broken into  (A maximum of 16 segments

can be sent for one N-UNITDATA request primitive) . 

Is the same limit applicable for CODT message as well, 

Thanks, 

Rishi Srivastava

Wipro Technologies

Bangalore

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 3 Jan 2006 22:53:14 -0700

srivastava.rishi,

No.

--brian

[email-masked] wrote:                         (Wed, 04 Jan 2006 10:47:39)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Ilie Glib <[email-masked]>
Date: Thu, 5 Jan 2006 09:40:42 +0100

Hello Brian,

I guess you meant, that CODT is not segmented (at least it is not
visible to SUA, since segmentation is done by SCTP).

When interworking with SS7, there cannot be more than 16 CODT
representing one SCCP/SUA-User message (in both directions on the
SGP-ASP interface).

Regards

Ilie

--
Ilie

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 5 Jan 2006 02:00:17 -0700

Ilie,

I think that you are confusing CODT and CLDT.

There is no limits on the number of Service Interface Data Units
(SIDUs) sent by the user to represent a single Service Data Unit
(SDU) for the CODT message.  The "more bit" in the "Sequence Number"
parameter, when set in the CODT, indicates that the next SIDU (Data)
belongs to the same SDU.  ...and there is no limit.

>    Is the same limit applicable for CODT message as well,

So, the answer to your question is "No."

Or, maybe I should have said read X.213, Q.711 and then RFC 3868.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Ilie Glib <[email-masked]>
Date: Thu, 5 Jan 2006 19:41:57 +0100

Brian,

I beg your pardon. I was mixing it, indeed.

Thank you

Ilie

--
Ilie