Subject: [Sigtran] Is an xxUA SGP capable of serving multiple SGs

From: Siu Chai Tho <[email-masked]>
Date: Wed, 8 Feb 2006 04:48:19 +1300 (NZDT)

Hello SIGTRAN Community!
   
  Clould you please answer the following questions
   
  1) Is an xxUA SGP capable of serving multiple SGs?
   
  2) Is there any difference between M3UA and SUA in this respect?
   
  Thank you!
  Joe

Send instant messages to your online friends http://au.messenger.yahoo.com 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Barry Nagelberg" <[email-masked]>
Date: Tue, 7 Feb 2006 10:58:43 -0500

Joe,

1) Yes, an xUA SGP can serve multiple SGs.

2) No, there aren't any major differences between M3UA and SUA in this respect.

Barry Nagelberg
Adax, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Siu Chai Tho
Sent: Tuesday, February 07, 2006 10:48 AM
To: SIGTRAN
Subject: [Sigtran] Is an xxUA SGP capable of serving multiple SGs

Hello SIGTRAN Community!

Thank you!
Joe

---

From: Ilie Glib <[email-masked]>
Date: Tue, 7 Feb 2006 19:08:02 +0100

Hello Barry,

I cannot agree with you. Is there a statement like yours in the M3UA RFC?

If we take an ASP viewpoint. What would be your answers to the
following questions.

a) How many SGs can an ASP see behind the SGP?

b) How would you decide to what SGs a DUNA message applies, when it is
sent from an SGP serving multiple SGs?

c) SGs can allocate RC values independently, therefore you can have
clashes in RC values. Do you expect that SGPs serving multiple SGs use
different RC value spaces for different SGs?

Regards

Ilie

--
Ilie

---

From: "Barry Nagelberg" <[email-masked]>
Date: Tue, 7 Feb 2006 13:49:08 -0500

Ilie,
Please see replies inline.
Barry Nagelberg

> From: Ilie Glib [mailto:[email-masked]]
> Sent: Tuesday, February 07, 2006 1:08 PM
> To: Barry Nagelberg
> Cc: SIGTRAN
> Subject: Re: [Sigtran] Is an xxUA SGP capable of serving multiple SGs
> 
> 
> Hello Barry,
> 
[BN] - I don't know. Is there a statement prohibiting it?

> a) How many SGs can an ASP see behind the SGP?
[BN] - No limit.

> sent from an SGP serving multiple SGs?
[BN] - From the Network Appearance parameter. I expect each SG to be serving a different network.

> different RC value spaces for different SGs?
[BN] - Yes. Why not? There is no restriction against it.

---

From: Ilie Glib <[email-masked]>
Date: Tue, 7 Feb 2006 20:18:39 +0100

Barry,

I see your point.

According to your view an AS talks to one and only one SG within SGP,
that is, the AS sees (registers with) just one SG in the SGP and
cannot see more SGs served by the same SGP.

Have I got it right?

Is it a largely accepted view? I mean, are there SG products that do
that, since it does not put any additional requirements on the ASPs in
my view.

Thank you in advance

Ilie

--
Ilie

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 7 Feb 2006 14:38:30 -0500

If you interpret the situation from protocol point of view, i.e. from
procedures point of view to be honored by both ends of the communication-,
this still is a SGP being part of a single SG. Afterall, what is
asked/discussed is SG/SGP abstractions as defined by the protocol. IMHO, the
rest, e.g. how one handles internally traffic belonging to different
networks, is not part of the protocol.

>From protocol point of view, I don't see how a SGP can be part of multiple
SG. There is no way during ASPAC/ASPAC-ACK exchange for the SGP to inform
ASP about which SGs that specific SGP is part of except the SCTP endpoint
information. Similar comment will apply also when sending messages etc..

    thanks,
    tolga

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Ilie Glib
> Sent: Tuesday, February 07, 2006 2:19 PM
> To: Barry Nagelberg
> Cc: SIGTRAN
> > > > From: [email-masked]
[mailto:[email-masked]]On Behalf Of Siu Chai Tho

--
Ilie

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 7 Feb 2006 07:01:48 -0700

Ilie,

An SGP is defined as a process instance of an SG.  As such, an SGP
"belongs to" (is contained by) only one SG.  

See, for example, RFC 3868 1.2.2.

--brian

Ilie Glib wrote:                          (Tue, 07 Feb 2006 20:18:39)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Barry Nagelberg" <[email-masked]>
Date: Tue, 7 Feb 2006 15:24:47 -0500

Tolga,

There is no need for the "SGP to inform ASP about which SGs that specific SGP is part of". This is known to the craft
administrator at each end, SGP and ASP.

Let's consider the example in which a single SGP is serving 2 SGs. SG1 represents SS7 network 1 and SG2 represents
network 2.
The ASP wishes to register to receive data only for network 1, i.e. SG1. The craft administrators agree that a value of
'1' in the Network Appearance param will represent network 1.

1. When the ASP sends a REG_REQ msg, it includes the Network Appearance param, and sets it to '1'. This tells the SGP
that the ASP wishes to register to receive data for network 1, i.e. SG1.

2. The SGP approves the registration request and responds with Routing Context 1. Now the ASP and SGP have established
that all communications between them for network 1 will be indicated by routing context 1.

Barry Nagelberg
Adax, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Tolga Asveren
Sent: Tuesday, February 07, 2006 2:39 PM
To: [email-masked]
Subject: RE: [Sigtran] Is an xxUA SGP capable of serving multiple SGs

    thanks,
    tolga

--
Ilie

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 7 Feb 2006 07:30:08 -0700

Barry,

I would call that 1 SG supporting multiple networks, not an SGP
belonging to multiple SGs.

--brian

Barry Nagelberg wrote:                                               (Tue, 07 Feb 2006 15:24:47)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Barry Nagelberg" <[email-masked]>
Date: Tue, 7 Feb 2006 15:43:55 -0500

Brian,

Good point. "1 SG supporting multiple networks" is an equally valid way to express the idea.

I nevertheless contend that "multiple SGs in an SGP" is a valid concept. I find it an easy way to conceptualize the
setup that I described below, sort of a mirror image of "multiple ASs in an ASP".

Barry Nagelberg
Adax, Inc.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Tuesday, February 07, 2006 9:30 AM
To: Barry Nagelberg
Cc: [email-masked]
Subject: Re: [Sigtran] Is an xxUA SGP capable of serving multiple SGs

Barry,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 7 Feb 2006 15:43:04 -0500

I also would call this "1 SG supporting multiple networks" -IMO, NA is an
attribute of traffic rather than a SG identifier- but as long as we all have
the same understanding in terms of how the protocol is supposed to work
naming issues are less important.

   tolga

> Behalf Of Barry Nagelberg
> Sent: Tuesday, February 07, 2006 3:44 PM
> To: [email-masked]
> I nevertheless contend that "multiple SGs in an SGP" is a valid
> concept. I find it an easy way to conceptualize the
> > There is no need for the "SGP to inform ASP about which SGs
> that specific SGP is part of". This is known to the craft
> > Let's consider the example in which a single SGP is serving 2
> SGs. SG1 represents SS7 network 1 and SG2 represents
> > network 2.
> > The ASP wishes to register to receive data only for network 1,
> i.e. SG1. The craft administrators agree that a value
> of
> > 1. When the ASP sends a REG_REQ msg, it includes the Network
> Appearance param, and sets it to '1'. This tells the SGP
> > 2. The SGP approves the registration request and responds with
> Routing Context 1. Now the ASP and SGP have established

---

From: Siu Chai Tho <[email-masked]>
Date: Thu, 9 Feb 2006 08:21:24 +1300 (NZDT)

Hello SIGTRAN Community!
   
  Let me reformulate my initial question. 
   
  I am after the following case. Imagine two overlapping sets of SGPs 
  S1 = {SGP1, SGP2, SGP3}, 
  S2 = {SGP2, SGP3, SGP4}, 
  and let's assume set S1 is serving SG1, while set S2 is serving SG2.
   
  Is this situation possible?
   
  I think it would have impacts both on SG as well as ASP implementations. 
  Is it so?
   
  Thank you,
  Joe

Barry Nagelberg <[email-masked]> wrote:
  Brian,

Barry Nagelberg
Adax, Inc.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Tuesday, February 07, 2006 9:30 AM
To: Barry Nagelberg
Cc: [email-masked]
Subject: Re: [Sigtran] Is an xxUA SGP capable of serving multiple SGs

Barry,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 8 Feb 2006 12:38:09 -0700

Siu,

An SG is defined as "containing" an SGP.  Therefore, the relation
you describe does not make sense.  For example, SG2 cannot be both
"contained by" SG1 as well as "contained by" SG2.

--brian

Siu Chai Tho wrote:                              (Thu, 09 Feb 2006 08:21:24)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/