Subject: RE: [Sigtran] M3UA notify message

From: "Haresign Lincoln" <[email-masked]>
Date: Thu, 23 Feb 2006 10:19:46 -0500

Nitin,

For the first scenario, I would think that the ASP is either:

1) Configured at the SG (perhaps with IP addresses)
2) Is sending an ASPID to the SG. 

In this way, the SG can see that the ASUP/ACPAC are coming from the same
ASP as the ASPID MUST be unique within the AS.  Therefore, the SG
properly manages the state of the AS and ASP.

For the second scenario, I would say the data message should be dropped
and an error return since the ASP/SGP2 state machine has not been
properly completed.

For scenario three, once one ASP is active to one SGP, the AS is active.

Regards,
Lincoln

________________________________

From: nitin [mailto:[email-masked]] 
Sent: Thursday, February 23, 2006 9:40 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA notify message

I am explaining some scenarios :-
 
1. Consider SG consisting of SGP1 and SGP2.
     Suppose an AS contain one ASP and the traffic mode of AS is
override. 
     If we look in terms of SGP then this override mode
     is of no use, but if we look in terms of SG  and this ASP is making
associations with 
     two SGP then this is of much significance. Actually for SGP , ASP
is identified by 
     the sctp association . For even if there is only one ASP in AS but
for SGP's they
     don't know this ASP as single ASP.
 
        Please take AS as inactive initially on both SGP's.
 
     ASP               SGP1              SGP2       SG
      |     aspAc       |                 |          |
      |---------------->|                 |          | ( please note
here that i have drawn  notify from SG, 
      |<----------------|                 |          |   just to
highlight that state of AS is maintained at SG,
      |  asp ac ack     |                 |          |             so
logically this notify is sent with respect to SG)
      |<---------------------------------------------|
      |       notify AS active            |          |
      |                 |                 |          |
      |---aspAc-------------------------->|          |
      |       aspac ack |                 |          |
      |<----------------------------------|          |
      |         notify Alt. Asp Ac.       |          |
      |<---------------------------------------------|
      |                 |                 |          |
      |                 |                 |          |
 
 Now sicne  when we have configured AS at the SG, we have configured
that AS has only one SGP
 in override mode. However this override mode doesn't makes sense with
one ASP in AS.
 
 But here what is happening that SGP's doesnot know , that it is the
same ASP which is doing
 active with both SGP's. So when ASP  does active with SGP1 then AS
becomes active. Now when
 ASP does active with SGP2 this is new ASP for SGP2. So what should be
done in this case.Should 
 Alternate ASP active notify be sent in this case to same ASP .
 
2. Now consider another case. 
 
   In this scenario , ASP1 and ASP2 are both part of AS and SGP1 and
SGP2 are both part of SG1.
   In this case assume that ASP1 and ASP2 are both inactive at their
respective SGP's.
   Now my question is little bit different in this case as explained
below:-
 
     ASP1                 ASP2                SGP1           SGP2 
      |     aspAc           |                   |              |
      |---------------------------------------->|              |

      |<----------------------------------------|              |        
      |  asp ac ack         |                   |              |

      |<--------------------------------|                        |
      |       notify AS active                   |
|
      |                          |                        |
|
      |                                    data        |
|
                                |---------------------------------->
      |                         |                        |
|
      |                          |                        |
      
      |                      |                       |
      |
|
      |                          |                        |
|
      |                          |                        |
|

Should this data message be dropped at SG or should it be allowed to SS7
side , Since AS is active at SG
 but ASP2 is not active on SGP2.
 
3. Now here is the 3rd scenario , this is related to n+k AS.
     
In this case , configuration is AS consisting of ASP1 and ASP2.
SG consisting of SGP1 and SGP2. 
Obviously the traffic mode is loadshare.
Now only ASP1 is doing ASP active on SGP1 and SGP2.
ASP2 has not done any m3ua procedures with neither SGP1 , nor SGP2.
 
ASP1                 ASP2                SGP1           SGP2 
      |     aspAc           |                        |
|
      |--------------------------------->|                      |

      |<---------------------------------|                      |

      |  asp ac ack       |                        |
|             
      |                          |                        |
      |                          |                        |
      |                          |                        |
|
      |----------asp Ac.---------------------------------------->|
                         
      <-----------ASP act . ack--------------------------------------- |
      |                          |                        |
      
      |<----------------------------------------------------|
      |
|
      |                          |                        |
|
      |                          |                        |
|
 
Now since ASP1 has done active on both SGP1 and SGP2 , it is active on
two SGP's.
So with respect to SG two SGP's are active. Should in this case AS be
active or not.
 
thanks
nitin
 
----- Original Message ----- 
From: "Brian F. G. Bidulock" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, February 23, 2006 11:34 AM
Subject: Re: [Sigtran] M3UA notify message

> Prabind,
> 
> You are correct, there is a case where the ASP state is shared across
> the SGPs making up an SG: in the Override traffic mode AS it is
> necessary to share which ASP is "Active" and which is "Standby" as
only
> one ASP can be Active for the AS.
> 
> This is also a case where state transitions directly associated with
> ASPTM/ASPSM message procedures must be considered on an SG-wide basis,
> contrary to Tolga's previous statements on this thread.
> 
> It is possible, but perhaps less important to interoperability, that
an
> SG could coordinate the ASP state for ASPs in a Loadshare or Broadcast
> AS.  That is, when loadsharing, the selection algorithm at an SGP
could
> consider the availability of ASPs to other SGPs to more equally
> distribute traffic.  For Broadcast mode AS, consideration of ASP state
> across the SGP could provide a more optimal broadcast of traffic (i.e.
> without sending multiple messages to or missing completely an ASP).
> 
> For the case of SSNM, it is possible (but not required) for the SG to
> avoid sending duplicate SSNM messagese to any given ASP.  By
considering
> the ASP state on an SG-wide basis, it is possible to ensure that only
> one SSNM message is sent to an ASP (via only one SGP).
> 
> The override and SSNM cases were given consideration in the original
> thread that led to the wording 1.4.1.  The others were not so much.
> 
> Therefore, I agree that the statement in 1.4.1 should not be ammended.
> 
> --brian
> 
> 
> [email-masked] wrote:                (Thu, 23 Feb 2006
09:50:04)
> > 
> > I am still concerned about this statement from Tolga:
> > 
> > " In any case, it is good that there is finally consensus regarding
that
> > ASPSM/ASPTM procedures and associated state machines being
independent
> > on
> > each SGP."
> > 
> > If multiple SGPs are serving a single AS, then shouldn't the ASP
states
> > also be shared across the related SGPs?
> > Else if I am wrong then the following statement in section 1.4.1
should
> > be amended to share the AS states only.
> > " Where an SG contains more than one SGP, the MTP3 routeset, SPMC
and
> >    remote AS/ASP states of each SGP SHOULD be coordinated across all
the
> >    SGPs."
> > 
> > Tolga, further considering the sahring of ASP states then, in the
case
> > of the interoperability issue (as you depicted), the rfc says that
if an
> > ASP is already inactive the ASP-UP message would still be respnded
by an
> > ack.
> > 
> > I think the things become simpler if we consider sharing of ASP
states
> > of a particular AS across all SGPs serving that AS.
> >  
> > 
> > Regards,
> >  
> > Prabind
> >  
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
> 
> 
> 
> -- 
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.1.375 / Virus Database: 268.0.0/267 - Release Date:
2/22/2006

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 23 Feb 2006 10:28:27 -0500

If there is consensus about using global-AS state for traffic mode related
procedures, we better have some explanation about it. IMHO, the way it is
stated right now in the RFC/IG does hardly lead to that interpretation -I am
speaking of section 4.3 -.

   Thanks,
   Tolga

> -----Original Message-----
> From: Haresign Lincoln [mailto:[email-masked]]
> Sent: Thursday, February 23, 2006 10:20 AM
> To: nitin; [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: [Sigtran] M3UA notify message
>
>
> Nitin,
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 23 Feb 2006 12:01:00 -0700

Tolga,

As Greg noted 5 years ago, global AS state is not necessary when:
there is only one SGP in the SG; or, only one SGP in the SG serves
any AS.  That is why changes were not made to section 4.3.
Nevertheless, section 1.4.1 is clearly stated.  I still think that
the original text is adequate.  What the document needs is several
examples that include multiple SGPs in an SG serving an AS, say,
one for each traffic mode.

--brian

Tolga Asveren wrote:                                                 (Thu, 23 Feb 2006 10:28:27)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 23 Feb 2006 12:34:53 -0700

Nitin,

Haresign Lincoln wrote:                                           (Thu, 23 Feb 2006 10:19:46)
> properly manages the state of the AS and ASP.

I agree with Lincoln here.  This scenario was already discussed on the list.
The SG in scenario 1 is plain behaving incorrectly.

> and an error return since the ASP/SGP2 state machine has not been

The spec says that an ASP should not send data from an AS before it has
received ASP Active Ack for the AS or it will risk message loss.  The
ASP is risking message loss because it has not done so.  The SG can drop
or process the message at its discretion.

> For scenario three, once one ASP is active to one SGP, the AS is active.

The third case depends on the value of n and k, which you did not provide.
If n is 1 and k is 1 then the AS is active.

In general I don't think that these flows (except perhaps the last one)
illustrate AS/ASP state coordination, but, instead, other provisions
in the RFC (such as ASP Id).

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 23 Feb 2006 14:34:22 -0500

Brian,

Yes, obviously there is no issue for the single SGP case.

I still think relying on the the private AS state of SGP for the traffic
mode operation is a more elegant solution. It allows the ASPTM/ASPSM logic
of SGPs run independently in a simplex way and requires some coordination
only to generate SPMC, which is a MTP3 construct anyhow. I really interprete
Greg's e-mail a bit different than you as well. To me, it seems that global
AS-state issue was more to accomodate my complain about NTFYs, and to be
honest I think he made the wrong decision. I think it is a better idea to
keep ASP/SGP interface totally clean, where the concept of SG is not visible
unless it is really required, i.e. for SSNM related issues, where SG is a
single entity. This basically means to run ASPSM/ASPTM procedures
independently on each SGP. Afterall, the concept of AS is a M3UA construct,
and there we have the freedom to decide for its scope.

I believe passages similar to below are describing use of the indpendent AS
state for traffic mode related procedures:  -from 4.3.4.3 ASP Active
Procedures-
   In the case of an Override mode AS, reception of an ASP Active
   message at an SGP causes the (re)direction of all traffic for the AS
   to the ASP that sent the ASP Active message.  Any previously active
   ASP in the AS is now considered to be in state ASP-INACTIVE and
   SHOULD no longer receive traffic from the SGP within the AS.  The SGP
   or IPSP then MUST send a Notify message ("Alternate ASP_Active") to
   the previously active ASP in the AS, and SHOULD stop traffic to/from
   that ASP.  The ASP receiving this Notify MUST consider itself now in
   the ASP-INACTIVE state, if it is not already aware of this via
   inter-ASP communication with the Overriding ASP.

Now, before we start exchanging thousands of e-mails, let me tell that I
don't think any of the choices is "wrong". Both of them will work as long as
both ASP and SGP have the same interpretation. Obviously the first priority
is to document the consensus clearly in the RFC/IG. I don't think the text
is clear enough. My and other peoples confusion is a good evidence for that.
My personal opinion is that there is contradicting stataments in the RFC/IG
and I don't necessarily aggree with you that everything is put there
actually with a unified view of how things are supposed to work.

I think the two options are clearly explained in this thread in terms of how
they are supposed to work. My personal choice is to have all ASPSM/ASPTM
independent on SGPs, without using any global AS state for that purpose.
AFAICS, you are in the opinion that using global-AS state on SGPs for
certain ASPTM procedures is a better idea. I think Barry and Lincoln think
similar to you(?). For other people, I don't have a clear guesstimate. I
also would think that it would be useful to have opinions from more people.
In any case, let's decide what needs to be done and do it.

    Thanks,
    Tolga

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, February 23, 2006 2:01 PM
> To: Tolga Asveren
> Cc: [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 23 Feb 2006 13:32:19 -0700

Tolga,

Tolga Asveren wrote:                                                 (Thu, 23 Feb 2006 14:34:22)
> and there we have the freedom to decide for its scope.

Then there would be no difference (other then SSNM) between an SG and an
SGP.  We agreed years ago that there was a difference between an SG and
an SGP.  An SG coordinates SPMC and AS/ASP state across all the SGP
serving an AS.

>    inter-ASP communication with the Overriding ASP.

No, no, no.  See Ken's note on override mode from the old mail thread.
Ken describes the following scenario (his is more complicated):

    ASP1/AS1         ASP2/AS1        SGP1/SG1         SGP2/SG1
       |                 |               |                |
       |----ASPUP----------------------->|                |
       |<---ASPUP Ack--------------------|                |
       |<---NTFY(AS Inactive)(AS1)-------|                |
       |<---NTFY(Insuff ASPs)(AS1)-------|                |
       |                 |               |                |
       |                 |----ASPUP---------------------->|
       |                 |<---ASPUP Ack-------------------|
       |                 |<---NTFY(AS Inactive)(AS1)------|
       |                 |<---NTFY(Insuff ASPs)(AS1)------|
       |                 |               |                |
       |----ASPAC-(AS1)----------------->|                |
       |<---ASPAC Ack-(AS1)--------------|                |
       |<---NTFY(AS Active)(AS1)---------|                |
       |<---NTFY(Alt ASP Act)(AS1)(ASP1)-|                |
       |                 |<--NTFY(AS Active)(AS1)---------|
       |                 |<--NFTY(Alt ASP Act)(AS1)(ASP1)-|
       |                 |               |                |
       |<---DATA-------------------------|                |
       |<---DATA-------------------------|<--DATA---------|
       |<---DATA-------------------------|                |
       |<---DATA-------------------------|<--DATA---------|
       |                 |               |                |
       |                 |---ASPAC (AS1)----------------->|
       |                 |<--ASPAC Ack (AS1)--------------|
       |                 |<--NTFY(Alt ASP Act)(AS1)(ASP2)-|
       |<---NTFY(Alt ASP Act)(AS1)(ASP2)-|                |
       |                 |               |                |
       |                 |               |---DATA--------\|
       |                 |<--DATA-------------------------|
       |                 |               |---DATA--------\|
       |                 |<--DATA-------------------------|
       |                 |               |---DATA--------\|
       |                 |<--DATA-------------------------|
       |                 |               |                |
       |                 |               |                |

Above, SGP2 follows the text in 4.3.4.3 to the letter; however, AS/ASP
state is coordinated across the SGPs serving the AS in accordance with
1.4.1.

When SGP2 receives the ASP Active it redirects traffic to ASP2.  Note
that it must also redirect traffic from SGP1.  ASP1 is now considered
ASP-INACTIVE in the AS.  This is also true on SGP1.

Ken mentioned that the way to resolve problems with override mode was
to act only on the last ASP Active received by the SG.  Which means
that the procedures are executed by the SGP with knowledge of the
overall (SG-wide) state of an ASP within an AS.

> actually with a unified view of how things are supposed to work.

There are not contradicting statements.

> independent on SGPs, without using any global AS state for that purpose.

Cannot work.  And is contrary to the existing RFC and the design
approach agreed by concensus leading to wide ranging changes between
M3UA Draft 7 and M3UA Draft 8.

> In any case, let's decide what needs to be done and do it.

Nothing needs to be done, except a few examples.  If you have another
proposal, please, craft some text and propose it.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "nitin" <[email-masked]>
Date: Fri, 24 Feb 2006 12:24:44 +0530

hi ,
For the 3rd case , i had not mentioned n , it is 2.
So if it is 2, then what will be the case.
----- Original Message ----- 
From: "Haresign Lincoln" <[email-masked]>
To: "nitin" <[email-masked]>; <[email-masked]>;
<[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, February 23, 2006 8:49 PM
Subject: RE: [Sigtran] M3UA notify message

Nitin,

Regards,
Lincoln

     ASP               SGP1              SGP2       SG
      |     aspAc       |                 |          |

     ASP1                 ASP2                SGP1           SGP2
      |     aspAc           |                   |              |

      |                      |                       |
      |
|
      |                          |                        |
|
      |                          |                        |
|

ASP1                 ASP2                SGP1           SGP2
      |     aspAc           |                        |
|

      |  asp ac ack       |                        |
|
      |                          |                        |
      |                          |                        |
      |                          |                        |
|

thanks
nitin

----- Original Message ----- 
From: "Brian F. G. Bidulock" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, February 23, 2006 11:34 AM
Subject: Re: [Sigtran] M3UA notify message

only
an
could
considering
09:50:04)
that
independent
states
should
and
the
case
if an
by an
states
2/22/2006

-- 
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.375 / Virus Database: 268.0.0/268 - Release Date: 2/23/2006

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 24 Feb 2006 00:21:52 -0700

nitin,

nitin wrote:                             (Fri, 24 Feb 2006 12:24:44)
> So if it is 2, then what will be the case.

If the SG is configured to wait for 'n' before activating the
AS, with n=2, the AS is inactive.  This is because only 1 ASP
(as identified by configuration or ASP Id) is active for the AS.

This, like case 1, only illustrates SGs with ASP identification
problems, and not AS/ASP state sharing.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 24 Feb 2006 08:59:14 -0500

Brian,

> Sent: Thursday, February 23, 2006 3:32 PM
> To: Tolga Asveren
> Cc: [email-masked]
[TOLGA]Concepts/Requirements shouldn't be created just for the sake of
creating them.There should be a reason for them. For example for single SPMC
view there is a good reason: It is a requirement put by SS7 specifications,
we can't change it, so we need to comply with it.
> overall (SG-wide) state of an ASP within an AS.
[TOLGA]I don't recall the details of the problem (IETF mail-archive starts
somewhere in 2002), so if you just tell about the problem statement, it
could be good to refresh the memory.
When I think about the scenario, I guess it could be something like that:
ASP2 wants to override ASP1. If no global-AS view is used, with the
ASPAC/ASPAC-ACK exchange with SGP1, SGP1 will start using ASP2 but SGP2 will
wait till the ASPAC/ASPAC-ACK exchange is performed with it as well.
I don't know whether this will be practically a big issue considering that
ASP2 can send ASPAC to SGP1 and SGP2 simultaneously -yes, they still won't
arrive simultaneously at SGP1 and SGP2-.
If one considers the scenarios where an ASP overrides another one, e.g.
ASP1 will be put down for maintainenece-, similar timing issues will arise
with multiple SGs as well. Obviosly, we can't say that ASPs using multiple
SGs, shouldn't be replaced. Based on that, I would expect ASPs to be clever
enough to deal with such situations.
> There are not contradicting statements.
[TOLGA]Let me try to summarize what I find as weak explanation in the
specification:
>From the passage I quoted before:
The SGP
   that ASP.

I would expect here "SG SHOULD stop traffic to/from that ASP" not "The SGP".
Similar not-so-clear statements are all over 4.3

Actually if we are so fond of using that global-AS state for traffic mode
related ASPTM procedures, why don't we use it for all ASPTM? Why is ASPAC
sent both to SGP1 and SGP2 from ASP1? SGP2 will identify ASP1 with
ASPUP/ASPUP-ACK exchange and can know from the global-AS view that it is
already in ACTIVE state. -Just to be clear, I am not proposing this ;-) -
> M3UA Draft 7 and M3UA Draft 8.
[TOLGA]Just out of curiosity, why can't it work, if both ASP and SGP have
the same interpretation?
> proposal, please, craft some text and propose it.
[TOLGA]Examples are important too. For the unnecessity of the text changes,
I will remind you on that, when this issue comes up again ;-)

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 24 Feb 2006 12:51:31 -0700

Tolga,

Tolga Asveren wrote:                                                 (Fri, 24 Feb 2006 08:59:14)

--x--snip--x--
> Similar not-so-clear statements are all over 4.3

An SG does not route traffic: and SG is a logical grouping of SGP.
SGP(s) route traffic.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 24 Feb 2006 14:53:30 -0500

Brian,

> Sent: Friday, February 24, 2006 2:52 PM
> To: Tolga Asveren
> Cc: [email-masked]
[TOLGA]To be constructive, let me suggest this:
"SGPs which are part of the same SG"

BTW, do you have any opinion on why not all ASPTM is not using the global-AS
view, e.g. why an ASP should send ASPAC to all SGPs?

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 24 Feb 2006 13:23:07 -0700

Tolga,

Tolga Asveren wrote:                                                 (Fri, 24 Feb 2006 14:53:30)
> "SGPs which are part of the same SG"

Sure, edit that phrase into all the statements in section 4.3, post the
resulting text to this list as a proposal, and let's see how it reads. ;)

> view, e.g. why an ASP should send ASPAC to all SGPs?

Because (except in the case of override) ASPAC starts traffic between an
ASP and an SGP on a specific association.  Do you not believe that it is
a good thing to be able to control traffic on an association?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 24 Feb 2006 15:32:59 -0500

Brian,

> Sent: Friday, February 24, 2006 3:23 PM
> To: Tolga Asveren
> Cc: [email-masked]
[TOLGA]Isn't this the responsibility of the IG author? ;-)   In any case,
let me try and let's see what will come out, but before I start doing this:

Ken,

Is IG frozen already -I think so but just to verify-?
> a good thing to be able to control traffic on an association?
[TOLGA]Let me play the devil's advocate: Why should it be? Didn't ASP
already indicated its interest for this traffic range with the first
ASPAC/ASPAC-ACK exchange? Why should it matter from ASP point of view,
whether this traffic is coming from SGP1 or SGP2?

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 24 Feb 2006 14:18:24 -0700

Tolga,

Tolga Asveren wrote:                                                 (Fri, 24 Feb 2006 15:32:59)
> whether this traffic is coming from SGP1 or SGP2?

Don't be silly.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 24 Feb 2006 16:14:41 -0500

Brian,

No, I am serious. What is the difference between a message coming from SGP1
and SGP2 for the same AS from ASP point of view? Are they processed
differently? Are messages from SGP1 higher priority/more valuable/more dear
to the ASP?

> Sent: Friday, February 24, 2006 4:18 PM
> To: Tolga Asveren
> Cc: [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 24 Feb 2006 14:40:10 -0700

Tolga,

Implementation specific.  You want an example?  How about _cost_?

--brian

Tolga Asveren wrote:                                                 (Fri, 24 Feb 2006 16:14:41)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 24 Feb 2006 17:04:30 -0500

Brian,

I don't know whether it is realistic to expect that _cost_ for messages
coming from two SGPs belonging to the same SG are different -whatever that
_cost_ is-

For now let me assume _cost_ is different for messages coming from SGP1 and
SGP2. We already had ASP1 and now let's introduce ASP2 to the picture. Let
me use the following symbols:

_cost_11 : Cost between SGP1, ASP1  = 1
_cost_12 : Cost between SGP1, ASP2  = 5
_cost_21 : Cost betweeen SGP2, ASP1 = 5
_cost_22 : Cost between SGP2, ASP2 = 1

Now, being the _cost_ efficient operator we are, we want mainly to use the
paths ASP1-SGP1 and ASP2-SGP2 but want to have the paths ASP1-SGP2 and
ASP2-SGP1 as backup. How can we achieve this?

   Tolga

> Sent: Friday, February 24, 2006 4:40 PM
> To: Tolga Asveren
> Cc: [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 24 Feb 2006 15:46:05 -0700

Tolga,

Tolga Asveren wrote:                                                 (Fri, 24 Feb 2006 17:04:30)
> ASP2-SGP1 as backup. How can we achieve this?

By coordinating AS/ASP state.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 24 Feb 2006 18:24:42 -0500

Brian,

Could you draw the message exchange between ASPs and SGPs you would expect
for this scenario?

   Thanks,
   Tolga

> Sent: Friday, February 24, 2006 5:46 PM
> To: Tolga Asveren
> Cc: [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 24 Feb 2006 17:24:19 -0700

Tolga,

Already drawn, see my previous messages on this thread.

--brian

Tolga Asveren wrote:                                                 (Fri, 24 Feb 2006 18:24:42)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "nitin" <[email-masked]>
Date: Mon, 27 Feb 2006 18:15:53 +0530

Please consider a scenario :-
Configuration of AS ---------> ASP1 + ASP2 in  Override Mode
Configuration of SG----------> SGP1 + SGP2

ASP1         ASP2               SGP1        SGP2
|-------ASP UP.------------>|                       |
|<-------ASPUP ACK. -------|                     |
|<-------Notify AS Inact.  ------|                       |
|                      |                       |                       |
|--------ASP UP.---------------------------->
|<---------ASP UP. ACK.---------------------|
 |                       |   ASP UP        |                       |
|                      |---------------->                       |
|                      |<---ASP UPACK.|                      |
|-------ASP AC.--------------->|                       |
|<--------ASP AC. ACK--------|                       |
|                      |                       |                       |
|<----------Who will Send Notify AS Active SGP1 or SGP2------------------ |
|                       |

1. Who will Send notify message in this case  and to whom .

1. SGP1 will give notify AS Active    to ASP1 and ASP2.
2. SGP2 will given notify to ASP2 and SGP1 to ASP1.

2. This is a simple case , but there can be many cases in which it is
difficult to identify who is responsible for sending notify messages.
For example , if this case Suppose ASP2 is inactive at SGP2 and not SGP1 ,
then SGP1 cannot send notify to ASP1 . So is there a
general rule to do it or is it implementation dependent ?

thanks
nitin
----- Original Message ----- 
From: "Brian F. G. Bidulock" <[email-masked]>
To: "Tolga Asveren" <[email-masked]>
Cc: <[email-masked]>
Sent: Saturday, February 25, 2006 5:54 AM
Subject: Re: [Sigtran] M3UA notify message

> Version: 7.1.375 / Virus Database: 268.1.0/269 - Release Date: 2/24/2006
>
>

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 27 Feb 2006 08:21:30 -0500

Brian,

If the message flow you quoted is the one you are mentioning, I don't think
it will be an efficient solution.

All traffic will be received by the ASP sending ASPAC last (ASP2). All SS7
traffic received by SGP1 would be internally routed to SGP2. This itself is
not a nice thing in any situation from performance point of view but in the
scenario we are considering, it would be even less desirable, because if we
consider the _cost_ parameters, it wouldn't be unrealistic to expect that
_cost_ between SGP1 and SGP2 is high (it was low between SGP1/ASP1 ,
SGP2/ASP2  but high between SGP1/ASP2 , SGP1/ASP2. Furthermore, only ASP2
would receive traffic , leaving ASP1 resources idle.

    Tolga

> Sent: Friday, February 24, 2006 7:24 PM
> To: Tolga Asveren
> Cc: [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 27 Feb 2006 11:37:19 -0700

Tolga,

The cost between SGP1 and SGP2 can be the highest.  (Hint: It is the most
important link in the system.)

--brian

Tolga Asveren wrote:                             (Mon, 27 Feb 2006 08:21:30)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/