Subject: Re: [Sigtran] SUA: Relay: SG-SG

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 20 Feb 2006 03:04:53 -0700

Howard,

May, Howard wrote:                           (Mon, 20 Feb 2006 09:36:42)
> Hi Brian, Ilie
> 
> Consider the following simple system:
> 
> AS1(PC10)/ASP1 connecting to SGP1.
> AS2(PC20)/ASP2 connected to SGP2.
> SGP1 and SGP2 both contain the relay function and connect to each other.
> 
> Assume the following initial state:
> 
> ASP1/ASP2 UP and AS1/AS2 ACTIVE.
> SGP1/SGP2 association down.
> 
> My question is:
> 
> Once the association between SGP1 and SGP2 is established what message
> flow would be expected.

Some more questions:

Do SGP1 and SGP2 belong to the same SG?  Different SG?

If different SG, why do you have an association between
SGP1(SG1) and SGP2(SG2)?  By definition, SGs are connected to
the SS7 network and therefore technically can signal each other
over the SS7 network.

If you want to rule out the SS7 network in your example, make
them IPSPs instead of SGs (i.e., take away the SG function).  In
which case the ASPs are really more appropriately described as
SE IPSPs without the relay or SG function.

--brian

> 
> To put it another way; I would find it very helpful to see some example
> message flows for SG-SG relay functionality.
> 
> Regards
> 
> Howard
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "May, Howard" <[email-masked]>
Date: Mon, 20 Feb 2006 09:36:42 -0000

Hi Brian, Ilie

My question is:

Regards

Howard

>-----Original Message-----
>From: [email-masked] 
>[mailto:[email-masked]] On Behalf Of Brian F. G. Bidulock
>Sent: 17 February 2006 19:22
>To: May, Howard
>Cc: [email-masked]
>Subject: Re: [Sigtran] SUA: Relay: SG-SG
>
>Howard,
>
>I don't really understand your diagram.  Can you describe the
>message flow?  Also, how the nodes are equipped? (Whether they
>have the relay function, for example.)
>
>--brian
>
>May, Howard wrote:                           (Fri, 17 Feb 2006 
>15:04:33)
>> Brian,
>> 
>> I would value some clarification of the SUA, SGP - SGP interface
>> required for relay mode.  If I have got the message flow shown below
>> incorrect please can you correct it for me.
>> 
>> If the message flow is correct then would it be valuable to 
>include it
>> in the implementers guide.
>> 
>> Regards
>> 
>> Howard May
>> 
>> 
>> ________________________________
>> 
>> 	From: [email-masked] [mailto:[email-masked]]
>> On Behalf Of May, Howard
>> 	Sent: 15 February 2006 14:57
>> 	To: [email-masked]
>> 	Subject: [Sigtran] SUA: Relay: SG-SG
>> 	
>> 	
>> 
>> 	Gentlemen, 
>> 
>> 	Having reviewed Decembers discussion of Relay functionality, I
>> would like to ask you to review the following message flow 
>and ask for
>> your comments.  
>> 
>> 
>> 
>> 	ASP1                 SGP                   SGP
>> ASP2 
>> 	AS1(PC10)
>> AS2(PC100) 
>> 
>> 	 --UP/Activate-->
>> <--UP/Activate-- 
>> 	                        ----DAUD(PC100)--> 
>> 	                        <---DAVA(PC100)--- 
>> 	                        
>> 	                        <---DAUD(PC10)---- 
>> 	                        ----DAVA(PC10)---> 
>> 	 ---DAUD(PC100)--> 
>> 	 <--DAVA(PC100)--- 
>> 	                                                <--DAUD(PC10)---
>> 
>> 	                                                ---DAVA(PC10)-->
>> 
>> 
>> 	---CLDT(PC100)-->       
>> 	                        ---CLDT(PC100)--->      
>> 	
>> ---CLDT(PC100)--> 
>> 	  
>> 
>> 	Best Regards 
>> 
>> 	Howard May 
>> 
>> 
>> 
>>