Subject: [Sigtran] M3UA notify message

From: "nitin" <[email-masked]>
Date: Wed, 22 Feb 2006 13:55:46 +0530

hi,
consider a scenario, 
SG having two SGP's and one AS is configured on SG. If SGP's are SGP1 and SGP2. AS having two ASP's (ASP1 and ASP2) . ASP1 has established association wiht SGP1 and ASP2 has established association with SGP2. Now if ASP1 sends Asp active and state of AS changes to active , should ASP2 receive notify for AS state change (assuming ASP1 was not in down state at SGP2).

thanks
nitin

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 22 Feb 2006 01:16:37 -0700

nitin,

nitin wrote:                                    (Wed, 22 Feb 2006 13:55:46)
> 
>    hi,
> 
>    consider a scenario,
> 
>    SG  having two SGP's and one AS is configured on SG. If SGP's are SGP1
>    and  SGP2.  AS having two ASP's (ASP1 and ASP2) . ASP1 has established
>    association  wiht SGP1 and ASP2 has established association with SGP2.
>    Now  if  ASP1  sends  Asp  active  and state of AS changes to active ,
>    should  ASP2 receive notify for AS state change (assuming ASP1 was not
>    in down state at SGP2).

Yes.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "nitin" <[email-masked]>
Date: Wed, 22 Feb 2006 17:28:49 +0530

Hi,
if this is the case, then what will happen when(4 cases given below are
different from each other) :-
1. AS(consisting of ASP1 and ASP2) is active at SG (consisting of SGP1 and
SGP2) since ASP1 has done ASP active at SGP1. AS is in override mode and now
ASP2 sends ASP active message to SGP2 , now what will happen. Should SGP1
send alternate ASP active notify to ASP1 and mark ASP2 as active. But if
such is the case , ASP2 has not yet formed the association with SGP1.
2. should the SS7 traffic of SGP2 be routed through SGP1 since AS(load share
mode) is active(ASP1 has done active at SGP1) and SGP2 has already sent the
notify for AS active to ASP2.
3. If  AS is in loadshare mode (rest of the configuration same as in 1) .
Now when ASP2 sends active to SGP2 , should notify be sent again to the
ASP2.
4. In n+k architecture should this n be taken for SG or this is for SGP. I
mean to say AS should become active at SG (when it is active at n SGP's ,
supposing single ASP of AS is active at each of n SGP)or (should n ASP's be
active at any SGP) or (n ASP's should be active only no matter where and how
they are).

There was an earlier mail (copied below) , in which SGP2 sends notify again
to ASP which should not happen if we are going according to the current
scenario.

---------- Forwarded message ----------
From: Tolga Asveren <[email-masked]>
Date: Feb 11, 2006 12:58 AM
Subject: RE: [Sigtran] SG view of the ASP
To: [email-masked]

As far as I understand, the scenario presented by Krishna should follow the
following  flow:

  ASP1             SGP1       SGP2
   |                |           |
   |---ASPAC(RC1)-->|           |
   |                |           |
   |<-ASPAC-ACK(RC1)|           |
   |                |           |
   |<-NTFY(AS1 ACT)-|           |
   |                |           |
   |           ASP1 is now      |
   |           ACTIVE for AS1   |
   |                |           |
   |           AS1 is now       |
   |             ACTIVE         |
   |                |           |
   |-------ASPAC(RC1|---------->|
   |                |           |
   |<------ASPAC-ACK(RC1)-------|
   |                |           |
   |<------NTFY(AS1 ACTIVE)-----|
   |                |           |
   |                |         ASP1 is now
   |                |         ACTIVE for AS1
   |                |           |
   |                |          AS1 is now
   |                |          ACTIVE
   |---ASPIA(RC1)-->|           |
   |                |           |
   |<-ASPIA-ACK(RC1)|           |
   |                |           |
   |<-NTFY(AS1 INACT)           |
   |                |           |
   |             ASP1 is now    |
   |             INACTIVE for   |
   |             AS1|           |
   |                |           |
   |             AS1 is now     |
   |             INACTIVE       |
   |

Based on the following passage in his message:

"The explanation given by the Third party SG team is that since they
treat association from SGP1 to ASP as one ASP (ASP1) and the association
from SGP2 to ASP as a separate ASP (ASP2), they are over writing the
status when the SGP2 received the ASP ACTIVE message from the ASP. They
suggest that I put the trafficmode=loadshare and that would solve the
problem.  So I am really confused."

I believe the problem is that SG executes SGP semantics as behaving as a
single distributed SGP, but this will cause interoperability problems
because an ASP would expect each SGP peer to execute these procedures
separetly and independently. Please note that ASP will see each remote SCTP
endpoint as a different SGP.

----- Original Message ----- 
From: "Brian F. G. Bidulock" <[email-masked]>
To: "nitin" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, February 22, 2006 1:46 PM
Subject: Re: [Sigtran] M3UA notify message

> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.1.375 / Virus Database: 268.0.0/266 - Release Date: 2/21/2006
>
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 22 Feb 2006 04:49:40 -0700

nitin,

nitin wrote:                                   (Wed, 22 Feb 2006 17:28:49)
> such is the case , ASP2 has not yet formed the association with SGP1.

SGP2 sends it.

Yes.

> Now when ASP2 sends active to SGP2 , should notify be sent again to the

What Notify?

> active at any SGP) or (n ASP's should be active only no matter where and how

n+k refers to ASPs (and possibly IPSPs), not SGPs.

> to ASP which should not happen if we are going according to the current

The extra Notify is redundant (but not forbidden).

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 22 Feb 2006 08:03:09 -0500

Nitin,
-----Original Message-----
From: nitin [mailto:[email-masked]]
Sent: Wednesday, February 22, 2006 3:26 AM
To: [email-masked]
Subject: [Sigtran] M3UA notify message

hi,
consider a scenario,
SG having two SGP's and one AS is configured on SG. If SGP's are SGP1 and
SGP2. AS having two ASP's (ASP1 and ASP2) . ASP1 has established association
wiht SGP1 and ASP2 has established association with SGP2. Now if ASP1 sends
Asp active and state of AS changes to active , should ASP2 receive notify
for AS state change (assuming ASP1 was not in down state at SGP2).
[TOLGA]No. ASP1 became ACTIVE on SGP1. ASP2 is not in UP state in SGP1. If
it were, it would receive the NTFY.

---

From: "nitin" <[email-masked]>
Date: Wed, 22 Feb 2006 19:55:20 +0530

hi ,
I think i had not explained my questions clearly . I am trying to explain
them again .

Please have a look at the diagram :-

-----------                 -----------
SGP1                         SGP2
---|--------                ----|--------
    |                                  |
    |                                  |
    |                                  |
    |                                  |
    |                                  |
------------               ----------
ASP1                        ASP2
------------               -----------

In this diagram, SGP1 and SGP2 are both part of SG1. ASP1 and ASP2 are part
of AS1.

ASP1 has made sctp associatiion with SGP1 only .
ASP2 has made sctp association with  SGP2 only.
AS is in override mode.

ASP1 is INACTIVE at SGP1 and ASP2 is INACTIVE at SGP2.

1. Now, if ASP1 sends ASP ACTIVE message to SGP1 . will SGP2 be sending
notify for AS ACTIVE to ASP2.

2. If yes, now suppose ASP2 sends ACTIVE to SGP2 .
    Should Alternate ASP active notify be given to ASP1.
    If yes , in earlier discussions we have observed that Notify should be
done per SGP and not SG.

3. To add further ,   ASPSM, ASPTM, SSNM/SPMC ,notify messages be considered
per SG  or per SGP.

4. The question 4 that i had written in previous mail , i am explaining
again.
In that question I was not very clear in saying that n+k was for SGP or SG.

Actually what i want to ask is that ..............n+k is per SG or per SGP.

For example :- suppose 2+1 architecture is there . Now SG has two SGP's and
AS has two ASP's.
ASP1 is active on SGP1 and ASP2 is active on SGP2.
Since in this case total number of active ASP's is two , we should consider
AS to be active at SG.

                OR
suppose ASP1 and ASP2 are both active on SGP1 but none of them is on SGP2.
So in that case also
the number of ASP's active is two. Should we consider AS active at SG in
this case .

Which of the above two cases is valid or both.

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 22 Feb 2006 08:25:23 -0500

Nitin,

> Sent: Wednesday, February 22, 2006 9:25 AM
> To: [email-masked]
> Cc: [email-masked]
[TOLGA]No. Each SGP executes its own state machines. ASP1 became ACTIVE in
SGP!, not in SGP2. SGP2 is not in UP state in SGP1, so it won't receive any
notification.
> 3. To add further ,   ASPSM, ASPTM, SSNM/SPMC ,notify messages be
[TOLGA]ASPTM/ASPSM is per SGP. SSNM is per SG.
> Since in this case total number of active ASP's is two , we
[TOLGA]No. Two wrong things:
1)AS status from protocl point of view is per SGP, not per SG.
2)Each SGP executes its own state machine, so both of them will have only 1
ACTIVE ASP, which is less than 2, so AS won't be ACTIVE in either of them.
> the number of ASP's active is two. Should we consider AS active at SG in
[TOLGA]AS will be ACTIVE in SGP1 from protocol point of view. All state
machines are per SGP, not per SG. All ASPTM/ASPSM signalling relationship is
between ASPs and SGPs.
> > > SGP2) since ASP1 has done ASP active at SGP1. AS is in
> override mode and
> now
> > > mode) is active(ASP1 has done active at SGP1) and SGP2 has
> already sent
> the
> > > 3. If  AS is in loadshare mode (rest of the configuration
> same as in 1)
> .
> > > 4. In n+k architecture should this n be taken for SG or this
> is for SGP.
> I
> > > mean to say AS should become active at SG (when it is active
> at n SGP's
> ,
> > > supposing single ASP of AS is active at each of n SGP)or
> (should n ASP's
> be
> > > active at any SGP) or (n ASP's should be active only no
> matter where and
> how
> > > they are).
> >