Subject: [SIGTRAN] - M2PA Discard message

From: "Daniel B. Simonraj" <[email-masked]>
Date: Fri, 3 Feb 2006 06:37:53 -0600 (CST)

Brian,

    The m2pa RFC says 
"If M2PA receives a message from SCTP with an invalid Message Class or
unsupported Message Type in the Common Message Header, M2PA SHALL
discard the message."

  For the message discarded by us, we need not send ack to the peer
 Is it correct ?

  If it is correct, the T7 timer will expire in the peer side and the link
will be taken out-of-service.

--- Daniel

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 3 Feb 2006 08:09:07 -0700

Daniel,

How would you send an ack for an invalid message class or unsupported
message type?  Why would a T7 time be running against a message with
an invalid message class or unsupported message type?

--brian

Daniel B. Simonraj wrote:                     (Fri, 03 Feb 2006 06:37:53)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Andrew Booth <[email-masked]>
Date: Fri, 03 Feb 2006 10:12:03 -0500

Hi Daniel,

T7 only applies to User Data.  A message with invalid Message Class or 
unsupported Message Type is not a User Data message (unless your 
implementation chooses to not support User Data).

Andrew

-- 
Andrew Booth
Signaling Systems Group
Performance Technologies
www.pt.com
+1-613-237-4344
fax: +1-613-237-5277

Visit www.pt.com/mailing.html to subscribe to our Packets & Signals eLetter.