Subject: RE: [Sigtran] Question on DAUD response processing

From: "Karl, Sherry" <[email-masked]>
Date: Mon, 6 Feb 2006 09:18:54 -0600

What should be the response, if the DAUD contains multiple RCs?

Thanks again,

Sherry Karl

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Thursday, February 02, 2006 11:09 PM
To: Karl, Sherry
Cc: [email-masked]
Subject: Re: [Sigtran] Question on DAUD response processing

Sherry,

Please see comments below.

Karl, Sherry wrote:                             (Thu, 02 Feb 2006
21:01:56)
> 
>    What should be the response for a DAUD from an ASP, which has
multiple
>    APCs  and  one  of  the  APCs  has an invalid mask (The APC can not
be
>    validated)?
> 
> 
>    1. Should we process all valid ones and ignore the invalid APC?

No. Invalid Parameter Value is to be returned as indicated by the spec.

> 
>    2.  Should  we send error response(Invalid Parameter Value) and
ignore
>    all APCs?

I would say yes (but, of course, it is not explicitly required by the
spec).  In general there is no definitive way for the ASP to determine
which mask value was considered invalid by the SGP, also, because one
parameter is invalid makes all suspect (even if they appear correct),
after all, CRC32c is not infalible.

> 
>    3.  Should we send error response(Invalid Parameter Value) and
process
>    all good APCs?

I would way no (but it is not forbidden by the spec).  IMHO one bad
value in a message makes the entire message suspect; and error message
is sent to the peer so it cannot expect a response to any portion of
the message; hopefully the situation is also reported to management on
both ends for any necessary corrective action.

> 
> 
>    4. Is there a difference in processing between SUA and M3UA?

No. M3UA and SUA are (intentionally) quite consistent on error and
SNMM handling.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 6 Feb 2006 10:10:58 -0700

Sherry,

The same response as though multiple DAUDs (one per RC) were
sent.

--brian

Karl, Sherry wrote:                  (Mon, 06 Feb 2006 09:18:54)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/