Subject: [Sigtran] Re: [M3UA] AS state machine sharing between SGPs

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 22 Feb 2006 14:05:01 -0700

Tolga,

Here is one quote.

Asveren, Tolga wrote:                                             (Tue, 15 May 2001 15:06:09)
> Hi,
>  
> I think the below discussion is about whether we need SGP concept or not. Unless we say that they are sharing AS states, I don't see any reason to have the SGP concept (According to me, practically it is the same to say there is no SGP concept or to say every SG consist of one SGP).
> But I believe on the importance of sharing AS states between SGPs.In fact it is for sure, that some information should be shared, on SG level or on ASP level or on both. If as an ASP, which is functioning as standby for some ASs, I receive some AS-DOWN notification message there are two choices. If I know, that all of SGP, I am connected (and also the active ASP for this AS, is connected to) are sharing AS state, then I am sure, the active ASP is not reachable via any of these SGPs (otherwise I wouldn't receive ASDOWN message). So, I don't need to check anything with the other ASP and can send an ASPAC. 
> But, if SGPs are not sharing AS state, then after receiving the ASDOWN, I should check with active ASP to see, whether it is reachable via another SG or not, i.e. this time we should share SG-ASP connectivity per AS basis between ASPs.
> So, I think it is unavoidable sharing states at some level. When I think conceptually, SG is functioning like a router on IP domain, so all of the message routing responsibility should be there, i.e. every SGP, which is serving the same AS should share the AS states. I also agree, that for practical purposes, this will bring more complications to SG-developers. 
>  
>    Regards,
>    Tolga
>  
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 22 Feb 2006 14:05:01 -0700

Tolga,

Here is one quote.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 22 Feb 2006 16:18:27 -0500

Brian,

Several points:

1)Like said before, it is RFC not my 5 year old mails, which are
normative -thanks for valuing my opinion anyway ;-) -

2)The behavior described below, can be achieved without using a SG-wide
global AS/ASP state on SGPs when following ASPTM/ASPSM procedures.

3)The below description is not consistent with the current description in
RFC. Considering the advisory behavior of NTFY, it probably wouldn't cause
big problems but following similar logic for ASPTM/ASPSM would.

4) Sharing states is not equal to using a global AS/ASP state for state
machines in each SGP when following ASPTM/ASPSM procedures -I would agree
that "sharing" is not the best word to use for that purpose-.

5) I think you have my mailing address wrong in your addressbook ;-)

6) I think most important is 1) and 4).

    Thanks,
    Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Brian F. G. Bidulock
> Sent: Wednesday, February 22, 2006 4:05 PM
> To: Tolga Averson
> Cc: [email-masked]
> Subject: [Sigtran] Re: [M3UA] AS state machine sharing between SGPs
>
>
> Tolga,
>
> Here is one quote.
>
> Asveren, Tolga wrote:
> > I think the below discussion is about whether we need SGP
> concept or not. Unless we say that they are sharing AS states, I
> don't see any reason to have the SGP concept (According to me,
> practically it is the same to say there is no SGP concept or to
> say every SG consist of one SGP).
> > But I believe on the importance of sharing AS states between
> SGPs.In fact it is for sure, that some information should be
> shared, on SG level or on ASP level or on both. If as an ASP,
> which is functioning as standby for some ASs, I receive some
> AS-DOWN notification message there are two choices. If I know,
> that all of SGP, I am connected (and also the active ASP for this
> AS, is connected to) are sharing AS state, then I am sure, the
> active ASP is not reachable via any of these SGPs (otherwise I
> wouldn't receive ASDOWN message). So, I don't need to check
> anything with the other ASP and can send an ASPAC.
> > But, if SGPs are not sharing AS state, then after receiving the
> ASDOWN, I should check with active ASP to see, whether it is
> reachable via another SG or not, i.e. this time we should share
> SG-ASP connectivity per AS basis between ASPs.
> > So, I think it is unavoidable sharing states at some level.
> When I think conceptually, SG is functioning like a router on IP
> domain, so all of the message routing responsibility should be
> there, i.e. every SGP, which is serving the same AS should share
> the AS states. I also agree, that for practical purposes, this
> will bring more complications to SG-developers.
> >
> >    Regards,
> >    Tolga
> >
> >
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 22 Feb 2006 22:10:39 -0700

Tolga,

Well, in fact they are: in Greg's other mail is the exact wording
from 1.4.1.

--brian

Tolga Asveren wrote:                                                 (Wed, 22 Feb 2006 16:18:27)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/