Subject: RE: [Sigtran] Test 4.4 when testing M3UA at SGP

From: "Trentadue, Tim" <[email-masked]>
Date: Wed, 15 Feb 2006 12:50:17 -0600

You are correct. The test I refer to comes from
draft-anshoo-test-spec-m3ua-01.txt

When reading the statement "the remote ASP state is changed to
ASP-INACTIVE in all relevant Application Servers", should I interperet
from the perspective of the SGP? i.e., 

"the remote ASP state (at the SGP) is changed to ASP-INACTIVE in all
relevant Application Servers (at the SGP)" ??

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Tolga Asveren
Sent: Wednesday, February 15, 2006 11:48 AM
To: [email-masked]
Subject: RE: [Sigtran] Test 4.4 when testing M3UA at SGP

Tim,

I don't know which document this test case is from but I assume it is
one of the drafts prepared for interoperability testings(?), so I
believe it is a safer approach to refer to RFC/IG rather than to such
drafts.

4.3.4.1 from M3UA IG
  If an ASP Up message is received and internally the remote ASP is in
   the ASP-ACTIVE state, an ASP Up Ack message is returned, as well as,
   an Error message ("Unexpected Message).  In addition, the remote ASP
   state is changed to ASP-INACTIVE in all relevant Application Servers
   and all registered Routing Keys are considered deregistered.

The above is the current officially expected behavior.

Note for IG update: Figure 3 misses this transition.

   Thanks,
   Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Trentadue, Tim
> Sent: Wednesday, February 15, 2006 12:53 PM
> To: [email-masked]
> Subject: [Sigtran] Test 4.4 when testing M3UA at SGP
>
>
> The PURPOSE and TEST DESCRIPTION.3 of this test seem to contradict 
> each other and I'm hoping somebody can clarify.
>
> PURPOSE states "and ASP state is moved to ASP-Inactive" - I assume 
> this is from the perspective of SGP
>
> DESCRIPTION.3 states "State of ASP should not change to ASP Inactive" 
> - I assume this too is from the perspective of the SGP. If so, it 
> contradicts the PURPOSE, right?
>
>
>
>
>        + TEST NUMBER : 4.4
>
>        + TITLE : Invalid Message Handling
>
>        + SUBTITLE : ASPUP message in ASP-Active state
>
>        + PURPOSE: To check that if ASPUP message is received in 
> ASP-Active
>          state then ACK message is sent to AS and ASP
>          state is moved to ASP-Inactive.
>
>        + TEST CONFIGURATION: A
>
>        + PRE-TEST CONDITIONS: SCTP association is established between 
> SGP and
>          ASP and ASP1 is Active. Arrange the data in AS such that
ASPUP
>          message is sent to the SGP on stream 0.
>
>         EXPECTED MESSAGE SEQUENCE :
>          ASP                           SGP             SM + NIF
>                                      ASP is Active
>
>         ASPUP      ---------------->
>
>                    <---------------   ASP-Up-Ack
>
>                                         Status Ind -------> AS 
> Inactive
>
>                    <---------------   Error
>                                       (Unexpected Message)
>
>         ASPAC      ---------------->
>                                         Status Ind ------->
>
>                    <---------------   ASP-Active-Ack
>
>        TEST DESCRIPTION:
>        1. Send ASPUP message to the SGP in ASP-Active state.
>        2. Check A: An Error message with parameter Unexpected Message 
> should
>           be received at ASP.
>        3. Check B: State of ASP should not change to ASP Inactive. 
> Send ASPAC
>           message with correct Type (Type is same as defined at SGP 
> for the
>           AS) and routing context P to the SGP and SGP should send
>           ASP-Active-Ack.
>
> Tim Trentadue
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
>

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 15 Feb 2006 13:36:36 -0500

Yes.

> Sent: Wednesday, February 15, 2006 1:50 PM
> To: [email-masked]