Subject: RE: [Sigtran] SG view of the ASP

From: "Munnaluru, Krishna" <[email-masked]>
Date: Thu, 9 Feb 2006 11:34:01 -0600

Brian,

This is how it is affecting my expected behavior.

Note: Currently I have only one ASP but in future I intend to add a
standby ASP. Hence I use the trafficmode=override in the messages. Also
the desired behavior is that the ASP to laodshare the traffic going to
the SG among the two SGPs.

The problem showed up during the following scenario:

The ASP comes up, establishes associations and sends ASP UP message
(ASPIdentifier = 10007) to both SGPs for which the SGPs respond with ASP
UP ACK. 

The ASP sends ASP ACTIVE (trafficmode=override) with a routing context
for the AS to the SGP1 and the SGP1 responds with ASP ACTIVE ACK. The
status on the SG shows that the AS is active on SGP1 and inactive on
SGP2.

Later the ASP sends ASP ACTIVE (trafficmode=override) with the same
routing context to the SGP2 and the SGP2 responds with ASP ACTIVE ACK.
The status on the SG shows that the AS is active on SGP2 and inactive on
SGP1. I was expecting the AS to be active on both SGPs since the ASP had
sent ASP ACTIVE to both SGPs.  This was not what I was expecting.

The explanation given by the Third party SG team is that since they
treat association from SGP1 to ASP as one ASP (ASP1) and the association
from SGP2 to ASP as a separate ASP (ASP2), they are over writing the
status when the SGP2 received the ASP ACTIVE message from the ASP. They
suggest that I put the trafficmode=loadshare and that would solve the
problem.  So I am really confused.

Hope this helps.

Thanks,
Krishna

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Thursday, February 09, 2006 11:15 AM
To: Munnaluru, Krishna
Cc: [email-masked]
Subject: Re: [Sigtran] SG view of the ASP

Krishna,

How is the behaviour different?

--brian

Munnaluru, Krishna wrote:                       (Thu, 09 Feb 2006
10:23:19)
> 
>    Hi,
> 
> 
>    I  am implementing ASP and we are trying to interop with a third
party
>    SG. The following is the scenario.
> 
> 
>    We  have  one  ASP  and  one  SG  containing  two  SGPs.  The  ASP
is
>    establishing  one  SCTP  association  with  each  SGP  (a total of
two
>    associations).
> 
> 
>    The problem is that the SG is treating each association as a
different
>    ASP.  So it thinks that there are two separate ASPs in the network.
Is
>    this  the  correct  behavior?  My  understanding is that the SG
should
>    treat  it  as  "two associations to the same ASP (from each SGPs)"
and
>    NOT "as two separate ASPs".
> 
> 
>    Could someone please comment on this behavior?
> 
> 
>    Thanks in advance,
> 
>    Krishna

> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Shelesh Bansal" <[email-masked]>
Date: Fri, 10 Feb 2006 00:17:47 +0530

Hi,

I agree with Ilie. When ASP sent traffic mode as override it means SGP
have to choose this ASP, by overriding the previous one. This does not
apply that SGP need to loadshare the traffic. Again can we have SG
contained in two SGP with same network appearance? 

Regards,

Shelesh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Ilie Glib
Sent: Thursday, February 09, 2006 9:58 AM
To: Munnaluru, Krishna
Cc: [email-masked]; [email-masked]
Subject: Re: [Sigtran] SG view of the ASP

Hello Krishna,

This kind of behaviour from the SG means that the SGPs in the SG act

in active/standby mode while your ASP acts in override mode.

You expect the behaviour where the SG supports loadsharing mode for

its SGPs and override mode for remote ASPs.

Regards

Ilie

 

--

Ilie

Sigtran mailing list

[email-masked]

---

From: "Haresign Lincoln" <[email-masked]>
Date: Thu, 9 Feb 2006 15:04:12 -0500

Krishna,

Are you including the optional ASP ID within your messages?

Regards,
Lincoln 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Munnaluru, Krishna
Sent: Thursday, February 09, 2006 2:52 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [Sigtran] SG view of the ASP

The ASP is currently sending the ASP UP message with the same ASP Id to
both SGPs. 

As per the SG guys suggestion we temporarily changed the ASP trafficmode
in the ASP ACTIVE message to loadsharing and this problem goes away. But
we see another problem.

The administrator on the ASP side decides to take down the SCTP
association with SGP2. The ASP sends ASP DOWN message to the SGP2. Then
the SGP2 responds with ASP DOWN ACK. So far everything looks good. But
then immediately the SGP1 sends a NOTIFY with the status=ASP Failure and
includes the Routing Context value. Why is the SGP1 sending this NOTIFY
and what is the expected behavior of the ASP upon receiving the NOTIFY
from the SGP1? The SG is sending the NOTIFY because it treats the ASP as
two separate ASPs and so it thinks that it is notifying to the other
ASP.

I think it came down to the way SG was designed - "The SG treating each
association as a separate ASP as supposed to just one ASP with two
associations".  Is this the general way a SG behaves (or designed)?
Should it not treat an ASP as just one rather than two?

Please provide some input so that I can confirm my understanding of the
M3UA protocol.

Thanks,
Krishna

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Thursday, February 09, 2006 12:21 PM
To: Munnaluru, Krishna
Cc: [email-masked]
Subject: Re: [Sigtran] SG view of the ASP

Krishna,

I suppose you could try adding ASP Id to the ASP Up message and see if
the SG recognizes the ASP as one.

However, as Ille suggests, perhaps the problem is the SG's traffic mode
(rather than the AS's traffic mode).

If the SG really believes that the ASP is two distinct ASPs, it should
be sending a NOTIFY("Alternate ASP Active") from SGP1.  If it does not,
IMO it is just a bug, so, perhaps the SG does not truly support Active/
Standby mode.

--brian

Munnaluru, Krishna wrote:                    (Thu, 09 Feb 2006 11:34:46)

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran
--------------------------------------------------------------------
This email message has been scanned by Comverse mail security system

---

From: "Munnaluru, Krishna" <[email-masked]>
Date: Thu, 9 Feb 2006 14:11:22 -0600

Yes I am including the ASP Identifier in the ASP UP message. Is there
any other message I need to include it in.

Thanks,
Krishna

-----Original Message-----
From: Haresign Lincoln [mailto:[email-masked]] 
Sent: Thursday, February 09, 2006 2:04 PM
To: Munnaluru, Krishna; [email-masked]
Cc: [email-masked]
Subject: RE: [Sigtran] SG view of the ASP

Krishna,

Regards,
Lincoln 

-----Original Message-----

Thanks,
Krishna

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Thursday, February 09, 2006 12:21 PM
To: Munnaluru, Krishna
Cc: [email-masked]
Subject: Re: [Sigtran] SG view of the ASP

Krishna,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Haresign Lincoln" <[email-masked]>
Date: Thu, 9 Feb 2006 16:16:38 -0500

I would agree with that.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Tolga Asveren
Sent: Thursday, February 09, 2006 2:56 PM
To: [email-masked]
Subject: RE: [Sigtran] SG view of the ASP

Lincoln,

> Sent: Thursday, February 09, 2006 3:02 PM
> To: Tolga Asveren; [email-masked]
> Tolga,
> The problem with this is that if ASP1 becomes inaccessible from SGP1, 
> but SGP2 can still talk to ASP1, what should the SG send to the SS7 
> network?  If SGP1 is not aware that SGP2 can still talk to ASP1, then 
> it might send out an SSP.  Or am I missing something in your
explanation?
[TOLGA]In such a case what I expect to happen is SGP1 to send messages
it receives from SS7 network to SGP2 so that it can send it to ASP1.
Such a mechanism -which is implementation dependent- would be necessary
even if one wants to keep a single ASP state machine in SG.
>
> There needs to be an overall view that is coordinated amoung SGPs in 
> one central place in order to manage the view of the ASPs out in to 
> the SS7 network.
[TOLGA]That is true, but this does not mean to keep a single ASP state
machine in SG. Each SGP will have their own ASP state machines, and some
other mechanims -which is implementation dependent- will coordinate the
unique SPMC view. Such a mechanism is necessary not only to coordinate
different ASP state in different SGPs but also to aggregate the PC
status as well, if RKs in User Part granularity are used.

> Behalf Of Tolga Asveren
> Sent: Thursday, February 09, 2006 2:33 PM
> To: [email-masked]
> Ooppppss a typo...
> ASP2 should read SGP2.
>    tolga
> > From: [email-masked] [mailto:[email-masked]]On
> > Behalf Of Tolga Asveren
> > Sent: Thursday, February 09, 2006 2:08 PM
> > To: [email-masked]
> > Bary,
> > I was maybe not clear from english language point of view.
> >
> > What I tried to say is:
> >
> > There is SGP1 and SGP2 and ASP1. SGP1 and SGP2 are part of SG1. SGP1

> > interacts only with a single ASP, i.e. ASP1. ASP2 interacts only 
> > with a single ASP, i.e. ASP1. Each SGP keeps their own state machine

> > tables
>
> > for ASPs. Because each of them has only a single ASP in their lists,

> > that ASP will be the only ACTIVE ASP from both SGP point of view.
> >
> >     Tolga
> >
> > > From: [email-masked] [mailto:[email-masked]]On
> > > Behalf Of Barry Nagelberg
> > > Sent: Thursday, February 09, 2006 2:17 PM
> > > To: [email-masked]
> > > Tolga,
> > > You are contradicting yourself. If "ASP/SGP relationship/state 
> > > machines are kep on each SGP separetly", then how can these two 
> > > separate SGPs know that they are interacting with a
> > single ASP?
> > >
> > > Barry Nagelberg
> > > Adax, Inc.
> > >
> > > From: [email-masked] [mailto:[email-masked]]On
> > > Behalf Of Tolga Asveren
> > > Sent: Thursday, February 09, 2006 12:55 PM
> > > To: [email-masked]
> > > Your expectation is how it is supposed to work. ASP/SGP
> > relationship/state
> > > machines are kep on each SGP separetly. In your example, both SGPs

> > > are interacting with a single ASP, and from their point of view, 
> > > it is the only ACTIVE ASP.
> > >
> > >    tolga
> > >
> > > > From: [email-masked] 
> > > > [mailto:[email-masked]]On
> > > > Sent: Thursday, February 09, 2006 12:35 PM
> > > > To: [email-masked]
> > > > Cc: [email-masked]
> > > > Note: Currently I have only one ASP but in future I intend to 
> > > > add a standby ASP. Hence I use the trafficmode=override in the
> > messages. Also
> > > > the desired behavior is that the ASP to laodshare the traffic 
> > > > going to the SG among the two SGPs.
> > > >
> > > > The ASP comes up, establishes associations and sends ASP UP 
> > > > message (ASPIdentifier = 10007) to both SGPs for which the SGPs
> > respond with ASP
> > > > UP ACK.
> > > >
> > > > The ASP sends ASP ACTIVE (trafficmode=override) with a routing 
> > > > context for the AS to the SGP1 and the SGP1 responds with ASP 
> > > > ACTIVE ACK. The status on the SG shows that the AS is active on
> > > > SGP1 and inactive on SGP2.
> > > >
> > > > Later the ASP sends ASP ACTIVE (trafficmode=override) with the 
> > > > same routing context to the SGP2 and the SGP2 responds with ASP
> ACTIVE ACK.
> > > > The explanation given by the Third party SG team is that since 
> > > > they treat association from SGP1 to ASP as one ASP (ASP1) and 
> > > > the
> > association
> > > > from SGP2 to ASP as a separate ASP (ASP2), they are over writing

> > > > the status when the SGP2 received the ASP ACTIVE message from 
> > > > the
> > ASP. They
> > > > suggest that I put the trafficmode=loadshare and that would 
> > > > solve the problem.  So I am really confused.
> > > >
> > > > Hope this helps.
> > > >
> > > > Thanks,
> > > > Krishna
> > > >
> > > >
> > > >

---

From: "Haresign Lincoln" <[email-masked]>
Date: Fri, 10 Feb 2006 08:32:16 -0500

Brian,

I think the RFC test plan is an excellent idea.  I believe that there
was a draft spec for M3UA floating around for a while:
draft-anshoo-test-spec-m3ua.01.txt.

Regards,
Lincoln

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Brian F. G. Bidulock
Sent: Thursday, February 09, 2006 6:17 PM
To: Munnaluru, Krishna
Cc: [email-masked]
Subject: Re: [Sigtran] SG view of the ASP

Krishna,

Well, that likely explains the NTFY("ASP Failure") in loadshare mode
too.

When SGP1 in loadshare mode sends an NTFY("ASP Failure") as you describe
below, does it include an ASP Id? (It is required to if an ASP Id was
provided in the ASP Up for that ASP.)  If so, it is indeed ignoring ASP
Id and telling the (attached) ASP that the ASP with the same id as it
has failed, which does not make much sense.  It really appears that the
implementation has some problems.  You might be able to find a few test
cases in one of the interop test plans that can illustrate the errors in
the implementation to its builders.

I have a few of the interop test plans posted starting here:

  http://www.openss7.org/sigtran.html

if that will help.  I recall some cases testing multiple ASPs and
multiple SGPs in various traffic modes.  Unfortunately the examples in
the specs show one SGP and multiple ASPs.  I think that it would make
sense to formalize a test spec for M3UA and SUA and publish them as
informational RFCs, serving to provide both examples and testing
suggestions.

--brian

Munnaluru, Krishna wrote:                    (Thu, 09 Feb 2006 16:56:42)
> Brian,
> 
> Yes. The SGP sent a NOTIFY with Alternate ASP Active. In reality there

> is only one ASP.
> Sent: Thursday, February 09, 2006 2:39 PM
> To: Munnaluru, Krishna
> Cc: [email-masked]
13:51:56)
> > the SGP2 responds with ASP DOWN ACK. So far everything looks good. 
> > But then immediately the SGP1 sends a NOTIFY with the status=ASP 
> > Failure
> and
> > and what is the expected behavior of the ASP upon receiving the 
> > NOTIFY from the SGP1? The SG is sending the NOTIFY because it treats

> > the ASP
> as

> In the override case, did the SG send NTFY("Alternate ASP Active") 
> when
> SGP1 marked the ASP ASP Inactive?  If not, the SG is not behaving 
> consistent with the view that there are two ASPs.
> 
> --brian
> 
> > 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/