Subject: RE: [Sigtran] (M2PA) Question about the requirement "The same standard MUST be followed on both ends"

From: "Craig, Jeffrey" <[email-masked]>
Date: Wed, 1 Feb 2006 07:25:57 -0600

Hello Brian,

Thanks for your response.

In my view, your statements confirm that the requirement
falls outside the scope of the M2PA RFC. M2PA has an 
unbounded list of 'applicable' specification/standards, 
since it states (note the 'SHOULD' and 'may include'):

   Except as modified in this document, M2PA SHOULD 
   follow the requirements of the applicable MTP2
   specification.  These may include [Q.703] or [T1.111].
   The same standard MUST be followed on both ends
   of the M2PA link.                                                    

If two different M2PA peers are able to pass an 
implementer's/user's interoperability tests, then it does 
not matter what the base MTP2 specification is for each 
M2PA. If the cited MTP specifications already state a 
'same standard on both ends' requirement, then M2PA does 
not also need to state the same requirement.

The last statement in the above RFC paragraph should either
be deleted or changed to 'SHOULD'. If the statement remains,
then it would have real value, if additional text is added 
explaining, with some detail, why both M2PA peers SHOULD 
conform to the same MTP2 specification.

Regards,

Jeff

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Tuesday, January 31, 2006 11:57 AM
To: Craig, Jeffrey
Cc: [email-masked]
Subject: Re: [Sigtran] (M2PA) Question about the requirement "The same
standard MUST be followed on both ends"

Craig,,

SS7 itself has no such mechanism, and yet, the same standard must be
followed on both ends of an SS7 link or the link will not operate
correctly.

As is is done in SS7 today, by provisioning, without the need for
protocol elements, that should be ok for M2PA as well.

--brian

Craig, Jeffrey wrote:                         (Tue, 31 Jan 2006
08:03:32)
> Hello All,
> 
> I am curious about the following RFC4165 M2PA requirement in section
4:
> 
> "The same standard MUST be followed on both ends of the M2PA link."
>
> M2PA does not appear to provide a mechanism for the user to identify
> the MTP2 standard upon which it is based, nor does it provide a
> mechanism to communicate that information to its peer. Given these
> facts, how is the user or the protocol supposed to satisfy the
> requirement?
>
> Shouldn't the statement be changed to something like:
>
> Interoperability cannot be guaranteed between two M2PA peers that are
> based upon different MTP2 standards, and so the M2PA user SHOULD
> ensure that M2PA peers conform to the same standard.
>
> Or, alternatively, perhaps M2PA should provide a mechanism to
> communicate the MTP2 standard upon which it is based. Perhaps a new
> parameter in the Link Status Alignment messsage can serve this
> purpose.
>
> Regards,
>
> Jeff
> 
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 1 Feb 2006 11:01:16 -0700

Jeffrey,

Being necessary for interoperability, "MUST" is appropriate
and it falls squarely inside the scope of the specification.

--brian

Craig, Jeffrey wrote:                                               (Wed, 01 Feb 2006 07:25:57)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/