Subject: RE: [Sigtran] SG view of the ASP

From: "Munnaluru, Krishna" <[email-masked]>
Date: Thu, 9 Feb 2006 11:34:46 -0600

Brian,

This is how it is affecting my expected behavior.

Note: Currently I have only one ASP but in future I intend to add a
standby ASP. Hence I use the trafficmode=override in the messages. Also
the desired behavior is that the ASP to laodshare the traffic going to
the SG among the two SGPs.

The problem showed up during the following scenario:

The ASP comes up, establishes associations and sends ASP UP message
(ASPIdentifier = 10007) to both SGPs for which the SGPs respond with ASP
UP ACK. 

The ASP sends ASP ACTIVE (trafficmode=override) with a routing context
for the AS to the SGP1 and the SGP1 responds with ASP ACTIVE ACK. The
status on the SG shows that the AS is active on SGP1 and inactive on
SGP2.

Later the ASP sends ASP ACTIVE (trafficmode=override) with the same
routing context to the SGP2 and the SGP2 responds with ASP ACTIVE ACK.
The status on the SG shows that the AS is active on SGP2 and inactive on
SGP1. I was expecting the AS to be active on both SGPs since the ASP had
sent ASP ACTIVE to both SGPs.  This was not what I was expecting.

The explanation given by the Third party SG team is that since they
treat association from SGP1 to ASP as one ASP (ASP1) and the association
from SGP2 to ASP as a separate ASP (ASP2), they are over writing the
status when the SGP2 received the ASP ACTIVE message from the ASP. They
suggest that I put the trafficmode=loadshare and that would solve the
problem.  So I am really confused.

Hope this helps.

Thanks,
Krishna

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Thursday, February 09, 2006 11:15 AM
To: Munnaluru, Krishna
Cc: [email-masked]
Subject: Re: [Sigtran] SG view of the ASP

Krishna,

How is the behaviour different?

--brian

Munnaluru, Krishna wrote:                       (Thu, 09 Feb 2006
10:23:19)
> 
>    Hi,
> 
> 
>    I  am implementing ASP and we are trying to interop with a third
party
>    SG. The following is the scenario.
> 
> 
>    We  have  one  ASP  and  one  SG  containing  two  SGPs.  The  ASP
is
>    establishing  one  SCTP  association  with  each  SGP  (a total of
two
>    associations).
> 
> 
>    The problem is that the SG is treating each association as a
different
>    ASP.  So it thinks that there are two separate ASPs in the network.
Is
>    this  the  correct  behavior?  My  understanding is that the SG
should
>    treat  it  as  "two associations to the same ASP (from each SGPs)"
and
>    NOT "as two separate ASPs".
> 
> 
>    Could someone please comment on this behavior?
> 
> 
>    Thanks in advance,
> 
>    Krishna

> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Ilie Glib <[email-masked]>
Date: Thu, 9 Feb 2006 18:57:34 +0100

Hello Krishna,

This kind of behaviour from the SG means that the SGPs in the SG act
in active/standby mode while your ASP acts in override mode.

You expect the behaviour where the SG supports loadsharing mode for
its SGPs and override mode for remote ASPs.

Regards

Ilie

--
Ilie

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 9 Feb 2006 12:54:56 -0500

Krishna,

Your expectation is how it is supposed to work. ASP/SGP relationship/state
machines are kep on each SGP separetly. In your example, both SGPs are
interacting with a single ASP, and from their point of view, it is the only
ACTIVE ASP.

   tolga

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Munnaluru, Krishna
> Sent: Thursday, February 09, 2006 12:35 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [Sigtran] SG view of the ASP
>
>
> Brian,
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 9 Feb 2006 11:20:45 -0700

Krishna,

I suppose you could try adding ASP Id to the ASP Up message and see
if the SG recognizes the ASP as one.

However, as Ille suggests, perhaps the problem is the SG's traffic
mode (rather than the AS's traffic mode).

If the SG really believes that the ASP is two distinct ASPs, it should
be sending a NOTIFY("Alternate ASP Active") from SGP1.  If it does not,
IMO it is just a bug, so, perhaps the SG does not truly support Active/
Standby mode.

--brian

Munnaluru, Krishna wrote:                    (Thu, 09 Feb 2006 11:34:46)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Barry Nagelberg" <[email-masked]>
Date: Thu, 9 Feb 2006 13:31:47 -0500

Tolga,

You are making this up. There is no statement in the spec such as "ASP/SGP relationship/state machines are kep on each
SGP separetly".

Barry Nagelberg
Adax, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Tolga Asveren
Sent: Thursday, February 09, 2006 12:55 PM
To: [email-masked]
Subject: RE: [Sigtran] SG view of the ASP

Krishna,

   tolga

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 9 Feb 2006 11:39:37 -0700

Barry,

It was nevertheless agreed by consensus.

--brian

Barry Nagelberg wrote:                    (Thu, 09 Feb 2006 13:31:47)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 9 Feb 2006 13:21:36 -0500

Bary,

4.3 AS and ASP/IPSP State Maintenance

   The M3UA layer on the SGP maintains the state of each remote ASP, in
   each Application Server that the ASP is configured to receive
   traffic, as input to the M3UA message distribution function.
   Similarly, where IPSPs use M3UA in a point-to-point fashion, the M3UA
   layer in an IPSP maintains the state of remote IPSPs.

I think it is one of the basics of M3UA that the signaling relationship is
between SGP and ASP.

   tolga

> Behalf Of Barry Nagelberg
> Sent: Thursday, February 09, 2006 1:32 PM
> To: [email-masked]
> You are making this up. There is no statement in the spec such as
> "ASP/SGP relationship/state machines are kep on each
> SGP separetly".
>
> Barry Nagelberg
> Adax, Inc.
>

---

From: "Barry Nagelberg" <[email-masked]>
Date: Thu, 9 Feb 2006 13:51:18 -0500

Brian,

The ASP Id param is expressly intended only for local use at the ASPs, to coordinate the actions of multiple ASPs within
an AS. It's only use at the SG is to indicate the "concerned" ASP in NTFY messages.

It is not used at the SG for coordinating the state machines of multiple M3UA endpoints.

If there are ASP implementations that would like to use the ASP Id for this purpose, then we should expressly add this
feature to the spec.

>From Section 3.5.1 (ASP Up):

<snip>
   ASP Identifier: 32-bit unsigned integer

      The optional ASP Identifier parameter contains a unique value that
      is locally significant among the ASPs that support an AS.  The SGP
      should save the ASP Identifier to be used, if necessary, with the
      Notify message (see Section 3.8.2).
<snip>

Barry Nagelberg
Adax, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Brian F. G. Bidulock
Sent: Thursday, February 09, 2006 1:21 PM
To: Munnaluru, Krishna
Cc: [email-masked]
Subject: Re: [Sigtran] SG view of the ASP

Krishna,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Barry Nagelberg" <[email-masked]>
Date: Thu, 9 Feb 2006 13:53:50 -0500

Brian,

The only arbiter of consensus is the spec, not you.

Barry Nagelberg
Adax, Inc.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Thursday, February 09, 2006 1:40 PM
To: Barry Nagelberg
Cc: [email-masked]
Subject: Re: [Sigtran] SG view of the ASP

Barry,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 9 Feb 2006 11:59:07 -0700

Barry,

Well, no.  The ASP Id is used by the SG to determine the
identity of the ASP that is performing an ASP Up (particularly
for dynamic port allocation where the SG cannot identify the ASP
by other means).  Thus the SG needs to determine which ASP state
machine (and corresponding AS state machines) belongs to the ASP
in accordance with the received ASP Id.  Otherwise, it would not
be possible to associate multiple ASP Ups received on multiple
associations for the same ASP.

This has always been the case for ASP Id.  I don't know how you
got this false impression that it need only be used for NTFY
messages.

--brian

Barry Nagelberg wrote:                                               (Thu, 09 Feb 2006 13:51:18)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 9 Feb 2006 12:00:15 -0700

Barry,

It was not me, see the mail archive.

--brian

Barry Nagelberg wrote:                                               (Thu, 09 Feb 2006 13:53:50)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Barry Nagelberg" <[email-masked]>
Date: Thu, 9 Feb 2006 14:05:45 -0500

Brian,

You are making this up. There is nothing in the spec about these additional uses of the Asp Id by the SGP.

Barry Nagelberg
Adax, Inc.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Thursday, February 09, 2006 1:59 PM
To: Barry Nagelberg
Cc: [email-masked]
Subject: Re: [Sigtran] SG view of the ASP

Barry,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Barry Nagelberg" <[email-masked]>
Date: Thu, 9 Feb 2006 14:17:14 -0500

Tolga,

You are contradicting yourself. If "ASP/SGP relationship/state machines are kep on each SGP separetly", then how can
these two separate SGPs know that they are interacting with a single ASP?

Barry Nagelberg
Adax, Inc.

-----Original Message-----

Krishna,

   tolga

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 9 Feb 2006 14:07:57 -0500

Bary,

I was maybe not clear from english language point of view.

What I tried to say is:

There is SGP1 and SGP2 and ASP1. SGP1 and SGP2 are part of SG1. SGP1
interacts only with a single ASP, i.e. ASP1. ASP2 interacts only with a
single ASP, i.e. ASP1. Each SGP keeps their own state machine tables for
ASPs. Because each of them has only a single ASP in their lists, that ASP
will be the only ACTIVE ASP from both SGP point of view.

    Tolga

> Sent: Thursday, February 09, 2006 2:17 PM
> To: [email-masked]
> You are contradicting yourself. If "ASP/SGP relationship/state
> machines are kep on each SGP separetly", then how can

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 9 Feb 2006 14:33:13 -0500

Ooppppss a typo...

ASP2 should read SGP2.

   tolga

> Sent: Thursday, February 09, 2006 2:08 PM
> To: [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 9 Feb 2006 13:34:01 -0700

Barry,

It appears that you think all the authors of the spec are
making things up today.

--brian

Barry Nagelberg wrote:                                               (Thu, 09 Feb 2006 14:05:45)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/