Subject: [Sigtran] Is sharing of one SCTP endpoint between Multiple Signalling Processes possible?

From: "Ilie Glib" <[email-masked]>
Date: Fri, 17 Feb 2006 19:52:45 +0100

Hello Folks,

could you please clarify for me whether it is possible that multiple
ASPs (IPSPs) serving the same AS share an SCTP endpoint when
communicating to an SGP (IPSP).

I think that SUA, M3UA do not prohibit explicitly use of the same SCTP
endpoint by multiple Signalling Processes serving the same traffic
range. Moreover the ASP_ID provides a means of interpreting multiple
ASP Up, ASP Down with different ASP_IDs sent over the same SCTP
association.

Can multiple ASP Up, ASP Down (with different ASP_IDs) be sent over
the same SCTP association in the same direction?
Is there a consensus in SIGTRAN community on this topic?

--
Ilie

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 17 Feb 2006 13:50:25 -0500

Ilie,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Ilie Glib
> Sent: Friday, February 17, 2006 1:53 PM
> To: SIGTRAN
> Subject: [Sigtran] Is sharing of one SCTP endpoint between
> MultipleSignalling Processes possible?
>
>
> Hello Folks,
>
[TOLGA]No, one SCTP endpoint = one ASP/IPSP
> ASP Up, ASP Down with different ASP_IDs sent over the same SCTP
[TOLGA]ASP-Id is not to identify ASPs using the saem SCTP associtiaon but to
identify ASPs which use dynamic addresses.
> the same SCTP association in the same direction?
[TOLGA]What about ASPAC? How will you distinguish, which ASP has sent the
ASPAC, ASPDN, ASPIA? Also, what is the use of such a setup?
> Is there a consensus in SIGTRAN community on this topic?
[TOLGA]As far as I can see, it won't work according to the procedures
defined in the RFC/IG. There is no ASP identifier in the messages -except
optional ASP-Id for ASPUP-, because it is assumed that this is known based
on the SCTP association the messages are received from.

---

From: "Ilie Glib" <[email-masked]>
Date: Fri, 17 Feb 2006 20:19:22 +0100

Hello Tolga,

thank you very much for your answer.
Indeed, use of ASPAC, ASPIA is a killing argument.

Regards

Ilie

--
Ilie