Subject: RE: [Sigtran] M3UA notify message

From: <[email-masked]>
Date: Thu, 23 Feb 2006 09:50:04 +0530

I am still concerned about this statement from Tolga:

" In any case, it is good that there is finally consensus regarding that
ASPSM/ASPTM procedures and associated state machines being independent
on
each SGP."

If multiple SGPs are serving a single AS, then shouldn't the ASP states
also be shared across the related SGPs?
Else if I am wrong then the following statement in section 1.4.1 should
be amended to share the AS states only.
" Where an SG contains more than one SGP, the MTP3 routeset, SPMC and
   remote AS/ASP states of each SGP SHOULD be coordinated across all the
   SGPs."

Tolga, further considering the sahring of ASP states then, in the case
of the interoperability issue (as you depicted), the rfc says that if an
ASP is already inactive the ASP-UP message would still be respnded by an
ack.

I think the things become simpler if we consider sharing of ASP states
of a particular AS across all SGPs serving that AS.

Regards,
 
Prabind

-----Original Message-----
From: Tolga Asveren [mailto:[email-masked]] 
Sent: Thursday, February 23, 2006 6:53 AM
To: [email-masked]
Subject: RE: [Sigtran] M3UA notify message

Brian,

As long as it is not an ASPSM/ASPTM procedure, it is fine. I probably
was
not careful when using the term "M3UA procedures" because it includes
pretty
much everything.

BTW, I still wouldn't call it "M3UA procedure on each SGP", because SSNM
is
not sent independently by each SGP when status of a destination in SS7
network changes. It is supposed to be sent only once, but this is
besides
the point for this thread.

In any case, it is good that there is finally consensus regarding that
ASPSM/ASPTM procedures and associated state machines being independent
on
each SGP.

  Tolga

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, February 22, 2006 8:34 PM
> To: Tolga Asveren
> Cc: [email-masked]
> Subject: Re: [Sigtran] M3UA notify message
>
>
> Tolga,
>
> By an SGP, making it an "M3UA procedure on each SGP".
>
> --brian
>
> Tolga Asveren wrote:
>    (Wed, 22 Feb 2006 18:10:02)
> > Yes, SSNM will be sent per SG.
> >
> > BTW, my messages from a few hours ago started just to arrive, not in
the
> > order I sent them.
> >
> >    Tolga
> >
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Wednesday, February 22, 2006 6:26 PM
> > > To: Tolga Asveren
> > > Cc: [email-masked]
> > > Subject: Re: [Sigtran] M3UA notify message
> > >
> > >
> > > Tolga,
> > >
> > > BTW it is used for sending SNMM from an SGP: another M3UA
> > > procedure at an SGP.
> > >
> > > --brian
> > >
> > > Tolga Asveren wrote:
> > >    (Wed, 22 Feb 2006 15:36:22)
> > > > Brian,
> > > >
> > > > Please show where in the specification it says that ASPTM/ASPSM
> > > relationship
> > > > is between ASP and SG?
> > > >
> > > >    Thanks,
> > > >    Tolga
> > > >
> > > > > -----Original Message-----
> > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > Sent: Wednesday, February 22, 2006 3:50 PM
> > > > > To: Tolga Asveren
> > > > > Cc: [email-masked]
> > > > > Subject: Re: [Sigtran] M3UA notify message
> > > > >
> > > > >
> > > > > Tolga,
> > > > >
> > > > > Tolga Asveren wrote:
> > > > >    (Wed, 22 Feb 2006 15:28:21)
> > > > > > Barry,
> > > > > >
> > > > > > Let me retry to explain my position:
> > > > > >
> > > > > > Coordination of AS/ASP is necessary to create the unique
> > > SPMC view. This
> > > > > > does not mean that the coordinated state should be used for
> > > > > M3UA procedures
> > > > > > on each SGP. Each SGP should maintain its own staet machine
> > > from ASP/SGP
> > > > > > procedures point of view.
> > > > > >
> > > > >
> > > > > Your statements conflict with the consensus that went into
> > > > > the RFC as upheld by the mailing list discussion on the
matter.
> > > > >
> > > > > --brian
> > > > >
> > > > > --
> > > > > Brian F. G. Bidulock
> > > > > [email-masked]
> > > > > http://www.openss7.org/
> > > > >
> > > > > _______________________________________________
> > > > > Sigtran mailing list
> > > > > [email-masked]
> > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > >
> > > >
> > > >
> > > >
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> > > --
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > >
> >
> >
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
>

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 22 Feb 2006 23:04:03 -0700

Prabind,

You are correct, there is a case where the ASP state is shared across
the SGPs making up an SG: in the Override traffic mode AS it is
necessary to share which ASP is "Active" and which is "Standby" as only
one ASP can be Active for the AS.

This is also a case where state transitions directly associated with
ASPTM/ASPSM message procedures must be considered on an SG-wide basis,
contrary to Tolga's previous statements on this thread.

It is possible, but perhaps less important to interoperability, that an
SG could coordinate the ASP state for ASPs in a Loadshare or Broadcast
AS.  That is, when loadsharing, the selection algorithm at an SGP could
consider the availability of ASPs to other SGPs to more equally
distribute traffic.  For Broadcast mode AS, consideration of ASP state
across the SGP could provide a more optimal broadcast of traffic (i.e.
without sending multiple messages to or missing completely an ASP).

For the case of SSNM, it is possible (but not required) for the SG to
avoid sending duplicate SSNM messagese to any given ASP.  By considering
the ASP state on an SG-wide basis, it is possible to ensure that only
one SSNM message is sent to an ASP (via only one SGP).

The override and SSNM cases were given consideration in the original
thread that led to the wording 1.4.1.  The others were not so much.

Therefore, I agree that the statement in 1.4.1 should not be ammended.

--brian

[email-masked] wrote:                (Thu, 23 Feb 2006 09:50:04)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 23 Feb 2006 08:17:20 -0500

Prabind,

> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, February 22, 2006 11:20 PM
> To: [email-masked]
[TOLGA]So are you claiming that there won't be an interoperability issue
according to the message flow I sent? Please look to steps marked with (1)
and (2). If one uses a global AS/ASP state which is SG-wide for ASPSM/ASPTM
procedures, interoperability issues will arise. OTOH, with NTFY, there is no
such danger, afterall it is just advisory.

---

From: "nitin" <[email-masked]>
Date: Thu, 23 Feb 2006 20:10:17 +0530

I am explaining some scenarios :-

1. Consider SG consisting of SGP1 and SGP2.
     Suppose an AS contain one ASP and the traffic mode of AS is override. 
     If we look in terms of SGP then this override mode
     is of no use, but if we look in terms of SG  and this ASP is making associations with 
     two SGP then this is of much significance. Actually for SGP , ASP is identified by 
     the sctp association . For even if there is only one ASP in AS but  for SGP's they
     don't know this ASP as single ASP.

        Please take AS as inactive initially on both SGP's.

     ASP                 SGP1                 SGP2           SG
      |     aspAc           |                        |                       |
      |---------------->|                       |                        |         ( please note here that i have drawn  notify from SG, 
      |<-----------------|                        |                      |            just to highlight that state of AS is maintained at SG,
      |  asp ac ack       |                        |                        |             so logically this notify is sent with respect to SG)
      |<--------------------------------------------------|
      |       notify AS active                   |                        |
      |                          |                        |                       |
      |---aspAc------------------------>|                       |
      |          aspac ack |                        |                        |
      |<----------------------------------|                        |
      |         notify Alt. Asp Ac.              |                       |
      |<--------------------------------------------------|
      |                          |                        |                        |
      |                          |                        |                       |

 Now sicne  when we have configured AS at the SG, we have configured that AS has only one SGP
 in override mode. However this override mode doesn't makes sense with one ASP in AS.

 But here what is happening that SGP's doesnot know , that it is the same ASP which is doing
 active with both SGP's. So when ASP  does active with SGP1 then AS becomes active. Now when
 ASP does active with SGP2 this is new ASP for SGP2. So what should be done in this case.Should 
 Alternate ASP active notify be sent in this case to same ASP .

2. Now consider another case. 

   In this scenario , ASP1 and ASP2 are both part of AS and SGP1 and SGP2 are both part of SG1.
   In this case assume that ASP1 and ASP2 are both inactive at their respective SGP's.
   Now my question is little bit different in this case as explained below:-

     ASP1                 ASP2                SGP1           SGP2
      |     aspAc           |                        |                       |
      |--------------------------------->|                      |         
      |<---------------------------------|                      |        
      |  asp ac ack       |                        |                        |             
      |<--------------------------------|                        |
      |       notify AS active                   |                        |
      |                          |                        |                       |
      |                                    data        |                       |
                                |---------------------------------->
      |                         |                        |                        |
      |                          |                        |
      
      |                      |                       |
      |                                                                          |
      |                          |                        |                        |
      |                          |                        |                       |

Should this data message be dropped at SG or should it be allowed to SS7 side , Since AS is active at SG
 but ASP2 is not active on SGP2.

3. Now here is the 3rd scenario , this is related to n+k AS.
     
In this case , configuration is AS consisting of ASP1 and ASP2.
SG consisting of SGP1 and SGP2. 
Obviously the traffic mode is loadshare.
Now only ASP1 is doing ASP active on SGP1 and SGP2.
ASP2 has not done any m3ua procedures with neither SGP1 , nor SGP2.

ASP1                 ASP2                SGP1           SGP2 
      |     aspAc           |                        |                       |
      |--------------------------------->|                      |         
      |<---------------------------------|                      |        
      |  asp ac ack       |                        |                        |             
      |                          |                        |
      |                          |                        |
      |                          |                        |                       |
      |----------asp Ac.---------------------------------------->|
                         
      <-----------ASP act . ack--------------------------------------- |
      |                          |                        |
      
      |<----------------------------------------------------|
      |                                                                          |
      |                          |                        |                        |
      |                          |                        |                       |

Now since ASP1 has done active on both SGP1 and SGP2 , it is active on two SGP's.
So with respect to SG two SGP's are active. Should in this case AS be active or not.

thanks
nitin

----- Original Message ----- 
From: "Brian F. G. Bidulock" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, February 23, 2006 11:34 AM
Subject: Re: [Sigtran] M3UA notify message

> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.1.375 / Virus Database: 268.0.0/267 - Release Date: 2/22/2006
> 
>

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 23 Feb 2006 08:14:41 -0500

Brian,

State sharing/State coordination etc.. are all not well defined terms. What
I mean is that each SGP needs to execute ASPTM/ASPSM state machine
procedures independently.

Please see below for more comments.

> Sent: Thursday, February 23, 2006 1:04 AM
> To: [email-masked]
> Cc: [email-masked]
[TOLGA]I disagree with this. "Override traffic mode" is applicable on the
SGP itself, it is the ASP state on each SGP, which will be used for the
decision,. Otherwise you are vioalating the principle that each SGP is
executing ASPTM/ASPSM procedures independently. Now that can effect
interoperability, we need to discuss this.
> contrary to Tolga's previous statements on this thread.
[TOLGA]Before I reply, I need to know which procedures you specifically have
inmind.
> without sending multiple messages to or missing completely an ASP).
[TOLGA]Yes, this won't effect interoperability at all.
> one SSNM message is sent to an ASP (via only one SGP).
[TOLGA]Yes not required with a "MUST", but it is common sense and is
mentioned in the RFC as well, because status of SS7 destinations is kept
gloabl in the SG, afterall it is a MTP3 entity.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 23 Feb 2006 12:26:04 -0700

Tolga,

Tolga Asveren wrote:                                                 (Thu, 23 Feb 2006 08:14:41)
> procedures independently.

One SGP cannot execute an override independent of the other SGPs (that is,
without considering which is the current primary ASP for the AS as determined
considering the ASP state in each SGP).  This is one reason why ASP state
is mentioned in 1.4.1.

If you mean to say that ASP state is maintained at the SGP for each and every
ASP to which the SGP has an association, then that is true; however, this does
not mean that the SGP can perform state machine procedures without consideration
for the state of the ASPs in other SGPs for the same AS.  Therefore, although
the ASP state is maintained in this fashion, the SGP needs to _not_ "execute
ASPTM/ASPSM state machine procedures independently".

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/