Subject: [Sigtran] [SIGTRAN -XUA]: ASPIA with no RC responded with ASPIAACK and Error code "0x1a"

From: Saraswati Bose <[email-masked]>
Date: Wed, 1 Feb 2006 04:59:59 -0800 (PST)

Hi Brian,
  Please check the below sections extracted from rfc-3868 and suggest:
  4.3.4.4. ASP Inactive Procedures:
   
                 - If the RC is missing and its specification is needed according to
                 the used configuration, the peer must respond with an ERROR
                 message with Error Code = "No Configured AS for ASP".
  Ques.Should SG encode the above error strictly as described above when same ASP serves multiple AS? 
  --------------------------------------------------------------------------------------------------------------------------
  4.3.4.4. ASP Inactive Procedures:
  [....]
           In the case where an ASP Inactive message does not contain a Routing
           Context parameter, the receiver must know, via configuration data,
           which Application Servers the ASP is a member and move the ASP to the
           ASP-INACTIVE state in each all Application Servers.
  Ques. Does this description only apply for a single ASP serving same AS?
  Or does the same also apply for same ASP serving multiple AS? I think not because then the first rule is violated. Please suggest.
   
  Regards,
  Saraswati

		
---------------------------------
 
 What are the most popular cars? Find out at Yahoo! Autos 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 1 Feb 2006 10:13:00 -0700

Saraswati,

The first says "according to the used configuration", the second says
"must know, via configuration data": that is, there is no contradiction.

--brian

Saraswati Bose wrote:                                            (Wed, 01 Feb 2006 04:59:59)
>    ----------------------------------------------------------------------
>    ----------------------------------------------------
>    Or  does the same also apply for same ASP serving multiple AS? I think
>    not because then the first rule is violated. Please suggest.
> 
>    Regards,
>    Saraswati
> 
> 
> 
>      _________________________________________________________________
> 
>    What are the most popular cars? Find out at [1]Yahoo! Autos
> 
> References
> 
>    1. http://us.rd.yahoo.com/evt=38382/_ylc=X3oDMTEzNWFva2Y2BF9TAzk3MTA3MDc2BHNlYwNtYWlsdGFncwRzbGsDMmF1dG9z/*http://autos.yahoo.com/newcars/popular/thisweek.html

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/