Subject: [Sigtran] Functionaliy of M3UA

From: "Савин Константин" <[email-masked]>
Date: Tue, 21 Feb 2006 13:07:34 +0300

Example: there is a network wtih one MGC and two SG, both affiliated to SS7 links. Than at some time one SS7 link to SG1 had been broken and SG1 sends DUNA to MGC! The question is how SG2 will know about link failure?

Stan

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 21 Feb 2006 03:18:05 -0700

óÁ×ÉÎ,

Each SG has a different Point Code in the SS7 network.  In your case, each
SG acts as an STP.  Associated pairs of STPs are normally inteconnected with
C-Links.  When SG/STP1 sends DUNA, it is because the destination cannot be
reached via either SG/STP in the pair.  Otherwise, it should not send DUNA.

If your SGs do not have different point codes, they are not SGs (they belong
to the same SPMC).  In that case, they are really SGP within a larger SG.

--brian

óÁ×ÉÎ ëÏÎÓÔÁÎÔÉÎ wrote:                                                              (Tue, 21 Feb 2006 13:07:34)
> 
>    Example:  there  is a network wtih one MGC and two SG, both affiliated
>    to  SS7  links.  Than at some time one SS7 link to SG1 had been broken
>    and  SG1  sends  DUNA  to MGC! The question is how SG2 will know about
>    link failure?
> 
> 
> 
>    Stan

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "????? ??????????" <[email-masked]>
Date: Tue, 21 Feb 2006 16:02:07 +0300

I think you didn't understood me! I'm talking about this scheme:  there is
two SP (Signalling Point) with differrent PC (Point Code); SP1(PC=1) have
SS7 link two SG1(PC=3) and SP2(PC=2) have SS7 different SS7 link two
SG2(PC=4); SP1 doesn't have any physical connection to SP2, SG2!!!! but they
have SS7-relations!
What will be if the link from SP2 ot SG2 broken?

Stan

---

From: "Sergey Mikhailov" <[email-masked]>
Date: Tue, 21 Feb 2006 16:39:06 +0300

Stan,

I suppose that in your scenario, when SG2 detects that the link to SP2 is 
broken, it may tell about it to SG1, for instance, via C-Link, along with 
sending DUNA to the concerned active ASPs (connected to this SG).

Regards,
Sergey Mikhailov.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 21 Feb 2006 06:26:21 -0700

?????,

Sorry, no relay function in M3UA.  SP1 cannot have signalling relation
with SP2 in the configuration you illustrate.

--brian

????? ?????????? wrote:                                              (Tue, 21 Feb 2006 16:02:07)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "????? ??????????" <[email-masked]>
Date: Wed, 22 Feb 2006 11:00:27 +0300

Sergey,
Thank you for understanding, it's not easy to explaine on the foreign
language. I wish you will be kind to me :)
But lets get back to my question. I can agree that SG2 may send DUNA to
concerned active ASPs(connected to both SGs and placed in MGC), but what
message should send ASP to SG1( to the other one) to tell him about link
failure (at SS7 side of the SG2) in this case? Or ASP shouldn't do it?

Stan.
P.S.
Sergey, I think you are absolutely right (about politeness)!

----- Original Message -----
From: "Sergey Mikhailov" <[email-masked]>
To: "????? ??????????" <[email-masked]>
Sent: Tuesday, February 21, 2006 4:45 PM
Subject: Re: [Sigtran] Functionaliy of M3UA

> Stan,
>
>
> I think one could be more accurate when describing a specific case. I
> supposed that you told about the link at SS7 side of SG when saying "at
some
> time one SS7 link to SG1 had been broken"... Brian may have understood it
> the same way.
>
> By the way, I would like to say that if we will keep our statements more
> polite in this mailing list, then such valuable gurus like Brian may wish
to
> explain us much more. :)
> Sincerely,
> From: "????? ??????????" <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>
> Sent: Tuesday, February 21, 2006 4:02 PM

---

From: "Sergey Mikhailov" <[email-masked]>
Date: Wed, 22 Feb 2006 11:50:32 +0300

I'm sure the ASP has nothing to do with it.
Instead, I think the SGPs can exchange this information over C-Links.

Sergey.

>> >> SG acts as an STP.  Associated pairs of STPs are normally 
>> >> inteconnected
>> > with
>> >> C-Links.  When SG/STP1 sends DUNA, it is because the destination 
>> >> cannot
>> >> be