Subject: [Sigtran] [SIGTRAN-XUA]:Clarification on Error "No configured AS for ASP"

From: Saraswati Bose <[email-masked]>
Date: Wed, 1 Feb 2006 22:07:56 -0800 (PST)

Hi Brian,
Can you please suggest one such condition where the ASP can expect 
the following error message without contradicting the second feature?

  Regards,
Saraswati.

  "Brian F. G. Bidulock" <[email-masked]> wrote:

  Saraswati,
The  first  says  "according to the used configuration", the 
second says "must   know,  via  configuration  data":  that  is,  there  is  
no contradiction.
 --brian

  Saraswati Bose wrote: (Wed, 01 Feb 2006 04:59:59)
Hi Brian,
Please  check  the  below  sections  extracted from rfc-3868 
and suggest:
  4.3.4.4. ASP Inactive Procedures:
- If the RC is missing and its specification is needed
  according to the used configuration, the peer must respond with an
  ERROR message with Error Code = "No Configured AS for ASP".
Ques.Should SG encode the above error strictly as described 
above when same ASP serves multiple AS?
   
--------------------------------------------------------------------------------------------------------------------------
4.3.4.4. ASP Inactive Procedures:
[....]
In the case where an ASP Inactive message does not contain a
Routing Context parameter, the receiver must know, via configuration
data, which Application Servers the ASP is a member and move the
ASP to the ASP-INACTIVE state in each all Application Servers.
Ques.  Does this description only apply for a single ASP 
serving multiple AS?
I think not because then the first rule is violated. Please suggest.

  Regards,
Saraswati

---------------------------------
 
 What are the most popular cars? Find out at Yahoo! Autos 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 1 Feb 2006 23:47:13 -0700

Saraswati,

When "the RC is missing and its specification is needed according
to the used configuration."

--brian

Saraswati Bose wrote:                                            (Wed, 01 Feb 2006 22:07:56)
>    "Brian F. G. Bidulock" <[1][email-masked]> wrote:
> 
>    Saraswati,
>    ----------------------------------------------------------------------
>    ----------------------------------------------------
>      _________________________________________________________________
> 
>    What are the most popular cars? Find out at [2]Yahoo! Autos
> 
> References
> 
>    1. http://us.f538.mail.yahoo.com/ym/Compose?To=[email-masked]&YY=26437&order=down&sort=date&pos=0&view=a&head=b
>    2. http://us.rd.yahoo.com/evt=38382/_ylc=X3oDMTEzNWFva2Y2BF9TAzk3MTA3MDc2BHNlYwNtYWlsdGFncwRzbGsDMmF1dG9z/*http://autos.yahoo.com/newcars/popular/thisweek.html

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/