Subject: [Sigtran] IP aliases and SCTP network paths question

From: "Davidson, Mark" <[email-masked]>
Date: Fri, 3 Mar 2006 09:18:25 -0600

When using an IP address alias on an interface, depending on the
implementation, a heartbeat ack may be sent with an IP "from" address
different than the one to which the heartbeat was sent (i.e. if the IP
layer is allowed to fill in the "from" address).  Should the receiver of
the heartbeat ack treat a heartbeat ack with correct payload but
unexpected "from" address as valid?
 
-Mark
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 3 Mar 2006 20:25:04 +0100

Hi Mark,

I would consider the received HEARTBEAT-ACK as one for the path on 
which the HEARTBEAT was
sent to...

Best regards
Michael

On Mar 3, 2006, at 16:18 Uhr, Davidson, Mark wrote:

> layer is allowed to fill in the "from" address).  Should the receiver 
> of the heartbeat ack treat a heartbeat ack with correct payload but 
> -Mark_______________________________________________
> Sigtran mailing list
> [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 3 Mar 2006 13:48:20 -0700

Mark,

I use the destination address contained in the heartbeat info
and ignore the source address for the BEAT ACK for most purposes.
However, difficulties might ensue if the source address is not
one that corresponds to at least some destination address in the
association for the peer receiving the BEAT ACK.

--brian

Michael Tuexen wrote:                       (Fri, 03 Mar 2006 20:25:04)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 3 Mar 2006 22:17:46 +0100

Brian,
see my comments in-line.
Best regards
Michael

> association for the peer receiving the BEAT ACK.
Then it is an out of the blue packet... An ABORT might be sent.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 3 Mar 2006 14:23:54 -0700

Michael,

Michael Tuexen wrote:                  (Fri, 03 Mar 2006 22:17:46)
> Then it is an out of the blue packet... An ABORT might be sent.
Yes, that was my point.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/