Subject: [Sigtran] Chunk bundling indicator ?

From: <[email-masked]>
Date: Sat, 4 Mar 2006 15:46:42 +0200

Dear Experts,

Is there any flag in an SCTP packet indicating that there is many chunks that are bundled together ? I got some captures with Ethereal and I see that a couple of different application messages behind one-single SCTP header but I couldn't find if it is stated/indicated in the SCTP header ?

Any feedback will be appreciated.

Regards

Bülent YILMAZ
Operations/R&D
Network Technologies and Architecture

************************************************************************
Bu elektronik posta ve onunla iletilen bütün dosyalar sadece göndericisi tarafindan almasi amaclanan yetkili gercek ya da tüzel kisinin kullanimi icindir.  Eger söz konusu yetkili alici degilseniz bu elektronik postanin icerigini aciklamaniz, kopyalamaniz, yönlendirmeniz ve kullanmaniz kesinlikle yasaktir ve bu elektronik postayi derhal silmeniz gerekmektedir.
TURKCELL bu mesajin icerdigi bilgilerin dogrulugu veya eksiksiz oldugu konusunda herhangi bir garanti vermemektedir.  Bu nedenle bu bilgilerin ne sekilde olursa olsun iceriginden, iletilmesinden, alinmasindan ve saklanmasindan sorumlu degildir. Bu mesajdaki görüsler yalnizca gönderen kisiye aittir ve TURKCELLin görüslerini yansitmayabilir
Bu e-posta bilinen bütün bilgisayar virüslerine karsi taranmistir.
************************************************************************
This e-mail and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you are not the intended recipient you are hereby notified that any dissemination, forwarding, copying or use of any of the information is strictly prohibited, and the e-mail should immediately be deleted.
TURKCELL makes no warranty as to the accuracy or completeness of any information contained in this message and hereby excludes any liability of any kind for the information contained therein or for the information transmission, reception, storage or use of such in any way whatsoever.  The opinions expressed in this message belong to sender alone and may not necessarily reflect the opinions of TURKCELL.
This e-mail has been scanned for all known computer viruses.
************************************************************************

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 4 Mar 2006 14:28:22 -0700

bulent.yilmaz,

B and E bits in the DATA Chunk header.

--brian

[email-masked] wrote:                         (Sat, 04 Mar 2006 15:46:42)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Michael Tuexen <[email-masked]>
Date: Sun, 5 Mar 2006 12:16:36 +0100

Hi Bülent,

there is no indication in the SCTP common header how many chunks are  
present
in the packet. Any number (even 0) is allowed.

Because the chunks have a tag-length-value (TLV) structure the receiver  
and even
ethereal can understand the structure of the packet.

It is OK to have multiple chunks (even, multiple DATA chunks) in one  
packet.

Best regards
Michael

On Mar 4, 2006, at 14:46 Uhr, <[email-masked]> wrote:

> Dear Experts,
>
> Is there any flag in an SCTP packet indicating that there is many  
> chunks that are bundled together ? I got some captures with Ethereal  
> and I see that a couple of different application messages behind  
> one-single SCTP header but I couldn't find if it is stated/indicated  
> in the SCTP header ?
>
> Bu elektronik posta ve onunla iletilen bütün dosyalar sadece  
> göndericisi tarafindan almasi amaclanan yetkili gercek ya da tüzel  
> kisinin kullanimi icindir.  Eger söz konusu yetkili alici degilseniz  
> bu elektronik postanin icerigini aciklamaniz, kopyalamaniz,  
> yönlendirmeniz ve kullanmaniz kesinlikle yasaktir ve bu elektronik  
> postayi derhal silmeniz gerekmektedir.
> TURKCELL bu mesajin icerdigi bilgilerin dogrulugu veya eksiksiz oldugu  
> konusunda herhangi bir garanti vermemektedir.  Bu nedenle bu  
> bilgilerin ne sekilde olursa olsun iceriginden, iletilmesinden,  
> alinmasindan ve saklanmasindan sorumlu degildir. Bu mesajdaki görüsler  
> yalnizca gönderen kisiye aittir ve TURKCELLin görüslerini  
> yansitmayabilir
> This e-mail and any files transmitted with it are confidential and  
> intended solely for the use of the individual or entity to whom they  
> are addressed. If you are not the intended recipient you are hereby  
> notified that any dissemination, forwarding, copying or use of any of  
> the information is strictly prohibited, and the e-mail should  
> immediately be deleted.
> TURKCELL makes no warranty as to the accuracy or completeness of any  
> information contained in this message and hereby excludes any  
> liability of any kind for the information contained therein or for the  
> information transmission, reception, storage or use of such in any way  
> whatsoever.  The opinions expressed in this message belong to sender  
> alone and may not necessarily reflect the opinions of TURKCELL.