Subject: RE: [Sigtran] survey of UA implementations

From: "Haresign Lincoln" <[email-masked]>
Date: Tue, 7 Mar 2006 16:19:51 -0500

For some reason, I didn't receive Lyndon's original email, but only Michael's follow-up.

We have implemented:

M2PA
M3UA
SUA

We done limited testing with all three against various test devices, switches, and IETF interops and more extensive testing with M3UA.  Currently, M3UA is getting the most productization and is deployed in several sites for a couple years.  SUA is currently being used for our internal architecture and typically does not interact with 3rd party equipment.  Since we are building eqiupment for the edge of the network, we haven't had any customer interest in M2PA which we typically see being used in the CORE of the network.  We build Voice Mail systems, SMSCs, PrePaid systems, Intelligent Peripherals, and many other SCP or SCP-like boxes for deploying Value Added services in the wireless and wireline networks.

Regards,
Lincoln

-----Original Message-----
From: Michael Tuexen [mailto:[email-masked]] 
Sent: Monday, March 06, 2006 5:58 AM
To: Ong, Lyndon
Cc: [email-masked]
Subject: Re: [Sigtran] survey of UA implementations

Hi Lyndon,

see my comments in-line.

Best regards
Michael

On Mar 6, 2006, at 6:06 Uhr, Ong, Lyndon wrote:

> Hi Folks,
>  
> To get an idea of the actual usage of the specs, I would like to take 
> a poll for input from those people who have done
>
> implementations and products for the following information:
>  
> -- what UAs have you implemented?
> -- what UAs have you tested with others?
> -- what UAs have you productized?
> -- what UAs have been deployed in active use?
> -- what kind of applications have they been used for?
It is not an implementation and I'm not sure if it counts as a product (since it is free), but Ethereal (http://www.ethereal.com) is a packet analyzer which supports all SIGTRAN protocols.
It has been tested at every SIGTRAN Interop and I think it is in active use...
>  
> Responses can be sent privately to me if desired (note I no longer 
> work for a company that has any products in this area).
>  
> I'll compile any responses and put the results out on the mailing 
> list, leaving out names.
>  
> Thanks,
>  
> Lyndon
>  
>  _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran
--------------------------------------------------------------------
This email message has been scanned by Comverse mail security system

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Ong, Lyndon" <[email-masked]>
Date: Fri, 10 Mar 2006 19:09:55 -0500

Hi Folks,
 
Survey results so far show the following (out of 7 companies
responding):
 
iua: 3 implementations 
m2ua: 3 implementations 
m3ua: 7 implementations 
sua: 5 implementations
m2pa: 5 implementations
v5ua: 1 implementation
dua: 2 implementations
 
Generally almost all of the implementations have been tested and
deployed as products,
although one respondent noted that their m2pa implementation was
initially productized
but is no longer deployed for lack of interest.
 
Applications used included signaling backhaul (of course), as well as
SMS, voicemail
systems, intelligent peripherals and link consolidation.
 
Thank you for your help!
 
Cheers,
 
Lyndon

---

From: "McCandless, Kevin" <[email-masked]>
Date: Wed, 15 Mar 2006 15:30:12 -0600

We also support the following as access methods to our network:  SUA,
M3UA, and M2PA.

________________________________

From: Ong, Lyndon [mailto:[email-masked]] 
Sent: Friday, March 10, 2006 6:10 PM
To: [email-masked]
Cc: Peterson, Jon
Subject: RE: [Sigtran] survey of UA implementations

Hi Folks,

iua: 3 implementations 

m2ua: 3 implementations 

m3ua: 7 implementations 

sua: 5 implementations

m2pa: 5 implementations

v5ua: 1 implementation

dua: 2 implementations

Thank you for your help!

Cheers,

Lyndon