Subject: [Sigtran] M3UA_"ts_102381v010101p.pdf" TestPlan Clarification

From: Saraswati Bose <[email-masked]>
Date: Wed, 10 May 2006 06:05:40 -0700 (PDT)

Hi All,
   
  As per the spec “ts_102381v010101p.pdf” please suggest in the below.
  1. M3UA_SGP_ASPSM_V_001

Pre-condition      Successfully established SCTP association between the  SGP and the ASP. ASP marked as ASP-DOWN at the SGP
  
    Reference        Section 4.3.1 [1] Section 4.3.4.1 [1]
  Purpose         Ensure that the IUT, upon reception of an ASP Up  message, responds     with an ASP Up Ack.
  
    Comments:       This test case, even though included in   M3UA_SGP_ASPSM_v_003    
      validates the response with an ASP Up Ack  regardless of the number of ASPs    
      configured in the AS.

  Query:
   In the above test plan, whether more than one ASPs will be configured in 
   the AS and ASP UP message will be send from the all the configured ASPs   or only
    one ASP will be configured in the AS and ASP  UP message will be send   from the   
      ASP only?

 2.M3UA_SGP_ASPTM_V_001

  Pre-condition: Successfully established SCTP association  between the SGP and  
    the ASP. PsPs ASP marked as ASP-INACTIVE at the SGP
    
  Reference:Section 4.3.1 [1] Section 4.3.4.3 [1]
    
  Purpose Ensure that the IUT, upon reception of an ASP  Active message, responds with 
     an   ASP Active Ack
  Query:
   In the above plan there should be at least two ASPs in the AS and one  should be in the   
     ASP ACTIVE state and other should be in the ASP  INACTIVE  state. other wise if    
     there is only one ASP in the AS, then NOTIFY  message should be send after sending  
     ASP ACTIVE ACK, indicating AS state  change to ASP ACTIVE?

    
  3.M3UA_SGP_ASPTM_I_009
    Status                 Optional
   
    Pre-condition           Successfully established SCTP association  between the SGP and  
      the ASP  2 ASPs in AS ASPs marked as ASP-ACTIVE at the       SGP
    Reference             Section 3.8.2 [1] Section 4.3.3 [1]
    
  Purpose: Ensure that the IUT that has lost SCTP  connectivity with ASP1 sends a   
    NOTIFY  message with status "ASP Failure" to ASP2
  Query:
     Here whether we have to abort the sctp association between SGP and ASP1  or  after  
     sending heartbeat message  for PATH.MAX .RX times, we have to   send NTFY   
     message to ASP2?
       
   4. M3UA_SGP_MTR_V_001
    Status                 Optional
    Pre-condition           Successfully established SCTP association  between the SGP and 
      the ASP. ASPs marked as ASP Active at the SGP  Multiple Routing Keys and Routing 
      Contexts are being used across a   common association
    Reference             Section 3.3.1 [1]
    Purpose               Ensure that the IUT includes a valid Routing =
    Context in any Payload Data Message
    Query:
      Here how many ASPs will be active at the SGP and whether routing 
    procedure is to be done before the ASP s bring to ASP ACTIVE state?
    
    To my knowledge for the above test plan only one ASP will be there 
    and which is configured to server more than one AS. so that RES REQ
    and ASP ACTIVE message will be send with more than one routing keys and 
    RCs respectively.
    
   5.    M3UA_SGP_MTR_V_003
      Status                 Mandatory
    Pre-condition           Successfully established SCTP association  between the SGP and   
      the ASP
    Reference             Section 4.1.1 [1]
    Purpose               Ensure that the IUT sends DATA messages on any   valid SCTP  
      stream other than stream "0".
  
      Query:
       Here the  pre-condition tell only SCTP association is established   between SGP and  
       ASP. So how DATA message can be send, when ASP is in   DOWN  state.
     So here the pre-condition should be ASP in ACTIVE at the SGP?

      6.M3UA_SGP_RKM_I_014
    Pre-condition           Successfully established SCTP association    between the SGP and   
      the ASP. ASP marked as ASP-INACTIVE at the SGP.   AS in Loadshare mode 
    SGP does support the Routing Key Management Procedures SGP does support 
      dynamic configuration of Routing Keys
    Reference Section 3.6.2 [1] Section 4.4.1 [1]
    Purpose Ensure that the IUT, upon reception of a first REG  REQ that specifies a     
  Traffic Mode Type of Loadshare, followed, once the  first REG REQ has been ACKed, by a second REG REQ that specifies a Traffic Mode Type of Override, responds to the second REG REQ with a REG   RSP with Registration Result 10 "Error-Unsupported/Invalid Traffic   Handling Mode"

  Query:
  Here the AS in load share mode. This implies that there should be more than one ASPs. so whether the second REG REQ  message will be send from   alternate ASP or from the ASP, from where the first REG REQ  is send?

---------------------------------
Yahoo! Mail goes everywhere you do.  Get it on your phone.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 10 May 2006 12:29:18 -0600

Saraswati,

Please see comments inline...

Saraswati Bose wrote:                           (Wed, 10 May 2006 06:05:40)
> 
>    Hi All,
> 
> 
> 
>    As per the spec ts_102381v010101p.pdf please suggest in the below.
> 
>    1. M3UA_SGP_ASPSM_V_001
>    Pre-condition       Successfully  established SCTP association between
>    the  SGP and the ASP. ASP marked as ASP-DOWN at the SGP
> 

Yes, each ASP sends ASP Up Ack in response to ASP Up regardless of the number
of ASPs configured for the AS, just as the comment says.

>       ASP ACTIVE ACK, indicating AS state  change to ASP ACTIVE?

Yes, as NOTIFY must be sent.  Perhaps you could take this up with ETSI as it
is their document?

>        sending  heartbeat  message   for  PATH.MAX  .RX times, we have to

Abort is one way to do it; I would just pull the RJ-45 out, but for automated
testing the ABORT is probably better.

>         procedure  is  to  be  done  before the ASP s bring to ASP ACTIVE

The pre-condition says that (all of) the ASPs are marked as ASP Active at
the SGP.
>         So here the pre-condition should be ASP in ACTIVE at the SGP?

Another one to take up with ETSI?

>    Traffic  Mode Type of Loadshare, followed, once the  first REG REQ has
>    been  ACKed, by a second REG REQ that specifies a Traffic Mode Type of
>    Override,  responds  to  the  second  REG  REQ  with  a REG   RSP with
>    Registration  Result  10 "Error-Unsupported/Invalid Traffic   Handling
>    Mode"
> 
>    Query:
> 
>    Here the AS in load share mode. This implies that there should be more
>    than  one  ASPs.  so  whether the second REG REQ  message will be send
>    from   alternate ASP or from the ASP, from where the first REG REQ  is
>    send?

It is sent from the same ASP as the first REG REQ.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/