Subject: RE: [Sigtran] (M2PA) Initial version of M2PA IG is Now Available

From: "Ong, Lyndon" <[email-masked]>
Date: Wed, 24 May 2006 19:51:15 -0400

Ouch, I see we still have a disagreement here.  Are there any
points in Jeff's document that you agree with?   Are there 
issues that you feel were missed in the document?

Also, what are other peoples' views, esp. those that have
participated in the bakeoffs?

Advancing the test spec is I think a separate topic.

Thanks,

L. Ong 

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Wednesday, May 24, 2006 10:40 AM
To: Ong, Lyndon
Cc: [email-masked]; Craig, Jeffrey
Subject: Re: [Sigtran] (M2PA) Initial version of M2PA IG is Now
Available

Lyndon,

On the contrary, in my case silence means that I disagree with the
entire document.  IMHO it represents the author's views only, does not
capture any discussions from the working group, and is unsuitable in its
current form as a WG item.

OTOH, as test specs are suitable as informational RFCs, and there is, of
yet, no other industry test specification for M2PA, I suggest that
draft-bidulock-sigtran-m2pa-test-06.txt be advanced as an informational
RFC.

--brian

Lyndon Ong wrote:                                (Wed, 24 May 2006
10:42:57)
> 
>    Hi Folks,
> 
> 
> 
>    I have not seen any comments on Jeff's first draft of the M2PA IG,
> 
>    so assuming that silence means no concerns - are there objections
> 
>    to making the next version a WG draft?
> 
> 
> 
>    Cheers,
> 
> 
> 
>    L. Ong
>      _________________________________________________________________
> 
>    From: Craig, Jeffrey [mailto:[email-masked]]
>    Sent: Thursday, May 11, 2006 1:38 PM
>    To: [email-masked]
>    Subject: [Sigtran] (M2PA) Initial version of M2PA IG is Now 
> Available
> 
>    Hello All,
> 
> 
> 
>    The initial version of the M2PA Implementer's Guide is now
available.
[1]http://www.ietf.org/internet-drafts/draft-craig-sigtran-m2pa-ig-00.
>    txt
> 
>    Regards,
> 
>    Jeff
> 
> References
> 
>    1. 
> http://www.ietf.org/internet-drafts/draft-craig-sigtran-m2pa-ig-00.txt

> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 24 May 2006 19:00:40 -0600

Lyndon,

Sorry, I read through it again, and there is not one major bullet in
section 2 that I can agree with.  IMO they are all incorrect, out of
scope, unnecessary or already provided for in test specification.

This process strike me a rather backwards: normally the WG has
discussion to convince the editor of an IG to include an item in the IG,
rather than the editor of the IG trying to convince the WG that some
item needs to be included.  At least this is how we have operated in the
past and I believe that it makes sense.  That is the easiest way to
ensure that the IG represents concensus within the WG.  By reversing the
process, the IG does not represent the concensus of the WG.

I would gladly discuss any of these points within the WG, particularly
with the other authors of the RFC, but I feel that it would be a waste
of time to argue them with the IG's author when noone else in the WG seems
to care to discuss them.

Contrary to the legal principle, silence in this case might mean
absence rather than consent. ;)

What happened to moving the WG to another area?  I thought that the
WG items were complete...  Are you suggesting that we recharter to
include an M2PA-IG as a work item?  What about the SUA-IG?  Should
we not complete an rfc3868bis incorporating the SUA-IG or move the
SUA-IG to an RFC?  The SUA-IG is already a WG item and currently
is the only oustanding item to completing the charter.

--brian

Lyndon Ong wrote:                            (Wed, 24 May 2006 19:51:15)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 25 May 2006 11:28:17 +0200

Hi Lyndon,

I think it makes sense to have an IG. I think we need some
discussion on the points in the IG on the mailing list
to figure out if there is consensus.

I do not think that it is not enough to provide clarifications
in test specifications. If there is a need for clarification,
it should go into the protocol spec.

Regarding the interop experience. M2PA has been tested and
there where some issues related to unclear text in the spec.
That is why there are some clarifications in the IG. Unfortunately
the Interops have changed: The first SIGTRAN interops where attended
mostly by people aslo active on this list. The later interops
where attended mostly by people not active on this list. So they will
not represent interop issues here with multiple voices...

Best regards
Michael

On May 25, 2006, at 3:00 AM, Brian F. G. Bidulock wrote:

> 19:51:15)

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 25 May 2006 03:59:15 -0600

Michael,

I agree, a test spec is not for clarification.  What it does provide,
however, is 96 crystal clear examples.  I don't believe that Jeffrey's
IG clarifies anything.  It may even muddle some points.

Issues posted here from the last interop were dealt with on the
list and by the RFC.  The last change was made at 48 hours.  There
were no items outstanding and there has not been an interop since.

If someone other else feels that there is an issue with the M2PA
protocol as expressed by the RFC, please post it and let us discuss it.

--brian

Michael Tuexen wrote:                        (Thu, 25 May 2006 11:28:17)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/