Subject: RE: [Sigtran] M2PA - SIB vs. SCTP association level flow-control

From: "Craig, Jeffrey" <[email-masked]>
Date: Tue, 9 May 2006 07:11:06 -0500

Hello Stanislav,
 
LS Busy is used by M2PA to inform the peer that it cannot acknowledge received
messages due to implementation-dependent reasons, such as the MTP3 instance
is not receiving messages fast enough. You are correct that M2PA can simply stop
receiving from the association in this situation, but the LS Busy provides an explicit
mechanism for signaling to the peer the reason for congestion, thereby enhancing
servicibility.
 
Coincidentally, I submitted the first draft M2PA IG yesterday, draft-craig-sigtran-m2pa-ig-00.txt.
It should become available on the IETF draft website soon.
 
Regards,
 
Jeff

________________________________

From: Stanislav Ivanovich [mailto:[email-masked]] 
Sent: Tuesday, May 09, 2006 7:15 AM
To: SIGTRAN
Subject: [Sigtran] M2PA - SIB vs. SCTP association level flow-control

Hello colleagues,
 
M2PA RFC defines the protocol which is to provide the MTP L2 services and functions together with underlying SCTP protocol. I see that most important MTP L2 features (like error detection and correction, supervision, alignment etc...) are replaced with corresponding SCTP functions.
 
However I am wondering why would one need SIB (or in M2PA terminology "Link Status Busy") if:
 
a) the relationship between SCTP association and M2PA link is 1:1
 
b) SCTP provides the means to stop acknowledging incoming traffic if the local user stops to read the messages (i.e. local user function does not invoke recvmsg() on the socket API thus causing filling of the receiving buffer at local SCTP thus causing stop of acknowledgment of incoming traffic which in turn causes closing of the cwnd at the remote SCTP at the sender side)
 
I am asking this question since maybe I missed something...

I am also wondering is there any preliminary version of the M2PA Implementor's guide available?
 
thank you for your cooperation!
 
best regards/ Stanislav Ivanovich

________________________________

Love cheap thrills? Enjoy PC-to-Phone calls to 30+ countries <http://us.rd.yahoo.com/mail_us/taglines/postman9/*http://us.rd.yahoo.com/evt=39666/*http://messenger.yahoo.com/>  for just 2¢/min with Yahoo! Messenger with Voice.
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Stanislav Ivanovich <[email-masked]>
Date: Tue, 9 May 2006 05:33:15 -0700 (PDT)

Hello Jeff,
   
  Thank you!
   
  In addition I would say that actually explicit indication as proposed by the RFC also helps separation of M2PA->MTP3 from SCTP->M2PA flow-controls. I mean if one stops reading the sockets just to signal congestion of the local MTP3 he might lose opportunity to promptly react on M2PA signals (e.g. processor outage etc...) thus affecting M2PA internal procedures...
   
  So M2PA should read the sockets to receive all the management signals on the M2PA level but signal LS_Busy when the MTP3 instance gets congested.
   
  thank you again and best regards/ Stanisalv Ivanovich

"Craig, Jeffrey" <[email-masked]> wrote:
      Hello Stanislav,

   
  Regards,
   
  Jeff

---------------------------------
  From: Stanislav Ivanovich [mailto:[email-masked]] 
Sent: Tuesday, May 09, 2006 7:15 AM
To: SIGTRAN
Subject: [Sigtran] M2PA - SIB vs. SCTP association level flow-control

  Hello colleagues,

   

   

---------------------------------
  Love cheap thrills? Enjoy PC-to-Phone calls to 30+ countries for just 2¢/min with Yahoo! Messenger with Voice. 

---------------------------------
New Yahoo! Messenger with Voice. Call regular phones from your PC and save big.