Subject: RE: [Sigtran] (M2PA) Initial version of M2PA IG is Now Available

From: "Davidson, Mark" <[email-masked]>
Date: Thu, 25 May 2006 08:25:27 -0500

Brian's objections are the same ones he raised before Jeff's draft was
even written.

I was at the M2PA plugtest and I will say that most of the issues in
Jeff's draft did not appear (the one I know of for sure was that not
everyone had the same initial FSN).  But the testing I saw only covered
basic alignment, traffic handling, processor outage of in-service links
and congestion.  Issues such as processor outage and recovery during
proving were not tested to my knowledge.  

The additional states introduced by the processor outage recovery
procedure (waiting for an LSR on stream 1) introduces several issues
that should be clarified (or failing the link should be an option as
they really aren't worth the effort required to solve them).

Some of the issues in the draft WERE discussed on this list (e.g.
alignment bugs in Q.703 SDLs) and satisfactory answers were not
forthcoming.

It is certainly better to have the discussion than not to, and protocol
issues/clarification do belong in an IG.

-Mark Davidson

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Wednesday, May 24, 2006 1:40 PM
To: Ong, Lyndon
Cc: Craig, Jeffrey; [email-masked]
Subject: Re: [Sigtran] (M2PA) Initial version of M2PA IG is Now
Available

Lyndon,

On the contrary, in my case silence means that I disagree with the
entire document.  IMHO it represents the author's views only, does not
capture any discussions from the working group, and is unsuitable in its
current form as a WG item.

OTOH, as test specs are suitable as informational RFCs, and there is, of
yet, no other industry test specification for M2PA, I suggest that
draft-bidulock-sigtran-m2pa-test-06.txt be advanced as an informational
RFC.

--brian

Lyndon Ong wrote:                                (Wed, 24 May 2006
10:42:57)
> 
>    Hi Folks,
> 
> 
> 
>    I have not seen any comments on Jeff's first draft of the M2PA IG,
> 
>    so assuming that silence means no concerns - are there objections
> 
>    to making the next version a WG draft?
> 
> 
> 
>    Cheers,
> 
> 
> 
>    L. Ong
>      _________________________________________________________________
> 
>    From: Craig, Jeffrey [mailto:[email-masked]]
>    Sent: Thursday, May 11, 2006 1:38 PM
>    To: [email-masked]
>    Subject: [Sigtran] (M2PA) Initial version of M2PA IG is Now 
> Available
> 
>    Hello All,
> 
> 
> 
>    The initial version of the M2PA Implementer's Guide is now
available.
[1]http://www.ietf.org/internet-drafts/draft-craig-sigtran-m2pa-ig-00.
>    txt
> 
>    Regards,
> 
>    Jeff
> 
> References
> 
>    1. 
> http://www.ietf.org/internet-drafts/draft-craig-sigtran-m2pa-ig-00.txt

> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 25 May 2006 16:39:06 -0600

Davidson,,

Davidson, Mark wrote:                                           (Thu, 25 May 2006 08:25:27)
> proving were not tested to my knowledge.  

I agree that it would be a good starting point to strike all items from
Jeffery's IG expect the FSN.

> they really aren't worth the effort required to solve them).

That was the change made at 48 hours.  There is no waiting for LSR state
in the RFC.

> alignment bugs in Q.703 SDLs) and satisfactory answers were not

Which issues where those?  I don't think that bugs in SDLs developed by
the ITU are within the scope of M2PA.  Do you?

> issues/clarification do belong in an IG.

Yes, I agree, after the disccussion, not before it as we have now.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/