Subject: [Sigtran] M2PA - SIB vs. SCTP association level flow-control

From: Stanislav Ivanovich <[email-masked]>
Date: Tue, 9 May 2006 04:14:30 -0700 (PDT)

Hello colleagues,
   
  M2PA RFC defines the protocol which is to provide the MTP L2 services and functions together with underlying SCTP protocol. I see that most important MTP L2 features (like error detection and correction, supervision, alignment etc...) are replaced with corresponding SCTP functions.
   
  However I am wondering why would one need SIB (or in M2PA terminology "Link Status Busy") if:
   
  a) the relationship between SCTP association and M2PA link is 1:1
   
  b) SCTP provides the means to stop acknowledging incoming traffic if the local user stops to read the messages (i.e. local user function does not invoke recvmsg() on the socket API thus causing filling of the receiving buffer at local SCTP thus causing stop of acknowledgment of incoming traffic which in turn causes closing of the cwnd at the remote SCTP at the sender side)
   
  I am asking this question since maybe I missed something...

  I am also wondering is there any preliminary version of the M2PA Implementor's guide available?
   
  thank you for your cooperation!
   
  best regards/ Stanislav Ivanovich

---------------------------------
Love cheap thrills? Enjoy PC-to-Phone  calls to 30+ countries for just 2¢/min with Yahoo! Messenger with Voice.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 9 May 2006 05:45:49 -0600

Stanislav,

Please see comments inline...

Stanislav Ivanovich wrote:                                      (Tue, 09 May 2006 04:14:30)
> 
>    Hello colleagues,
> 
> 
> 
>    M2PA  RFC defines the protocol which is to provide the MTP L2 services
>    and  functions together with underlying SCTP protocol. I see that most
>    important  MTP  L2  features  (like  error  detection  and correction,
>    supervision,  alignment  etc...)  are replaced with corresponding SCTP
>    functions.
> 
> 
> 
>    b)  SCTP  provides the means to stop acknowledging incoming traffic if
>    the  local  user  stops to read the messages (i.e. local user function
>    does  not  invoke  recvmsg() on the socket API thus causing filling of
>    the receiving buffer at local SCTP thus causing stop of acknowledgment
>    of  incoming  traffic  which in turn causes closing of the cwnd at the
>    remote SCTP at the sender side)
> 
> 
> 

M2PA provides its own acknowlegdement of messages separate from SCTP.  This
is for a number of reasons.  SIB is necessary for the receiver to indicate
that it might not acknowledge a message within T7.

>    Implementor's guide available?

Not that I know of.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/