Subject: [Sigtran] Data and Sack bundling in SCTP

From: "Ambika Prasad" <[email-masked]>
Date: Mon, 3 Jul 2006 17:48:33 +0530

Hi All

    I have one doubt is SCTP bundling since this point is not clear on rfc-2960. The doubt is:

    Can one SCTP packet contain more than one SACK with multiple Data chunk.

    If one can, then as per the RFC-2960 then all the SACK chunks must be appear at the beginning of the SCTP packet is possible?

BR
Ambika Prasad

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 3 Jul 2006 07:09:27 -0600

Ambika,

Ambika Prasad wrote:                            (Mon, 03 Jul 2006 17:48:33)
>         Can one SCTP packet contain more than one SACK with multiple Data

There is no point to putting multiple SACKs in the same packet: one SACK
can hold all the information.

>        If one can, then as per the RFC-2960 then all the SACK chunks must
>    be appear at the beginning of the SCTP packet is possible?

The SACK must precede data chunks.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/