Subject: [Sigtran] [SCTP] Minimum DATA Length possible

From: ash kat <[email-masked]>
Date: Wed, 19 Jul 2006 03:35:00 -0700 (PDT)

Hi All
   
  What is the minimum possible length of user DATA which can be sent by SCTP DATA chunk?
   
  ------------------------------
  1. As per Section 3.3.1 of
  draft-ietf-tsvwg-2960bis-02
  ------------------------------
  "   Length: 16 bits (unsigned integer)
        This field indicates the length of the DATA chunk in bytes from
      the beginning of the type field to the end of the user data field
      excluding any padding.  A DATA chunk with no user data field will
      have Length set to 16 (indicating 16 bytes)."
   
  This indicate that user data of length zero can be sent by setting "length" field in the DATA chunk to 16, which is the DATA chunk header length. It means no user data in the DATA chunk.
   
  However as per
  ------------------------------
  Section 3.3.10.9 of
  draft-ietf-tsvwg-2960bis-02
  ------------------------------
   
  " 3.3.10.9.  No User Data (9)
     Cause of error
     ---------------
     No User Data: This error cause is returned to the originator of a
   DATA chunk if a received DATA chunk has no user data. "
   
  So my point is that - 
  If the length field in the DATA chunk Header will be of 16 bytes then there will be no user data in the DATA chunk and when there will be no user data in the DATA chunk the SCTP will returm error.
  So why it is allowed by SCTP to send DATA chunk with no user data when it is not accepted by the peer SCTP.
   
  Thanks & Regards,
  --Ashwani Kathuria
  FSS India

---------------------------------
See the all-new, redesigned Yahoo.com.  Check it out.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 19 Jul 2006 06:27:25 -0600

ash,

ash kat wrote:                                   (Wed, 19 Jul 2006 03:35:00)
>    What  is the minimum possible length of user DATA which can be sent by

1-byte.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/