Subject: [Sigtran] SCTP: Un ordered delivery mode and SACK generation

From: Saraswati Bose <[email-masked]>
Date: Tue, 25 Jul 2006 21:07:56 -0700 (PDT)

Hi Brian,
  Is the following true for the case of unordered data delivery mode and sack generation in sctp? Like,
  When delivery mode is un ordered then is it true that the sctp sender need not wait for sack (acknowledgement) as receiver may not send sack?
   
  Also in this mode of data delivery is it true that there is no need of data Rx?
   
  Though am not sure about the above assumptions as sack generation is related to tsn while delivery mode is related to ssn.
  Please suggest.
   
  Regards,
  Saraswati.

---------------------------------
Do you Yahoo!?
 Next-gen email? Have it all with the  all-new Yahoo! Mail Beta.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 25 Jul 2006 22:19:14 -0600

Saraswati,

Saraswati Bose wrote:                         (Tue, 25 Jul 2006 21:07:56)
> 
>    Though am  not  sure about the above assumptions as sack generation is
>    related to tsn while delivery mode is related to ssn.

Yes, SACK generation is based on TSN and is independent of delivery mode.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/