Subject: [Sigtran] Re: Sigtran Digest, Vol 27, Issue 16

From: "Ambika Prasad" <[email-masked]>
Date: Mon, 31 Jul 2006 12:46:41 +0530

Hi Folk

    I have one doubt regarding SACK generation.

1. Is it mandatroy to send SACK for every two SCTP data packets?

2. If one receives 50 SCTP data packet within (say) 50ms then should we 
generate approxmately 25 SACK for these 50 SCTP packets?

3.Think, if u generate only one SACK for those 50 data packets comming 
within few span of time, is there any problem? (By this way one can avoid 24 
SACK message overhead)

Thanks and Regards

Ambika Prasad Tripathy

Nethawk Networks India Pvt. Ltd.
Tower-2000, 5th floor
Mancheswar, Bhubaneswar
Orissa, India
web: www.nethawk.fi
cell: 91-94375 47730
IM: ambika_tripathy
----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, July 19, 2006 9:30 PM
Subject: Sigtran Digest, Vol 27, Issue 16

> Send Sigtran mailing list submissions to
> [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
> https://www1.ietf.org/mailman/listinfo/sigtran
> or, via email, send a message with subject or body 'help' to
> [email-masked]
>
> You can reach the person managing the list at
> [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Sigtran digest..."
>
>
> Today's Topics:
>
>   1. Re: [SCTP] Minimum DATA Length possible (Brian F. G. Bidulock)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Wed, 19 Jul 2006 06:27:25 -0600
> From: "Brian F. G. Bidulock" <[email-masked]>
> Subject: Re: [Sigtran] [SCTP] Minimum DATA Length possible
> To: ash kat <[email-masked]>
> Cc: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=us-ascii
>
> ash,
>
> ash kat wrote:                                   (Wed, 19 Jul 2006 
> 03:35:00)
>>
>>    What  is the minimum possible length of user DATA which can be sent by
>>    SCTP DATA chunk?
>
> 1-byte.
>
> --brian
>
>
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
>
>
>
> ------------------------------
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
>
>
> End of Sigtran Digest, Vol 27, Issue 16
> *************************************** 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Ashish Soregaonkar" <[email-masked]>
Date: Mon, 31 Jul 2006 13:16:52 +0530

My view below.

> 1. Is it mandatroy to send SACK for every two SCTP data packets?

[Ashish]  No . It is not. I think this is just a recommendation.

> generate approxmately 25 SACK for these 50 SCTP packets?

[Ashish] Again No.

> within few span of time, is there any problem? (By this way one can avoid

[Ashish]  This has more to do with how soon will the peer get congested if
it does not received a timely SACK. If the peer has a big enough transmit
buffer and can hold more un-acknowledged messages, then SACKing every 50
data chunks should be fine.

Thanks and Regards