Subject: [Sigtran] [SCTP] Minimum DATA Length possible

From: ash kat <[email-masked]>
Date: Wed, 19 Jul 2006 03:35:51 -0700 (PDT)

Hi All
   
  What is the minimum possible length of user DATA which can be sent by SCTP DATA chunk?
   
  ------------------------------
  1. As per Section 3.3.1 of
  draft-ietf-tsvwg-2960bis-02
  ------------------------------
  "   Length: 16 bits (unsigned integer)
        This field indicates the length of the DATA chunk in bytes from
      the beginning of the type field to the end of the user data field
      excluding any padding.  A DATA chunk with no user data field will
      have Length set to 16 (indicating 16 bytes)."
   
  This indicate that user data of length zero can be sent by setting "length" field in the DATA chunk to 16, which is the DATA chunk header length. It means no user data in the DATA chunk.
   
  However as per
  ------------------------------
  Section 3.3.10.9 of
  draft-ietf-tsvwg-2960bis-02
  ------------------------------
   
  " 3.3.10.9.  No User Data (9)
     Cause of error
     ---------------
     No User Data: This error cause is returned to the originator of a
   DATA chunk if a received DATA chunk has no user data. "
   
  So my point is that - 
  If the length field in the DATA chunk Header will be of 16 bytes then there will be no user data in the DATA chunk and when there will be no user data in the DATA chunk the SCTP will returm error.
  So why it is allowed by SCTP to send DATA chunk with no user data when it is not accepted by the peer SCTP.
   
  Thanks & Regards,
  --Ashwani Kathuria
  FSS India

 __________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 19 Jul 2006 12:43:21 +0200

Hi,

I'm sending the answer also to TSVWG, where the SCTP related things  
are discussed now...
draft-ietf-tsvwg-2960bis-02 should be changed to state

A DATA chunk with a user data field of length L will have Length set  
to (16 + L)
(indicating 16+L bytes).

I consider this editorial.

Best regards
Michael

On Jul 19, 2006, at 12:35 PM, ash kat wrote:

> This indicate that user data of length zero can be sent by setting  
> "length" field in the DATA chunk to 16, which is the DATA chunk  
> header length. It means no user data in the DATA chunk.
>
> However as per
> If the length field in the DATA chunk Header will be of 16 bytes  
> then there will be no user data in the DATA chunk and when there  
> will be no user data in the DATA chunk the SCTP will returm error.
> So why it is allowed by SCTP to send DATA chunk with no user data  
> when it is not accepted by the peer SCTP.
>
> Thanks & Regards,
> --Ashwani Kathuria
> FSS India

---

From: ash kat <[email-masked]>
Date: Wed, 19 Jul 2006 04:17:51 -0700 (PDT)

Hi Michael
   
  Thanks for the response.

  Please clarify about the minimum value of L. 
  I think it should be 1. Which means that SCTP should not allow the zero byte data in the DATA chunk.
   
  Thanks & Regards,
  Ashwani Kathuria
  FSS India.
    
Michael Tuexen <[email-masked]> wrote:

  Hi,

Best regards
Michael

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 19 Jul 2006 13:33:54 +0200

Correct, L >= 1.

Best regards
Michael