Subject: [Sigtran] SCTP: Reassembling chunks of unordered Message

From: Saraswati Bose <[email-masked]>
Date: Thu, 10 Aug 2006 04:23:17 -0700 (PDT)

Hi Brian,
  rfc-2960 says, for data chunks with U flag=1 there is usually no SSN indicating these follow unordered delivery.
  Then how does SCTP identify and reassemble TSNs belonging to same user data message before delivering to ULP?
   
  Regards,
  Saraswati

---------------------------------
Do you Yahoo!?
 Next-gen email? Have it all with the  all-new Yahoo! Mail Beta.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 10 Aug 2006 18:11:25 +0200

Hi Saraswati,

it uses the TSNs... These have to be assigned in sequence for all  
fragments belonging
to 1 user message.

Best regards
Michael

On Aug 10, 2006, at 1:23 PM, Saraswati Bose wrote:

> Hi Brian,
> rfc-2960 says, for data chunks with U flag=1 there is usually no  
> SSN indicating these follow unordered delivery.
> Then how does SCTP identify and reassemble TSNs belonging to same  
> user data message before delivering to ULP?
>
> Regards,
> Saraswati
>
> Do you Yahoo!?