Subject: [Sigtran] RTP over SCTP

From: Константин Савин <[email-masked]>
Date: Tue, 22 Aug 2006 18:49:29 +0400

Hello everybody,

could somebody provide information about work on the RTP over SCTP issue?

Is it discarded by SIGTRAN WG or there are some drafts available?

Does anybody know any examples of such implementation?

Best regards

Stan

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 22 Aug 2006 18:46:15 +0200

Hi Stan,

could you explain what 'the' RTP over SCTP issue is?

Best regards
Michael

---

From: Константин Савин <[email-masked]>
Date: Wed, 23 Aug 2006 13:03:11 +0400

Hello Michael,
I'm sorry for not a clear question.
I've heard from my colleagues about an idea of transporting RTP (Real-Time
Transport Protocol) on the edge of SCTP. It means that you could send both
signalling and user data (e.g. voice) in the same SCTP packet.
Do you know any documents on this question? 

Best regards
Stan
-----Original Message-----
From: Michael Tuexen [mailto:[email-masked]] 
Sent: Tuesday, August 22, 2006 8:46 PM
To: Константин Савин
Cc: [email-masked]
Subject: Re: [Sigtran] RTP over SCTP

Hi Stan,

Best regards
Michael

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 23 Aug 2006 11:52:17 +0200

Hi Stan,

no I'm not aware on an internet draft about this. But you can run RTP  
and
RTCP on top of SCTP by using the PPID to distinguish between them.  
You might
want to use PR-SCTP (RFC 3758) to avoid retransmissions.

Best regards
Michael

---

From: Константин Савин <[email-masked]>
Date: Thu, 24 Aug 2006 16:42:49 +0400

Hi Michael,
Thank you very much for such useful information about RTP over SCTP.

Best regards
Stan

-----Original Message-----
From: Michael Tuexen [mailto:[email-masked]] 
Sent: Wednesday, August 23, 2006 1:52 PM
To: Константин Савин
Cc: [email-masked]
Subject: Re: [Sigtran] RTP over SCTP

Hi Stan,

Best regards
Michael