Subject: [Sigtran] Minimum Number of Streams in SCTP

From: Aditya <[email-masked]>
Date: Fri, 4 Aug 2006 22:50:29 -0700 (PDT)

Does SCTP RFC specify the minimum no. of strems that must be opened. If not, then what happens if there is only one stream negoitated (i.e stream id 0). DATA message cannot be sent on stream 0. This leads me to think that there must be atleast two streams. Any references in the RFC, pls quote. 

Thanks in advance,
Aditya

---------------------------------------------------------------------------X----------------------------------------------------
 
Don't take life too seriously...
Nobody comes out alive anyway

---------------------------------
How low will we go? Check out Yahoo! Messenger’s low  PC-to-Phone call rates.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Saurabh Jain" <[email-masked]>
Date: Sat, 5 Aug 2006 22:59:06 +0530

Hi Aditya,
The statement that "DATA message cannot be sent on stream 0" is not true for
all UA's. For example

*M3UA 3332:*
4.1.1 Receipt of Primitives from the M3UA-User
DATA messages MUST be sent on an SCTP stream other than stream '0'.

*SUA 3868:*
4.1.1.  Receipt of Primitives from SCCP
DATA messages MUST be sent on an SCTP stream other than stream '0' when
there is more than one stream.

Thus SUA does allow sending DATA on Stream 0, if there is only one stream.

rgds
Saurabh

On 8/5/06, Aditya <[email-masked]> wrote:
>
> Does SCTP RFC specify the minimum no. of strems that must be opened. If
> not, then what happens if there is only one stream negoitated (i.e stream
> id 0). DATA message cannot be sent on stream 0. This leads me to think that
> there must be atleast two streams. Any references in the RFC, pls quote.
>
> Thanks in advance,
> Aditya
>
>
>
> ------------------------------
> How low will we go? Check out Yahoo! Messenger's low PC-to-Phone call
> rates.
> <http://us.rd.yahoo.com/mail_us/taglines/postman8/*http://us.rd.yahoo.com/evt=39663/*http://voice.yahoo.com>
>
>

---

From: "Ashish Soregaonkar" <[email-masked]>
Date: Sun, 6 Aug 2006 13:55:37 +0530

Is this not an inconsistency among the UA's then? I dont see why M3UA should
not allow data transmission on stream '0', if the number of negotiated
streams is 1. If not then RFC 3332 should mention that the number of streams
to be used should always be >1.

-Ashish

On 8/5/06, Saurabh Jain <[email-masked]> wrote:
>
> Hi Aditya,
> The statement that "DATA message cannot be sent on stream 0" is not true
> for all UA's. For example
>
> *M3UA 3332:*

---

From: Aditya <[email-masked]>
Date: Mon, 7 Aug 2006 00:26:08 -0700 (PDT)

What about the specific case of M3UA running over SCTP. M3UA does not allow data messages to be sent over stream 0. However, there is no mention in either RFC's (M3UA or SCTP) about the minimum number of streams to be opened. My question was strictly for M3UA over SCTP. The implementation I work on rejects associations with streams less than 2. However,  I found no support for this behaviour in the RFC. 

Ashish Soregaonkar <[email-masked]> wrote: Is this not an inconsistency among the UA's then? I dont see why M3UA should not allow data transmission on stream '0', if the number of negotiated streams is 1. If not then RFC 3332 should mention that the number of streams to be used should always be >1. 

-Ashish

On 8/5/06, Saurabh Jain <[email-masked]> wrote: Hi Aditya,
 The statement that "DATA message cannot be sent on stream 0" is not true for all UA's. For example 
  
 M3UA 3332: 
  
 SUA 3868:
 4.1.1.  Receipt of Primitives from SCCP
DATA messages MUST be sent on an SCTP stream other than stream '0' when there is more than one stream.

rgds
 Saurabh

On 8/5/06, Aditya < [email-masked]> wrote: 

Thanks in advance,
Aditya

   

---------------------------------
 How low will we go? Check out Yahoo! Messenger's low   PC-to-Phone call rates.

---

From: ash kat <[email-masked]>
Date: Mon, 7 Aug 2006 02:47:56 -0700 (PDT)

Hi Aditya
   
  SCTP RFC states that number of streams must not be zero. Hence it should be greater than zero.
   
  Application running over SCTP should set the number of SCTP streams for an association, based on it's requirement.
   
  So if the M3UA requires 2 streams then M3UA should itself take care of this while connecting to peer.
   
  Regards,
  Ashwani Kathuria
  FSS India.

Aditya <[email-masked]> wrote:
  What about the specific case of M3UA running over SCTP. M3UA does not allow data messages to be sent over stream 0. However, there is no mention in either RFC's (M3UA or SCTP) about the minimum number of streams to be opened. My question was strictly for M3UA over SCTP. The implementation I work on rejects associations with streams less than 2. However,  I found no support for this behaviour in the RFC. 

-Ashish

  M3UA 3332: 
   
  SUA 3868:

rgds
  Saurabh

Thanks in advance,
Aditya

    

   

---------------------------------
  How low will we go? Check out Yahoo! Messenger’s low PC-to-Phone call rates._______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---------------------------------
Want to be your own boss? Learn how on  Yahoo! Small Business.

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 7 Aug 2006 12:06:20 +0200

Aditya,

SCTP can not make such a requirement because it is a general purpose  
transport
protocol not specific designed for M3UA.

So it is up to the upper layer to request setting up an association  
with the
appropriate number of streams and check if the requirements are  
fulfilled after
the association has been set up. If the upper layer needs more  
streams he
only can turn down the association. So if you run M3UA and want to  
send DATA
messages you need more than one stream. From
http://www.ietf.org/internet-drafts/draft-ietf-sigtran-rfc3332bis-06.txt

    1. DATA message MUST NOT be sent on stream 0.
    2. ASPSM, MGMT, RKM  classes SHOULD be sent on stream 0 (Other than
       BEAT, BEAT ACK and NTFY messages)
    3. SSNM, ASPTM classes and BEAT, BEAT ACK and NTFY messages can be
       sent on any stream.

Only if you do not want to send DATA messages one stream would be  
enough.

Best regards
Michael

On Aug 7, 2006, at 9:26 AM, Aditya wrote:

> What about the specific case of M3UA running over SCTP. M3UA does  
> not allow data messages to be sent over stream 0. However, there is  
> no mention in either RFC's (M3UA or SCTP) about the minimum number  
> of streams to be opened. My question was strictly for M3UA over  
> SCTP. The implementation I work on rejects associations with  
> streams less than 2. However,  I found no support for this  
> behaviour in the RFC.
>
> Ashish Soregaonkar <[email-masked]> wrote: Is this not  
> an inconsistency among the UA's then? I dont see why M3UA should  
> not allow data transmission on stream '0', if the number of  
> negotiated streams is 1. If not then RFC 3332 should mention that  
> the number of streams to be used should always be >1.
>
> -Ashish
>
> Does SCTP RFC specify the minimum no. of strems that must be  
> opened. If not, then what happens if there is only one stream  
> negoitated (i.e stream id 0). DATA message cannot be sent on stream  
> 0. This leads me to think that there must be atleast two streams.  
> Any references in the RFC, pls quote.
>
> Thanks in advance,
> Aditya
>
>
> ---------------------------------------------------------------------- 
> -----X----------------------------------------------------
>
> ---------------------------------------------------------------------- 
> -----X----------------------------------------------------
>

---

From: Aditya <[email-masked]>
Date: Mon, 7 Aug 2006 05:44:50 -0700 (PDT)

Any reason why DATA messages are not allowed to be sent over stream 0 in M3UA. Saurabh in his mail chain has mentioned that SUA does allow it. So, why not M3UA.

Michael Tuexen <[email-masked]> wrote: Aditya,

Best regards
Michael

On Aug 7, 2006, at 9:26 AM, Aditya wrote:

> Ashish Soregaonkar  wrote: Is this not  
> On 8/5/06, Saurabh Jain  wrote:
> Hi Aditya,

 		
---------------------------------
Yahoo! Music Unlimited - Access over 1 million songs.Try it free.