Subject: RE: [Sigtran] Routing Key for an Appllication Server and an IP server

From: "Bui, MyHanh" <[email-masked]>
Date: Wed, 16 Aug 2006 15:20:14 -0700

Hi Anjali,

Thank you for the clarification.

1.                   I understand that different AS(s) can share the
same DPC but my concern was 1 AS can only have 1 DPC value in the
routing key.

Example: It's OK to have the routing key parameters of an AS to be:
{DPC = X, OPC = Y; DPC = X, SI = K}

But is it wrong to configure the routing key parameters of AS #1 to be:
{DPC = X, OPC = Y; DPC = M, OPC = N} ?  

I ask this question because the format of the Routing Key parameter
[RFC3332bis page 44] allows many DPC fields.

You gave example of one AS having RK as DPC = X and other AS having RK
as DPC = X, OPC = Y.  Is the 2nd AS a subset of the 1st AS?  Then how is
an SS7 message (e.g. DPC = X, OPC = Y) distributed at the SGP since it
matches both routing keys?  Would it select the full match routing key
first?

MyHanh              

________________________________

From: anjali gurmukhani [mailto:[email-masked]] 
Sent: Wednesday, August 16, 2006 12:18 PM
To: Bui, MyHanh; [email-masked]
Subject: Re: [Sigtran] Routing Key for an Appllication Server and an IP
server

MyHanh...

1) An application server is uniquely identified by a Routing Key. Now
this Routing key can be any combination of DPC/OPC/SI/CIC. This
combination has to be unique across the Application servers added. 

What this means is that you can have two Application servers added such
that one AS has a Routing key type as DPC only with DPC=X and another
having Routing key type as DPC+OPC where DPC=X and OPC=Y.

2) In IPSP-IPSP scenario, the communication is between two M3UA
endpoints and the traffic has not be carried over the remote end as in
the case of ASP-SGP scenario where the traffic is originating from SS7
side and has to be carried over to ASP OR is originating from ASP side
and may be is destined for some point code in SS7 cloud. 

So point-to-point means that between two end-points in IP
domain/conceptually no services of SG being used..For ex, an MSC could
be talking to an SG and IP resident HLR at the same time. So in this
case , MSC-HLR communication is IPSP-IPSP( point-to-point) and MSC-SG is
ASP-SG.

As far as Routing Key type is concerned, it does not necessarily be
DPC-OPC.can be DPC only also.

3)Didnt much get what you mean by one pair of (DPC-OPC) ?can you
elaborate

-Regards

Anjali.

"Bui, MyHanh" <[email-masked]> wrote: 

Hi All

1.                   Is it true that the routing key of an Application
Server can have 1 and only 1 unique DPC (while OPC, SI, CIC can be
different)? (This DPC is this AS's point code).  

2.                   The only difference about the IPSP and ASP is the
point to point nature.  Does this point to point mean that the routing
key for an IP server requires a DPC-OPC pair? Or it has other meaning?
I am not clear about this point to point.   

3.                   If question # 1 is TRUE then it means the routing
key of an IP server can only have 1 pair of DPC-OPC (while SI, CIC can
be different)?

MyHanh

E-mail confidentiality.
--------------------------------
This e-mail contains confidential and / or privileged information
belonging to Spirent Communications plc, its affiliates and / or
subsidiaries. If you are not the intended recipient, you are hereby
notified that any disclosure, copying, distribution and / or the taking
of any action based upon reliance on the contents of this transmission
is strictly forbidden. If you have received this message in error please
notify the sender by return e-mail and delete it from your system. If
you require assistance, please contact our IT department at
[email-masked].

Spirent Communications plc,
Spirent House, Crawley Business Quarter, Fleming Way, Crawley, West
Sussex, RH10 9QL, United Kingdom.
Tel No. +44 (0) 1293 767676
Fax No. +44 (0) 1293 767677

Registered in England Number 470893
Registered at Spirent House, Crawley Business Quarter, Fleming Way,
Crawley, West Sussex, RH10 9QL, United Kingdom 

Or if within the US,

Spirent Communications,
26750 Agoura Road, Calabasas, CA, 91302, USA.
Tel No. 1-818-676- 2300 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

________________________________

Do you Yahoo!?
Next-gen email? Have it all with the all-new Yahoo! Mail Beta.
<http://us.rd.yahoo.com/evt=42241/*http:/advision.webevents.yahoo.com/ha
ndraisers> 

<DIV><FONT size="1">

E-mail confidentiality.
--------------------------------
This e-mail contains confidential and / or privileged information belonging to Spirent Communications plc, its affiliates and / or subsidiaries. If you are not the intended recipient, you are hereby notified that any disclosure, copying, distribution and / or the taking of any action based upon reliance on the contents of this transmission is strictly forbidden. If you have received this message in error please notify the sender by return e-mail and delete it from your system. If you require assistance, please contact our IT department at [email-masked].

Spirent Communications plc,
Spirent House, Crawley Business Quarter, Fleming Way, Crawley, West Sussex, RH10 9QL, United Kingdom.
Tel No. +44 (0) 1293 767676
Fax No. +44 (0) 1293 767677

Registered in England Number 470893
Registered at Spirent House, Crawley Business Quarter, Fleming Way, Crawley, West Sussex, RH10 9QL, United Kingdom 

Or if within the US,

Spirent Communications,
26750 Agoura Road, Calabasas, CA, 91302, USA.
Tel No. 1-818-676- 2300 

</FONT></DIV>
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: anjali gurmukhani <[email-masked]>
Date: Thu, 17 Aug 2006 20:35:39 -0700 (PDT)

MyHanh
   
  In the example given, the traffic originating from OPC=Y and for DPC=X shall use AS2 and for all other traffic AS1 shall be used to route the traffic. The selection would go from full to partial match. 
   
  Regards
  Anjali.
  
"Bui, MyHanh" <[email-masked]> wrote:
        v\:* {behavior:url(#default#VML);}  o\:* {behavior:url(#default#VML);}  w\:* {behavior:url(#default#VML);}  .shape {behavior:url(#default#VML);}        st1\:*{behavior:url(#default#ieooui) }                Hi Anjali,

  1.                   I understand that different AS(s) can share the same DPC but my concern was 1 AS can only have 1 DPC value in the routing key.
  Example: It’s OK to have the routing key parameters of an AS to be:  {DPC = X, OPC = Y; DPC = X, SI = K}
  But is it wrong to configure the routing key parameters of AS #1 to be:  {DPC = X, OPC = Y; DPC = M, OPC = N} ?  
  I ask this question because the format of the Routing Key parameter [RFC3332bis page 44] allows many DPC fields.
   
  You gave example of one AS having RK as DPC = X and other AS having RK as DPC = X, OPC = Y.  Is the 2nd AS a subset of the 1st AS?  Then how is an SS7 message (e.g. DPC = X, OPC = Y) distributed at the SGP since it matches both routing keys?  Would it select the full match routing key first?
   
  MyHanh              

---------------------------------
  
  From: anjali gurmukhani [mailto:[email-masked]] 
Sent: Wednesday, August 16, 2006 12:18 PM
To: Bui, MyHanh; [email-masked]
Subject: Re: [Sigtran] Routing Key for an Appllication Server and an IP server

    MyHanh...

    1) An application server is uniquely identified by a Routing Key. Now this Routing key can be any combination of DPC/OPC/SI/CIC. This combination has to be unique across the Application servers added. 

    What this means is that you can have two Application servers added such that one AS has a Routing key type as DPC only with DPC=X and another having Routing key type as DPC+OPC where DPC=X and OPC=Y.

    2) In IPSP-IPSP scenario, the communication is between two M3UA endpoints and the traffic has not be carried over the remote end as in the case of ASP-SGP scenario where the traffic is originating from SS7 side and has to be carried over to ASP OR is originating from ASP side and may be is destined for some point code in SS7 cloud. 

    So point-to-point means that between two end-points in IP domain/conceptually no services of SG being used..For ex, an MSC could be talking to an SG and IP resident HLR at the same time. So in this case , MSC-HLR communication is IPSP-IPSP( point-to-point) and MSC-SG is ASP-SG.

    As far as Routing Key type is concerned, it does not necessarily be DPC-OPC.can be DPC only also.

    3)Didnt much get what you mean by one pair of (DPC-OPC) ?can you elaborate

    -Regards

    Anjali.

     

    1.                   Is it true that the routing key of an Application Server can have 1 and only 1 unique DPC (while OPC, SI, CIC can be different)? (This DPC is this AS’s point code).  

    2.                   The only difference about the IPSP and ASP is the point to point nature.  Does this point to point mean that the routing key for an IP server requires a DPC-OPC pair? Or it has other meaning?  I am not clear about this point to point.   

    3.                   If question # 1 is TRUE then it means the routing key of an IP server can only have 1 pair of DPC-OPC (while SI, CIC can be different)?

    MyHanh

E-mail confidentiality.

Or if within the US,

Spirent Communications,

    
---------------------------------
  
  Do you Yahoo!?

E-mail confidentiality.

Or if within the US,

Spirent Communications,

---------------------------------
Do you Yahoo!?
 Everyone is raving about the  all-new Yahoo! Mail Beta.