Subject: [Sigtran] Re: Can One M2PA layer have

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 7 Aug 2006 03:00:53 -0600

Bibhuti,

Single link between two given hosts, multiple links to multiple hosts.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 7 Aug 2006 06:42:08 -0600

Bibhuti,

Then it is still 1 link per pair of hosts.

--brian

Bibhuti Bhusan Tosh wrote:                                         (Mon, 07 Aug 2006 16:26:44)
> Hi Brian
> I agree with You But What if the associations handled by the M2PA layer may
> be connected to different hosts. This case is needed to support separate
> Links as per the SLS values. In these cases Do we need separate M2PA layers
> for different links of the endpoint?

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 7 Aug 2006 04:48:36 -0600

Bibhuti,

On Mon, 07 Aug 2006, Bibhuti Bhusan Tosh wrote:

> Hi Brian
> Can I have multiple M2PA links between 2 hosts where the links are handled
> by same M2PA layer?

Not recommended.

> 
> If a single M2PA layer will have multiple links then All the procedures like
> alignment/proving/ready etc will be done separately for different links
> (associations).

Multiple links between the same two hosts is not recommended.

--brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 7 Aug 2006 13:02:52 -0600

Bibhuti,

Bibhuti Bhusan Tosh wrote:                   (Mon, 07 Aug 2006 19:19:51)
> 
> Consider the following case
>                    IPSP X                        IPSP Y
> 
>                +-------------+               +-------------+
>                |             |     SCTP      |             |
>                |         IPA | association 1 | IPB         |
>                |   port = PW +---------------+ port = PW   |
>                |     SLC = a |               | SLC = a     |
>                |             |               |             |
>                |             |               |             |
>                |             |     SCTP      |             |
>                |         IPC | association 2 | IPD         |
>                |   port = PW +---------------+ port = PW   |
>                |     SLC = b |               | SLC = b     |
>                |             |               |             |
>                |             |               |             |
>                +-------------+               +-------------+
> 
> 
> 
> In the above case Does Both the links are part of single M2PA endpoint or we
> need separate END Points?
> 
> If We consider both the links by a single M2PA. Then Do We need to do all
> the procedures for both the links?

Yes, but such an arrangement is counter-recommended.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/