Subject: [Sigtran] Mandatory/optional RC in ACTIVE/INACTIVE ACK

From: "Ilie Glib" <[email-masked]>
Date: Fri, 22 Sep 2006 14:18:04 +0200

Hello Folks

SUA RFC requires RC in ACTIVE ACK message, while the RC in ACTIVE is
optional. Perhaps, this is OK, but the RC in INACTIVE ACK is optional.

What is the reason for that difference.

Thank you in advance

-- 
Ilie

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Saurabh Jain" <[email-masked]>
Date: Sat, 23 Sep 2006 15:30:52 +0530

Hello Ilie,
I believe your point is valid. In ASP Active Ack Message, the Routing Key IE
should have been Optional.

In ASP Active and ASP Inactive, absence of RC, would imply that ASP Active
is meant for all AS served by the ASP.
Section 4.3.4.3 :
*        In the case where an ASP Active message does not contain a Routing
Context parameter, *
*        the receiver must know, via configuration data, which Application
Server(s) the ASP is a member.
*

Similarly in ASP Active Ack and ASP Inactive Ack, absence of RC should imply
that Acknowledgement is meant for all AS served by ASP. (NOTE: Peer SUA
always has the option o sending individual acknowledgements for each RC)
Section 4.3.4.3 :
*        The Routing Context parameter "MUST" be included in the ASP Active
Ack message(s) "if" the*
*        received ASP Active message contained any Routing Contexts. In
ACTIVE and INACTIVE, RC is optional,*
*       would imply that ASP Active is meant for all AS served by the ASP.*

Thus, in case ASP Active didn't contain RC, then MUST clause doesn't apply.

Regards
Saurabh Jain
Flextronics Software Systems

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 23 Sep 2006 04:47:54 -0600

Saurabh,

RC is not really optional in ASP Active Ack: it is conditional.
If an RC value is specified int the ASP Active, the RC value
MUST be sent in the ASP Active Ack or it is an error, see
section 4.3.4.3.:

 "... The Routing Context parameter MUST be included in
  the ASP Active Ack messages(s) if the received ASP
  Active message contained any Routing Contexts. ..."

THe same is true for ASP Inactive Ack: if an RC was sent in
the ASP Inactive, it MUST be sent in the ASP Inactive Ack.

M3UA calls them both Optional, which they really are not
in all circumstances.

So, for both ASP Active Ack and ASP Inactive Ack they should
probably read:

   Routing Context	    Mandatory *1

   *1 - The Routing Context parameter MAY be omitted if
        there was no Routing Context parameter in the
	corresponding ASP (In)Active message.

This will agree with the text in 4.3.4.3 and 4.3.4.4.

One for the I-G.  (Is John still maintaining it?)

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/