Subject: [Sigtran] Fwd: Re: SCTP data message handling

From: Saraswati Bose <[email-masked]>
Date: Thu, 14 Sep 2006 05:48:26 -0700 (PDT)

Note: forwarded message attached.
 		
---------------------------------
Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls.  Great rates starting at 1¢/min.

Subject: Re: SCTP data message handling
From: Saraswati Bose <[email-masked]>
To: [email-masked]
Date: Thu, 14 Sep 2006 05:45:46 -0700 (PDT)

Hi Brian,
  It seems I am not understood properly.
  I wanted to know in case SCTP endpoint A receives ulp data of size greater than the ARWND value of its peer (say Endpoint B) and and suppose that fragmentation/bundling is not supported by endpoint A, should A reject the data or not?
   
  If not then should endpoint B reject the data?
   
  Regards,
  Saraswati
  "Brian F. G. Bidulock" <[email-masked]> wrote:
  Saraswati,

Saraswati Bose wrote: (Thu, 14 Sep 2006 04:22:41)
> SCTP-A SCTP-B
> ARWND==4000

If the MTU greater than 5000, SWS Avoidance dictates that SCTP-A either
advertize 1 MTU or zero. SCTP-B after SWS Avoidance should either treat
this as 1 MTU or zero also.

Nevertheless, the other reponse is correct: you can always have one MTU
in flight.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---------------------------------
Do you Yahoo!?
 Everyone is raving about the  all-new Yahoo! Mail.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: ash kat <[email-masked]>
Date: Thu, 14 Sep 2006 23:55:17 -0700 (PDT)

Hi Saraswati
  IMO If Side B has to send User data greater then a_rwnd of peer then
   
  1. The SCTP should discard the data only in one case when it is not able to fragment the data to less than PMTU size configured. [ i.e fragmentation is not allowed ]
   
  2. Otherwise it should send the data to peer, but peer will drop the DATA as no buffers are available to receive that DATA, However the peer SCTP will send the SACK containing TSN of the last data chunk successfully received and also the updated receiver window.
  SCTP will keep on retransmitting that DATA chunk until it receives SACK for "that" DATA chunk.
   
  If PMTU size is configured to 1500 [ for ethernet] then your case lies in the first scenario, hence the SCTP should discard the data and give proper error to the user.
   
  --Ashwani kathuria
    FSS India
  
Saraswati Bose <[email-masked]> wrote:

  Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls. Great rates starting at 1¢/min.Date: Thu, 14 Sep 2006 05:45:46 -0700 (PDT)

  Hi Brian,

  Regards,
  Saraswati

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---------------------------------
  Do you Yahoo!?
Everyone is raving about the all-new Yahoo! Mail._______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---------------------------------
Want to be your own boss? Learn how on  Yahoo! Small Business.