Subject: [Sigtran] SCTP: Multihoming Configuration

From: Saraswati Bose <[email-masked]>
Date: Tue, 5 Sep 2006 22:23:07 -0700 (PDT)

Hi Brian,
  please suggest in the below.
   
  Endpoint A (ASP)                                     Endpoint B (SG)
                                       ASSO-1
  IPs== IP1,IP2                                           IP== IP1'
  Port==P1                                                 Port== P1'
   
                                       ASSO-2
  IPs== IP1                                                 IP== IP2
  Port==P1                                                 Port== P2
   
  In ASP side Is the above a valid configuration?
  If yes then wht about the fact tht the same transport address of one multi homed endpoint (IP1+P1) must be used by any other SCTP endpoint?
   
  If no then how to support 1 ASP 2 SG scenario since we need 2 unique ASSOCIATION establishment for the scenarion?
   
  Regards,
  Saraswati

---------------------------------
Get your own web address for just $1.99/1st yr. We'll help. Yahoo! Small Business.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 6 Sep 2006 03:55:20 -0600

Saraswati,

Saraswati Bose wrote:                               (Tue, 05 Sep 2006 22:23:07)
>    In ASP side Is the above a valid configuration?

Yes, it is valid but not common.

>    If  yes  then wht about the fact tht the same transport address of one
>    multi homed endpoint (IP1+P1) must be used by any other SCTP endpoint?

The only rule is that there can only be one associated between a pair of
transport addresses (address list and port number).  The rule is not violoated
here because in the second instance IP1,P1 connects to IP2,P2.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/