Subject: [Sigtran] ASP Active for pending RC

From: Padmalochan Moharana <[email-masked]>
Date: Thu, 14 Sep 2006 22:20:52 -0700 (PDT)

Hi Brian,

please suggest for the following doubts.

1 - In SUA should ASP encode ASP Active for pending
RCs if no responce is being received for them.

2 - Should the state of the ASP change to ACTIVE if it
not received ASP ACTIVE ACK  for all the RC encoded in
the ASP ACTIVE message.

Regards,
Padman,

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 15 Sep 2006 00:11:54 -0600

Padmalochan,

Padmalochan Moharana wrote:          (Thu, 14 Sep 2006 22:20:52)
> RCs if no responce is being received for them.

I am not sure what you mean by "pending RCs".

> not received ASP ACTIVE ACK  for all the RC encoded in

The state can change to AS-ACTIVE for the AS for which
ASP ACTIVE ACK was received for the associated RCs.  The
state of AS for which no ASP ACTIVE ACK has been received
for the corresponding RCs, can remanin in a state awaiting
receipt of an ASP ACTIVE ACK.  If a timeout occurs, the
ASP can resend ASP ACTIVE with the RC for which no responding
ASP ACITVE ACK has yet been received.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 15 Sep 2006 00:17:34 -0600

Padmalochan,

Brian F. G. Bidulock wrote:            (Fri, 15 Sep 2006 00:11:54)
> ASP ACITVE ACK has yet been received.

Let me put that another way:  Sending multiple RCs in an ASP ACTIVE
(Ack) or ASP INACTIVE (Ack) is really just a convenience for compacting
multiple messages into one.  No relationship between the RCs contained
in the message is formed by placing them together.  From a state machine
view, one message containing five different RC values is treated the
same as though 5 messages of the same type were received each with only
one RC value in it.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Padmalochan Moharana <[email-masked]>
Date: Thu, 14 Sep 2006 23:25:51 -0700 (PDT)

Hi brian,

suppose the ASP active contains 5 RCs. But SG responce
Active ack with 3 RC .Also not receive error for the
rest of the 2 RC then should ASP encode ASP Active for
the rest of the 2 RC.

--- "Brian F. G. Bidulock" <[email-masked]>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 15 Sep 2006 00:38:38 -0600

Padmalochan,

Padmalochan Moharana wrote:          (Thu, 14 Sep 2006 23:25:51)
> rest of the 2 RC then should ASP encode ASP Active for

Well, think about it.  I said they were independent.  When the
ASP sends ASP Active containing 5 RCs it is no different than
sending 5 ASP Active messages each containing one of the RCs.
So, if the ASP sends 5 ASP Active messages to the SG and only
receives 3 ASP Active Ack messages, for three of the 5 sent
message, what does the ASP do with the other two?  Well, it can
wait for a time and then resend the messages (in which case it
could send both RC in the same retry message), or, it could wait
indefinitely.  Whether multiple RCs are in a message or not has
nothing to do with it.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Bhanu Prakash <[email-masked]>
Date: Fri, 15 Sep 2006 12:04:15 +0530

<>Padmalochan,

The ASP state will not change to ACTIVE untill the ASP ACTIVE ACK
has been received for the corresponding RCs.

Regards,
Bhanu.

Padmalochan Moharana wrote:

>>>Padmalochan Moharana wrote:          (Thu, 14 Sep
>>>      
>>>
>>2006 22:20:52)
>>    
>>
>>>>Hi Brian,
>>>>
>>>>1 - In SUA should ASP encode ASP Active for
>>>>        
>>>>
>>pending
>>    
>>
>>>>2 - Should the state of the ASP change to ACTIVE
>>>>        
>>>>
>>if it
>>    
>>
>>>>not received ASP ACTIVE ACK  for all the RC
>>>>        
>>>>
>>encoded in
>>    
>>
>>>>the ASP ACTIVE message.
>>>>        
>>>>
>>>The state can change to AS-ACTIVE for the AS for
>>>      
>>>
>>which
>>    
>>
>>>ASP ACTIVE ACK was received for the associated
>>>      
>>>
>>RCs.  The
>>    
>>
>>>state of AS for which no ASP ACTIVE ACK has been
>>>      
>>>
>>received
>>    
>>
>>>for the corresponding RCs, can remanin in a state
>>>      
>>>
>>awaiting
>>    
>>
>>>receipt of an ASP ACTIVE ACK.  If a timeout
>>>      
>>>
>>occurs, the
>>    
>>
>>>ASP can resend ASP ACTIVE with the RC for which no
>>>      
>>>
>>responding
>>    
>>

---

From: Padmalochan Moharana <[email-masked]>
Date: Fri, 15 Sep 2006 06:56:46 -0700 (PDT)

Hi Brian,

1 - As per the RFC3332 (m3ua) the traffic mode is
optional parameter.Should server response error on
receiving ASP ACTIVE or REG REQ message without
traffic mode?

2- What should be the defult traffic mode if server
not receive traffic mode in the ASP active or REG REQ
message.

Regards,
Padmalochan

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 15 Sep 2006 08:18:44 -0600

Padmalochan,

Padmalochan Moharana wrote:   (Fri, 15 Sep 2006 06:56:46)
> receiving ASP ACTIVE or REG REQ message without

Did you think it was an error to not do something that is
optional?

> not receive traffic mode in the ASP active or REG REQ

What do you thinK?

I think you really need to read the traffic management
section of the RFC again.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/