Subject: RE: [SIGTRAN]:Invalid ASPID error in XUA

From: Joerg Simm <[email-masked]>
Date: Fri, 27 Oct 2006 09:51:53 +0200

Hello Brian,
I think the question was about the behaviour of the ASP in this case and not
if the SG implementation is incorrect. I'm interested in an answer too.
Greetings,
Joerg Simm

-- Joerg Simm
TELES AG
Chief Developer of Protocol Department
Dovestr. 2-4
D-10587 Berlin
GERMANY
mailto:[email-masked]

> -----Original Message-----
> From:	Brian F. G. Bidulock [SMTP:[email-masked]]
> Sent:	Friday, October 27, 2006 9:20 AM
> To:	Saraswati Bose
> Cc:	sigtran
> Subject:	Re: [SIGTRAN]:Invalid ASPID error in XUA
> 
> Saraswati,
> 
> Saraswati Bose wrote:                               (Thu, 26 Oct 2006
> 23:13:06)
> >
> >    What  about  Notify message received with ASPID different from the
> one
> >    sent in ASPUP?
> 
> Then the SG lied and it is a bug in the SG implementation that should
> never have made it to the field.
> 
> --brian
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Saraswati Bose <[email-masked]>
Date: Fri, 27 Oct 2006 01:46:08 -0700 (PDT)

Hi Joerg,
  Thanks for getting my question rightly. I am awaiting an appropriate reply.
   
  Will ASP generate an error "inavlid ASPID" in response or will simply discard the ntfy message.
   
  Regards,
  Saraswati.

Joerg Simm <[email-masked]> wrote:
  Hello Brian,
I think the question was about the behaviour of the ASP in this case and not
if the SG implementation is incorrect. I'm interested in an answer too.
Greetings,
Joerg Simm

-- Joerg Simm
TELES AG

> never have made it to the field.

---------------------------------
Yahoo! Messenger with Voice. Make PC-to-Phone Calls to the US (and 30+ countries) for 2¢/min or less.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 27 Oct 2006 03:23:21 -0600

Saraswati,

How is the ASP to know that the ASP ID is invalid?

Please provide an example.

SG only sends Notify with ASP ID when another ASP serving the AS fails.
Unless the SG has an error, the ASP ID is unique across the AS and is
different from the ASP ID of the ASP to which the Notify is sent.  If the SG
implementation has no error, the ASP ID is correct: it is the ASP ID with
which the failed ASP is configured (or the one that the failed ASP used to
identify itself in an ASP UP).

--brian

Saraswati Bose wrote:                            (Fri, 27 Oct 2006 01:46:08)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Saraswati Bose <[email-masked]>
Date: Fri, 27 Oct 2006 02:52:22 -0700 (PDT)

Hi Brian,
  Just for example say ASP sends ASPUP with ASPID=X, SG responds back with appropriate UPACK followed by a NOTIFY with some corrupted ASPID. Now how should ASP react to the notify message?
   
  Regards,
  Saraswati

"Brian F. G. Bidulock" <[email-masked]> wrote:
  Saraswati,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---------------------------------
Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls.  Great rates starting at 1¢/min.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 27 Oct 2006 06:13:51 -0600

Saraswati,

Please explain how the ASPID is corrupted (and note that an SG does not
send to an ASP in a Notify its own ASPID).

--brian

Saraswati Bose wrote:                                            (Fri, 27 Oct 2006 02:52:22)
> 
>    Hi Brian,
> 
>    Just  for  example  say ASP sends ASPUP with ASPID=X, SG responds back
>    with appropriate UPACK followed by a NOTIFY with some corrupted ASPID.
>    Now how should ASP react to the notify message?
> 
> 
> 
>    Regards,
> 
>    Saraswati
>      >  Thanks  for  getting  my  question  rightly.  I  am  awaiting an
>      appropriate
>      > reply.
>      >
>      >
>      >
>      >  Will  ASP  generate an error "inavlid ASPID" in response or will
>      simply
>      > discard the ntfy message.
>      >
>      --
>      Brian F. G. Bidulock
>      [email-masked]
>      http://www.openss7.org/
>      _________________________________________________________________
> 
>    Talk  is  cheap.  Use  Yahoo!  Messenger  to  make  PC-to-Phone calls.
>    [1]Great rates starting at 1¢/min.
> 
> References
> 
>    1. http://us.rd.yahoo.com/mail_us/taglines/postman7/*http://us.rd.yahoo.com/evt=39666/*http://messenger.yahoo.com

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/