Subject: [Sigtran] RFC 2960 : #14. Suggested SCTP Protocol Parameter Values

From: "Robby Pocornie" <[email-masked]>
Date: Tue, 17 Oct 2006 15:46:20 +0200

*Dear All,*
**
*In RFC 2960, October 2000 the Retransmission timers are difined in chapter
14 as:*
**
*Suggested SCTP Protocol Parameter Values
   The following protocol parameters are RECOMMENDED:
   RTO.Initial              - 3  seconds
   RTO.Min                  - 1  second
   RTO.Max                 -  60 seconds*
*........etc..*
*My question is: are these values not ridiculously too large for today
Signalling enviroment.*
*Is RTO.Min of 1 second not too large. I think 120 msec / 200 msec would be
enough.*
**
*Can you tell me if someone also has occur poblems with interworking where
one Vender has 1000 msec and the other 200msec*
*and how do I can solve those problems.*
**
*Within ITU specs you find Bileteral agreements for this kind of issue's. In
IETF RFC I still not find this kind of agreement *
*mention*
**
Regards,
Robby Pocornie
[email-masked]*

*
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 17 Oct 2006 11:08:41 -0600

Robby,

See RFC 4166.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 17 Oct 2006 21:26:24 +0200

Hi Robby,

these values are given for the usage of SCTP as a general transport  
protocol
in the public Internet. You most likely want to use different values  
when you use
SCTP for SIGTRAN in a private network. That is why the ETSI spec for  
SCTP requires
SCTP implementations to provide a set of configurable parameters  
requires values
from the  minimum, maximum and granulary. From an interoperability  
point if view
the delayed SACK timer and the RTO values of the peer are related.

In addition to the SCTP layer you need to adjust the SCTP parameters  
to the parameters
in the upper layer, like M2PA for example. But this is not an SCTP  
issue...

Best regards
Michael

On Oct 17, 2006, at 3:46 PM, Robby Pocornie wrote:

> Dear All,
>
> In RFC 2960, October 2000 the Retransmission timers are difined in  
> chapter 14 as:
>
> Suggested SCTP Protocol Parameter Values
>    RTO.Max                 -  60 seconds
> ........etc..
> My question is: are these values not ridiculously too large for  
> today Signalling enviroment.
> Is RTO.Min of 1 second not too large. I think 120 msec / 200 msec  
> would be enough.
>
> Can you tell me if someone also has occur poblems with interworking  
> where one Vender has 1000 msec and the other 200msec
> and how do I can solve those problems.
>
> Within ITU specs you find Bileteral agreements for this kind of  
> issue's. In IETF RFC I still not find this kind of agreement
> mention
>
> Regards,
> Robby Pocornie
> [email-masked]
>
>

---

From: "Robby Pocornie" <[email-masked]>
Date: Wed, 25 Oct 2006 16:33:07 +0200

Hi Michael, Brian,

The timers like e.g. RTO.min/max are SCTP timers. As you said addition to
the SCTP I have to ajust parameters in the upper layer. My problem occurs in
the M3UA protocol.
- Are beside the SCTP timers parameters (ETSI TS 102 144) also M3UA
ajustable parameters.
- What is the ETSI/ITU/IETF # standard where I can find these timers or way
to set these timers.
- Do you know the mean value Telco's worldwide used for  RTO.min/max.

Thanks,
Robby Pocornie

2006/10/18, Robby Pocornie <[email-masked]>:
>
>
>
> ---------- Forwarded message ----------
> From: Michael Tuexen <[email-masked]
> [email-masked]>
> Date: 17-okt-2006 21:26
> Subject: Re: [Sigtran] RFC 2960 : #14. Suggested SCTP Protocol Parameter
> Values
> To: Robby Pocornie <[email-masked]>
> Cc:
>
> Hi Robby,
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 25 Oct 2006 12:11:22 -0600

Robby,

See ETSI TS 102 142.  There are no protocol timers for M3UA that are
of other than local significance.

--brian

Robby Pocornie wrote:                                                (Wed, 25 Oct 2006 16:33:07)
> 
>    Hi Michael, Brian,
> 
> 
> 
>    The timers like e.g. RTO.min/max are SCTP timers. As you said addition
>    to  the SCTP I have to ajust parameters in the upper layer. My problem
>    occurs in the M3UA protocol.
> 
>    -  What  is the ETSI/ITU/IETF # standard where I can find these timers
>    or way to set these timers.
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/