Subject: RE: [Sigtran] M2PA Alignment Clarification

From: "Erickson, Mark" <[email-masked]>
Date: Tue, 3 Oct 2006 09:12:37 -0500

Brian:

So, a stream synchronization error was created during alignment due to
normal, real-life network conditions.  How should the link recover -
that was my original question?  Force the link down and attempt to
re-establish the link?

Is there a better method?  What about acknowledging the proving messages
in some fashion?

Mark

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Tuesday, October 03, 2006 9:58 AM
To: Erickson, Mark
Cc: [email-masked]
Subject: Re: [Sigtran] M2PA Alignment Clarification

Mark,

Regardless, ignoring errors during alignment is not an answer.

--brian

Erickson, Mark wrote:                         (Tue, 03 Oct 2006
08:44:06)
> Brian:
> 
> Whether or not the network was too poor to sustain the link is not the
> point.  The point is that if you have some - read that any - packet
loss
> in the network, if a proving packet is lost in the network at the end
of
> the proving period, this situation can be created.  It's just that
it's
> easier to create/more prevalent in lossier networks.
> 
> Mark

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 3 Oct 2006 08:38:46 -0600

Mark,

Just wait until all your proving messages (or the LSR) have
been acknowleged by the peer SCTP before sending DATA.

Otherwise, choose your Proving_Interval more wisely.

--brian

Erickson, Mark wrote:                     (Tue, 03 Oct 2006 09:12:37)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/