Subject: [Sigtran] Notify messages in M3UA

From: Satya Prasad Nemana <[email-masked]>
Date: Thu, 02 Nov 2006 15:27:46 +0530

Hi 

I have a question regarding the notify messages in M3UA.
A lot of clauses are found in the RFC where in all the circumstances in 
which the notify messages
are issued by the SGP are mentioned.
But how should the ASP react to the notify messages is never mentioned 
anywhere which
has caused many implmentations of AS to simply ignore the messages and 
still remain RFC compliant.
Steps to be taken when Notify messages are not received by the ASP are 
also not mentioned.

Can a clarification be solicited in this aspect?

Thanks
Satya Prasad

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Nov 2006 06:35:20 -0700

Satya,

All NOTIFY messagse are advisory.  That is, although they must be
issued by the SGP in specific circumstances, but they do not compel
the ASP to take any action whatsoever.  Yes, an ASP that ignores all
NOTIFY messages can be compliant with the specification (but might
not be very useful in practice).  I am not sure what you mean by
"not received by the ASP" as SCTP is a reliable transport protocol.

--brian

Satya Prasad Nemana wrote:                  (Thu, 02 Nov 2006 15:27:46)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/