Subject: RE: [Sigtran] RFC 4666 M3UA - Reg Request Message

From: "Bhandari, Jitin (Jitin)" <[email-masked]>
Date: Tue, 7 Nov 2006 14:55:29 -0500

Brian,

If you look at LOADSEL from ONLY CIC perspective, all I see that a new parameter is defined "CIC RANGE" which can very well be defined within Routing Key defined in 4666. 

Again talking ONLY from CIC perspective, I don't know as what problems you are trying to quote which are solved by LOADSEL and not by re-introducing CICs at Reg-Req.

I agree to the fact that LOADSEL takes a generic approach for Load sharing but I disagree load sharing when comes to a very CIC level. Each CIC is a unique physical resource between any OPC/DPC. All call handling messages for any OPC-DPC-CIC resource should be handled by a unique Active ASP.

Again notification to other ASPs regarding resources which are never handled by them is the same as such resources are given a generic treatment at SG (or by Default ASP as RFC says). I don't understand as why this is a better solution? 
Relocating ISUP handling to SG or default ASP is implementation dependant if you are trying to avoid that by this method.

I also don't understand as what other three problems pertaining to CIC & ISUP traffic is solved by LOADSEL? 

LOADSEL is a good draft from various load sharing parameters at various protocols but I still think it does not solve any issues for ISUP and traffic at CIC Level.

-Jitin

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Tuesday, November 07, 2006 2:35 PM
To: Bhandari, Jitin (Jitin)
Cc: 'Ilie Glib'; Haresign Lincoln; [email-masked]
Subject: Re: [Sigtran] RFC 4666 M3UA - Reg Request Message

Jitin,

Bhandari, Jitin (Jitin) wrote:                     (Tue, 07 Nov 2006 14:25:57)
> Thanks Brian for the responses. I did read the summary section and it is
> just that I was trying to confirm couple of thoughts being exchanged in this
> email chain.
> 
> Anyhow, I agree with Ilie that either by re-introducing CIC Ranges for
> Reg-Req or defining LOADSEL draft as an extension could be a viable path.
> 
> However, I still think that LOADSEL is not solving any issues of un-handled
> CICs when AS is unavailable so if CICs are re-introduced in Reg-Req message
> for ISUP traffic, re-introducing CIC ranges in Reg-Req is the simplest way
> to solve handling of ISUP traffic. 

I disagree.  Routing on CIC introduces more problems, LOADSEL less.

> Having a default ASP handling un-available CICs is same as having an
> implementation dependant solution at SG. I think Notify procedures between
> ASPs also don't solve this issue.

It is a far better situation with LOADSEL where ASPs are informed that a
CIC range is unserved.

> Talking about requirements, If CIC handling (Note ONLY CIC Handling between
> ASPs) is the only issue to be solved, then for a simplest solution I see
> re-introduction of CIC ranges is the best way. Though for now I see CIC
> handling amongst ASP as a bigger issue given provisioning nature of CICs at
> MGC.

It is certainly not the simplest approach and it does not address the three
other issues addressed by LOADSEL.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 7 Nov 2006 23:52:00 -0700

Jitin,

I don't see how you can possibly need to split CIC ranges across ASPs,
and why you could possibly need to register them dynamically even if you
did.

It think that you are expecting M3UA to solve internal MGC design issues
that it was never intended to solve.

Why do you need to do this at all?

Why do you not just place two ASPs in front of your MGC and distribute
by CIC within the MGC architecture to your heart's content?

Why do you expect the SG (which is obviously distant from the MGC) to
perform this distribution for you?.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/