Subject: [Sigtran] SCTP Association and M3UA relation

From: "Ambika Tripathy" <[email-masked]>
Date: Wed, 29 Nov 2006 12:19:24 +0530

Hi All,

    I have doubt regarding the SCTP association and M3UA link.The doubt is.

Can we map multiple SCTP associations to a single M3UA(ASP) or there is only
one-to-one relationship between a M3UA layer and one SCTP association.

+----------------------------------------+
|                 M3UA                   |
+----------------------------------------+
|   Asso   |   Asso   |   Asso   |  Asso |
+----------------------------------------+

-- 
Br,
Ambika Prasad Tripathy
Nethawk Networks
Cell: +91-94375 47730
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Bhanu Prakash <[email-masked]>
Date: Wed, 29 Nov 2006 12:31:35 +0530

Ambika,

We cannot map multiple SCTP associations to a single ASP.

Regards,
Bhanuprakash.

Ambika Tripathy wrote:

> Can we map multiple SCTP associations to a single M3UA(ASP) or there 
> is only one-to-one relationship between a M3UA layer and one SCTP 
> association.
>  
>------------------------------------------------------------------------
>

---

From: Mahantesh <[email-masked]>
Date: Wed, 29 Nov 2006 12:45:22 +0530

*Ambika,*
**
*Between an SGP and an ASP?  Zero or one.  Two is not permitted.
If a second connection is attempted to an SGP and the SGP knows
that it is the same ASP (from the remote or local IP address(es)
and port and configuration) it should refuse the connection.  If
it cannot determine the ASP identity (or uniqeness) from these
parameters, it will require an ASP Id.  If a ASP Up is received
on two associations with the same ASP Id, the second should be
refused with error Invalid ASP Id.  Note that an ASP or an SGP
is not a piece of hardware or an IP host (although they are
drawn that way in the examples), it can be a process or
sub-process within a host.  As such, one host can represent
multiple ASPs, but each must have only one association to each
SGP.
*

*~! *
*Mahantesh*

On 11/29/06, Ambika Tripathy <[email-masked]> wrote:
> Can we map multiple SCTP associations to a single M3UA(ASP) or there is
> only one-to-one relationship between a M3UA layer and one SCTP association.
>

-- 
Rgrds,
-Mahantesh

---

From: "Ashish Soregaonkar" <[email-masked]>
Date: Wed, 29 Nov 2006 12:57:46 +0530

I dont think this is the limitation, though having multiple associations
between the same nodes is of little help. If you want path redundancy, then
a single association can very well do that.
If a node is designed that way, I dont see a problem with having multiple
associations between two nodes. As the associations are mapped to the same
node pair, management messaging should not be considered association
specific. Consider it one ASP-SGP pair specific and then all rules about
duplicate messaging apply.
This has to be implementaion specific.

-Ashish

---

From: Mahantesh <[email-masked]>
Date: Wed, 29 Nov 2006 13:08:03 +0530

Hi,

Multiple Association between two nodes is possible.
But for ASP, there is a 1:1:1 relationship between AS:RC:RK.

*~! * *Mahantesh*

On 11/29/06, Ashish Soregaonkar <[email-masked]> wrote:
> >  On 11/29/06, Ambika Tripathy < [email-masked]> wrote:
> >
> > >  Hi All,
> > >
> > >     I have doubt regarding the SCTP association and M3UA link.Thedoubt is.
> > >
> > ________________________

---

From: "Ambika Tripathy" <[email-masked]>
Date: Wed, 29 Nov 2006 13:45:30 +0530

Ashish,

But for path redundancy Multihomed path for Asociation is there.
My question is is there any need of multiple SCTP association for one
ASP-SGP communication. RFC-3332 describes about M3UA layer keeps track of
the underlaying SCTP associoations state but there is no such description
for multiple Association for single ASP-SGP communication.

---

From: "Ashish Soregaonkar" <[email-masked]>
Date: Wed, 29 Nov 2006 16:28:25 +0530

I think its not required. Multihoming should give you the same results
unless you are trying to achieve SCTP layer redundancy.

-Ashish

On 11/29/06, Ambika Tripathy <[email-masked]> wrote:
> > If a node is designed that way, I dont see a problem with having
> > multiple associations between two nodes. As the associations are mapped to
> > the same node pair, management messaging should not be considered
> > association specific. Consider it one ASP-SGP pair specific and then all
> > rules about duplicate messaging apply.
> > On 11/29/06, Mahantesh <[email-masked] > wrote:
> > >
> > > *Ambika,*
> > > **
> > >  On 11/29/06, Ambika Tripathy < [email-masked] > wrote:
> > >
> > > >  Hi All,
> > > >

---

From: "Ilie Glib" <[email-masked]>
Date: Wed, 29 Nov 2006 12:22:07 +0100

Hello Folks,

I think having multiple SCTP associations between an ASP and an SGP is
not an interoperable scenario, although the M3UA standard does not
prohibit it explicitly.

For instance loadcharing, changeover etc. are not detailed in the M3UA
RFC for that particular scenario.

Regards

//Ilie

On 11/29/06, Ashish Soregaonkar <[email-masked]> wrote:
> > On 11/29/06, Ashish Soregaonkar < [email-masked]> wrote:
> > >
> > > > Between an SGP and an ASP?  Zero or one.  Two is not permitted.
> > > > ~!
> > > > Mahantesh

-- 
Ilie