Subject: [Sigtran] Is it possible to make all the associations ACTIVE at a time at M3UA level ?

From: Mahantesh <[email-masked]>
Date: Tue, 6 Feb 2007 14:19:26 +0530

Hi,

I m using the following setup for M3UA testing

+------------+                         +--------------+
|              |                          |                |     [@ M3UA]
|________|                          |_________|
    ^     |                                     ^     |
   |     V                                    |     V
+------------+ p1-------------------- +----------------+
|              |  p2-------------------  |                 |    [@ SCTP
level]
| 1.1.1.39 |  p3-------------------- |  1.1.3.65    |
|________|  p4-------------------- |__________|
  server                                   client

ports used:
========
               p1-9002 - Association-1
               p2-9004 - Association-2
               p3-9006 - Association-3
               p4-9008 - Association-4

My query is

1. Is it possible to make all the associations ACTIVE at a time at M3UA
level ?and how?
2. Tried with 2-Associations, but at a time only one Association is active.
For another association, UP-ACK is not received for ASP-UP message.

*Rgds,
Mahantesh
[email-masked]
Call: 9945363151, 9980941127*
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 6 Feb 2007 02:13:37 -0700

Mahantesh,

Mahantesh wrote:                                                                 (Tue, 06 Feb 2007 14:19:26)
>    ports used:
> 
>    ========
>                   p1-9002 - Association-1
>                   p2-9004 - Association-2
>                   p3-9006 - Association-3
>                   p4-9008 - Association-4
> 
>    My query is
> 
>    1.  Is  it  possible  to make all the associations ACTIVE at a time at
>    M3UA level ?and how?

Yes.  ASP Up.

> 
>    2.  Tried  with  2-Associations, but at a time only one Association is
>    active.  For  another  association,  UP-ACK is not received for ASP-UP
>    message.

Your implementation might not support this arrangement.  Only one association
active at the M3UA level is permitted between a given SGP and ASP.  So, in
your case, either the one host must support multiple SGP per host, or the
other host must support multiple ASPs per host.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Dario Filjar <[email-masked]>
Date: Tue, 6 Feb 2007 05:13:08 -0800 (PST)

Hi,
   
  isn't this case with multiple associations between two processes?
  I did not understand what "active association" means. 
   
  I understood that ASP UP is related to Application Process states - here we have one M3UA ASP (or IPSP) activating on SGP (another IPSP)?
  SCTP is transport, so those associations can be established or down.
   
  Why would you send 4 ASP Up messages, and how SGP would react on those
  4 ASP Up messages, say, carrying identical ASP ID?
   
  thanks.
  Best regards, Dario

"Brian F. G. Bidulock" <[email-masked]> wrote:
  Mahantesh,

Yes. ASP Up.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

 
---------------------------------
Don't get soaked.  Take a quick peak at the forecast 
 with theYahoo! Search weather shortcut.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 6 Feb 2007 07:07:10 -0700

Dario,

                 ---------- 1.1.3.65:9002 ASP1
                /                             
  1.1.1.39:2095 ----------- 1.1.3.65:9004 ASP2
     SGP1      |\                             
               | ---------- 1.1.3.65:9006 ASP3
                \                             
                 ---------- 1.1.3.65:9008 ASP4

Dario Filjar wrote:                               (Tue, 06 Feb 2007 05:13:08)
>    isn't this case with multiple associations between two processes?

Not necessarily.  A host can support multiple ASPs or SGPs.
>    I did not understand what "active association" means.

By "active for M3UA" I assumed Mahantesh meant in the ASP Up state.
> 
>    I  understood  that  ASP UP is related to Application Process states -
>    here we have one M3UA ASP (or IPSP) activating on SGP (another IPSP)?

Well, no, it could be 4 ASPs activating on 1 SGP or 1 ASP activating on
4 SGP, or some other combination.

>    SCTP is transport, so those associations can be established or down.

I assumed that all 4 were established as Mahantesh indicated.
>    4 ASP Up messages, say, carrying identical ASP ID?

Depends on what ASP is connecting to what SGP.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Dario <[email-masked]>
Date: Tue, 6 Feb 2007 06:52:38 -0800 (PST)

Hi Brian,

I understand this - if these were multiple signalling processes (either 4
ASPs and one SGP, or one ASP with 4 SGP/SGs or combination of four
signalling process pairs, they'd work separately
(communication between redundant processes - either ASPs or SGPs is out of
the RFC scope).

However how would this work with just single processes?
I understood that multiple SCTP associations between two processes are not
recommended,
however standards do not forbid such configuration.

thanks!
Best regards, Dario

-- 
View this message in context: http://www.nabble.com/Is-it-possible-to-make-all-the-associations-ACTIVE-at-a-time-at-M3UA-level---tf3179458.html#a8827309
Sent from the IETF - Sigtran mailing list archive at Nabble.com.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 6 Feb 2007 12:19:32 -0700

Dario,

Dario wrote:                                                         (Tue, 06 Feb 2007 06:52:38)
> recommended, however standards do not forbid such configuration.

If the ASPs identify themselves with a unique ASP Id, they are separate ASPs.
If they do not use a unique ASP Id, there is an error for that.  If they do
not identify themselves at all (no ASP Id) the SGP is welcome to treat them
as independent ASPs.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Ambika Tripathy" <[email-masked]>
Date: Wed, 7 Feb 2007 09:35:37 +0530

Hi Dario,

     There is no suhc procedure defined in the rfc where we cam map multiple
SCTP association to a single ASP.
There is a one to one relationship between the ASP with SCTP association.

br,
Ambika Prasad Tripathy

On 2/7/07, Brian F. G. Bidulock <[email-masked]> wrote:
> > View this message in context:
> http://www.nabble.com/Is-it-possible-to-make-all-the-associations-ACTIVE-at-a-time-at-M3UA-level---tf3179458.html#a8827309

-- 
Br,
Ambika Prasad Tripathy
Nethawk Networks
Cell: +91-94375 47730