Subject: [Sigtran] [SUA] In multiple SG, when ASP receives DUNA(SSN) from a SG.

From: Moohyoung Kim <[email-masked]>
Date: Tue, 13 Feb 2007 22:28:06 +0900

Hi, Experts ...

I have a questions about SUA

                             ---------
                  --------| SG#1 |--------
--------     |           ---------          |    ---------
| MSC | ---  SS7                      IP   ---| SMSC |
--------     |           ---------          |    ---------
                  --------| SG#2 |--------
                              ---------

The above figure is SUA network.

In RFC 3868,
3.4.  Signalling Network Management (SNM) Messages

3.4.1.  Destination Unavailable (DUNA)

    In the scope of SUA, this message is covered by the PC- or N-state
    indication passed between SCCP and local SCCP-user.  The DUNA  
message
    is sent from the SG or relay node to all concerned ASPs (servicing
    SCCP-users considered local to the SG or relay node, see chapter
    1.3.1.1), when a destination or SCCP-user has become unreachable.
    * The SUA-User at the ASP is expected to stop traffic to the  
affected
    destination or SCCP-user through the SG or relay node initiating the
    DUNA. *

If SMSC receive a DUNA(SSN) from SG#1 and SG#2 did not send DUAN(SSN)  
to SMSC,
is it means that SMSC can send traffic to the affected SCCP-user  
through SG#2 ?

Regards

* NOTICE:
    Change the Text Encoding to UTF-8 if you can't read the text in  
this mail.

Moo-hyoung Kim
Network R&D II / Assistant Manager
Network BIZ. Division
UANGEL Corporation
Tel   : +82-31-710-6240
Mobile: +82-11-9052-1122
E-mail: [email-masked]

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 13 Feb 2007 08:08:46 -0700

Moohyoung,

Moohyoung Kim wrote:                                (Tue, 13 Feb 2007 22:28:06)
> I have a questions about SUA

[snip]

> to SMSC, is it means that SMSC can send traffic to the affected SCCP-user
> through SG#2 ?

No.  N-STATE means that the remote SSN or SCCP(SSN=0) is unavailable.  It does
not matter what route you take to an unavailable SSN or SCCP(SSN=0), it is
still unavailable.

N-PCSTATE (point code) indicates unavailability via a path.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/