Subject: [Sigtran] Working of IPSP Clients in Override Mode !

From: Mahantesh <[email-masked]>
Date: Wed, 21 Feb 2007 13:18:02 +0530

Hi there,

I am using ONE IPSP server and TWO IPSP clients configured in OVERRIDE mode.
When I brought-up server and client-1 both comes up as an ACTIVE node. After
bring-up client-2, client-1 goes to INACTIVE state.
Now,

If I kill client-2, Client-1 should come up as ACTIVE. In my case, Client-1
is still INACTIVE.
Is it so that, always ASP-ACTIVE message needs to be sent to bring-up the
client-1, even in case of other ASP-failure.

>From server NTFY message with "ASP Failure" is sent to Client-1 [RC value is
wrong in NTFY message].
Is this behaviour acceptable? [No, I guess]
Is it configuration dependent?

Rgds,
Mahantesh
IntelliNet Technologies
[email-masked]
Call: 9945363151, 9980941127
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 21 Feb 2007 02:30:57 -0700

Mahantesh,

Mahantesh wrote:                                                 (Wed, 21 Feb 2007 13:18:02)
>    When I brought-up server and client-1 both comes up as an ACTIVE node.
>    After bring-up client-2, client-1 goes to INACTIVE state.
>    Now,
>    If  I  kill  client-2,  Client-1 should come up as ACTIVE. In my case,
>    Client-1 is still INACTIVE.
>    Is  it so that, always ASP-ACTIVE message needs to be sent to bring-up
>    the client-1, even in case of other ASP-failure.
>    From  server  NTFY  message with "ASP Failure" is sent to Client-1 [RC
>    value is wrong in NTFY message].

It appears that the problem is that the RC value is wrong in the NTFY message.
I assume that if client-1 receive an ASP Failure message with the correct RC
value, it would follow with an ASP-ACTIVE message.

Nevertheless, it is up to the IPSPs to coordinate amoung themselves.  When
IPSP-2 fails, IPSP-1 should detect this also through IPSP-IPSP communication.
The implementation might be relying, however, upon the application to perform
this IPSP-IPSP communication.

Step 1 would be correcting the problem with the RC value in the NTFY message.

--brian

>    [1][email-masked]
> References
>    1. mailto:[email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/