Subject: [Sigtran] M2UA, M3UA: Notify and Dynamic Registration

From: "Grasic Valerij ITPSA9" <[email-masked]>
Date: Thu, 15 Feb 2007 13:56:42 +0100

Hi,

I have questions about sending Notify message in case 
of dynamic registration for both protocols M3UA and M2UA when 
there is moving into AS-INACTIVE state. For both protocols it is 
said that Notify message must be send after change in AS state. 
For protocol M3UA there is flow chart regarding dynamic registration:
                SGP                             ASP1 
                 |                               |
                 |<------------ASP Up------------|
                 |----------ASP Up Ack---------->|
                 |                               |
                 |<----REGISTER REQ(LRCn,RKn)----|  LRC: Local Routing
                 |                               |       Key Id
                 |----REGISTER RESP(LRCn,RCn)--->|   RK: Routing Key
                 |                               |   RC: Routing Context
                 |----NTFY(AS-INACTIVE)(RCn)---->|
                 |                               |
                 |                               |
                 |<------- ASP Active(RCn)-------|
                 |-----ASP Active Ack (RCn)----->|
                 |                               |
                 |-----NTFY(AS-ACTIVE)(RCn)----->|
                 |                               |

For M2UA there is a flow chart:
                SGP                       ASP1
                 |
                 |<---------ASP Up----------|
                 |--------ASP Up Ack------->|
                 |                          |
                 |<--------REG REQ----------|
                 |------REG REQ RESP------->|
                 |                          |
                 |<-------ASP Active--------|
                 |------ASP Active Ack----->|
                 |                          |
                 |------NTFY(AS-ACTIVE)---->|

Which of following is correct (sending Notify with move into AS-ACTIVE
state):
1. SGP must send Notify after ASP Up and before REG Req (following text
description - Notify after ASP Up). 
2. SGP must send Notify after ASP Up and before REG Req,
plus can send another Notify after REG REQ Resp
3. SGP can send Notify after REG Resp (following flow chart description 
plus Notify after ASP Up)

If statement 3.) is true, this can makes problem if another equipment is
working as statement 1.)?  

Or there is even differrence between  M3UA and M2UA on this issue?

Any suggestion wellcomed!

Regards,
Valerij

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 15 Feb 2007 09:10:38 -0700

Grasic,

When the AS changes state, the SGP sends NTFY to all ASPs in the
ASP-INACTIVE or ASP-ACTIVE state for the AS.  The SGP may send
NTFY to ASPs newly ASP-INACTIVE for an AS.

So, when an ASP completes the ASP Up procedure: it might receive
NTFY of the current state of the AS for each AS for which the
ASP is configured at the SGP; it will receive NTFY that all of
the AS for which it is configured at the SGP that were
previously in the AS-DOWN state have moved to the AS-INACTIVE
(as a result of ASP Up).  When an ASP completes a registration
procedure: it might receive NTFY of the current state of the AS
as it has just become ASP-INACTIVE for the AS; it will receive
NTFY if the AS was AS-DOWN previous to registration as it has
moved to the AS-INACTIVE state as a result of registration.

--brian

Grasic Valerij    ITPSA9 wrote:                (Thu, 15 Feb 2007 13:56:42)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/