Subject: [Sigtran] How to share Routing info. in IPSPs communication at M3UA level

From: [email-masked]
Date: Mon, 12 Feb 2007 23:41:45 -0800

Dear 

According to rfc  4666, This is the call flow for  Single Exchange IPSPs 
Communication at M3UA level, I can't be able to know how they exchange 
their Routing Keys and how to create respective Routing Context(RCb). 
thanks in advance...

                  IPSP-A                           IPSP-B
                 |                                |
                 |-------------ASP Up------------>|
                 |<----------ASP Up Ack-----------|
                 |                                |
                 |<------- ASP Active(RCb)--------|  RC: Routing Context
                 |-----ASP Active Ack (RCb)------>|      (optional)
                 |                                |
                 |                                |
                 |<=========  DATA (RCb) ========>|
                 |                                |
                 |<-----ASP Inactive (RCb)--------|  RC: Routing Context
                 |----ASP Inactive Ack (RCb)----->|      (optional)
                 |                                |
                 |<-----------ASP Down------------|
                 |---------ASP Down Ack---------->|
                 |                                |

With Regards,
Dheeraj
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 13 Feb 2007 01:24:44 -0700

Dheeraj.Dubey,

The RC can be provisioned at either or both sides.  A side not provisioning
the RC may register a routing key with the other.  The exchange is the same
as for AS-SGP registration where the IPSP registering behaves like the AS
and the IPSP providing registration behaves like the SGP.

--brian

[email-masked] wrote:            (Mon, 12 Feb 2007 23:41:45)
> 
>    Dear
>    According  to  rfc   4666,  This is the call flow for  Single Exchange
>    IPSPs  Communication  at  M3UA level, I can't be able to know how they
>    exchange  their  Routing  Keys  and  how  to create respective Routing
>    Context(RCb). thanks in advance...
>                      IPSP-A                           IPSP-B
>                     |                                |

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: [email-masked]
Date: Tue, 13 Feb 2007 01:23:12 -0800

Thanks for instant response , it means after receiving ASPUP-ACK message 
by IPSP-A , IPSP-A should be send REGREQ to IPSP-B to register itself. 
Like this...
                          IPSP-A                           IPSP-B
                     |                                |
                     |-------------ASP Up------------>|
                     |<----------ASP Up Ack-----------|
                           |                                |
                     |----------- REG REQ (RKa)------>|(?)
                     |<---------- REG RSP (RCb)-------|
                           |                                |
                     |<------- ASP Active(RCb)--------|  RC: Routing 
Context
                     |-----ASP Active Ack (RCb)------>|      (optional)
                     |                                |
                     |                                |
                     |<=========  DATA (RCb) ========>|
                     |                                |
                     |<-----ASP Inactive (RCb)--------|  RC: Routing 
Context
                     |----ASP Inactive Ack (RCb)----->|      (optional)
                     |                                |
                     |<-----------ASP Down------------|
                     |---------ASP Down Ack---------->|
                     |                                |

Now my question is this, How will IPSP-B generate Routing Context(RCb) 
from Routing Key(RKa) of IPSP-A? Is there any algorithm to do this? thanks 
in advance...

With Regards,
Dheeraj 

"Brian F. G. Bidulock" <[email-masked]> 
02/13/2007 12:24 AM
Please respond to
[email-masked]

To
[email-masked]
cc
[email-masked]
Subject
Re: [Sigtran] How to share Routing info. in IPSPs communication at M3UA 
level

Dheeraj.Dubey,

The RC can be provisioned at either or both sides.  A side not 
provisioning
the RC may register a routing key with the other.  The exchange is the 
same
as for AS-SGP registration where the IPSP registering behaves like the AS
and the IPSP providing registration behaves like the SGP.

--brian

[email-masked] wrote:            (Mon, 12 Feb 2007 
23:41:45)
>                           |<------- ASP Active(RCb)--------|  RC: 
Routing
>    Context
>                           |<-----ASP Inactive (RCb)--------|  RC: 
Routing
>    Context

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 13 Feb 2007 02:30:11 -0700

Dheeraj.Dubey,

[email-masked] wrote:                                         (Tue, 13 Feb 2007 01:23:12)
> 
>    Thanks  for  instant  response  ,  it  means after receiving ASPUP-ACK
>    message by IPSP-A , IPSP-A should be send REGREQ to IPSP-B to register
>    itself. Like this...
>                               IPSP-A                           IPSP-B
>                        |                                |
>    from  Routing  Key(RKa)  of IPSP-A? Is there any algorithm to do this?

IPSP-B can use whatever algorithm it wants to genereate a unique RC.  The
simple approach is to provision RKa against RCb.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Ankit Kumar Sharma" <[email-masked]>
Date: Tue, 13 Feb 2007 11:20:29 +0000

Dheeraj,

On 2/13/07, [email-masked] <[email-masked]>
wrote:
> by IPSP-A , IPSP-A should be send REGREQ to IPSP-B to register itself. Like
> this...

REGREQ is a optional message which is only used, when someone wants to
dynamically register routing key. You could provision routing keys
statically as well on both ends.

                           IPSP-A                           IPSP-B
>  *"Brian F. G. Bidulock" <[email-masked]>*
>
> 02/13/2007 12:24 AM  Please respond to
> [email-masked]
>
>   To
> [email-masked]  cc
> [email-masked]  Subject
> Re: [Sigtran] How to share Routing info. in IPSPs communication at
> M3UA level
>
>
>
>
>
>
> Dheeraj.Dubey,
>

cheers,
Ankit

---

From: "Ambika Tripathy" <[email-masked]>
Date: Thu, 15 Feb 2007 10:05:15 +0530

Hi All,

   Can we deliver REG REQ message in IPSP case???
Mean can we have multiple RK in IPSP configuration?

br,
Ambika P. Tripathy

On 2/13/07, Ankit Kumar Sharma <[email-masked]> wrote:
>
> Dheeraj,
>
> On 2/13/07, [email-masked] < [email-masked]>
> wrote:
> >
> >

---

From: "Ankit Kumar Sharma" <[email-masked]>
Date: Thu, 15 Feb 2007 09:00:36 +0000

>    Can we deliver REG REQ message in IPSP case???

Yes

Yes

br,
> > >   *"Brian F. G. Bidulock" <[email-masked] >*
> > >