Subject: [Sigtran] Changeover M3UA-M2PA

From: pavel <[email-masked]>
Date: Thu, 22 Feb 2007 16:00:44 +0100

I have the following scenario. Connection between STP-ASP is M3UA and 
between STP-STP M2PA.
My question is which primitives must be exchanged in the case of the 
Changeover-Procedure, when
one connection between STP-ASP is failed, to retransmit the messages 
over another STP.

Pavel

                                                      +-------+
                                                       |  ASP  |
                                                      +-------+
                                                           |    |
                                                        M3UA
                                         _________|    |_________
                                        |                               
           |
                                        |                                
          |
                                        |                                
          |
                                    +-------+                          
+--------+
                                    |SG/STP|------------------|SG/STP |
                                    +-------+       M2PA        +--------+
                                        |                               
           |
                                        |                               
           |
                                        
|                                          |
                                      SS7                                
   SS7

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Haresign Lincoln" <[email-masked]>
Date: Thu, 22 Feb 2007 11:32:27 -0500

Pavel,

The connection between STPs is somewhat irrelevant in this scenario.

And unfortunately there is no "change over procedure" in M3UA that
includes retrieval with sequence numbers.  So...in the case of loss of
an association, any messages that had been transmitted over SCTP, but
not received on the remote end is lost.

Regards,
Lincoln

-----Original Message-----
From: pavel [mailto:[email-masked]] 
Sent: Thursday, February 22, 2007 10:01 AM
To: [email-masked]
Subject: [Sigtran] Changeover M3UA-M2PA

I have the following scenario. Connection between STP-ASP is M3UA and
between STP-STP M2PA.
My question is which primitives must be exchanged in the case of the
Changeover-Procedure, when one connection between STP-ASP is failed, to
retransmit the messages over another STP.

Pavel

                                                      +-------+
                                                       |  ASP  |
                                                      +-------+
                                                           |    |
                                                        M3UA
                                         _________|    |_________
                                        |                               
           |
                                        |

          |
                                        |

          |
                                    +-------+                          
+--------+
                                    +-------+       M2PA
+--------+
                                        |                               
           |
                                        |                               
           |
                                        
|                                          |
                                      SS7

   SS7

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 22 Feb 2007 11:32:09 -0500

Pavel,

To give a more complete picture, let me add that this is exactly what
happens when a node goes down in SS7 network.

   Thanks,
   Tolga

> From: Haresign Lincoln [mailto:[email-masked]]
> Sent: Thursday, February 22, 2007 11:32 AM
> To: pavel; [email-masked]
> Subject: RE: [Sigtran] Changeover M3UA-M2PA
>
>
> Pavel,
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Feb 2007 11:19:10 -0700

pavel,

Actions taken with regard to the association, both at the ASP and the
SG, equivalent to the sequenced changeover procedure of Q.704/Clause 5
are described in Section 1.5.1.2 (SPP Diverting peer SPP Traffic) of this
draft:

 http://www.ietf.org/internet-drafts/draft-bidulock-sigtran-corid-05.txt

With regard to the interaction between STPs, the normal forced rerouting
actions are taken per the likes of Q.704/Clause 7 (Forced rerouting).

--brian

On Thu, 22 Feb 2007, pavel wrote:

>    +-------+                +--------+
>      SS7                       SS7

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 23 Feb 2007 08:22:33 -0500

Pavel,

Just to clarify, the draft pointed by the link provided below is not a WG
item, i.e. it represents the views of the author rather than the consensus
of the WG.

    Thanks,
    Tolga

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Brian F. G. Bidulock
> Sent: Thursday, February 22, 2007 1:19 PM
> To: pavel
> Subject: Re: [Sigtran] Changeover M3UA-M2PA
>
>
> pavel,
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 23 Feb 2007 09:46:19 -0700

Tolga,

Meaning what?

--brian

Tolga Asveren wrote:                                                 (Fri, 23 Feb 2007 08:22:33)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: pavel <[email-masked]>
Date: Sun, 25 Feb 2007 17:20:20 +0100

Brian,

thanks for your answer.

i.e. if one ss7 SEP communicate with ASP and association to ASP is 
broken, then SG1 must send the TFP-Message
to SEP, when no alternative ways on SG1 to ASP more exists. As response 
activate the SEP rerouting to ASP over
SG2 (Forced rerouting).
But the SG1 have an alternate route to ASP (e.g. over SG2), the 
following trafic must be transporeted on this route.
Please correct me.

               +-------+
               |  ASP  |
               +-------+
                 |    |
                  M3UA
        _________|    |_________
       |                        |
       |                        |
       |                        |
   +-------+                +--------+
   |  SG1  |----------------|   SG2  |
   +-------+      M2PA      +--------+
       |                     /    
       |                    /     
       |  _________________/
       | /
       |/
   +-------+ 
   |SS7 SEP|                   
   +-------+

Regards,
pavel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 25 Feb 2007 16:34:28 -0700

pavel,

That is correct.  When the association SG1-ASP fails, SG1 force reroutes
traffic destined for the ASP to SG2 over C-links (M2PA).  When redirecting
traffic to an alternate route in this fashion, Q.704/Clause 13 requires that
SG1 send TFP to SG2 with respect to the ASP's point code.  Also, if the
network supports the transfer restricted national option, TFR is sent to
the SEP with respect to the ASP's point code indicating that it is more
efficient for the SEP to route messages destined for the ASP directly
via SG2.  But this is normal SS7 operation.

--brian

pavel wrote:                                      (Sun, 25 Feb 2007 17:20:20)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 26 Feb 2007 14:20:44 -0700

Pavel,

I don't really know of a document.  There might be something on PT's website,
or the IEC Proforum.  Google is your friend.

M2PA is like an IP SS7 link.  Its primary adtvantage is much higher capacity
than traditional narrow-band SS7 signalling links, as well as the ability to
use more cost-effective modern facilities (e.g. Carrier Ethernet) instead of
the more expensive groomed and graded voice channels that traditional
narrowband signalling links use.  Also, network interface cards for Ethernet
are cheaper than specialized TDM cards for narrowband signalling links.

--brian

On Mon, 26 Feb 2007, pavel wrote:

> Brian,
> 
> I have difficultys to understand what is the advantage of use M2PA as 
> C-links instead standard SS7-links.
> Exists some documents to clarify this?
> 
> Regards,
> Pavel
> 
>