Subject: [Sigtran] Doubt regarding routing context.

From: "Mohammad Arif" <[email-masked]>
Date: Mon, 17 Sep 2007 13:10:28 +0530

Hi All,

I have some confusion regarding routing contexts...

Imagine a scenarion where i have two IPSPs( IPSP-A and IPSB-B).
IPSP-A has pointcode -100 and IPSP-B has pointcode-200.

So during dyamnic regisration of RKs , IPSP -A sends Reg-req to IPS-B with
PC-100 and inturn gets a Routingcontext=1 from IPSB-B.
simialrly IPSP -B sends Reg-req to IPS-A with PC-200 and inturn gets a
Routingcontext=2 from IPSB-A.

so now if IPSB-A wants to sends ASP-ACTIVE to IPSP-B , then will it use
Routing context as 1 0r 2 ??
as all other sua messages from IPSP-A to IPSB-B will use routing context of
2, so wil it be used in ASP ACTIVE?

Also...in ASP ACTIVE ACK message the routing context recevied in ASP ACTIVE
should be sent back?

Please clarify.

Thanks i advance.

-- 
Regards
Mohammad Arif
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Ankit Kumar Sharma" <[email-masked]>
Date: Mon, 17 Sep 2007 09:40:31 +0100

Arif,

> Routing context as 1 0r 2 ??

Assuming double exchange mode, IPSP-A should use routing context 1. By
sending ASPAC, we are telling remote node that this ASP is ready to
process traffic for a particular AS, and that AS is identified by supplied
routing context.

> 2, so wil it be used in ASP ACTIVE?

No

>
> Also...in ASP ACTIVE ACK message the routing context recevied in ASP
> ACTIVE should be sent back?
>

Yes, because if IPSP-A wants to handle traffic for more than one AS then it
could send ASPAC messages(with respective routing contexts) for all of them.
After receiving ASPAC-ACK with a particular routing context, it could easily
identify AS for which peer is ready to process traffic.

---

From: "Mohammad Arif" <[email-masked]>
Date: Mon, 17 Sep 2007 14:40:39 +0530

Hi Ankit,
Thanks for your help.

Then will SUA messages like CORE,COREF,CODT,RELRE etc will use Routing
context= 2...??
because if this messages use routing-context=1 then it wont be possible to
deliver it to the correct ASP in receving side.

Please clarify if i m wrong,

thanks.

On 9/17/07, Ankit Kumar Sharma <[email-masked]> wrote:
> > So during dyamnic regisration of RKs , IPSP -A sends Reg-req to IPS-B
> > with PC-100 and inturn gets a Routingcontext=1 from IPSB-B.
>  as all other sua messages from IPSP-A to IPSB-B will use routing context
> > of 2, so wil it be used in ASP ACTIVE?
> >
>
> No
>
>
> >
> Yes, because if IPSP-A wants to handle traffic for more than one AS then
> it could send ASPAC messages(with respective routing contexts) for all of
> them. After receiving ASPAC-ACK with a particular routing context, it could
> easily identify AS for which peer is ready to process traffic.
>
>
> > Please clarify.
> >
> > Thanks i advance.
> >
> > --
> > Regards
> > Mohammad Arif
> >

---

From: "Ankit Kumar Sharma" <[email-masked]>
Date: Mon, 17 Sep 2007 12:50:56 +0100

> deliver it to the correct ASP in receving side.

IMO, you are correct with little modification in your statement. "....wont
be possible to deliver it to the correct *AS* in receving side."

> > On 9/17/07, Mohammad Arif < [email-masked]> wrote:
> > >
> > > Hi All,
> > >
> > > so now if IPSB-A wants to sends ASP-ACTIVE to IPSP-B , then will it
> > > use Routing context as 1 0r 2 ??
> > >
> >
> >  as all other sua messages from IPSP-A to IPSB-B will use routing
> > > context of 2, so wil it be used in ASP ACTIVE?
> > >
> >
> > No
> >
> >
> > >