Subject: [Sigtran] M3UA registration query

From: "David Laight" <[email-masked]>
Date: Tue, 9 Oct 2007 11:12:49 +0100

We are implementing the M3UA protocol and I have a query
about how the registration protocol is used in 'real life'.

The RFC seems to allow rather more flexibility that seems
strictly necessary (I guess this has something to do with
the differing views of those on the original comittee).

1) The registration procedures are marked as optional.
   Is it 'normal' to use these procedures ?

2) If the registration procedures are not used, what is
   used to identify the connecting client ?
   The only possible items are the IP address and the
   ASP Identifier from the ASP up message.  Neither seems ideal.
   (Clearly this is less of a problem if the server connects
   to the client - since the client can be configured to send
   all its outbound traffic to any server.)

3) The Routing key parameter seems to allow more flexibility
   than any application could possibly want.
   I can see why it multiple dpc, si and opc might be needed.
   But, since multiple routing contexts are also allowed, why
   the values are grouped as triplets - allowing, for instance,
   different si values for different remote pointcodes.
   In the non-IPSP case the dpc surely has to be that of the SS7
   MTP3 stack in the server system.
   
4) Reading the mailing list archive I notice that it is suggested to
   not use the 'double-exchange' for IPSP.
   Is it worth (trying) to implement DE ?
   Is it reasonable to detect a SE IPSP connection from the 'reversed'
   opc/dpc fields in the registation request ?

	David

Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)  
P Please consider the environment and don't print this e-mail unless you really need to

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 9 Oct 2007 08:21:34 -0600

David,

David Laight wrote:                                                 (Tue, 09 Oct 2007 11:12:49)
>    Is it 'normal' to use these procedures ?

Depends what you mean by normal.  ETSI TS 102 142 forbids it.

>    all its outbound traffic to any server.)

It provides no more information to have the server connect to the
client.

>    MTP3 stack in the server system.

Perhaps mre flexibility that you know how to use.  Even moderate
side local switches have multiple point codes to circimvent CIC
limitations.  In the multiple SG as STP configuration, the registered
point code is never the "server's" point code.

>    not use the 'double-exchange' for IPSP.

More than suggested: SE is recommended (meaning that DE is
counter-recommended).

>    Is it worth (trying) to implement DE ?

No.

>    opc/dpc fields in the registation request ?

OPC and DPC are not reversed for SE: they are the same as ASP/SG.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "David Laight" <[email-masked]>
Date: Tue, 9 Oct 2007 16:14:41 +0100

> Depends what you mean by normal.  ETSI TS 102 142 forbids it.

Hmmm....
That is a document we didn't know about.

	David