Subject: Re: [Sigtran] Can SGP send ASPDN or ASPUP messages?

From: "ZHOU Minggang" <[email-masked]>
Date: Wed, 20 Feb 2008 08:59:21 +0800

Hello Brian,
    I am confused to your reply, according to RFC 4666, it says ASP Down
ACK is used to reply a ASP Down message,
Would you like to give more explaination to this?

Best regards,
Zhou Minggang

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Tuesday, January 29, 2008 9:13 AM
To: Christopher Benson
Cc: [email-masked]; Shmelev Kirill
Subject: Re: [Sigtran] Can SGP send ASPDN or ASPUP messages?

Christopher,

The SGP may also send unsolicited ASP Down Ack, which is quicker than
many ASP Inactive Acks.

--brian

Christopher Benson wrote:              (Mon, 28 Jan 2008 13:29:56)
> Hi Shmelev,
> 
> A procedure that has been used in M3UA is that the SGP will send an 
> ASP-Inactive-Ack without receiving an ASP Inactive message first. I 
> believe this has the same eventual result that you desire.
> 
> ASP Inactive and ASP Down messages *FROM* an SGP, are not recognized 
> message types in that direction, and so cannot and should not be used.
> 
> With thanks, from Chris Benson.
> 
> On Thu, 17 Jan 2008, Shmelev Kirill wrote:
> 
> >>  Date: Thu, 17 Jan 2008 00:25:28 -0800 (PST)
> >>  From: Shmelev Kirill <[email-masked]>
> >>  To: [email-masked]
> >>  Subject: [Sigtran] Can SGP send ASPDN or ASPUP messages?
> >>  
> >>  
> >>  Hi, experts!
> >>  
> >>  Can SGP (or server in broader meaning) ever send ASPDN message? 
> >> Sometimes it  is more preferrable than closing SCTP association, 
> >> since the connection will  not be closed until ASPDN_ACK is 
> >> received
> >>  --
> >>  View this message in context: 
> >> http://www.nabble.com/Can-SGP-send-ASPDN-or-ASPUP-messages--tp14914
> >> 300p14914300.html  Sent from the IETF - Sigtran mailing list 
> >> archive at Nabble.com.
> >>  
> >>  
> >>  
> >>  _______________________________________________
> >>  Sigtran mailing list
> >>  [email-masked]
> >>  https://www1.ietf.org/mailman/listinfo/sigtran
> >>  
> 
> 
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran
_______________________________________________
Sigtran mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 20 Feb 2008 02:27:30 -0700

ZHOU,

RFC 4666/4.3.4.2 ASP-Down Procedures:

   If the ASP receives an ASP Down Ack without having sent an ASP Down
   message, the ASP should now consider itself to be in the ASP-DOWN
   state.

   If the ASP was previously in the ASP-ACTIVE or ASP-INACTIVE state,
   the ASP should then initiate procedures to return itself to its
   previous state.

This is the "unsolicited" ASP Down Ack procedure.

--brian

ZHOU Minggang wrote:                                                  (Wed, 20 Feb 2008 08:59:21)

---

From: "ZHOU Minggang" <[email-masked]>
Date: Thu, 21 Feb 2008 15:33:29 +0800

Thanks！ 

Best regards,
Zhou Minggang

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Wednesday, February 20, 2008 5:28 PM
To: ZHOU Minggang
Cc: Christopher Benson; [email-masked]; Shmelev Kirill; CHEN Disheng
Subject: Re: [Sigtran] Can SGP send ASPDN or ASPUP messages?

ZHOU,

--brian

> Hello Brian,
>     I am confused to your reply, according to RFC 4666, it says ASP 
> Down ACK is used to reply a ASP Down message, Would you like to give 
> more explaination to this?
> 
> Best regards,
> Zhou Minggang
>