Subject: [Sigtran] PN2AC transition clarification in n+k redundancy model

From: "Pascal Bouveron (Netbricks)" <[email-masked]>
Date: Mon, 7 Apr 2008 19:13:52 +0200

Hello,

I need some clarifiction for the PN2AC transition in n+k redundancy model.
What condition should trigger the move from AS-PENDING to AS-ACTIVE state ?

Is 1 ASP-ACTIVE enough to move AS-ACTIVE again, or should the AS wait for "n" Active ASPs again, as during the startup phase ?

In an n+k redundancy model, an AS moves AS-PENDING when it has no more Active ASP/IPSP to serve its traffic.

In rfc4666, the "Figure 4: AS State Transition Diagram" describes the "PN2AC" transition (Pending-to-Active) as "One ASP moves to 
ASP-ACTIVE".
Meaning that a single ASP/IPSP moving ASP_ACTIVE is enough to move AS_ACTIVE again.

However, there is no text dealing explicitely with this particular case in the procedures sections.

The only section dealing with the n+k redundancy case is "4.3.4.3.  ASP Active Procedures":

"   For the n+k redundancy case, ASPs that are in that AS should
   coordinate among themselves the number of active ASPs in the AS and
   should start sending traffic only after n ASPs are active."

and:

"    At startup or restart phases, an SGP or IPSP, upon receipt of an ASP
   Active message for the first ASP in a Loadshare AS, SHOULD NOT direct
   traffic to a newly active ASP until it determines that there are
   sufficient resources to handle the expected load (e.g., until there
   are "n" ASPs in state ASP-ACTIVE in the AS). "

So, the question is:
is 1 ASP-ACTIVE enough to move AS-ACTIVE again, or should the AS wait for "n" Active ASPs again ?

Allowing a single Active ASP to move AS-ACTIVE would help avoid traffic failure conditions, by allowing to run in 
"degraded-capacity" condition, rather than having to wait for the "full-capacity" to be reached again.

Any thoughts about that ?

Thanks.

Pascal Bouveron
www.netbricks.com 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran

---

From: "Barry Nagelberg" <[email-masked]>
Date: Fri, 11 Apr 2008 09:26:30 -0400

Pascal,

The intention is that the pending-to-active transition happens in a similar manner to the inactive-to-active transition.
So the "4.3.4.3. ASP Active Procedures" section, that you quote below, is applicable also to the pending-to-active
transition.

You are correct that in some cases "Allowing a single Active ASP to move AS-ACTIVE would help avoid traffic failure
conditions". However it's equally possible that allowing a single (underpowered) ASP to go active, in a situation where
2 or more ASPs are needed to handle a high traffic load, could just prolong the period of instability before equilibrium
is reached. So it's probably best to make the values for "n" and "k" configurable, and let the user decide how the ASP
should behave.

Barry Nagelberg

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Pascal Bouveron (Netbricks)
> Sent: Monday, April 07, 2008 1:14 PM
> To: [email-masked]
> Cc: Pascal Bouveron (Netbricks)
> Subject: [Sigtran] PN2AC transition clarification in n+k redundancy
> model
>
>
> Hello,
>
> In rfc4666, the "Figure 4: AS State Transition Diagram" describes the "PN2AC" transition (Pending-to-Active) as "One
ASP
> moves to