Subject: [Sigtran] Routing Context clarification

From: "Valerie Gastaud" <[email-masked]>
Date: Mon, 13 Oct 2008 10:30:36 -0400

Hello,
 
I'd like to get the advice from the list on the following question:
 
I believe it's very clear from the RFC 4666 that when multiple Routing
Keys are used across a common association, the Routing Context MUST be
sent to identify the traffic flow, assisting in the internal
distribution of Data messages. This implies that the routing context
must be sent in the ASPAC message and in the subsequent DATA messages
for this RK. 
 
However in the case where there is only one Routing Key used across an
association, it is specified that the routing context is optional and
can be negotiated between the AS and SG (sent in the ASPAC message). 
What is not clearly specified then is if the routing context MUST be
sent in the DATA message as soon as it has been sent in the ASPAC
message or if the routing context can be sent in the ASPAC message and
not in the DATA messages. 
 
What is the your advice on this point?
 
Valerie
 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Oct 2008 20:53:51 -0600

Valerie,

In the case of a single Routing Key, the Routing Context may be
included (or not) in any message.

For maximum interoperability, I would say that any implementation
that can discern the RC value, either through configuration or
negotiation, should include it in every sent message in which RC
can occur, yet require it in no received message in which RC is
conditional.

--brian

Valerie Gastaud wrote:                      (Mon, 13 Oct 2008 10:30:36)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "JEYASEELAN Samuel Durairaj" <[email-masked]>
Date: Mon, 13 Oct 2008 22:09:16 -0500

If the SSG recevs the DATA messages from an ASP which serves an AS, it should be able to process the DATA messages regardless of the RC. IMO, it does't matter whether RC is exchanged or not as long as the ASP serves one master.
 
 RC makes sense only if an ASP serves multiple ASes.

________________________________

From: [email-masked] on behalf of Valerie Gastaud
Sent: Mon 10/13/2008 9:30 AM
To: [email-masked]
Subject: [Sigtran] Routing Context clarification

Hello,

I believe it's very clear from the RFC 4666 that when multiple Routing Keys are used across a common association, the Routing Context MUST be sent to identify the traffic flow, assisting in the internal distribution of Data messages. This implies that the routing context must be sent in the ASPAC message and in the subsequent DATA messages for this RK. 
 
However in the case where there is only one Routing Key used across an association, it is specified that the routing context is optional and can be negotiated between the AS and SG (sent in the ASPAC message). 
What is not clearly specified then is if the routing context MUST be sent in the DATA message as soon as it has been sent in the ASPAC message or if the routing context can be sent in the ASPAC message and not in the DATA messages. 

Valerie

---

From: "Adnan Hasnain Alam" <[email-masked]>
Date: Sat, 18 Oct 2008 13:18:07 +0530

If the ASP is hosting/serving (what is the correct terminology?)
multiple AS'es, does it have to include the RC when it sending the
DATA to the SGP? My gut feeling is that the RC has to be included in
the DATA in both directions - ASP to SGP and SGP to ASP. Am I correct?

Cheers,

Adnan

On Tue, Oct 14, 2008 at 8:39 AM, JEYASEELAN Samuel Durairaj
<[email-masked]> wrote:
> If the SSG recevs the DATA messages from an ASP which serves an AS, it
> should be able to process the DATA messages regardless of the RC. IMO, it
> does't matter whether RC is exchanged or not as long as the ASP serves one
> master.
>
> Keys are used across a common association, the Routing Context MUST be sent
> to identify the traffic flow, assisting in the internal distribution of Data
> messages. This implies that the routing context must be sent in the ASPAC
> message and in the subsequent DATA messages for this RK.
>
> association, it is specified that the routing context is optional and can be
> negotiated between the AS and SG (sent in the ASPAC message).
> What is not clearly specified then is if the routing context MUST be sent in
> the DATA message as soon as it has been sent in the ASPAC message or if the
> routing context can be sent in the ASPAC message and not in the DATA
> messages.
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 18 Oct 2008 02:33:17 -0600

Adnan,

That is correct.

--brian

Adnan Hasnain Alam wrote:                     (Sat, 18 Oct 2008 13:18:07)