Subject: Re: [Sigtran] Regarding hostname/ip address based routing in SUA

From: "Rabindra Nath Tiwari" <[email-masked]>
Date: Wed, 31 Dec 2008 16:50:46 +0530

Hi Brian,

As you have mentioned that hostname/IP address based routing in SUA is
underspecified, can we expect any further version of SUA RFC which would
address these open points?
Please note that I am asking for this information because due to the
existence of these open points in RFC, from the implementer point of
view it becomes taking an implementation specific approach to address
these open points.

Thanks and Regards,
Rabindra Nath Tiwari
-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Monday, December 29, 2008 7:39 PM
To: Ashish Gupta
Cc: [email-masked]; Rabindra Nath Tiwari
Subject: Re: [Sigtran] Regarding hostname/ip address based routing in
SUA

Ashish,

Hostname/IP address in SUA is broken and underspecified.  Further
it attempts to extend SCCP which is outside the scope of the RFC.
I fully expect it to fall out of use.

--brian

Ashish Gupta wrote:                          (Mon, 29 Dec 2008 18:55:35)
> 
>    Hi,
> 
> 
> 
>    I  have two questions regarding the hostname/ip address based
routing
>    in SUA, about which the RFC doesn't talk about.
> 
> 
>    Q 1) I believe that hostname/ip address  based routing will be of
use
>    in the All-IP network, i.e. IPSP-IPSP mode of communication. Hence,
>    the SSNM messages generated by SUA layer in this scenario will be
the
>    result of the invocation of the N-STATE primitive only (having
>    affected hostname/ip address  and SSN). Unlike, the SG-ASP mode of
>    communication where the SSNM messages will also be generated as a
>    result of invocation of the N-PCSTATE primitives. Please clarify if
my
>    understanding is correct.
> 
> 
>    Q2)Inline with the previous question, since hostname/ip address
based
>    routing will be used by SUA-USER in only ALL IP domain, so what, if
at
>    all, would be the usage of network appearance in this scenario. As
>    network appearance parameter has the primary importance of
identifying
>    the point code format in the SS7 interworking domain. I believe
that
>    SUA can refrain from using network appearance parameter in this
>    scenario. Please clarify if my understand is correct.
> 
> 
> 
> 
>    Thanks,
> 
>    Ashish

> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 31 Dec 2008 04:38:08 -0700

Rabindra,

As John Loughney indicated when the SUA user was added, the
SUA-user (in contrast with the SCCP-user) is underspecified
and out of scope, yet was intended to meet some of the
perceived needs of the 3GPP at the time.  It was left to the
3GPP, or other organs that could take advantage of this
capability, to specify their operation further.

To my knowledge this has not occured.  After it was added
3GPP specified M3UA instead of SUA and that is pretty much
where it still sits.  It is largely up to someone that sees
a use for SUA-users to specify them further.  Otherwise,
the option will deprecate.

It is unlikely that it will happen within this WG as it has
all but closed down.

That's my view: others may disagree.

--brian

Rabindra Nath Tiwari wrote:                (Wed, 31 Dec 2008 16:50:46)