Subject: [Sigtran] SCTP ABORT Issue

From: "Kumar, Vivek (NSN - IN/Bangalore)" <[email-masked]>
Date: Mon, 12 Jan 2009 15:08:34 +0530

Hello Sir,

I am facing a rather strange scenario:

Endpoint A              Endpoint B 
SCTP-INIT-------------------> 
        <----------------------INIT_ACK 
COOKIE-ECHO-----------> 
        <---------------------COOKIE-ACK
M3UA msg------------->
	<--------------ABORT
	<--------------HEARTBEAT

In the Abort Chunk I observe that the T bit is set to 1 indicating that Endpoint B does not have a TCB. What could be the problem here. Is this an OOTB case? Shouldnt TCB be present on Endpoint B as the 4-way handshake has been successfully been completed. If Endpoint B does not have a TCB ? How can it send HEARTBEAT to Endpoint A?
Thanks in advance.

 <<capture.txt>> 
Regards,
Vivek Kumar

_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 12 Jan 2009 14:14:00 -0700

Vivek,

Looks to me like a bug in Endpoint B.

--brian

Kumar, Vivek (NSN - IN/Bangalore) wrote:     (Mon, 12 Jan 2009 15:08:34)
>    In the Abort Chunk I observe that the T bit is set to 1 indicating
>    that Endpoint B does not have a TCB. What could be the problem here.
>    Is this an OOTB case? Shouldnt TCB be present on Endpoint B as the
>    4-way handshake has been successfully been completed. If Endpoint B
>    does not have a TCB ? How can it send HEARTBEAT to Endpoint A?
> 
>    Thanks in advance.
> 
>    <<capture.txt>>
>    Regards,
>    Vivek Kumar

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Kumar, Vivek (NSN - IN/Bangalore)" <[email-masked]>
Date: Fri, 16 Jan 2009 12:31:54 +0530

Hello Brian,

Thanks for the response. It would be really helpful if you could point
what the potential bug could be. 

Regards,
Vivek Kumar
Ph: +918040553823

-----Original Message-----
From: ext Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Tuesday, January 13, 2009 2:44 AM
To: Kumar, Vivek (NSN - IN/Bangalore)
Cc: [email-masked]
Subject: Re: [Sigtran] SCTP ABORT Issue

Vivek,

--brian

---

From: Ankit Kumar Sharma <[email-masked]>
Date: Sat, 17 Jan 2009 19:43:52 +0530

Vivek,
  Have you checked whether a single instance(implementation) of SCTP is
running on the endpoint B?

I have seen a similar issue when, unknowingly,  some vendor's SCTP and
kernel SCTP were running on the same machine, simultaneously.

Cheers
Ankit