Subject: [Sigtran] SCTP INITs failing :Incorrect CRC32C,should be

From: "Kumar, Vivek (NSN - IN/Bangalore)" <[email-masked]>
Date: Fri, 24 Apr 2009 22:26:10 +0800

Hello,

We have a scenario in which we have a server running linux kernel
2.6.28-7 on a MIPS64 architecture machine.
The client on the other hand is an X86 machine.

The issue being observed here now is that the When the client sends and
INIT message the server discards the packet as the packet shows
"Incorrect CRC32C,should be 0x98bfedc6".
If we disable the CRC checking at the server side though it proceeds one
step further,i.e.,the server now responds back with an INIT ACK
(ignoring the checksum) but the client now discards the packet giving
the same reason,i.e.,"Incorrect CRC32C,should be "

I have attached a capture file illustrating the same.

Any comments/suggestions would be really helpful.

 <<capture.txt>> 

Thanks in advance.
Regards,
Vivek Kumar
Ph: +918043633849

---

From: Adnan Hasnain Alam <[email-masked]>
Date: Sat, 25 Apr 2009 09:37:11 +0530

Vivek,

Have you checked if both sides are using CRC32 and not Adler-32. (RFC 3309).
Change the settings in Wireshark to determine if the checksum is correct if
it were Adler-32.

Best regards,

Adnan

On Fri, Apr 24, 2009 at 7:56 PM, Kumar, Vivek (NSN - IN/Bangalore) <
[email-masked]> wrote:

>  Hello,
>
> We have a scenario in which we have a server running linux kernel 2.6.28-7
> on a MIPS64 architecture machine.
> INIT message the server discards the packet as the packet shows "Incorrect
> CRC32C,should be 0x98bfedc6".
>
> step further,i.e.,the server now responds back with an INIT ACK (ignoring
> the checksum) but the client now discards the packet giving the same
> reason,i.e.,"Incorrect CRC32C,should be "
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran
>
>

-- 
Adnan Hasnain Alam
Sent from Delhi, DL, India

---

From: Michael Tüxen <[email-masked]>
Date: Sat, 25 Apr 2009 07:58:23 +0200

Dear all,

you can choose in Wireshark Edit/Preferences/Protocols/SCTP and
select Checksum type 'Automatic'.

Please note that Adler32 has been replaced by CRC32 years ago!

Best regards
Michael

On Apr 25, 2009, at 6:07 AM, Adnan Hasnain Alam wrote:

> Vivek,
>
> Have you checked if both sides are using CRC32 and not Adler-32.  
> (RFC 3309). Change the settings in Wireshark to determine if the  
> checksum is correct if it were Adler-32.
>
>
> Best regards,
>
> Adnan
>
> On Fri, Apr 24, 2009 at 7:56 PM, Kumar, Vivek (NSN - IN/Bangalore) <[email-masked] 
> > wrote:
> Hello,
>
> The issue being observed here now is that the When the client sends  
> and INIT message the server discards the packet as the packet shows  
> If we disable the CRC checking at the server side though it proceeds  
> one step further,i.e.,the server now responds back with an INIT ACK  
> (ignoring the checksum) but the client now discards the packet  
> giving the same reason,i.e.,"Incorrect CRC32C,should be "
>