Subject: [Sigtran] [M3UA] Routing-Key Values

From: Kuldeep Janjua <[email-masked]>
Date: Fri, 26 Jun 2009 15:34:48 +0530

Hi Brian,

According to the specifications of M3UA possible routing keys are :

1. DPC only
2. DPC,OPC
3. DPC,OPC,CIC
4. DPC,SSN

My queries are:

1. Can you suggest me the difference between routing keys, DPC only
and DPC+OPC.
2. What could be the possible network scenario when these will be used ?
3. What is the exact purpose of using DPC+OPC as routing key ?

Please provide the insight.

Regards,
Kuldeep

---

From: "David Laight" <[email-masked]>
Date: Fri, 26 Jun 2009 11:13:02 +0100

> According to the specifications of M3UA possible routing keys are :

CIC shouldn't be there, since that requires inappropriate knowledege
of other protocol layers. It is also impossible to implement ISUP
group messages with such a naive routing rule.

> 4. DPC,SSN

You should also have DPC,SSN,OPC

> 1. Can you suggest me the difference between routing keys, DPC only

One includes the source address!

> 3. What is the exact purpose of using DPC+OPC as routing key ?

To route traffic from different systems to different applications!

For ISUP traffic this might let you split the load between different
systems - since the traffic for each relation (pointcode pair) is
completely separate.

	David

Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)  
P Please consider the environment and don't print this e-mail unless you really need to

---

From: Kuldeep Janjua <[email-masked]>
Date: Fri, 26 Jun 2009 17:17:01 +0530

Thanks David.

But can you give me one example, when do you require DPC+OPC as routing key ?

Regards,
Kuldeep

On 6/26/09, David Laight <[email-masked]> wrote:
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran
>