Subject: [Sigtran] [M3UA] Double Exchange procedures

From: Santhana <[email-masked]>
Date: Fri, 05 Jun 2009 16:26:38 +0530

Hi Brian

            In M3UA what is the main purpose of Double Exchange in the ASP
procedures. Is it to do something with the directional control(controlling
traffic in both directions independently) of AS/ASP traffic ?

            How to know whether the peer IPSP/ASP is working as per Single
Exchange or Double exchange ? Is it purely based on config only.

            I am not sure whether these questions are already answered in
the working group. But I searched enough.

Regards

Santhanakrishnan

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 5 Jun 2009 09:07:26 -0600

Santhana,

Santhana wrote:                            (Fri, 05 Jun 2009 16:26:38)
> 
>    Hi Brian
> 
>                In M3UA what is the main purpose of Double Exchange in the
>    ASP procedures. Is it to do something with the directional
>    control(controlling traffic in both directions independently) of
>    AS/ASP traffic ?

I'm sorry, but I never liked DE mode and advocated against it.
I don't see that it has any practical purpose better handled
by SE mode.  SE mode is recommended over DE mode in the RFC.

>                How to know whether the peer IPSP/ASP is working as per
>    Single Exchange or Double exchange ? Is it purely based on config
>    only.

Configuration only.  A useful policy might be to assume SE mode
(as recommended in the RFC) with an option to configure DE mode
if you really see a need to support DE mode at all.

>                I am not sure whether these questions are already answered
>    in the working group. But I searched enough.

There is substation discussion of the modes, but a ways back in
the mail archive (about 2003? 2004?).  The working group is now
shut down so we a stuck with a bunch of half-baked "Proposed
Standard" RFCs with no MIBs.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "David Laight" <[email-masked]>
Date: Fri, 5 Jun 2009 16:23:19 +0100

> > Single Exchange or Double exchange ?
> > Is it purely based on config only ?
> 

I guess the only reason for DE is that it is symmetric.
With SE one end has to do the client M3UA procedures and the
other the server ones.

I couldn't decide when a DE system would be able to send data,
nor things like which routing context be included,
so only implemented SE.

	David

Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)  
P Please consider the environment and don't print this e-mail unless you really need to

---

From: Adnan Hasnain Alam <[email-masked]>
Date: Sun, 7 Jun 2009 10:35:58 +0530

Hi Brian, David,
IPSP SE mode confuses me. What is the RC value that should be sent in the
ASP Active message? And what should be the routing key that would be
associated with this RC value? Would routing key define traffic in both
directions (how do you do that!) or only in one direction.

In IPSP DE mode, I am clear that each node would send its local RC value in
the ASP Active. And the routing key associated with this local RC value
would only define the nature of incoming traffic at this node.

Therefore I prefer IPSP DE mode. IPSP SE mode cause a lot of problems in
networks where there are many M3UA nodes interconnected in RC value
provisioning.

All the best,

Adnan

On Fri, Jun 5, 2009 at 8:53 PM, David Laight <[email-masked]>wrote:

> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 7 Jun 2009 01:39:47 -0600

Adnan,

If one doesn't understand something, it is better to form
questions rather than sweeping assertions.

You seem to prefer DE for most of the reasons that it was
technically counter-recommended in favor of SE.

Provisioning multiple RC values, one at each end per IPSP and
synchronizing them (which RC value corresponds to which) is
wasetful, prone to error, race conditions, and can yield
half-flows where two endpoints cannot communication (unbeknownst
to either of them when RC values lose synchronization).  Unless
grossly misconfigured, this can never happen in the real SS7
network and all communications between SS7 provider and SS7 user
are inherently full-duplex.

SE has half the RC values for the same system as DE, and cannot
result in broken half-traffic flows.  Contrary to your
statements, SE eases RC provisioning in comparison to DE.

--brian

Adnan Hasnain Alam wrote:                     (Sun, 07 Jun 2009 10:35:58)
> 
>    Hi Brian, David,
> 
>    IPSP SE mode confuses me. What is the RC value that should be sent in
>    the ASP Active message? And what should be the routing key that would
>    be associated with this RC value? Would routing key define traffic in
>    both directions (how do you do that!) or only in one direction.
> 
>    In IPSP DE mode, I am clear that each node would send its local RC
>    value in the ASP Active. And the routing key associated with this
>    local RC value would only define the nature of incoming traffic at
>    this node.
> 
>    Therefore I prefer IPSP DE mode. IPSP SE mode cause a lot of problems
>    in networks where there are many M3UA nodes interconnected in RC value
>    provisioning.
> 
>    All the best,
> 
>    Adnan
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/