Subject: [Sigtran] [M3UA] SE Override

From: Евгений Фокин <[email-masked]>
Date: Mon, 2 Nov 2009 14:01:07 +0300

Hi

  Could you tell me this sequence is right?

There are three IPSPes in Single Exchange model. All IPSPes are in state
Inactive.
Please look at the sequence.

IPSP1------------------------IPSP2------------------------IPSP3

    1 -> Asp Activate
    2 <- Asp Activate Ack
    3 <- Notify As Active
                                  4 -> Notify As Active

                   Some time later

                                  5 -> Asp Activate
                                  6 <- Asp Activate Ack

    7 -> Notify AltAspActive

---

Regards

    Evgenij

---

From: "David Laight" <[email-masked]>
Date: Mon, 2 Nov 2009 11:11:21 -0000

> There are three IPSPes in Single Exchange model.
> All IPSPes are in state Inactive.

I'm not even sure it makes any sense.
IPSP is an application <-> application mode.
Only the SG end sends 'alternate ASP active',
not the ASP.

	David

Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)  
P Please consider the environment and don't print this e-mail unless you really need to

---

From: Evgenij <[email-masked]>
Date: Mon, 2 Nov 2009 15:19:41 +0300

I don't anderstand what it means "IPSP is an application <-> application
mode."
Does it mean than one IPSP can't process instance of an Application Server
in overraide mode and IPSP must work with only one IPSP?

Can be configuration like this

ASP----------SGP----------ASP

but with IPSP?

2009/11/2 David

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 2 Nov 2009 05:36:52 -0700

Which IPSPs belong to which nodes?

--brian

??????? ????? wrote:                        (Mon, 02 Nov 2009 14:01:07)
>    There are three IPSPes in Single Exchange model. All IPSPes are in
>    state Inactive.

> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Evgenij <[email-masked]>
Date: Mon, 2 Nov 2009 15:52:19 +0300

IPSP2 belongs node2. IPSP1 and IPSP3 belong node13.

Example of configuration

                                     IPSP1
                                    /          \
User----Node2------IPSP2              ----Node13----User
                                    \          /
                                     IPSP3

2009/11/2 Brian F. G. Bidulock <[email-masked]>

---

From: Evgenij <[email-masked]>
Date: Tue, 3 Nov 2009 11:54:25 +0300

Sorry in previous sequense was mistake. Notify AltAspActive had wrong direction.

Configuration:

                     IPSP1
                    /     \
User---Node2---IPSP2       Node13---User
                    \     /
                     IPSP3

IPSP1------------------------IPSP2------------------------IPSP3
  |                           |                             |
1 |  -> Asp Activate       -> |                             |
2 |  <- Asp Activate Ack   -> |                             |
3 |  <- Notify As Active   -> |                             |
4 |                           |    -> Notify As Active      |

                   Some time later

5 |                           |      -> Asp Activate        |
6 |                           |      <- Asp Activate Ack    |
7 |  <- Notify AltAspActive<- |                             |

---

Regards

    Evgenij

---

From: Chris Benson <[email-masked]>
Date: Tue, 3 Nov 2009 15:36:15 -0800 (PST)

Evgenij,

Yes the sequence you portray is correct, assuming that
Node13 operation is intended to be in M3UA traffic 
Override mode, either by external shared "knowledge", 
or by specification of the traffic mode in the ASP-Active 
and ASP-Active-Ack messages.

As a result of the first exchange, IPSP2 is instructed 
to transmit data to Node13 by way of IPSP1 only.

Some time later, IPSP3 took action to activate itself.
As this is in override mode, IPSP3's activation overrides
IPSP1's previous activation. IPSP1 becomes INACTIVE on
receipt of the Notify Alt ASP Active.

As a result of the later exchange, IPSP2 is instructed
to transmit data to Node13 by way of IPSP3 only.

I have assumed that the first exchange ASP-Active-Ack
(and first Notify AS Active) travelled from IPSP2 to 
IPSP1, and were not somehow bidirectional.

With thanks, from Chris Benson.

On Tue, 3 Nov 2009, Evgenij wrote:

>>  Date: Tue, 3 Nov 2009 11:54:25 +0300
>>  From: Evgenij <[email-masked]>
>>  To:  <[email-masked]>,  <[email-masked]>,  <[email-masked]>
>>  Subject: Re: [Sigtran] [M3UA] SE Override
>>