Subject: [Sigtran] [M3UA] IPSP DE ASP Up Procedures

From: Evgenij <[email-masked]>
Date: Wed, 16 Dec 2009 18:35:12 +0300

Hi All,

    How many interchange ASP Up messages are needed for ASP Up procedure?
In section 4.3.4.1.2 saying that four messages are needed but in section 5.6.2
saying that one single exchange of ASP UP message is enough. It is
contradiction or not?

4.3.4.1.2.  IPSP Considerations (ASP Up)

  Alternatively, when using the IPSP DE model, an interchange of ASP Up
  messages from each end *MUST* be performed.  Four messages are needed
   for completion.

5.6.2.  Double Exchange

              IPSP-A                           IPSP-B
                |                                |
                |<-------------ASP Up------------|
                |-----------ASP Up Ack---------->|
                |                                |
                |-------------ASP Up------------>|  (optional)
                |<----------ASP Up Ack-----------|  (optional)
                |                                |
                |<------- ASP Active(RCb)--------|  RC: Routing Context
                |-----ASP Active Ack (RCb)------>|      (optional)
                |                                |
                |------- ASP Active(RCa)-------->|  RC: Routing Context
                |<-----ASP Active Ack (RCa)------|      (optional)
                |                                |
                |<=========  DATA (RCa) =========|
                |==========  DATA (RCb) ========>|
                |                                |
                |<-----ASP Inactive (RCb)--------|  RC: Routing Context
                |----ASP Inactive Ack (RCb)----->|
                |                                |
                |------ASP Inactive (RCa)------->|  RC: Routing Context
                |<----ASP Inactive Ack (RCa)-----|
                |                                |
                |<-----------ASP Down------------|
                |---------ASP Down Ack---------->|
                |                                |
                |------------ASP Down----------->|  (optional)
                |<--------ASP Down Ack-----------|  (optional)
                |                                |

  In this approach, *only one single exchange of ASP Up message* can be
   considered sufficient since the response by the other peer can be
  considered a notice that it is in ASP_UP state.

---

Regards

    Evgenij

---

From: Igor Fedotov <[email-masked]>
Date: Wed, 16 Dec 2009 19:19:59 +0300

Hi, Evgenij

IMHO M3UA spec isn't clear in the issue. This was mentioned for example 
at SIGTRAN PLUGTESTS in Moscow in 2007 
( http://www.etsi.eu/WebSite/document/PlugtestsHistory/2007SIGTRAN/SIGTRAN_2007_REPORT.pdf, 
day 5 report, issue 1).

I'd say, the most preferable approach would be to use four messages in 
Double Exchange, as described here:
http://www.archivum.info/[email-masked]/2005-07/00030/RE:_%5BSigtran%5D_M3UA_:_2_or_4_messages_for_ASP-UP_in_IPSP_DE

> *From: *Evgenij <[email-masked] <mailto:[email-masked]>>
> *Date: *December 16, 2009 7:35:12 AM PST
> *To: [email-masked] <mailto:[email-masked]>
> *Subject: **[Sigtran] [M3UA] IPSP DE ASP Up Procedures*
>
> Hi All,
>
> In section 4.3.4.1.2 saying that four messages are needed but in 
> section 5.6.2 saying that one single exchange of ASP UP message is 
> enough. It is contradiction or not?
>
> _______________________________________________
> Sigtran mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sigtran

---

From: Evgenij <[email-masked]>
Date: Thu, 17 Dec 2009 12:03:46 +0300

Thanks Igor!

The links is very useful for me.

2009/12/16 Igor Fedotov

>  Hi, Evgenij
>
> IMHO M3UA spec isn't clear in the issue. This was mentioned for example at
> SIGTRAN PLUGTESTS in Moscow in 2007 (
> http://www.etsi.eu/WebSite/document/PlugtestsHistory/2007SIGTRAN/SIGTRAN_2007_REPORT.pdf,
> day 5 report, issue 1).
>
> [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 17 Dec 2009 07:45:00 -0700

Evgenij,

It was agreed to make all four ASP UP/Ack message mandatory for
both SUA and M3UA in the thread
"RE: M3UA also affected : [SUA issue 17] IPSP cases."
from August 28, 2001.

It is the passages mentioning two as optional that are incorrect
(a holdover from drafts previous to August 2001).

--brian

Evgenij wrote:                              (Thu, 17 Dec 2009 12:03:46)
>    IMHO M3UA spec isn't clear in the issue. This was mentioned for
>    example at SIGTRAN PLUGTESTS in Moscow in 2007
>    ( [1]http://www.etsi.eu/WebSite/document/PlugtestsHistory/2007SIGTRAN/
>    SIGTRAN_2007_REPORT.pdf, day 5 report, issue 1).
>    [2]http://www.archivum.info/[email-masked]/2005-07/00030/RE:_%5BSigt
>    ran%5D_M3UA_:_2_or_4_messages_for_ASP-UP_in_IPSP_DE
> 
>      [3][email-masked]
>      [4]https://www.ietf.org/mailman/listinfo/sigtran
> 
> References
> 
>    1. http://www.etsi.eu/WebSite/document/PlugtestsHistory/2007SIGTRAN/SIGTRAN_2007_REPORT.pdf
>    2. http://www.archivum.info/[email-masked]/2005-07/00030/RE:_%5BSigtran%5D_M3UA_:_2_or_4_messages_for_ASP-UP_in_IPSP_DE
>    3. mailto:[email-masked]
>    4. https://www.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/