Subject: [Sigtran] Should ASP send a DUPU?

From: Sandy <[email-masked]>
Date: Thu, 3 Dec 2009 14:57:31 +0530

Hi All,

We generally know that DUPU message is sent from SGP to ASP to indicate that
the remote peer MTP3-user part is unavailable at SS7 node.

What if ASP receives message with invalid SIO or if the message destined to
the particular user is not available.In this case should ASP send a DUPU
message to remote? If not what action should ASP take? Please explain.
Thanks in advance.

Regards,
Sandeep B S.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 3 Dec 2009 06:30:21 -0700

Sandy,

Invalid SIO should be screened by the SG.  When an AS becomes
unavailable at an ASP it should deactivate for the AS.  DUPU
is not permitted in the direction from ASP to SG.

--brian

Sandy wrote:                                  (Thu, 03 Dec 2009 14:57:31)
> 
>    Hi All,
>    We generally know that DUPU message is sent from SGP to ASP to
>    indicate that the remote peer MTP3-user part is unavailable at SS7
>    node.
>    What if ASP receives message with invalid SIO or if the message
>    destined to the particular user is not available.In this case should
>    ASP send a DUPU message to remote? If not what action should ASP take?
>    Please explain.  Thanks in advance.
>    Regards,
>    Sandeep B S.

> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Deepak Gunjal <[email-masked]>
Date: Thu, 3 Dec 2009 19:57:53 +0530

Hi,

In case if my local SCCP user at ASP become unavailable, how does my local ASP will notify to SG without DUPU?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian F. G. Bidulock
Sent: Thursday, December 03, 2009 7:00 PM
To: Sandy
Cc: [email-masked]
Subject: Re: [Sigtran] Should ASP send a DUPU?

Sandy,

--brian

"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 3 Dec 2009 12:55:04 -0700

Deepak,

ASP Inactive.

-- brian

Deepak Gunjal wrote:                                                                     (Thu, 03 Dec 2009 19:57:53)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Sandy <[email-masked]>
Date: Fri, 4 Dec 2009 19:14:57 +0530

Hi Brain,

 When the user part of ASP becomes unavailable then corresponding INACTIVE
message for that AS is sent by ASP to SGP. At SGP side on receiving INACTIVE
message from ASP, it searches for the corresponding routing key of the AS
and sends DUNA/DUPU to SS7 point code based on the following conditions.

DUNA is sent if the route is based on DPC only.

DAVA is sent if the route is based on DPC and SIO

Please confirm whether my understanding is on a right path.

Regards,
Sandeep B S

On Fri, Dec 4, 2009 at 1:25 AM, Brian F. G. Bidulock
<[email-masked]>wrote:

> > In case if my local SCCP user at ASP become unavailable, how does my
> local ASP will notify to SG without DUPU?
> >
> >
> > "DISCLAIMER: This message is proprietary to Aricent and is intended
> solely for the use of the individual to whom it is addressed. It may contain
> privileged or confidential information and should not be circulated or used
> for any purpose other than for what it is intended. If you have received
> this message in error, please notify the originator immediately. If you are
> not the intended recipient, you are notified that you are strictly
> prohibited from using, copying, altering, or disclosing the contents of this
> message. Aricent accepts no responsibility for loss or damage arising from
> the use of the information transmitted by this email including damage from
> virus."

---

From: Sandy <[email-masked]>
Date: Fri, 4 Dec 2009 19:22:23 +0530

Sorry, the second condition as to be :

*DUPU* is sent if the route is based on DPC and SIO.

Regards,
Sandeep B S

On Fri, Dec 4, 2009 at 7:14 PM, Sandy <[email-masked]> wrote:

> On Fri, Dec 4, 2009 at 1:25 AM, Brian F. G. Bidulock <[email-masked]
> > wrote:
>
>> Deepak,
>>
>> ASP Inactive.
>>
>> -- brian
>>
>> Deepak Gunjal wrote:

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 4 Dec 2009 17:07:51 -0700

Sandy,

The SG does not send M3UA messages to SS7 Signalling Points.

--brian

Sandy wrote:                                  (Fri, 04 Dec 2009 19:22:23)
>    DUPU is sent if the route is based on DPC and SIO.
>    Regards,
>    Sandeep B S
> 
>    On Fri, Dec 4, 2009 at 7:14 PM, Sandy <[1][email-masked]> wrote:
> 
>      Hi Brain,
> 
>      When the user part of ASP becomes unavailable then corresponding
>      INACTIVE message for that AS is sent by ASP to SGP. At SGP side on
>      receiving INACTIVE message from ASP, it searches for the
>      corresponding routing key of the AS and sends DUNA/DUPU to SS7
>      point code based on the following conditions.
> 
>    <[2][email-masked]> wrote:
> 
>      Deepak,
>      ASP Inactive.
>      -- brian
>      Deepak Gunjal wrote:
>    > From: [3][email-masked]
>    [mailto:[4][email-masked]] On Behalf Of Brian F. G. Bidulock
>    > Cc: [5][email-masked]
>    > > [6][email-masked]
>    > > [7]https://www.ietf.org/mailman/listinfo/sigtran
>    >
>    >
>    > --
>    > Brian F. G. Bidulock
>    > [8][email-masked]
>    > [9]http://www.openss7.org/
>    > [10][email-masked]
>    > [11]https://www.ietf.org/mailman/listinfo/sigtran
>    >
>    solely for the use of the individual to whom it is addressed. It may
>    contain privileged or confidential information and should not be
>    circulated or used for any purpose other than for what it is intended.
>    If you have received this message in error, please notify the
>    originator immediately. If you are not the intended recipient, you are
>    notified that you are strictly prohibited from using, copying,
>    altering, or disclosing the contents of this message. Aricent accepts
>    no responsibility for loss or damage arising from the use of the
>    information transmitted by this email including damage from virus."
>    > [12][email-masked]
>    > [13]https://www.ietf.org/mailman/listinfo/sigtran
>    --
>    Brian F. G. Bidulock
>    [14][email-masked]
>    [15]http://www.openss7.org/
> 
> References
> 
>    1. mailto:[email-masked]
>    2. mailto:[email-masked]
>    3. mailto:[email-masked]
>    4. mailto:[email-masked]
>    5. mailto:[email-masked]
>    6. mailto:[email-masked]
>    7. https://www.ietf.org/mailman/listinfo/sigtran
>    8. mailto:[email-masked]
>    9. http://www.openss7.org/
>   10. mailto:[email-masked]
>   11. https://www.ietf.org/mailman/listinfo/sigtran
>   12. mailto:[email-masked]
>   13. https://www.ietf.org/mailman/listinfo/sigtran
>   14. mailto:[email-masked]
>   15. http://www.openss7.org/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Sandy <[email-masked]>
Date: Mon, 7 Dec 2009 11:19:47 +0530

Hi,

Thanks for your response.

Does the corresponding SS7 primitives holds good for the scenario explained
in previous mail.

So on receiving INACTIVE from ASP, the SGP sends

 MTP- PAUSE primitive is sent if the route is based on dpc.
 MTP- UPU primitive is sent if the route is based on dpc and SIO.

Regards,
Sandeep B S

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 7 Dec 2009 00:12:08 -0700

Sandy,

The SG does not send MTP primitives to SS7 signalling points either.

(Also, there is no such MTP primitive as MTP-UPU.)

--brian

Sandy wrote:                                  (Mon, 07 Dec 2009 11:19:47)
>    Does the corresponding SS7 primitives holds good for the scenario
>    explained in previous mail.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Deepak Gunjal <[email-masked]>
Date: Mon, 7 Dec 2009 12:47:13 +0530

Hi Brian,

If it is not the SG then who converts the various state management messages from ASP to corresponding MTP3 management messages?

As per my understanding NIF at SG should map the State management messages from ASP to MTP3 traffic management messages and finally the MTP3 layer at SEP would convert to MTP3 upper layer service primitives like pause/resume indications.

-Deepak

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, December 07, 2009 12:42 PM
To: Sandy
Cc: Deepak Gunjal; [email-masked]
Subject: Re: [Sigtran] Should ASP send a DUPU?

Sandy,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 7 Dec 2009 00:43:51 -0700

Deepak,

Yes, and the SG would have to send SS7 MESSAGES to the remote SEP to
accomplish this.  The messages sent, and under what circumstances
they are sent, are dictated by the SS7 protocol and variant: not by
M3UA.

So, why is DUPU only sent from SG to ASP?--because, the MTP-STATUS
primitive to which it corresponds is only available as an indication
primitive.

How does an ASP (instance of an MTP-User) indicate to the SG (MTP)
that it has gone away?--by loss of communication or explicit
deactivation (ASP Inactive).

What does the SG (MTP) do with that information?--what MTP always
does when a user goes away.  It matters not what registration key is
used within the domain of M3UA.  What the SG does is within the
scope of the SS7 standards and is outside the scope of M3UA.

See sections 1.6, 4.5 and 5.5.2.3 of the RFC.

--brian

Deepak Gunjal wrote:                         (Mon, 07 Dec 2009 12:47:13)
> Hi Brian,
> 
> If it is not the SG then who converts the various state management
> messages from ASP to corresponding MTP3 management messages?
> 
> As per my understanding NIF at SG should map the State management
> messages from ASP to MTP3 traffic management messages and finally
> the MTP3 layer at SEP would convert to MTP3 upper layer service
> primitives like pause/resume indications.
> 
> -Deepak
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Deepak Gunjal <[email-masked]>
Date: Mon, 7 Dec 2009 13:26:55 +0530

Thanks Brian. It explains the SG functions.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, December 07, 2009 1:14 PM
To: Deepak Gunjal
Cc: Sandy; [email-masked]
Subject: Re: [Sigtran] Should ASP send a DUPU?

Deepak,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/