Subject: [Sigtran] [IUA] SCTP RI missing in IUA FSM

From: Santhana <[email-masked]>
Date: Thu, 04 Feb 2010 10:59:07 +0530

Hi Brian

            In IUA RFC 3057, it does not describe about processing of
SCTP-RI in the IUA FSM. I could see SCTP-RI mentioned in other UAs. Is it
some miss in the IUA RFC, or it has some special insight ?

Regards

Santhanakrishnan

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 4 Feb 2010 02:20:18 -0700

Santhana,

RFC 3057 dates back a ways, and IUA was the first SIGTRAN WG product
(other than SCTP and the framework docs) to go to RFC.  I don't think
that SCTP RI missing has any real significance.  It is always at the
SCTP receiver's discretion to treat SCTP RI as SCTP CI.

--brian

Santhana wrote:                            (Thu, 04 Feb 2010 10:59:07)
>    SCTP-RI in the IUA FSM. I could see SCTP-RI mentioned in other UAs. Is
>    it some miss in the IUA RFC, or it has some special insight ?
> 
> 
>    Regards
> 
>    Santhanakrishnan

> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Santhana <[email-masked]>
Date: Thu, 04 Feb 2010 18:59:43 +0530

Hi Brian
	Thanks for ur clarification. In IUA ASP FSM, it is mentioned like
this for SCTP-CDI.

"SCTP CDI: The local SCTP layer's Communication Down Indication to the Upper
Layer Protocol (IUA) on an SG. The local SCTP will send this indication when
it detects the loss of connectivity to the ASP's peer SCTP layer. SCTP CDI
is understood as either a SHUTDOWN COMPLETE notification and COMMUNICATION
LOST notification from the SCTP."

I guess the same applies even for SCTP-RI. 

Suppose in an IUA SGP-ASP relation, where SGP is working as SCTP Server and
ASP as SCTP Client. By the above RFC statements, it implies that the restart
can be initiated only by the ASP side by sending INIT(and hence the RI to
the Upper Layer Protocol (IUA) on an SG). 

As per my SCTP understanding, once an association is established, any
EndPoint can send INIT to restart the association. Does the above RFC
statement prohibit a restart initiation from SGP side by sending INIT in the
already establilshed SCTP association.

In simple words can an SCTP restart triggered from the SGP side of IUA ?

Regards
Santhanakrishnan 

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Thursday, February 04, 2010 2:50 PM
To: Santhana
Cc: [email-masked]
Subject: Re: [Sigtran] [IUA] SCTP RI missing in IUA FSM

Santhana,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/