Subject: [Sigtran] Query regarding reachability STATUS of Signaling Point Code

From: Rajesh Makhija <[email-masked]>
Date: Fri, 19 Mar 2010 16:29:08 +0530

Hello,

We would like to understand how the STATUS of Signaling Point Code (that uniquely identifies an SS7 node) shall be interpreted by M3UA at ASP/AS side.

Entities Configured:

Let us consider an ASP is serving two Application servers, say AS-1 and AS-2.  This ASP is connected (through SCTP association) to an SGP. This SGP is serving an SG.

The routing context of AS1 is X and routing context of AS2 is Y.

A route is configured for an SS7 destination (say with point code 101) through this SG.

This SS7 node with point code 101 is initially unavailable.

Now, a DAVA message (for SS7 point code 101) is sent by SGP to ASP with routing context X (which is the routing context corresponding to AS1)

There seem to be two possible interpretations:

1.       SS7 node with point code (101) is marked as reachable for both the Application servers, AS1 and AS2.
2.       SS7 point code (101) is marked as reachable for AS-1 only (as determined by the RC in the DUNA message) and remains unreachable for AS-2.

Which one of the above-mentioned interpretations is correct?

Regards

Rajesh

________________________________
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

---

From: Xiangsong Cui <[email-masked]>
Date: Fri, 19 Mar 2010 22:02:25 +0800

> Now, a DAVA message (for SS7 point code 101) is sent by SGP to ASP 
> with routing context X (which is the routing context corresponding 
> to AS1)

But why does the SGW send NAVA only for routing context X?

Xiangsong

----- 原邮件 -----
发件人: Rajesh Makhija <[email-masked]>
日期: 星期五, 三月 19日, 2010 下午6:59
主题: [Sigtran] Query regarding reachability STATUS of Signaling Point	Code
收件人: "[email-masked]" <[email-masked]>
抄送: Rajat2 Gupta <[email-masked]>, Amit Jain <[email-masked]>

> Hello,
> 
> 
> 
> We would like to understand how the STATUS of Signaling Point Code 
> (that uniquely identifies an SS7 node) shall be interpreted by 
> M3UA at ASP/AS side.
> 
> Entities Configured:
> 
> Let us consider an ASP is serving two Application servers, say AS-
> 1 and AS-2.  This ASP is connected (through SCTP association) to 
> an SGP. This SGP is serving an SG.
> 
> Now, a DAVA message (for SS7 point code 101) is sent by SGP to ASP 
> with routing context X (which is the routing context corresponding 
> to AS1)
> 
> 1.       SS7 node with point code (101) is marked as reachable for 
> both the Application servers, AS1 and AS2.
> 2.       SS7 point code (101) is marked as reachable for AS-1 only 
> (as determined by the RC in the DUNA message) and remains 
> unreachable for AS-2.
> 
> "DISCLAIMER: This message is proprietary to Aricent and is 
> intended solely for the use of the individual to whom it is 
> addressed. It may contain privileged or confidential information 
> and should not be circulated or used for any purpose other than 
> for what it is intended. If you have received this message in 
> error, please notify the originator immediately. If you are not 
> the intended recipient, you are notified that you are strictly 
> prohibited from using, copying, altering, or disclosing the 
> contents of this message. Aricent accepts no responsibility for 
> loss or damage arising from the use of the information transmitted 
> by this email including damage from virus."
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 19 Mar 2010 08:15:33 -0600

Rajesh,

Please see comments below:

Rajesh Makhija wrote:                        (Fri, 19 Mar 2010 16:29:08)
> 
> Hello,
>  
> We would like to understand how the STATUS of Signaling Point
> Code (that unique ly identifies an SS7 node) shall be
> interpreted by M3UA at ASP/AS side.
> 
> 
>    Entities Configured:
> 
> 
>    Let us consider an ASP is serving two Application servers,
>    say AS-1 and AS-2.  This ASP is connected (through SCTP
>    association) to an SGP.  This SGP is serving an SG.
> 
> 
>    Now, a DAVA message (for SS7 point code 101) is sent by SGP
>    to ASP with routing context X (which is the routing context
>    corresponding to AS1)
> 
> 
>    1.       SS7 node with point code (101) is marked as
>    reachable for both the Application servers, AS1 and AS2.
> 
>    2.       SS7 point code (101) is marked as reachable for
>    AS-1 only (as determined by the RC in the DUNA message) and
>    remains unreachable for AS-2.
> 
> 

Neither.  M3UA at the ASP simply identifies the MTP/MTP-User
interface (AS) associated with the RC and passes an MTP-RESUME
primitive to the MTP-User.  It is the MTP-User's responsibility
to track the state of remote signalling points.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Rajesh Makhija <[email-masked]>
Date: Sat, 20 Mar 2010 15:35:16 +0530

Xiangsong,

Thank you for pointing this out.

I was originally wondering if SGW does send DAVA for routing context X only then how should AS/ASP interpret the same.

At this moment I am not sure if this (SGW sending DAVA with routing context X only) can happen in a real life network.

And whether it is possible that a route for an SS7 destination is available for one AS and not available for second AS through the same SGW (given that both AS(s) are in Active state).

I would request others to comment on the following two points:

1. Whether it is possible that a route for an SS7 destination is available for one AS (AS-1) and not available for second AS (AS-2) through the same SGW (given that both AS(s) are in Active state),
When a "common ASP" is serving both AS-1 and AS-2 (given the common ASP is active for both AS-1 and AS-2)

2. Whether it is possible that a route for an SS7 destination is available for one AS (AS-1) and not available for second AS (AS-2) through the same SGW (given that both AS(s) are in Active state),
When "two mutually exclusive" ASP(s), say ASP-1 and ASP-2 are serving AS-1 and AS-2 respectively (given the ASP-1 is active for AS-1 and ASP-2 is active for and AS-2)

Regards

Rajesh

-----Original Message-----
From: Xiangsong Cui [mailto:[email-masked]]
Sent: Friday, March 19, 2010 7:32 PM
To: Rajesh Makhija
Cc: [email-masked]; Rajat2 Gupta; Amit Jain
Subject: Re :[Sigtran] Query regarding reachability STATUS of Signaling Point Code

Xiangsong

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 20 Mar 2010 14:57:55 -0600

Rajesh,

Rajesh Makhija wrote:                        (Sat, 20 Mar 2010 15:35:16)
> I was originally wondering if SGW does send DAVA for routing context X
> only then how should AS/ASP interpret the same.
> 
> At this moment I am not sure if this (SGW sending DAVA with routing
> context X only) can happen in a real life network.
> 
> And whether it is possible that a route for an SS7 destination is
> available for one AS and not available for second AS through the same
> SGW (given that both AS(s) are in Active state).

Yes, it is possible.

> 1. Whether it is possible that a route for an SS7 destination is
> available for one AS (AS-1) and not available for second AS (AS-2)
> through the same SGW (given that both AS(s) are in Active state), When
> a "common ASP" is serving both AS-1 and AS-2 (given the common ASP is
> active for both AS-1 and AS-2)

Yes, it is possible.

> 2. Whether it is possible that a route for an SS7 destination is
> available for one AS (AS-1) and not available for second AS (AS-2)
> through the same SGW (given that both AS(s) are in Active
> state), When "two mutually exclusive" ASP(s), say ASP-1 and ASP-2 are
> serving AS-1 and AS-2 respectively (given the ASP-1 is active for AS-1
> and ASP-2 is active for and AS-2)

Yes, it is possible.

Just because it is one SG does not mean that all AS that
it serves have the same connectivity or routing to the SS7
network.  For example, AS-1 may use one set of signalling
links, and AS-2 may use another.  Conditions in the SS7
network may cause one route set to become unavailable to
one AS, yet it is available to another.

The ASP, however, does not need to know this.  All it needs
to do is identify which AS correspond to an SNMM message
(from the RC or NA in the message) and deliver the
corresponding MTP primitive.

This is in contrast with SGP within an SG: when an SS7
destination is inaccessible to an AS via one SGP it is
inaccessilble to that AS via all SGP forming an SG.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/