Subject: Re: [Sigtran] Behaviour in DE-IPSP model when ASPAC does not haveany RC.

From: "[email-masked]" <[email-masked]>
Date: Fri, 26 Mar 2010 00:32:05 +0000

LAS1 serves traffic with RK DPC=111,similarly LAS2 serves traffic for DPC=222 and RAS1 serves RK with DPC=333.

-----Original Message-----
From: Brian F. G. Bidulock
Sent:  2010-03-26 05:54:41
To: Anand N Ilkal
Cc: Jaddu, Suresh (NSN - IN/Bangalore); [email-masked]
Subject:  Re: [Sigtran] Behaviour in DE-IPSP model when ASPAC does not haveany RC.

Anand,

And what would those DPC values be for each AS?

--brian

Anand N Ilkal wrote:                          (Fri, 26 Mar 2010 05:25:57)
> 
>    hello Brian,
>    Yes, even i doubt the scenario. In other do you see any scenario under
>    which only one ASPAC/ASPAC_ACK are enough to start traffic both ends
>    in Double Exchange mode?
>    Here RK's are made up of just DPC. And the references are from IPSP A
>    node.
>    LAS1        is Local AS1 with Routing Context 100 (values are fixed
>    from static configuration)
>    LAS2        is Local AS2 with Routing Context 200 (values are fixed
>    from static configuration)
>    RAS1        is Remote AS1 with Routing Context 300 (values are fixed
>    from static configuration)
>    LASP1      is ASP at IPSP A serving LAS1 and LAS2
>    RASP1      is ASP at IPSP B serving RAS1.
>    my question is regarding the following statement in RFC.
>    Does it says, one ASPAC (without RC) from Peer. and ASPAC_ACK from
>    local is enough to start traffic from both ends?
>    Or
>    It says sender of ASPTM message to activate/deactivate all traffic,
>    can send one ASPAC without any RC, And it expecte peer end to send its
>    own ASPAC.
>    - ASPTM messages. When sending ASPTM messages to activate/deactivate
> 
>         all the traffic independently of routing keys by not specifying
>    any
> 
>         RC, a single exchange could be sufficient.
> 
>    On 26 March 2010 01:03, Brian F. G. Bidulock <[1][email-masked]>
>    wrote:
> 
>      Anand,
>      Your example does not make any sense to me: you did know that for
>      DE mode to work, each AS must be defined at either end of the
>      association and that a separate RK, RS and AS must be defined
>      for each direction of traffic?
>      Please provide the real-world RK's for the AS in your example.
>      --brian
>      Anand N Ilkal wrote:                 (Thu, 25 Mar 2010 20:23:47)
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 26 Mar 2010 00:38:00 -0600

anandnilkal,

You can't do DE this way.  RKs must be symmetric.  Also, you should not send ASPAC
without RC when multiple AS are supported over the same association according to
the RFC regardless of operating mode.

--brian

[email-masked] wrote:                                                                (Fri, 26 Mar 2010 00:32:05)
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/