Subject: [Sigtran] Query regarding routing context (RC) value in dynamic registration

From: Sandy <[email-masked]>
Date: Wed, 7 Apr 2010 14:30:04 +0530

Hi All,

Consider a scenario where 2 ASPs register at SG for same routing key
dynamically.

Let ASP-1 has received RC1 in the registration response for the routing key
dynamically registered at SG. Now if ASP2 registers for same Routing Key at
SG, Should ASP-2 restrict itself to receive same RC1 in registration
response?

Thanks in advance.

Regards,
Sandeep B S

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 7 Apr 2010 04:59:30 -0600

Sandy,

It would be better to use the RC it receives.

--brian

Sandy wrote:                                                         (Wed, 07 Apr 2010 14:30:04)
>    Let ASP-1 has received RC1 in the registration response for the
>    routing key dynamically registered at SG. Now if ASP2 registers for
>    same Routing Key at SG, Should ASP-2 restrict itself to receive same
>    RC1 in registration response?
>    Thanks in advance.
>    Regards,
>    Sandeep B S

> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Chris Benson <[email-masked]>
Date: Thu, 8 Apr 2010 11:01:12 -0700 (PDT)

Sandy,

As previously advised by Brian Bidulock, the two ASPs should not 
expect or require that they receive the same Routing Context 
value for the same Routing Key at the same SG.

I'd like to add specifically that although not very helpful,
it is possible (and mentioned in the RFCs) that different SGPs
within the same SG might use different Routing Context number 
values - one might imagine them to be indexes into some local
table maintained at each SGP instance.

With thanks, from Chris.

Chris Benson, Software Engineer,
Adax Inc., Berkeley, California, USA.
    [email-masked]
    +1 510 548-7047 ext. 189
    www.adax.com

On Wed, 7 Apr 2010, Sandy wrote:

>>  Date: Wed, 7 Apr 2010 14:30:04 +0530
>>  From: Sandy <[email-masked]>
>>  To:  <[email-masked]>
>>  Subject: [Sigtran] Query regarding routing context (RC) value in dynamic
>>      registration
>>  
>>  Hi All,
>>