Subject: [Sigtran] is it compulsary to have RC in ASP Active?

From: "SINGH VIKRAMJEET" <[email-masked]>
Date: Wed, 5 May 2010 07:28:14 +0200

Hi All,
 
 I have following configuration:
 2 nodes on IPSP-SE mode.
Node A------------------------------NodeB 
 
in NOTIFY procedures Node A has already send its RC.
When NodeB sends its RC in ASP Active,Node A throws error as invalid RC.
Is it expected by Node A ,to have RC absent in ASP active ?
 
Query :I f RC is already exchanged during Notify procedures,RC is
optional in followed ASP Active procedures?
 
-Vikramjeet Singh

---

From: "Barry Nagelberg" <[email-masked]>
Date: Wed, 5 May 2010 09:15:17 -0400

Vikramjeet,

It is recommended to have RC in ASP Active message, especially when more than one AS is using the association, but it is
not mandatory. From 4.3.4.3. "ASP Active Procedures":

<snip>
   In the case where an ASP wishes to
   process the traffic for more than one Application Server across a
   common SCTP association, the ASP Active message(s) SHOULD contain a
   list of one or more Routing Contexts to indicate for which
   Application Servers the ASP Active message applies.
<snip>

<snip>
   In the case where an ASP Active message does not contain a Routing
   Context parameter, the receiver must know, via configuration data,
   which Application Server(s) the ASP is a member.
<snip>

Barry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of SINGH VIKRAMJEET
Sent: Wednesday, May 05, 2010 1:28 AM
To: [email-masked]
Subject: [Sigtran] is it compulsary to have RC in ASP Active?

Hi All,

Query :I f RC is already exchanged during Notify procedures,RC is optional in followed ASP Active procedures?

-Vikramjeet Singh

---

From: Moloud Mousavi <[email-masked]>
Date: Thu, 13 May 2010 13:50:39 -0400

Hi all,

I was looking for the initiator of M3UA message sequencing in RFC, and couldn't find any.
Usually an association type (client or server) identifies who should starts connection establishment!

So my questions are:

1) Who sends ASP UP or ASPAC "according to RFC"?
2) Does it have anything to do with SCTP; the one who sends INIT is the one who sends the ASPUP and ASPAC?

Thanks,
Moloud

NOTICE: This e-mail contains information that may be confidential and proprietary. If you are not the intended recipient, any disclosure or other use of this e-mail or the information contained herein or attached hereto may be unlawful and is strictly prohibited. If you have received this e-mail in error, please notify the sender immediately and delete this e-mail without reading, printing, copying or forwarding it to anyone. Thank you for your kind cooperation.
AVIS : Ce courriel contient des renseignements qui peuvent etre confidentiels ou de propriete industrielle. Si vous n'etes pas le veritable destinataire, la diffusion ou l'usage de ce courriel, des renseignements qu'il contient ou des documents qui lui sont joints pourrait etre illegal. Il est donc strictement interdit de les diffuser ou de les utiliser. Si vous avez recu ce courriel par erreur, veuillez en aviser l'expediteur immediatement et veuillez le supprimer sans le lire, l'imprimer, le sauvegarder ou le diffuser. Merci de votre aimable collaboration.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 13 May 2010 17:45:51 -0600

Moloud,

See RFC 4666 section:  "1.4.8.  SCTP Client/Server Model", pp 19-20.

--brian

Moloud Mousavi wrote:                                                               (Thu, 13 May 2010 13:50:39)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Chris Benson <[email-masked]>
Date: Thu, 13 May 2010 18:11:26 -0700 (PDT)

Moloud,

I think you already received a pointer as reply to your question 2).
That is to say the direction of certain management M3UA messages 
is NOT related to client/server or sender of SCTP INIT.

For question 1), you may note the first sentence of the ASP 
Active description in RFC 4666 (page 59) ...

   "The ASP Active message is sent by an ASP ...".

The same direction is true for ASP UP.

With thanks, from Chris.

On Thu, 13 May 2010, Moloud Mousavi wrote:

>>  Date: Thu, 13 May 2010 13:50:39 -0400
>>  From: Moloud Mousavi <[email-masked]>
>>  To: "[email-masked]" <[email-masked]>
>>  Subject: [Sigtran] Message initiator
>>  
>>  Hi all,
>>  
>>  _______________________________________________
>>  Sigtran mailing list
>>  [email-masked]
>>  https://www.ietf.org/mailman/listinfo/sigtran
>>