Subject: [Sigtran] M3UA AS override mode from SGP perspective

From: Mikhail Plotkin <[email-masked]>
Date: Fri, 1 Oct 2010 01:19:32 +0400

Hi,

It is not obvious for me how the M3UA "Override mode" should be understood from the description in RFC4666 (ch. 4.3.4.3).

Consider the following configuration: Local side is SG and it has two SGPs each connected with two remote ASPs. Note that both SGPs are handled by the same SW process! The consideration is within the same AS, which is served by all 4 ASPs:

Local Side                         Remote Side
                                   +------------+
              -------assoc11-------|ASP_1       |
+----------+ /                     |            |
|     SGP_1| --------assoc12-------|ASP_2       |
|          |                       |            |
| SG       |                       |        AS  |
|          |                       |            |
|     SGP_2| --------assoc23-------|ASP_3       |
+----------+ \                     |            |
              -------assoc24-------|ASP_4       |
                                   +------------+

If the AS works in an Override mode, then how many associations (max) may be simultaneously active in this configuration? I see two options:

Option 1. There can be only one association active within the AS at the same time. So if any of the remote ASPs activates, all other ASPs will receive Notify(Alternative ASP active).

Option 2. There can be two associations active within the AS at the same time: one of {assoc11, assoc12} and one of {assoc23, assoc24}. So activation of ASP_1 or ASP_2 does not affect SGP_2.

BR/ Mikhail

---

From: Chris Benson <[email-masked]>
Date: Thu, 30 Sep 2010 14:52:48 -0700 (PDT)

Mikhail,

It is the individual ASPs (endpoints) that are active or not 
active - rather than M3UA connections (or SCTP associations)
being active or not active.  The number of current connections 
is not equivalent to whether they can be used to tranfer user 
data to the AS.

An M3UA traffic mode specifies how one side wishes to RECEIVE 
traffic.  In the example you cite, the whole AS (all four ASPs)
are in "Override mode". This means that within the AS there can
only be one currently active ASP (except for a tiny window of 
time when changing from one ASP to another).  This rule (only
one ASP in use) must be honoured by both SGP1 and SGP2.  This
means in your example, that there must be two M3UA connections 
at all [active] times: for example between SGP1 and ASP3 as 
well as between SGP2 and ASP3.  Later this may change to
these two connections:  SGP1 <==> ASP2  and  SGP2 <==> ASP2.

There may be other M3UA connections, but they cannot be used
to transfer user data (nor most other messages) from any
SGP to a non-active ASP.

This sounds a little more complicated when considering
IPSP-DE mode, where within the same connection, one side
can be ACTIVE (can receive data) and the other side
INACTIVE or DOWN (cannot receive data).

This only discussed how the AS wishes to RECEIVE traffic
(one ASP at a time), and does not consider that the SG
has an independent traffic mode for how it wishes to
share traffic coming in to SGP1 or SGP2.

With thanks, from Chris Benson.

On Fri, 1 Oct 2010, Mikhail Plotkin wrote:

>>  Date: Fri, 1 Oct 2010 01:19:32 +0400
>>  From: Mikhail Plotkin <[email-masked]>
>>  To:  <[email-masked]>
>>  Subject: [Sigtran] M3UA AS override mode from SGP perspective
>>  
>>  Hi,
>>  
>>  _______________________________________________
>>  Sigtran mailing list
>>  [email-masked]
>>  https://www.ietf.org/mailman/listinfo/sigtran
>>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 30 Sep 2010 19:28:11 -0600

Mikhail,

Please see comments below:

Mikhail Plotkin wrote:                     (Fri, 01 Oct 2010 01:19:32)
> If the AS works in an Override mode, then how many associations (max)
> may be simultaneously active in this configuration?

1. The four SCTP associations (connected or not) are independent of
   Override mode.  One would expect that in the normal case, all four
   SCTP associations are connected.

2. Equally, one would expect that in normal operation, all four ASPs are
   in the ASP-UP state.

3. In override mode only one ASP in the AS can be receiving traffic
   (usually all can send traffic).

If this arrangement is not just hypothetical, one should really run
full-mesh with regard to SCTP associations and SGP.  That is, four
associations should be added: assoc13, assoc14, assoc21 and assoc22.
Associations are cheap, but failover between ASPs usually is not.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/