Subject: [Sigtran] SCTP-Multihoming Clarification needed

From: Amar Nv <[email-masked]>
Date: Wed, 15 Sep 2010 19:31:55 +0530

Hi,

SCTP association has been established between Local and Remote machine,
between these machine's there is a switch.

Local machine is having only one NIC with two IP's , say
192.168.12.1(primary) and 192.168.12.2(secondary) configured.
Remote machine is having two NICs each having a single IP , say
192.168.13.1(primary) and 192.168.13.2(secondary) configured.

Primary of Local is exchanging HB messages with Primary of Remote
and
Secondary of Local is exchanging HB messages with Secondary of Remote.

After some time, primary IP of Local machine i.e., 192.168.12.1 has been
forbid at the switch (This testcase be considered as a Network Failure).
As a result, HB sent by Local is not reached to Remote and hence no HB_ACK
is received. Local has sent more than 100 HBs.

But, still if we check the *cat /proc/net/sctp/assocs* , it is showing a *
mark before the primary IP 192.168.12.1. Switchover didn't happen at the
Local machine.

Whereas, in the remote machine, the primary of the destination has got
switched over, where it was marking 192.168.12.2 as the primary.

My question is, why did the switchover didn't happen at the Local machine?
How does SCTP multi-homing behaves in case of Network failures?

Best Regards,
Amar N V

---

From: "David Laight" <[email-masked]>
Date: Wed, 15 Sep 2010 15:11:34 +0100

The IP address an NIC assignments below aren't a good (ie valid) choice.
 
If you have 2 IP interfaces in the same subnet you typically have no
control over which interface packets are sent out of. Usually all the
packets are transmitted from one of the interfaces (regardless as to the
local IP address).
 
The ARP responses will, however, contain the mac address of the
associated interface.
So your 'local' system is probably sending traffic to both of the remote
system's NICs, but the remote is only sending out of a single interface.
 
This may (or may not!) be the reason for what you are seeing.
 
I've seen systems try to use address pairs for data messages before
verifying (with a HB) that the interfaces are actually connected. There
are some valid network configurations where this is guaranteed to
happen.
 
    David

---

From: "Leontsinis, Nikos" <[email-masked]>
Date: Thu, 16 Sep 2010 10:05:01 +0300

Another well overlooked issue in the case of sctp multihoming is to
ensure on your ip backbone that each SCTP (pair) path follows a distinct
route in such a way as to ensure that failure of the one path
will never impact the path of the other as far I can see this can best
be accomplished using RSVP-TE end2end to ensure redundancy across all
layers (cable/router (PE/P)/slot). I haven't seeing any recommendation
stating the BCP of this deployment.
 
/nikos
 
From: [email-masked] [mailto:[email-masked]] On
Behalf Of David Laight
Sent: Wednesday, September 15, 2010 5:12 PM
To: [email-masked]
Subject: Re: [Sigtran] SCTP-Multihoming Clarification needed

 

 
    David

Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes,
MK1 1PT, UK
Registration No: 1397386 (Wales)
P Please consider the environment and don't print this e-mail unless you
really need to

DISCLAIMER:
This electronic mail message is intended exclusively for the individual or entity to which it is addressed. This message, together with any attachment, may contain confidential and legally privileged information. Any views, opinions or conclusions expressed in this message are those of the individual sender and do not necessarily reflect the views of OTEGLOBE. Any unauthorized review, use, printing, copying, retention, disclosure or distribution is strictly prohibited. If you have received this message in error, please immediately advise the sender by reply email message to the sender and delete all copies of this message. OTEGLOBE cannot accept any responsibility for the accuracy or completeness of this message as it has been transmitted over a public network. If you suspect that the message may have been intercepted or amended in any way please contact the sender. Thank you.

---

From: "Saxena, Ravi (CMS)" <[email-masked]>
Date: Thu, 16 Sep 2010 11:08:00 +0000

Sometime routes configuration also leads to this kind of problem.
You can give a try with primaries using same subnet, and secondaries using same subnet, but different than Primaries.

Local: 192.168.12.1(Primary) and 192.168.13.1 (Secondary)
Remote: 192.168.12.2(Primary) and 192.168.13.2 (Secondary)

Thanks,
Ravi Saxena

From: [email-masked] [mailto:[email-masked]] On Behalf Of Leontsinis, Nikos
Sent: Thursday, September 16, 2010 12:35 PM
To: David Laight; [email-masked]
Subject: Re: [Sigtran] SCTP-Multihoming Clarification needed

Another well overlooked issue in the case of sctp multihoming is to ensure on your ip backbone that each SCTP (pair) path follows a distinct route in such a way as to ensure that failure of the one path
will never impact the path of the other as far I can see this can best be accomplished using RSVP-TE end2end to ensure redundancy across all layers (cable/router (PE/P)/slot). I haven't seeing any recommendation stating the BCP of this deployment.

/nikos

From: [email-masked] [mailto:[email-masked]] On Behalf Of David Laight
Sent: Wednesday, September 15, 2010 5:12 PM
To: [email-masked]
Subject: Re: [Sigtran] SCTP-Multihoming Clarification needed

If you have 2 IP interfaces in the same subnet you typically have no control over which interface packets are sent out of. Usually all the packets are transmitted from one of the interfaces (regardless as to the local IP address).

The ARP responses will, however, contain the mac address of the associated interface.
So your 'local' system is probably sending traffic to both of the remote system's NICs, but the remote is only sending out of a single interface.

I've seen systems try to use address pairs for data messages before verifying (with a HB) that the interfaces are actually connected. There are some valid network configurations where this is guaranteed to happen.

    David

Local machine is having only one NIC with two IP's , say 192.168.12.1(primary) and 192.168.12.2(secondary) configured.
Remote machine is having two NICs each having a single IP , say 192.168.13.1(primary) and 192.168.13.2(secondary) configured.

Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)

P Please consider the environment and don't print this e-mail unless you really need to

DISCLAIMER: