Subject: [Sigtran] [M3UA] Clarification required on Static provisioning

From: Santhana <[email-masked]>
Date: Tue, 30 Nov 2010 16:28:11 +0530

Dear Brian

            In the case of static provisioning between two IPSPs IPSP-A and
IPSP-B, when there is a mismatch in the static configuration of Local
Entity, Dest Entity, Routing Contexts, then how to detect it ? 

            In such case, when ASP and AS becomes ACTIVE, the Destinations
are also made Available. But there may be a mismatch between IPSP-A Local
Entity and IPSP-B Dest entity. Now when AS becomes available it may convey
wrong state about a particular Dest entity. How to avoid such a situation
when Dynamic registration of RKs is not supported ?

            Are SNM messages(DUNA, DAVA, DAUD) supported in IPSP mode ?

Regards

Santhanakrishnan

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 30 Nov 2010 05:16:58 -0700

Santhana,

Santhana wrote:                                                   (Tue, 30 Nov 2010 16:28:11)
>    Dear Brian
> 
>                In the case of static provisioning between two IPSPs IPSP-A
>    and IPSP-B, when there is a mismatch in the static configuration of
>    Local Entity, Dest Entity, Routing Contexts, then how to detect it ?
> 
>                In such case, when ASP and AS becomes ACTIVE, the
>    Destinations are also made Available. But there may be a mismatch
>    between IPSP-A Local Entity and IPSP-B Dest entity. Now when AS becomes
>    available it may convey wrong state about a particular Dest entity. How
>    to avoid such a situation when Dynamic registration of RKs is not
>    supported ?

Simple: don't misconfigure the nodes.

>                Are SNM messages(DUNA, DAVA, DAUD) supported in IPSP mode ?

No.  M3UA IPSP does not support the transfer function at any node.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Santhana <[email-masked]>
Date: Tue, 30 Nov 2010 17:47:16 +0530

Dear Brian
	But the configuration at the other node IPSP-B, may not be in
IPSP-A's control. If such is the case, is there any way to avoid it ?
	Or is the strict co-operation among the operating parties, a must in
the Statically provisioned network ?

Regards
Santhanakrishnan

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Tuesday, November 30, 2010 5:47 PM
To: Santhana
Cc: [email-masked]
Subject: Re: [Sigtran] [M3UA] Clarification required on Static provisioning

Santhana,

Santhana wrote:                                                   (Tue, 30
Nov 2010 16:28:11)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 30 Nov 2010 14:03:20 -0700

Santhana,

Santhana wrote:                                                   (Tue, 30 Nov 2010 17:47:16)
> IPSP-A's control. If such is the case, is there any way to avoid it ?

Misconfiguration is misconfiguration no matter where the error is introduced.

> the Statically provisioned network ?

It is also a must in dynamically configured networks: wherever the routing
key is plugged-in in error, it is still an error.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/