Subject: [Sigtran] Max routing context value.

From: "Kulkarni, Vijay K. (NSN - IN/Bangalore)" <[email-masked]>
Date: Thu, 3 Mar 2011 02:57:15 +0800

Hi,
    we have issue with routing context, where we want to configure routing context value higher than 65535.
    but configuration is failing, as stack accepts only unsigned int (0 - 65535).
  
    And from RFC its clear that its 4 octet value. So cant we give the value more than 65535?

-vijay.

---

From: Ankit Kumar Sharma <[email-masked]>
Date: Thu, 3 Mar 2011 01:13:23 +0530

Yes, you should be able to configure a value in between 0-4294967295. It
seems your stack has set the upper limit to 2 bytes (unsigned) for the
routing context value.

On Thu, Mar 3, 2011 at 12:27 AM, Kulkarni, Vijay K. (NSN - IN/Bangalore) <
[email-masked]> wrote:

>     but configuration is failing, as stack accepts only* unsigned int* (0
> - 65535).
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran
>
>

---

From: "Kulkarni, Vijay K. (NSN - IN/Bangalore)" <[email-masked]>
Date: Thu, 3 Mar 2011 03:45:32 +0800

Thanks for the immediate reply.
 
-vijay.

________________________________

From: ext Ankit Kumar Sharma [mailto:[email-masked]] 
Sent: Thursday, March 03, 2011 1:13 AM
To: Kulkarni, Vijay K. (NSN - IN/Bangalore)
Cc: [email-masked]
Subject: Re: [Sigtran] Max routing context value.

Yes, you should be able to configure a value in between 0-4294967295. It seems your stack has set the upper limit to 2 bytes (unsigned) for the routing context value. 

On Thu, Mar 3, 2011 at 12:27 AM, Kulkarni, Vijay K. (NSN - IN/Bangalore) <[email-masked]> wrote:

	Hi, 

	-vijay.