Subject: [Sigtran] SIGTRAN test bed setup

From: mosbah abdelkader <[email-masked]>
Date: Fri, 15 Apr 2011 10:42:22 +0100

Hi,

I am relatively new to SIGTRAN/SS7 field and protocol certification process.
And I am getting involved in a project where I have to setup a test bed for
testing some SIGTRAN implementations against their specifications.

It appears for me that not all the SIGTRAN specs have test specifications.

I have access to 2 commercial SS7/SIGTRAN implementations from very known
companies in the field that I guess they will be a reference for testing.

I need some help or doc that demonstrates at least one example of test bed
setup and the protocol implementation certification process. And, if
possible, provide test specification documents for SIGTRAN.

Any other idea or tip is welcome.

Thank you.

--
BR
Abdelkader Mosbah.

---

From: Michael Tüxen <[email-masked]>
Date: Fri, 15 Apr 2011 12:10:48 +0200

On Apr 15, 2011, at 11:42 AM, mosbah abdelkader wrote:

> Hi,
> 
> 
> I am relatively new to SIGTRAN/SS7 field and protocol certification process. And I am getting involved in a project where I have to setup a test bed for testing some SIGTRAN implementations against their specifications.
> 
> I have access to 2 commercial SS7/SIGTRAN implementations from very known companies in the field that I guess they will be a reference for testing.
> 
> I need some help or doc that demonstrates at least one example of test bed setup and the protocol implementation certification process. And, if possible, provide test specification documents for SIGTRAN.
> 
ETSI has published some test specifications for SCTP, M2UA and M3UA.
On
http://sctp.fh-muenster.de
you can find implementations of some of the ETSI tests.

Best regards
Michael
> 
> Thank you.
> 
> --
> BR
> Abdelkader Mosbah.
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 15 Apr 2011 04:18:38 -0600

mosbah,

I suggest you hire a consultant, protocol test company, or
training course.

Either way, this WG mailing list does not exist for the purpose
of doing anyone's job for them.  Particularly when they neglect
to even use a search engine to answer obvious questions.

Try: http://www.google.com/search?q=m3ua+conformance+test+suite

--brian

mosbah abdelkader wrote:                       (Fri, 15 Apr 2011 10:42:22)
>    Hi,
>    I am relatively new to SIGTRAN/SS7 field and protocol certification
>    process. And I am getting involved in a project where I have to setup a
>    test bed for testing some SIGTRAN implementations against their
>    specifications.
>    I have access to 2 commercial SS7/SIGTRAN implementations from very
>    known companies in the field that I guess they will be a reference for
>    testing.
>    I need some help or doc that demonstrates at least one example of test
>    bed setup and the protocol implementation certification process. And,
>    if possible, provide test specification documents for SIGTRAN.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: mosbah abdelkader <[email-masked]>
Date: Fri, 15 Apr 2011 11:18:44 +0100

Ok, thank you.

On Fri, Apr 15, 2011 at 11:10 AM, Michael Tüxen <
[email-masked]> wrote:

> process. And I am getting involved in a project where I have to setup a test
> bed for testing some SIGTRAN implementations against their specifications.
> >
> bed setup and the protocol implementation certification process. And, if

---

From: mosbah abdelkader <[email-masked]>
Date: Fri, 15 Apr 2011 11:27:32 +0100

Brian,

Please do not give responses if you do not have a response.

I am asking for help here from people ready to help. You are not required to
give responses nor to speak on behalf of the mailing list!!!!!!!

On Fri, Apr 15, 2011 at 11:18 AM, Brian F. G. Bidulock <[email-masked]
> wrote:

---

From: mosbah abdelkader <[email-masked]>
Date: Fri, 15 Apr 2011 11:55:56 +0100

Brian,

I suggest you correct the thousands of errors and bugs in your *"said" open
source project **OpenSS7* instead of wasting time giving bad responses and
worst suggestions in the mailing list !!!!

On Fri, Apr 15, 2011 at 11:27 AM, mosbah abdelkader <
[email-masked]> wrote:

> I am asking for help here from people ready to help. You are not required
> to give responses nor to speak on behalf of the mailing list!!!!!!!
>
>
>
> On Fri, Apr 15, 2011 at 11:18 AM, Brian F. G. Bidulock <
> [email-masked]> wrote:
>
>> mosbah,
>>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 15 Apr 2011 06:53:06 -0600

mosbah,

IETF mailing lists are for conducting IETF business and
WG mailing lists are for technical discussions relating
to the WG work items.

If you have a question concerning a SIGTRAN WG document,
please pose it.

Your most recent posts, however, are not only OT they
are abusive.

--brian

mosbah abdelkader wrote:                  (Fri, 15 Apr 2011 11:55:56)
>    Brian,
>    I suggest you correct the thousands of errors and bugs in your "said"
>    open source project OpenSS7 instead of wasting time giving bad
>    responses and worst suggestions in the mailing list !!!!
>    On Fri, Apr 15, 2011 at 11:27 AM, mosbah abdelkader
>    <[1][email-masked]> wrote:
> 
>    Brian,
>    I am asking for help here from people ready to help. You are not
>    required to give responses nor to speak on behalf of the mailing
>    list!!!!!!!
>    On Fri, Apr 15, 2011 at 11:18 AM, Brian F. G. Bidulock
>    <[2][email-masked]> wrote:
> 
>      mosbah,
>      Try: [3]http://www.google.com/search?q=m3ua+conformance+test+suite
>      --brian
>    > [4][email-masked]
>    > [5]https://www.ietf.org/mailman/listinfo/sigtran
> 
>      --
>      Brian F. G. Bidulock
>      [6][email-masked]
>      [7]http://www.openss7.org/
> 
> References
> 
>    1. mailto:[email-masked]
>    2. mailto:[email-masked]
>    3. http://www.google.com/search?q=m3ua+conformance+test+suite
>    4. mailto:[email-masked]
>    5. https://www.ietf.org/mailman/listinfo/sigtran
>    6. mailto:[email-masked]
>    7. http://www.openss7.org/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Ankit Kumar Sharma <[email-masked]>
Date: Fri, 15 Apr 2011 19:54:53 +0530

Mosbah,

I agree with Brian, and I also request you to use google first and then post
your queries here. It was indeed a sound advice, and it would definitely
save your time.

There is no need to get personal here. Brian is an active and well respected
contributor of this mailing list. No one is forcing you to use OpenSS7, and
if you really hate it then go for some other commercial version. But, do not
insult people who have invested their time and energy in this project. No
software in this world is bug free. isnt it?

Regards

On Fri, Apr 15, 2011 at 4:25 PM, mosbah abdelkader <
[email-masked]> wrote

> Brian,
>
> I suggest you correct the thousands of errors and bugs in your *"said"
> open source project **OpenSS7* instead of wasting time giving bad

---

From: mosbah abdelkader <[email-masked]>
Date: Fri, 15 Apr 2011 15:27:37 +0100

Ok, you are right. I am sorry.

Thank you and thanks to Brian who also gave respected advices :)

Sorry again.

On Fri, Apr 15, 2011 at 3:24 PM, Ankit Kumar Sharma <[email-masked]>wrote:

> Mosbah,
>
> I agree with Brian, and I also request you to use google first and then
> post your queries here. It was indeed a sound advice, and it would
> definitely save your time.
>
> There is no need to get personal here. Brian is an active and well
> respected contributor of this mailing list. No one is forcing you to use
> OpenSS7, and if you really hate it then go for some other commercial
> version. But, do not insult people who have invested their time and energy
> in this project. No software in this world is bug free. isnt it?
>
> Regards
>