Subject: Re: [Simple] SUBSCRIBE for xcap-diff event sent by the presence server to the XCAP server

From: Iñaki Baz Castillo <[email-masked]>
Date: Tue, 5 Jan 2010 13:15:34 +0100

El Lunes, 28 de Diciembre de 2009, Iñaki Baz Castillo escribió:
> I would like to understand how such SUBSCRIBE sent by the presence server 
> looks. The above draft just shows examples when a SIP user send such
>  SUBSCRIBE  but no one example when the subscriber is the presence server.

Hi, it's strange for me not to see questions/responses in this maillist, so 
perhaps I'm wrong and the purpose of this maillist is to announce drafs/RFC's 
and OMA/IETF liaisons.

Please, could I know if this maillist is appropriate for asking SIMPLE related 
questions? or should I ask in sip-implementors?

Thanks a lot.

-- 
Iñaki Baz Castillo <[email-masked]>

---

From: Ben Campbell <[email-masked]>
Date: Tue, 5 Jan 2010 08:23:20 -0600

<as chair>

Actually, this list is for the purpose of discussing SIMPLE standards work--that is, drafts, RFCs, liaisons, etc. But since xcap-diff is relatively new, it does not hurt to ask clarification questions. It's up to individuals to decide how to respond. SIP-implementors may be another good place to ask.

Also, keep in mind that lots of people are just getting back from holiday, so responses may be slower than usual.

Thanks!

Ben.

On Jan 5, 2010, at 6:15 AM, Iñaki Baz Castillo wrote:

> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple

---

From: Jari Urpalainen <[email-masked]>
Date: Thu, 07 Jan 2010 13:15:27 +0200

On Mon, 2009-12-28 at 00:36 +0100, ext Iñaki Baz Castillo wrote:
> Hi, the way a presence server receives notifications for changes in XCAP 
> documents (so it can notify the watchers) is by subscribing to the XCAP server 
> for the event "xcap-diff" as specified in:
>   http://tools.ietf.org/html/draft-ietf-sip-xcapevent
> 
> looks. The above draft just shows examples when a SIP user send such SUBSCRIBE 
> but no one example when the subscriber is the presence server.
a presence server can be a "normal" xcap-diff client. Acls though would
be quite different than with the typical use-case.   

> 
> For example, let's imagine a simplified case in which there are just two XCAP 
> applications ("pres-rules" and "resource-lists").
> 
> The presence server should subscribe to users documents. AFAIK the presence 
> server would send a SUBSCRIBE as follows:
> 
> 
>    SUBSCRIBE sip:[email-masked] SIP/2.0
>    From: sip:[email-masked]
>    Accept: application/xcap-diff+xml
>    Event: xcap-diff; diff-processing=no-patching
>    Content-Type: application/resource-lists+xml
> 
>    <?xml version="1.0" encoding="UTF-8"?>
>    <resource-lists xmlns="urn:ietf:params:xml:ns:resource-lists">
>      <list>
>        <entry uri="pres-users/users/" />
>        <entry uri="resource-lists/users/" />
>      </list>
>    </resource-lists>
> 
> 
> Then when any user creates or modifies a XCAP document for those auids, then 
> XCAP server would sent a NOTIFY to the presence-server telling the document 
> addition/modification.
> 
> 
> Doubts:
> 
> - Is the above correct? (is it defined somewhere?)
theoretically yes, if you really have a distributed system, and you
indeed must use a public interface (though acls are beyond the scope of
xcap-diffevent). But in practice however, i'd assume you'd use some
"internal" api for this, and you wouldn't need to have a duplicated xcap
database (or equivalent).

> 
> - Most probably the presence-server is just interested in "index" documents 
> for both XCAP applications. However it would receive notifications for every 
> document created by any user even if it's not called "index". Is it the 
> expected behavior? How to ask in the SUBSCRIBE that there is noly interest on 
> "index" called documents?
there's no such thing like reg-expressions (or some search) in
diff-event subscriptions, though i don't think it's a big problem in
reality as you can easily skip those docs that you aren't interested in.

> 
> - Could the notification from the XCAP server to the presence server work with 
> PUBLISH rather than SUBSCRIBE & NOTIFY? This is: when a XCAP document is 
> modified the XCAP server sends a PUBLISH to the presence server with xcap-diff 
> body. Does it make sense?
Sure, but i cannot see any actual benefit

> 
> - And last question. Are all my questions defined in IETF docs? or do they 
> require specifications on top of IETF docs as OMA specs?
> 
at least rfc's will give you some hints how to make a system what you
are probably aiming at, i don't know about other specs though.

br, jari

---

From: Adrian Georgescu <[email-masked]>
Date: Thu, 7 Jan 2010 12:20:06 +0100

> Sure, but i cannot see any actual benefit

The benefit would be that you (as an XCAP server) can send a publish  
once to the Presence Agent when a document has changed rather than  
using Subscribe/Notify which requires maintaining a continuous  
subscription to get an update.

Adrian

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Thu, 7 Jan 2010 13:17:16 +0100

El Jueves, 7 de Enero de 2010, Adrian Georgescu escribió:
> The benefit would be that you (as an XCAP server) can send a publish once
>  to the Presence Agent when a document has changed rather than using
>  Subscribe/Notify which requires maintaining a continuous subscription to
>  get an update.

Yes I agree. Sending a PUBLISH is more or less "easy" but building a complete 
presence server just to handle subscription for presence server(s) is more 
complex.

The fact is that I don't want that my XCAP server becomes a SIP presence 
server. Instead it could publish xca-diff status to the *real* SIP presence 
server, and this last would also manage the xcap-diff subscriptions from real 
clients.

Is this design wrong for some reason?

Thanks a lot.

---

From: Adrian Georgescu <[email-masked]>
Date: Thu, 7 Jan 2010 13:19:19 +0100

For me this is the right design and this is how we are implementing it  
in OpenSIPS/OpenXCAP tandem.

Adrian

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Thu, 7 Jan 2010 13:33:16 +0100

> in OpenSIPS/OpenXCAP tandem.

Is there any limitation in this approach? This is:

Theorically the presence server subscribes to the XCAP server and receives 
NOTIFY with xcap-diff. 
Also the clients subscribe to the XCAP server for xcap-diff event (to know 
changes in their documents).

Instead of that, the client would subscribe to the presence server for xcap-
diff event and the XCAP server would publish xcap-diff to the presence server, 
so this last would notify the users.

IMHO there is no limitation and we avoid building a complex presence server on 
top of a XCAP server (HTTP server, not SIP!). :)

Thanks.

---

From: Adrian Georgescu <[email-masked]>
Date: Thu, 7 Jan 2010 13:35:14 +0100

> so this last would notify the users.

This last paragraph is exactly what I meant.

Adrian