Subject: [Simple] Consensus Call on draft-ietf-simple-chat

From: Ben Campbell <[email-masked]>
Date: Thu, 16 Dec 2010 10:36:46 -0600

(as chair)

Hi,

I discussed this with a number of people individually, but I don't think we ever brought this to the SIMPLE list, so I want to make it official. I've copied the XCON chairs, as well as people I recall discussing this with.

In reviewing draft-ietf-simple-chat prior to requesting publication, we ran across the fact that this draft extended the data format from RFC 4575 (sip event package) in order to add a "nickname" data element. The issue was that RFC 4575 did not define a clear way to add new data elements, so this would appear to require an update to that RFC.

OTOH, XCON produced draft-ietf-xcon-event-package and draft-ietf-xcon-common-data-model in order to extend RFC 4575 with a richer data set. The former is in the RFC Editor queue, and the latter is in AD Followup. These drafts extend the SIP conference model with a richer data format. My understanding is that draft-ietf-xcon-common-data-model includes the "nickname" element, and is otherwise a superset of the format in RFC 4575.

We have a proposal to change draft-ietf-simple-chat as follows:

1) Remove the update to RFC 4575

2) Demote the reference to RFC 4575 to informational.

3) Add an informational reference to draft-ietf-xcon-common-data-model as a possible way to convey "nickname" information to conference package subscribers.

Please respond indicating whether you agree with some or all of the above, along with any rational you would like to share. I don't think these are all or nothing--for example one might agree with 3 but disagree with 1 or 2.

We'd really like to get submit this draft prior to the end of the year, and I think this is the last blocking item, so please respond ASAP.

---

From: Mary Barnes <[email-masked]>
Date: Thu, 16 Dec 2010 11:04:24 -0600

I would agree with option 1, but I do not think you can have the 'nickname'
defined in an informational draft so options 2) and 3) are not good IMHO.
 Nickname is a key data element for chats.  So, I would suggest you add a
fourth option and that is to add a normative reference to the
xcon-data-model.  Of course, that doc will be published right around the
same time as CCMP and per the draft-boulton-xcon-session-chat, you will have
a chat based mechanism that doesn't require extensions to MSRP.  Although,
in cases where folks might first implement this mechanism for chat (rather
than XMPP, for example) and later want to use this mechanism with XCON, it
would still work - it's just that you'd have two different mechanisms for
setting the nickname.

Regards,
Mary.

On Thu, Dec 16, 2010 at 10:36 AM, Ben Campbell <[email-masked]> wrote:

> (as chair)
>
> Hi,
>
> I discussed this with a number of people individually, but I don't think we
> ever brought this to the SIMPLE list, so I want to make it official. I've
> copied the XCON chairs, as well as people I recall discussing this with.
>
> In reviewing draft-ietf-simple-chat prior to requesting publication, we ran
> across the fact that this draft extended the data format from RFC 4575 (sip
> event package) in order to add a "nickname" data element. The issue was that
> RFC 4575 did not define a clear way to add new data elements, so this would
> appear to require an update to that RFC.
>
> OTOH, XCON produced draft-ietf-xcon-event-package and
> draft-ietf-xcon-common-data-model in order to extend RFC 4575 with a richer
> data set. The former is in the RFC Editor queue, and the latter is in AD
> Followup. These drafts extend the SIP conference model with a richer data
> format. My understanding is that draft-ietf-xcon-common-data-model includes
> the "nickname" element, and is otherwise a superset of the format in RFC
> 4575.
>
> 3) Add an informational reference to draft-ietf-xcon-common-data-model as a
> possible way to convey "nickname" information to conference package
> subscribers.
>
> Please respond indicating whether you agree with some or all of the above,
> along with any rational you would like to share. I don't think these are all
> or nothing--for example one might agree with 3 but disagree with 1 or 2.
>
> We'd really like to get submit this draft prior to the end of the year, and
> I think this is the last blocking item, so please respond ASAP.
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple
>

---

From: Ben Campbell <[email-masked]>
Date: Thu, 16 Dec 2010 11:19:56 -0600

(as individual)

On Dec 16, 2010, at 11:04 AM, Mary Barnes wrote:

> I would agree with option 1, but I do not think you can have the 'nickname' defined in an informational draft so options 2) and 3) are not good IMHO.   Nickname is a key data element for chats.  So, I would suggest you add a fourth option and that is to add a normative reference to the xcon-data-model. 

The informational part was not to say an informational draft, but an informational reference. I think the approach under discussion was to say that you MAY convey nickname information. One possible way to do that is with draft-ietf-xcon-common-data-model. I don't have a strong objection to making that a normative reference, though, if that is what others prefer.

> Of course, that doc will be published right around the same time as CCMP and per the draft-boulton-xcon-session-chat, you will have a chat based mechanism that doesn't require extensions to MSRP.  Although, in cases where folks might first implement this mechanism for chat (rather than XMPP, for example) and later want to use this mechanism with XCON, it would still work - it's just that you'd have two different mechanisms for setting the nickname.

Yep. That's come up before, and each time we land on "lets go ahead and publish simple-chat". I don't expect a different answer this time (although if someone has actually changed their mind since last time, I'd love to hear it.)

---

From: "Geir Sandbakken (geirsand)" <[email-masked]>
Date: Thu, 16 Dec 2010 22:11:58 +0100

The draft has seven informative references to RFC 4575 - and a single
one that is normative for adding the Nickname code point.   Most of the
text is in the form "typically you would subscribe to RFC 4575 gather
information about the conference".  It's no problem adding "...subscribe
to RFC 4575 or draft-xcon-common-data-model..".     

While Nicknames are important for chat - so is a lot of the information
already referred to by informational references.  We make the references
informational by example for nicknames.   "For example the nickname can
be learned by subscribing to the draft-ietf-xcon-common-data-model or by
extending the user-type of RFC 4575 ".

Geir A

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Ben Campbell
Sent: 16. desember 2010 18:20
To: Mary Barnes
Cc: Miguel A. Garcia; Geir Arne Sandbakken; Adam Roach; Simple WG;
[email-masked]; Aki Niemi
Subject: Re: [Simple] Consensus Call on draft-ietf-simple-chat

(as individual)

I would agree with option 1, but I do not think you can have the
'nickname' defined in an informational draft so options 2) and 3) are
not good IMHO.   Nickname is a key data element for chats.  So, I would
suggest you add a fourth option and that is to add a normative reference
to the xcon-data-model.  

The informational part was not to say an informational draft, but an
informational reference. I think the approach under discussion was to
say that you MAY convey nickname information. One possible way to do
that is with draft-ietf-xcon-common-data-model. I don't have a strong
objection to making that a normative reference, though, if that is what
others prefer.

Of course, that doc will be published right around the same time as CCMP
and per the draft-boulton-xcon-session-chat, you will have a chat based
mechanism that doesn't require extensions to MSRP.  Although, in cases
where folks might first implement this mechanism for chat (rather than
XMPP, for example) and later want to use this mechanism with XCON, it
would still work - it's just that you'd have two different mechanisms
for setting the nickname.

Yep. That's come up before, and each time we land on "lets go ahead and
publish simple-chat". I don't expect a different answer this time
(although if someone has actually changed their mind since last time,
I'd love to hear it.)

Regards,

Mary. 

	(as chair)
	
	Hi,
	
	I discussed this with a number of people individually, but I
don't think we ever brought this to the SIMPLE list, so I want to make
it official. I've copied the XCON chairs, as well as people I recall
discussing this with.
	
	In reviewing draft-ietf-simple-chat prior to requesting
publication, we ran across the fact that this draft extended the data
format from RFC 4575 (sip event package) in order to add a "nickname"
data element. The issue was that RFC 4575 did not define a clear way to
add new data elements, so this would appear to require an update to that
RFC.
	
	OTOH, XCON produced draft-ietf-xcon-event-package and
draft-ietf-xcon-common-data-model in order to extend RFC 4575 with a
richer data set. The former is in the RFC Editor queue, and the latter
is in AD Followup. These drafts extend the SIP conference model with a
richer data format. My understanding is that
draft-ietf-xcon-common-data-model includes the "nickname" element, and
is otherwise a superset of the format in RFC 4575.

	
	
	3) Add an informational reference to
draft-ietf-xcon-common-data-model as a possible way to convey "nickname"
information to conference package subscribers.
	
	Please respond indicating whether you agree with some or all of
the above, along with any rational you would like to share. I don't
think these are all or nothing--for example one might agree with 3 but
disagree with 1 or 2.
	
	We'd really like to get submit this draft prior to the end of
the year, and I think this is the last blocking item, so please respond
ASAP.
	_______________________________________________
	Simple mailing list
	[email-masked]
	https://www.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Thu, 16 Dec 2010 15:19:00 -0600

Oh, and I forgot to put in my answers to the proposal consensus call: Yes on all 3.  

I can live with both references being normative if people want that, but concur with Geir's other post--I don't think we're making any normative requirement to use the event-package.

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Fri, 17 Dec 2010 09:37:39 +0100

I was checking the Instructions to RFC Authors, 
http://www.rfc-editor.org/rfc-editor/instructions2authors.txt

I was trying to understand if the reference to XCON Common Data Model 
should be normative or informative. According to the RFC Editor document,

                                                     Normative references
       specify documents that must be read to understand or implement the
       technology in the new RFC, or whose technology must be present for
       the technology in the new RFC to work.  An informative reference
       is not normative; rather, it provides only additional information.
       For example, an informative reference might provide background or
       historical information.  Material in an informative reference is
       not required to implement the technology in the RFC.

As you can see, the distinction between normative and informative lies on 
the importance of the referred document for the implementation of the 
technology, not on whether the referred document is an optional 
implementation or not.

Given that, I believe that someone wanted to implement the simple-chat 
draft, and in particular, the option to learn nicknames through the 
extension to the conference package, should do at least a partial 
implementation of the XCON Common Data Model, in which case, the 
reference to the XCON Common Data Model must be normative.

So, in case I was not clear enough.

I agree with 1).

Option 2) should be a normative reference to RFC 4575.

I agree with 3). I am not sure what "informational reference" means here 
again, presumably you mean a non-normative text indicating a possible way 
to learn nicknames. I agree with that.

BR,

        Miguel

On 16/12/2010 22:19, Ben Campbell wrote:
> I can live with both references being normative if people want that, but
> concur with Geir's other post--I don't think we're making any normative
> requirement to use the event-package.
>
>>> suggest you add a fourth option and that is to add a normative
>>> reference to the xcon-data-model.
>>
>>> Of course, that doc will be published right around the same time as
>>> CCMP and per the draft-boulton-xcon-session-chat, you will have a chat
>>> based mechanism that doesn't require extensions to MSRP. Although, in
>>> cases where folks might first implement this mechanism for chat
>>> (rather than XMPP, for example) and later want to use this mechanism
>>> with XCON, it would still work - it's just that you'd have two
>>> different mechanisms for setting the nickname.
>>
>>> On Thu, Dec 16, 2010 at 10:36 AM, Ben Campbell <[email-masked]
>>> <mailto:[email-masked]>> wrote:
>>>
>>>     (as chair)
>>>
>>>     Hi,
>>>
>>>     I discussed this with a number of people individually, but I don't
>>>     think we ever brought this to the SIMPLE list, so I want to make
>>>     it official. I've copied the XCON chairs, as well as people I
>>>     recall discussing this with.
>>>
>>>     publication, we ran across the fact that this draft extended the
>>>     data format from RFC 4575 (sip event package) in order to add a
>>>     "nickname" data element. The issue was that RFC 4575 did not
>>>     define a clear way to add new data elements, so this would appear
>>>     to require an update to that RFC.
>>>
>>>     draft-ietf-xcon-common-data-model in order to extend RFC 4575 with
>>>     a richer data set. The former is in the RFC Editor queue, and the
>>>     latter is in AD Followup. These drafts extend the SIP conference
>>>     model with a richer data format. My understanding is that
>>>     draft-ietf-xcon-common-data-model includes the "nickname" element,
>>>     and is otherwise a superset of the format in RFC 4575.
>>>
>>>     draft-ietf-xcon-common-data-model as a possible way to convey
>>>     "nickname" information to conference package subscribers.
>>>
>>>     the above, along with any rational you would like to share. I
>>>     don't think these are all or nothing--for example one might agree
>>>     with 3 but disagree with 1 or 2.
>>>
>>>     We'd really like to get submit this draft prior to the end of the
>>>     year, and I think this is the last blocking item, so please
>>>     respond ASAP.
>>>     [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Ben Campbell <[email-masked]>
Date: Fri, 17 Dec 2010 14:35:48 -0600

On Dec 17, 2010, at 2:37 AM, Miguel A. Garcia wrote:

> I was checking the Instructions to RFC Authors, http://www.rfc-editor.org/rfc-editor/instructions2authors.txt
> 
> I was trying to understand if the reference to XCON Common Data Model should be normative or informative. According to the RFC Editor document,
> 
>                                                    Normative references
> As you can see, the distinction between normative and informative lies on the importance of the referred document for the implementation of the technology, not on whether the referred document is an optional implementation or not.
> 
> Given that, I believe that someone wanted to implement the simple-chat draft, and in particular, the option to learn nicknames through the extension to the conference package, should do at least a partial implementation of the XCON Common Data Model, in which case, the reference to the XCON Common Data Model must be normative.
> 
> I agree with 3). I am not sure what "informational reference" means here again, presumably you mean a non-normative text indicating a possible way to learn nicknames. I agree with that.
> 

I meant "informative" as in "in the informative reference section". That is, non-normative.

Why would you expect a normative reference to 4575, but a non-normative reference to the xcon-common-data-model?

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Mon, 20 Dec 2010 08:03:57 +0100

> Why would you expect a normative reference to 4575, but a non-normative reference to the xcon-common-data-model?

The normative reference is based on my interpretation of the RFC Editor 
instructions to authors, so that if a document is a requirement for 
implementing the technology, it should be listed in the normative 
references section. I understand that if someone wants to implement this 
particular mechanism for acquiring nicknames (based on RFC 4575), it 
should implement RFC 4575 (or a fraction of it). IMHO this is enough to 
require a normative reference.

The informative text is based on the fact that this reference merely 
lists one possible mechanism for acquiring nicknames. There could be more.

BR,

           Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Ben Campbell <[email-masked]>
Date: Mon, 20 Dec 2010 15:52:35 -0600

On Dec 20, 2010, at 1:03 AM, Miguel A. Garcia wrote:

> The normative reference is based on my interpretation of the RFC Editor instructions to authors, so that if a document is a requirement for implementing the technology, it should be listed in the normative references section. I understand that if someone wants to implement this particular mechanism for acquiring nicknames (based on RFC 4575), it should implement RFC 4575 (or a fraction of it). IMHO this is enough to require a normative reference.
> 
> The informative text is based on the fact that this reference merely lists one possible mechanism for acquiring nicknames. There could be more.

Okay, but aren't we really saying that RFC 4575 combined with the xcon-common-data-model is one way you could acquire nicknames, and there could be more? The point I'm confused on is it seems to me they should both be normative, or both not be normative. Furthermore, 4575 _without_ xcon-common-data-model won't work for this purpose, since the 4975 format does not cnotain an element for nickname. 

What am I missing?

Thanks!

Ben.

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Tue, 21 Dec 2010 07:57:46 +0100

On 20/12/2010 22:52, Ben Campbell wrote:
> Okay, but aren't we really saying that RFC 4575 combined with the xcon-common-data-model is one way you could acquire nicknames, and there could be more? The point I'm confused on is it seems to me they should both be normative, or both not be normative. Furthermore, 4575_without_  xcon-common-data-model won't work for this purpose, since the 4975 format does not cnotain an element for nickname.
>
> What am I missing?
>
> Thanks!
>
> Ben.

You aren't missing anything. I treat these two documents as a single 
package for acquiring nicknames. So, to be explicit, I think both 
documents should be listed as normative references. The text should make 
an informative description of these two documents as one possible 
mechanism to acquire nicknames.

/Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Ben Campbell <[email-masked]>
Date: Tue, 21 Dec 2010 08:27:16 -0600

On Dec 21, 2010, at 12:57 AM, "Miguel A. Garcia" <[email-masked]> wrote:

> You aren't missing anything. I treat these two documents as a single package for acquiring nicknames. So, to be explicit, I think both documents should be listed as normative references. The text should make an informative description of these two documents as one possible mechanism to acquire nicknames.

Okay, I'm convinced.

Thanks,
Ben.

---

From: Ben Campbell <[email-masked]>
Date: Wed, 22 Dec 2010 16:43:09 -0600

(as chair)

From the comments in the resulting thread, I think we have consensus to remove the update to 4575 from simple-chat.

It's a little less clear, but I _think_ we have a consensus to keep the 4575 reference as normative, and also make the new reference to the xcon-common-data-model normative. If anyone objects to that please speak up ASAP.

(as individual)

I suspect the xcon-common-data-model reference implies also referencing draft-ietf-xcon-event-package(possibly as an informative reference). What do the authors think?

Thanks!

Ben.

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Thu, 23 Dec 2010 09:27:55 +0100

> I suspect the xcon-common-data-model reference implies also referencing draft-ietf-xcon-event-package(possibly as an informative reference). What do the authors think?

Yes, I think there should be a reference to the xcon-event-package. My 
understanding is that RFC 4575, xcon-common-data-model, and 
xcon-event-package should be taken as one package of references.

/Miguel
-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Ben Campbell <[email-masked]>
Date: Thu, 23 Dec 2010 10:29:59 -0600

On Dec 23, 2010, at 2:27 AM, Miguel A. Garcia wrote:

> Yes, I think there should be a reference to the xcon-event-package. My understanding is that RFC 4575, xcon-common-data-model, and xcon-event-package should be taken as one package of references.

Works for me.