Subject: [sip-clf] sipclf-problem-statement-03 released

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 29 Jun 2010 12:59:43 -0500

All: Based on the comments in the list discussion [1], I
have released a new version of the sipclf problem-statement.

The editor of the indexed-ASCII draft will be releasing an
initial version of the indexed-ASCII draft shortly using the
data model in the problem-statement.  I would like to draw
the attention of the IPFIX community to the data model
section of the sipclf-problem-statement draft so they can
produce a comparable draft for IPFIX as well.

The following are highlights of the changes in -03:

1) Each SIP CLF line has the same canonical format (see
  S8 of the draft.)

2) Added a table (Table 1) that outlines how the mandatory
  fields are logged by SIP entities.

3) Added record length, type of message (request or response)
  and directionality (send or receive) to the SIP CLF record.

4) Various nits found by Peter Musgrave.

Peter had indicated that he would like to include a discussion
of message sizes in the document.  This version does not include
message size discussion (as yet.)

The -03 version is available at:
http://www.ietf.org/internet-drafts/draft-ietf-sipclf-problem-statement-03.txt

A diff between -02 and -03 is at the following URL:
http://tools.ietf.org/rfcdiff?url2=draft-ietf-sipclf-problem-statement-03.txt

Thanks,

[1] http://www.ietf.org/mail-archive/web/sip-clf/current/msg00181.html

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Tue, 29 Jun 2010 19:10:31 -0400

All - 

I have uploaded the initial version of the indexed-ASCII implementation draft. 
This draft attempts to line up with the data model proposed in the SIPCLF Problem Statement draft.

Please note that this work was expedited in an attempt to get this draft submitted prior to the -00 draft cutoff deadline.
I intend to add a section with an example record using the syntax proposed in the draft. 

The -00 version is available at:
http://www.ietf.org/id/draft-salgueiro-sipclf-indexed-ascii-00.txt

Thanks,

Gonzalo

On Jun 29, 2010, at 1:59 PM, Vijay K. Gurbani wrote:

> _______________________________________________
> sip-clf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sip-clf