Subject: [sip-clf] Extend Charter to Include IPFIX streaming?

From: Peter Musgrave <[email-masked]>
Date: Wed, 10 Nov 2010 05:43:03 +0800

All, 

As discussed in the consensus call to choose ASCII thread, there was agreement that IPFIX was not motivated to log into files. 

Is there interest in this group extending it's charter to allow the IPFIX streaming work to be specified here?

I wanted to get a sense for this before embarking on specific charter text changes. 

As I see it the IPFIX work is well known by this group and makes reference to the data model specified here.

I would see two work items:
- specification of and IANA registration for elements to be logged (all are in the current problem statement)
- a doc which indicates how signalling flows can be linked with existing data flows already reported with IPFIX mechanisms (this might just be an addition to the existing doc)

Speaking personally, I think it makes sense to continue the discussion with this group and avoid the admin overhead of creating another one via dispatch. 

We have a group of IPFIX contributors who have shown their continued willingness to do the work necessary to make this happen (and in fact the first work item has seen lots of work, and two implementations are known to exist).

Opinions?

Regards, 

Peter Musgrave
(as co-chair)

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 9 Nov 2010 16:57:47 -0500

Count me in, I'm interested. (but of course I would say that :)

I think it would be silly to go to dispatch and create yet another working group, when we're basically only talking about a doc to register some numbers in IANA plus some informative text.

-hadriel

On Nov 9, 2010, at 4:43 PM, Peter Musgrave wrote:

> _______________________________________________
> sip-clf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sip-clf

---

From: Benoit Claise <[email-masked]>
Date: Wed, 10 Nov 2010 07:59:43 +0800

Hi Peter,

It seems like a good idea/compromise to me.

I remember Daryl's draft about performance metrics that went all over 
the place because every WG said: "not in my yard!"
He started in which date? Answered at 
http://tools.ietf.org/html/draft-malas-performance-metrics-00 to finally 
end up in PMOL, and it's just almost over.

It seems so easy for me to simply to update the SIPCLF charter, to add 
the item, to get it done with the same people/interest and at the same 
time as the ASCII file... and to move on.

Regards, Benoit.

---

From: Eric Burger <[email-masked]>
Date: Wed, 10 Nov 2010 22:45:48 +0800

So long as the milestone is later than getting the real work done.

On Nov 10, 2010, at 7:59 AM, Benoit Claise wrote:

> I remember Daryl's draft about performance metrics that went all over the place because every WG said: "not in my yard!"
> He started in which date? Answered at http://tools.ietf.org/html/draft-malas-performance-metrics-00 to finally end up in PMOL, and it's just almost over.
> 
> It seems so easy for me to simply to update the SIPCLF charter, to add the item, to get it done with the same people/interest and at the same time as the ASCII file... and to move on.
> 
> Regards, Benoit.
>> All,
>>

---

From: Saverio Niccolini <[email-masked]>
Date: Wed, 10 Nov 2010 14:54:33 +0000

Count me in!

Saverio

============================================================
Dr. Saverio Niccolini
Manager, Real-Time Communications Group
NEC Laboratories Europe, Network Research Division     
Kurfuerstenanlage 36, D-69115 Heidelberg
Tel.     +49 (0)6221 4342-118
NEC*NET Phone: 800-49-33-118
Fax:     +49 (0)6221 4342-155
e-mail:  [email-masked]
============================================================
NEC Europe Limited Registered Office: NEC House, 1 Victoria
Road, London W3 6BL Registered in England 2832014

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Peter Musgrave
> Sent: 09 November 2010 22:43
> To: List SIP-CLF Mailing
> Subject: [sip-clf] Extend Charter to Include IPFIX streaming?
> 
> All,
> 
> As discussed in the consensus call to choose ASCII thread, there was
> agreement that IPFIX was not motivated to log into files.
> 
> Is there interest in this group extending it's charter to allow the
> IPFIX streaming work to be specified here?
> 
> As I see it the IPFIX work is well known by this group and makes
> reference to the data model specified here.
> 
> - a doc which indicates how signalling flows can be linked with
> existing data flows already reported with IPFIX mechanisms (this might
> just be an addition to the existing doc)
> 
> Speaking personally, I think it makes sense to continue the discussion
> with this group and avoid the admin overhead of creating another one
> via dispatch.
> 
> We have a group of IPFIX contributors who have shown their continued
> willingness to do the work necessary to make this happen (and in fact
> the first work item has seen lots of work, and two implementations are
> known to exist).
> 
> Opinions?
> 
> Regards,
> 
> Peter Musgrave
> (as co-chair)
> 
>

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 10 Nov 2010 10:24:46 -0600

On 11/09/2010 03:43 PM, Peter Musgrave wrote:
> IPFIX streaming work to be specified here? [...] Speaking personally,
> I think it makes sense to continue the discussion with this group and
> avoid the admin overhead of creating another one via dispatch.
>
> willingness to do the work necessary to make this happen (and in
> fact the first work item has seen lots of work, and two
> implementations are known to exist).
>
> Opinions?

I am fine with extending the charter for the new milestone.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Wed, 10 Nov 2010 19:05:17 -0500

> We have a group of IPFIX contributors who have shown their continued willingness to do the work necessary to make this happen (and in fact the first work item has seen lots of work, and two impleme…

A simple recharter seems a much more reasonable and efficient approach to get this work done.

Regards,

Gonzalo

---

From: Brian Trammell <[email-masked]>
Date: Thu, 11 Nov 2010 08:29:21 +0800

I'll throw an unsurprising +1 in here.

Cheers,

Brian

---

From: Dan Burnett <[email-masked]>
Date: Wed, 10 Nov 2010 21:11:10 -0500

While a -1 would generate more interesting emails, I also have a +1 on  
this approach -- extending the charter makes more sense and may  
simplify keeping the two formats aligned.

-- dan

On Nov 9, 2010, at 4:43 PM, Peter Musgrave wrote:

> - specification of and IANA registration for elements to be logged  
> (all are in the current problem statement)
> existing data flows already reported with IPFIX mechanisms (this  
> might just be an addition to the existing doc)
>
> Speaking personally, I think it makes sense to continue the  
> discussion with this group and avoid the admin overhead of creating  
> another one via dispatch.
>

---

From: Brian Trammell <[email-masked]>
Date: Thu, 11 Nov 2010 10:17:54 +0800

I'm sure we can generate interesting emails through the work of actually _specifying_ IPFIX export, if that's what worries you. :)

Cheers,

Brian

On Nov 11, 2010, at 10:11 AM, Dan Burnett wrote:

> While a -1 would generate more interesting emails, I also have a +1 on this approach -- extending the charter makes more sense and may simplify keeping the two formats aligned.
> 
> -- dan
>