Subject: [sip-clf] Changes for Problem Statement Doc

From: Peter Musgrave <[email-masked]>
Date: Sun, 14 Nov 2010 18:42:33 +0800

Reviewing the rough minutes of the session in Beijing I see two actions for the WG doc and one issue:

Decision 1) Limit is 4K per field
Decision 2) Destination field will be an IP address. 

Issue: There was an issue about logging bodies. I see agreement that this does not need to be mandatory. I would suggest it could be incorporated into the log format in a TLV manner. Does anyone want to see words in the problem statement about e,g. what TLV should be used to log SDP?

I think once we close on language for the above issue we're ready for WGLC. Opinions?

Regards, 

Peter Musgrave
(as co-chair)

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 22 Nov 2010 15:13:33 -0600

On 11/14/2010 04:42 AM, Peter Musgrave wrote:
> Decision 1) Limit is 4K per field Decision 2) Destination field will
> be an IP address.
>
> Issue: There was an issue about logging bodies. I see agreement that
> this does not need to be mandatory. I would suggest it could be
> incorporated into the log format in a TLV manner. Does anyone want to
> see words in the problem statement about e,g. what TLV should be used
> to log SDP?

Peter: I think doing so would be useful.  However, before going down
this path, I have a question.  Is the intent to reserve a label
specifically for a SDP body (i.e., Content-Type: "application/sdp")
or is the intent to reserve a TLV for any type of body?

If the former (reserve a label for SDP only), the problem-
statement can reserve "sdp-body" as a special name that is allowed
to appear in the optional field.  If the intent is the former
(i.e., log any body) then "body" seems appropriate.

It is, of course, understood that neither the "sdp-body" nor the
"body" labels are mandatory.

> I think once we close on language for the above issue we're ready for

The 4K limit per field is fine, and even though I wish that the
destination field could be an IP address or a domain name, I understand
that the consensus is towards an IP address.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/

---

From: Peter Musgrave <[email-masked]>
Date: Mon, 22 Nov 2010 19:46:34 -0500

>> see words in the problem statement about e,g. what TLV should be used
(as individual)
I'd welcome other opinions here. I tend to think primarily in terms of sdp bodies. I also think this raises an issue in the ascii draft about how to represent a multi-line body in a format which tries to use a single text line. Some options are:
1. allow the line breaks to happen (and use the pointer block to indicate where the next message starts) 
  - this does make simple line based scripting harder  - so I do not favour it. 
2. Have a different EOL character
3. Make each sdp line it's own TLV (or have an list-like TLV entity)

These issues may recur in other body types (e.g. the XML docs which are bodies in INFOs and NOTIFYs). So any solution should bear that in mind. 

Opinions?

Peter Musgrave