Subject: [sip-clf] Request for Consensus: Adopt ASCII

From: Peter Musgrave <[email-masked]>
Date: Wed, 10 Nov 2010 05:34:23 +0800

[Background]
As has been clear for several sessions, there are two distinct communities of interest in the sip-clf:
- those who favour a apache-style text logging format
- those who prefer a binary IPFIX based format

In discussions with the IPFIX sub-group it was clear that they did not really desire a logging file format - this was a means to specify a format for streaming binary information to collectors and that they had additional goals which included the ability to correlate signalling information with information on media flows. 

As a consequence I suggested that this was a different enough objective that it would be appropriate to pursue it in either a re-chartered SIP-CLF or via the RAI dispatch process. 

This met with their agreement. 

This leaves ASCII as the default option for WG adoption for sip-clf. There was the start of a discussion about whether this indexing is still desired - but I feel we can have this discussion in the context of it as a WG document (if it is agreed to adopt it). 

[Consensus Call]
As discussed in the Beijing session, I would like to ask for a consensus call for the sip-clf group to adopt ascii as the format to proceed with under the present charter. 

Please reply with the next 7 days.

Regards, 

Peter Musgrave
Co-Chair SIP-CLF

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 9 Nov 2010 16:50:49 -0500

To be clear, you're asking for a consensus call on the sip-clf group to adopt *an* ascii format, not necessarily the indexed-ascii format as it stands right now in its draft, correct?

-hadriel

On Nov 9, 2010, at 4:34 PM, Peter Musgrave wrote:

> _______________________________________________
> sip-clf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sip-clf

---

From: Peter Musgrave <[email-masked]>
Date: Wed, 10 Nov 2010 05:51:38 +0800

Correct.

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 9 Nov 2010 17:05:03 -0500

OK, +1 for your consensus call count.  
When Eric Burger speaks, I listen.

-hadriel

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Tue, 9 Nov 2010 17:14:15 -0500

It goes without saying, but nonetheless...

+1

Regards,

Gonzalo

---

From: Brian Trammell <[email-masked]>
Date: Wed, 10 Nov 2010 08:04:31 +0800

+1

Cheers,

Brian

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 10 Nov 2010 08:30:03 -0600

On 11/09/2010 03:51 PM, Peter Musgrave wrote:
> [Consensus Call] As discussed in the Beijing session, I would like
> to ask for a consensus call for the sip-clf group to adopt ascii as
> the format to proceed with under the present charter.

And Hadriel Kaplan asked for a clarification:
> To be clear, you're asking for a consensus call on the sip-clf group
> to adopt *an* ascii format, not necessarily the indexed-ascii format
> as it stands right now in its draft, correct?

To which, Peter replied:
> Correct

So ... yes, I support adopting an ASCII format.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/

---

From: Eric Burger <[email-masked]>
Date: Wed, 10 Nov 2010 22:44:25 +0800

And, for completeness, I'll second Hadriel's motion ;-)

---

From: Saverio Niccolini <[email-masked]>
Date: Wed, 10 Nov 2010 14:51:36 +0000

+1

Saverio

============================================================
Dr. Saverio Niccolini
Manager, Real-Time Communications Group
NEC Laboratories Europe, Network Research Division     
Kurfuerstenanlage 36, D-69115 Heidelberg
Tel.     +49 (0)6221 4342-118
NEC*NET Phone: 800-49-33-118
Fax:     +49 (0)6221 4342-155
e-mail:  [email-masked]
============================================================
NEC Europe Limited Registered Office: NEC House, 1 Victoria
Road, London W3 6BL Registered in England 2832014

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Vijay K. Gurbani
> Sent: 10 November 2010 15:30
> To: [email-masked]
> Subject: Re: [sip-clf] Request for Consensus: Adopt ASCII
>

---

From: Dan Burnett <[email-masked]>
Date: Wed, 10 Nov 2010 21:07:19 -0500

+1

---

From: Peter Musgrave <[email-masked]>
Date: Mon, 29 Nov 2010 14:55:56 -0500

(as chair)

I have not seen any contrary opinions on the list. 

The WG will adopt the ASCII draft as a working doc.

Regards

Peter Musgrave

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Wed, 1 Dec 2010 01:47:53 -0500

Peter - 

There might be value in converging as a group on many of these lingering issues that have recently been raised before submitting the -00 version of the WG doc. 

These issues include:

- Should we use indexing at all versus tab delimited? or should we stick with just pointers? or go with do away with the indexing but still log the field lengths?
- Do we use TAB or spaceE as field separators?
- Update the presentation of optional fields from something like: <mandatory fields>	01,07,foo.bar	02,0b,hello world      to something like: <mandatory fields> 1="foo.bar" 2="hello world"
- Should we add vendor specified fields in the optionally logged portion (using enterprise numbers or related mechanism)
- What format do we use to log a field that cannot be parsed?
- How do we log a missing field? Stick with - and come up with some escape sequence for it? or do we log all fields which are interpreted/derived not use "", but all fields which are the literal string use " ?
- While we have to consensus that logging bodies (SDP and otherwise) is capped at 4k and optional, how much of of this should be specified in the Problem Statement and how much in the ASCII draft?  For something that is considered option, do we need to decide on how to represent a multi-line body in a format which tries to use a single text line?

Can we generate some productive discussion on these with the intent of getting consensus and finally get these issues resolved? Closing on these will improve our starting point and  will expedite progress on the draft

Regards,

Gonzalo