Subject: Re: [sip-clf] I-D Action: draft-ietf-sipclf-format-06.txt

From: Peter Musgrave <[email-masked]>
Date: Sun, 1 Apr 2012 14:09:36 -0400

Hi Robert, Gozallo, Vijay

I have read the diffs in the document and think this is in good shape. 

Do we feel that a final WGLC is needed for any of these changes - or should I go ahead and do the writeup for IESG?

Robert - as AD do the changes made here address your concerns? 

SIP-CLFers: Any issues here?

Peter 

On 2012-03-12, at 4:14 PM, Gonzalo Salgueiro wrote:

> Folks:
> 
> I have posted the -06 version of the SIP CLF Format Draft and it is now in the archives at [1].
> 
> This draft was meant to address the AD review items that were raised. The diffs between the -05 and the -06 versions is at [2]
> 
> Some of the more substantial changes include:
> 
> - Added IANA registry for Version field and Transport Flags
> - Addressed change request from ASCII to UTF-8
> - Updated escaping mechanism description for CRLF, TAB, '-', '?'
> - Clarified treatment of repeated optional fields
> - Cleaned up Timestamp and Length definitions
> - Removed all body type restrictions
> - Addressed a bunch of minor issues and nits
>  
> [1] http://tools.ietf.org/html/draft-ietf-sipclf-format
> [2] http://tools.ietf.org/rfcdiff?url2=draft-ietf-sipclf-format-06.txt
> 
> Regards,
> 
> Gonzalo
> 
> On Mar 12, 2012, at 3:13 PM, [email-masked] wrote:
> 
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the SIP Common Log Format Working Group of the IETF.
>> 
>> 	Title           : Format for the Session Initiation Protocol (SIP) Common Log Format (CLF)
>> 	Author(s)       : Gonzalo Salgueiro
>>                          Vijay Gurbani
>>                          Adam Roach
>> 	Filename        : draft-ietf-sipclf-format-06.txt
>> 	Pages           : 28
>> 	Date            : 2012-03-12
>> 
>>   The SIPCLF Workgroup has defined a common log format framework for
>>   Session Initiation Protocol (SIP) servers.  This common log format
>>   mimics the successful event logging format found in well-known web
>>   servers like Apache and web proxies like Squid.  This document
>>   proposes an indexed text encoding format for the SIP Common Log
>>   Format (CLF) that retains the key advantages of a text-based format,
>>   while significantly increasing processing performance over a purely
>>   text-based implementation.  This file format adheres to the SIP CLF
>>   data model and provides an effective encoding scheme for all
>>   mandatory and optional fields that appear in a SIP CLF record.
>> 
>> 
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-ietf-sipclf-format-06.txt
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> This Internet-Draft can be retrieved at:
>> ftp://ftp.ietf.org/internet-drafts/draft-ietf-sipclf-format-06.txt
>> 
>> _______________________________________________
>> sip-clf mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sip-clf
>> 
>

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 02 Apr 2012 10:11:04 -0500

> I have read the diffs in the document and think this is in good shape.

Peter: Thank you for going through the updated drafts.

> Do we feel that a final WGLC is needed for any of these changes - or
> should I go ahead and do the writeup for IESG?

I will leave that question to the chairs and AD to decide.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web:   http://ect.bell-labs.com/who/vkg/

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Mon, 2 Apr 2012 14:56:20 -0400

> Peter: Thank you for going through the updated drafts.

Thanks, indeed.
> I will leave that question to the chairs and AD to decide.

I'm of the mind that this isn't necessary but will gladly defer to the chair and AD.

Cheers,

Gonzalo

---

From: Robert Sparks <[email-masked]>
Date: Mon, 30 Apr 2012 13:11:26 -0500

So I'm going through all the email since the original publication 
request on this document to make sure we haven't missed anything.

A couple of points on this one (since I had not previously replied to it).

> should I go ahead and do the writeup for IESG?
The changes between -05 and -06 were actually pretty massive. It created 
registries, it changed the capability of the
mechanism (by forcing truncation of messages instead of repeating blocks 
when logging bodies of entire sip messages.
The only comments on this message on list have been from Vijay and 
Gonzalo. It would be good to see some evidence
that someone else in the group has at least looked at the changes.
> Robert - as AD do the changes made here address your concerns?
Not completely - I reread the draft and my comments today - I'll be 
replying separately on those.
>> This draft was meant to address the AD review items that were raised. 
>> The diffs between the -05 and the -06 versions is at [2]
>>
>> On Mar 12, 2012, at 3:13 PM, [email-masked] 
>> <mailto:[email-masked]> wrote:
>>
>>>
>>> A New Internet-Draft is available from the on-line Internet-Drafts 
>>> directories. This draft is a work item of the SIP Common Log Format 
>>> Working Group of the IETF.
>>>