Subject: Re: [sip-ops] [dispatch] [Sipping] SIP-CLF: Results on ASCII vs. binary representation

From: Cullen Jennings <[email-masked]>
Date: Fri, 1 May 2009 06:23:16 -0600

On Apr 29, 2009, at 1:34 PM, Elwell, John wrote:

> p.s. which list - DISPATCH or SIP-OPS?

Folks, please use DISPATCH for this for now.

Thanks,
Cullen <in my RAI AD role>

ANd in gneraly, please, don't cross post whole threads if at all  
posible.

---

From: Tom Taylor <[email-masked]>
Date: Fri, 01 May 2009 15:34:14 -0400

How about adding length fields to ASCII?

Hadriel Kaplan wrote:
> 
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of Vijay K. Gurbani
>>
>> So after tweaking all kinds of optimizations for binary CLF, the
>> best we can do is approach ASCII CLF without any optimizations.
>> This much no one will dispute, I hope.
> 
> Depends on how you plan to disambiguate legal characters in the fields from the field separators.  In binary the length field removes the need for disambiguation, or a CRLF itself does it (depending on the format).  In ascii, if you have to escape characters, then that escaping and de-escaping could be a big hit.
> 
> But anyway, I think the real question that needs to be answered *first* is "what is the purpose of the CLF?"  What is it going to help admins do?  Is it for troubleshooting, or for registration audit logging, or for IDS systems, etc?
> 
> -hadriel
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>