Subject: Re: [sip-overload] draft-gurbani-sip-overload-control-02 submitted

From: Salvatore Loreto <[email-masked]>
Date: Thu, 21 Oct 2010 18:02:02 +0300

in 4.2 the draft states:

  The "oc", "oc_validity" and "oc-seq" Via header parameters are only
    defined in SIP responses and MUST NOT be used in SIP requests.

however this seems contradict sections 3 and 4.1 where
'oc' parameter MUST be inserted into SIP requests by SIP entity that 
supports
the spec.

/Sal

On 8/23/10 8:38 PM, Vijay K. Gurbani wrote:
> Folks: I have updated draft-gurbani-sip-overload-control to
> reflect the discussion we had in Maastricht and subsequently,
> on the mailing list.  Version -02 is now available in the
> IETF archives (please see
> http://www.ietf.org/id/draft-gurbani-soc-overload-control-02.txt)
>
> This version has the following changes:
>
> 1) Reduced the parameters from 5 to 2, as per the Maastricht
>    discussion;
> 2) Simplified oc-validity ABNF, as per the Maastricht
>    discussion;
> 3) Include Janet's comments on RPH that were sent on the list
>    following the Maastricht meeting;
> 4) Took out the simplistic random number algorithm to determine
>    whether or not a request was to be forwarded.  Clearly,
>    based on the list discussion, we will need a more resilient
>    algorithm;
> 5) Attended to various nits and edits.
>
> Please do take a look and post any comments.
>
> Thank you,
>
> - vijay

-- 
Salvatore Loreto
www.sloreto.com

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 21 Oct 2010 14:10:14 -0500

On 10/21/2010 10:02 AM, Salvatore Loreto wrote:
> supports the spec.

Sal: Thanks for catching this.  I believe some WG member (Hadriel?)
had reported this already since I have it on my list of fixes for the
next revision.

Ciao,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/