Subject: RE: Clarifications on attributes in a SDP message

From: "Paul Defrain" <[email-masked]>
Date: Thu, 18 Nov 1999 16:46:41 -0600

Without going back to the spec, my take on the matter was that any attribute
specification within a media session pertains only to that particular
session. Anything set before the first media session pertains to all
sessions unless otherwise overriden within a media session.

PDD

> -----Original Message-----
> From:	Sunitha Kumar [SMTP:[email-masked]]
> Sent:	Thursday, November 18, 1999 3:48 PM
> To:	siplist
> Subject:	Clarifications on attributes in a SDP message
> 
> Hi:
> 
> In an SDP message, it is said that the attributes could be defined for
> the entire session and for each media, and that the one in the media
> over rides the one in the session.
> 
> It is given in the SDP spec that  the property attribute, such as
> a=recvonly applies to the session.
> So, if this occurs in the media, is this to be ignored ; or treated as
> the session attribute ?
> 
> Thanks
> sunitha
> 
> 
>

---

From: Sunitha Kumar <[email-masked]>
Date: Thu, 18 Nov 1999 19:05:44 -0600

Thanks for the reply :)
It is fine that the attrib after the m field belongs to the media, and
not the session. However, I am confused with the statement, in the SDP
spec (page 18) which says about the property attribute being that of the
session. Now, if I get a property attribute after the m field, does this
belong to the session or should this be ignored?

Thanks again.
sunitha

Paul Defrain wrote:

>
>
> Without going back to the spec, my take on the matter was that any
> attribute specification within a media session pertains only to that
> particular session. Anything set before the first media session
> pertains to all sessions unless otherwise overriden within a media
> session.
>
> PDD
>