Subject: Where are the headers of "Reqested-By" and "Also" defined?

From: "Yu Shen" <[email-masked]>
Date: Wed, 3 Nov 1999 11:48:33 -0800

In reading ID "SIP Telephony Services Examples with Call Flows" (draft-sparks-sip-service-exaples-00), I found the use of the headers "Also" and "Requested-By" in call transfer. But I could not find them defined in SIP, RFC 2543. They are not listed as extension from the RFC 2543 either. 

I guess that it may be defined in "H. Schulzrinne, J. Roseberg, SIP Call Control Servcies, Internet Draft, IETF, June 17, 99, work in progress". However, I could not find the document in the IETF ID directory.

Yu Shen
UTStarCom

---

From: "David Shrader" <[email-masked]>
Date: Wed, 03 Nov 1999 15:03:49 -0500

Try looking for I-D <draft-ietf-mmusic-sip-cc-01.txt>

----------------------------
David Shrader
Master Consultant, Inc.
[email-masked]

----------
From: "Yu Shen" <[email-masked]>
To: <[email-masked]>
Subject: Where are the headers of "Reqested-By" and "Also" defined?
Date: Wed, Nov 3, 1999, 2:48 PM

In reading ID "SIP Telephony Services Examples with Call Flows"
(draft-sparks-sip-service-exaples-00), I found the use of the headers "Also"
and "Requested-By" in call transfer. But I could not find them defined in
SIP, RFC 2543. They are not listed as extension from the RFC 2543 either.

I guess that it may be defined in "H. Schulzrinne, J. Roseberg, SIP Call
Control Servcies, Internet Draft, IETF, June 17, 99, work in progress".
However, I could not find the document in the IETF ID directory.

Yu Shen
UTStarCom

---

From: "Vakil, Mohammad (c)" <[email-masked]>
Date: Wed, 03 Nov 1999 21:11:04 +0000

They're defined in SIP Call Control Services. 

draft-ietf-mmusic-sip-cc-01.txt
<http://search.ietf.org/internet-drafts/draft-ietf-mmusic-sip-cc-01.txt> 

Following discussion would be helpful about the BNF of these headers.

Mohammad Vakil
MCI Worldcom
Multimedia Services Engineering
972-7297117

No, it wasn't explicit. Probably because I wrote the BNF too quickly. It
should definitely be name-addr | addr-spec, with the same rules regarding
which one to use as normal SIP.
*	Jonathan R.

Robert Sparks wrote:
	>
	> draft-ietf-mmusic-sip-cc-01 currently calls for name-addr when it
needs
	> addresses in the Also: and Requested-By: headers. Did you
explicitly
choose
	> not to allow the (name-addr|addr-spec) construct used by
To:,From:, and
	> Contact:?
	>
	> Robert Sparks
	> MultiMedia Services Engineering
	> MCI Worldcom

	----------
	From:  David Shrader [SMTP:[email-masked]]
	Sent:  Wednesday, November 03, 1999 2:04 PM
	To:  Yu Shen
	Cc:  SIP List
	Subject:  Re: Where are the headers of "Reqested-By" and "Also"
defined?

	
	----------

		In reading ID "SIP Telephony Services Examples with Call
Flows" (draft-sparks-sip-service-exaples-00), I found the use of the headers
"Also" and "Requested-By" in call transfer. But I could not find them
defined in SIP, RFC 2543. They are not listed as extension from the RFC 2543
either. 
		 
		I guess that it may be defined in "H. Schulzrinne, J.
Roseberg, SIP Call Control Servcies, Internet Draft, IETF, June 17, 99, work
in progress". However, I could not find the document in the IETF ID
directory.
		 
		Yu Shen
		UTStarCom