Subject: RE: Comments on draft-camarillo-mmusic-sip-isup-bcp-00.txt

From: [email-masked]
Date: Tue, 23 Nov 1999 13:43:52 +0200

The problem with the timeout-based solution, which Matt 
suggests, is how this timeout is defined. The user may 
sometimes stop dialing for several seconds between the digits. 
How long should the timeout be in order not to misinterpret 
this and think that all the needed digits are received?
In Q.931 the minimum for this inter digit timeout is 
10 seconds, after which the ingress switch disconnects 
the call, if it hasn't received an Address Complete from
the egress switch, of course.
 
I would imagine that the users will start complaining,
if the timeout would be shorter than 5 seconds. And 5 seconds 
is an awful lot of extra delay for a call setup.

Using # to notify that the last digit has been dialed 
would solve the problem, but is it justified to teach a 
new way of dialing for this?
(Moreover, it works only with DTMF-capable phones, 
but that isn't a big disadvantage.)

Pardon me Matt, if I got you wrong. If you meant that a 
timeout based solution should be used in addition to 
overlap sending with SIP, I agree with you 100%. 
It is probably a good idea to wait about 1 second
before sending a new INVITE, but not for 5 seconds. 
But this is an implementation issue.

Regards,

Mikko Alutoin
Nokia Networks
[email-masked]

---

From: "Matt Cannon" <[email-masked]>
Date: Tue, 23 Nov 1999 13:37:00 -0600

Mikko,
	Since as Jonathan has pointed out the protocol 
can easily and inherently support the use of overlap,
the conflict between timeout/# and overlap is
really a configuration issue on the client. Luckily
I believe the choice of that configuration is probably
out of the scope of the working group and is more 
an issue with the requirements between vendors 
and service providers.

I agree with Pete, as long as Jonathan's 484 solution
is acceptable with everyone, we've beat this topic to death. 
Lets move on.

Matt

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, November 23, 1999 5:44 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: Comments on draft-camarillo-mmusic-sip-isup-bcp-00.txt
> 
>