Subject: Implementation detail about tags.

From: "Rick Dean" <[email-masked]>
Date: Fri, 12 Nov 1999 11:32:12 -0600

Whenever my SIP UA sends an invite,
it includes a "From" tag.  This makes the case
of me calling myself through
a proxy easier.  Otherwise, matching messages to
call-leg-ends is more painful.  I believe this
is allowable within the spec, and you have now
been warned, so don't let it break your stack.

When responding to an invite, I always include
a "to" tag even though I sometimes don't have to.
Thus, if I ever receive a invite with a "to" tag, yet have
no record of the call, I know the invite is
a re-invite, and either could be for someone else
or is ancient, thus I return "481 Call Leg
does not exist".

Does anyone have a problem with this?

--
Rick Dean
3Com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 16 Nov 1999 09:21:18 -0500

> been warned, so don't let it break your stack.

Yes.

> or is ancient, thus I return "481 Call Leg

Also correct.

-Jonathan R.
-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: Shail Bhatnagar <[email-masked]>
Date: Tue, 16 Nov 1999 12:33:57 -0500

> or is ancient, thus I return "481 Call Leg

Not sure what this achieves. When you say "yet have no record of
the call", you have probably done some kind of lookup based on 
Call-ID. It does not optimize your decision to send 481 in any
way, does it ?