Subject: RE: Text based protocols

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 24 Nov 1999 08:08:40 -0500

Gently phrased I'm sure.

I'm not aware of any, but I'm sure we will have a good 
opportunity to look into this when MEGACO/H.248 implementations
start appearing.  There is both a text and a binary encoding.
It would be possible to make direct comparisons given enough
real world examples to create a sufficiently reliable dataset.

Until then, or the emergence of some realistic data from some
other source, I beg of you not to start a debate on the issue;
it was very unpleasant when it happened on the Megaco list,
and there was no convincing either side.

Brian

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: Wednesday, November 24, 1999 3:00 AM
> To: sip
> Subject: Text based protocols
> 
> 
> Hi,
> 
> I am looking for information about the real overhead that a text-based
> protocol (like SIP) has "on the wire" in relation to binary 
> encoding. Is
> there any study about this available.
> 
> Thanks,
> 
> Gonzalo 
> -- 
> Gonzalo Camarillo         Phone :  +358  9 299 33 71
> Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
> Telecom R&D               Fax   :  +358  9 299 31 18
> FIN-02420 Jorvas          Email :  [email-masked]
> Finland
>

---

From: "Paul E. Jones" <[email-masked]>
Date: Sun, 28 Nov 1999 21:03:11 -0500

Brian,

Not trying to start a debate at all... I, too, am pretty tired of reading
the endless debates on this subject.

However, I would like to see information on the processing requirements of
text versus binary.  My own belief is that bandwidth for signaling is much
less of an issue than processing requirements for large-scale devices.  I
would like to see results that confirms or disputes that.  Will we see those
results, possibly?

Best Regards,
Paul

----- Original Message -----
From: "Rosen, Brian" <[email-masked]>
To: "'Gonzalo Camarillo'" <[email-masked]>; "sip"
<[email-masked]>
Sent: Wednesday, November 24, 1999 8:08 AM
Subject: RE: Text based protocols