Subject: Line Folding + Grammar strictiness {RESEND}

From: [email-masked]
Date: Mon, 22 Nov 1999 18:18:30 +0530

Hi
This is a resend - I think our mail server was down - these 2 mails bounced
back.
Pls ignore if you have already received it.
Regds
Arjun

---------------------- Forwarded by Arjun Roychowdhury/HSSBLR on 11/22/99
06:23 PM ---------------------------

Arjun Roychowdhury
11/21/99 12:15 PM

To:   [email-masked]
cc:
Subject:  Line Folding

Hi,
According to the specification of line folding, a header may be broken into
multiple lines by inseting a LWS in the next line.
so
<hdr>:<token1> <token2>
     <token3>

is allowed.

However, the spec says that Headers itself should not have leading white
spaces.

However, Ive seen certain examples where many headers beging with an LWS.
Is this something that is allowed ? If this is so, it makes differentiating
between a Header continuation and a new Header more difficult.

Regds
Arjun

---------------------- Forwarded by Arjun Roychowdhury/HSSBLR on 11/22/99
06:23 PM ---------------------------

Arjun Roychowdhury
11/21/99 12:24 PM

To:   [email-masked]
cc:
Subject:  How strictly is the SIP grammar being followed ?

Hi,
Please refer to definition of a tag-param

tag-param= "tag=" UUID
UUID = 1*(hex|'-')

However, in one of the test messages of 2nd bakeoff (test1.txt) , there was
a
test which had a

tag=12231423424n
and
tag=98ashd<something>

None of the above confirm to the grammar specified, so why should a parser
allow it ?

Just wondering how strictly the tests are following the grammar - if not,
why define a fixed rule set in the first place ?

Regds
Arjun

---

From: Pyda Srisuresh <[email-masked]>
Date: Thu, 25 Nov 1999 12:05:45 -0800 (PST)

--- Lars Berggren <[email-masked]> wrote:
> On Thu, 25 Nov 1999, Pyda Srisuresh wrote:
> 
> > --- Henning Schulzrinne <[email-masked]> wrote:
> > > 
> > > 
> > > Lars Berggren wrote:
> > > > 
> > > 
> > > > 
> > > > There are also cases when the host part of the user@host form causes
> > > > problems when creating a globally unique id, e.g. for hosts on LANs
> without
> > > > globally unique hostnames or ip-addresses.
> > > > 
> > 
> > A host must either have a globally unique name or globally unique IP
> address
> > in order for the host to be globally accessible by external hosts.
> > Hosts in private domain (say, 10.0 address space) do not have globally
> unique
> > addresses, but can have globally unique DNS names.
> > 
> > > > However if such hosts is to be reached globally I believe they must
> have
> > > > some globally reachable sip-url (where the host part indicates some
> kind
> > > > of nat-sip-proxy).
> > > > Thus, I think it might be a good idea that clients without globally
> unique
> > > > ip-addresses constructs its Call-ID from their globally reachable
> sip-url
> > > > or some other unique token (given by the sysadmin) that can be
> configured
> > > > into the client.
> > 
> > I dont see a problem with the current SIP URL, as this does allow for
> > idetifying a host by name. 
> > 
> 
> I didn't say that there was a problem with the sip-url, rather I said the
> sip-url was the solution for a 10.x.x.x-host when constructing the
> Call-ID.
> 

OK. Apparantly, I misunderstood.

> > > > 
> > > > For example:
> > > > Call-ID: [email-masked];tag=12921838
> > > > or
> > > > Call-ID:[email-masked]
> > > > (the latter following the current rfc stated syntax of Call-ID)
> > > > 
> > > > What about this? Is it something to add to the firewall-friendly
> > > > implementation requirements in appendix A of the rfc?
> > > > 
> > > 
> > Of the two examples you gave,  how does the former offer any advantage 
> > over the latter for a 10.0 host? How is it more firewall/NAT friendly
> > than the other? Thanks.
> 
> Didn't say that one example was more firewall-friendly than the other.
> These two examples were just examples of how a Call-ID might look like if
> they were constructed from a sip-url of a 10.x.x.x-host.
> 
> Note that the 'sip.company.com' is the name of the firewall and is used to
> form a global sip-url to a host without unique address behind the
> firewall.
> 

OK. Sounds like we are in full agreement.

> > 
> > > I'm not sure that making the Call-ID more complicated is all that
> > > helpful, since it is after all (mostly) an opaque identifier. The local
> > > part is supposed to be globally unique all by itself, with the host part
> > > adding a layer of "insurance" that makes it safe to use mainly
> > > time-based identifiers as the local part.
> > > 
> > > For those with non-globally-unique addresses, there is a potential
> > > problem only if they use a 10.x.x.x address. (Even in that case, the
> > > likelihood of bad consequences is probably small.) Otherwise, if they
> > > use a host name, that host is not likely to be pingable or resolvable
> > > via DNS, but probably unique.
> > > 
> > > Thus, I would suggest leaving things as is. It doesn't seem to be broken
> > > and I'm reluctant to add complexity if I can help it.
> > > 
> > 
> > I agree.
> > 
> > > Henning
> > > 
> > > 
> > 
> > regards,
> > suresh
> > __________________________________________________
> > Do You Yahoo!?
> > Thousands of Stores.  Millions of Products.  All in one place.
> > Yahoo! Shopping: http://shopping.yahoo.com
> > 
> > 
> 
> Lars Berggren       <[email-masked]>
> Intertex Data AB    tel: +46-8-6282828
> Sundbyberg, Sweden  fax: +46-8-6286414
> 
> 

regards,
suresh

__________________________________________________
Do You Yahoo!?
Thousands of Stores.  Millions of Products.  All in one place.
Yahoo! Shopping: http://shopping.yahoo.com