Subject: RE: Please push the pound key ( was RE: Comments on draft-camari llo-mmusic-sip-isup-bcp-00.txt)

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 23 Nov 1999 13:21:29 -0600

Fact is, a lot of European phones don't have such a key.

Seriously, what we need is to thrash out an IETF view of the architecture
for IP Telephony.  This could include views on how to make the transition
between the legacy GSTN and the SIP network of the future, both spatially
(between islands) and temporally (making the new islands grow).  For the
issue at hand, this exercise would delineate the situations where overlap
outpulsing has to be supported and make recommendations on the protocols to
be used (not necessarily SIP if there's no intent to take advantage of the
new possibilities added by SIP).

Sounds like what TIPHON is doing, but they were handicapped by starting with
an assumed protocol.  Are we going to do that again or learn from their two
years of thrashing?

> -----Original Message-----
> From:	David R. Oran [SMTP:[email-masked]]
> Sent:	Tuesday, November 23, 1999 9:53 AM
> To:	Lawrence Conroy; sip
> Subject:	RE: Please push the pound key ( was RE: Comments on
> draft-camarillo-mmusic-sip-isup-bcp-00.txt)
> 
> OK, that's not so bad as what might happen 'way down south on this side of
> the pond if the message said "press the HASH key".
> 
> Or how many people would freeze and say "duh?" if the message said "press
> the octothorpe key".
> 
> Gee, maybe that last is a good idea, because while the poor sod sits
> wondering what the f... an octothorpe is, the digit timer would have
> expired
> and the call completed!
> 
> Dave.
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Lawrence
> > Conroy
> > Sent: Tuesday, November 23, 1999 8:32 AM
> > To: [email-masked]
> > Subject: Re: Please push the pound key ( was RE: Comments on
> > draft-camarillo-mmusic-sip-isup-bcp-00.txt)
> >
> >
> > >Please forgive me for "not getting it", but why can things not be kept
> > >simple along the reasoning by Matt Cannon and others: If an IP
> telephony
> > >gateway terminates calls to a PSTN network with numbering plans having
> > >different digit string lengths, it can just insert a voice
> > message: "Please
> > >push the pound key when you have finished dialing". Are there
> > any problems
> > >with this approach?
> > >
> > >Thanks, Henry
> > >
> > Hello all,
> >   Amusing as this particular discussion is, I do wonder what most
> > of the people
> > over here in the U.K. would think if they heard such an announcement.
> > If they aren't on strike, I'd dearly love to hear BT's call center
> agents
> > explaining that the "pound" key is not one with a Sterling symbol on it.
> >
> > All the best, Lawrence
> > -----------------------------------------------------------------------
> > | Lawrence Conroy,    | "These Opinions must be mine, 'cos if they    |
> > | Roke Manor Research |  were my Company's they'd pay me for them"    |
> > |- [email-masked]  ---+- Tel: +44 1794 833666  Fax: +44 1794 833434 --|
> >
> >
> >
> 
>

---

From: "Paul E. Jones" <[email-masked]>
Date: Sun, 28 Nov 1999 20:27:53 -0500

RE: Please push the pound key ( was RE: Comments on draft-camarillo-mmusic-sip-isup-bcp-00.txt)Tom,

Your point here is one that I have tried to make several times.  The answer I have consistently received is that the IETF is in the business of designing protocols, not architectures.

The fact is that without a well-defined VoIP architecture in the IETF, it is going to be very hard to meet the needs... because, what are the needs?

TIPHON and ITU-T have worked hard on integrating IP/ATM networks with the PSTN.  Now, TIPHON is examining pure IP to IP solutions and the ITU-T is adding new features to H.323 to make it a better IP service platform, including HTTP-based service control.  The two organizations are also working cooperatively on user and service mobility within H.323.

This type of effort-- both on the protocol side and the architectural and requirements side-- are essential to the success of any protocol.  As a result, H.323 has been successful.

SIP is missing a lot of what H.323 has.  To be fair, I would say H.323 has a lot that SIP does not need, as well.

What was once a protocol to initiate a simple session has been touted as the solution for telephony, but questions are being raised about its utility in that space.  The missing functionality may be very difficult to put back into this protocol (or complementary or replacement protocols) if we do not have a good understanding of the requirements and VoIP architecture.  The end result may be a solution that is no better than H.323.  Why waste time re-inventing if we cannot improve?

The IETF can continue to define protocols without requirements and architecture documents, but I question how successful it can be in the marketplace without such documents.  What, exactly, are we trying to achieve with SIP?

Paul

  ----- Original Message ----- 
  From: Tom-PT Taylor 
  To: sip 
  Sent: Tuesday, November 23, 1999 2:21 PM
  Subject: RE: Please push the pound key ( was RE: Comments on draft-camari llo-mmusic-sip-isup-bcp-00.txt)

  Seriously, what we need is to thrash out an IETF view of the architecture for IP Telephony.  This could include views on how to make the transition between the legacy GSTN and the SIP network of the future, both spatially (between islands) and temporally (making the new islands grow).  For the issue at hand, this exercise would delineate the situations where overlap outpulsing has to be supported and make recommendations on the protocols to be used (not necessarily SIP if there's no intent to take advantage of the new possibilities added by SIP).

  Sounds like what TIPHON is doing, but they were handicapped by starting with an assumed protocol.  Are we going to do that again or learn from their two years of thrashing?

    -----Original Message----- 
    From:   David R. Oran [SMTP:[email-masked]] 
    Sent:   Tuesday, November 23, 1999 9:53 AM 
    To:     Lawrence Conroy; sip 
    Subject:        RE: Please push the pound key ( was RE: Comments on  draft-camarillo-mmusic-sip-isup-bcp-00.txt) 

    Gee, maybe that last is a good idea, because while the poor sod sits 
    wondering what the f... an octothorpe is, the digit timer would have expired 
    and the call completed! 

    Dave. 

    > >simple along the reasoning by Matt Cannon and others: If an IP telephony 
    > If they aren't on strike, I'd dearly love to hear BT's call center agents