Subject: RE: [SIP] "method" parameter in "contact"

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 9 Jan 2001 01:50:59 -0500

> -----Original Message-----
> From: Deepak Mohan [mailto:[email-masked]]
> Sent: Thursday, January 04, 2001 6:54 AM
> To: [email-masked]
> Subject: [SIP] "method" parameter in "contact"
> 
> 
> In which request/response will the "contact" header have the 
> "method" parameter, and what is the use?

The primary use for the method parameter was when a URL was embedded in a
web page. It indicates what method the UA should use. Very useful for things
like:

<html>
You can send me an <a
href="sip:[email-masked];method=message">Instant Message</a>.
</html>

I don't see much use in the method parameter within a SIP request itself.

The SIP for presence documents talk about a "methods" parameter (NOTE the
plural), but this is not a URL parameter, its a Contact header parameter,
defined in the caller preferences specification.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: James Undery <[email-masked]>
Date: Tue, 09 Jan 2001 09:02:45 +0000

> defined in the caller preferences specification.

Although I've noticed most of the examples in draft-rosenberg-impp-presence-00
are wrong and use "method", this lead to a number of the sip impp
implementations we saw at the bakeoff copying this.

James Undery