Subject: RE: [[email-masked]: Re: [SIP] draft-calhoun-sip-aaa-req]

From: "Gross, Gerhard" <[email-masked]>
Date: Wed, 3 Jan 2001 14:21:22 -0800

> -----Original Message-----
> From: Henning G. Schulzrinne [mailto:[email-masked]]
> Sent: Wednesday, January 03, 2001 1:04 PM
> To: Gross, Gerhard
> Cc: [email-masked]
> Subject: Re: [[email-masked]: Re: [SIP] 
> draft-calhoun-sip-aaa-req]
> 
> 
> "Gross, Gerhard" wrote:
> > 
> > >Instead of re-casting the SIP request into another format and
> > >translating status codes between protocols, why not just 
> proxy the SIP
> > >request to whatever database/server decides whether the person has
> > >subscribed to this service?
> > 
> > One reason is for simplicity and to potentially
> > increase processing speed. This is done by taking
> > advantage of the SIP parser already built into
> > the SIP proxy. If the whole SIP message were
> > just forwarded as is to the PDP (policy decision
> > point), the PDP would need some sort of SIP
> > parser (thus adding complexity/redundancy to
> > the chain).
> 
> "Henning, Schulzrinne" wrote:
> This assumes that SIP parsing is a major delay or processing expense.
> Experience seems to indicate that it is not, compared to the typical
> database lookups, crypto and other operations that need to take place.

Understood. A different reason to re-format the SIP
message at the SIP proxy before sending it off to
a AAA/policy server is because different SIP methods
may need to be forwarded, in addition to an INVITE.
Examples are 2xx responses and ACK during call
setup and REGISTER otherwise. 2xx and ACK messages
may contain session information (due to negotiation)
that is relevant to local policy decision making.

In the re-format case, the information is packaged
in the same structure in all cases and sent to the
PDP. Simple for the PDP to parse the same structure
each time. If the raw SIP message were forwarded the
PDP would need code to parse each message (which
may be a negligible time delay but adds complexity
to the PDP).

In the end, it doesn't really matter to me whether
we re-format the SIP messages or just forward them.
Just looking to consider all angles before a choice
is made :>)

> 
> > 
> > On the other hand, while the SIP proxy parses the
> > SIP message, it may extract certain information
> > from it and put it in a simpler and smaller structure
> > to be passed on to the PDP (AAA/policy server). Such
> > a structure/protocol has been defined in
> > http://search.ietf.org/internet-drafts/draft-gross-cops-sip-00.txt.
> > 
> 
> -- 
> Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Wed, 03 Jan 2001 17:26:13 -0500

> that is relevant to local policy decision making.

Obviously, 200s (and any other response) will traverse the same proxy
chain that the requests were sent through. The parsing difference 
between requests and responses is roughly ten lines of code, if that.
(With use of scanf, it's probably one line...)