Subject: [SIP] Canceling BYE

From: "Deepak Mohan" <[email-masked]>
Date: 4 Jan 2001 12:04:11 -0000

The draft-ietf-sip-rfc2543bis-02 does not say anything about a CANCEL being used to cancel a BYE. Should this be allowed? I don't think very many protocols allow a 'Release' message to be canceled.

Thanks,
Deepak

_____________________________________________________
Chat with your friends as soon as they come online. Get Rediff Bol at
http://bol.rediff.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Sean Olson <[email-masked]>
Date: Thu, 04 Jan 2001 10:08:53 -0600

Yes, this should be allowed. The more important question
is what it means. Since CANCEL is just a suggestion, I
would not count on it having *any* effect on the outcome
of the BYE transaction. ie. it may be effectively ignored.

/sean

---

From: Vijay Gurbani <[email-masked]>
Date: Thu, 04 Jan 2001 12:34:14 -0600

Deepak Mohan wrote:
> 
> The draft-ietf-sip-rfc2543bis-02 does not say anything about a CANCEL 
> being used to cancel a BYE. Should this be allowed? I don't think very 
> many protocols allow a 'Release' message to be canceled.

While CANCEL can be used to cancel a pending request (including BYE or
OPTIONS, or even REGISTER), in majority of cases, it is used in conjunction
with an INVITE request.  

If a UAS gets a CANCEL to a non-INVITE request before it has generated a 
final response, the request can effectively be canceled (although, as you
point out, what is the result of CANCEL'ing a BYE -- does that mean that
the session should NOT be torn down?).  If a final response has already been
generated by a UAS and a CANCEL received after that, the CANCEL is basically
a no-op (although the UAS has to 200 OK it).

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184