Subject: Re: Re: [SIP] Regarding multiple headers

From: "Deepak Mohan" <[email-masked]>
Date: 10 Jan 2001 07:33:09 -0000

Hi,
 For the original poster's question

> In the rfc *message-header is given.
> Does it mean we can allow same header
> multiple times ?. i want some clarification on this.

My reply is correct.
You can have multiple "Accept"s in an INVITE to inform the callee what format the "Content-type" of it's response SHOULD be in. Please note that what is being discussed here is "*message-header", and not "message-body". However, your post seems to answer the  "Regarding Multiple Content Types" thread.

Thanks,
Deepak 
------------- Original Message --------------
Christer Holmberg <[email-masked]> wrote:
To:"[email-masked]" <[email-masked]>
From:Christer Holmberg <[email-masked]>
Date:Wed, 10 Jan 2001 09:02:00 +0200
CC:Deepak Mohan <[email-masked]>,
"[email-masked]" <[email-masked]>
Subject:Re: [SIP] Regarding multiple headers

Hi,

>Yes, You can have the same header more than once.
>You can have
>QT:
> 
>Accept: application/sdp;level=1, application/x-private, text/html
> 
>UQT:
> 
>or you can have it as
>QT:
> 
>Accept: application/sdp;level=1
>Accept: application/x-private
>Accept: text/html
> 
>UQT:
> 
>I think this is mentioned somewhere in the rfc or draft.
>It also might be required to keep in mind that some other header might >come between two "Accept"s. Comments, anyone?

Actually, what you say is not correct.

The Accept header is used only to indicate which kind of message bodies
you accept, and (like the RFC says) can be used in 415 (Unsupported
Media Type) responses.

When you want to actually include multiple message bodies in your
message you can use Content-Type: multipart/mixed to indicate that, and
then use MIME, in which you then have a separate Content-Type header for
each message body you send. 

Regards,

Christer Holmberg
Ericsson Finland

>Deepak
> 
> ------------- Original Message --------------
> laks hmi <[email-masked]> wrote:
> To:SIP discussion list <[email-masked]>
> From:laks hmi <[email-masked]>
> Date:Tue, 9 Jan 2001 21:30:50 -0800 (PST)
> Subject:[SIP] Regarding multiple headers
> 
> hi,
> 
> In the rfc *message-header is given.
> Does it mean we can allow same header
> multiple times ?. i want some clarification on this.
> 
> lakshmi

_____________________________________________________
Chat with your friends as soon as they come online. Get Rediff Bol at
http://bol.rediff.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 10 Jan 2001 09:44:46 +0200

Hi,

>You can have multiple "Accept"s in an INVITE to inform the callee what format the "Content-type" of it's >response SHOULD be in. Please note that what is being discussed here is "*message-header", and not >"message-body". However, your post seems to answer the  "Regarding Multiple Content Types" thread.

True. I guess I replied to the wrong mail. Sorry, my misstake :)

Christer Holmberg
Ericsson Finland