Subject: [SIP] SIP grammar doubt.

From: "Vijeth D" <[email-masked]>
Date: 4 Jan 2001 12:32:52 -0000

Hi,

 I am referrring to draft-ietf-sip-rfc2543bis-01.abnf for the sip message grammar. The authorization and the WWW Auth. header fields have been specified as using PGP based encryption.But RFC says that SIP can support both basic and digest schemes of HTTP. 
Is it still as the RFC specifies or is it that authorization and www auth headers can have only PGP based encryption.

regards. 

_____________________________________________________
Chat with your friends as soon as they come online. Get Rediff Bol at
http://bol.rediff.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 9 Jan 2001 01:59:26 -0500

> -----Original Message-----
> From: Vijeth D [mailto:[email-masked]]
> Sent: Thursday, January 04, 2001 7:33 AM
> To: [email-masked]
> Subject: [SIP] SIP grammar doubt.
> 
> 
> Hi,
> 
>  I am referrring to draft-ietf-sip-rfc2543bis-01.abnf for the 
> sip message grammar. The authorization and the WWW Auth. 
> header fields have been specified as using PGP based 
> encryption.But RFC says that SIP can support both basic and 
> digest schemes of HTTP. 

The format of the headers is actually specified in rfc2616, which says:

Authorization  = "Authorization" ":" credentials

credentials is defined in rfc2617 for the case of Basic and Digest:

credentials      = "Digest" digest-response
digest-response  = 1#( username | realm | nonce | digest-uri
                       | response | [ algorithm ] | [cnonce] |
                       [opaque] | [message-qop] |
                           [nonce-count]  | [auth-param] )

credentials = "Basic" basic-credentials

and then the PGP version is defined in rfc2543bis:

Authorization = "Authorization" ":" "pgp" # pgp-response
pgp-response = realm | pgp-version | pgp-signature
               | signed-by | nonce

A generalization is that the structure of the header is:

Authorization = "Authorization" ":" mechanisms 1#mech-params
mechanisms = "pgp" | "Basic" | "Digest" | token
mech-params = digest-response | basic-response | pgp-response

Note, however, that we are going to deprecate PGP stuff. It will be
superceded by S/MIME and PGP MIME.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: [email-masked]
Date: Tue, 9 Jan 2001 15:06:24 +0200

> superceded by S/MIME and PGP MIME.

A question concerning this, is there any work ongoing in this field? Any
drafts about S/MIME and MIME PGP usage in SIP on the way? 

Cheers,
Aki Niemi