Subject: [SIP] A foolish idea

From: james jack <[email-masked]>
Date: Thu, 4 Jan 2001 07:33:04 -0800 (PST)

Dear All:
  I have foolish idea on Via, for via, On page 57 of
RFC2543bis02, which describes as the following"
" Each subsequent proxy server that sends the request
onwards MUST add its own additional Via field before
any existing Via fields. " It means whether the proxy
to be stateful or stateless must insert via
information in the Via header.
    In my opinion, I think for stateless proxy, there
is no need to insert it's via information in the Via
header. thus can save the time for parsing the SIP
message. Then stateless proxy received one request
message, there is no need for it to parse the whole
message, only parse the Request-Line,using DNS to 
get the next hop of the request?
    But this idea also has some disadvantage, for
example, if not parsed fully, how can the stateless
proxy check the location information?
   Thanks in advance, please give your idea?
                                    Yours: james

__________________________________________________
Do You Yahoo!?
Yahoo! Photos - Share your holiday photos online!
http://photos.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 9 Jan 2001 01:47:40 -0500

> -----Original Message-----
> From: james jack [mailto:[email-masked]]
> Sent: Thursday, January 04, 2001 10:33 AM
> To: [email-masked]
> Subject: [SIP] A foolish idea
> 
> 
> Dear All:

The primary problem is that this does not work.

The reason is that if a proxy doesn't insert a Via header, the
hop after the proxy will see a different source address than the
via header. It will thusly still send responses back to the
proxy anyway, but to the port in the via header. Of course, this 
port is whatever the hop PREVIOUS to that stateless proxy is listening
on. As such, this stateless proxy would need to listen on every single
UDP port. Not a very good thing.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com