Subject: [SIP] SIP digest authentication

From: PD20 Jennifer Xu <[email-masked]>
Date: Fri, 5 Jan 2001 05:39:24 +0800

I have a doubt regarding digest authentication processing in between SIP UA
and UA, how can one side UA let remote side UA know their username and
password information? I can not find the clear answer from the SIP spec.
Could some one please advice. Thanks! 

Jennifer Y. Xu

Winbond Electronic Corp. America
408-474-1674
[email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: David Daiker <[email-masked]>
Date: Fri, 5 Jan 2001 10:43:26 -0500 (EST)

the short answer is that username and response (not password)
are provided as parameters to the authorization header,
both parties have access to the user's password

the long (and best) answer is to read rfc.2617 - http digest access
authentication

hth,
david