Subject: [SIP] A question on ACK

From: h chang <[email-masked]>
Date: Sun, 28 Jan 2001 01:18:24 +0800 (CST)

Is a UAC required to retransmit ACK like other
requests when using an unreliable transport? I cannot
find the answer in the current SIP spec. I would
apprecite any clarification from the list. Thanks.

H. Chang

_________________________________________________________
Do You Yahoo!?
登記免費的 @yahoo.com.tw 電子郵件 @ http://mail.yahoo.com.tw
Get your free @yahoo.com.tw address at http://mail.yahoo.com.tw

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Kundan Singh <[email-masked]>
Date: Sat, 27 Jan 2001 13:52:08 -0500 (EST)

> requests when using an unreliable transport? I cannot

No.
ACK is used to stop retransmission of final response to INVITE.
UAC should send ACK when it receives this final response.
If it receives the retransmitted final response (i.e.,
if previous ACK was lost, UAS will retransmit 200),
it sends the ACK again.

> µn°O§K¶Oªº @yahoo.com.tw ¹q¤l¶l¥ó @ http://mail.yahoo.com.tw