Subject: RE: [SIP] "dedicated" proxy servers and user application custom SIP headers ?

From: "Gross, Gerhard" <[email-masked]>
Date: Mon, 8 Jan 2001 12:19:06 -0800

Daniel,

> ... would there be a "dedicated" stateful 
> user proxy servers "close" to the user agents, that would 
> take care of the 
> users preferences/policies/data, when he/she makes or 
> receives a "call"

Such a server (policy server) is described in 
http://search.ietf.org/internet-drafts/draft-gross-sipaq-00.txt

Gery

        XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
        X                                         X
        X    Gerhard W. Gross, Ph.D.              X
        X    Intel                                X
        X    2111 NE 25th Ave                     X
        X    Hillsboro, OR 97124-5961, USA        X
        X    Policy Architecture Group            X
        X      - Internet and Communication Lab   X
        X    phone:    (503) 264-6389             X
        X    fax:      (503) 264-3483             X
        X    email:    [email-masked]    X
        X                                         X
        XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

> -----Original Message-----
> From: Daniel Gross [mailto:[email-masked]]
> Sent: Monday, January 08, 2001 3:03 PM
> To: [email-masked]'
> Cc: [email-masked]'
> Subject: [SIP] "dedicated" proxy servers and user application 
> custom SIP
> headers ?
> 
> 
> Dear all,
> 
> I was referred to the SIP list and started to browse its archives. I 
> thought to also post some specific questions i have in mind 
> in the hope 
> someone might be able to give me some quick feedback on them ...
> 
> I have started read about SIP as an infrastructure for 
> flexible services 
> creation, and have stumbled over an interesting paper by 
> Jonathan Rosenberg 
> et. al., where the authors describes the use of a SIP CGI 
> interface for 
> programming services. An admin (a trusted user) can provide 
> SIP CGI scripts 
> to SIP proxy servers, which are executed in an event driven 
> manner when the 
> server processes SIP protocol commands (quite similar to http 
> processing). 
> You can find the paper at: 
> http://www.cs.columbia.edu/~jdrosen/papers/program_report.ps  .
> 
> The authors do not elaborate where the SIP proxy server that 
> processes the 
> SIP CGI scripts would reside in the "SIP network". I was 
> wondering, for 
> service applications that need user states over long periods of time 
> (beyond single SIP transactions -- perhaps over the lifetime 
> of the user 
> being a customer to an operator), would there be a 
> "dedicated" stateful 
> user proxy servers "close" to the user agents, that would 
> take care of the 
> users preferences/policies/data, when he/she makes or 
> receives a "call" (by 
> invoking those CGI scripts)? Would infrastructure operators 
> create such an 
> application proxy server for each one of their customers?
> 
> I was also wondering what is the current state of the art in 
> SIP, are such 
> SIP CGI scripts utilized, or are perhaps java servlets used or other 
> mechanisms (if at all)?
> 
> And perhaps if i can ask one more question. In the paper the authors 
> describe how custom header information can be passed back and 
> forth between 
> the SIP proxy server and the CGI script. Is it possible in 
> SIP to have 
> custom headers generated by the users agent application (and/or by a 
> "dedicated" user application proxy server), similar to user defined 
> "X-headers" in Mime, which could then be utilized by the CGI 
> scripts (or 
> other 3rd party call control "plug-in" functions)?  Or does 
> SIP not allow 
> for custom header tags to be specified to be delivered to 
> such 3rd call 
> control "plug-ins", unless they are official header extension 
> made by IETF 
> ( does SIP perhaps expects extensions to be placed in the 
> body as, for 
> example a mime message, thus making call control extension "media" 
> specific).
> 
> appreciating any response
> 
> Daniel
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henry Sinnreich <[email-masked]>
Date: Mon, 08 Jan 2001 15:10:02 -0600

Network policies are described as in the attached. Personal preferences
reside in the SIP server, see
http://search.ietf.org/internet-drafts/draft-ietf-sip-callerprefs-03.txt

Henry

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Gross, Gerhard
Sent: Monday, January 08, 2001 2:19 PM
To: [email-masked]'; [email-masked]'
Subject: RE: [SIP] "dedicated" proxy servers and user application custom
SIP headers ?

Daniel,

Gery