Subject: [SIP] Routing of SIP calls

From: Kevin McCandless <[email-masked]>
Date: Mon, 22 Jan 2001 12:25:16 -0800

Hello Everyone:

Can someone explain these two routing scenarios of SIP calls for me.  

1.  The first would be SIP1 calls SIP2 and neither party has moved.  In this
example, how does SIP1 find SIP2?   

2.  The second would be SIP1 calls SIP2 but SIP2 has moved.  In this
example, how does SIP1 find SIP2?   

Also, would the ENUM proposed databases be involved in the routing for
either scenario?

Sincerely,

Kevin McCandless
Senior Network Planner
Illuminet
913-814-6397
[email-masked]

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: [email-masked]
Date: Tue, 23 Jan 2001 18:45:59 +0200

Hi,

These things are handled by SIP servers, namely proxy, registrar and
redirect. Users simply REGISTER to a registrar, which makes a pointer from
your well known SIP URL, e.g., <sip:[email-masked]> to your
current location (IP-address). 

People call <sip:[email-masked]>, and the SIP proxy/redirect
server at illuminet.com takes care of the messages from there on.

For further info, see RFC2543 and http://www.cs.columbia.edu/~hgs/sip/, they
are good starting points.

Cheers,
Aki

> I would appreciate some help with my questions.  I am new to 
> IETF and SIP.
> Also, is there a document that spells out answers to my questions??
> 
> -----Original Message-----
> From: Kevin McCandless [mailto:[email-masked]]
> Sent: Monday, January 22, 2001 2:25 PM
> To: [email-masked]
> Subject: [SIP] Routing of SIP calls
> 
> 
> Hello Everyone:
>