Subject: [SIP] Some idea on Stateful SIP Proxy for Card Service

From: james jack <[email-masked]>
Date: Wed, 17 Jan 2001 03:09:26 -0800 (PST)

Dear All:
   My question is on card serice, how to realize
 the traditional card service with SIP. one difficulty
 is that if the money in the card is over, how to
 control the terminal to break the connection.
   For example, User B use the Terminal to dial
 terminal C through Proxy P, the charging is
controlled by the application layer in proxy P--which
can contact the database, then if the money in the
card is over, how to control to break the connection?
   In my opinion, the application layer of Proxy P
 can send a instruction, then the proxy send BYE to
both sides (B and C), then the connection can be
broken.
  But the proxy will never generate BYE request
according to RFC2543?  then how to solve such problem?
  Any suggestions and ideas are welcome!
  I am looking forwards to getting your reply as
 soon as possible!
     Best Regards!
                           Yours: james

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Jiri Kuthan <[email-masked]>
Date: Wed, 17 Jan 2001 12:55:38 +0100

I believe the question can be answered if details of the scenario
are known. 

For example, in the most simple PC-to-PC scenario w/o QoS you will send
your signaling request to callee's proxy. It seems unlikely to me that 
the proxy will charge any of call parties for call duration. I can rather
think of a web-like charging model in which the called party will be
charged flat-rate fees or compelled to receive advertising JPEGs attached
by the proxy to incoming invitations. If your SIP proxy provider insists
on per-minute charges, I'd recommend you subscribing to some other one.
Obviously, if there are no per-minute charges prepaid cards do not
make so much sense.

If you look at a PC-to-phone scenario, a gateway may want to project
PSTN per-minute charges into your bill. In such a case, implementing prepaid 
card services could be useful but is not very difficult. A gateway acts from 
SIP perspective as a UA and can easily terminate a call by sending BYE as any 
other UA would. No third-party call termination is needed. 

Jiri

-- 
Jiri Kuthan         http://www.fokus.gmd.de/usr/kuthan
		    tel:+49-30-34637271
Internet Telephony: http://www.fokus.gmd.de/glone/projects/ipt