Subject: [SIP] Contact in proxy non 407 response

From: "Pizzimenti, Joe" <[email-masked]>
Date: Fri, 12 Jan 2001 21:06:45 +0000

I recently ran across this question and after looking at the 02 bis, I would
like opinions regarding the following.

Should a 407 proxy response include the Contact header that was in the
original INVITE?

Should the proxy remove the contact header/headers that are in the original
INVITE? or may the proxy return the Contact header(s) found in the original
INVITE?

There have been discussions on the list with the title of why is contact
header mandatory invites and positiveresponses
but nothing about whether a proxy may or may not return the Contacts that
were sent in the request, in the 407 response.

- Joe Pizzimenti

---

From: "Jo Hornsby" <[email-masked]>
Date: Mon, 15 Jan 2001 09:12:26 -0000

Joe Pizzimenti wrote:
> I recently ran across this question and after looking at the 02
> bis, I would like opinions regarding the following. 
>
> Should a 407 proxy response include the Contact header that was
> in the original INVITE?

No.

> Should the proxy remove the contact header/headers that are in
> the original INVITE? or may the proxy return the Contact header(s)
> found in the original INVITE?

When a proxy generates a response, it should copy
{From, To, Call-ID, CSeq, Vias} from the corresponding request.
In general, that is all.

> There have been discussions on the list with the title of why
> is contact header mandatory invites and positiveresponses but
> nothing about whether a proxy may or may not return the Contacts
> that were sent in the request, in the 407 response.

The dodgy thing about doing this is that a Contact in a non-2xx
or non-3xx response is supposed to indicate somewhere where
further error information may be obtained.  For example, a
gateway might add something like:
    Contact: sip:[email-masked]
if the destination you were calling was busy.

HTH,

 - Jo.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip