Subject: Re: [SIP] REFER open issues

From: Rohan Mahy <[email-masked]>
Date: Mon, 08 Jan 2001 08:20:26 -0800

Hi,

I've heard some mixed interest at the IETF, and no objections to an interim
meeting to build some consensus around REFER open issues.  If you are intersted
in attending a meeting **and have posted to the list on one of these
REFER-related topics**, please indicate your availability and ability to travel
to some sample US destinations the last week of January/first week of February
by filling in the grid below.  an [x] means you are available, a [?] is a
maybe.

Of course all the meeting minutes, proposals, etc will get posted back to this
list.
Again, please do not spam the whole list with your availability.  I'll post a
summary.

        Please use a fixed-width font such as Courier.

        Available    San Jose   Dallas   New York  RaleighNC  Other

Jan 29    [ ]           [ ]      [ ]        [ ]       [ ]      [ ]
    30    [ ]           [ ]      [ ]        [ ]       [ ]      [ ]
    31    [ ]           [ ]      [ ]        [ ]       [ ]      [ ]
Feb  1    [ ]           [ ]      [ ]        [ ]       [ ]      [ ]
     2    [ ]           [ ]      [ ]        [ ]       [ ]      [ ]

     5    [ ]           [ ]      [ ]        [ ]       [ ]      [ ]
     6    [ ]           [ ]      [ ]        [ ]       [ ]      [ ]
     7    [ ]           [ ]      [ ]        [ ]       [ ]      [ ]
     8    [ ]           [ ]      [ ]        [ ]       [ ]      [ ]
     9    [ ]           [ ]      [ ]        [ ]       [ ]      [ ]

thanks,
-rohan

At 10:08 AM 12/15/00 , Rohan Mahy wrote:
>Hi,
>
>I'd like to summarize ALL the open issues that we have with REFER.  In the
>interest of coming to consensus, I'd like to invite interested implementers
>who have comments to meet in person before Minneapolis to close REFER open
>issues.  If folks think this is a good idea, we would certainly post the
>minutes and partial consensus back to the list for comments/changes.  As a
>strawman, I will suggest sometime in the last week of January.  A few
>plausible locations are: Dallas, New York, San Jose...  I volunteer to
>organize this if necessary.
>
>A short summary of the issues are below in no particular order:
>
>1) Retransmission problem:
>Robert Sparks already summarized this problem in his recent post.
>(a) REFER completes early, use explicit SUBSCRIBE for more info
>(b) REFER completes early and implicitly SUBSCRIBEs to more info
>(c) REFER completes after 16 secs and provides URL for SUBSCRIBE
>(d) send new REFER (new CSeq same call ID) after 32 seconds.
>
>2) Cancellation:
>If REFER returns a final response before a long INVITE transaction
>completes, how do you cancel that INVITE?  
>(a) send same REFER with ;method=CANCEL
>(b) send REFERCANCEL method
>
>3) Call-leg matching:
>Should you include call-id's in Refer-to URLs?  If not, what do you use for
>matching (Replaces or similar)?
>(a) match call-ids
>(b) use a Replaces header
>(c) use the mesh-id to setup mesh, then say BYE
>(d) use a new header
>
>4) If we choose Replaces or the like, how do we express that we want to
>*join* 2 legs via REFER?
>(a) Join header
>(b) Associate header
>(c) new method
>(d) something else
>
>5) If Refer-To contains parameters (method, transport), or potentially
>contradictory headers, what do we do with them?
>(a) allow all of them if authorized
>(b) allow a subset of methods/headers
>(c) send an error mesage
>(d) ignore the headers/parameters
>(e) ignore the whole message
>
>6) If we don't allow  ;method=BYE, how do we solve the problem described in
>the Music on 
>Hold flow?
>(a) method=BYE
>(b) ???
>
>7) How do we ask devices to do stuff for us?  [probably defer this issue]
>(a) REFER with parameters/headers
>(b) PHONECTL
>(c) some NEWMETHOD
>(d) Mbus
>(e) other
>
>Any other REFER open issues I missed?
>
>thanks,
>-rohan
>
>
>
>_______________________________________________
>SIP mailing list
>[email-masked]
>http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 9 Jan 2001 02:34:44 -0500

I don't want to have an interim meeting JUST on REFER. There are lots of
other open issues. We should seek to accomplish as much as possible in one
meeting, rather than having meetings for each issue. 
 
-Jonathan R.

Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen <http://www.cs.columbia.edu/~jdrosen>
PHONE: (973) 952-5000
http://www.dynamicsoft.com <http://www.dynamicsoft.com/> 

-----Original Message-----
From: Rohan Mahy [mailto:[email-masked]]
Sent: Monday, January 08, 2001 11:20 AM
To: [email-masked]
Subject: Re: [SIP] REFER open issues

Hi,

I've heard some mixed interest at the IETF, and no objections to an interim
meeting to build some consensus around REFER open issues.  If you are
intersted in attending a meeting **and have posted to the list on one of
these REFER-related topics**, please indicate your availability and ability
to travel to some sample US destinations the last week of January/first week
of February by filling in the grid below.  an [x] means you are available, a
[?] is a maybe.

Of course all the meeting minutes, proposals, etc will get posted back to
this list.
Again, please do not spam the whole list with your availability.  I'll post
a summary.

thanks,
-rohan

>Any other REFER open issues I missed?
<http://lists.bell-labs.com/mailman/listinfo/sip>

---

From: "Taylor, Tom-PT [NORSE:B901:EXCH]" <[email-masked]>
Date: Mon, 8 Jan 2001 13:09:51 -0500

I think part of the problem is to agree on the requirements the method is to
satisfy.  On one side of the debate, we've had pressure to restrict REFER
functionality to call transfer.  On the other is Jonathan's vision of a set
of general primitives.  Thus to add to Rohan's valuable roundup of issues
below, I add a list of alternative functional requirements.  Just to make it
clear that I have my own views on the matter, I list my preferred
alternative first in each case.
 
1) Relation to existing session
(a) REFER can be sent independently of any existing session.
(b) REFER can only be sent on an already-existing call-leg.
(c) ...
 
2) Method invoked by REFER
(a) Any method can be invoked, including BYE.
(b) REFER always asks the receiving party to send an INVITE.
(c) REFER-eligibility varies and must be documented on a per-method basis.
 
3) Notification of results
(a) REFER implicitly subscribes to SIP events at the receiver 
(b) The referror must issue an explicit SUBS to get notification
 
4) Join vs. Replace vs. New
(a) Explicit indication of intent in a header
(b) ...
Note that this is an issue for any receiver of an INVITE, not necessarily
tied to REFER.  As such, it is a matter for another thread, which I will
initiate.

-----Original Message-----
From: Rohan Mahy [mailto:[email-masked]]
Sent: Monday, January 08, 2001 11:20 AM
To: [email-masked]
Subject: Re: [SIP] REFER open issues

 [meeting proposal snipped]

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 9 Jan 2001 08:00:30 -0500

Depends on the players.
 
If the same folks need to solve multiple problems, then Jonathan is right.
If the cast
of characters changes, than single purpose meetings work.  I suspect the
same folks
need to be at most if not all these meetings, and thus we need to have a
(small)
set of problems to solve.
 
I don't want to spoil Rohan's initiative however.  So, let's 
        Respond to his request
        Make a (small) list of other topics to cover
 
Brian

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Tuesday, January 09, 2001 2:35 AM
To: 'Rohan Mahy'; [email-masked]
Subject: RE: [SIP] REFER open issues

-Jonathan R.

-----Original Message-----
From: Rohan Mahy [mailto:[email-masked]]
Sent: Monday, January 08, 2001 11:20 AM
To: [email-masked]
Subject: Re: [SIP] REFER open issues

Hi,

thanks,
-rohan

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 9 Jan 2001 13:30:03 -0500

Apologies for resending this, but yesterday's transmission still hasn't
shown up on the list.

---

From: Rohan Mahy <[email-masked]>
Date: Tue, 09 Jan 2001 14:20:20 -0500

Brian, Jonathan,

I think we need to focus on one topic at a time.  I'd be happy to spend a day
working on "Call Control" as a chartered topic area, but this topic needs a
whole day.  

By my count, of the nearly 100 email messages exchanged on topics related to
REFER, only 20 people were involved, most sent only a single reply for
clarification or consensus with a previous message, only 8 people sent more
than 3 messages on the topic:
(Robert Sparks, Venkatesh, Billy Biggs, Rick Dean, Henning, Jonathan R, Tom
Taylor, Sean Olson, and me)

I picked this item because it is a charter item with active list discussion not
reaching consensus, but a relatively small number needed for quorum.

Sure, some of the people will overlap, but you'd need a mostly different group
to discuss proxy issuues, or security, or telephony intergration issues.

thanks,
-rohan

At 08:00 AM 1/9/01 , Rosen, Brian wrote: 
> of characters changes, than single purpose meetings work.  I suspect the same
> folks
>> <http://www.cs.columbia.edu/~jdrosen>http://www.cs.columbia.edu/~jdrosen
>>   PHONE: (973) 952-5000 
>> <http://www.dynamicsoft.com/>http://www.dynamicsoft.com 
>>

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 9 Jan 2001 14:30:47 -0500

The problem here is travel.  If it's a whole day, then most people will suck
up 2 days.
If we have, say 3 or 4 topics, and we can organize well, we might get that
done in 2 long days, plus travel.
 
Brian

-----Original Message-----
From: Rohan Mahy [mailto:[email-masked]]
Sent: Tuesday, January 09, 2001 2:20 PM
To: Rosen, Brian; 'Jonathan Rosenberg'; [email-masked]
Subject: RE: [SIP] REFER open issues

Brian, Jonathan,

I think we need to focus on one topic at a time.  I'd be happy to spend a
day working on "Call Control" as a chartered topic area, but this topic
needs a whole day.  

I picked this item because it is a charter item with active list discussion
not reaching consensus, but a relatively small number needed for quorum.

Sure, some of the people will overlap, but you'd need a mostly different
group to discuss proxy issuues, or security, or telephony intergration
issues.

thanks,
-rohan

Depends on the players.

 
Brian 

-----Original Message----- 

From: Jonathan Rosenberg [ mailto:[email-masked]
<mailto:[email-masked]> ] 

-Jonathan R. 

-----Original Message----- 

From: Rohan Mahy [ mailto:[email-masked] <mailto:[email-masked]> ] 

Hi,

thanks, 

-rohan