Subject: [SIP] Status of draft-ietf-sip-session-timer-04.txt

From: "Dan Sahar" <[email-masked]>
Date: Sun, 7 Jan 2001 19:47:13 +0200

Hi,

I wanted to inquire as to the status of draft-ietf-sip-session-timer-04.txt.
How widely implemented is this extension to the protocol?
Also, if it is not imlemented, what are my other options to time out a
sesssion?
Regards,

Dan Sahar
Kagoor Networks Ltd.
Tel: 972-9-9565333 ext. 221
E-mail: mailto:[email-masked]
Web: www.kagoor.com
______________________________
"..he not busy being born is busy dying."
~Bob Dylan

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 8 Jan 2001 02:03:54 -0500

-----Original Message-----
>From: Dan Sahar [mailto:[email-masked]]
>Sent: Sunday, January 07, 2001 12:47 PM
>To: Sip
>Subject: [SIP] Status of draft-ietf-sip-session-timer-04.txt
>
>
>Hi,
>

It is complete, and awaiting a working group last call.

>How widely implemented is this extension to the protocol?

There are definitely implementations. Of all the sip extensions, I believe
this one to be amongst the most commonly implemented. I do not have concrete
data on what percentage of sip implementations also have session timer.

sesssion?

The other options for session timeout are active "pings", using something
like OPTIONS, or RTCP. OPTIONS can detect if a UA is alive or not, but
cannot determine whether a session is active. RTCP has periodic feedback
roughly every 5 seconds that can be used for liveness. However, not all SIP
sessions need be RTP. People also wanted a sip level session timer, rather
than relying on the underlying media.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip