Subject: [SIP] LWS grammar.....

From: "Rakesh Jain" <[email-masked]>
Date: Tue, 16 Jan 2001 04:40:23 -0000

Hi,
        I am having some doubt on LWS grammar,
        It is
            LWS = *(SP|HT) [CRLF] 1*(SP|HT)

        Can someone tell me what is the significance of putting
        [CRLF] here, It will allow to have CRLF in message header's
        field-value. It can come in between also.

        from RFC2543
           message-header  =  field-name ":" [ field-value ] CRLF
           field-name      =  token
           field-value     =  *( field-content | LWS )
           field-content   =  < the OCTETs  making up the field-value
                              and consisting of either *TEXT-UTF8
                              or combinations of token,
                              separators, and quoted-string>

        And whenever CRLF is coming ( not the final one ), it will give
        impression of ending of the header field value, which is not
        actually. Is it OK or I am missing something. Or special care
        should be taken to avoid CRLF in between field-value.

        I am sorry, if same question had been asked previously.
        thanks....

  rakesh

_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: [email-masked]
Date: Tue, 16 Jan 2001 10:51:10 +0530

The CRLF is for line folding - that is , a header can be broken up into
multiple lines as long as the continuation
line starts with one or more space/tab

example:

From: [email-masked]; foo=1; shoo=2

AND

From:
     [email-masked];
          foo=1;
     shoo=2

are both allowed

Regds
Arjun

--
Arjun Roychowdhury @ Hughes Software Systems

"Rakesh Jain" <[email-masked]> on 01/16/2001 10:10:23 AM

To:   [email-masked]
cc:

Subject:  [SIP] LWS grammar.....

   Hi,

        from RFC2543

  rakesh