Subject: RE: [SIP] Tel-Url query

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 16 Jan 2001 01:17:23 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, January 11, 2001 7:29 AM
> To: [email-masked]
> Subject: [SIP] Tel-Url query
> 
> 
> 
> 
> Hello,
> 
> I have a query regarding the usage of "Tel" URLs specified in
> the RFC 2806 as a part of the Addr-spec within the SIP Headers.
> The ABNF for the Tel URL includes
> 
> token-char = (%x21 / %x23-27 / %x2A-2B / %x2D-2E / %x30-39
>                 / %x41-5A / %x5E-7A / %x7C / %x7E)
>                *(%x21-3A / %x3C-7E)
> 
> which is a part of "private-prefix". These characters include
> "<", ">" among others.

Thats probably a mistake.

> 
> Do these particular characters need to be escaped if the URL
> appears as a part of the Addr-spec within a SIP header, like 'From'?

THey need to be escaped, period. The "<" and ">" are not valid URI
characters according to rfc2396. This specification defines syntax for all
URIs, including SIP and tel.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Tue, 16 Jan 2001 09:42:43 -0500

> Thats probably a mistake.

As has been observed in the past, the RFC 2806 ABNF is a royal mess that
differs from all other ABNFs for URLs (not just syntactically, but
conceptually). It is hoped that the author will fix this in the next
version.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs