Subject: [SIP] Consultation on Multicast

From: james jack <[email-masked]>
Date: Fri, 5 Jan 2001 04:52:20 -0800 (PST)

Dear All:
   I have one question to consult, On page 57 of
RFC2543bis02(PDF format),In section "6.46.1 Requests",

the description on Via, which describes
"A client that sends a request to a multicast address
MUST add the "maddr" parameter to its Via header
field, and SHOULD add the "ttl" parameter. (In that
case, the maddr parameter SHOULD contain the
destination multicast address, although under
exceptional circumstances it MAY contain a unicast
address.)"

  But on page 81, in section "12.3.1 Proxying
Requests", which describes
"A Proxy server MUSTNOT forward a request to a
multicast group which already appears in any of the
Via headers."
   Then I have one doubt, if a client send a request
to a multicast group, if this request is passed
through one proxy, then this proxy will not forward
this request according to the previous description!
   Is that right?
   Could anyone give me suggestion?
   I am looking foreard to getting your reply as soon 
as possible!
    Best regards!
                  yours: james

It means the proxy will never forward multicast
request.

__________________________________________________
Do You Yahoo!?
Yahoo! Photos - Share your holiday photos online!
http://photos.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 8 Jan 2001 02:27:59 -0500

> -----Original Message-----
> From: james jack [mailto:[email-masked]]
> Sent: Friday, January 05, 2001 7:52 AM
> To: [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Consultation on Multicast
> 
> 
> Dear All:

No, it is not. This is not what the text says. The text says that
a proxy does not forward a request TO A MULTICAST GROUP that already
appears in the via header. This means that every time a request is
forwarded to a multicast group, it must be a different one than previously
used.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com