Subject: [SIP] Consultation on Stateless Proxy

From: james jack <[email-masked]>
Date: Mon, 29 Jan 2001 09:01:45 -0800 (PST)

Dear All:
   I have one question to consult, since
the stateless proxy does not produce the 
response for the coming reques,then for
example, if the coming SIP request without
essential information such as from, to; the
stateless proxy will not generate any response.
Then what the function for stateless proxy?
then is it necessary to add via information in
the Via headers in SIP request message? 
   Could any one give me some suggestion?
   Best regards!
                       Yours: james

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - Buy the things you want at great prices. 
http://auctions.yahoo.com/

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Neil Deason <[email-masked]>
Date: Mon, 29 Jan 2001 17:15:37 +0000

Please address future consultations to the sip implementors list
-
[email-masked]. 

>    Could any one give me some suggestion?

Messages that don't contain crucial info such as To, From,
Call-ID, Via can expect to be silently discarded by any 
server stateless or otherwise. 

Remember the terms stateless/stateful/proxy/redirect/
registrar are used to describe logical entities. Thus a 
single network server may choose to be stateful or 
stateless on a per transaction basis. Typically being 
stateless is seen as a way to aid performance.

Cheers,
Neil
-- 
Ubiquity Software Corporation, UK        http://www.ubiquity.net