Subject: RE: [SIP] Announcements in SIP

From: "Venkatesh Venkataramanan" <[email-masked]>
Date: Wed, 24 Jan 2001 11:59:39 -0800

Yes. I had suggested the usage of an alternate header instead of using
contact (something similar to Alert-Info header, say CallProgress-Info, or
rename Alert-Info to a more generic name like, CallProgress-Info) which can
indicate to the announcement server the announcement id to play.... Haven't
heard any response on that one :-)?

On seeing a 404 response, an end UA *may* choose to use the information in
the CallProgress-Info header if it is not capable of providing local
annoucements, otherwise, it could render to the user the information
provided in the CallProgress-Info header. How does this look?

-----Original Message-----
From: Michael Thomas [mailto:[email-masked]]
Sent: Wednesday, January 24, 2001 11:40 AM
To: Bryan Byerly
Cc: Venkatesh Venkataramanan; [email-masked]
Subject: Re: [SIP] Announcements in SIP

Bryan Byerly writes:
 > The approach using a Contact in the response would also work for smart
 > UAs.
 > 
 > A              Po             Pt           AnnServer
 > |              |              |                |
 > |--INV Bob@Po->|              |                |
 > |              |--INV Bob@Pt->|                |
 > |              |              |                |
 > |              |<-404---------|                |
 > |              |              |                |
 > |<-404---------|              |                |
 > |  Contact: AnnServer         |                |
 > |              |              |                |
 > |--INV AnnServer------------------------------>|
 > |              |              |                |
 > |<-183/200-------------------------------------|
 > |              |              |                |
 > |<="The URL you have dialed B...O...B at Pt is=|
 > |   unrouteable, please check the URL or       |
 > |   contact your system admin for assistance"  |
 > 
 > 
 > 
 > However,
 > a) this doesn't provide an announcements solution for dumb UAs

   How so? It's the announcement server that has the
   smarts, right?

 > b) I doubt a smart UA would even need an AnnServer contact.  Since he's
 > smart, he would either 1) be able to generate annoucements locally or
 > 2) know the FQDN/IP address of the AnnServer directly.  I'm not aware
 > that smart UAs need any proxy assist. (Although, they would need to be
 > able to turn off proxy assist).

   It's not like the smart UA would need to be
   *forced* to use the contact header, right?
   If it thinks it can put on a better side show
   than the announcement server, nothing's
   stopping it, right?

 > 
 > In the proposal above, how would the Announcement server know to say
 > "B...O...B"?

   contact: sip:[email-masked]?luser=bob

   or some such?

 > One solution would be for the Annoucement server to examine the
 > Diversion header (draft-levy-sip-diversion-01.txt).  The Diversion
 > header provides the necessary supplemental information to the
 > announcement server.  Since the Diversion header is already needed for
 > voicemail servers, I think it is a good candidate for usage here.

   The problem with the diversion header is that
   my UA never got a chance to, oh say, have my
   UA brew me another cup of coffee while I'm
   camping on Bob to become available. Instead,
   the *proxy* decided that for me, and as a 
   result I get no coffee to pacify me.

	    Mike

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: "Eric Burger" <[email-masked]>
Date: Wed, 24 Jan 2001 19:43:47 -0500

If it can be done (getting around the 4xx response issue), it look great.
Rather than recreating the bugs (I mean features :-) of the PSTN [sending
aural signaling in-band as "early media"], we provide useful solutions to
end users [providing informative responses, using local resources when
possible or network resources if necessary].

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Venkatesh
> Venkataramanan
> Sent: Wednesday, January 24, 2001 3:00 PM
> To: Michael Thomas; Bryan Byerly
> Subject: RE: [SIP] Announcements in SIP
>
>
[snip]