Subject: [SIP] Regarding Multiple Content Types

From: "Mayank Sharma" <[email-masked]>
Date: Wed, 10 Jan 2001 11:33:24 +0530

Hi List,
	I have a question about sending a Message body with a
Request/Response. Can I send a Message body with more than one Content Type..
for eg. with the Invite request I might want to send some text/pic along with
the SDP parameters. So I want to send a message body which will have two
differnet content type, application/sdp and text/html for eg. Maybe we can
have a proper demarkation in the message body which will separate the two
different Message types and have two Content-Type header's indicating the
different Content type.

	Please excuse me if this question does not fall in the discussions of
this mailing list.

With Regards,
Mayank Sharma

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Petri K. Koskelainen" <[email-masked]>
Date: Thu, 11 Jan 2001 14:06:16 -0500 (EST)

Hi,

> I have a question about sending a Message body 
> with a Request/Response. Can I send a Message body 
> with more than one Content Type..
> for eg. with the Invite request I might want to 
> send some text/pic along with the SDP parameters. 
> 

Yes.
Use MIME multipart as the content type.
(which may include several content types).

This is a standard feature and supported
probably by all decent SIP implementations.

--
Petri

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 16 Jan 2001 00:59:17 -0500

> -----Original Message-----
> From: Mayank Sharma [mailto:[email-masked]]
> Sent: Wednesday, January 10, 2001 1:03 AM
> To: SIP discussion list
> Subject: [SIP] Regarding Multiple Content Types
> 
> 
> Hi List,

Yes. You would use MIME multipart. See rfc2045.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com