Subject: RE: [SIP] Timestamp header

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 16 Jan 2001 01:36:53 -0500

The spec is not clear on this, saying simply that it should be echoed. I
would imagine placing it in all responses, provisional and final, makes the
most sense.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Grant McSheffrey [mailto:[email-masked]]
> Sent: Thursday, January 11, 2001 11:42 AM
> To: Sip List
> Subject: [SIP] Timestamp header
> 
> 
> If a client sends an INVITE request containing a Timestamp header,
> should the Timestamp be echoed back in both provisional responses and
> the final response, or should it only appear in the first provisional
> response that is sent?
> 
> It seems to make sense that since it used to calculate timing, it is
> only needed in the first response but I have a developer who seems to
> think differently.
> 
> Any help greatly appreciated.
> 
> Grant McSheffrey
> Test Engineer
> EmpowerTel Networks
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Tue, 16 Jan 2001 10:25:16 -0500

> would imagine placing it in all responses, provisional and final, makes the

Note that because of the different origins, the delay for the 100 may
differ from the other 1xx and the final response.
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs