Subject: [SIP] Decoding the SIP URL

From: Baniel Uri-CUB001 <[email-masked]>
Date: Sun, 28 Jan 2001 18:17:33 -0600

Say a UAC gets the following SIP URL from its user in the 'To' and 'request
URI' fields: "[email-masked]".
How does the UAC 'guess' if 'ieee.org' refer to a specific host or a domain?
Looks like according Bis02 para 1.4.2, the UAC tries to get DNS SRV record
first, and then A record if the former query has failed. Is that true? If
yes, looks like according the DNS RFC, one may issue a DNS query w/ multiple
types (e.g. _sip, a, aaaa) and act based on the response.
Was that the intention of Bis?

============================================
[email-masked], 
Tel: (847) 632 4616; Fax: (847) 632 3963; 
============================================

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Baniel Uri-CUB001 <[email-masked]>
Date: Tue, 30 Jan 2001 22:30:58 -0600

So I guess my question is either just too dumb or too boring :(
Still, is there any good soul on the list, who has a moment to go over the
question and respond.

Thanks!

Uri

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 31 Jan 2001 10:27:39 -0500

I think you clearly reflect the intent of the relevant section (1.4.2) in
the bis document.  Note the reservation that you don't try for SRV if the
port in the Request-URI differs from 5060.

> From: Baniel Uri-CUB001 [mailto:[email-masked]]
> Sent: Tuesday, January 30, 2001 11:31 PM
> To: Baniel Uri-CUB001; [email-masked]
> Cc: Dyer William-QA1394; Miller Trent-QA1400
> Subject: RE: [SIP] Decoding the SIP URL
> 
>

---

From: Igor Slepchin <[email-masked]>
Date: Wed, 31 Jan 2001 11:26:33 -0500

> How does the UAC 'guess' if 'ieee.org' refer to a specific 

What's the difference? The behavior is precisely the same and you quote the
appropriate paragraph from the bis.

---
Igor Slepchin