Subject: [SIP] adding a display name in From

From: "Connie Blanchard" <[email-masked]>
Date: Thu, 25 Jan 2001 13:37:26 -0500

According to the SIP FAQ, Caller ID is accomplished by using the "display
name" portion of the From header. But a proxy is not supposed to modify the
From field. Does this mean that Caller ID will only be available if
initiated from the originator of the call?

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: "Dean Willis" <[email-masked]>
Date: Thu, 25 Jan 2001 17:33:02 -0600

Yep. Kindof like ISDN.

Some of the DCS authors proposed adding an authenticated-caller header at
the proxy, using public-key mechanisms to provide for the integrity of the
header through later hops.

--
Dean

---

From: Chris Wayman Purvis <[email-masked]>
Date: Tue, 30 Jan 2001 11:01:22 +0000

Dean,

Or, to put it another way, "kindof" NOT like ISDN (where caller ID and display
elements are often munged by networks).

Regards,
Chris

-- 
Dr Chris Purvis -- Development Manager
ISDN Communications Ltd, The Stable Block, Ronans, Chavey Down Road
Winkfield Row, Berkshire.  RG42 6LY  ENGLAND
Phone: +44 1344 899 007
Fax:   +44 1344 899 001