Subject: RE: [[email-masked]: Re: [SIP] draft-calhoun-sip-aaa-req]

From: Matt Holdrege <[email-masked]>
Date: Thu, 04 Jan 2001 14:54:27 -0800

At 12:43 PM 1/4/2001, Gross, Gerhard wrote:
>Furthermore, concerning
>
> > As for the question why XML/HTTP:
>
>(paraphrasing one of my colleagues):
>
>A major drawback of AVP is that it uses
>a binary (non-textual) representation
>requiring programmers and the appropriate
>programming tools to use and understand it.

Just a nit of mine, but I really hate it when we have to sacrifice quality 
because we're worried about programmers who are inexperienced. Let them go 
to school and learn binary and let the end-users have what they need. There 
are plenty of coders who can handle binary just fine.

I'm not against XML, rather I'm in favor of it. But let's not use the above 
as an excuse.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henry Sinnreich <[email-masked]>
Date: Fri, 05 Jan 2001 12:03:55 -0600

>we're worried about programmers who are inexperienced

top talent is hard to get and adds to cost...

> Let them go 
> to school and learn binary 

Am not sure this is a good idea. Prefer non-binary coded.

Henry

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Matt Holdrege
> Sent: Thursday, January 04, 2001 4:54 PM
> To: Gross, Gerhard; SIP List
> Subject: RE: [[email-masked]: Re: [SIP] draft-calhoun-sip-aaa-req]
> 
>