Subject: [SIP] Some idea on Stateful SIP Proxy

From: james jack <[email-masked]>
Date: Mon, 15 Jan 2001 20:31:01 -0800 (PST)

Dear All:
   I have one foolish idea on stateful SIP Proxy.
   For some service on SIP, for example, card service,
if card A has account of 40$,assumed that one minute
costs 1$, then the time for this card user to
communicate is only 40 minutes.
   Supposed a card user use this card for
communication, when 40 minutes passed, the application

layer of Proxy should send BYE request to caller 
and callee. Otherwise, how can the system stop
communication. Then under this situatuion, I think the
stateful proxy should send out BYE request. That is, I
think on RFC 2543, it should add that the stateful
proxy can send BYE.
    Any suggestion and idea are welcome!
    Best Regards!
                        Yours:james!

   This is my idea, 

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Billy Biggs <[email-masked]>
Date: Mon, 15 Jan 2001 23:42:05 -0500

james jack ([email-masked]):

> I have one foolish idea on stateful SIP Proxy.  For some service on
> SIP, for example, card service, if card A has account of 40$,assumed
> that one minute costs 1$, then the time for this card user to
> communicate is only 40 minutes.  Supposed a card user use this card
> for communication, when 40 minutes passed, the application layer of
> Proxy should send BYE request to caller and callee. Otherwise, how can
> the system stop communication. Then under this situatuion, I think the
> stateful proxy should send out BYE request. That is, I think on RFC
> 2543, it should add that the stateful proxy can send BYE.

  A proxy cannot send a BYE.

  To perform this behavior you must use a back-to-back UA.

-- 
Billy Biggs                     [email-masked]
http://www.billybiggs.com/      [email-masked]