Subject: FW: [SIP] Routing of SIP calls

From: Kevin McCandless <[email-masked]>
Date: Tue, 23 Jan 2001 08:29:39 -0800

I would appreciate some help with my questions.  I am new to IETF and SIP.
Also, is there a document that spells out answers to my questions??

-----Original Message-----
From: Kevin McCandless [mailto:[email-masked]]
Sent: Monday, January 22, 2001 2:25 PM
To: [email-masked]
Subject: [SIP] Routing of SIP calls

Hello Everyone:

Can someone explain these two routing scenarios of SIP calls for me.  

1.  The first would be SIP1 calls SIP2 and neither party has moved.  In this
example, how does SIP1 find SIP2?   

2.  The second would be SIP1 calls SIP2 but SIP2 has moved.  In this
example, how does SIP1 find SIP2?   

Also, would the ENUM proposed databases be involved in the routing for
either scenario?

Sincerely,

Kevin McCandless
Senior Network Planner
Illuminet
913-814-6397
[email-masked]

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Vijay Gurbani <[email-masked]>
Date: Tue, 23 Jan 2001 12:23:14 -0600

Kevin McCandless wrote:
[...]
> 1.  The first would be SIP1 calls SIP2 and neither party has moved.  In 
> this example, how does SIP1 find SIP2?

Depends on many factors; but for the most part DNS lookups.  See the steps
in the bis draft, Section 1.4.2.
 
> example, how does SIP1 find SIP2?

Again, depends on many factors.  Easiest explanation is that when SIP2 
moved, he/she re-registered the new location with the Registrar and SIP1
queried the Registrar (through a SIP Proxy/Redirect server) to find out the
new location.

> Also, would the ENUM proposed databases be involved in the routing for

Could be; so could SIP CGI, CPL, TRIP, ...

Hope that helps.  If you have follow-up questions, you may want to post them 
to the SIP IMPLEMENTORS list ([email-masked])

Regards,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184