Subject: [SIP] Tag in From Field

From: "Divya Nath" <[email-masked]>
Date: 17 Jan 2001 08:54:01 -0000

As specified in section 6.26 of draft-ietf-sip-rfc2543bis-0.2 
" A tag in From field must be present when it is possible that the two instances of a user sharing a SIP address can make call invitations with the same Call-Id."
What I am unable to understand is when can the Call-Id be same since as per my understanding the Call-Id is globally unique within a single boot cycle .
Can anybody please clearify the same .
Thanx & Regards
Divya

_____________________________________________________
Chat with your friends as soon as they come online. Get Rediff Bol at
http://bol.rediff.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Vijay Gurbani <[email-masked]>
Date: Wed, 17 Jan 2001 15:02:33 -0600

Divya Nath wrote:
> " A tag in From field must be present when it is possible that the two 
>instances of a user sharing a SIP address can make call invitations with 
> the same Call-Id."

Divya:

One way for a single Call-ID to have two instances of a user sharing a SIP
address is when a proxy forks an INVITE request.  Each of the forked 
requests will have the same From (including tags) as that of the original.

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184