Subject: [SIP] Some consultation on Via

From: james jack <[email-masked]>
Date: Thu, 4 Jan 2001 07:45:36 -0800 (PST)

Dear All:
   I have one question to consult.
   Supposed a stateless proxy P received the following

response ( assume the domain of proxy P is
pp.pcom.com,
the listening port is 5700)
 "  SIP/2.0 200 OK
   Via: SIP/2.0/UDP ss1.wcom.com:5060;branch=2d4790.1
   Via: SIP/2.0/UDP
fwp1.wcom.com:5060;branch=9471385739578.1
   Via: SIP/2.0/UDP here.com:5060
   Record-Route:
<sip:[email-masked];maddr=ss1.wcom.com>,
    <sip:[email-masked];maddr=fwp1.wcom.com>
   From: BigGuy <sip:[email-masked]>
   To: LittleGuy <sip:[email-masked]>;tag=314159
   Call-ID: [email-masked]
   CSeq: 1 INVITE
   Contact: LittleGuy <sip:[email-masked]>
   Content-Type: application/sdp
   Content-Length: 147

   v=0
   o=UserB 2890844527 2890844527 IN IP4 there.com
   s=Session SDP
   c=IN IP4 110.111.112.113
   t=0 0
   m=audio 3456 RTP/AVP 0
   a=rtpmap:0 PCMU/8000"
  The above message,where the Via information can't
match the information of that in Proxy P, Under this
situation, will P discard it or continue upstream it?

  What's more, if this is stateful proxy, and the
callleg can match the stored information, then 
what would happen?
  You are welcome to give your suggestion and 
opinion?
  I am looking foreard to getting your reponse as soon
as possible!
  Best Regards!
                yours: James

__________________________________________________
Do You Yahoo!?
Yahoo! Photos - Share your holiday photos online!
http://photos.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Hisham Khartabil" <[email-masked]>
Date: Fri, 5 Jan 2001 10:06:44 +0200

Section 6.46.3 "The first Via header field should indicate the proxy or
client processing this response. If it does not, discard the message"

Regards,
Hisham

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of james jack
Sent: Thursday, 4 January 2001 5:46 PM
To: [email-masked]
Subject: [SIP] Some consultation on Via

Dear All:

   v=0