Subject: [SIP] One consulation on multiple Contact headers in INVITE request

From: james jack <[email-masked]>
Date: Mon, 29 Jan 2001 04:39:00 -0800 (PST)

Dear All:
   I have one question to consult,
in INVITE request, if there is multiple 
Contact headers, should this be valid?
   In my opinion, I think it is valid,
but this may cause problem, that is ,
when the callee send BYE request for the 
established call between caller with multiple 
contacts, then the proxy will fork this request?
   Could anyone give me some suggestion?
   Best regards!
                   Yours:james

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - Buy the things you want at great prices. 
http://auctions.yahoo.com/

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: "Jo Hornsby" <[email-masked]>
Date: Mon, 29 Jan 2001 12:52:34 -0000

> Contact headers, should this be valid?

No.  There should be stricly one Contact header in an INVITE
request, and correspondingly, one Contact header in a 2xx to
an INVITE.

HTH,

 - Jo.