Subject: RE: [SIP] Early media replacement.

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Wed, 17 Jan 2001 14:38:25 -0800

Eric,

If a gateway, knows what's going on then it should send the appropriate
response code (ie, 180, 182, etc with SDP). If the gateway _doesn't_ know
what is going on then it can only send the 183 Session Progress response.
It's not really helpful if the gateway knows what is happening but sends a
response that doesn't convey any information (ie, 183 with SDP)! We don't
need another "I don't know what's going on" Response Code. ("184 Session
Confused"??<grin>)

Robert.

-- My opinions are my own and should not be taken as representing those of
Nuera Communications, Inc. -- 

		-----Original Message-----
		From:	Eric Burger [mailto:[email-masked]]
		Sent:	Thursday, January 18, 2001 9:07 AM
		To:	[email-masked]
		Subject:	RE: [SIP] Early media replacement.

		Why no middle ground:

		200 OK :  The call is established, everyone's happy
		183 :     Something's going on that I understand; here it
is...
		184 :     Something's going on that I don't understand;
here's the audio

		This gets around just about all of the issues raised:

		1. Either a call is established (200) or it's in the process
of being
		established (18x).  Established calls have the audio path
established.
		Calls not established (181, 182, 183, et. al.) don't have
the audio path
		established, except for the case of 184.

		2. If there's a billing policy that needs to police media
cut-through, it
		can trigger off the 184 message.

		3. It's forward compatible: as we get a truly digital GSTN,
the dependence
		on audio cut-through for human call progress analysis will
go away.  By not
		overloading 183, we make life much easier.

		> ----- Forwarded message from Rick Dean <[email-masked]>
-----
		> Date: Tue, 16 Jan 2001 10:58:05 -0600
		> From: Rick Dean <[email-masked]>
		> In-Reply-To:
		>
<[email-masked]
		> om>; from [email-masked] on Tue, Jan 16, 2001 at
01:34:26AM -0500
		>
		> On Tue, Jan 16, 2001 at 01:34:26AM -0500, Jonathan
Rosenberg wrote:
		> > > -----Original Message-----
		> > > From: Rick Dean [mailto:[email-masked]]
		> > >
		> > > On Tue, Jan 09, 2001 at 01:25:41AM -0500, Jonathan
Rosenberg wrote:
		[snip]
		> > > PSTN interoperability is paramount to me.
		> > > Unfortunately, my calls need to work better
		> > > than 99% of the time.
		[snip]
		> Sure, if a gateway knows the far end is busy, it should
send
		> a 486 busy -- no debate.  If the gateway has unknown
progress media
		> which might be busy-tone, ringback, or voice prompting;
sending 200
		> OK helps manage the audio channel.   Do you expect the
human to
		> hit a key on busy tone so his UA sends a CANCEL?  or
should
		> he just know to wait?
		>
		> I regret the 200 OK notion.  With audio, I argue a session
		> is established.  As a call originating UA, how to I
suspend or
		> redirect the early media if my INVITE won't complete?
		>
		> Sorry to be such as pain on this subject.
		[snip]
		> > >  Hopefully, the gateway builders will
		> > > do the right thing.
		> >
		> > Its not a question of lazy implementations. Its a
question of not having
		> > enough
		> > information to send anything but early media.

		_______________________________________________
		This list is for continuing development of the SIP protocol.
		The sip-implementer's list is the place to discuss
implementation,
		and to receive advice on understanding existing sip.
		To subscribe to it, send mail to [email-masked]
with
		"subscribe sip-implementors" in the body.

---

From: "Eric Burger" <[email-masked]>
Date: Thu, 18 Jan 2001 10:59:15 -0500

RE: [SIP] Early media replacement.The confusing part is the text part of 183
:-)

"The 183 (Session Progress) response is used to convey information about the
progress of the call which is not otherwise classified" implies the gateway
does know what is going on.

What started the whole thread was the problem of interpreting non-digital
call progress, such as 1A or PBX-generated call progress tones. The problem
with the original PSTN solution is the well documented problem of toll
fraud.  In the PSTN, most carriers address this possibility by either
establishing a one-way voice path and dropping the call in 30 to 48 seconds
if answer supervision is not applied, or starting billing irrespective of
answer supervision after 48 to 60 seconds.

I can't speak for the list, but my concern is that we're opening the same
hole in the packet network that exists in the PSTN.  Moreover, we have the
technology to eliminate most of the cases where the PSTN needed to open that
hole.  I think that's why there's such pushback to the whole idea.

Because I don't personally know of any gateways that can do CPA *today*, I'd
begrudgingly agree to "183 Status Unknown".  If the "we can't change
anything even if it's wrong or confusing police" don't like it, keep the
"Session Progress" token.  I would expect a paragraph in Section 13 (bis) on
the theft of service issue, and would hope to see text similar to Robert's
below explaining what 183 is for in the annotated version / implementer's
guide.

  -----Original Message----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Fairlie-Cuninghame,
Robert
  Sent: Wednesday, January 17, 2001 5:38 PM
  To: 'Eric Burger'; [email-masked]
  Subject: RE: [SIP] Early media replacement.

  Eric,

  Robert.

      -----Original Message-----
      From:   Eric Burger [mailto:[email-masked]]
      Sent:   Thursday, January 18, 2001 9:07 AM
      To:     [email-masked]
      Subject:        RE: [SIP] Early media replacement.

      Why no middle ground:

      200 OK :  The call is established, everyone's happy
      183 :     Something's going on that I understand; here it is...
      184 :     Something's going on that I don't understand; here's the
audio

      1. Either a call is established (200) or it's in the process of being
      established (18x).  Established calls have the audio path established.
      Calls not established (181, 182, 183, et. al.) don't have the audio
path
      established, except for the case of 184.

      2. If there's a billing policy that needs to police media cut-through,
it
      can trigger off the 184 message.

      3. It's forward compatible: as we get a truly digital GSTN, the
dependence
      on audio cut-through for human call progress analysis will go away.
By not
      overloading 183, we make life much easier.

      > ----- Forwarded message from Rick Dean <[email-masked]> -----
01:34:26AM -0500
      >
      > On Tue, Jan 16, 2001 at 01:34:26AM -0500, Jonathan Rosenberg wrote:
      > > > On Tue, Jan 09, 2001 at 01:25:41AM -0500, Jonathan Rosenberg
wrote:
      [snip]
      [snip]
      > Sure, if a gateway knows the far end is busy, it should send
      > a 486 busy -- no debate.  If the gateway has unknown progress media
      > which might be busy-tone, ringback, or voice prompting; sending 200
      > OK helps manage the audio channel.   Do you expect the human to
      > hit a key on busy tone so his UA sends a CANCEL?  or should
      > he just know to wait?
      >
      > is established.  As a call originating UA, how to I suspend or
      [snip]
      > > Its not a question of lazy implementations. Its a question of not
having

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.