Subject: [SIP] Clarification of para in 100-rel-02.txt

From: [email-masked]
Date: Thu, 4 Jan 2001 10:51:22 +0530

Hi,
please refer to sec 5.2 of the rel-02 draft (june 30, 2000)

"Note that the UAS MAY send a final response to the initial request
before having received PRACKs for all outstanding reliable
provisional responses. However, it MUST be prepared to process PRACK
requests for those outstanding responses. A UAS MUST NOT send
reliable provisional responses after sending a final response to a
request."

The clarificartion is wrt to the last line. Does it mean that the

1)  UAS MUST not send any new rel prov. responses after sending the final
response
or
does it mean that
2)  the UAS must stop retransmission of its old non PRACKed rel prov.
responses + 1)

I feel its the former - I may have sent some early media information in my
1xx response which
I want to make sure he has got. The reason I sent 200 OK quickly is for
faster call processing, but I
still want to know if he got my earlier 1xx. So retransmissions of old 1xx
should not stop even if I sent
a final response.

Is this correct ?
Regds
Arjun

--
Arjun Roychowdhury @ Hughes Software Systems

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 4 Jan 2001 01:33:46 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, January 04, 2001 12:21 AM
> To: [email-masked]
> Subject: [SIP] Clarification of para in 100-rel-02.txt
> 
> 
> 
> 
> Hi,
> I want to make sure he has got. 

Correct. It is new provisional responses you are not supposed to send.
Existing ones in flight should complete normally. I'll clarify that.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com