Subject: [SIP] Presence of * in Contact Header

From: Sekhar Banerjee <[email-masked]>
Date: Mon, 15 Jan 2001 21:47:46 -0800

Hi All,
	I would like to get a consensus on this issue from the SIP
implementors on this list. Is the contact header
	
Contact:	*69 <sip:[email-masked]:5060>
	
	a valid contact header. I have had one side say that since the * has
a special meaning in the Contact header and hence there shouldnt be anything
else in that header. The other opinion is that since
the Contact Header contains more than the * hence there isnt anything wrong
with it and the stack should parse it all.
	What is the correct way of handling this ?

Thanks

Sekhar Banerjee

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Igor Slepchin <[email-masked]>
Date: Tue, 16 Jan 2001 13:44:06 -0500

I don't think there is an ambiguity here: a Contact consisting of a _sole_
"*" character has that special meaning; the "*" in the Contact below is part
of display name, which allows "*" characters.

---
Igor Slepchin

> -----Original Message-----
> From: Sekhar Banerjee [mailto:[email-masked]]
> Sent: Tuesday, January 16, 2001 12:48 AM
> To: [email-masked]
> Subject: [SIP] Presence of * in Contact Header
> 
> 
> Hi All,

_______________________________________________
"This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip
to subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body"