Subject: RE: [SIP] is SIP backward compatible?

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 9 Jan 2001 01:45:20 -0500

> -----Original Message-----
> From: Itamar Gilad [mailto:[email-masked]]
> Sent: Thursday, January 04, 2001 12:23 PM
> To: 'SIP List'
> Subject: [SIP] is SIP backward compatible?
> 
> 
> Everybody,
> I'm looking for some guidance in regard to the backward 
> compatibility of
> SIP.  From following the mailing list and relevant events I 
> know that an
> effort is made not to break existing implementations, yet a 
> pure RFC2543
> might have interop problems with a pure bis-02 implementation 
> because of
> some of the changes made.  My questions:
> * What are the rules that determine this?  
> * Are the compatibility-breaking changes about to stop once 
> bis-02 goes RFC?
> Anytime?
> * Is there some sort of general IETF guideline to this matter?

We've been attempting to maintain compatibility as much as possible. The
primary, but to date implicit, guideline has been that, in the worse case, a
change should cause the behavior between an rfc2543bis and rfc2543 entity to
be no different than if both were only rfc2543 compliant. In other words,
certain things are broken and/or unspecified in rfc2543. It may be that the
fix in bis will not correct the problem unless some or all of the entities
are bis compliant. I think this is a reasonable thing to do.

There is only one thing I know of that is formally not backward compatible -
the addition of extension parameters in several places. A very strict parser
might bomb on headers with extension parameters although none were allowed
according to rfc2543. Fortunately, most implementations have been tracking
the changes in the drafts, and I don't think this will be a problem in
practice. 

If you know of anything specific that has been added or changed that breaks
backwards compatibility, please let us know.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Itamar Gilad <[email-masked]>
Date: Fri, 12 Jan 2001 15:52:17 +0200

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Tue, January 09, 2001 8:45 AM
> To: 'Itamar Gilad'; 'SIP List'
> Subject: RE: [SIP] is SIP backward compatible?
> 
> 
> 
> 
>  
> 
> 

I'm assuming this question refers to RFC2543 (March 99) vs. bis-02.  A
couple of things I'm aware of:

1) To/From tags

RFC 2543:
        tag-param    =  "tag=" UUID
        UUID         =  1*( hex | "-" )

bis-02:  
        tag-param = "tag" "=" token

2) Call-ID:  

RFC 2543:
     Call-ID   =  ( "Call-ID" | "i" ) ":" local-id "@" host
     local-id  =  1*uric
bis-02:
     callid = token [ "@" token ]
     Call-ID = ( "Call-ID" | "i" ) ":" callid

  Itamar