Subject: RE: [SIP] new record-route text!

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 4 Jan 2001 02:13:00 -0500

> -----Original Message-----
> From: Christian Huitema [mailto:[email-masked]]
> Sent: Tuesday, January 02, 2001 1:47 PM
> To: Henning Schulzrinne; Jonathan Rosenberg
> Cc: [email-masked]
> Subject: RE: [SIP] new record-route text!
> 
> 
> I am concerned with the mandatory aspect of the record-route 
> parameter.
> Part of the beauty of SIP is that it can operate in a strict 
> end-to-end
> mode; the record-route procedure allows intermediaries to arbitrarily
> break that end-to-end property. I understand that this could be useful
> sometimes, for some crazy network configurations,

Er, I suspect these "crazy" cases are likely to be the norm (i.e., presence
of NATs and firewalls).

>  but if we make this
> mandatory we should have at a minimum an escape hatch. 

I want to make sure that a UA can be deployed in many different network
configurations. There is nothing that forces a network operator to
record-route, and thus provide direct end to end signaling as you would
like. However, there are operators that will want to, and need to,
record-route, and I want to make sure any UA can operate under these
conditions.

More precisely,
> the syntax of the contact header should allow us to 
> distinguish between
> two cases:
> 1) a contact address that can only be reached through the recorded
> route,
> 2) a contact address that can be accessed directly.
> I would contend that, if we don't want to recycle the SIP spec to the
> proposed standard spec, the latter should be the default, as 
> the strict
> record route requirement breaks compatibility with the original
> specification.

I believe that not having record-route be mandatory in rfc2543 is actually a
bug, and so fixing it is part of what happens in the evolution to draft. THe
reason I think its broken is that there will be firewalls and ALGs that need
to see all the signaling in order to open pinholes and do NAT bindings.
These devices need to record route, and if clients don't follow that
record-routing, the call will fail. 

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Thu, 04 Jan 2001 09:40:57 -0500

Jonathan Rosenberg wrote:

> record-routing, the call will fail.

I don't think this is true. In almost all cases, outbound proxies,
without RR, can handle firewalling and NATs.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: Michael Thomas <[email-masked]>
Date: Thu, 4 Jan 2001 08:20:03 -0800 (PST)

> Er, I suspect these "crazy" cases are likely to be the norm (i.e., presence

Jonathan,

I respect your desire to get this to play as well
as to be expected with fog machines, but if it
comes at the cost of making a mess out of a clear,
sunny net I have serious problems. Assuming you
haven't already drank the kool-aid, let's be
careful here; record route is a sometimes useful,
but unwieldy and unreliable tool which should be
used as little as possible. The preface text of
RR ought to be "If you think you need it, you
probably don't. Think again."

 > record-route, and I want to make sure any UA can operate under these

Doesn't the proxy which is controlling the
firewall already need to protect itself from
either non-compliant UA's, or, say, UA's that
crash mid-call? Ie, the proxy only expecting to
see a BYE to close the pinhole is already in
trouble due to entropy? If so, might not a better
route to rely on soft state on the firewall
completely instead of trying to rely on the
signaling plane?

If so, I think that Christian's sense is right
insofar as it underscores to the proxy that the
UA _may_ respect the RR, but ultimately it cannot
be counted on to do so for either policy or 
entomological reasons.

		Mike