Subject: [SIP] REGISTER requests

From: "Vijeth D" <[email-masked]>
Date: 16 Jan 2001 07:28:22 -0000

Hi,
  What does the REGISTRAR do after recieving a REGISTER request i.e, a valid request with user name password and the like? How will the REGISTRAR find the IP address corresponding to the SIPURL being registered and how does he update the Location server of the same?

_____________________________________________________
Chat with your friends as soon as they come online. Get Rediff Bol at
http://bol.rediff.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Vijay Gurbani <[email-masked]>
Date: Tue, 16 Jan 2001 10:32:47 -0600

Vijeth D wrote:
> 
> Hi,
>   What does the REGISTRAR do after recieving a REGISTER request i.e, a 
> valid request with user name password and the like? 

Save it in persistent store.

> How will the REGISTRAR find the IP address corresponding to the SIPURL 
> being registered

Contact header.  All this is included in the RFC as well.

> and how does he update the Location server of the same?

Implementation specific.  Depends on if the Registrar and LS are co-located,
in which case a functional interface suffices.  If they are not, some sort
of middleware (CORBA, RPC, LDAP) can be employed.

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184

_______________________________________________
"This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip
to subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body"