Subject: [SIP] OPTIONS method, bug in draft-ietf-sip-rfc2543bis-02

From: "Deepak Mohan" <[email-masked]>
Date: 9 Jan 2001 11:25:38 -0000

In table 4 and 5 of draft-ietf-sip-rfc2543bis-02, the OPTIONS message cannot have the "Expires" or the "Priority" headers.

Couldn't the "Expires" header be used to *check* if a call can be established using OPTIONS, within the specified time?

Similarly, couldn't "Priority" be used to *check* if a call will succeed through a heavily-laden proxy that uses "Priority" to filter out calls (to reduce the load)? It is true that even sending an OPTIONS will un-necessarily increase the load on the proxy.

Regarding the bug in draft-ietf-sip-rfc2543bis-02, I think "6.46 User-Agent" is supposed to refer to H14.43 and not "H14.42" as mentioned.

Thanks,
Deepak

_____________________________________________________
Chat with your friends as soon as they come online. Get Rediff Bol at
http://bol.rediff.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 16 Jan 2001 00:46:06 -0500

> -----Original Message-----
> From: Deepak Mohan [mailto:[email-masked]]
> Sent: Tuesday, January 09, 2001 6:26 AM
> To: [email-masked]
> Subject: [SIP] OPTIONS method, bug in draft-ietf-sip-rfc2543bis-02
> 
> 
> In table 4 and 5 of draft-ietf-sip-rfc2543bis-02, the OPTIONS 
> message cannot have the "Expires" or the "Priority" headers.
> 
> Couldn't the "Expires" header be used to *check* if a call 
> can be established using OPTIONS, within the specified time?

THis is not the meaning of expires. As a general header, it refers to the
amount of time for which the request is valid. That is not the same thing as
the amount of time over which a call from the same party would be
acceptable.

> 
> Similarly, couldn't "Priority" be used to *check* if a call 
> will succeed through a heavily-laden proxy that uses 
> "Priority" to filter out calls (to reduce the load)? It is 
> true that even sending an OPTIONS will un-necessarily 
> increase the load on the proxy.

I doubt this is useful in any case. By the time you send your INVITE, the
state of the proxy or UA might have changed so that the resulting decision
would be different in any case.

> 
> Regarding the bug in draft-ietf-sip-rfc2543bis-02, I think 
> "6.46 User-Agent" is supposed to refer to H14.43 and not 
> "H14.42" as mentioned.

We've gotten many such notes along these lines. RFC2543 references the older
http spec, and most of those references are now incorrect in rfc2617. We
will need to do a global sweep through the document and check all of them.

Thanks,
Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Deepak Mohan" <[email-masked]>
Date: 17 Jan 2001 04:19:30 -0000

What I meant to ask was, can OPTIONS with an "Expires" of say, "some_date", can be used to check if another request (INVITE), will reach the target UAS with the "Expires" value also set to "some_date". This might be useful if you want a call to be setup within a certain duration of receiving a command from a user to setup a call.

Thanks,
Deepak

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.