Subject: [SIP] SIP App Components

From: "Eric Burger" <[email-masked]>
Date: Thu, 4 Jan 2001 15:58:05 -0500

The SIP App Components infrastructure assumes that the SIP UA's understand
multipart MIME body parts.  This is a MAY in bis 02 (Section 8.2).

Is it safe to assume that the current SIP infrastructure won't choke on SIP
INVITES and potentially responses with multipart MIME, instead of
application/sdp, body parts?

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Sean Olson <[email-masked]>
Date: Thu, 04 Jan 2001 19:23:56 -0600

Define "choke" :) Multipart MIME should not crash
an implementation that doesn't understand it.
I think you will find that multipart implementations
will become more prevalent as S/MIME catches on and
as more inventive uses of the REGISTER body come
around. [I hope that SIP implementors consider
multipart MIME useful enough to implement it]

/sean