Subject: RE: [SIP] draft-ietf-sip-handoff-00pre8.txt

From: "Emami-Nouri, Mohsen" <[email-masked]>
Date: Thu, 25 Jan 2001 16:04:20 -0800

Is not it the case that when the transferor receives the response to his
HANDOFF request , he can not assume with certainty that the HANDOFF was
executed successfully as opposed to REFER where the response indicates the
success or failure of REFER request. 
-----Original Message-----
From: Rick Dean [mailto:[email-masked]]
Sent: Wednesday, January 24, 2001 11:21 PM
To: Emami-Nouri, Mohsen
Cc: [email-masked]
Subject: Re: [SIP] draft-ietf-sip-handoff-00pre8.txt

Sorry, the authors of HANDOFF don't see a 
sync vs. async issue.  With both methods 
the initial transaction completes before
the spawned request does, and both have a 
means of conveying final status.

As for a sound bite difference, we would say "scope".
HANDOFF, PhoneControl, JOIN, TAKE, and a few other
methods (hopefully never to be defined) are replaced
by REFER and a sandbox.  We believe reduced scope
and simplified syntax make HANDOFF easier to implement
and will improve compatibility.

--
Rick
3Com

On Wed, Jan 24, 2001 at 04:40:18PM -0800, Emami-Nouri, Mohsen wrote:
> Hi,
> If we were to totally summarize the difference between REFER and HANDOFF,
> would it be close if we said HANDOFF is a asynchronous and REFER is a
> synchronous call transfer model?.
> 
> -----Original Message-----
> From: Rick Dean [mailto:[email-masked]]
> Sent: Wednesday, January 17, 2001 10:27 AM
> To: [email-masked]
> Subject: [SIP] draft-ietf-sip-handoff-00pre8.txt
> 
> 
> 
> Dear SIP list,
> 
> Although we would like more time to 
> edit this poor draft, we feel a sneak
> peek is warranted due to its urgent nature
> with the upcomming meeting.
> 
> http://phonectl.sfour.com/draft-ietf-sip-handoff-00pre8.txt
> 
> Some significant differences from REFER are:
>   * narrower scope
>   * method completes without prompting
>   * referred-by like header generated by transferee
>   * location of headers for spawned invite
>   * error processing & final notification
> 
> Cheers,
> Rick
> [email-masked]
> 
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementer's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to [email-masked] with
> "subscribe sip-implementors" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Billy Biggs <[email-masked]>
Date: Fri, 26 Jan 2001 01:00:03 -0500

Emami-Nouri, Mohsen ([email-masked]):

> Is not it the case that when the transferor receives the response to
> his HANDOFF request , he can not assume with certainty that the
> HANDOFF was executed successfully as opposed to REFER where the
> response indicates the success or failure of REFER request. 

  As it turns out, REFER is being redrafted to have the REFER
transaction complete immediately upon acceptance of the request rather
than success or failure of the action.  So, in this respect they are
identical.

-- 
Billy Biggs                     [email-masked]
http://www.billybiggs.com/      [email-masked]