Subject: RE: [SIP] Canceling BYE

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 8 Jan 2001 02:36:26 -0500

> -----Original Message-----
> From: Vijay Gurbani [mailto:[email-masked]]
> Sent: Thursday, January 04, 2001 1:34 PM
> To: Deepak Mohan
> Cc: [email-masked]
> Subject: Re: [SIP] Canceling BYE
> 
> 
> Deepak Mohan wrote:
> > 
> > The draft-ietf-sip-rfc2543bis-02 does not say anything 
> about a CANCEL 
> > being used to cancel a BYE. Should this be allowed? I don't 
> think very 
> > many protocols allow a 'Release' message to be canceled.
> 
> If a UAS gets a CANCEL to a non-INVITE request before it has 
> generated a 
> final response, the request can effectively be canceled 
> (although, as you
> point out, what is the result of CANCEL'ing a BYE -- does 
> that mean that
> the session should NOT be torn down?).

If you honor the CANCEL, you would basically undo whatever you have done to
the
point where its as if you never received the message being cancelled. So,
yes,
if you get a CANCEL for a BYE, and the UAS decides to honor it, it would no
longer
consider the call terminated. The BYE would be answered by a 487, and the
CANCEL with a 200. 

However, this is really not useful. Its a lot of work for a UAS for no gain.
I suspect all UASs answer a BYE immediately, so that in practice, the CANCEL
will always be a no-op, as the final response to the BYE has already been
sent.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 08 Jan 2001 09:52:54 +0200

Hi,

Especially if you have a PSTN/SIP GW, I guess you will have to answer to
the BYE immediately, and then ignore any possible CANCEL, because once
you start tearing down a PSTN connection you don't "undo" it just like
that...

Regards,

Christer Holmberg
Ericsson Finland