Subject: [SIP] Syntax for To: and From: An ambiguity ?

From: "M. Ranganathan" <[email-masked]>
Date: Wed, 10 Jan 2001 15:49:23 -0500

Hello!

In the syntax for FROM and TO headers, there appears to be an ambiguity.
According to what I read,

To:  sip:[email-masked];tag=9

is valid but then  is the tag a url parameter or  part of the To
header?  The ambiguity can be resolved  of course  by only allowing the
name-addr form of the address  i.e.

To: <sip:[email-masked]>; tag = 9

however, the RFC does not appear to require this. Am I missing something
here?

Thanks

Ranga.

--
M.Ranganathan
NIST Advanced Networking Technologies Group,
100 Bureau Drive, Stop 8920, Gaithersburg, MD 20899.
Tel: 301 975 3664 Fax: 301 590 0932

ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÒ ùšŠX§‚X¬µ"þX¬¶ÏÛzYÿ•¦ìýÊ&†ÛiÿÿåŠËlý·¥—ùZnÏÜ¢oæj)fjåŠËbú?

---

From: Shailendra Bhatnagar <[email-masked]>
Date: Wed, 10 Jan 2001 15:54:20 -0500

From the SIP spec :

" The Contact, From and To header fields contain a URL. If the URL
   contains a comma, question mark or semicolon, the URL MUST be
   enclosed in angle brackets (< and >). Any URL parameters are
   contained within these brackets. If the URL is not enclosed in angle
   brackets, any semicolon-delimited parameters are header-parameters,
   not URL parameters."

Hope it helps.

"M. Ranganathan" wrote:
> Hfæj)b? b²Ô^>X¬¶ÆÞ-YZnÇ(sm§ÿåSËlmée*¦ìr?¿?¨¥?©ÿ-+-SwèþÈ©

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "M. Ranganathan" <[email-masked]>
Date: Thu, 11 Jan 2001 12:20:12 -0500

N§’Çè®Ø^êeÉ©ÝžŒ!z·¬jz-…êçŠÚbrLª¹ë-Š‰È²Ø^~‰e£§‚W jTè²*n±êÜ¢jZŸ'(šÖ öz-‰Ç­…ë)iÇ›zÜz{azÇ¦‰Ê%¢v§vØ^µ¨†+"²z-jW jTˆ=DK¡÷(º»²*n®[!j÷§¢ÊZqë"žØ^™»ŠËaŠÆ¥z¥¶ˆ^i×«JŠëÉú+mè§‚Ê'ŠÚbrL“…©ä±§¤¡j)^ÚÚ¨¯
èµák¢kay"²—œN‚¢{ZrÑk¢f§u:!y§^øž•Û¢{ZŠv”D²¶”D·(žÖ¢žÆœ¢išªç¬¶*'™ªä¢»š'(–‰í…å,ÅM·žÉh±çb©à•æëiÉ¶Æ§t	òQéj¶¦z×«±ªÞr‰íj)Þw†)í…ën¶œ‘ël!ûayDKŠÉèµéÜ–‹v)Úž	^n¶œ‘ëlj|¬zhœ¢Z'uébš+^v–«jgz»è^i×«¥ªÚ™ë^®ÉèµDK¥ªÚ™ë^®Áè¥è­…éi°ÄZž§jØZŸ
èµáÞ–ZžØ^³)íkè¬TN1©ÝLè^i×«²Ø^æ©¥æ«²Úy©Ú™¸ º+rÇ(Ø§‚Ú0…«HæN‹"¦ëÊ&¥©òr‰jb²ö¥‰Öî¶Ø^ž+-…ëZ««––«jgzº+¥ªí¡ûay:!y§^8^jfâ‚èÉÆ§mêÞ²‰oyÚr‹«±æò¢yrjYhÂ)à¶§jgšuÚß¢¹¨~Ø^i×kzË"y:,Š›¬z·(š–§ÉÊ&µ¨=†Œ½êí…äE	Ú²z-jš^j»hê®Š·†+˜‰¢²È§‚Ê&zØbž^äájy,E©àhÄZž§jØZœÒLojwt×­ÂŠäŠxyÈg¢Z ‰ë®‹©×Mº·š¸:â½ä­¢Ÿ=ÛAšŠØ^®Æî®ÛO=õ7¥ßM}ïúëZÇ}5çÝ4÷}‡~6Û]†g²d¥™êþKjx«ajsHI0½©ÜyÓ^·
+’)àMç!ž‰h‚'¬º.§]4êÞjàëŠ÷’¶Š|÷mj+az»º¸m<÷ÔÞ—}5÷¾wë®kô×ŸtÓÝö

---

From: Sean Olson <[email-masked]>
Date: Thu, 11 Jan 2001 12:04:50 -0600

Yes, this is perfectly legal.
/sean

M. Ranganathan wrote:

> Thanks for the reply, and now here's another nitpicky question:
> 
> Is the following legal
> 
> To: sip:[email-masked];   tag=9
> 
> (notice the space between the semicolon and the tag.)  This is not a 
> legal  SIP URL of course (sip url's have  no spaces in them) but is this 
> a legal to header?
> 
> Sorry for being so nitpicky.
> 
> Thanks.
> 
> Ranga.
> 
> Shailendra Bhatnagar wrote:
> 
>      >From the SIP spec :
>