Subject: [SIP] Escaped characters in sip/tel URLs

From: Shail Bhatnagar <[email-masked]>
Date: Tue, 23 Jan 2001 11:38:49 -0500

I am trying to understand how a proxy or UA would handle
escaped characters in sip/tel URLs and what are its uses. 
Are you supposed to unescape those characters in the 
parsed form and re-escape them when generating the 
unparsed form ? I understand it provides a mechanism to
put illegal characters but what is the real use of this
feature. Can somebody provide some  examples ?
I see one example on page 29 of rfc2543bis-02.ps, according
to which the To header of the REGISTER request would look
like this :

To: [email-masked]
         ^^^ ( note the '@' sign in the user portion).

Does it mean that proxy/registrar at example.com would 
actually save [email-masked] as the search key/user
portion of this registration. 

Thanks,
Shail

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Sean Olson <[email-masked]>
Date: Tue, 23 Jan 2001 11:04:34 -0600

Shail Bhatnagar wrote:

> unparsed form ? 

Yes.

> I understand it provides a mechanism to

The whole point is to allow someone else define
how they will use the fields of the URI and what
information they will put in them. In a word,
extensibility.

> portion of this registration. 

Yes. Note that is it also legal to escape
characters that can legally appear unescaped.
For this reason, you will also need to unescape
the user portion, for instance, before doing
comparisons, sorts, storing, etc.

> Shail

/sean