Subject: [SIP] Question on draft-ietf-sip-100rel-02.txt

From: Aymeric Moizard <[email-masked]>
Date: Thu, 11 Jan 2001 17:09:34 +0100

Hi,

The draft-ietf-sip-100rel-02.txt appears to
expire in December 2000. Is there a new
version of this one and is it on the way
to be accepted?

How do we cancel the INVITE if the UAC has
already received the 183 response. Must we
complete the PRACK "transaction" and send
"request canceled" for invite right after?

Thanks for help
Aymeric

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 16 Jan 2001 01:21:45 -0500

> -----Original Message-----
> From: Aymeric Moizard [mailto:[email-masked]]
> Sent: Thursday, January 11, 2001 11:10 AM
> To: [email-masked]
> Subject: [SIP] Question on draft-ietf-sip-100rel-02.txt
> 
> 
> 
> Hi,
> 

This document was submitted to IESG for consideration
as proposed standard. According to:

http://www.ietf.org/IESG/status.html

it has been under AD review since September 8.

> "request canceled" for invite right after?

Cancellation of the INVITE would proceed normally. You'd send a CANCEL, and
the UAS would respond with a 487 to the INVITE, and then a 200 OK to the
CANCEL. Any reliable provisionals in progress would complete normally; that
is, the UAS would continue to retransmit them until it received a PRACK.
This is part of the important SIP characteristic that all transactions
complete normally and independently of any other transactions.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com