Subject: RE: [SIP] Discussion of Default Timers

From: William Marshall <[email-masked]>
Date: Wed, 3 Jan 2001 09:05:17 -0500 (EST)

Igor Slepchin wrote:
> 50ms for a stateless proxy is also rather bad. If a proxy needs that much
> time to process a message, it's likely to be performing some fairly advanced
> logic, hence the extra overhead of becoming stateful should be rather
> minimal. I guess that's equivalent to your option 2.

Proxies are not likely to be sitting idle.  If you figure instead that
10ms is the processing requirement, at a proxy that is 80% loaded
(on average when the request arrives there are 4 ahead of it in the queue)
the total transit delay through the proxy is 50ms.

Jon Peterson wrote:
> I would imagine that 'six proxy' architectures will eventually fall by the
> wayside. Today, even, I'd imagine that for most networks, the majority of
> those six proxies are either ALGs controlling FWs or stateless proxies that
> are thrown in to achieve greater scalability or availability.

I went through the scaling arguments at the WashDC meeting a little while
ago.  Basically, the proxy closest to the UA provides the IN services, and
forwards/receives requests to/from a stateless proxy at the Access Tandem.
There are 15000 Access Tandems in US.  So, if the stateless proxy could
maintain ~16000 security associations, then a 4-proxy model would work.
(There was an audible gasp in the room at this point)
It is more likely to stay at 6 to keep the IPSec overhead low.

Bill Marshall
[email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Neil Deason <[email-masked]>
Date: Wed, 03 Jan 2001 14:45:16 +0000

> the total transit delay through the proxy is 50ms.

I would hope that the server did not process requests 
sequentially.

> It is more likely to stay at 6 to keep the IPSec overhead low.

For the benefit of those of us not present could you
elaborate on why you would need this 6 (or 4) Proxy 
model when you could just have two proxies (outbound 
and inbound). 
Also what are the 'security associations' you refer to and 
how does the number of them potentially remove 2 proxies?
Is what you refer to here as the Access Tandem the same 
as Jon's SIP ALG - does it do anything more than firewall 
control?

Cheers,
Neil.
-- 
Ubiquity Software Corporation, UK        http://www.ubiquity.net