Subject: RE: [[email-masked]: Re: [SIP] draft-calhoun-sip-aaa-req]

From: "Gross, Gerhard" <[email-masked]>
Date: Wed, 3 Jan 2001 12:00:01 -0800

>Instead of re-casting the SIP request into another format and
>translating status codes between protocols, why not just proxy the SIP
>request to whatever database/server decides whether the person has
>subscribed to this service?

One reason is for simplicity and to potentially
increase processing speed. This is done by taking
advantage of the SIP parser already built into
the SIP proxy. If the whole SIP message were
just forwarded as is to the PDP (policy decision
point), the PDP would need some sort of SIP
parser (thus adding complexity/redundancy to
the chain).

On the other hand, while the SIP proxy parses the
SIP message, it may extract certain information
from it and put it in a simpler and smaller structure
to be passed on to the PDP (AAA/policy server). Such
a structure/protocol has been defined in
http://search.ietf.org/internet-drafts/draft-gross-cops-sip-00.txt.

Gery

        XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
        X                                         X
        X    Gerhard W. Gross, Ph.D.              X
        X    Intel                                X
        X    2111 NE 25th Ave                     X
        X    Hillsboro, OR 97124-5961, USA        X
        X    Policy Architecture Group            X
        X      - Internet and Communication Lab   X
        X    phone:    (503) 264-6389             X
        X    fax:      (503) 264-3483             X
        X    email:    [email-masked]    X
        X                                         X
        XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Wed, 03 Jan 2001 16:04:11 -0500

> parser (thus adding complexity/redundancy to

This assumes that SIP parsing is a major delay or processing expense.
Experience seems to indicate that it is not, compared to the typical
database lookups, crypto and other operations that need to take place.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs