Subject: [SIP] Location of users

From: "Marcus Vinicius" <[email-masked]>
Date: Sun, 14 Jan 2001 13:48:33 -0200

Dear Mr. ....,

	I'm a student, new to SIP, I'm trying to understand it and have some
questions.
	I think that one of the good aspects of SIP is the fact that any user can
be found in the network, wherever he is. Well, since he is registered in a
registrar in a domain.
	But let's imagine a user (that is usually found in
[email-masked]) moves to the university where he studies, and now
is registered as [email-masked]. I think that an INVITE for him to the
domain correia.home.net will be redirected (by a location server) to the
domain he has moved to.
	My question is, how the location server in the domain correia.home.net
knows that the user moves to ic.uff.br as he can move anywhere? As that user
can be located anywhere, the user himself has to include as a list, the
possible domains he can be located? There is any procedure used among
location servers to inform each other the location of a user?

Thanks and Best regards,

Marcus Vinicius Ferreira Correia

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Rolland, Frederic" <[email-masked]>
Date: Mon, 15 Jan 2001 11:20:16 +0100

Hi Marcus,
your question addresses one typical example of personal mobility management.
when you're located in a foreign remote network (in contrast with your home
network),
you must register *locally* (foreign network) in order to tell the local
proxy you're here
and allowing it to forward messages to you, *and* register to your home
network to indicate
your current location to where message must be forwarded to..
so, first message take this path:
source-->home network proxy-->foreign network proxy-->you

this is the same model of personal mobility management that can be found in
the IP Mobility framework...

an example can be found slide 157 in "The Session Initiation Protocol" by
Henning Schulzrinne
http://www.cs.columbia.edu/~hgs

see you,
Frederic.

!!-: -----Original Message-----
!!-: From: Marcus Vinicius [mailto:[email-masked]]
!!-: Sent: Sunday, January 14, 2001 4:49 PM
!!-: To: [email-masked]
!!-: Subject: [SIP] Location of users
!!-: 
!!-: 
!!-: Dear Mr. ....,
!!-: 
!!-: 	I'm a student, new to SIP, I'm trying to understand it 
!!-: and have some
!!-: questions.
!!-: 	I think that one of the good aspects of SIP is the fact 
!!-: that any user can
!!-: be found in the network, wherever he is. Well, since he is 
!!-: registered in a
!!-: registrar in a domain.
!!-: 	But let's imagine a user (that is usually found in
!!-: [email-masked]) moves to the university where 
!!-: he studies, and now
!!-: is registered as [email-masked]. I think that an 
!!-: INVITE for him to the
!!-: domain correia.home.net will be redirected (by a location 
!!-: server) to the
!!-: domain he has moved to.
!!-: 	My question is, how the location server in the domain 
!!-: correia.home.net
!!-: knows that the user moves to ic.uff.br as he can move 
!!-: anywhere? As that user
!!-: can be located anywhere, the user himself has to include 
!!-: as a list, the
!!-: possible domains he can be located? There is any procedure 
!!-: used among
!!-: location servers to inform each other the location of a user?
!!-: 
!!-: 
!!-: Thanks and Best regards,
!!-: 
!!-: Marcus Vinicius Ferreira Correia
!!-: 
!!-: 
!!-: _______________________________________________
!!-: SIP mailing list
!!-: [email-masked]
!!-: http://lists.bell-labs.com/mailman/listinfo/sip
!!-: