Subject: [SIP] matching m= lines with multi-unicast SDP

From: Rohan Mahy <[email-masked]>
Date: Tue, 13 Feb 2001 09:08:20 -0800

Hi folks,

Let's say I send an INVITE to A with a multi-unicast SDP.  I want A to send
(the same) audio to 10.1.1.1 and 10.1.1.2, and be prepared to receive audio
from either (or both).

A -- 10.1.1.1
 \
  10.1.1.2

Here is part of my INVITE:
INVITE sip:A -> 
... 
m=audio 16902 0 
c=10.1.1.1 
m=audio 19764 0 
c=10.1.1.2

Now according to the m= line matching rules, I need all the lines to match.  So
which of the following are valid responses?  It seems that none of them have
the desired semantics.

Two m= lines, but use the same port  (is this allowed?)

        <- 200
        ...  
m=audio 17804 0 
c=10.1.1.3 
m=audio 17804 0 
c=10.1.1.3

Two m= lines, one port set to zero (doesn't this mean "i won't accept that
stream"?)
<- 200 
... 
m=audio 17804 0 
c=10.1.1.3 
m=audio 0 0 
c=10.1.1.3

Two m= lines, one address line set to zero (make 10.1.1.2 stop sending?)
<- 200 
... 
m=audio 17804 0 
c=10.1.1.3 
m=audio 17804 0 
c=0.0.0.0

Only one m= line (seems to violate principal of m= line matching)
<- 200 
... 
m=audio 17804 0 
c=10.1.1.3

Comments are welcome.

thanks,
-rohan

---

From: "Christopher A. Martin" <[email-masked]>
Date: Tue, 13 Feb 2001 11:17:18 -0600

Hello,
Wouldnt the response be unique from each host, regardless of the mcast
INVITE, since the INVITE specifies which listening port is open on the
caller to each recipient?

One callee wouldnt respond with a listening port on behalf of the other
callee, would they?

I'll go and read up on this, since these are assumptions on my part.
Chris.
  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Rohan Mahy
  Sent: Tuesday, February 13, 2001 11:08 AM
  To: [email-masked]
  Subject: [SIP] matching m= lines with multi-unicast SDP

  Hi folks,

  Let's say I send an INVITE to A with a multi-unicast SDP.  I want A to
send (the same) audio to 10.1.1.1 and 10.1.1.2, and be prepared to receive
audio from either (or both).

  A -- 10.1.1.1
   \
    10.1.1.2

    INVITE sip:A ->
    ...
    m=audio 16902 0
    c=10.1.1.1
    m=audio 19764 0
    c=10.1.1.2

  Now according to the m= line matching rules, I need all the lines to
match.  So which of the following are valid responses?  It seems that none
of them have the desired semantics.

          <- 200
          ...
    m=audio 17804 0
    c=10.1.1.3
    m=audio 17804 0
    c=10.1.1.3

    <- 200
    ...
    m=audio 17804 0
    c=10.1.1.3
    m=audio 0 0
    c=10.1.1.3

    <- 200
    ...
    m=audio 17804 0
    c=10.1.1.3
    m=audio 17804 0
    c=0.0.0.0

    <- 200
    ...
    m=audio 17804 0
    c=10.1.1.3

  Comments are welcome.

  thanks,
  -rohan

---

From: Billy Biggs <[email-masked]>
Date: Tue, 13 Feb 2001 16:29:09 -0500

Rohan Mahy ([email-masked]):

> send (the same) audio to 10.1.1.1 and 10.1.1.2, and be prepared to
> receive audio from either (or both).

  Careful: If A accepts the INVITE, it should be prepared to receive
media from anywhere, not only from 10.1.1.1 and 10.1.1.2.

> match.  So which of the following are valid responses?  It seems that
> none of them have the desired semantics.
>
> [...]
>

  (personal opinion) I think it should be this.  Because your SDP may be
modified by a third party, or transcoded, or whatever, I believe that
the two session descriptions (local and remote) to be completely
independant:  advertise what you are willing to receive, the remote end
will do the same, we'll talk happily.  I'm against the idea of m= line
matching.

-- 
Billy Biggs                     [email-masked]
http://www.billybiggs.com/      [email-masked]

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 14 Feb 2001 17:06:42 +0200

Hello Rohan,

You might want to check
http://search.ietf.org/internet-drafts/draft-ietf-mmusic-fid-00.txt
this draft defines the concept of flow (as opposed to media stream).

Best regards,

Gonzalo

Rohan Mahy wrote:
> Two m= lines, one port set to zero (doesn't this mean "i won't accept
> that stream"?)
> 
>      <- 200
>      ...
>      m=audio 17804 0
>      c=10.1.1.3
>      m=audio 0 0
>      c=10.1.1.3
> 

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]