Subject: RE: [SIP] New version of message waiting draft

From: Rohan Mahy <[email-masked]>
Date: Fri, 09 Feb 2001 06:01:54 -0800

At 08:33 AM 2/8/01 , Kevin Wang wrote:
>Hi,
>
>I guess I did not make my 2nd question clear. If we look at the NOTIFY
>message A5 on Page 5, we may find out that the 3rd section and 4th section
>of the NOTIFY message contain some information (such as message subject,
>date/time, priority, etc) about the new voicemail messages. However, the
>NOTIFY message for re-synchronization (for example A3) does not contain that
>information. So, my question is: if a UA loses its previous data for some
>reason and restart again, how can the UA retrieve that information (message
>subject, date/time, priority, etc) from the Notifier?

it is unreasonable to resyncronize this information with NOTIFY, so the
client must use POP or IMAP to get the current contents of the mailbox.

thanks,
-rohan

>Thanks,
>
>-Kevin
>> -----Original Message-----
>> From:	Rohan Mahy [SMTP:[email-masked]]
>> Sent:	Thursday, February 08, 2001 10:57 AM
>> To:	Kevin Wang; [email-masked]
>> Subject:	RE: [SIP] New version of message waiting draft
>> 
>> Hi,
>> 
>> At 12:59 PM 2/7/01 , Kevin Wang wrote:
>> >I have 2 questions about this message waiting draft:
>> >(1) In the 2nd paragraph of section 5.1, "The Subscriber MAY also
>> explicitly
>> >fetch the current status at any time." How does a subscriber fetch the
>> >status? Based on the draft, my guess is that the subscriber sends a
>> >re-SUBSCRIBER message and expects the current status in a NOTIFY message.
>> >Could the subscriber expect the current status in the 200 OK? (In this
>> way,
>> >we do not need that NOTIFY message for re-synchronization).
>> 
>> you can't put this in the 200, because the SUBSCRIBE might be forked, and
>> only one of the 200s will get back.
>> 
>> >(2) I notice that there is no user's message information in the NOTIFY
>> >message for re-synchronization. (There is user's message information in
>> the
>> >NOTIFY message when the status of the messages changes.) If a UA is
>> shutted
>> >down abnormally and lost all the information, how can it get the user's
>> >message information when it is restarted? 
>> 
>> POP or IMAP.  getting this via NOTIFY is not practical.
>> 
>> >> -----Original Message-----
>> >> From:	Rohan Mahy [SMTP:[email-masked]]
>> >> Sent:	Wednesday, February 07, 2001 11:26 AM
>> >> To:	[email-masked]
>> >> Subject:	[SIP] New version of message waiting draft
>> >> 
>> >> Hi,
>> >> 
>> >> I just finished a new version of the message waiting draft from Ilya
>> Slain
>> >> and I.  Until it appears in the archives it is available at:
>> >> 
>> >> 	ftp://ftpeng.cisco.com/rmahy/draft-mahy-sip-message-waiting-01.txt
>> >> 
>> >> thanks,
>> >> -rohan 
>> >> 
>> >> _______________________________________________
>> >> This list is for continuing development of the SIP protocol.
>> >> The sip-implementer's list is the place to discuss implementation,
>> >> and to receive advice on understanding existing sip.
>> >> To subscribe to it, send mail to [email-masked] with
>> >> "subscribe sip-implementors" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: "Eric Burger" <[email-masked]>
Date: Sat, 10 Feb 2001 21:35:11 -0500

[First of all, I suggest any follow-up to go to the sip-events list!!!]

If I may rephrase Kevin's question, it is "what happens if I (the UA)
crashes after I've set up a SUBSCRIPTION?"  For example, the UA will receive
what are, in its view, unsolicited NOTIFY messages.  Alternately, the UA may
recognize that the NOTIFY messages belong to it, but it will have lost the
initial state.  Remember, the NOTIFY message only propagates updates (IMHO
the correct choice).

My response to the question: if the UA crashes, when it restarts it will
re-subscribe to the message presence server.  This subscription is an
initial subscription, so the UA will receive the entire state of the
mailbox.  See Section 5.3 of the draft.

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Rohan Mahy
> Sent: Friday, February 09, 2001 9:02 AM