Subject: [SIP] Question on Missing Content Length field

From: Nirmalya Ghosh <[email-masked]>
Date: Tue, 13 Feb 2001 11:07:27 +0800 (CST)

Hi,
I've been trying to find the answer in the RFC (2543) and also in past queries posted on
this mailing list - but couldn't quite get a clear answer. What I wish to find out is
what does a proxy server do, if it receives a request with a missing "Content-Length"
field?

Section 6.15 (pg.51) says that, "if a server receives a UDP request without
Content-Length, it MUST assume that the request encompasses the remainder of the packet";

Whereas, Section 7.4.12 (pg.79) says that, "The server refuses to accept the request
without a defined Content-Length" 

So, does this imply that if this field is missing in an incoming request, the server
returns a 411 (Length Required) response? Or, does it just assume to have no body and
process the request?

Thanks in advance.

Regards,
nirmalya

__________________________________________________
Do You Yahoo!?
Yahoo! Mail – Free email you can access from anywhere!
http://mail.yahoo.com.sg/

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: "Hisham Khartabil" <[email-masked]>
Date: Tue, 13 Feb 2001 10:28:12 +0200

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Nirmalya Ghosh
> Sent: Tuesday, 13 February 2001 5:07 AM
> To: [email-masked]
> Subject: [SIP] Question on Missing Content Length field
>
>
> Hi,

I think this was during the days when you were allowed more than one SIP
message in a UDP datagram.

> without a defined Content-Length"

well, i think this is an implementation issue. We just make the assumption
that the rest of the packet is the body and try and parse that.

Regards,

Hisham Khartabil
Hotsip Finland
www.hotsip.com