Subject: RE: [SIP] Removing 409 to conflicting action params

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 9 Feb 2001 07:50:50 -0500

The reason it was there is that if the proxy DOES want to follow it, it
becomes meaningless to have some URLS with redirect, and some with proxy.
What does the proxy do? Does it mean to redirect if the highest q value URL
has an action of redirect, even though others say proxy? What if the q
values are the same, or none were specified? We came to the conclusion that
it could mean any number of more complex behaviors, most of which were more
appropriately specified via a CPL than action params.

So, I would like to keep this restriction.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Robert Sparks [mailto:[email-masked]]
> Sent: Wednesday, February 07, 2001 11:55 AM
> To: [email-masked]
> Subject: RE: [SIP] Removing 409 to conflicting action params
> 
> 
> I share Neil's opinions here.
> Can anyone state a reason for keeping the restriction?
> 
> RjS
> 
> > -----Original Message-----
> > From: Neil Deason [mailto:[email-masked]]
> > Sent: Friday, January 19, 2001 6:06 AM
> > To: [email-masked]
> > Subject: [SIP] Removing 409 to conflicting action params
> > 
> > 
> > Can we please remove the restriction that all current 
> > registrations MUST share the same action param. I haven't 
> > found this to be helpful to either users or implementers. 
> > 
> > The spec doesn't really say anything about servers having 
> > to obey action params so they could be treated as just a 
> > hint to the users wishes. A SIP server could then choose 
> > to try and follow them, use it's own configuration policy 
> > or follow alternative user defined processing logic (CPL etc).
> > This is more in keeping with the handling of params like
> > methods that we are seeing more of in Contact headers.
> > 
> > Cheers,
> > Neil.
> > -- 
> > Ubiquity Software Corporation, UK        http://www.ubiquity.net
> > 
> > _______________________________________________
> > This list is for continuing development of the SIP protocol.
> > The sip-implementer's list is the place to discuss implementation,
> > and to receive advice on understanding existing sip.
> > To subscribe to it, send mail to [email-masked] with
> > "subscribe sip-implementors" in the body.
> > 
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementer's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to [email-masked] with
> "subscribe sip-implementors" in the body.
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Neil Deason <[email-masked]>
Date: Fri, 09 Feb 2001 13:34:43 +0000

Jonathan Rosenberg wrote:
> What does the proxy do? 

I am not asking that Proxy/Registrars be forbidden from
responding 
409 just that they be free to choose not to. Presently a
registrar 
MUST respond 409 to conflicting action params. I don't want to 
be forced to respond 409 when somebody has their mailto URL
registered 
with an redirect action and then wants to add a SIP URL which 
they want requests proxied to.

> Does it mean to redirect if the highest q value URL

This is a fair point but we could define how a server
should respond to mixed action params wrt q values if that
is perceived to be an issue. I think that generally CPL will be 
available to provide this sort of control where it is really 
needed and so the whole existence of an action param is fairly 
unintersting. If present can't it just be treated more as a hint. 
A SIP server could then choose to try and follow them, use it's 
own configuration policy or follow alternative user defined 
processing logic (CPL etc). This gives more flexibility than 
mandating 409s.

Cheers,
Neil.