Subject: [SIP] A question of contact header?

From: Charles Zeng <[email-masked]>
Date: Tue, 20 Feb 2001 11:13:45 -0600

Hi All,

Can I use one IP process all incoming INVITE msg.
And use another IP to send all 1xx and 2xx msg with
the contact header associate.

Does the SIP required one transation should be finish
in same IP source.

Best regards.

Charles Zeng

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Charles Zeng <[email-masked]>
Date: Thu, 22 Feb 2001 11:51:41 -0600

Hi friends,

Does anyone has the experience to help for this issue?
Can I use one IP process all incoming INVITE msg.
And use another IP to send all 1xx and 2xx msg with
the contact header associate.

Best regards.

Charles Zeng

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Charles Zeng <[email-masked]>
Date: Thu, 22 Feb 2001 13:55:05 -0600

!Re-send with re-format chart
Thanks

Dear Vijay,

Thanks for help.  We are considering the high-performance SIP server design.
Using one front processor (with its own IP) to receive all INVITE msg. Then
forwarding these msg to main processors for msg process.

For example:

Using CONTACT header, we can do:
==================
Multi-Processor UAS/UAC                  remote SIPTerminal
Processor 1       Processor 0
IP: 10.0.1.1       IP: 10.0.0.1
------------------------------------------------------------------------------------------------

INVITE send to 10.0.0.1
<---------------------------------------------------

200 OK with contact=10.0.1.1 send from 10.0.0.1
---------------------------------------------------->

ACK send to 10.0.1.1
<----------------------------------------------------

But we want to do like this !!!
==================
Multi-Processor UAS/UAC                  remote SIPTerminal
Processor 1       Processor 0
IP: 10.0.1.1       IP: 10.0.0.1
-------------------------------------------------------------------------------------

INVITE send to 10.0.0.1
<---------------------------------------------------

Internal BUS send from Processor 0 to Processor 1
<-------INVITE

200 OK with contact=10.0.1.1 send from 10.0.1.1 (???)
---------------------------------------------------->

ACK send to 10.0.1.1
<----------------------------------------------------

Is it OK?

I am not sure. Because the INVITE/1xx/200OK is the one transcation define
in SIP protocol, when using UDP, it sugguest use connect() to bind the
destination IP to socket. The socket layer may reject the 100 Try, 183 and
200OK, treat them as the hacker packets.

Best Regards

Charles Zeng

Vijay Gurbani wrote:
> Charles Zeng wrote:
> >
> > Hi friends,
>
> [...moved to SIP Implementors...]
>
> This is an implementation issue.  For instance, you could use one process
> for handling TCP SIP messages and another for handling UDP SIP messages.
> Both of these processes may gather SIP messages from their respective
> sockets and send it to the parser or transaction handler for further
> processing.
>
>
> If I understand your question correctly, no.  For instance, you can initiate
> a CANCEL request to a previously pending INVITE transaction.
>
> Hope that helps.
>
> - vijay
> --
> Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
> Internet Software and eServices Group
> Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
> Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184