Subject: RE: [SIP] New version of message waiting draft

From: Kevin Wang <[email-masked]>
Date: Wed, 7 Feb 2001 15:59:34 -0500

I have 2 questions about this message waiting draft:
(1) In the 2nd paragraph of section 5.1, "The Subscriber MAY also explicitly
fetch the current status at any time." How does a subscriber fetch the
status? Based on the draft, my guess is that the subscriber sends a
re-SUBSCRIBER message and expects the current status in a NOTIFY message.
Could the subscriber expect the current status in the 200 OK? (In this way,
we do not need that NOTIFY message for re-synchronization).
(2) I notice that there is no user's message information in the NOTIFY
message for re-synchronization. (There is user's message information in the
NOTIFY message when the status of the messages changes.) If a UA is shutted
down abnormally and lost all the information, how can it get the user's
message information when it is restarted? 
Thanks,

Kevin Wang
Senior Software Engineer
NetSpeak Co.
Boca Raton, FL 33437
> -----Original Message-----
> From:	Rohan Mahy [SMTP:[email-masked]]
> Sent:	Wednesday, February 07, 2001 11:26 AM
> To:	[email-masked]
> Subject:	[SIP] New version of message waiting draft
> 
> Hi,
> 
> I just finished a new version of the message waiting draft from Ilya Slain
> and I.  Until it appears in the archives it is available at:
> 
> 	ftp://ftpeng.cisco.com/rmahy/draft-mahy-sip-message-waiting-01.txt
> 
> thanks,
> -rohan 
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementer's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to [email-masked] with
> "subscribe sip-implementors" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Rohan Mahy <[email-masked]>
Date: Thu, 08 Feb 2001 07:56:52 -0800

Hi,

>we do not need that NOTIFY message for re-synchronization).

you can't put this in the 200, because the SUBSCRIBE might be forked, and
only one of the 200s will get back.

>message information when it is restarted? 

POP or IMAP.  getting this via NOTIFY is not practical.

---

From: Kevin Wang <[email-masked]>
Date: Thu, 8 Feb 2001 11:33:06 -0500

Hi,

I guess I did not make my 2nd question clear. If we look at the NOTIFY
message A5 on Page 5, we may find out that the 3rd section and 4th section
of the NOTIFY message contain some information (such as message subject,
date/time, priority, etc) about the new voicemail messages. However, the
NOTIFY message for re-synchronization (for example A3) does not contain that
information. So, my question is: if a UA loses its previous data for some
reason and restart again, how can the UA retrieve that information (message
subject, date/time, priority, etc) from the Notifier?

Thanks,

-Kevin
> Sent:	Thursday, February 08, 2001 10:57 AM
> To:	Kevin Wang; [email-masked]
> Subject:	RE: [SIP] New version of message waiting draft
> 
> Hi,
>