Subject: RE: [SIP] Interworking Between SIP/SDP and H.323

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Fri, 2 Feb 2001 17:04:17 -0800

Hi Kundan,

Do you see any problems with forming the destination h323-id with the
display name from the To: and the SIP URL from the Request-URL?

Robert.

> -----Original Message-----
> From: Kundan Singh [mailto:[email-masked]]
> Sent: Saturday, February 03, 2001 5:21 AM
> To: Fairlie-Cuninghame, Robert
> Cc: [email-masked]; [email-masked]
> Subject: Re: [SIP] Interworking Between SIP/SDP and H.323
> 
> 
> 
> > Hi Henning & Kundan,
> >
> > I have a query with regards to draft-singh-sip-h323-01.txt.
> >
> > The draft states that the destination information from the 
> H.323 call be
> > derived from the To URL in a new INVITE (see A.1.2). It 
> seems that the
> > request-URI is ignored entirely (despite the fact that some 
> of the call
> 
> This is an error. The signaling gateway should use
> the Request-URI instead of To: URL. This occurs at more than
> one place in the draft.
> 
> We will correct this in the next version.
> 
> Thanks for pointing out the mistake.
> 
> Kundan
> 
> > flows are annotated with "INVITE sip:[email-masked]").
> >
> > I do not see how this will work when a SIP UA or proxy 
> redirects (or proxies
> > with updating the request) call to a H.323 device.
> >
> > For example:
> >
> > INVITE sip:[email-masked] SIP/2.0
> > To: "Robert Fairlie-Cuninghame" <sip:[email-masked]>
> >
> > is sent to the proxy at nuera.com which responds with a 
> SIP/2.0 302 Temp
> > Moved
> > Contact: 
> <sip:[email-masked];maddr=h323-iwf.nuera.com>
> >
> > How will this work if the IWF ignores the Request-URI ?
> >
> > If the IWF instead uses the request URI in the H323 SETUP 
> destinationInfo,
> > is there anythign wrong with it using the display name from 
> the To? Unless a
> > 380 Alternate Service is issued then the display name 
> should still be
> > correct.
> >
> > On a related note in the base SIP spec, if a 380 Alternate 
> Service is issued
> > (which requires user interaction), the spec needs to be 
> clarified whether
> > the new call attempt will use a new call-leg with the To 
> field changed
> > apprpriately.
> >
> > Cheers,
> >
> > Robert.
> >
>

---

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Sun, 4 Feb 2001 19:13:56 -0800

Kundan,

There also seems to be other discrepancies in the H.323 - SIP address
conversion. For instance, Section 6.1.2 says that if a tel url contains "w"
then it cannot be converted into an e164-id alias address. The draft however
makes no mention of the digits A, B, C & D which are allowed in tel URL's
but not allowed in e164-id (according to the draft). What is the correct
action here?

In the same section, the visual separators "(" & ")" should be mentioned for
completeness.

The draft also makes no mention with regards to the "+" character when
converting a e164-id to a SIP URL (or tel: URL). Is this an intentional
omission? 

I also wished to point out that acoording to
http://www.ietf.org/internet-drafts/draft-singh-sip-h323-01.txt has expired
(and hence is unavilable).

Robert.