Subject: RE: [SIP] SIP in small adhoc and Pico networks

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 10 Feb 2001 00:41:06 -0500

I actually don't think SIP REGISTER is appropriate here. THe reason is that
this problem is much broader than SIP.

As a general issue, the devices which come into being in one of these
piconets will have many services associated with URLS - ftp services, web
services, IM services, sip services, and so on. Normally, these service URLs
are published through out-of-bands means, like on a business card or from a
directory service. What you need here is a way to construct dynamic,
distributed directory services that allow you access to the resources on the
network as they are introduced.

In fact, the argument could be made that the right solution is actually a
Directory Agent-less SLP network. When a device joins the piconet, it
creates service agents that advertise the services on the device - the sip
URL, for example, along with the parameters of that service (the name of the
user, their codecs, and so on). By doing this with a service independent
mechanism, it works for lots of things besides SIP.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Ashutosh Dutta [mailto:[email-masked]]
> Sent: Friday, February 02, 2001 2:19 PM
> To: Michael O'Doherty
> Cc: [email-masked]
> Subject: Re: [SIP] SIP in small adhoc and Pico networks
> 
> 
> 
> 
> Michael, would you assume each Piconet member in the same 
> subnet (broadcast
> domain), can we define a well defined multicast address to 
> get the listing of
> the users with SIP UA enabled in the neighborhood, and their 
> contact address,
> may be by using something  like SAP/SDP.
> 
> Thanks
> Ashutosh
> 
> 
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementer's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to [email-masked] with
> "subscribe sip-implementors" in the body.
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 10 Feb 2001 12:41:01 -0800

> this problem is much broader than SIP.

That is true, but that doesn't argue any more for not using REGISTER as
in a non-ad-hoc network. After all, we could also use SLP to locate
users in a regular network for SIP. SLP isn't particularly well suited
for locating persons, as it's mostly designed for parameterized
services. I'm sure you could modify it appropriately, but the REGISTER
approach seems pretty natural for the user-location model.