Subject: RE: [SIP] Re: SIP digest, Vol 1 #750 - 4 msgs

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 10 Feb 2001 00:41:07 -0500

> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Friday, February 02, 2001 9:28 AM
> To: [email-masked]'; [email-masked]
> Cc: [email-masked]
> Subject: RE: [SIP] Re: SIP digest, Vol 1 #750 - 4 msgs
> 
> 
> > And is it just me, or is the idea that BICC will be 
> > encapsulated in SIP
> > somewhat counterintuitive? Are there any services today that 
> > require that?
> > Anyway, if there is interest I'd be inclined to say that BICC 
> > should have
> > it's own MIME type which should be discussed on its own merits.
> 
> So, SIP-T is used for, among other things, ISUP-SIP-ISUP.
> You don't think anyone wants to do BICC-SIP-BICC when SIP is 
> one operator's
> network, and the BICCs are two other operators?
> 
> I also see BICC-SIP-ISUP and of course ISUP-BICC-SIP-ISUP and 
> variations.

Seems prejudicial in favor of SIP catering to BICC. If we do this, what
about:

SIP-BICC-SIP

I think we should request the BICC guys to be able to encapsulate SIP
messages. After all, what about service transparency across my SIP network!
All these operators that are deploying SIP are doing so, in part, because of
the service possibilities. Shall I be forced to lose those capabilities when
I traverse an IP based BICC network? Why do the BICC guys get to keep their
services, and the SIP guys don't? After all, BICC is even newer than SIP.

Of course, once we do that, the more fun case is:

ISUP-SIP-BICC-SIP-ISUP

in which case the encapsulated SIP messages themselves contain ISUP
messages, both of which are encapsulated in BICC.

Of course, we should probably also consider the case of:

SIP-ISUP-SIP

Think about it; a SIP phone calls a PSTN number. It goes to an ss7 gateway.
Turns out, that this number is then forwarded to another number, and that
number is a VoIP terminal. So, it exits at another gateway, and hits the
terminal. I suppose we should also request the ISUP guys to encapsulate SIP
messages. 

Now then, we should also probably consider the case of:

SIP-BICC-SIP-ISUP-SIP-BICC

-Jonathan R.
"reducio ad absurdum"
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 13 Feb 2001 11:34:44 +0200

Not to forget the cases where we encapsulate everything in morse code
and smoke signals - after all, SIP is newer than those methods, so... :)

Christer Holmberg
Ericsson Finlande