Subject: [SIP] Doubt in the RFC

From: "Vijeth D" <[email-masked]>
Date: 15 Feb 2001 05:29:33 -0000

Hi,
 I would like to know if the rfc bis-02 has to be followed while implementing SIP or the original RFC. Because there are some deviations are present which are not mentioned in the changes section.

regards,
 Vijeth

_____________________________________________________
Chat with your friends as soon as they come online. Get Rediff Bol at
http://bol.rediff.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Vijay Gurbani <[email-masked]>
Date: Thu, 15 Feb 2001 09:01:29 -0600

Vijeth D wrote:
> 
> Hi,
>  I would like to know if the rfc bis-02 has to be followed while 
> implementing SIP or the original RFC. Because there are some deviations 
> are present which are not mentioned in the changes section.

I beleive until the bis obsoletes RFC 2543, the latter is the authoratative
word on SIP.  Most of the changes made to the bis are backwards compatible,
except for a couple of places; to wit, some headers (R-R, for instance) in
the bis can accept additional parameters (rr-param) which may cause a strict
RFC 2543 parser to choke.  Also, the bis adds some new response codes; "487
Request Terminated" springs to mind...

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184

---

From: "Christopher A. Martin" <[email-masked]>
Date: Thu, 15 Feb 2001 12:13:27 -0600

I would have to add a grain of salt to this and add that the bug fixes in
bis02 should be followed, as they are obvious fixes to real problems found
in the current RFC. Other than that the RFC should be adhered to, IMHO.

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Vijay Gurbani
> Sent: Thursday, February 15, 2001 9:01 AM
> To: Vijeth D
> Cc: [email-masked]
> Subject: Re: [SIP] Doubt in the RFC
>
>
> Vijeth D wrote:
> >
> > Hi,