Subject: [SIP] SIP in small adhoc and Pico networks

From: "Michael O'Doherty" <[email-masked]>
Date: Fri, 2 Feb 2001 15:11:10 -0000

Hi,

The draft below has been submitted and is now available online. It discusses
the use of SIP in small adhoc and Pico networks.

The intention is not to imply that using SIP for session control in these
type of networks is necessarily a use of SIP that leverages the strengths of
the protocol, rather to recognize that there may be SIP based applications
that a user wants to use in the usual way  between locally available clients
without any changes to his application while attached to such networks.

Comments or feedback would be welcome.

Cheers,

Mick O'Doherty
Nortel Networks

----------------------->

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: Pico SIP
	Author(s)	: M. O'Doherty
	Filename	: draft-odoherty-pico-sip-00.txt
	Pages		: 8
	Date		: 30-Jan-01
	
This document defines an extension to the SIP protocol to allow 
it be used in adhoc networks or Pico Networks. It leverages the 
direct, client to client session initiation capabilities of SIP, 
although there may be applications where the redirect and 
proxying abilities will be important also. Note the intention is 
not to imply that SIP is inherently the best protocol for such 
networks, but to recognize that there will likely be many SIP 
based applications in existence and that it would be good to 
allow these applications work with as little change as possible 
in this different type of network.

A URL for this Internet-Draft is:
<http://www.ietf.org/internet-drafts/draft-odoherty-pico-sip-00.txt>

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-odoherty-pico-sip-00.txt".

A list of Internet-Drafts directories can be found in
<http://www.ietf.org/shadow.html> 
or <ftp://ftp.ietf.org/ietf/1shadow-sites.txt>

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-odoherty-pico-sip-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
draft-odoherty-pico-sip-00.txt <bin00056.bin>

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Fri, 02 Feb 2001 13:10:56 -0500

Interesting idea. I would think that REGISTER, in peer-to-peer mode
effectively, would fit pretty well. In a sense, every piconet member is
a registrar. 
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: "Robert Chen" <[email-masked]>
Date: Fri, 2 Feb 2001 11:07:31 -0800

hi,

We do not want have a database. We do not want to implement Register
messages.
How can I location?

For example, a message from our company out to sip:[email-masked] , how can
I get the IP address of [email-masked] , some articles say use DNS. But I do
not know how to implement this with DNS. I have no experience about this.
Please help!!!

Best wishes!
Yours sincerely, Robert Chen
___________________________________
Cisco Certified Network Associate
Oracle Certified Professional DBA
SUN Certified Solaris7 System Administrator
SUN Certified Solaris7 Network Administrator