Subject: [SIP] REFER revision

From: Robert Sparks <[email-masked]>
Date: Mon, 26 Feb 2001 10:35:15 -0500

The attached draft-ietf-sip-cc-transfer-04 has been submitted
to the draft repostitory. This draft is destined to be split
into two (separating the definition of REFER from is use to
achieve transfer). I've kept them as one for this iteration
primarily to make sure the changes to the use of NOTIFY were
available in the draft repository before the March meeting.

Here's the changes section from the document:

   Editor's note: The changes for this revision focused on the changes
   to the NOTIFY response mechanism discussed at February's interim
   meeting, and clarification to the REFER method itself. As mentioned
   above, the intent is to separate this document into two. The split
   was postponed a version to ensure the edits to REFER/NOTIFY would be
   reflected in the ID repository in time for discussion at IETF 50.

   o  Modified contents of NOTIFYs to reflect the consensus at the
      interim meeting. One event type, with an application/sip body
      representing the information to be returned.
   o  Added message detail to the prototypical flow
   o  More explicitly stated that REFER MAY occur outside an existing
      call-leg
   o  Reinforced that REFER can be record-routed
   o  Made the presence of a Contact header mandatory
   o  Changed the positive response to a REFER request to 202 Accepted
      instead of 200 OK
   o  Corrected editing errors in examples and message diagrams

RjS

---

From: [email-masked]
Date: Tue, 27 Feb 2001 09:59:12 +0530

hello,
This is fine except for a minor change in the BNF.

The opening ' [ ' should be before the semicolon

Referred-By      = ("Referred-By" | "b") ":" referrer-url  [ ";"

-ashok
------------------
ashok @ Hughes S/W
------------------
>>Referred-By      = ("Referred-By" | "b") ":" referrer-url ";"

>>So, would the following be acceptable?

>>Referred-By      = ("Referred-By" | "b") ":" referrer-url ";"
                      [(     referenced-url
                        | ( referenced-url ";" ref-signature )
                        | ( ref-signature ";" referenced-url )
                       )]

>>RjS

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.