Subject: Re: [SIP] Timestamp header

From: Christer Holmberg <[email-masked]>
Date: Fri, 02 Feb 2001 08:39:24 +0200

Hi,

This has probably been discussed before, but I will give my comment
anyway.

If a UAC only wants to know the time between a request and a response
(provisional or final, depending on what the UAC wants to know) I see no
reason to add a header which only has to be echoed. Instead, the UAC
could save the request-sent-time together with the rest of the
transaction data, and then calculate the time when the response is
received.

And, if any other node, for some reason, really needs the time, it could
send an "Extension required" response. Of course, the UAC could choose
to always include the Timestamp header in every request, but it
shouldn't be mandatory to echo it.

From a SIP standard point of view this is not a big issue, but I am only
trying to keep the network packages as small as possible :)

Regards,

Christer Holmberg
Ericsson Finland

Jonathan Rosenberg wrote:
> 
> 
> 
> > -----Original Message-----
> > From: Henning G. Schulzrinne [mailto:[email-masked]]
> > Sent: Tuesday, January 16, 2001 10:25 AM
> > To: Jonathan Rosenberg
> > Cc: 'Grant McSheffrey'; Sip List
> > Subject: Re: [SIP] Timestamp header
> >
> >
> > Jonathan Rosenberg wrote:
> > >
> > > The spec is not clear on this, saying simply that it should
> > be echoed. I
> > > would imagine placing it in all responses, provisional and
> > final, makes the
> > > most sense.
> >
> > Note that because of the different origins, the delay for the 100 may
> > differ from the other 1xx and the final response.
> 
> Hmm. This brings up some more issues.
> 
> If the purpose of the Timestamp header is to determine RTT for
> retransmission rates, then what you really want is the delay between the UAC
> and the *first stateful entity* (be it stateful proxy or UAS/redirect) on
> the call path, since retransmissions terminate there. The final responses
> are from UAS to UAC, which is going to have an RTT much higher than the UAC
> to first stateful proxy. In fact, in this case, the 100 response is the ONLY
> place that Timestamp would be useful.
> 
> Other applications of timestamp (not sure what they are, though) might make
> an end to end measurement useful.
> 
> -Jonathan R.
> 
> ---
> Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementer's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to [email-masked] with
> "subscribe sip-implementors" in the body.

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Fri, 02 Feb 2001 09:08:13 -0500

The timestamp header is needed to distinguish between retransmissions of
the same request, which will otherwise look identical. Determining the
round-trip and the ACK ambiguity is a classical TCP problem.
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs