Subject: [SIP] Second try - Branch parameter question

From: Shail Bhatnagar <[email-masked]>
Date: Thu, 08 Feb 2001 10:16:22 -0500

(a) When a proxy computes the cryptographic hash of
From, To, Call-ID, CSeq.seqnum and Request-URI,
can it use the unparsed From and To or normalized
form of their parsed components. 
Does the loop detection scheme in the bis-02
version assumes that From header of a looped 
request or a spiralled request is byte-by-byte
same as the From header of the original incoming
request ? (Same question for To header)

(b) When using the To header, should the proxy include
the To tag in the hash computation ? If it did, then
ACK will map to a different transaction than the 
corresponding INVITE ??

Comments ??

Thanks,
Shail

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: "Jo Hornsby" <[email-masked]>
Date: Thu, 8 Feb 2001 16:27:22 -0000

> request ? (Same question for To header)

I would say that, in general, byte-by-byte is far too
fragile.  Some sort of normalised form sounds like a
good way to go.

> ACK will map to a different transaction than the 

Indeed.  I would just go on the To's URI.

HTH,

 - Jo.

---

From: Shail Bhatnagar <[email-masked]>
Date: Thu, 08 Feb 2001 12:02:56 -0500

Jo, I tend to think that doing URL match for addr-spec of
From/To headers and concatenating normalized
URL components even for hash computation,
is an unnecessary overhead. Practically speaking,
every proxy/ua will save the unparsed form
of From/To as it came in the first time (or
as it sent out the first time) and could do a 
simple string match on the addr-spec. (I thought
URLs cannot have white spaces ??)
I don't find the URL matching rules very useful
for the addr-spec of From and To headers, but
would be forced to use them.

Shail