Subject: [SIP] removing the bis draft dependency from manyfolks

From: Rohan Mahy <[email-masked]>
Date: Mon, 26 Feb 2001 14:24:52 -0800

Hi,

There is a very simple way to remove the dependency of manyfolks on the bis 
draft.

Simply change the behavior in manyfolks such that 180/181/182 with 
preconditions means "I will ring/alert/notify the phone _as soon as my 
preconditions are satisfied_."

Only a few lines of text need to be replaced:

(from Section 8.1):
>Upon receipt of the COMET message, the UAC/UAS continues normal SIP
>    call handling, by (for a UAS) alerting the user and sending e.g. a
>    180-Ringing or 200-OK response.
     --->
"Upon receipt of the COMET message (or the 200 response to the COMET), the 
UAS (or UAC) continues normal SIP call handling, by performing the action 
normally associated with sending or recieving the 18x provisional response 
(e.g. for a 180, the UAC plays local ringback and the UAS alerts the user)."

(from Section 9.1)
>At this point it alerts the user, and sends a 180-
>Ringing provisional response.  This provisional response is also
>sent using the reliability mechanism of [12], resulting in a PRACK
>message and 200-OK of the PRACK.
--> "At this point it alerts the user.  Upon receipt of the 200 response to 
the COMET, the UAC generates local ringback."

Also replace: "183-Session-Progress" with "18x".

If these small changes are made, the example flow already in the draft will 
still work (because the 183 has empty semantics, no action is postponed; 
the subsequent 180 will cause ringback immediately because preconditions 
are already satisfied).  Also the shorter flow shown below will also work.

    Originating (UAC)                            Terminating (UAS)
         |                  SIP-Proxy(s)                 |
         |  INVITE               |                       |
         |---------------------->|---------------------->|
         |                       |                       |
         |       180 w/SDP       |       180 w/SDP       |
       * |<----------------------|<----------------------| *
         |                                               |
         |                       PRACK                   |
         |---------------------------------------------->|
         |               200 OK (of PRACK)               |
         |<----------------------------------------------|
         | Reservation                       Reservation |
          ===========>                       <===========
         |                                               |
         |                                               |
         |               COMET                           |
         |---------------------------------------------->|
         |               200 OK (of COMET)               |
         |<----------------------------------------------|
         |                                               |
    **  Local Ringback Played                    User Alerted **
         |                                               |
         |              time passes ...                  |
         |                                               |
         |                                       User Picks-Up
         |                  SIP-Proxy(s)         the phone
         |                       |                       |
         |       200 OK          |       200 OK          |
         |<----------------------|<----------------------|
         |                       |                       |
         |                                               |
         |                       ACK                     |
         |---------------------------------------------->|

Ringing and Ringback are delayed from * until ** . The Terminating UAS 
rings the phone when the COMET arrives.  The Originating UAC plays local 
ringback when the 200 OK to the COMET arrives.

Please consider this proposal.  I feel this is both useful technically, as 
well as an ideal short-cut around more process-related delay.

thanks,
-rohan

---

From: William Marshall <[email-masked]>
Date: Tue, 27 Feb 2001 17:36:38 -0500 (EST)

Rohan,

Your approach was certainly considered; the main problem was
a UAS that doesn't ring -- it would then send a 200-OK that
means "I will complete the call _as soon as my preconditions
are satisfied_."  Now there is no way to signal an error, and
all the semantics of media flow timings are different.

Further, it means the manyfolks-based-on-2543 would have
different call flows than manyfolks-based-on-bis; not desirable.

Seems much better to slightly increase the documentation, and
keep the semantics of each message the same as the draft
had previously defined.

I expect the updated draft will be out shortly....

Bill Marshall
[email-masked]

-----original message-----
Date: Mon, 26 Feb 2001 14:24:52 -0800
To: [email-masked]
From: Rohan Mahy <[email-masked]>
Subject: removing the bis draft dependency from manyfolks
Cc: [email-masked], [email-masked]

Hi,

     --->

(from Section 9.1)

thanks,
-rohan

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.