Subject: [SIP] Branch parameter question

From: Shail Bhatnagar <[email-masked]>
Date: Tue, 06 Feb 2001 14:52:55 -0500

The bis-02 version says 
Branch Parameter = f(To, From, Call-ID, Request-URI, Seq number of CSeq)

where 'f' is some hashing function.
Which part of the From and To is this referring to  - the
addr-spec portion ?  Does it not assume that addr-spec
of From and To headers are byte-by-byte equal. I thought
From and To headers should be compared by comparing
  - the addr-spec portion ( per the rules of URL comparison)
  -  the tag and possibly extension params ??
Now, as we all know 2 URLS may be equal but may not be 
byte-by-byte equal. So, how does this branch parameter
scheme work ??

Thanks,
Shail

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Shail Bhatnagar <[email-masked]>
Date: Tue, 06 Feb 2001 16:48:56 -0500

Just  to clarify, I don't mean comparison
of From with To, but comparison of From
header as stored in transaction state with
what is received in a PDU. Similarly for
To header.
Basically, my question is hash output of
equivalent From headers would be different,
so should the hashing be done on "normalized"
URL components or the unparsed addr-spec.

Thanks,
Shail