Subject: RE: [SIP] Removing 409 to conflicting action params

From: Robert Sparks <[email-masked]>
Date: Wed, 7 Feb 2001 11:55:05 -0500

I share Neil's opinions here.
Can anyone state a reason for keeping the restriction?

RjS

> -----Original Message-----
> From: Neil Deason [mailto:[email-masked]]
> Sent: Friday, January 19, 2001 6:06 AM
> To: [email-masked]
> Subject: [SIP] Removing 409 to conflicting action params
> 
> 
> Can we please remove the restriction that all current 
> registrations MUST share the same action param. I haven't 
> found this to be helpful to either users or implementers. 
> 
> The spec doesn't really say anything about servers having 
> to obey action params so they could be treated as just a 
> hint to the users wishes. A SIP server could then choose 
> to try and follow them, use it's own configuration policy 
> or follow alternative user defined processing logic (CPL etc).
> This is more in keeping with the handling of params like
> methods that we are seeing more of in Contact headers.
> 
> Cheers,
> Neil.
> -- 
> Ubiquity Software Corporation, UK        http://www.ubiquity.net
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementer's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to [email-masked] with
> "subscribe sip-implementors" in the body.
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Robert Sparks <[email-masked]>
Date: Fri, 9 Feb 2001 08:55:51 -0500

I'm not advocating destroying the response code, just
allowing using it to be policy at the registrar.

The classic proxy you mention would choose to use a
registar that by policy returned 409.

The current MUST restriction prevents applications
that _can_ deal with multiple action types from using
a "compliant" registrar.

Further, with the current wording, I can't ask a
proxy to proxy MESSAGEs and redirect INVITES, which
is a very reasonable thing to ask a classic proxy to
do.

RjS

> From: Jonathan Rosenberg 
> Sent: Friday, February 09, 2001 6:51 AM
> To: Robert Sparks; [email-masked]
> Subject: RE: [SIP] Removing 409 to conflicting action params
> 
> 
> The reason it was there is that if the proxy DOES want to 
> follow it, it becomes meaningless to have some URLS with 
> redirect, and some with proxy. What does the proxy do? Does 
> it mean to redirect if the highest q value URL has an action 
> of redirect, even though others say proxy? What if the q 
> values are the same, or none were specified? We came to the 
> conclusion that it could mean any number of more complex 
> behaviors, most of which were more appropriately specified 
> via a CPL than action params.
> 
> So, I would like to keep this restriction.
> 
> -Jonathan R.
> 
> ---
> Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
> http://www.dynamicsoft.com
>  
> 
> > From: Robert Sparks [mailto:[email-masked]]
> > Sent: Wednesday, February 07, 2001 11:55 AM
> > Subject: RE: [SIP] Removing 409 to conflicting action params
> > 
> >