Subject: RE: [SIP] VIA header encryption?

From: Baniel Uri-CUB001 <[email-masked]>
Date: Mon, 26 Feb 2001 12:31:11 -0600

Hi Sean

You said...

> In 3GPP, there are essentially three SIP "servers":
> A Proxy CSCF (Call Session Control Function) which
> sits on the border between the access network and the
> core network, the Interrogating CSCF (I-CSCF) that
> sits on the border between two operator's network,
> and a serving CSCF (S-CSCF) that is the real SIP server
> for a subscriber. The goal is to hide the number of
> S-CSCFs in an operator's network. To do this, the
> I-CSCF is being tasked with this Via: hiding function.

All what you say does make sense, Still allow me to be picky a bit and to enhance some more about the CSCF flavors, in favor of those who may learn from it. (Though I know you know it for sure and was just short in time..)

The Proxy CSCF (Call Session Control Function) does not sit on the border between the access network and the core network...
It does sit in the IMS sub network, which is pass the Core-Network itself... It is true though that in case of the P-CSCF it is an IMS, which is associated with the geographic Access and core (PS domain) networks, in which the user is currently roaming ( a special case would be his home network..). Also the P-CSCF is a 'real SIP proxy server' too... You may compare it to an local outbound SIP proxy server. Actually if BIS2543 have had also a local inbound proxy server then we would have said the P-CSCF mimics the functionality of both local SIP proxy servers..

Still your intention is of course good and helpful :)

Uri 

===========================================
[email-masked], 
Tel: (847) 632 4616; Fax: (847) 632 3963; 
===========================================

> -----Original Message-----
> From: Sean Olson [mailto:[email-masked]]
> Sent: Monday, February 26, 2001 9:37 AM
> To: Henning G. Schulzrinne
> Cc: Neil Deason; Arnoud van Wijk (ELN); [email-masked]
> Subject: Re: [SIP] VIA header encryption?
> 
> 
> I hope I can clarify this a bit. First, the goal
> is not to hide the address of the endpoint. The
> goal is to hide the capacity of the core or internal
> network. That is, the number of SIP servers in a
> given domain. This information is seen as a competitive
> advantage in the wireless arena.
> 
> In 3GPP, there are essentially three SIP "servers":
> A Proxy CSCF (Call Session Control Function) which
> sits on the border between the access network and the
> core network, the Interrogating CSCF (I-CSCF) that
> sits on the border between two operator's network,
> and a serving CSCF (S-CSCF) that is the real SIP server
> for a subscriber. The goal is to hide the number of
> S-CSCFs in an operator's network. To do this, the
> I-CSCF is being tasked with this Via: hiding function.
> 
> Hope this helps somewhat,
> sean
> 
> Henning G. Schulzrinne wrote:
> 
> >> I think the motivation in 3GPP is more to do with providers
> >> hiding internal network topography rather than the fact
> >> signalling ever passed through them.
> > 
> > 
> > Why hiding the IP addresses or names of servers is of any value has
> > always baffled me. This strikes me as having no security value, but
> > making diagnosis of problems that much more difficult. 
> After all, nobody
> > (except spammers) worries about "exposing the topology of 
> email servers"
> > and does Received header hiding (I hope...). I think rather 
> than rolling
> > over and saying "3GPP must know best", some effort at 
> education should
> > be made by those active in that community. This strikes me as a
> > requirement where the best approach is to say "you really 
> don't want to
> > do this" rather than devising ever more ingenious and 
> complicated ways
> > to pursue the elusive goal of address hiding. If you truly 
> want to hide
> > the IP address of the end system (for which arguments can 
> be made, as
> > that address may reveal location information), you'll need 
> some form of
> > B2B UA, with media handling.
> 
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementor's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to 
> [email-masked] with "subscribe" in the body.
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Neil Deason <[email-masked]>
Date: Tue, 27 Feb 2001 09:43:51 +0000

> It does sit in the IMS sub network, which is pass the Core-Network itself... It is true though that in case of the P-CSCF it is an IMS, which is associated with the geographic Access and core (PS d…

Thanks for the further info Uri, however please allow me to 
now be a little bit picky with your comments too ;)

I have seen these comparisons in presentations on SIP and 3GPP 
and I think it is a over simplification which has potential to 
mislead. The functionality potentially being placed in a P-CSCF 
would make it a very different 'Proxy Server' to any you would 
conclude from reading RFC 2453bis. An example is the possible 
proposed behaviour of a P-CSCF on an incoming call - the 'local 
inbound proxy server' role. It appears possible that the P-CSCF 
may be expected to remove all Via headers and only pass a 
locally unique token on to the called party. There are quite a 
few other differences too. :PLEASE NOTE: I am not saying this 
sort of thing is right or wrong within the 3GPP. Though I do 
have general concerns that the proposed architecture is heading 
towards a networks of B2B UAs which would be wrong. I just think 
that as the two communities engage we need to ensure we fully 
understand each others terminology.

Cheers,
Neil
-- 
Ubiquity Software Corporation, UK        http://www.ubiquity.net