Subject: RE: [SIP] Re: Location information

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 6 Feb 2001 16:39:50 -0000

You seem to have two comments:

i)	that this is a service issue and should not be dealt with at the
protocol level. I do have some sympathy with this. However the privacy draft
does not stop at the protocol level, and does define that in full anonymity
is requested the information is supressed at the last proxy in the trusted
network, which I guess you would defined as a service level requirement.
Even at the protocol level, we do need a common understanding of the
semantics of all the codings, and in my belief, "full" can never mean full
anonymity to all potential recipients. Therefore even if we remove all the
service aspects, we should be extremely clear about the semantics of the
defined values.

ii)	you seem to be querying whether such a requirement exists at all,
and propose to leave everything to analysing call logs. In public networks,
all emergency attendents will be specified to automatically have access to
such information. They need to assess whether the call is meaningful from
that URL (as part of the input to quickly identify malicious calls -
something that is an increasing problem throughout the world) and also as a
means to reestablishing the call should it be terminated before completion
(assuming the call has failed for only a temporary condition). No scanning
of call logs is going to fulfil this requirement. I believe this requirement
is general for all public networks. In addition, in some countries it
appears to be part of the regulatory framework that certain classes of users
have access to restricted identities, and therefore public networks in those
countries have to provide a means of supporting it. I believe, but have no
further information, that the calls that might fall into this class are
non-emergency calls to the police, i.e. calls that fulfil some of the
requirements of emengency calls but not all of them, e.g. with regard to
urgency of response.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Michael Thomas[SMTP:[email-masked]]
> Sent: 	06 February 2001 16:18
> To: 	Drage, Keith (Keith)
> Cc: 	'William Marshall'; 'Rosen, Brian'; [email-masked]
> Subject: 	RE: [SIP] Re: Location information
> 
> Drage, Keith (Keith) writes:
>  > While the current privacy draft identifies that a user requesting
> "full"
>  > privacy will receive this, I do not believe it is true. The current
> PSTN,
>  > ISDN and mobile network service definitions all provide for some
> special
>  > users (normally law enforcement agencies or emergency attendants) who
> have
>  > access to this information no matter what the anonymity aka restriction
>  > parameters indicate. I think the privacy draft needs to identify that
>  > certain categories of user will exist that override the anonymity
> setting,
>  > and that this is a "national option" of whatever the IETF equivalent of
> such
>  > terminology is.
> 
>    Ick. This sounds like just the kind of thing that
>    _shouldn't_ be handled at the protocol level, but
>    instead at the service deployment level with the
>    necessary agreements. Why can't the UAC look at
>    the INVITEE's identity to determine if it wants
>    to give out its identity after all? Why can't you
>    make the proxy log INVITE's with calling anonymity
>    requested and then the cops can get it out of the logs
>    if required?
> 
> 		Mike
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Michael Thomas <[email-masked]>
Date: Tue, 6 Feb 2001 09:00:45 -0800 (PST)

> service aspects, we should be extremely clear about the semantics of the

   I don't see what the problem is here. The proxy that
   suppresses caller id is a trusted third party. Part
   of the implicit agreement between my UA and the 
   proxy is that certain entities -- 911 centers, etc, --
   will always have access to my caller id. If you 
   don't like that service, then don't use that proxy.

 > requirements of emengency calls but not all of them, e.g. with regard to

   And what, exactly, is the problem of having a back door
   interface to call logs for certain people? I think it
   would be pretty trivial to hack up a http GET that did
   this, for example, and that's just off the top of my
   head -- there's probably a dozen other better ways to
   skin that cat. Heck, if E911 has static routing entries at
   the proxy, it doesn't even need a back channel
   since it would know that the caller id
   shouldn't be scrubbed.

   *My* point is that SIP being required to define
   classes of users to have certain privileges
   begs an enormous number of questions, not the
   least of which is designing for a particular
   system which the IETF don't do.

		Mike