Subject: RE: [SIP] Re: SIP digest, Vol 1 #750 - 4 msgs

From: Chip Sharp <[email-masked]>
Date: Mon, 19 Feb 2001 11:58:37 -0500

At 09:47 AM 2/19/2001, Mark Watson wrote:

>Indeed. But to answer the original question, there is no requirement to 
>encapsulate BICC in SIP - this does not make sense.
>
>BICC consists of two logical parts, (i) ISUP messages (which support the 
>narrowband ISDN/PSTN service set) and (ii) Bearer Information (which 
>controls the setup of the bearer connection across the ATM/IP network).

True, and item (ii) should at least allow use of existing SIP or SDP. And I 
believe the ISUP is slightly modified in BICC so it isn't exactly ISUP as 
used over SS7.

>SIP-T consists of three logical parts, (i) ISUP messages (ii) Bearer 
>Information (in the form of SDP) and (iii) SIP headers (supporting 
>integration with native SIP networks.

I believe there is bearer information in the ISUP message carried by SIP-T 
as well.  It may just not apply to the IP network.

>Therefore SIP-T is already a superset of BICC. Encapsulating BICC inside 
>SIP-T would just result in duplicating the Bearer Information. So, in the 
>BICC-SIP-BICC case, the SIP messages will look just like the ISUP-SIP-ISUP 
>ones. When you subtract the bearer information from a BICC message, you 
>are essentially left with an ISUP one.
>
>In fact, for IP networks, BICC just about uses SDP to carry the Bearer 
>Information, so it should interwork to SIP without *too* much difficulty 
>(but don't quote me on that).

Except "just about uses" isn't the same as "uses".  Instead of using SIP or 
SDP (or even H.323), SG11 has invented a new protocol by adding 
request/response semantics into the SDP "a = " line and calling it the "IP 
Bearer Control Protocol."

This in addition to modifying H.248/Megaco to fit into their "architecture."

>Regards,
>
>Mark
>
> > -----Original Message-----
> > From: Christer Holmberg 
> [<mailto:[email-masked]>mailto:[email-masked]] 
>
> > Sent: 13 February 2001 09:35
> > To: [email-masked]
> > Subject: Re: [SIP] Re: SIP digest, Vol 1 #750 - 4 msgs
> >
> >
> >
> > Not to forget the cases where we encapsulate everything in morse code
> > and smoke signals - after all, SIP is newer than those
> > methods, so... :)
> >
> > Christer Holmberg
> > Ericsson Finlande
> >
> > Jonathan Rosenberg wrote:
> > >
> > >
> > >
> > > > -----Original Message-----
> > > > From: Rosen, Brian 
> [<mailto:[email-masked]>mailto:[email-masked]]
> > > > Sent: Friday, February 02, 2001 9:28 AM
> > > > To: [email-masked]'; [email-masked]
> > > > Cc: [email-masked]
> > > > Subject: RE: [SIP] Re: SIP digest, Vol 1 #750 - 4 msgs
> > > >
> > > >
> > > > > And is it just me, or is the idea that BICC will be
> > > > > encapsulated in SIP
> > > > > somewhat counterintuitive? Are there any services today that
> > > > > require that?
> > > > > Anyway, if there is interest I'd be inclined to say that BICC
> > > > > should have
> > > > > it's own MIME type which should be discussed on its own merits.
> > > >
> > > > So, SIP-T is used for, among other things, ISUP-SIP-ISUP.
> > > > You don't think anyone wants to do BICC-SIP-BICC when SIP is
> > > > one operator's
> > > > network, and the BICCs are two other operators?
> > > >
> > > > I also see BICC-SIP-ISUP and of course ISUP-BICC-SIP-ISUP and
> > > > variations.
> > >
> > > Seems prejudicial in favor of SIP catering to BICC. If we
> > do this, what
> > > about:
> > >
> > > SIP-BICC-SIP
> > >
> > > I think we should request the BICC guys to be able to
> > encapsulate SIP
> > > messages. After all, what about service transparency across
> > my SIP network!
> > > All these operators that are deploying SIP are doing so, in
> > part, because of
> > > the service possibilities. Shall I be forced to lose those
> > capabilities when
> > > I traverse an IP based BICC network? Why do the BICC guys
> > get to keep their
> > > services, and the SIP guys don't? After all, BICC is even
> > newer than SIP.
> > >
> > > Of course, once we do that, the more fun case is:
> > >
> > > ISUP-SIP-BICC-SIP-ISUP
> > >
> > > in which case the encapsulated SIP messages themselves contain ISUP
> > > messages, both of which are encapsulated in BICC.
> > >
> > > Of course, we should probably also consider the case of:
> > >
> > > SIP-ISUP-SIP
> > >
> > > Think about it; a SIP phone calls a PSTN number. It goes to
> > an ss7 gateway.
> > > Turns out, that this number is then forwarded to another
> > number, and that
> > > number is a VoIP terminal. So, it exits at another gateway,
> > and hits the
> > > terminal. I suppose we should also request the ISUP guys to
> > encapsulate SIP
> > > messages.
> > >
> > > Now then, we should also probably consider the case of:
> > >
> > > SIP-BICC-SIP-ISUP-SIP-BICC
> > >
> > > -Jonathan R.
> > > "reducio ad absurdum"
> > > ---
> > > Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> > > Chief Scientist                             First Floor
> > > dynamicsoft                                 East Hanover, NJ 07936
> > > [email-masked]                     FAX:   (973) 952-5050
> > > 
> <http://www.cs.columbia.edu/~jdrosen>http://www.cs.columbia.edu/~jdrosen 
> PHONE: (973) 952-5000
> > > <http://www.dynamicsoft.com>http://www.dynamicsoft.com
> > >
> > > _______________________________________________
> > > This list is for continuing development of the SIP protocol.
> > > The sip-implementer's list is the place to discuss implementation,
> > > and to receive advice on understanding existing sip.
> > > To subscribe to it, send mail to [email-masked] with
> > > "subscribe sip-implementors" in the body.
> >

-------------------------------------------------------------------
Chip Sharp                       Consulting Engineering
Cisco Systems
-------------------------------------------------------------------

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementer's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to [email-masked] with
"subscribe sip-implementors" in the body.

---

From: Henry Sinnreich <[email-masked]>
Date: Mon, 19 Feb 2001 21:55:10 -0600

>SG11 has invented a new protocol by adding

Every new protocol costs a lot of money to introduce in the network and
needs a solid business case, such as new revenue that would not be possible
otherwise. Just my usual skeptical outlook on reincarnations of SS7 and
device control protocols...

Henry

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Chip Sharp
Sent: Monday, February 19, 2001 10:59 AM
To: Mark Watson
Cc: [email-masked]
Subject: RE: [SIP] Re: SIP digest, Vol 1 #750 - 4 msgs

> > -----Original Message-----
[<mailto:[email-masked]>mailto:[email-masked]
sson.se]