Subject: [SIP] I-D ACTION:draft-ietf-sip-isup-01.txt

From: David Auerbach <[email-masked]>
Date: Wed, 23 May 2001 17:00:29 +0200

In looking at this draft and the SIP-T draft :

I think it would be good for the draft(s) to address procedures for the 
case when an IAM is received
at the ingress MGC with a COT on Previous circuit indication in the nature 
of call indicators.  If the
COT on previous indication is carried by the INVITE in the embedded ISUP to 
the egress MGC and
sent in a subsequent IAM,  either

	1.  a procedure should be defined for delivering the eventual COT message 
through the SIP
	network (INFO?)

or

	2.  the ingress MGC must break the COT on previous chain and not send an 
INVITE
	with the embedded IAM indicating COT on previous.  In this case, it the 
ingress
	MGC would have to hold up the INVITE until the COT message is received.

Regards,

David Auerbach
EMEA Technology Center
Cisco Systems Europe

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Adam Roach" <[email-masked]>
Date: Wed, 23 May 2001 10:22:49 -0500

It would be the second choice: there's no point in checking
circuit continuity across an IP network. I think this is actually
discussed in the draft. Specifically, if my memory serves,
it is the example that we give for the class of problems that
we will not attempt to solve in this draft. ISUP administrative
procedures (such as circuit maintanance) are outlined in their
relevant specifcations, and don't need to be repeated in ours.

An additional factor is that the procedure you talk about
is ANSI specific. You need to keep in mind that each flavor of
ISUP has its own maintanance procedures; repeating all of these
procedures for all flavors and detailing exactly how they will
work for a SIP-ISUP gateway would take years, and result in a
several-thousand page document.

In this case (as with others), the correct answer is rather obvious:
it just takes a very brief rumination on the meaning of circuit
continutity testing and some common sense to figure out how to implement
this sort of function in the spirit of the ISUP specs.

/a

> -----Original Message-----
> From: David Auerbach [mailto:[email-masked]]
> Sent: Wednesday, May 23, 2001 10:00 AM
> To: [email-masked]
> Subject: [SIP] I-D ACTION:draft-ietf-sip-isup-01.txt
> 
>

---

From: David Auerbach <[email-masked]>
Date: Wed, 23 May 2001 17:47:05 +0200

Adam,

Thanks for your comments -

I was not implying that we would want to check continuity across the IP
network ... the reason for the COT on previous was to allow for a pipeline
of COT across a series of switches to reduce dial delay.  So I did not think
the answer was that straight forward.

This bit is found in Q.763 and I did not think it was limited to ANSI
only.

David