Subject: [SIP] question about 3-way Conference

From: Harbor Dong <[email-masked]>
Date: Wed, 9 May 2001 14:26:22 -0700 (PDT)

In draft-ietf-sip-service-examples-01...

2.9  3-way Conference
   User A calls User B, User B then invites user C to
a 3-way call. User B will mix the audio streams (act
as the conference bridge).  If user B drops out of the
call then the entire call is dropped.  This is not   
a fully meshed conference, and does not make use of
the concepts in the call control draft......

>>>Question: What does it mean about "User B will mix
the audio streams (act as the conference bridge)."? 

Thanks.

Laker

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - buy the things you want at great prices
http://auctions.yahoo.com/

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Mohammad Vakil" <[email-masked]>
Date: Thu, 10 May 2001 09:18:10 -0400

User B will be receiving the audio streams from User A and C. User B will
have two RTP sessions active one with A and another one with C. It's User
B's job to mix the audio streams from A and C along with its own and send it
back the mixed steams to A and C.

I guess n -1 mixing can be done here.

A + B ====> C
A + C ====> B
B + C ====> A

note that, here since it's not a fully meshed conference so only User B's
media component would be doing the mixing job and A and C would be dealing
with just on RTP session.

Hope it answers your question.

Mohammad Vakil
SIP Communications

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Harbor Dong
> Sent: Wednesday, May 09, 2001 5:26 PM
> To: [email-masked]
> Subject: [SIP] question about 3-way Conference
>
>