Subject: RE: [SIP] Comments about draft-ietf-sip-call-flows-03.txt

From: Baniel Uri-CUB001 <[email-masked]>
Date: Fri, 11 May 2001 17:09:02 -0500

Alan

According Bis section 11.4:

"Regardless of whether the caller or callee is generating the new request, the header fields in the request are set as follows. For the desired call leg, the To header field is set to the remote address, and the From header field is set to the local address (both including any tags)"

So does that explain why User B has reused the To-Tag as From-Tag in its subsequent request?
It does make sense, if that it is the explanation, since User A knows User B by the To-Tag, so when it gets the same tag in the From field it knows what instance of user B it came from. 

Is that so?

What would you say about the following sequence, which has been built based on the above assumption and based on the call-flows draft (note the '???' at the last line)

A -> B (Request1): FromTag='fa'; ToTag=null 
B -> A (200 response): FromTag='fa'; ToTag='tb'
A -> B (subsequent request): FromTag='fa'; ToTag=null
B -> A (subsequent request): FromTag='tb'; ToTag=null
A -> B (200 response): FromTag='tb'; ToTag='ta'
A -> B (subsequent request): FromTag='fa or tb???'; ToTag=null

=================================================================
[email-masked], 
Tel: (847) 632 4616; Fax: (847) 632 3963; 
"Learning that does not daily increase will daily decrease" E.w.c
=================================================================

> -----Original Message-----
> From: Baniel Uri-CUB001 [mailto:[email-masked]]
> Sent: Friday, May 11, 2001 4:20 PM
> To: 'Alan Johnston'
> Cc: [email-masked]
> Subject: RE: [SIP] Comments about draft-ietf-sip-call-flows-03.txt
> 
> 
> Alan
> 
> In draft-ietf-sip-call-flows-04.txt section 3.1.1 Successful 
> Simple SIP to SIP:
> 
> User B uses the same tag value (tag=8321234356) for the 'To' 
> field (in its response) and then for the 'From' field
> when it initiates the 'Bye' transaction.
> 
> Bis02 section 6.26 says: "The UA SHOULD use different tags 
> for From and To header fields"
> 
> Am I missing something here?
> Thanks,
> 
> Uri
> 
> =================================================================
> [email-masked], 
> Tel: (847) 632 4616; Fax: (847) 632 3963; 
> "Learning that does not daily increase will daily decrease" E.w.c
> =================================================================
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementor's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to 
> [email-masked] with "subscribe" in the body.
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Alan Johnston <[email-masked]>
Date: Fri, 11 May 2001 19:10:12 -0500

Uri,

A tag is associated with a URL, so when the To and From URLs are swapped, so are the tags.  Once the tags are added, they are used throughout the session and become part of the call leg that uniquely identifies the call.  If a tag is dropped in a request (as in your example, see below),
the call leg no longer matches, and the UAS will reply with a 481 Call leg does not exist.

Thanks,
Alan Johnston
WorldCom
sip:[email-masked]

> B -> A (200 response): FromTag='fa'; ToTag='tb'

From now on, every request and response should contain the two tags, fa and tb.

> A -> B (subsequent request): FromTag='fa'; ToTag=null

The response to this request would be a 481 since to tag inserted by B is not present.

> B -> A (subsequent request): FromTag='tb'; ToTag=null

Likewise, this request would receive a 481

> A -> B (subsequent request): FromTag='fa or tb???'; ToTag=null

These two are also not correct.