Subject: [SIP] RE: I-D ACTION:draft-ietf-sip-isup-01.txt

From: [email-masked]
Date: Tue, 15 May 2001 15:16:56 -0600

Please note that this draft reflects the merger of draft-ietf-sip-isup-00
with draft-jfp-sip-isup-header-00. Also note that the elements of
draft-ietf-sip-isup-00 dealing with overlap dialing and signaling have been
removed from the new draft; a separate draft which will appear shortly
focuses solely on overlap procedures.

Jon Peterson
Level(3) Communications

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 15, 2001 5:02 AM
Cc: [email-masked]
Subject: I-D ACTION:draft-ietf-sip-isup-01.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Session Initiation Protocol Working Group
of the IETF.

	Title		: ISUP to SIP Mapping
	Author(s)	: G. Camarillo, A. Roach et al.
	Filename	: draft-ietf-sip-isup-01.txt
	Pages		: 52
	Date		: 14-May-01
	
This document describes a way to perform the mapping between two
signaling protocols: the Session Initiation Protocol (SIP) and the
ISDN User Part (ISUP) of SS7.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-sip-isup-01.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-sip-isup-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-sip-isup-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: [email-masked]
Date: Wed, 23 May 2001 09:49:56 -0600

This sort of scenario is also addressed in the SIP-T Contexts and
Architectures draft:

http://search.ietf.org/internet-drafts/draft-vemuri-sip-t-context-02.txt

... in section 8 note number 4, so at the very least this is a known
problem. As Adam noted, this is only one of a whole class of such problems.
While your suggestions could potentially work, I think that in all instances
this is probably something that a terminating gateway should address by
ignoring certain aspects of the received encapsulated ISUP if they are
determined to be out of date or inappropriate. I don't think that sending
the COT or what have you is necessary - the terminating gateway has no use
for this information; bug I agree with you that the originating gateway
should withhold the INVITE in this case until it receives a COT - in fact,
this is specified explicitly in draft-ietf-sip-isup-01 section 10.3.

I envision that there will be a new SIP-T draft at some point that will
address several types of potential ISUP modification in greater detail,
including this sort of case.

Jon Peterson
Level(3) Communications

-----Original Message-----
From: David Auerbach [mailto:[email-masked]]
Sent: Wednesday, May 23, 2001 9:00 AM
To: [email-masked]
Subject: [SIP] I-D ACTION:draft-ietf-sip-isup-01.txt

In looking at this draft and the SIP-T draft :

I think it would be good for the draft(s) to address procedures for the 
case when an IAM is received
at the ingress MGC with a COT on Previous circuit indication in the nature 
of call indicators.  If the
COT on previous indication is carried by the INVITE in the embedded ISUP to 
the egress MGC and
sent in a subsequent IAM,  either

	1.  a procedure should be defined for delivering the eventual COT
message 
through the SIP
	network (INFO?)

or

	2.  the ingress MGC must break the COT on previous chain and not
send an 
INVITE
	with the embedded IAM indicating COT on previous.  In this case, it
the 
ingress
	MGC would have to hold up the INVITE until the COT message is
received.

Regards,

David Auerbach
EMEA Technology Center
Cisco Systems Europe

---

From: David Auerbach <[email-masked]>
Date: Mon, 28 May 2001 15:21:52 +0200

One final comment ...

I am not referring to COT on current leg (which is only important to the 
two ends of the
TDM connection).  Clearly this has no bearing on SIP-T.

I am referring to the COT on previous indication which is, in effect, an 
end to end indication
(or at least beyond the scope of the two ends of a TDM connection.)  The
downstream switches (that may be on the other side of the SIP network) 
normally DO
care about the COT on previous setting in the IAM and DO expect to set a COT
message even if that switch was not involved in a COT test.

This is why I thought it merited special attention.

David

---

From: Lueken Joachim <[email-masked]>
Date: Mon, 28 May 2001 17:53:00 +0200

Hi David,

In my opinion the ingress VoIP-GW should wait for a successful continuity indication for the cases "cot required" and "cot performed on previous circuit" before an INVITE is sent on the SIP side. In this case a distinction between interworking to SIP or SIP-T, respectively, is not necessary.

As a consequence it should not happen that SIP is envolved at all and that values different from "cot not required" can be reveived at the egress VoIP-GW in the encapsulated IAM.

Joachim
Siemens AG

> From:	David Auerbach [SMTP:[email-masked]]
> Sent:	Monday, May 28, 2001 3:22 PM
> To:	[email-masked]
> Subject:	RE: [SIP] I-D ACTION:draft-ietf-sip-isup-01.txt
> 
> One final comment ...
> 
> >The sip-implementor's list is the place to discuss implementation,>