Subject: [SIP] Doubt in a implementation of Sip stateless Proxy server

From: "manish kulkarni" <[email-masked]>
Date: Thu, 24 May 2001 10:06:22 -0000

hi,
  i am new user to Sip,and i have implemented a parser for a Sip message and 
it parses the Sip Message Line by Line.i want to implement a Stateless 
Proxy,i would like to know What methods my Stateless Proxy Should understand 
and What Responses it should generate.i went to RFC-2543 but it never says 
anything about the methods a stateless proxy should understand,it talks only 
about the methods understood by a Proxy Server,does that mean the method 
should be understood by a Statelss Proxy and a Stateful Proxy?.actually i am 
developing a Interfaces that will be used to write a stateless proxy,in that 
i have decided to give a interface for changing the Request-URI as the 
RFC-2543 says that the Proxy SHOULD change the request-URI,i am unable to 
procced in implementing the interface as it needs to DNS SRV lookup,can 
anyone tell me how far this interface would be relavent for a Stateless 
Proxy?.When a Proxy Receives a Request,it checks the Top most Via to see of 
the Request-URI is correct as seen by the proxy,now here i would like to 
know whether the proxy needs to keep a list of all the users it 
knows?.kindly clear my doubts.if they have already been discussed,sorry i 
might have missed in the mailing lists.
            Thank u.

MANISH.R.K
_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Thu, 24 May 2001 09:56:47 -0500

Hi Manish,

   The basic difference between stateless and stateful proxy is  stateless
proxy forgets about the SIP request once it has forwarded.
But stateful prxies remember the request so that they can associate the
request with the corresponding response and also take care
of any retransmissions if required. Also Stateful proxies maintain
transaction states i.e in which state a transaction is ....

like WaitingForFinalResponse  or WaitingForACK , etc.

But both types of proxies are logical. A physical proxy can act as both
stateful and stateless depending on the requirement.

HTH.

Regards
Ranjit
Mascon Communication Technologies
http://www.masconit.com

----- Original Message -----
From: manish kulkarni <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 24, 2001 5:06 AM
Subject: [SIP] Doubt in a implementation of Sip stateless Proxy server

hi,

MANISH.R.K

---

From: "Michel A. Maddux" <[email-masked]>
Date: Thu, 24 May 2001 09:55:25 -0600

At what point does a stateful proxy determine that a call is no longer
valid/in use?  Is this only via timer, sans BYE?  thanks. /m.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Ranjit Avasarala
Sent: Thursday, May 24, 2001 8:57 AM
To: manish kulkarni; [email-masked]
Subject: Re: [SIP] Doubt in a implementation of Sip stateless Proxy
server

Hi Manish,

HTH.

Regards
Ranjit

----- Original Message -----
From: manish kulkarni <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 24, 2001 5:06 AM
Subject: [SIP] Doubt in a implementation of Sip stateless Proxy server

hi,

MANISH.R.K

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Thu, 24 May 2001 11:52:36 -0500

Hi
    One possibility could be through use of timers i.e you wait for some
event to take place within a certain time frame and if it
does not happen you abort the transaction and restart it .

or maintain a counter for maximum number of retransmissions and abort the
transaction after  you reached that limit.

Any comments?

Regards
Ranjit

----- Original Message -----
From: Michel A. Maddux <[email-masked]>
To: 'Ranjit Avasarala' <[email-masked]>; 'manish kulkarni'
<[email-masked]>; <[email-masked]>
Sent: Thursday, May 24, 2001 10:55 AM
Subject: RE: [SIP] Doubt in a implementation of Sip stateless Proxy server

-----Original Message-----

Hi Manish,

HTH.

Regards
Ranjit

----- Original Message -----
From: manish kulkarni <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 24, 2001 5:06 AM
Subject: [SIP] Doubt in a implementation of Sip stateless Proxy server

hi,

MANISH.R.K

---

From: "Michel A. Maddux" <[email-masked]>
Date: Thu, 24 May 2001 11:03:10 -0600

oh; doest that mean that RFC2543bis doesn't specify the action to be taken
for a statful proxy?  This is left up to the implementor?  Seems like a BCP
might be in order... thanks. /m.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Ranjit Avasarala
Sent: Thursday, May 24, 2001 10:53 AM
To: [email-masked]; 'manish kulkarni'; [email-masked]
Subject: Re: [SIP] Doubt in a implementation of Sip stateless Proxy
server

Hi

Any comments?

Regards
Ranjit

-----Original Message-----

Hi Manish,

HTH.

Regards
Ranjit

----- Original Message -----
From: manish kulkarni <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 24, 2001 5:06 AM
Subject: [SIP] Doubt in a implementation of Sip stateless Proxy server

hi,

MANISH.R.K

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Thu, 24 May 2001 12:04:01 -0500

ya  RFC only specifies what a proxy should do, but does not differentiate
between stateful and stateless.

Regards
Ranjit

----- Original Message -----
From: Michel A. Maddux <[email-masked]>
To: 'Ranjit Avasarala' <[email-masked]>; 'manish kulkarni'
<[email-masked]>; <[email-masked]>
Sent: Thursday, May 24, 2001 12:03 PM
Subject: RE: [SIP] Doubt in a implementation of Sip stateless Proxy server

-----Original Message-----

Hi

Any comments?

Regards
Ranjit

-----Original Message-----

Hi Manish,

HTH.

Regards
Ranjit

----- Original Message -----
From: manish kulkarni <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 24, 2001 5:06 AM
Subject: [SIP] Doubt in a implementation of Sip stateless Proxy server

hi,

MANISH.R.K