Subject: [SIP] timeout value for response

From: "kumar s" <[email-masked]>
Date: 18 May 2001 15:21:59 -0000

Hello All,

what is the recommended 'timeout value' for a sipstack to wait for a response.

In particular, what is the recommended time  the sipstack  would wait for an
ACK for a 200 OK.

Thanks

S.Kumarconfirm 748539

_____________________________________________________
Chat with your friends as soon as they come online. Get Rediff Bol at
http://bol.rediff.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Fri, 18 May 2001 13:19:31 -0500

Hi
     if u don't want the sip stack to timeout and want it to wait for
infinite time for the ACK then give the value -1. and 0 for
 asynchronous receive.

Regards
Ranjit
Mascon Communication Technologies
http://www.masconit.com

----- Original Message -----
From: kumar s <[email-masked]>
To: <[email-masked]>
Sent: Friday, May 18, 2001 10:21 AM
Subject: [SIP] timeout value for response

Hello All,

what is the recommended 'timeout value' for a sipstack to wait for a
response.

Thanks

S.Kumarconfirm 748539

---

From: Jose Martinez <[email-masked]>
Date: Sun, 20 May 2001 12:37:19 -0700 (PDT)

Ranjit,

I dont want our SIP Proxy to timeout neither.  But we
our using a dynamicsoft proxy.  Will setting the
timeout to -1 or 0 set the timout to infinity on the
dynaimcsoft SIP stack.  Thnx a lot.

Jose
--- Ranjit Avasarala <[email-masked]>
> Chat with your friends as soon as they come online.

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - buy the things you want at great prices
http://auctions.yahoo.com/

---

From: "jinho Hwang" <[email-masked]>
Date: Mon, 21 May 2001 11:36:06 +0900

1.In this figure

if 11th BYE is sent by UAC and SPS does not receive the BYE message,
  How is the fee computation of Calling UA ? and a point in time of the
fee computation ?

2. In this figure

in Called UA which is received INVITE message,
How decides UAS whether this INVITE  is first INVITE or is second, 3th...
INVITE?
As 400 rejected Media message is sent by UAS, UAS must know the state of
INVITE message's counts.....

What do you think about 2 problem?...

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Mon, 21 May 2001 10:33:57 -0500

Hi
     I am not sure of the internal implementation of dynamicsoft SIP stack.
But ya setting timeout to -1 will make the proxy wait for infinite time.
u can also alternatively set the timeout to a specific value and wait for
that time  period.

Regards
Ranjit

----- Original Message -----
From: Jose Martinez <[email-masked]>
To: <[email-masked]>
Sent: Sunday, May 20, 2001 2:37 PM
Subject: Re: [SIP] timeout value for response

Ranjit,

Jose