Subject: [SIP] REFER before INVITE is completed

From: Itamar Gilad <[email-masked]>
Date: Wed, 9 May 2001 10:48:01 +0300

Can a REFER transaction occur before the INVITE that initiated the call is
completed?  For example:

   UA1                        UA2
   |          INVITE            |
   |--------------------------->|
   |                            |
   |          REFER             |
   |<---------------------------|
   |                            |
   |         202 (of REFER)     |
   |----------------------------|
   |                            |
   |         200 (of INVITE)    |
   |<---------------------------|
   |                            |
   |          ACK               |
   |--------------------------->|
   |                            |
   |                            |
      UA2 continues with REFER...

Itamar Gilad
RADVISION
[email-masked]           24 Raul Wallenberg St.
tel: +972 3 7659938                 Building D
mob: +972 56 429938                 Tel-Aviv 69719
fax: +972 3 6472637                 Israel

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Robert Sparks <[email-masked]>
Date: Wed, 9 May 2001 10:15:57 -0400

The session doesn't exist until the INVITE transaction completes,
so at best UA1 would treat that REFER as an out-of-session REFER.
If the REFER had the tags UA2 planned to place in the INVITE, it
would get 481'ed. 

Why would UA2 ever want to do this?

RjS

> -----Original Message-----
> From: Itamar Gilad [mailto:[email-masked]]
> Sent: Wednesday, May 09, 2001 2:48 AM
> To: 'SIP List'
> Subject: [SIP] REFER before INVITE is completed
> 
>