Subject: Re: [SIP] Are Contact headers mandatory in 2xx responses ?

From: [email-masked]
Date: Tue, 8 May 2001 14:30:42 -0500

Hi Ranjit,

rfc2543bis-02 says that contact header is a general header and not a contact
header.
Section 6.15 of the drafts says that the UAS MUST  insert a contact response
header
to indicate where it is reachable for future SIP requests.

-Deepak

"Ranjit Avasarala" <[email-masked]> on 05/16/2001 02:26:13 PM

Please respond to "Ranjit Avasarala" <[email-masked]>

Sent by:  "Ranjit Avasarala" <[email-masked]>

To:   "Don Jackson" <[email-masked]>, [email-masked]
cc:    (Deepak Pant/MW/US/3Com)
Subject:  Re: [SIP] Are Contact headers mandatory in 2xx responses ?

Hi
    Contact header is a request header. So it won't appear in response.

Regards
Ranjit

----- Original Message -----
From: Don Jackson <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, May 08, 2001 2:15 PM
Subject: [SIP] Are Contact headers mandatory in 2xx responses ?

In the bis 02 draft, on page 37, table 4

Header field         where  proxy ACK BYE CAN INV OPT REG

 Contact               2xx          -   -   -   m   o   o

Does this mean that when a UAS responds 2xx to an INVITE
that a Contact header is mandatory?  If not, what does this
mean?

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to
[email-masked] with "subscribe" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to
[email-masked] with "subscribe" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Wed, 16 May 2001 14:44:11 -0500

Deepak,

ya I agree with you, contact is a general header. My mistake.
and it appears in INVITE, OPTIONS , BYE and 2XX.

Regards
Ranjit

----- Original Message -----
From: <[email-masked]>
To: Ranjit Avasarala <[email-masked]>
Cc: Don Jackson <[email-masked]>; <[email-masked]>
Sent: Tuesday, May 08, 2001 2:30 PM
Subject: Re: [SIP] Are Contact headers mandatory in 2xx responses ?

Hi Ranjit,

-Deepak

Hi

Regards
Ranjit

----- Original Message -----
From: Don Jackson <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, May 08, 2001 2:15 PM
Subject: [SIP] Are Contact headers mandatory in 2xx responses ?

 Contact               2xx          -   -   -   m   o   o