Subject: RE: [SIP] Draft about diversion out of date

From: Igor Slepchin <[email-masked]>
Date: Mon, 7 May 2001 15:54:17 -0400

A motivation section and examples of functionality that require this
extension are conspicuously lacking in the current draft. Adding them may
help me understand why this draft is needed in the first place.

---
Igor Slepchin

> -----Original Message-----
> From: Bryan Byerly [mailto:[email-masked]]
> Sent: Friday, May 04, 2001 12:39 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [SIP] Draft about diversion out of date
> 
> 
> Hi Patrick,
> 
> There is an updated version of the I-D available.  I'll post it to the
> list shortly.
> 
> thanks,
> Bryan
> 
> [email-masked] wrote:
> 
> > Sirs,
> >
> > The following I-D "draft-levy-sip-diversion-01.txt" is now 
> out of date.
> > Could someone give us the future of that I-D:
> > -No longer used
> > -new version soon available,
> > -else ?
> >
> > TIA for your response,
> >
> > Patrick
> >
> > _______________________________________________
> > This list is for continuing development of the SIP protocol.
> > The sip-implementor's list is the place to discuss implementation,
> > and to receive advice on understanding existing sip.
> > To subscribe to it, send mail to
> > [email-masked] with "subscribe" 
> in the body.
> 
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementor's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to 
> [email-masked] with "subscribe" in the body.
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Bryan Byerly <[email-masked]>
Date: Mon, 07 May 2001 18:40:27 -0400

Hi Igor,

As I presented at the December 2000 IETF, the I-D is motivated by several
PSTN/SIP internetworking scenarios including:
Multiple diversions.
Diverting a call to an E.164 service.
Configuration issues (moving policy configuration to edges (UAs))

An ultimately called UAS can use the Diversion headers to implement a local
policy for his particular service.  For example, to answer the question:
Into which voice mailbox should a message be placed?  It's important to
understand that this is a policy decision; and as such should be
configurable at the ultimate edge of the voice network (i.e. move the smarts
to the edges).  The examples in section 9 do cover some of these issues.

Because there are some typos in the draft that need to get published, we'll
go ahead and release the -02 version.  However, we'll work on improving the
motivation scenarios for an -03 version.

thanks for your help,
Bryan

Bryan J. Byerly
[email-masked]