Subject: RE: [SIP] 3gpp--controoler?????

From: "Michael Junge-Pedersen (QRA)" <[email-masked]>
Date: Tue, 8 May 2001 11:05:36 +0200

Hi.
 
I think that there is one thing that should be stated here very clearly about the Controller/B2B-UA.
 
That is a session setup between users1 and user2 using the Controller will have two different call-id's
compared to an ordinary session setup directly from user1 to user2, which would hold the very same
call-id.
 
This provides the ''controller'' with the ability to manipulate each call-leg separately at a later 
state like after an external timer expires in the middle of an established session.
 
With kind regards, Michael Junge Pedersen.

-----Original Message-----
From: Brian Gracely [mailto:[email-masked]]
Sent: Wednesday, April 25, 2001 11:12 PM
To: kanumuri sreeram; Jonathan Rosenberg; 'Drage, Keith (Keith)'; 'Mayank Sharma'; Chen, Xin (Xin); [email-masked]'
Subject: Re: [SIP] 3gpp--controoler?????

the 3pcc controller can also be thought of as a back-to-back UA.....ie. 2 UAs in the same logical entity.  It terminates the signaling, but the media goes between points A & B.  it will need to be call-stateful, like a UA.

BG

At 12:18 PM 04/25/2001 -0700, kanumuri sreeram wrote:

hi all,

i have a douth regarding the 3pcc in sip.

i am clear that this is possible with the help of the controller.

like it is what which will take care of the signalling and the medai will be transfer will be taking place among them selves "true" i.e

A-------------CONTROLLER---------------------------B

  direct media transfer

===================================

ok but i am not claer about this entity controller can any one make me clear likw what is ?

if this is a different entity it should also be showm in the architecture of sip

like sipua,proxy,rediect,CONTROLLER....

so i am clear with me douth can anu one help me

sreeram

Do You Yahoo!?
Yahoo! Auctions <http://auctions.yahoo.com/>  - buy the things you want at great prices

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Ajay K. Garg" <[email-masked]>
Date: Thu, 10 May 2001 10:59:54 -0500

Where I can find more information about this controller. Please point me to
the right URL.

Thanks
-Ajay
> That is a session setup between users1 and user2 using the
> Controller will have two different call-id's
> To: kanumuri sreeram; Jonathan Rosenberg; 'Drage, Keith (Keith)';
> 'Mayank Sharma'; Chen, Xin (Xin); [email-masked]'
> the 3pcc controller can also be thought of as a back-to-back
> UA.....ie. 2 UAs in the same logical entity.  It terminates the
> signaling, but the media goes between points A & B.  it will need
> to be call-stateful, like a UA.
>
> BG
>
>
>
> I have a douth regarding the 3pcc in sip.
>
> I am clear that this is possible with the help of the controller.
>
> like it is what which will take care of the signaling and the
> media will be transfer will be taking place among them selves "true" i.e.
>
> ok but I am not clear about this entity controller can any one
> make me clear like what is ?
>
> if this is a different entity it should also be show in the
> architecture of sip
>
> so I am clear with me douth can anu one help me
>
> sreeram
>
>
>
>
>
>
>
>
> Do You Yahoo!?

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Thu, 10 May 2001 13:10:46 -0500

Ajay I think this is the document

http://www.fokus.gmd.de/research/cc/glone/projects/ipt/players/ietf/allsipdi
r/draft-mahy-sip-peer-3pcc-00.txt

Regards
Ranjit
Mascon Communication Technologies
http://www.masconit.com

----- Original Message -----
From: Ajay K. Garg <[email-masked]>
To: Sip Bell Labs <[email-masked]>
Sent: Thursday, May 10, 2001 10:59 AM
Subject: RE: [SIP] 3gpp--controoler?????

Thanks
-Ajay

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Thu, 10 May 2001 13:23:11 -0500

Hi
    I have a query related to back to back UA  i.e the controller. So is it
that controller's job is only call signaling part and not media?
    and will controller be a seperate entity . or could it be a part of
proxy server?

Regards
Ranjit

----- Original Message -----
From: Ajay K. Garg <[email-masked]>
To: Sip Bell Labs <[email-masked]>
Sent: Thursday, May 10, 2001 10:59 AM
Subject: RE: [SIP] 3gpp--controoler?????

Thanks
-Ajay

---

From: "Medhavi Bhatia" <[email-masked]>
Date: Thu, 10 May 2001 16:00:01 -0400

True, only signalling. However he may need to know the SDP
getting relayed across.

Controller does not have to be in the proxy. Its a very good way
to manipulate conferencing, and media server calls, so it can reside
on a separate entity which controls conferencing say.

However the proxy may impelement this function too.