Subject: [SIP] FW: SIP Session Timer NITS

From: Steve Donovan <[email-masked]>
Date: Thu, 24 May 2001 10:15:28 -0400

I am bringing a proposal from an off line discussion to the list, as it
proposes a change to the existing session timer specification.

-----Original Message-----
From: Jonathan Rosenberg 
Sent: Tuesday, May 08, 2001 11:13 PM
To: Steve Donovan; 'Sean Olson (EUS)'
Subject: RE: SIP Session Timer NITS

> -----Original Message-----
> From: Steve Donovan 
> Sent: Tuesday, May 08, 2001 3:07 PM
> To: 'Sean Olson (EUS)'; Steve Donovan; Jonathan Rosenberg
> Subject: RE: SIP Session Timer NITS
> 
> 
> 
> 3.  If a UAS crashes and reboots, then receives a re-INVITE 
>     refresh in which the To: has a tag parameter (informing 
>     the UAS that this was an ongoing session before the crash), 
>     shouldn't it be a MUST that the UAS insert a Session-Expires: 0 
>     and a Require: timer header? (Right now it is a SHOULD; first 
>     paragraph on page 9) 
> 
> SRD> Jonathan, can you comment on this.  I don't see a reason 
> it shouldn't be a MUST, but this was your wording.  Was there 
> something specific you were thinking about?

No; MUST would be appropriate. However, I'm not sure this bit is needed. 

The reason has to do with a decision we made at IETF 49. That decision was
to say that if a mid-call request generates a 481, the UAC considers the
call terminated. In that case, if a UAS gets a session timer refresh with a
tag, and doesn't want to reconstitute the call, it can just generate a 481
and that terminates the call. The bit on using session timer is an alternate
way to do it. I don't like it as much since it requires the session timer
extension to provide a function which really belongs (and now is) in the
baseline spec).

So, perhaps we should remove that text altogether...

---
Steven R. Donovan
Architect                           dynamicsoft                         
mailto:[email-masked]     5100 Tennyson Parkway
sip:[email-masked]    Plano, Texas 75025
tel:+1-972-473-5469                 http://www.dynamicsoft.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Brett Tate" <[email-masked]>
Date: Thu, 24 May 2001 14:02:41 -0400

My understanding is that the paragraph was 
explicitly added for a UAC that didn't add a 
From tag and couldn't distinguish an invite 
from re-invite.  This is no longer a 
possibility since email 
http://lists.bell-labs.com/pipermail/sip/2001q2/006912.html 
mentions the usage of tags is now mandatory for 
implementers of the timer draft.  Thus I 
agree that the text about adding Require timer 
and Session-Expires immediate can be removed.

I agree that a 481 is the best response when
a UAS chooses not to allow a dropped call-leg's 
session to be revived.

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Steve Donovan
> Sent: Thursday, May 24, 2001 10:15 AM
> To: [email-masked]'
> Subject: [SIP] FW: SIP Session Timer NITS
> 
>