Subject: [SIP] what UA does for a -ve response for HOLD/HOLD retrieve

From: "S.Kumar" <[email-masked]>
Date: Fri, 1 Jun 2001 00:27:16 +0530

hello all,

could any one explain what a SIP UA has to do for a -ve response for a HOLD
and HOLD retrieve messages. And how long a UA could remain in held state.

Thanks
S.Kumar

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Thu, 31 May 2001 19:56:06 -0500

Kumar,

consider the following scenario:

User A  and User B are in a call.
User A  sends a mid call INVITE request to User C that places the existing
call between A and B on HOLD.
Now if User C sends 200 OK to User A then it implies that INVITE was
successful.

or if  User A receives a non 200 OK response then it implies that INVITE was
not successful. The depending on the
type of response , corresponding action could be taken by User A.

Regards
Ranjit
Mascon Communication Technologies
http://www.masconit.com

----- Original Message -----
From: S.Kumar <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 31, 2001 1:57 PM
Subject: [SIP] what UA does for a -ve response for HOLD/HOLD retrieve

hello all,

Thanks
S.Kumar