Subject: RE: [SIP] SIP MGCP i/w

From: "Info Van" <[email-masked]>
Date: Wed, 16 May 2001 10:50:39 -0400

thanks for the insight, and the counter-questions have made me think as to why we might need such a document.

yes, it is a gateway in question. firstly, i am little more than uninitiated about H323, and only a little more welloff about SIP, so while going thru the SIP-H323 i/w draft, i came up with this idea of SIP-MGCP draft. i know, there could be similar situation in case of SIP-ISUP and SIP-Q931 i/w, but obviously they are very simple looking, but it gets a little more involved when you have to map "Information Elements"... obviously, not all IE's would make sense one a call-signal enters from ISUP/ISDN to SIP... so which to drop, which to keep or re-map. easy answer i believe is -- keep the mandatory (as they are mandatory) and think about optionals... is that how people are implementing ? is it totally on a case-by-case basis, and is this where people/vendors are trying to be competetive -- by differntiating they way they i/w (and to what extent they i/w ??)

thanks for any further insight... still my basic question is, why do we need SIP-H323 i/w draft, and not SIP-MGCP i/w draft. one reason i can think of right away is that SIP and MGCP are not mutually-exclusive, rather perform complementary functions, which SIP/H323 are alternatives (to a great extent) of each other ? am i right or wrong ?

thanks,
iv.

--

On Wed, 16 May 2001 10:20:00  
 Eric Burger wrote:
>What would you try to accomplish?  Is it a gateway, as Matt mentioned, or something else?
>
>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of Info Van
>Sent: Tuesday, May 15, 2001 12:10 PM
>To: SIP List
>Subject: [SIP] SIP MGCP i/w
>
>
>hi,
>
>in the SIP FAQ (http://www.cs.columbia.edu/~hgs/sip/faq.cgi) the answer to "Q. What is the relationship between MGCP and SIP?" [email-masked] writes that "The details of combining the two in a system are still being fleshed out"...
>
>is this still true, i mean are they still being fleshed out, or some document (draft maybe) is available to help with the interworking ?
>
>thanks,
>iv.
>
>
>Get 250 color business cards for FREE!
>http://businesscards.lycos.com/vp/fastpath/
>
>_______________________________________________
>This list is for continuing development of the SIP protocol.
>The sip-implementor's list is the place to discuss implementation,
>and to receive advice on understanding existing sip.
>To subscribe to it, send mail to 
>[email-masked] with "subscribe" in the body.
>
>

Get 250 color business cards for FREE!
http://businesscards.lycos.com/vp/fastpath/

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Info Van" <[email-masked]>
Date: Wed, 16 May 2001 12:36:52 -0400

thank you very much for your comments. i am posting this message with an obvious extra caution. i respect the "forum" and it's policies, but i can't help but try to take this discussion just 1 step further.

have the implementors/sip developers/contributors and WG looked at the proposals of MSF (www.msforum.org). they do believe in such a decomposition of UA under certain circumstances. i believe the motivation to keep this question of to decompose or not to, is left to implementor s.t. the applicability of SIP in general, remains more generic, than the "centralized" approach of traditional-telephony. also, another good place to look for very good (common-sensicle) ideas is TINA-C (www.tinac.com). i agree (and see your point) that SIP and MGCP are orthogonal, but like the SIP Hosts/Proxyserver's requirements (which tends to take a shape similar to the RFC defining requirements of internet routers/hosts), shouldn't it have some provision for this decomposed architecture too. is the WG sure that there is never going to be a SIP/MGCP document? not interworking, but use of MGCP in a decomposed SIP UA, type of document ?

anyway, this is my last post on this group regarding this topic.

thanks,
iv.
--

On Wed, 16 May 2001 11:03:06  
 Alan Johnston wrote:
>Hi,
>
>This discussion does not really belong on the SIP list, as it has nothing to do with developing the SIP protocol.  However, here's my comments.
>
>MGCP and SIP are completely orthogonal - they do not map from one to the other.  SIP is a pure signaling protocol used to locate endpoints and setup calls across the Internet between intelligent devices. MGCP is a device control protocol between a Master (controller) and a
>Slave (gateway).
>
>A SIP UA contains both a controller (SIP signaling) and gateway (RTP and user interface), so MGCP is just a way of decomposing a UA into two components, but you are left with only a UA, and not a complete SIP network of registrars, proxies, location servers, and UAs.
>
>I hope this helps - there is absolutely no need for this to be standardized.
>
>Alan Johnston
>WorldCom
>sip:[email-masked]
>
>Info Van wrote:
>
>> hi matt,
>>
>> >>"Q. What is the relationship between MGCP and SIP?"
>> ...
>> >>document (draft maybe) is available to help with the interworking ?
>>
>> >Why is such a document needed? This is not something that needs
>> >standardization, especially at this stage. Anyone can build an IWF that
>> >speaks MGCP out one interface and SIP out another. How they choose to make
>> >sense of each message is up to them. Let's not try to reproduce Q.699.
>>
>> do you think the DSS1/ISUP I/W document was unnecessary or not upto it's mark ? why i am asking this is because, i need to ascertain and justify to me and my peers that the task that's assigned to me, is really not worth "standardization effort". any arguments would help.
>>
>> thanks,
>> iv.
>>