Subject: [SIP] Record-Route in ACK

From: "Stefan Runeson (ECS)" <[email-masked]>
Date: Fri, 18 May 2001 09:23:22 +0200

Hi,

In rfc2543bis-02 Table 5 is stated that the Record-Route header is optional for _all_ methods. However, if the Record-Route header is used for ACK there might be a problem, since ACK has no response to carry the Record-Route header back. This might result in different routes for the different directions of the message flow of the same call-leg. I think that Record-Route header should be stated "Not applicable" for ACK.

BR
Stefan Runeson
Ericsson Mobile Communications AB
S - 221 83 Lund
SWEDEN

E-mail: mailto:[email-masked]
Phone:  +46 46 19 39 38

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Christian Jansson" <[email-masked]>
Date: Fri, 18 May 2001 13:17:05 +0200

We can't make rules for every weird situation that can happen. I think that
a server that Record-Routes the ACK without Record-Routing the INVITE is one
of those weird situations that shouldn't be dealt with because any sane
implementation would not do such a thing.

Christian Jansson
Hostip
www.hotsip.com

> Hi,
>
> In rfc2543bis-02 Table 5 is stated that the Record-Route header is
optional for _all_ methods. However, if the Record-Route header is used for
ACK there might be a problem, since ACK has no response to carry the
Record-Route header back. This might result in different routes for the
different directions of the message flow of the same call-leg. I think that
Record-Route header should be stated "Not applicable" for ACK.