Subject: [SIP] WWW-Authenticate in 2xx responses

From: "Brett Tate" <[email-masked]>
Date: Mon, 14 May 2001 15:57:57 -0400

The bis currently reflects that the WWW-Authenticate 
header can only be in requests and 401 responses.
Can the WWW-Authenticate header be passed within a 
2xx response (updating nonce) to hopefully avoid 
some extra 401's during subsequent 
registrations/requests directed to the same 
registrar/UAS?

The bis currently reflects that Proxy-Authenticate 
can only be in 401 and 407.  Can the Proxy-Authenticate 
header be passed within a 2xx response (updating nonce) 
to hopefully avoid some extra 401/407's for subsequent
requests/calls through an outbound proxies?

Any comments or pointers to email threads where 
this has been previously discussed?

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Jonathan Lennox <[email-masked]>
Date: Tue, 15 May 2001 10:27:48 -0400 (EDT)

> this has been previously discussed?

RFC 2617 defines Authentication-Info and Proxy-Authentication-Info response
headers for this purpose (a 'nextnonce' parameter) among other things.

Since bis now references 2617 rather than the older 2069 for authentication,
I imagine these headers are now incorporated by reference, even though
they're not explicitly mentioned in bis yet.

-- 
Jonathan Lennox
[email-masked]