Subject: [Sip] I-D ACTION:draft-ietf-sip-service-examples-02.txt

From: [email-masked]
Date: Wed, 27 Jun 2001 07:03:15 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Protocol Working Group of the IETF.

	Title		: SIP Service Examples
	Author(s)	: A. Johnston, R. Sparks, C. Cunningham, 
                          S. Donovan, K. Summers
	Filename	: draft-ietf-sip-service-examples-02.txt
	Pages		: 107
	Date		: 26-Jun-01
	
This informational document gives examples of SIP (Session Initiation
Protocol) services.  This covers most features offered in so-called
Centrex offerings from local exchange carriers and PBX (Private
Branch Exchange) features.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-sip-service-examples-02.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-sip-service-examples-02.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-sip-service-examples-02.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Alan Johnston <[email-masked]>
Date: Wed, 27 Jun 2001 15:11:27 -0500

This new version of the SIP Service Examples has the following changes:

   - Added Replaces header to flows involving attended transfer or call pickup.

   - Changed handling of call hold from responding to hold re-INVITE with hold SDP to
responding with normal SDP.

   - Added Contact and Referred-By headers and ref parameters to REFER  messages (hopefully
the URL escaping is correct)

   - Changed some Contacts, Routes, and Request-URIs to IP addresses.

   - Incremented o= line when SDP is updated with hold.

   - Added From tags throughout.

   - Renamed Music On Hold/Call Park call flow to Call Park and added new Music On Hold
call flow using 3pcc

Comments and suggestions are most welcome.

Thanks,
Alan Johnston
sip:[email-masked]

[email-masked] wrote:

>   ------------------------------------------------------------------------
>
>    draft-ietf-sip-service-examples-02.txtName: draft-ietf-sip-service-examples-02.txt
>                                          Type: Plain Text (text/plain)

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip