Subject: RE: [SIP] Re-invites in a multi-party call

From: Deepika Giri <[email-masked]>
Date: Wed, 13 Jun 2001 17:56:33 +0530

My conferencing model centralized in nature, where the conference
server/bridge does the mixing.  The usr A is not aware that he's connected
to the bridge, only the Conference Control application does the bridging of
all the users to the CB, this is using 3pcc.

As far as A is concerned, he knows that he is in conference with B and C,
so, he can put them on hold by sending them messages individually. right? or
can he send a single hold message that will put both of the users on hold?
how does a standard SIP phone do this?

what if there is a situation where there is one more user D in the
conference(brought in by C, whose presence A is not aware of?  He cannot
send a hold message to D, he doesn't even know he exists, unless the list of
participants in the conference is constantly given to each of the users.

THanks
Deepika
-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 4:40 AM
To: 'Deepika Giri'; Jonathan Rosenberg
Cc: [email-masked]
Subject: RE: [SIP] Re-invites in a multi-party call

> -----Original Message-----
> From: Deepika Giri [mailto:[email-masked]]
> Sent: Monday, June 11, 2001 6:03 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [SIP] Re-invites in a multi-party call
> 
> 
> Hi,
> 
> I am trying to implement a multi-party conference control 
> application in SIP
> using 3pcc.
> My problem is this:
> 
> Usr A is currently in a conference call with User B and C, 
> now it wishes to
> put the current conference call on hold, by sending a 
> re-INVITE, but what
> will be the sip request url for this re-invite, does it send 
> hold messages
> to B and C individually? 

This question cannot be answered without knowing what conferencing model is
being used. Conferencing models for SIP are discussed at length in:

http://search.ietf.org/internet-drafts/draft-rosenberg-sip-conferencing-mode
ls-00.txt

In the case of a dial-in conference server, you would hold the other
participants by sending a re-INVITE to the server itself, with a 0.0.0.0
SDP.

In the case of end system mixing, described in section 2 of the above
document, you would send a hold individually to all the other participants
being mixed.

You later write:
> That was not my question, not to put a single user on hold, I 
> need to put
> all "conference participants on hold".
> 
> Anyway, I think multi-cast should work as suggested by Iliff TIna.
> 

Multicast? The phrases "multicast" and "should work" are contradictory and
usually don't belong in the same sentence. In any case, multicast won't help
you in any way for anything but multicast conferences. In the case of a
multicast conference (where the media is distributed via multicast), there
is no possibility for a hold. You would simply stop listening for media.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: [email-masked]
Date: Wed, 13 Jun 2001 08:50:15 -0500

[Moving to IETF list]

> so, he can put them on hold by sending them messages 
> individually. right?

Not with the architecture you just described. As far as user A's
equipment is concerned, he is communicating with exactly one
party: the conference bridge. He will hold the conference bridge.

/a

_______________________________________________
Sip mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/sip