Subject: RE: [Sip] II digit & Calling Name

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 16 Jun 2001 02:12:18 -0400

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: Friday, June 15, 2001 5:24 PM
> To: Romel Khan; [email-masked]
> Subject: Re: [Sip] II digit & Calling Name
> 
> 
> 
> Something relevant might be contained in the Privacy draft - see:
> 
> http://www.softarmor.com/sipwg/drafts/draft-ietf-sip-privacy-02.txt

Its also worth noting that the caller prefernces extension defines Contact
parameters that can describe the endpoint making or answering the call. Some
folks had expressed an interest in registering some Contact params for
things like payphone and prison phone, once the spec went to RFC.

The privacy draft, to some degree, is inconsistent with the caller
preferences spec in this regard. For example, one of the rpi-id-types is
"return", which is more like the Contact, in that its a "device" address,
not a user identity.

One might also argue that, if you want to allow the network to provide and
validate a user identity, then you might want the network to provide and
validate a device identity (i.e., the Contact). This would argue for the
equivalent of remote-party-id for Contact. To be honest, I never understood
why we didn't have the header called Auth-From, and now we might want to
think about Auth-Contact.....

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

> ----- Original Message -----
> From: "Romel Khan" <[email-masked]>
> To: <[email-masked]>
> Sent: Friday, June 15, 2001 3:31 PM
> Subject: [Sip] II digit & Calling Name
> 
> 
> > Is there a way to pass the II digit (a.k.a. originating 
> line info, such
> as,
> > hotel/motel/prison/coin) over SIP?
> > Is there a way to pass Calling Name over SIP?
> >
> > Thanks.
> >
> > Romel Khan
> > Ph: (732)-363-0213, x241
> >
> >
> > _______________________________________________
> > Sip mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/sip
> >
> 
> 
> _______________________________________________
> Sip mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/sip
> 

_______________________________________________
Sip mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Sat, 16 Jun 2001 10:18:37 -0400

> "return", which is more like the Contact, in that its a "device" address,

My interpretation was that this was more of a logical address rather
than a device address, similar to the 'reply-to' header in email. For
example, you could imagine that you want all future calls (not
transactions within the call) to sales critter S to always go to
[email-masked]. (Or the example given in the spec, of providing an
800# for return calls in outgoing calls.)

If this difference is indeed correct, I believe it would be helpful if
the authors could clarify the call vs. transactions-within-call
distinction.

> think about Auth-Contact.....

It seems pretty clear that the privacy draft makes rather traditional
assumptions about the network architecture, for example, that the entity
doing the identity checking is implied and requires no identification.
However, without cryptographic authentication of the verifier, it's not
clear how useful this whole scheme is outside tightly constrained
network architectures and rather old-fashioned trust relationships.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs