Subject: [SIP] Proxy - A basic question

From: Varadarajan Srinivasan <[email-masked]>
Date: Thu, 07 Jun 2001 05:39:58 +0531

Hi,

From RFC, We are asked to look upon proxy as DNS sort.

Can I assume that UA "MUST"  be tagged to a proxy?
That is all calls to UA outside its domain should come via proxy?

Mr. Varadarajan Srinivasan,
Senior Systems Engineer,
Wipro Technologies.

---

From: "Bob Penfield" <[email-masked]>
Date: Wed, 6 Jun 2001 09:18:19 -0400

----- Original Message -----
From: "Varadarajan Srinivasan" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, June 06, 2001 8:08 PM
Subject: [SIP] Proxy - A basic question

> Can I assume that UA "MUST"  be tagged to a proxy?

The SIP spec does not require that UA to use a proxy.

> That is all calls to UA outside its domain should come via proxy?

If a UAC knows or can determine the IP address of the UAS and the UAC and
UAS are in the same "realm" (i.e. NAT and firewall are not an issue), it
does not have to go thru a proxy.

The presence of proxies in the network relieve UAs from having to figure out
the IP Address of the other end by providing location services. It can also
enable lots of other services.

> Mr. Varadarajan Srinivasan,

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Victor A Paulsamy" <[email-masked]>
Date: Wed, 6 Jun 2001 09:41:36 -0400

Hi Varadarajan,

  Even if an UA is calling another UA within the same domain, proxy receives
the call, looks up in the registration database, extracts Contact address
and forwards the call. To reach the callee directly, caller needs to know
the IP address and port of the callee, which is very unlikely in real life.

  Warm regards,

  --victor

   -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Varadarajan Srinivasan
  Sent: Wednesday, June 06, 2001 8:09 PM
  To: [email-masked]
  Subject: [SIP] Proxy - A basic question

  Hi,

---

From: "Dean Willis" <[email-masked]>
Date: Wed, 6 Jun 2001 11:09:50 -0500

Not really. For example, one of the SIP phones around my house is directly listed in dns. Incoming calls to its DNS name do not go through my proxy.

--
Dean

----- Original Message ----- 
  From: Varadarajan Srinivasan 
  To: [email-masked] 
  Sent: Wednesday, June 06, 2001 7:08 PM
  Subject: [SIP] Proxy - A basic question

  Hi,

---

From: Jose Martinez <[email-masked]>
Date: Wed, 6 Jun 2001 11:00:09 -0700 (PDT)

Why do they have to be in the same realm?

> > Mr. Varadarajan Srinivasan,

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/