Subject: [Sip] Consecutive REFERs

From: Itamar Gilad <[email-masked]>
Date: Tue, 26 Jun 2001 11:05:50 +0300

Below are a couple of questions regarding REFER scenarios and appropriate
response code usage. I'm sorry if this has been asked before.

1) A sends a REFER to B directing it to call C.  B sets up a call with C
successfully.  Now A sends another (new) REFER to B directing it to contact
D.  B wants to reject this REFER on the grounds that it currently can't take
additional calls.  Is 486 the appropriate response?

2) Same as A, but this time the second REFER directs B to call C again.  B
wants to reject this on the grounds that it already has a call-leg setup
with C.  What's the response code B should use here?
 
Thanks,

Itamar Gilad
RADVISION
[email-masked]               24 Raul Wallenberg St.
tel: +972 3 7659938                 Building D
cel: +972 56 429938                 Tel-Aviv 69719
fax: +972 3 6472637                 Israel

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Fri, 29 Jun 2001 10:17:12 -0400

> -----Original Message-----
> From: Itamar Gilad [mailto:[email-masked]]
> Sent: Tuesday, June 26, 2001 3:06 AM
> To: 'SIP list'
> Subject: [Sip] Consecutive REFERs
> 
> 

If the UA has asked the user at B to make the decision, or
was configured to do so, you could use a 603. If the agent
is making the decision, a 486 is reasonable. This is the
similar to the decision your agent would need to make if
a REFER showed up outside a call context from D while B 
was talking to C.

> with C.  What's the response code B should use here?

If B holds to that policy, 486 isn't insane (treating it
as an example of case 1). This is not much different from
the case that a REFER to C shows up out of band from
somewhere while B is already in a call with C.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 29 Jun 2001 15:11:07 -0400

> Sent: Tuesday, June 26, 2001 4:06 AM
> To: 'SIP list'

I'm actually curious why you ask. THe response code really shouldn't matter
unless you were planning to define logic at A that did something special
depending on the response code. Was that the case?

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com