Subject: RE: [Sip] Re: reason code in BYE/CANCEL (was[Sip-implementors] an other problem related to multiple call l egs at UAC)

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 29 Jun 2001 04:56:18 -0400

Ashar,

Thanks for the reminder about international support.

There is already support in SIP for management of internationalized reason
phrases. This is done through the Accept-Language header. A truly
internationalized server would be able to generate reason phrases in the
responses by figuring out the preferred language from the Accept-Language
header in the INVITE. I doubt any server actually does that, but the
facility is built into the protocol. 

So, for the Reason header in BYE/CANCEL, the same would be done. The UAC
generating a BYE would use the Accept-Language from the 2xx to the initial
INVITE response to figure out what language to use. Same with a proxy.

Would this require storing reason phrases, hardcoded into the UA, for each
language supported? Possibly. A more creative approach is to add an http
client and then access one of the many fine translation services on the web
to translate the reason phrases into the target language as needed. Either
way is an implementation choice.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Ashhar Farhan [mailto:[email-masked]]
> Sent: Thursday, June 28, 2001 1:05 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Sip] Re: reason code in BYE/CANCEL (was[Sip-implementors]
> another problem related to multiple call l egs at UAC)
> 
> 
> a message code alone is a better option rather than a text 
> alongwith it too. the reason is internationalism.
> 
> telephony, by definition involves spanning distances and 
> geographys and cultures. therefore, an english message 
> explaining the reason for call rejection (like 'Needs 
> Payment') may not make sense to an arab or a japanese. 
> however, reason code is easily localised to local dialects 
> and sensitivities. (in my city hyderabad, getting a message 
> like 'you dont have money in the bank to make this call' will 
> be considered very rude).
> 
> if the text message that goes along with a message is 
> customisable from message to message, it will effect 
> definitive interpretation of the reason code. on the other 
> hand, if the text message is not adding more intelligence to 
> the reason code, it is best to localy generate it on the UA.
> 
> as per the original rosenberg-henning vision, SIP is not 
> concerned with presentation layer, therefore, i dont see the 
> need for text messages. For instance, how do you interpret 
> these text messages to a display-less device like a POTS phone?
> 
> - [email-masked]
> 
> 
> 
> ____________________________________________________
> Buy Feng Shui Package for Rs. 151/- only, at 
> http://shopping.rediff.com/shopping/fengshui_mailer.htm
> 
> 
> 
> 
> _______________________________________________
> Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Michael Hammer <[email-masked]>
Date: Fri, 29 Jun 2001 09:52:51 -0400

>way is an implementation choice.

And to complete the picture, you are saying that the responsibility for 
using http to access the translation service and return the correct local 
display belongs to the UA and not a proxy, therefore, no protocol element 
is needed to convey that information to the UA other than the code 
number?  Or did I misread this?

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 29 Jun 2001 15:37:41 -0400

> From: Michael Hammer [mailto:[email-masked]]
> Sent: Friday, June 29, 2001 9:53 AM
> To: Jonathan Rosenberg
> Cc: 'Ashhar Farhan'; [email-masked]; [email-masked]
> Subject: RE: [Sip] Re: reason code in BYE/CANCEL 
> (was[Sip-implementors]
> an other problem related to multiple call l egs at UAC)
> 
> 
> display belongs to the UA and not a proxy, 

Yes. The entity sending the message should make the reason phrases in the
language of the recipient. This is not the job of the proxy.

-Jonathan R.
---