Subject: [SIP] SIP and IN services environment

From: [email-masked]
Date: Mon, 25 Jun 2001 16:30:41 +0200

Hello,
I am new in the SIP world, and  my English is not my native language, so please, be indulgent .

I make some mismatch with the following notions : SIP proxy /redirect server, the application server, the 3d Party Call control and the softwitch.

If I understand :
SIP PROXY : In a SIP request, the SIP proxy can change the URI, add or delete a Via field and add or delete data into the record-route field.
The SIP Proxy can originate a CANCEL but not a BYE.
Controller : A 3d Party Call Control or controller is able to create, modify and terminate call with other entities.
So the controller is allowed to modify all the fields of the Header and the body of a SIP INVITE coming from a Caller , in order to re-route the call to a different entity than the original callee such as a media server, it is called B2BUA .
 Does the controller manage is own call ID and CSeq or it has to take the call ID from the Caller INVITE ?
A Controller can Initiate a  call leg to a Media Server, in order for example, to play mid-call announcement.
The application server can act as a Controller.  The application server provides  services not the controller.

About the mapping with the IN :
Can we make the correlation between the SSP in a IN environment and the Controller B2BUA in a SIP environment ??

About the notion of Softswitch :
Does the softswitch can act as an extended proxy or a controller or an application server? Or it must act as a controller only ?

Thank you

Pierre

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Vijay Gurbani <[email-masked]>
Date: Mon, 25 Jun 2001 11:14:51 -0500

[...Pierre -- the SIP WG list has moved to [email-masked], please make a note
    of it...]

[email-masked] wrote:
> I make some mismatch with the following notions : SIP proxy /redirect 
> server, the application server, the 3d Party Call control and the 
> softwitch.
> 
> If I understand :
> SIP PROXY : In a SIP request, the SIP proxy can change the URI, add or 
> delete a Via field and add or delete data into the record-route field.

It can only add/delete *it's* Via field; add a R-R with *it's* URI, and
remove a Route with *it's* URI.

> Controller B2BUA in a SIP environment ??

Sort of; see the following I-Ds on this:

http://search.ietf.org/internet-drafts/draft-gurbani-iptel-sip-to-in-04.txt
http://search.ietf.org/internet-drafts/draft-gurbani-iptel-sip-in-imp-01.txt
http://search.ietf.org/internet-drafts/draft-haerens-sip-in-00.txt

Also, there is an IETF design team on SIP/IN interworking.  Interested
parties can contact me privately and I can fill you in on the current
happenings in the design team.

Regards,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip