Subject: [SIP] Registrar cancelation of registers

From: "David Simons" <[email-masked]>
Date: Mon, 11 Jun 2001 17:19:58 -0700

One of the limitation I see in SIP is that a registrar has no way of
indicating to a UAC that it's registration is no longer valid.  There
doesn't seem to be a mechanism to cancel registrations.  I can think of
two scenarios were this could be very useful.  First, a registrar needs
to shutdown but it has recently accepted one hour registrations.  It
would be nice if the registrar could indicate to the UAC that its
registration is no longer valid and should re-register after a while.
In the second scenario a service wants to minimize the amount of
resources that a users consumes on the Registrar.  This could be done by
deigning new registration but the new registrations are the ones most
likely to be called successfully.  Or you could say you want to remove
registration for the lowest q-values.  I'd be interesting in the
thoughts of others on this group.

One solution I've considered is to send a CANCEL with the same FROM, TO,
and Call-ID as the REGISTER to the UAC, In effect canceling the
registration.  This doesn't seem to conform to RFC2543bis03.  This
solution would be canceling a request that had a final reply.   Also the
CANCEL wouldn't be sent by the requester.  Then there is the use of BYE
that could be an option but BYE only seems to address INVITE.

Comments?

Regards, 

David J. Simons
Development Lead
Microsoft Windows RTC

---

From: Michael Thomas <[email-masked]>
Date: Mon, 11 Jun 2001 17:48:39 -0700 (PDT)

Funny, DNS has the exact same problem and nobody
to my knowledge is trying to back annotate changes
in status into DNS records. Either DNS servers
never go down, or I expect that similar methods of
dealing with highly available do-dads might be
appropriate for SIP registrars.

	      Mike

David Simons writes:
 > <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
 > <HTML>
 > <HEAD>
 > <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii">
 > <META NAME="Generator" CONTENT="MS Exchange Server version 6.0.4712.0">
 > <TITLE>Registrar cancelation of registers</TITLE>
 > </HEAD>
 > <BODY>
 > <!-- Converted from text/rtf format -->
 > 
 > 
 > 
 > <P ALIGN=LEFT><SPAN LANG="en-us"><FONT SIZE=2 FACE="Arial">Comments</FONT></SPAN><SPAN LANG="en-us"></SPAN><SPAN LANG="en-us"><FONT SIZE=2 FACE="Arial">?</FONT></SPAN></P>
 > 
 > <P ALIGN=LEFT><SPAN LANG="en-us"><FONT SIZE=2 FACE="Arial">Regards,</FONT></SPAN><SPAN LANG="en-us"></SPAN><SPAN LANG="en-us"><FONT SIZE=2 FACE="Arial"></FONT></SPAN><SPAN LANG="en-us"></SPAN><SPAN LANG="en-us"> </SPAN></P>
 > 
 > <P ALIGN=LEFT><SPAN LANG="en"></SPAN><A NAME=""><SPAN LANG="en"><FONT COLOR="#0000FF" FACE="Monotype Corsiva">David J. Simons</FONT></SPAN></A><SPAN LANG="en-us"></SPAN><SPAN LANG="en-us"></SPAN><SPAN LANG="en"></SPAN></P>
 > 
 > <P ALIGN=LEFT><I><SPAN LANG="en"><FONT COLOR="#008080" SIZE=2 FACE="Monotype Corsiva">Development Lead</FONT></SPAN></I></P>
 > 
 > <P ALIGN=LEFT><I><SPAN LANG="en"><FONT COLOR="#008080" SIZE=2 FACE="Monotype Corsiva">Microsoft Windows RTC</FONT></SPAN></I></P>
 > 
 > <P ALIGN=LEFT><SPAN LANG="en-us"></SPAN></P>
 > 
 > </BODY>
 > </HTML>�����������������������������������ӆ+%��b��+r��{��^��h�g�����>�趇(���zȩ�)��鞞�+��b�ج������b�ˬ�)��鞞֭���jwm���z+�i��q�'�w^��Z�ا��b�ا�ȩ�:,���&޶���ǧvf���,��⚙^��������z��r�ܢ[�n&�y۰������r��{�������

---

From: [email-masked]
Date: Tue, 12 Jun 2001 09:23:42 -0500

If the clients don't care, this is correct -- there is no way for
registrars to indicate this information. This issue has been raised
uncountable times over the past couple of years on the list; the
group consensus is that we will not add a mandatory mechanism for
this sort of thing.

On the other hand, the presence work going on in the SIMPLE working
group *does* provide an interesting mechanism to provide the same
functionality -- assuming, that is, that the client cares.

If a client *wants* to be notified when his registration is no longer
valid, he may send a SUBSCRIBE message for his own presence to his
registrar. In this way, just like anyone else subscribed to his
presence, he will receive a NOTIFY message when his registration
disappears.

See http://www.ietf.org/internet-drafts/draft-ietf-simple-presence-00.txt
for further details on presence and SIP.

/a

-----Original Message-----
From: David Simons [mailto:[email-masked]]
Sent: Monday, June 11, 2001 7:20 PM
To: [email-masked]
Cc: David Simons; Robert Brown
Subject: [SIP] Registrar cancelation of registers

One of the limitation I see in SIP is that a registrar has no way of indicating
to a UAC that it’s registration is no longer valid.  There doesn’t seem to be a
mechanism to cancel registrations.  I can think of two scenarios were this
could be very useful.  First, a registrar needs to shutdown but it has recently
accepted one hour registrations.  It would be nice if the registrar could
indicate to the UAC that its registration is no longer valid and should
re-register after a while.  In the second scenario a service wants to minimize
the amount of resources that a users consumes on the Registrar.  This could be
done by deigning new registration but the new registrations are the ones most
likely to be called successfully.  Or you could say you want to remove
registration for the lowest q-values.  I’d be interesting in the thoughts of
others on this group.
One solution I’ve considered is to send a CANCEL with the same FROM, TO, and
Call-ID as the REGISTER to the UAC, In effect canceling the registration.  This
doesn’t seem to conform to RFC2543bis03.  This solution would be canceling a
request that had a final reply.   Also the CANCEL wouldn’t be sent by the
requester.  Then there is the use of BYE that could be an option but BYE only
seems to address INVITE.
Comments?
Regards,
David J. Simons
Development Lead
Microsoft Windows RTC

_______________________________________________
Sip mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/sip