Subject: RE: [SIP] Replaces leg matching (was Re: [Sip-implementors] repla ces)

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 26 Jun 2001 00:51:21 -0400

> -----Original Message-----
> From: Billy Biggs [mailto:[email-masked]]
> Sent: Tuesday, June 26, 2001 12:27 AM
> To: Jonathan Rosenberg
> Cc: Alan Johnston; Dvir Oren; SIP List
> Subject: Re: [SIP] Replaces leg matching (was Re: [Sip-implementors]
> repla ces)
> 
> 
> Jonathan Rosenberg ([email-masked]):
> 
> > >   Since the Call-ID is unique, I don't see a matching problem.  We
> > > can also recommend that any UA which supports Replaces must also
> > > support bis (at least use tags).
> > 
> > Another practical issue worth considering is that many 
> implementations
> > in gateways store call leg objects indexed by the hash of 
> the call leg
> > ID.  There is no direct index of calls based on call-id, since its
> > really not needed. Therefore, it becomes a practical problem to find
> > the matching call leg with just the call-id.
> 
>   This would be solved by having the full to and from in the 
> header, but
> putting instead a hash would just mean standardizing the hash function
> used by gateways, or force them to index by another hash.
> 
>   If we're forcing them to index on another hash, I'd rather just let
> that be the call-id + tags.
> 
>   Nasty situation regardless.

I don't want to standardize this hash. What is the issue with just including
the full To, From, Call-ID along with tags? Just the length?

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Billy Biggs <[email-masked]>
Date: Tue, 26 Jun 2001 09:51:34 -0400

Jonathan Rosenberg ([email-masked]):

> >   This would be solved by having the full to and from in the header,
> > but putting instead a hash would just mean standardizing the hash
> > function used by gateways, or force them to index by another hash.
> > 
> >   If we're forcing them to index on another hash, I'd rather just
> > let that be the call-id + tags.
> > 
> I don't want to standardize this hash. What is the issue with just
> including the full To, From, Call-ID along with tags? Just the length?

  The length and the escaping, since the full To and From includes all
parameters, some of which may be quoted strings, etc etc.

-- 
Billy Biggs                     [email-masked]
http://www.billybiggs.com/      [email-masked]