Subject: [SIP] (no subject)

From: "Ashwani Kumar Kesharwani" <[email-masked]>
Date: Wed, 6 Jun 2001 10:22:52 +0530

Hi

When a request goes through more than one proxy how does a proxy decides about the next proxy.

Thanks

---

From: Varadarajan Srinivasan <[email-masked]>
Date: Thu, 07 Jun 2001 04:05:22 +0531

Hi,

Proxy consults Location Server( Database) and finds the proxy URI which
can handle this request (
need not be the proxy in which UAS in there).

On issuing Request, it will put the new Request_URI in request line of
the INVITE message and sends out.

Anyways, routing is done at third layer. It it just the URI we can
mention in SIP.

Cheers,
Varadarajan

URI)Ashwani Kumar Kesharwani wrote:

> Hi When a request goes through more than one proxy how does a proxy
> decides about the next proxy.  Thanks

Mr. Varadarajan Srinivasan,
Senior Systems Engineer,
Wipro Technologies.

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Wed, 6 Jun 2001 10:08:25 -0500

see my comments inline.....
Regards
Ranjit
Mascon Communication Technologies
http://www.masconit.com

  ----- Original Message -----
  From: Ashwani Kumar Kesharwani
  To: [email-masked]
  Sent: Tuesday, June 05, 2001 11:52 PM
  Subject: [SIP] (no subject)

  Hi

  When a request goes through more than one proxy how does a proxy decides
about the next proxy.

   usually every LAN could have an inbound and outbound proxy. so when u
send ur request to a proxy, proxy will know if the destination UA
  is within its network or another network. then it will fwd the request to
another proxy.
  Thanks

---

From: Jose Martinez <[email-masked]>
Date: Wed, 6 Jun 2001 11:13:40 -0700 (PDT)

To answer the your question 'HOW it dedides' that
depends on the proxy server.  There are different
conditions in which a proxy will contact a another
proxy.  It might not even know that it is contacting
another proxy.  You can put a perminent register, a
register that does not timeout, on a proxy for a
specific number.  Everytime that number is rung up the
proxy will forward the request to whoever is
registered.  Another way is to use some sort of phone
route that forwards the request to a specified IP
address.  You can also setup the proxyZ to redirect to
another proxyX, in this case the proxyZ does not
forward but instead tells the source of the request to
try proxyX.  Hope that helped somewhat.  
--- Ashwani Kumar Kesharwani
<[email-masked]> wrote:
> Hi
> 
> When a request goes through more than one proxy how
> does a proxy decides about the next proxy.
> 
> 
> Thanks
> 

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.