Subject: RE: [Sip] Few tiny issues with SDP section of bis3

From: "Mohsen Soroush-nejad" <[email-masked]>
Date: Wed, 13 Jun 2001 12:27:39 -0700

Section 6 of RFC 2327 lists all the SDP fields. The optional
fields are identified by "*". "e" & "p" are identified as optional....

Mohsen
-----Original Message-----
From: Flemming Andreasen [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 12:17 PM
To: Anders Kristensen
Cc: Jonathan Rosenberg; 'Cullen Jennings'; [email-masked]
Subject: Re: [Sip] Few tiny issues with SDP section of bis3

That's far from clear if you read it in the context it was provided in.
Also, do
note that both of these fields are in fact listed as optional earlier in the
spec.

-- Flemming

Anders Kristensen wrote:

> It's required by RFC 2327 (no idea why, though:
>
>    o Either an email field or a phone field must be specified.
>      Additional email and phone fields are allowed.
>
> Thanks,
> Anders
>
> Flemming Andreasen wrote:
> >
> > Jonathan Rosenberg wrote:
> >
> > >
> > >
> > > > -----Original Message-----
> > > > From: Cullen Jennings [mailto:[email-masked]]
> > > > Sent: Monday, June 11, 2001 3:15 PM
> > > > To: [email-masked]
> > > > Subject: [Sip] Few tiny issues with SDP section of bis3
> > > >
> > > >
> > > >
> > > > Examples in section B don't have an e or P line in the SDP
> > > > even though one
> > > > them must be present.
> > >
> > > OK, I fixed that.
> >
> > Speaking of that: Why is there now a requirement in the SDP section
stating
> > that "Either an e line or p line MUST be present." ?
> >
> > -- Flemming
> >
> > --
> > Flemming Andreasen
> > Cisco Systems
> >
> > _______________________________________________
> > Sip mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/sip

--
Flemming Andreasen
Cisco Systems

_______________________________________________
Sip mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/sip

_______________________________________________
Sip mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/sip

---

From: Anders Kristensen <[email-masked]>
Date: Wed, 13 Jun 2001 15:36:14 -0400

They're optional in the grammar, but the accompanying text seems
perfectly clear that one or the other must be present. Sometimes it's
more convenient to state requirements in english than BNF - doesn't mean
it's not part of the spec. I'm pretty sure that the quoted sentence is
the only reason it's required for SIP.

Anders