Subject: RE: [SIP] Invitation for a multicast session

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 3 Jun 2001 23:42:56 -0400

> -----Original Message-----
> From: Baniel Uri-CUB001 [mailto:[email-masked]]
> Sent: Sunday, June 03, 2001 8:58 AM
> To: 'Jonathan Rosenberg'; [email-masked]
> Subject: RE: [SIP] Invitation for a multicast session
> 
> 
> So just to be 100% sure that I got this one right once and 
> for all... say I like to invite A, B, C and D who belong to 
> the same multicast group, to a conf call (mbone session). Say 
> I like to invite them by multicast means.
> Do I have to multicast 4 Invites (each with a different 
> request-URI and To fields(e.g. [email-masked], [email-masked], 
> etc.,) or one multicast will do?? 

Sending the same request four times would completely defeat the purpose of
using multicast in the first place. The whole idea with multicast is that
you don't know how many recipients there are. So, the answer is "one
multicast will do".

If one will do, what will 
> be the request-URI? What will be the To?
> Based on your message below I think we need 4 invitations, 
> but just to be on the safe side...

INVITE sip:[email-masked] SIP/2.0
From: "Me" <sip:[email-masked]>
To: "The Gaggle" <sip:[email-masked]>
Via: SIP/2.0/UDP 1.2.3.4;maddr=224.2.3.4;ttl=2

Of course, each user in the group would need to be prepared to accept
request sfor [email-masked]. Once one decides to accept, they send a 200
OK. This triggers a CANCEL by the UAC. As a result, the caller is connected
to one of the members of this group, whomever it might be. What SIP cannot
do is help you generate a request so that a call is connected to ALL members
of the group (this really requires reliable multicast to avoid response
implosion). You'll only get the first to answer.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "suncz" <[email-masked]>
Date: Mon, 4 Jun 2001 13:46:25 +0800

I have a question about the Call ID.If sending the same request  four times to A,B,C and D respectively for the same conference,the reqest's Call ID is same?
And how to write the To head field ?
Thanks in advance.

Best regards,

Yours sincerely,
Chengzhen Sun
-------------------------------------------------

Standardization Department
Mobile Communication R&D Center
China Academy of Telecommunication Technology(CATT)
No.40,Xueyuan Road
Beijing,China
100083
Tel:+8610 62304422EXT227
Fax:+8610 62303127
Mailto:[email-masked]
-------------------------------------------------- 
 
----- Original Message ----- 
From: "Jonathan Rosenberg" <[email-masked]>
To: "'Baniel Uri-CUB001'" <[email-masked]>; <[email-masked]>
Sent: Monday, June 04, 2001 11:42 AM
Subject: RE: [SIP] Invitation for a multicast session

> http://www.dynamicsoft.com
ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÓ†+%ŠËb±ú+r‰íŠ{¢ž^½éh¦g§¶‡í…äˆ>šè¶‡(—ôázÈ©þ)©•éžžÚ+þÉb²Ø¬¶©•§¶‡b±Ë¬²)©•éžžÖ­Š‰ÿjwm¢·œz+ÞiÛâqê'ºw^®ËZØ§ìb²Ø§‚È©ý:,¹»®&Þ¶ˆþÇ§vf¢–Ú,ŠŸâš™^™éí¢»ÿê®zËÿrÏÜ¢[¦n&ÿyÛ°ŠØÿ²æìr¸›{ø§¶›¡Üÿ

---

From: "Gautham A N" <[email-masked]>
Date: Mon, 4 Jun 2001 11:31:58 -0500

hi Chengzhen Sun,
    The Call ID is different for each of the requests.
gautham

----- Original Message -----
From: suncz <[email-masked]>
To: Jonathan Rosenberg <[email-masked]>; 'Baniel Uri-CUB001'
<[email-masked]>; <[email-masked]>
Sent: Monday, June 04, 2001 12:46 AM
Subject: Re: [SIP] Invitation for a multicast session

> I have a question about the Call ID.If sending the same request  four
times to A,B,C and D respectively for the same conference,the reqest's Call
ID is same?
> N-+SÇ­Ê¶)Sxz÷¢TzÚ¶ ú¢Ú¢TzÈSjzg¶S-+SËzTqëv+ºËsTTéjØ©¶Sqèy§?Çzéz»jwzSËz
¥:¹»®&¶^±éT¨¶<"¦)©.ézzÚ+²·ª¹ë-rÇ(-é>?§»?Ë>±Êâmè§¶>