Subject: RE: [SIP] Re-invites in a multi-party call

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 21 Jun 2001 12:52:49 -0400

> -----Original Message-----
> From: Michael Hammer [mailto:[email-masked]]
> Sent: Thursday, June 21, 2001 9:50 AM
> To: Jonathan Rosenberg
> Cc: 'Deepika Giri'; [email-masked]'
> Subject: RE: [SIP] Re-invites in a multi-party call
> 
> 
> In the centralized model, is the concept that one controls the other 
> parties streams or that one controls the flows to/from 
> oneself? 

To/from oneself, just like a regular call.

> That is, 
> when I do a hold, I am not putting other parties on hold from 
> the bridge, I 
> am putting myself on hold from the bridge. 

Right. If you send a re-INVITE with 0.0.0.0 in the SDP, you will stop
receiving media. This has nothing to do with anyone else.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

> > > -----Original Message-----
> > > From: Deepika Giri [mailto:[email-masked]]
> > > Sent: Wednesday, June 13, 2001 8:27 AM
> > > To: Jonathan Rosenberg
> > > Cc: [email-masked]
> > > Subject: RE: [SIP] Re-invites in a multi-party call
> > >
> > >
> > > My conferencing model centralized in nature, where the conference
> > > server/bridge does the mixing.  The usr A is not aware that
> > > he's connected
> > > to the bridge, only the Conference Control application does
> > > the bridging of
> > > all the users to the CB, this is using 3pcc.
> > >
> > > As far as A is concerned, he knows that he is in conference
> > > with B and C,
> > > so, he can put them on hold by sending them messages
> > > individually. right? or
> > > can he send a single hold message that will put both of the
> > > users on hold?
> > > how does a standard SIP phone do this?
> >
> >Adam responded:
> > > Not with the architecture you just described. As far as user A's
> > > equipment is concerned, he is communicating with exactly one
> > > party: the conference bridge. He will hold the conference bridge.
> >
> >That is correct. To add to that, it doesn't even make sense. 
> If A sends a
> >hold to C, so that C stops sending media to the mixer, then 
> B will not hear
> >A. That doesn't make sense.
> >
> >Perhaps what you want is that A gets to decide that it 
> doesn't want to hear
> >C anymore, but that B should still continue to hear C. To do 
> this, you need
> >a conference control protocol in order to set the mixing 
> matrix used by the
> >bridge. There is not yet a standardized protocol, but I 
> would note that
> >using a web interface to control this can get you a very long way.
> >
> > >
> > > what if there is a situation where there is one more user D in the
> > > conference(brought in by C, whose presence A is not aware of?
> > >  He cannot
> > > send a hold message to D, he doesn't even know he exists,
> > > unless the list of
> > > participants in the conference is constantly given to each of
> > > the users.
> >
> >No, there is a direct SIP signaling relationship between 
> each user an the
> >bridge. There are no other SIP relationships.
> >
> >-Jonathan R.
> >
> >---
> >Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> >Chief Scientist                             First Floor
> >dynamicsoft                                 East Hanover, NJ 07936
> >[email-masked]                     FAX:   (973) 952-5050
> >http://www.jdrosen.net                      PHONE: (973) 952-5000
> >http://www.dynamicsoft.com
> >
> >_______________________________________________
> >Sip mailing list
> >[email-masked]
> >http://www.ietf.org/mailman/listinfo/sip
> 

_______________________________________________
Sip mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/sip

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 21 Jun 2001 19:00:40 -0400

Jonathan Rosenberg wrote:
[snip] 
> receiving media. This has nothing to do with anyone else.

This is really only true with cooperative partners isn't it?

I have asked the other party to stop sending media,
but if he ignores my request and continues sending, and if I
am still using the socket (perhaps for some other call),
then I will still receive what he sends.

	Paul Kyzivat
	Cisco Systems

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip