Subject: RE: [SIP] Proxy - A simple question

From: "Iliff, Tina" <[email-masked]>
Date: Thu, 07 Jun 2001 14:17:01 +0000

Let me correct myself here as well..I was only referring to INVITE Requests.
However, if a proxy has inserted a Record-Route Header in any initial
transaction responses from the UAS, then subsequent BYE, OPTIONS, etc
Requests must pass through the proxy.
Correct?

Tina Iliff

 -----Original Message-----
From: 	Iliff, Tina  
Sent:	Thursday, June 07, 2001 8:50 AM
To:	'Provin Gurung'; Ashwani Kumar Kesharwani
Cc:	Varadarajan Srinivasan; [email-masked]
Subject:	RE: [SIP] Proxy - A simple question

Let me get back on track with the original question:  Typically, subsequent
requests involve changes in SDP content.  Transaction Stateful proxies do
not need to be involved in these sorts of transactions.

Tina Iliff

 -----Original Message-----
From: 	Provin Gurung [mailto:[email-masked]] 
Sent:	Thursday, June 07, 2001 12:48 AM
To:	Ashwani Kumar Kesharwani
Cc:	Varadarajan Srinivasan; [email-masked]
Subject:	Re: [SIP] Proxy - A simple question

On Thu, 7 Jun 2001, Ashwani Kumar Kesharwani wrote:

> Hi It is actually like this.
> With in first request UAC provides its contact address so that UAS sends a
> final response at the contact address mentioned rather than sending it
> through all the proxies.

I think there is a slight misunderstanding here,
The contact is there so that future requests from the called
UA can be sent directly to the calling UA. All the responses *must*
traverse back the same path that the request followed, i.e responses are
forwarded to the top via field of the SIP message. The responses cannot
bypass the proxies. 

Proveen Gurung

Telcordia Technologies,
MCC-1H-209R,
445,South Street,
Morristown,NJ,USA-07960-6438
Tel (973)829-2323

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Provin Gurung <[email-masked]>
Date: Thu, 7 Jun 2001 13:06:00 -0400 (EDT)

You are correct, if a Record Route header is present, all future
requests/responses travel through the proxies that inserted the
Record-Route header, irrespective of the
direction the request/response is travelling (from calling to called or
vice versa)
Also irrespective of the proxy being stateful or stateless, the responses
always travel the same path back. Btw there is no way for an UAS
downstream to determine if the proxy that forwarded the request is a
stateful or stateless. So without making any assumption the rule is to use
the via field to forward the message upstream. Also when a stateless
proxy receives a response it removes its Via field and forwards the
response upstream using the next via field.

-Provin.

> Morristown,NJ,USA-07960-6438

Telcordia Technologies,
MCC-1H-209R,
445,South Street,
Morristown,NJ-07960-6438
Tel (973)829-2323