Subject: RE: [SIP] Proxy - A simple question

From: "Iliff, Tina" <[email-masked]>
Date: Thu, 07 Jun 2001 13:40:57 +0000

What about the case of a Stateless proxy?
A stateful proxy would insert a Record-Route and this would cause the
responses to traverse via the proxy.  However, with a stateless proxy the
responses can go directly to the originating UAC.
Tina Iliff

 -----Original Message-----
From: 	Provin Gurung [mailto:[email-masked]] 
Sent:	Thursday, June 07, 2001 12:48 AM
To:	Ashwani Kumar Kesharwani
Cc:	Varadarajan Srinivasan; [email-masked]
Subject:	Re: [SIP] Proxy - A simple question

On Thu, 7 Jun 2001, Ashwani Kumar Kesharwani wrote:

> Hi It is actually like this.
> With in first request UAC provides its contact address so that UAS sends a
> final response at the contact address mentioned rather than sending it
> through all the proxies.

I think there is a slight misunderstanding here,
The contact is there so that future requests from the called
UA can be sent directly to the calling UA. All the responses *must*
traverse back the same path that the request followed, i.e responses are
forwarded to the top via field of the SIP message. The responses cannot
bypass the proxies. 

Proveen Gurung

Telcordia Technologies,
MCC-1H-209R,
445,South Street,
Morristown,NJ,USA-07960-6438
Tel (973)829-2323

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Iliff, Tina" <[email-masked]>
Date: Thu, 07 Jun 2001 13:45:52 +0000

If a UAC knows the IP address of the UAS with which it wishes to
communicate, then the transaction can happen directly without the Request
going through a proxy.

Tina Iliff

 -----Original Message-----
From: 	Provin Gurung [mailto:[email-masked]] 
Sent:	Thursday, June 07, 2001 12:48 AM
To:	Ashwani Kumar Kesharwani
Cc:	Varadarajan Srinivasan; [email-masked]
Subject:	Re: [SIP] Proxy - A simple question

Proveen Gurung

Telcordia Technologies,
MCC-1H-209R,
445,South Street,

---

From: "Iliff, Tina" <[email-masked]>
Date: Thu, 07 Jun 2001 13:49:50 +0000

Let me get back on track with the original question:  Typically, subsequent
requests involve changes in SDP content.  Transaction Stateful proxies do
not need to be involved in these sorts of transactions.

Tina Iliff

 -----Original Message-----
From: 	Provin Gurung [mailto:[email-masked]] 
Sent:	Thursday, June 07, 2001 12:48 AM
To:	Ashwani Kumar Kesharwani
Cc:	Varadarajan Srinivasan; [email-masked]
Subject:	Re: [SIP] Proxy - A simple question

Proveen Gurung

Telcordia Technologies,
MCC-1H-209R,
445,South Street,

---

From: "MPJ Krishna" <[email-masked]>
Date: Thu, 7 Jun 2001 09:53:23 -0400

Responses are routed using the Via header field not the Record-Route.

Krishna

"Iliff, Tina" <[email-masked]> on 06/07/2001 09:40:57 AM

To:   "'Provin Gurung'" <[email-masked]>, Ashwani Kumar
      Kesharwani <[email-masked]>
cc:   Varadarajan Srinivasan <[email-masked]>,
      [email-masked] (bcc: MPJ Krishna/Raleigh/TEKELEC)
Subject:  RE: [SIP] Proxy - A simple question

 -----Original Message-----
From:     Provin Gurung [mailto:[email-masked]]
Sent:     Thursday, June 07, 2001 12:48 AM
To:  Ashwani Kumar Kesharwani
Cc:  Varadarajan Srinivasan; [email-masked]
Subject:  Re: [SIP] Proxy - A simple question

Proveen Gurung

Telcordia Technologies,
MCC-1H-209R,
445,South Street,

---

From: "Iliff, Tina" <[email-masked]>
Date: Thu, 07 Jun 2001 14:04:18 +0000

Thank you.  I just about to post another e-mail and apologize for my
incorrect statement.

Tina Iliff

 -----Original Message-----
From: 	MPJ Krishna [mailto:[email-masked]] 
Sent:	Thursday, June 07, 2001 8:53 AM
To:	Iliff, Tina
Cc:	'Provin Gurung'; Ashwani Kumar Kesharwani; Varadarajan Srinivasan;
[email-masked]

Krishna

 -----Original Message-----
From:     Provin Gurung [mailto:[email-masked]]
Sent:     Thursday, June 07, 2001 12:48 AM
To:  Ashwani Kumar Kesharwani
Cc:  Varadarajan Srinivasan; [email-masked]
Subject:  Re: [SIP] Proxy - A simple question

Proveen Gurung

Telcordia Technologies,
MCC-1H-209R,
445,South Street,