Subject: [Sip] RE: reason code in BYE/CANCEL (was[Sip-implementors] another problem related to multiple call l egs at UAC)

From: "Ashhar Farhan" <[email-masked]>
Date: 28 Jun 2001 11:09:11 -0000

is the reason code meant for machine interpretation or is it meant to be informational for the end-user?

if it is meant for the machine to interpret the reason, that is to be covered by the response code itself. we may have to expand the number of response codes.
The number codes are the most efficient and unambiguous way of conveying a reason.

on the otherhand, if the reason is a message targeted at the end-user, it's place would probably be in the body of the message. if the machine is NOT interpreting the reason code, it could as well be supplied as a seperate MESSAGE.

- [email-masked]

____________________________________________________
Buy Feng Shui Package for Rs. 151/- only, at http://shopping.rediff.com/shopping/fengshui_mailer.htm

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 28 Jun 2001 16:09:41 +0300

Hi,

Since a BYE is always a BYE, no matter what the reason code will be (if
there is a reason code in the first place...), I would say it's an
implementation issue to decide which set of reason codes will trigger
extra internal actions by the server. If a reason code is not
understood/supported by the server, it will simply discard it, but still
release the call. We should remember that the Reason will be an optional
feature, so the server may not even understand them in the first place.

However, I DO think that we should specify the set of reason codes that
the Reason header will use, and WHEN, so that servers that do trigger
some kind of action really do the right thing (ie if they trigger a
message telling the user that the reason for the call release is X, then
the reason really is X).

Regards,

Christer Holmberg
Ericsson Finland

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 28 Jun 2001 17:49:17 +0300

Hello,

> on the otherhand, if the reason is a message targeted at the end-user, it's place would probably be in the body of the message. if the machine is NOT interpreting the reason code, it could as well…

As I said in a previous mail, we already have a set of reason phrases
and reason codes used in responses. Since it is very likely that in 3pcc
situations the reason phrase and the status codes of a response is
mapped into the BYEs' reason phrase and status code, I would suggest to
use the same format and the same codes.

If we have to add a couple of codes (I do not think we need too many),
it is alright. However, defining brand new status codes does not sound
good to me. Let us reuse what we already have.

Regards,

Gonzalo
-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]

---

From: "Bob Penfield" <[email-masked]>
Date: Thu, 28 Jun 2001 10:45:21 -0400

----- Original Message -----
From: "Christer Holmberg" <[email-masked]>
To: "Ashhar Farhan" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Thursday, June 28, 2001 9:09 AM
Subject: [Sip] Re: reason code in BYE/CANCEL (was[Sip-implementors] another
problem related to multiple call l egs at UAC)

> feature, so the server may not even understand them in the first place.

The call should always be released no matter what the reason code is. It is
up to the UA implementation what it wants to do with the information.

> message telling the user that the reason for the call release is X, then

Agreed.

> > if it is meant for the machine to interpret the reason, that is to be
covered by the response code itself. we may have to expand the number of
response codes.
> > on the otherhand, if the reason is a message targeted at the end-user,
it's place would probably be in the body of the message. if the machine is
NOT interpreting the reason code, it could as well be supplied as a seperate
MESSAGE.
> > Buy Feng Shui Package for Rs. 151/- only, at
http://shopping.rediff.com/shopping/fengshui_mailer.htm

---

From: "Bob Penfield" <[email-masked]>
Date: Thu, 28 Jun 2001 10:41:26 -0400

----- Original Message -----
From: "Ashhar Farhan" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Thursday, June 28, 2001 7:09 AM
Subject: RE: reason code in BYE/CANCEL (was[Sip-implementors] another
problem related to multiple call l egs at UAC)

> is the reason code meant for machine interpretation or is it meant to be
informational for the end-user?

The reason code is meant for machine interpretation so that a UA could act
on it. The Reason header would contain both a numeric value and a textual
description.

The most likely action with BYE (if it was a SIP phone) would be to display
something on the phone.

The reason code is in a request rather than a response.