Subject: [SIP] Proxy - A simple question

From: Varadarajan Srinivasan <[email-masked]>
Date: Thu, 07 Jun 2001 08:58:50 +0531

Hi,

Basically, I am concern about the statement

"Typically, only the first request within a call traverses all proxies,
while subsequent requests are exchanged directly between user agents"

Section 1.3, last but one statement in RFC2543bis03.

Rajan

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 07 Jun 2001 08:02:03 +0300

Hi,

The reason for this is that since the remote UA MUST insert a Contact
header in the 200 final response, subsequent requests are then sent
there. However, if a proxy does want to be in the path also for the
subsequent requests, it is possible by using the record route.

Regards,

Christer Holmberg
Ericsson Finland

---

From: "Ashwani Kumar Kesharwani" <[email-masked]>
Date: Thu, 7 Jun 2001 11:01:29 +0530

Hi It is actually like this.
With in first request UAC provides its contact address so that UAS sends a
final response at the contact address mentioned rather than sending it
through all the proxies.
And with this final response it is a must for the UAS that it sends its own
contact address too. So that next time UAC will contact UAS without going
through proxies.

So after first request-response UAC and UAS could communicate without going
through proxies.
But if a proxy wants yo be in the path it adds a record route header while
first request is going through it.

---

From: Provin Gurung <[email-masked]>
Date: Thu, 7 Jun 2001 01:48:08 -0400 (EDT)

> final response at the contact address mentioned rather than sending it

I think there is a slight misunderstanding here,
The contact is there so that future requests from the called
UA can be sent directly to the calling UA. All the responses *must*
traverse back the same path that the request followed, i.e responses are
forwarded to the top via field of the SIP message. The responses cannot
bypass the proxies. 

Proveen Gurung

Telcordia Technologies,
MCC-1H-209R,
445,South Street,
Morristown,NJ,USA-07960-6438
Tel (973)829-2323

---

From: "Ashwani Kumar Kesharwani" <[email-masked]>
Date: Thu, 7 Jun 2001 11:48:50 +0530

Yes Provin You are right.

A request and a final  response forms a transaction.
And both follow same set of proxies.

Contact address are used for further requests.

----- Original Message -----
From: "Provin Gurung" <[email-masked]>
To: "Ashwani Kumar Kesharwani" <[email-masked]>
Cc: "Varadarajan Srinivasan" <[email-masked]>;
<[email-masked]>
Sent: Thursday, June 07, 2001 11:18 AM
Subject: Re: [SIP] Proxy - A simple question