Subject: RE: [Sip] Few tiny issues with SDP section of bis3

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 12 Jun 2001 16:51:00 -0400

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Monday, June 11, 2001 3:15 PM
> To: [email-masked]
> Subject: [Sip] Few tiny issues with SDP section of bis3
> 
> 
> 
> Examples in section B don't have an e or P line in the SDP 
> even though one
> them must be present.

OK, I fixed that.

> 
> When adding a media steam it must be below existing media 
> streams but the
> example in (3rd SDP in section B.5 - top of page 122) seems 
> to have it at
> the top.

Yeah, that was a big oops. I fixed that one already.

> 
> Would be nice to have an example that sent video and audio to 
> a different
> IPs to illustrate this case.

The spec is not the place to deal with tons of examples. We could add such
things to the call flows example doc.

> 
> A clear example of the SDP for a call that was doing some 
> voice codec, say
> G.711, and was also doing RFC 2833 events would be nice.

There is such an example in the new SDP section in bis-03.

Thanks for your comments,

Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/sip

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 13 Jun 2001 14:09:01 -0400

> > Examples in section B don't have an e or P line in the SDP

Speaking of that: Why is there now a requirement in the SDP section stating
that "Either an e line or p line MUST be present." ?

-- Flemming

--
Flemming Andreasen
Cisco Systems

---

From: Anders Kristensen <[email-masked]>
Date: Wed, 13 Jun 2001 14:15:02 -0400

It's required by RFC 2327 (no idea why, though:

   o Either an email field or a phone field must be specified.
     Additional email and phone fields are allowed.

Thanks,
Anders

---

From: [email-masked]
Date: Wed, 13 Jun 2001 13:20:00 -0500

> From: Flemming Andreasen [mailto:[email-masked]]
>

This is actually a requirement straight from SDP; it's just so
often overlooked that (I guess) it seems to make sense to
reiterate it in SIP.

From RFC2327:

    "Either an email field or a phone field must be specified.
     Additional email and phone fields are allowed."

/a

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 13 Jun 2001 15:16:36 -0400

That's far from clear if you read it in the context it was provided in. Also, do
note that both of these fields are in fact listed as optional earlier in the
spec.

-- Flemming

--
Flemming Andreasen
Cisco Systems