Subject: [Sip] Retransmisstion detection at Proxy

From: "Chen, Xin (Xin)" <[email-masked]>
Date: Thu, 1 Nov 2001 15:58:51 -0000

I think in the Bis-05, it is not clear that how a proxy detects that a
request is a retransmission or not.

Currently, in line 3573 in bis-05, it says that CSeq is used to
differentiate a new request or a retransmission.

But what about a spiral or a loop, those request also have the same CSeq?

Regards

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 8 Nov 2001 01:19:19 -0500

> -----Original Message-----
> From: Chen, Xin (Xin) [mailto:[email-masked]]
> Sent: Thursday, November 01, 2001 10:59 AM
> To: [email-masked]'
> Subject: [Sip] Retransmisstion detection at Proxy
> 
> 

Section 17.2.3 discusses precisely this subject. I can see why you may not
have viewed this section as defining retransmissions since it doesn't use
that term itself. I will clarify that. Basically, two requests which match
the same server transaction are retransmissions.

> But what about a spiral or a loop, those request also have 

17.2.3 would tell you that in a loop or spiral, the top via is different and
therefore it is not a retransmission.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com