Subject: [Sip] Via received and DNS advancing for responses

From: "Brett Tate" <[email-masked]>
Date: Mon, 5 Nov 2001 17:40:33 -0500

Sections 24 and 19.2.2 of rfc2543bis-05 
discuss how DNS and the Via-received can 
be used to identify the destination address 
that should be used when sending a response.  
These sections make it clear that ICMP 
failure can cause the need to try the 
next-hop for both requests and responses.  
Is line 4179 indicating that next-hop 
advancement cannot be done based upon 
timeouts when sending responses?

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 6 Nov 2001 01:29:38 -0500

> -----Original Message-----
> From: Brett Tate [mailto:[email-masked]]
> Sent: Monday, November 05, 2001 5:41 PM
> To: sip-ietf (E-mail)
> Subject: [Sip] Via received and DNS advancing for responses
> 
> 

In the current draft, yes. This is due, in part, to the placement of SRV
processing "above" the client and server transactions. There is no way for
the TU above the server transaction to tell the server transaction to try a
different destination. It just gets awfully messy.

That said, the SRV stuff is under much discussion with IESG at this time,
and I expect there will be several changes coming. One thing we need to
consider is whether timeouts even make sense for SRV failure detection. They
can take a very long time. So long, in fact, that the transactions will have
all likely timed out. In that case, trying the next server isn't useful,
since its already too late. ICMP and TCP connection failures are more
immediate and therefore more useful.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com