Subject: [Sip] Nit: grammar for display-name

From: Anders Kristensen <[email-masked]>
Date: Fri, 23 Nov 2001 12:33:30 -0500

The production for display-name and token in bis-05 are:

    token         =  1*(alphanum | "-" | "." | "!" | "%" | "*"
                                 | "_" | "+" | "`" | "'" | "~" )
    display-name  =  LWS (*token | quoted-string)

This is broken as it doesn't allow for LWS between tokens, as in

    From: John Doe <sip:[email-masked]>

Also, I suspect the leading LWS is unnecessary, as display-name always
occurs after something that ends in LWS anyway. Probably better not to
match it as part of the display-name, then.

Another nit: The bis-05 example Date header (line 3588) is bogus:

  Date: Sat, 13 Nov 2001 23:29:00 GMT

13 Nov 2001 is a tuesday, not a saturday.

Anders

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 27 Nov 2001 16:05:59 -0500

> -----Original Message-----
> From: Anders Kristensen [mailto:[email-masked]]
> Sent: Friday, November 23, 2001 12:34 PM
> To: SIP
> Subject: [Sip] Nit: grammar for display-name
> 
> 

Good catch. It looks like we missed the implicit->explicit LWS here.

> match it as part of the display-name, then.

Good point.

> 13 Nov 2001 is a tuesday, not a saturday.

Anders, you win the prize for the most obscure nit in bis-05....

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com