Subject: RE: [Sip] bis-05: Terminating a session

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 20 Nov 2001 12:42:05 -0500

> -----Original Message-----
> From: Bob Penfield [mailto:[email-masked]]
> Sent: Monday, October 29, 2001 3:45 PM
> To: [email-masked]
> Subject: [Sip] bis-05: Terminating a session
> 
> 
> Hi,
> 
> Section 15 is a great improvement,

Thanks! Its nice to see a complement after the nonstop barrage of complaints
and nits ;)

> Section 15 begins:
> 
>    Terminating a session is done either with the BYE request, or the
>    CANCEL request, depending on the state of the dialog. Either caller
>    or callee can terminate, and may do so for any reason.
> 
> One might interpret this as allowing a callee to send CANCEL 
> or a callee to
> send BYE prior to an "established" dialog. This whole area of 
> terminating
> session has caused a lot of confusion and discussion and I 
> think we need to
> be really clear.
> 
> I suggest section 15 begin:
> 
> "Either the caller or callee may terminate a session for any reason. A
> caller terminates a session either with BYE or CANCEL 
> depending on the state
> of the dialog. A callee uses BYE to terminate an established dialog."

OK, that sounds good.

> 
> Somewhere near line 1957, it should be noted that the callee 
> terminates an
> early dialog by sending a non-2xx final response to the INVITE.

There is no early dialog; its rejecting the invitation, and will thus not
cause a dialog to be established, or the session. But, I understand what you
are getting at, and we'll add some words.

> 
> As far as issue#202 is concerned, I think that this is the 
> right solution.

Yes, I think so too (thats why we put it in). It mirrors the solution for
CANCEL/100.

> 
> In section 15.1.1 at line 1972, ".. creation of dialog 
> (either early or
> established)." should be "... creation of dialog (established for the
> callee, early or established for the caller)".

Another good suggestion. 

Thanks for your comments,
Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Bob Penfield" <[email-masked]>
Date: Tue, 20 Nov 2001 15:45:52 -0500

----- Original Message -----
From: "Jonathan Rosenberg" <[email-masked]>
<snip>
> are getting at, and we'll add some words.

I was talking about the case where a UAS has sent a 1xx (e.g. 183 Ringing)
which establishes an early dialog, and then sends a 4xx when the UAS wants
to terminate because the user pressed the "don't bother me now" button.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 22 Nov 2001 01:06:31 +0200

Hello,

> to terminate because the user pressed the "don't bother me now" button.

I have added some wording about it.

Thanks,

Gonzalo