Subject: RE: [Sip] How does Stateless Proxy handle Retransmission

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 12 Nov 2001 12:01:44 -0500

> -----Original Message-----
> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Saturday, November 10, 2001 3:34 AM
> To: Robert Sparks
> Cc: 'Gonzalo Camarillo'; Shan Lu; Jonathan Rosenberg; [email-masked]
> Subject: Re: [Sip] How does Stateless Proxy handle Retransmission
> 
> 
> 
> Hi,
> 
> Just one clarification I would like to get.
> 
> To my understanding stateless proxies don't Record-Route.

No, that is not correct. Statelessness and record-routing are orthogonal.

> 
> However, IF the INVITE has a pre-defined route (if it will be 
> allowed),
> that route MAY include a stateless proxy. Then, if I want to 
> CANCEL the
> INVITE I guess I must include the same route in the CANCEL (it IS
> allowed according to Table 3 on page 132), because otherwise 
> there is no
> guarantee that the "routing algorithm" of the stateless proxy will
> forward the CANCEL to the same destination as the INVITE?

This is a good point. For INVITE with pre-loaded Route, the CANCEL should
probably have the same route set as the request its cancelling. This will
also be needed for re-INVITE. 

We need to add that to the spec.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com 

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 12 Nov 2001 11:53:49 -0500

> From: Shan Lu [mailto:[email-masked]]
> Sent: Monday, November 12, 2001 10:04 AM
> To: 'Jonathan Rosenberg'
> Cc: [email-masked]
> Subject: RE: [Sip] RE: How does Stateless Proxy handle Retransmission
> 
> 
> Hi,
> 
> > Going stateful for 32s before using the updated routing 
> > tables is indeed one
> > way to do this. There are other ways that use lesser amounts 
> > of state; these
> > are implementation choices and areas of innovation. The 
> > specification states
> > a clear set of requirements. It is worth clarifying that you 
> > need to worry
> > about this issue of configuration changes, although I do 
> > believe that the
> > solution should be left open.
> > 
> 
> The solutions described so far on the list all require the stateless
> proxy to go stateful (for maybe limited period of time). While this is
> doable in theory, it is very complicated in practice. IMHO, it may go
> against the very purpose of having a stateless proxy to start 
> with. 

You can't have your cake and eat it too; total statelessness along with
failover and dynamic configurability are not simultaneously achievable. 

> With
> the newly added text about requirments on stateless proxy, I think it
> would also help if bis-05 mentions that a stateless proxy may 
> need to go
> stateful to meet these requirments.

Yes, we will clarify.

-Jonathan R.
---

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 16 Nov 2001 23:04:44 -0000

I believe this is much the same problem.

You may also like to consider whether we have sufficient information to
route the ACK that is a response to 3xx or 4xx when the INVITE passed
through an intermediate proxy behaving statelessly for the INVITE
transaction, but which appeared on a pre-loaded Route. In this case assume
that the intermediate proxy wishes to process all methods, no matter what
they are.

The ACK should presumably contain the same routeing information as the
INVITE, but ACKs cannot contain the Route header.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Jonathan Rosenberg[SMTP:[email-masked]]
> Sent: 	12 November 2001 17:01
> To: 	'Christer Holmberg'; Robert Sparks
> Subject: 	RE: [Sip] How does Stateless Proxy handle Retransmission
> 
> 
> 
>  
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 18 Nov 2001 23:29:04 -0500

> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: Friday, November 16, 2001 6:05 PM
> To: 'Christer Holmberg'; Robert Sparks; 'Jonathan Rosenberg'
> Cc: 'Gonzalo Camarillo'; Shan Lu; [email-masked]

Indeed, you are correct. It is the same problem. Dean pointed it out to me
privately. I have already corrected the text. 

> INVITE, but ACKs cannot contain the Route header.

This has now changed in the text.

-Jonathan R.

---