Subject: RE: [Sip] Handling of duplicate requests with differing request p aths.

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 6 Nov 2001 02:53:24 -0500

> -----Original Message-----
> From: Shan Lu [mailto:[email-masked]]
> Sent: Monday, October 29, 2001 5:11 PM
> To: 'Jo Hornsby'; [email-masked]
> Subject: RE: [Sip] Handling of duplicate requests with 
> differing request
> paths.
> 
> 
> 
> 
> > -----Original Message-----
> > From: Jo Hornsby [mailto:[email-masked]] 
> > Sent: Monday, October 29, 2001 12:21 PM
> > To: Shan Lu; [email-masked]
> > Subject: RE: [Sip] Handling of duplicate requests with 
> > differing request paths.
> > 
> > 
> > > > Assume that the UAS receives the INVITE from two separate 
> > "routes". It
> > > > sends 200 to the first one, and 482 to the other.
> > > > 
> > > <snip>
> > > Q1. Is 482 the proper response? This isn't a loop, is it?
> > 
> > It's important not to get too hung-up on the
> > default Reason Phrases.  An implementor is
> > free to use "Request Merged", or sommat, as
> > the Reason Phrase that accompanies the 482.
> > 482 is specified by bis-05, and I think
> > fits very well semantically with the
> > "classical" notion of a 482.
> 
> This sounds like a pretty good reason to define a new cause 
> code rather
> than let everybody come up with their own reason phase.

You need different response codes when there is a differing set of protocol
behaviors that a client should take. There isn't anything a client can do
about a merged request, and anything it might do (try later) is no different
than what it would do for a loop detected (which is also, try later).
Therefore, I think it is fine for the same response code to be used in this
case.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Shan Lu" <[email-masked]>
Date: Tue, 6 Nov 2001 10:19:17 -0500

> Therefore, I think it is fine for the same response code to 

Isn't "try later" something that a UAC can always do? Then I am
wondering why we need response codes 404, 410, 483, and 486, just to
name a few? The only thing the UAC can do upon receiving these responses
is to ... Try Later.

Regards,

Shan Lu
sentitO Networks