Subject: RE: [Sip] How does Stateless Proxy handle Retransmission

From: Robert Sparks <[email-masked]>
Date: Fri, 9 Nov 2001 16:41:24 -0500

Aslo, its not necessary to switch the whole proxy
from stateless to stateful - if the db/routing
table change allows you to partition resources into
"recently changed" vs stable, you can continue to
forward stable resources statelessly.

RjS

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: Thursday, November 08, 2001 7:11 PM
> To: Shan Lu
> Cc: 'Jonathan Rosenberg'; [email-masked]
> Subject: Re: [Sip] How does Stateless Proxy handle Retransmission
> 
> 
> Hello,
> 
> Shan Lu wrote:
> > 
> > Hello,
> > 
> > > -----Original Message-----
> > > From: Gonzalo Camarillo [mailto:[email-masked]]
> > > Sent: Thursday, November 08, 2001 2:52 PM
> > > To: Shan Lu
> > > Cc: 'Jonathan Rosenberg'; [email-masked]
> > > Subject: Re: [Sip] How does Stateless Proxy handle Retransmission
> > >
> > >
> > > Hi,
> > >
> > > Shan Lu wrote:
> > > >
> > > > To quote bis-05, line 2458, "They (stateless proxies) do
> > > not have the
> > > > ability to distinguish a retransmission from the original
> > > message" and
> > > > Line 2466, "a retransmitted request MUST be forwarded 
> to the same
> > > > desitnation each time it is processed".
> > > >
> > > > Assume that a stateless proxy uses the request-uri to look
> > > up a location
> > > > DB and make routing decisions. Given these two lines, does
> > > it mean that
> > > > all INVITEs with the same request-uri have to be routed to
> > > exactly the
> > > > same destination for as long as the proxy is running, 
> regardless of
> > > > database changes? Can you provide some ideas how line 
> 2466 can be
> > > > accomplished without the proxy going stateful?
> > > >
> > >
> > > As Jonathan said already, if something external changes (like
> > > you update
> > > the database), you need to go stateful to be sure that you do not
> > > re-route ongoing dialogs.
> > >
> > 
> > If this is the case, then the proxy MUST be stateful 
> ALWAYS. How can the
> > proxy be certain that all INVITEs have finished their 
> retransmissions
> > and therefore it's "safe" to update database? Wait for 32s of no
> > activity?
> 
> As folks have said multiple times. If you intend to change 
> your "routing
> tables" often, do not implement a stateless proxy.
> 
> And if you have a stateless proxy and make a change in the "routing
> table", you have to go stateful for max (T1*64, T3). Then you 
> change the
> "routing table", and go stateless again. You have simply to stay
> stateful for all the transactions that were initiated during 
> your timer.
> 
> You have changed everything is 1 minute. Is this a big deal? As cannot
> stress enough that stateless proxies are not used when 
> "routing tables"
> change very often.
> 
> 
> 
> > 
> > > Stateless proxies are very useful as load distributors, and
> > > in this case
> > > the database you are referring to only changes when some 
> server goes
> > > down... and as Jonathan already said, bis-05 does not cover
> > > any possible
> > > failure scenario you can think of.
> > >
> > 
> > I am afraid this view of stateless proxy is very 
> restrictive. SL proxy
> > can be used as more than LB and can connect to a location 
> database which
> > may be updated for reasons other than server failure. When 
> this happens,
> > unless the proxy has been operating stateful since the 
> initial INVITE,
> > you can't ensure that retransmissions will be routed to the 
> same path.
> > 
> > I can't find similar text in bis-04 that talks about how 
> retransmission
> > should be handled by a stateless proxy. So is the intension 
> to deprecate
> > SL proxy in bis-05?
> 
> I really wonder what makes you think that...
> 
> Regards,
> 
> Gonzalo
> 
> 
> > 
> > Regards,
> > 
> > Shan Lu
> > sentitO Networks
> 
> -- 
> Gonzalo Camarillo                    Phone :   +1 212 939 71 71
> Columbia University                  Mobile:  +358 40 702 35 35
> 472 Computer Science Building        Fax   :  +358  9 299 30 52
> 1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
> New York, NY 10027                   
> USA                              [email-masked]
> 
> _______________________________________________
> Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 10 Nov 2001 10:33:58 +0200

Hi,

Just one clarification I would like to get.

To my understanding stateless proxies don't Record-Route.

However, IF the INVITE has a pre-defined route (if it will be allowed),
that route MAY include a stateless proxy. Then, if I want to CANCEL the
INVITE I guess I must include the same route in the CANCEL (it IS
allowed according to Table 3 on page 132), because otherwise there is no
guarantee that the "routing algorithm" of the stateless proxy will
forward the CANCEL to the same destination as the INVITE?

Regards,

Christer Holmberg
Ericsson Finland