Subject: RE: [Sip] Bis-5: TLS as secure transport for SIP

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 7 Nov 2001 23:31:15 -0500

One thing on this draft... you run TLS over each stream separately. Whilst
it makes sense, it is really awful for applications that use lots of
streams. It would be nice to be able to protect the entire association with
a single TLS connection.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Tuexen Michael [mailto:[email-masked]]
> Sent: Tuesday, November 06, 2001 7:55 AM
> To: [email-masked]'; Jonathan Rosenberg
> Cc: [email-masked]; [email-masked]; Tuexen Michael;
> [email-masked]
> Subject: RE: [Sip] Bis-5: TLS as secure transport for SIP 
> 
> 
> Dear all,
> there will be an update for the next IETF.
> Best regards
> Michael
> 
> Michael Tuexen    Tel.:   +49 89 722 47210
> Siemens AG        Fax:    +49 89 722 48212
> ICN WN CS SE 5    E-mail: [email-masked]
> 
> > -----Original Message-----
> > From:	Allison Mankin [SMTP:[email-masked]]
> > Sent:	Tuesday, November 06, 2001 12:49 AM
> > To:	Jonathan Rosenberg
> > Cc:	[email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> > Subject:	Re: [Sip] Bis-5: TLS as secure transport for SIP 
> > 
> > 
> > > That said, TLS over SCTP would be another option, but is 
> not specified 
> > > as far as I know.
> > 
> > draft-tuexen-tsvwg-tls-over-sctp-00.txt
> > 
> > A chartered work item in TSVWG - new draft was expected...
> > 
> > ------
> > 
> > > 
> > > In the case of secured interconnects between proxies that 
> have some kind of
> > > administratively agreed upon security relationship, I 
> don't see a whole lot
> > > of reason for UDP as opposed to TCP. The connections can 
> be set up ahead of
> > > time, or on the first call, and then reused as needed. I 
> am sure people will
> > > dredge up the old HOL blocking issues with TCP. I still 
> am waiting for
> > > specific analysis on the impact on sip call set up time 
> distributions. That
> > > said, TLS over SCTP would be another option, but is not 
> specified as far as
> > > I know.
> > > 
> > > -Jonathan R.
> 
> _______________________________________________
> Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Michael Thomas <[email-masked]>
Date: Thu, 8 Nov 2001 09:53:06 -0800 (PST)

> streams. It would be nice to be able to protect the entire association with

   You strive for IPsec, Grasshopper. :-)

	      Mike