Subject: RE: [Sip] Bis-5: TLS as secure transport for SIP

From: "Vesa Torvinen (LMF)" <[email-masked]>
Date: Mon, 5 Nov 2001 14:35:13 +0100

> -----Original Message-----
> From: Peterson, Jon [mailto:[email-masked]]
> Sent: 3. marraskuuta 2001 22:59
> To: 'Jari Arkko'; Shieh, Hugh; [email-masked]
> Subject: RE: [Sip] Bis-5: TLS as secure transport for SIP
>

[cut]

> - Because use of TLS is reflected in the SIP protocol. The application
> therefore has direct knowledge of the use of a secure transmission
> mechanism, and uses this knowledge to populate the 
> 'sent-protocol' in Via
> headers or the 'transport-param' in various URI. In fact, an 
> application
> could even inspect the trail of Via headers to determine how 
> many hops of a
> signaling chain went over TLS. 

[cut]

I don't understand how a SIP entity can trust on Via or various URI fields/parameters. For example, an untrustworthy proxy could change these fields making a SIP entity downstream believe that TLS was used for certain hops (and change them back to original when the messages are delivered back to upstream). Shouldn't you somehow protect all those fields/parameter which you wanted to use to determine anything about security? 

At least the protection of Via headers sounds a bit complicated because they are added by every proxy... 

Vesa 

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Michael Thomas <[email-masked]>
Date: Mon, 5 Nov 2001 10:44:40 -0800 (PST)

> At least the protection of Via headers sounds a bit complicated because they are added by every proxy... 

  You are correct. In order to protect via's, you need some
  mechanism for each proxy to sign their via. Before we
  went there though, I think that the real life threats
  would need to be examine very carefully. I'm somewhat
  doubtful that it's high on the threat list considering
  that most SIP traffic is sent in the clear :-)

	    Mike