Subject: RE: [SIP] Killing hung media streams

From: [email-masked]
Date: Thu, 1 Nov 2001 16:14:41 -0700

Last word below on this topic was some verbage was going into the next bis
draft about reconstituting session state or terminating the session when
ICMP errors are encountered on the media stream.  I am unable to find
anything discussing this in bis-05.  Did I miss it?

John Hearty
Level3

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Friday, August 24, 2001 1:15 AM
To: Hearty, John; Jonathan Rosenberg
Cc: [email-masked]; [email-masked]; Terpstra, Rich; Fischer, Ken
Subject: RE: [SIP] Killing hung media streams

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, August 23, 2001 4:32 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [SIP] Killing hung media streams
> 
> 
> 
> > My recommendation is this. If a UA is in a call, and begins 
> getting ICMP
> > errors on a media stream, and wishes to continue with the 
> call, it SHOULD
> > send a re-INVITE on that leg. 
> >
> > As an orthogonal issue, if a UAC receives a 481 to a 
> mid-call re-INVITE,
> it
> > SHOULD tear down the call by sending a BYE.
> 
> 
> This sounds great.  In addition, a recommedation for the case 
> where a UA
> begins getting ICMP errors and does not wish to continue the 
> call should
> also be noted.  Sending a BYE in this case as well seems 
> consistent with
> your position below. 

Yes, thats fine. But, I want the text to be clear that this is only if you
really have some other reason for not continuing. A triggered re-INVITE on
ICMP errors does wonders for reconstituting state and providing fault
tolerance. Most of the times, that is what you want.

> If there is no objection, can we get 
> modified language
> in the bis indicating these behaviors?

Fine by me. Speak up folks, or the text is going in....

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 2 Nov 2001 01:12:51 -0500

John,

No, we didn't put it in. However, it is being tracked by bugzilla, so it
will be addressed in a subsequent version. Again, our aim with bis-05 was
primarily to rewrite, not to include resolution to many open issues.

-Jonathan R.

---

> Sent: Thursday, November 01, 2001 6:15 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]