Subject: [Sip] Stateless CANCEL Processing

From: Jiri Kuthan <[email-masked]>
Date: Wed, 14 Nov 2001 18:31:39 +0100

Can someone explain my why CANCELs for which no matching
INVITE/whatever transaction has not been found *MUST* be
processed *statelessly* (S. 16.8, bis-05)?

I understand they must be processed (the INVITE might have
been stateless) but is then stateless processing of the
CANCEL a MUST too?

What if the INVITE state does not exist and routing logic
asks for state (forking)? (I know, bizzar case but I just
wonder if we can remove possibly unnecessary requirements.)

Thanks,

-Jiri

--
Jiri Kuthan            http://iptel.org/~jiri/

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Bob Penfield" <[email-masked]>
Date: Wed, 14 Nov 2001 17:04:04 -0500

----- Original Message -----
From: "Jiri Kuthan" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, November 14, 2001 12:31 PM
Subject: [Sip] Stateless CANCEL Processing

> wonder if we can remove possibly unnecessary requirements.)

I'm inclined to agree with Jiri. If the proxy knows that it would not have
statelessly forwarded the request being cancelled, why cannot it just
respond with 481 (or even 200).

If the proxy does do any stateless forwarding of requests, it would know
based on the contents of the request whether or not it needs to be forwarded
since it has to be able to make the same routing choice for the CANCEL as it
did for the original request.