Subject: RE: [Sip] Handling of duplicate requests with differing request p aths.

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 6 Nov 2001 02:51:08 -0500

> -----Original Message-----
> From: Jo Hornsby [mailto:[email-masked]]
> Sent: Wednesday, October 31, 2001 8:19 AM
> To: Shan Lu; [email-masked]
> Subject: RE: [Sip] Handling of duplicate requests with 
> differing request
> paths.
> 
> > Not sure what is broken. Load balancer forwards INVITE #1 
> to Proxy #1
> > and INVITE #2 (retransmission of #1) to Proxy #2.  Nothing 
> wrong for a
> > stateless load balancer.
> 
> Uh.  Maybe there is nothing wrong with the "stateless
> load balancer" (I don't know what its mandate is),
> but it certainly represents no entity that I am aware
> of in the spec, and thus will break the network if
> the "proxy"s behind it are not aware that there is a
> "stateless load balancer" serving them.
> 
> What I'm saying is that this load balancer cannot
> exist on it's own as an entity in a SIP network --
> it would have to have cooperating servers that would
> legislate against retransmissions being distributed
> arbitrarily.

Jo is correct. A stateless LB is, according to the specification, just a
stateless proxy. A stateless proxy has to send retransmissions to the same
place as the original request. This means, effectively, that routing
decisions can ONLY be combinatoric functions of the request received plus
STATIC configuration data. You need to even be careful of configuration data
that can change in the middle of a transaction! The solution for these cases
is that the proxy becomes stateful for long enough to ensure that any
stateless transactions have cleared.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Shan Lu" <[email-masked]>
Date: Tue, 6 Nov 2001 10:12:36 -0500

Hello,

> decisions can ONLY be combinatoric functions of the request 

As I stated in my previous mail, the discussion of load balancer has
been side tracked. What you said above is true in a perfect world. But
there is no way you can guarantee a retransmitted INVITE is sent along
the same path when a stateless proxy goes down and its backup has a
slightly different view of the network topology. So a UAS may still
receive two INVITEs from the same UAC but through different paths.

> stateless transactions have cleared.

Where is this requirement stated in bis-05 that a stateless proxy must
route retransmitted INVITEs onto the same path? Are you saying that
stateless proxy does NOT exist in practice? 

Regards,

Shan Lu
sentitO Networks