Subject: [Sip] Use of Expires in Refer.

From: "Padhye, Chinmay" <[email-masked]>
Date: Tue, 20 Nov 2001 12:45:21 -0800

Hello,

	I remember seeing a couple of emails on this. However I could not
spot them in the archive. Hence I am writing this email. 

	Bis 05 says the following about Expires - 'The precise meaning of
this is method dependent'. 
	
	What is the meaning of the Expires header for the REFER method?

	In general should extensions that introduce new method/s also define
the precise meaning of Expires for those method/s? 

Regards,

Chinmay

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Tue, 20 Nov 2001 16:50:11 -0500

Expire has no special meaning for REFER. 

More specifically, the presence of an Expire header
in a REFER requests will not affect the processing
of that request. A Refer-To URI that happens to be a SIP
URI may contain an Expire header parameter that could
affect the resulting request.

For your last question, the lack of an explicitly
defined meaning for header FOO means header FOO has
no special meaning for the particular context and
should be treated as an unknown header. For REFER,
Expires is as unknown as Subscription-Expires...

RjS

> -----Original Message-----
> From: Padhye, Chinmay [mailto:[email-masked]]
> Sent: Tuesday, November 20, 2001 2:45 PM
> To: [email-masked]'; [email-masked]'
> Subject: [Sip] Use of Expires in Refer.
> 
> 
> Hello,
>