Subject: RE: [Sip] Session Timer - Timeout on Refresh

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 28 Nov 2001 01:15:20 -0500

> -----Original Message-----
> From: Brett Tate [mailto:[email-masked]]
> Sent: Thursday, October 25, 2001 7:45 PM
> To: 'Wray Ferrell'; [email-masked]
> Subject: RE: [Sip] Session Timer - Timeout on Refresh
> 
> 
> > Version 0.8 of the draft states:
> > "If no response is received to a refreshing re_INVITE
> > is received before the session expiration, the UA
> > SHOULD send a BYE request to terminate the call.
> > It SHOULD send this BYE slightly before session
> > expiration"
> 
> I think it should be "If no 2xx response ...".

Yup. THe draft pretty much assumes we are talking about 2xx. I'll fix that
during iesg comments.

> 
> > 
> > The bis-03 draft of SIP states under Reliability
> > for INVITE Requests:
> > "If no response is received after sending seven packet
> > requests, processing continues as if a 481 response was
> > received for that request."
> 
> Would a 408 be more appropriate than a 481?
> This would allow the UAC to decide the 
> importance of the re-invite.

bis-05 doesn't actually have this above text anymore; it talks about client
transactions sending timeouts to the TU, but I couldn't find any matching
text that describes how the ua core or proxy cores handle the timeouts.
Thats a bug.

Assuming it generates either a 408 or 481, the spec is clear that both
terminate a dialog anyway, so there is no difference.

>  
> > So does the SIP Session Timer override the section on
> > reliability for INVITE requests? More specifically if
> > a UA responsible for refreshing does not receive a
> > response to its' re-INVITE what should its' behavior
> > be? Disconnect the session as if receiving a 481 or
> > keep the session alive since the session expiration
> > has not yet been reached?
> 
> I think that the session should stay alive 
> if the re-invite didn't have a new sdp.

I don't like making this kind of behavior dependent on the SDP. A million
other things could have changed. Keep it simple - if the other side isn't
there any more, the call is over.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Wed, 28 Nov 2001 16:44:14 -0500

> terminate a dialog anyway, so there is no 

Thanks for pointing out the change in bis-05.
Why should a 408 automatically terminate a 
dialog?

This change will result in proxy failure 
causing a call to be released after 
approximately half Session-Expires instead 
of allowing approximately half Session-Expires 
for the proxy to recover.