Subject: [Sip] RE: How does Stateless Proxy handle Retransmission

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 9 Nov 2001 23:10:11 -0500

> -----Original Message-----
> From: Shan Lu [mailto:[email-masked]]
> Sent: Thursday, November 08, 2001 9:49 AM
> To: 'Jonathan Rosenberg'
> Cc: [email-masked]
> Subject: How does Stateless Proxy handle Retransmission
> 
> 
> Hi,
> 
> > -----Original Message-----
> > From: Jonathan Rosenberg [mailto:[email-masked]] 
> > Sent: Wednesday, November 07, 2001 11:03 PM
> > To: 'Shan Lu'; Jonathan Rosenberg; [email-masked]
> > Subject: RE: [Sip] Handling of duplicate requests with 
> > differing request paths.
> > 
> >
> > > Are you saying that
> > > stateless proxy does NOT exist in practice? 
> > 
> > No, I'm merely saying that they need to forward 
> > retransmissions to the same
> > place. However, it is not trivial to make sure you always do 
> > that, even
> > through configuration changes. 
> > 
> > -Jonathan R.
> > 
> 
> Ok, I've stolen the thread and changed the subject. 
> 
> To quote bis-05, line 2458, "They (stateless proxies) do not have the
> ability to distinguish a retransmission from the original message" and
> Line 2466, "a retransmitted request MUST be forwarded to the same
> desitnation each time it is processed".
> 
> Assume that a stateless proxy uses the request-uri to look up 
> a location
> DB and make routing decisions. Given these two lines, does it 
> mean that
> all INVITEs with the same request-uri have to be routed to exactly the
> same destination for as long as the proxy is running, regardless of
> database changes? Can you provide some ideas how line 2466 can be
> accomplished without the proxy going stateful?

Going stateful for 32s before using the updated routing tables is indeed one
way to do this. There are other ways that use lesser amounts of state; these
are implementation choices and areas of innovation. The specification states
a clear set of requirements. It is worth clarifying that you need to worry
about this issue of configuration changes, although I do believe that the
solution should be left open.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Shan Lu" <[email-masked]>
Date: Mon, 12 Nov 2001 10:03:51 -0500

Hi,

> solution should be left open.

The solutions described so far on the list all require the stateless
proxy to go stateful (for maybe limited period of time). While this is
doable in theory, it is very complicated in practice. IMHO, it may go
against the very purpose of having a stateless proxy to start with. With
the newly added text about requirments on stateless proxy, I think it
would also help if bis-05 mentions that a stateless proxy may need to go
stateful to meet these requirments.

Regards,

Shan Lu
sentitO Networks