Subject: RE: [Sip] bis-05 mostly NITS - full review

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 20 Nov 2001 02:54:16 -0500

John,

Thanks for the very detailed read!! Some responses below.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, November 15, 2001 10:28 AM
> To: [email-masked]
> Subject: [Sip] bis-05 mostly NITS - full review
> 
> 
> >  The following are largely pure nits.  A few may warrent 
> discussion.  If
> > so, please paste text in a separate thread. Thanks!
> > 
> > 26. Lines 1729-1733.  This is possibly more of a question 
> on the following
> > text:
> > 
> > The offer indicates the desired communications means (audio, video,
> > games), parameters of those means (such as codec types) and 
> addresses for
> > receiving media from the offerer. The other UA responds with another
> > session description, called the answer, which indicates which
> > communications means are accepted, the parameters which 
> apply to those
> > means, and addresses for receiving media from the answerer.
> > 
> >   It seemed "offerer" at the end of the first sentance and 
> "answerer" at
> > the end of the next sentence were reversed the way I have 
> typically seen
> > SDP sent, where the sender of the SDP is informing the 
> other end what
> > address they should send media to.  After some thought, at 
> least for SDP,
> > the info could be either way, as the SDP could have an attribute of
> > recvonly, sendrecv, or sendonly.  Do these sentences need 
> to be re-worded
> > taking this into consideration?

You are right, these have been misworded.

> > 29. Line 1769-1770:
> > 
> > The early dialog will only be needed if the UAC needs to 
> send a request to
> > its peer within the dialog before the initial INVITE transaction
> > completes.
> > 
> >  This confused me at first since the UAS is the one 
> deciding (based on
> > what response it sends) to start an early dialog.  After 
> reading it a few
> > times I realized what was being said, with CANCEL as an 
> example.  Perhaps
> > this would be better worded as something like the following 
> (let me know
> > if I'm off track).
> > 
> > The early dialog will only be needed by the UAC if the UAC 
> needs to send a
> > request (such as CANCEL) to its peer within the dialog 
> before the initial
> > INVITE transaction completes.

Actually, CANCEL is a bad example, since you don't need a dialog to send it.
Rather, its PRACK or INFO or something, or even BYE. 

> > 31. Line 1850, the sentence is missing a period.  "the UAS 
> MAY silently
> > accept the INVITE" is also not fully clear, I presume this 
> means 2xx, this
> > might be worth clarifying.

Yes, it means send a 2xx.

> > 52. Line 2437, "A stateful proxy may generate a CANCEL to any other
> > request it has generated at any time."  Needs to be 
> reworded to conform to
> > new wait for 1xx rule, no?

Yes, correct.

> > 63. Line 2877, forgot to add the received parameter in the example.

Right; that one has been noted already.

> > 
> > 64. Lines 2927-2928 need some wordsmithing beginning with 
> "not just what
> > they have to say", looks like something got deleted, at 
> least a comma.

Its a dash. We lost a bunch of dashes due to some conversion errors.

> 69. Line 3299, what about TLS transport (port 5061)?

Yeah, this is a big mess with that. One of the reasons I sent a query asking
about whether people put 5060 into the URL even though its the default, was
to try and change this behavior to have sip:user@host:5060 NOT equal
sip:user@host, since the former would use SRV and the latter wouldn't.
Unfortunately, it seems at least a few people are putting 5060 in the
URLs....

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 20 Nov 2001 10:37:10 +0200

Hi,

>Unfortunately, it seems at least a few people are putting 5060 in the

We should also remember tat the host may be an IP address, and the
client does not use SRV. So, if there is no port, and it does NOT mean
that 5060 shall be used as default, which port does the client use?

And, to say that 5060 is default if the host is an IP address, but not
if the host is a domain name, may sound a little messy?

Regards,

Christer Holmberg
Ericsson Finland