Subject: Re: [Sip] Resource-Priority Header

From: [email-masked]
Date: Wed, 21 Nov 2001 11:08:29 EST

In a message dated 11/20/01 1:13:06 PM Eastern Standard Time, 
[email-masked] writes:

> At 10:24 PM 11/19/2001 -0500, [email-masked] wrote:
>  >To all,
>  >
>  >I have the following comments on draft-polk-sip-resource-00:
>  >
>  >Nits: Section 4 gives example of 'e.g., "between urgent and normal".' 
This 
>  >should reference some of the values defined in Section 3.
>  
>  This is a generic example that most can understand -- that's why it was 
used.
>  James M. Polk
>  Consulting Engineer
>  Office of the CTO
>  Cisco Systems

I'll respond to each item in a separate e-mail so they don't get so lengthy.

Although "urgent" and "normal" are generic words, they are not the ones used 
in this document. Use of these words as examples here would confuse someone - 
If they were unaware of the details of the current Priority Header, they 
would be confused. If they were aware of the current Priority Header, they 
would be lead to believe that the definition of the value in this new Header 
were somehow related to the one in the Priority Header. I listed this as a 
"nit", since it was clearly a cut and paste error.

Mike Pierce
Artel

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Wed, 21 Nov 2001 11:53:15 -0500

> "nit", since it was clearly a cut and paste error.

Yes, that's a bug. I changed the wording to actually refer to labels
used in the draft. Thanks for catching this.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 21 Nov 2001 10:47:17 -0600

>"nit", since it was clearly a cut and paste error.

This phrase is intended as a comparison -- do you think that most or even some
people would believe that there isn't a difference between "urgent" and
"normal". In relative terms, probably not. And this was the intent.

>Artel

*************************************
"People generally demand more respect for their own rights than they are
willing to allow for others"

James M. Polk
Consulting Engineer
Office of the CTO

Cisco Systems
2200 East President George Bush Turnpike 
Richardson, TX  75082 USA
w) 972.813.5208
f)  972.813.5280
www.cisco.com

---

From: Lei Liang <[email-masked]>
Date: Wed, 21 Nov 2001 17:19:43 +0000 (GMT)

hi, everybody,
  i am not sure what will happen if a UAS receives more than one invite
from different poeple in the  same conference at the same time or almost
the same time that it hasn't sent out  a final response for any one of
them. will the UAS accept the first one and tell the rest it has join the
conference automatically or the user has to choose one of them manually or
establish calls with all of them. clearly the last choice is not necessary
and waste of bandwidth. does't any document mention this case? thanks.
lei

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 22 Nov 2001 01:12:05 +0200

Hello,

Lines 1844-1850 of the PDF version of bis-05 cover this.

Regards,

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]

---

From: Lei Liang <[email-masked]>
Date: Mon, 26 Nov 2001 14:04:30 +0000 (GMT)

hi, Gonzalo,
  could u please tell me where to download the pdf version of bis05?
Thanks very much.
 cheers, lei

---

From: Lei Liang <[email-masked]>
Date: Mon, 26 Nov 2001 16:34:20 +0000 (GMT)

Hi, falks,
   in the bis-05, it was mentioned that if a UAS receive multiple INVITE
from the same conference that it has been in, it will "silently" accept
the INVITE. 

firstly, I wondered what the "silently" mean. does
it mean that the USA send 2xx response or not? 

secondly, for a multipart multicast conference involving large number of
users, because each of them don't need to know who is participating the
conference, it's possibly that they will send out requests to every one
who has been in and when it tries to leave it will send BYE  to everyone
who has sip relation with it. wasn't it a waste of resource?
 
cheers.
lei

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 26 Nov 2001 19:56:00 +0200

Hello,

> it mean that the USA send 2xx response or not?

It means that it sends the 2xx response but it does not alert the user.

> who has sip relation with it. wasn't it a waste of resource?

No, it is not. The BYE will terminate the dialog between them

Regards,

Gonzalo