Subject: [Sip] -05bis and Contact

From: Vijay Gurbani <[email-masked]>
Date: Fri, 09 Nov 2001 14:44:39 -0600

In -05bis' definition of Contact (line 3492, PDF version), it appears that
the "action" parameter has disappeared since it says "parameters defined for
Contact include "q" and "expires"..."  However, in the BNF on page 134,
the "action" parameter is present.

I hope that the BNF on page 134 is accurate, not the description of para-
meters on line 3492.  The "action" parameter has not disappeared, has it?
I would hope not.

Thanks,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Fri, 9 Nov 2001 16:55:14 -0500

Use of the action parameter has been deprecated,
as such, there is no need to explicitly define it
in the syntax (it is still syntactically valid to
include it - it matches under contact-extension -
it just doesn't have semantic meaning).

RjS

> -----Original Message-----
> From: Vijay Gurbani [mailto:[email-masked]]
> Sent: Friday, November 09, 2001 2:45 PM
> To: SIP LIST
> Subject: [Sip] -05bis and Contact
> 
>

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 16 Nov 2001 21:51:13 -0000

When are we going to stop doing deprecation in this way.

All it does is lead to confusion. We've had it on Hide in the past, and now
we are having it here.

If the item is deprecated - take it out entirely. Don't leave it lying
around in the syntax.

If someone really wants to find out how to implement a deprecated item, then
let them go to the old version of the specification and do it from there
(after all RFCs never die).

The sole place a deprecated item should appear in the new specification is
in a list of changes since the previous version of the specification.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Robert Sparks[SMTP:[email-masked]]
> Sent: 	09 November 2001 21:55
> To: 	'Vijay Gurbani'; SIP LIST
> Subject: 	RE: [Sip] -05bis and Contact
>

---

From: Robert Sparks <[email-masked]>
Date: Fri, 16 Nov 2001 16:55:40 -0500

I agree wholeheartedly - it should be gone from the
next iteration of the doc.

RjS

> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: Friday, November 16, 2001 3:51 PM
> To: 'Vijay Gurbani'; SIP LIST; 'Robert Sparks'