Subject: RE: [Sip] Bis-5: TLS as secure transport for SIP

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 7 Nov 2001 23:07:26 -0500

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]]
> Sent: Tuesday, November 06, 2001 10:00 AM
> To: Jonathan Rosenberg
> Cc: Michael Thomas; 'Shieh, Hugh'; 'Peterson, Jon'; [email-masked]'
> Subject: Re: [Sip] Bis-5: TLS as secure transport for SIP
> 
> 
> 
> Jonathan Rosenberg writes:
> 
> > Since these are effectively pre-established and "nailed-up" 
> connections
> > (re-established under failure cases, of course), the amount 
> of messages to
> > set them up does not seem important.
> 
> Could be fine in a fixed LAN environment, but think
> mobile! If I roam under a different proxy, I need
> to establish a new connection.

I agree its not ideal there, but neither is IPSec. ALthough if I had to
pick, TLS is far better between a user and a proxy than IPSec. Its really
between proxies than I'm talking about "nailed up" connections.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Michael Thomas <[email-masked]>
Date: Thu, 8 Nov 2001 10:57:10 -0800 (PST)

> between proxies than I'm talking about "nailed up" connections.

   I'm not sure why you'd classify it as "far better".
   For nailed up connections, it seems fairly close
   to six of one, half dozen of the other. Some of
   the plusses and minuses I can see:

   + TLS can be linked into an application instead of
     requiring stack support
   - TLS is subject to a wedging attack, especially
     from an active snooper
   - TLS can't be run over UDP
   - TLS requires and extra 2 messages vs KINK
   + TLS requires 4 fewer messages than IKE
   + Application layer credential binding easy
   + Can be used with Kerberos auth
   - Can't be used with AAA-style auth (that I know of)

   + IPSec aggregates sessions onto a single SA
   + IPSec isn't subject to the wedging attack
   + IPSec covers UDP and any other protocol without
     further standards work needed 
   - IPSec requires implementation in the stack
     generally (or bump in the stack/wire)
   - IPSec application layer credential API missing
     (though not impossible)
   + Can be used with Kerberos auth (KINK)
   + Can be used with AAA auth (XAUTH)

   At this point, both are pretty well known quanitites,
   with lots of deployment. Both are pretty similar in
   footprint, and have similiar CPU considerations. So,
   I may have missed some point/counterpoints, but I 
   just don't see that as a slam dunk for either one,
   and I still find the lack of answer for UDP highly
   problematic.

		Mike

---

From: Jari Arkko <[email-masked]>
Date: Mon, 12 Nov 2001 15:21:20 +0200

> between proxies than I'm talking about "nailed up" connections.

Right. So we are in rough agreement regarding where the current
mechanisms are suitable and where they are not. I propose that
we

   (a) Agree that the TLS (or IPSec etc.) mechanisms are useful
       and necessary in many cases and proceed to document
       their use in the Bis.

   (b) Agree that there are cases where are not very good,
       such as in wireless networks, and initiate work
       to make the situation better.

Jari