Subject: RE: [Sip] use of MESSAGE method for passing display information t o the user

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 2 Sep 2002 18:01:58 +0100

With hindsight, I drafted the last paragraph of my original message badly.

Rather than try to paraphrase again, I will select a direct quote from the message draft abstract:

The MESSAGE method is an extension to the Session Initiation Protocol
   (SIP) that allows the transfer of Instant Messages.  MESSAGE requests
   carry the content in the form of MIME body parts.  

My concern is not over how such a body should be coded. The questions is does such a usage to carry "Please top up your units or your call may be terminated prematurely" qualify as an Instant Message, i.e. is it within the semantics of MESSAGE to perform this function.

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 02 September 2002 17:43
> To: [email-masked]; [email-masked]
> Subject: RE: [Sip] use of MESSAGE method for passing display 
> information
> to the user
> 
> 
> 
> Keith,
> 
> > Within 3GPP, there is a requirement for intermediate servers 
> > to pass textual information for display to the user. This may 
> > be related to a dialog or not.
> > 
> > A typical example may be (in the case of a prepay user):
> > 
> > "Please top up your units or your call may be terminated 
> prematurely".
> > 
> > There are a number of methods that are defined which 
> > essentially convey body information between User Agents 
> > (INFO, NOTIFY, MESSAGE, PUBLISH?).
> > 
> > Some of these would appear more suitable that others for 
> > passing this information. 
> > 
> > Of the existing methods, MESSAGE would appear to be the most 
> > suitable (and indeed is the one selected by some of the 
> > experts involved). However the internet draft specifically 
> > talks about the body being an "Instant Message".
> 
> draft-ietf-sip-message-06 states that the body can be of ANY 
> MIME type:
> "The body of the request will contain the message to be delivered.
>    This body can be of any MIME type, including message/cpim."
> 
> Regards,
> Krisztian
> 
> 
> > Rather than get into a situation similar to that which 
> > affects INFO (i.e. people seem to have implemented various 
> > applications on INFO and IETF experts say INFO is not 
> > appropriate for that application), could I request an 
> > exchange of views on the applicability or not of MESSAGE for 
> > this type of information, and if not, what solution would 
> > otherwise be suggested.
> > 
> > Note that the information would normally be expected to come 
> > from some network based entity (acting as a UA). When related 
> > to a dialog, the source may well be some B2BUA between the 
> > two end UAs involved in the dialog.
> > 
> > Keith Drage
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> > 
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Tue, 03 Sep 2002 14:29:51 +0300

Keith:

I have found some hints into the message draft that makes me think this is the appropriate usage of the method. This hints are:

    The MESSAGE method is an extension to the Session Initiation Protocol
   (SIP) that allows the transfer of Instant Messages. 

I guess instant message is a message delivered instantly to the user, and displayed to the user.

    All UAs which support the MESSAGE method MUST be prepared to send and
    receive MESSAGE requests with a body of type text/plain.

Text/plain seems to be textual information that can be displayed to a user.
If it was message/sipfrag, perhaps the information wasn't intended to be
delivered to the user, but text/plain seems to be unformatted information
intended to be readable by a human being.

   Normally, a 200 OK
   response will be generated by the user agent of the request's final
   recipient.  Note that this indicates that the user agent accepted the
   message, not that the user has seen it.

This again suggest that the payload of the MESSAGE method is typically
displayed to the user.

All these hints, make me think that your usage example seems to be a correct
usage of the MESSAGE method.

/Miguel

-- 
Miguel-Angel Garcia                     Oy LM Ericsson AB
                                        Jorvas, Finland
mailto:[email-masked]     Phone:  +358 9 299 3553
mailto:[email-masked]        Mobile: +358 40 5140002
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Tue, 3 Sep 2002 14:58:32 -0700

Hmmm...

I think the problem lies in the presentation to the user.  What Keith is 
describing is a message about a specific call, so it really should be 
sent in the context of that dialog.  (Otherwise, it might arrive with a 
whole pile of SMS messages). Unfortunately, the dialog identifiers and 
cseqs are being managed by the user agents, so the "system" really can't 
just send a MESSAGE mid-dialog unless it is a B2BUA managing the cseqs, 
dialog identifiers, and security associations for that user.   If you 
want this message to be handled differently than other messages, it 
needs to be different.

thanks,
-rohan

On Tuesday, September 3, 2002, at 04:29 AM, Miguel A. Garcia wrote:

> Keith:
>
> I have found some hints into the message draft that makes me think this 
> is the appropriate usage of the method. This hints are:
>
>> My concern is not over how such a body should be coded. The questions 
>> is does such a usage to carry "Please top up your units or your call 
>> may be terminated prematurely" qualify as an Instant Message, i.e. is 
>> it within the semantics of MESSAGE to perform this function.
>>
>> Keith
>>