Subject: RE: [Sip] Branch in INVITE ,ACK,BYE

From: [email-masked]
Date: Fri, 20 Sep 2002 16:21:35 +0300

ACK is only part of the transaction only if the response to the INVITE was an non-2xx final response. If the response was 200, then the ACK is a new transaction.
 
The example you talk about below is for an INVITE than got a 200 ok response.
 
Regards,
Hisham

-----Original Message-----
From: ext ABDUL SATTAR SHAIK [mailto:[email-masked]]
Sent: Friday, September 20, 2002 3:49 PM
To: [email-masked]'
Subject: [Sip] Branch in INVITE ,ACK,BYE

The branch parameter  should change with each request send by UAC  or per  Transaction Basis. If it is on transaction  basis INVITE and ACK should have same branch parameter

In RFC 3261 Examples The branch parameter is different for  INVITE and ACK message sent By UAC 

 24.2 Session Setup 

   This example contains the full details of the example session setup 
   in Section 4.  The message flow is shown in Figure 1.  Note that 
   these flows show the minimum required set of header fields - some 
   other header fields such as Allow and Supported would normally be 
   present. 

F1 INVITE Alice -> atlanta.com proxy 

INVITE sip:[email-masked] SIP/2.0 
Via: SIP/2.0/UDP pc33.atlanta.com;branch=z9hG4bKnashds8 
Max-Forwards: 70 
To: Bob <sip:[email-masked]> 
From: Alice <sip:[email-masked]>;tag=1928301774 
Call-ID: a84b4c76e66710 
CSeq: 314159 INVITE 
Contact: <sip:[email-masked]> 
Content-Type: application/sdp 
Content-Length: 142 

(Alice's SDP not shown) 

ACK sip:[email-masked] SIP/2.0 
Via: SIP/2.0/UDP pc33.atlanta.com;branch=z9hG4bKnashds9 
Max-Forwards: 70 
To: Bob <sip:[email-masked]>;tag=a6c85cf 
From: Alice <sip:[email-masked]>;tag=1928301774 
Call-ID: a84b4c76e66710 
CSeq: 314159 ACK 
Content-Length: 0 

Thanks in Advance 
Abdul Sattar

---

From: "Srivastava, Samir" <[email-masked]>
Date: Fri, 20 Sep 2002 12:13:55 -0700

ACK for 2XX is different Transaction. 
While ACK for non 2xx final responses is the part of same INVITE
transaction. 
Therefore ACK for the 2xx is having different Branch ID.
 
Thx
Samir

-----Original Message-----
From: ABDUL SATTAR SHAIK [mailto:[email-masked]]
Sent: Friday, September 20, 2002 5:49 AM
To: [email-masked]'
Subject: [Sip] Branch in INVITE ,ACK,BYE

The branch parameter  should change with each request send by UAC  or per
Transaction Basis. If it is on transaction  basis INVITE and ACK should have
same branch parameter

In RFC 3261 Examples The branch parameter is different for  INVITE and ACK
message sent By UAC 

 24.2 Session Setup 

(Alice's SDP not shown) 

Thanks in Advance 
Abdul Sattar