Subject: [Sip] use of MESSAGE method for passing display information to the user

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 2 Sep 2002 16:40:07 +0100

Within 3GPP, there is a requirement for intermediate servers to pass textual information for display to the user. This may be related to a dialog or not.

A typical example may be (in the case of a prepay user):

"Please top up your units or your call may be terminated prematurely".

There are a number of methods that are defined which essentially convey body information between User Agents (INFO, NOTIFY, MESSAGE, PUBLISH?).

Some of these would appear more suitable that others for passing this information. 

Of the existing methods, MESSAGE would appear to be the most suitable (and indeed is the one selected by some of the experts involved). However the internet draft specifically talks about the body being an "Instant Message".

Rather than get into a situation similar to that which affects INFO (i.e. people seem to have implemented various applications on INFO and IETF experts say INFO is not appropriate for that application), could I request an exchange of views on the applicability or not of MESSAGE for this type of information, and if not, what solution would otherwise be suggested.

Note that the information would normally be expected to come from some network based entity (acting as a UA). When related to a dialog, the source may well be some B2BUA between the two end UAs involved in the dialog.

Keith Drage
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Ben Campbell <[email-masked]>
Date: Tue, 03 Sep 2002 11:08:32 -0500

This seems to me to be an entirely appropriate use of page mode MESSAGE. 
Specifically, I would interpret a message, sent by an automaton, that is 
intended to be rendered for and interpreted by a human being in a timely 
manner, to fall into the category of "instant message."