Subject: [Sip] Branch in INVITE ,ACK,BYE

From: ABDUL SATTAR SHAIK <[email-masked]>
Date: Fri, 20 Sep 2002 18:19:22 +0530

The branch parameter  should change with each request send by UAC  or per
Transaction Basis. If it is on transaction  basis INVITE and ACK should have
same branch parameter

In RFC 3261 Examples The branch parameter is different for  INVITE and ACK
message sent By UAC

 24.2 Session Setup

   This example contains the full details of the example session setup
   in Section 4.  The message flow is shown in Figure 1.  Note that
   these flows show the minimum required set of header fields - some
   other header fields such as Allow and Supported would normally be
   present.

F1 INVITE Alice -> atlanta.com proxy

INVITE sip:[email-masked] SIP/2.0
Via: SIP/2.0/UDP pc33.atlanta.com;branch=z9hG4bKnashds8
Max-Forwards: 70
To: Bob <sip:[email-masked]>
From: Alice <sip:[email-masked]>;tag=1928301774
Call-ID: a84b4c76e66710
CSeq: 314159 INVITE
Contact: <sip:[email-masked]>
Content-Type: application/sdp
Content-Length: 142

(Alice's SDP not shown)

ACK sip:[email-masked] SIP/2.0
Via: SIP/2.0/UDP pc33.atlanta.com;branch=z9hG4bKnashds9 
Max-Forwards: 70
To: Bob <sip:[email-masked]>;tag=a6c85cf
From: Alice <sip:[email-masked]>;tag=1928301774
Call-ID: a84b4c76e66710
CSeq: 314159 ACK
Content-Length: 0

Thanks in Advance
Abdul Sattar

---

From: "Brett Tate" <[email-masked]>
Date: Fri, 20 Sep 2002 09:28:04 -0400

> Transaction Basis. 

It is per transaction.

> If it is on transaction basis INVITE and ACK 
> should have same branch parameter

The ACK is a special case.  The ACK's branch
changes for 2xx response; the ACK's branch
remains the same for other final responses.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip