Subject: RE: [Sip] use of MESSAGE method for passing display information t o the user

From: Kedar Patil <[email-masked]>
Date: Tue, 3 Sep 2002 12:00:10 -0500

Hi,

I have some input on having event-notification package
for this :

Although it looks like a user may have to subscribe to
"Credit overflow" kind of event all the time, I guess
this is going to be only during the calls.

This one case may be solved by "MESSAGE". However, is it the
only case? I believe there could be more. The commonality
is that all of them are going to be from the network (not the
peer) and are asynchrounous. For this why not have an event
pacakge under the framework of RFC3265. A UA may subscribe
to network of all network events, and any such event would
trigger the appropriate event notification.

If all the events are for human interaction then "Message"
looks fine. Is there any event where user interaction is
taken over by automatic actions by s/w config? (e.g. in this
case automatic credit upgrade just enough to avoid premature
call termination!)

The question remains : Is there one network element to which
a UA may have to subscribe or many?

thanks,
= Kedar =

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, September 03, 2002 3:57 AM
> To: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: RE: [Sip] use of MESSAGE method for passing display 
> information
> to the user
> 
> 
> Is it feasible to have that subscription state hanging around 
> just in case you may some day run out of credit?
> 
> Cheers,
> Aki
> 
> > -----Original Message-----
> > From: Khartabil Hisham (NMP/Helsinki) 
> > Sent: Tuesday, September 03, 2002 11:49 AM
> > To: Niemi Aki (NET/Espoo); [email-masked]; Kiss Krisztian
> > (NRC/Tampere); [email-masked]
> > Subject: RE: [Sip] use of MESSAGE method for passing display 
> > information
> > to the user
> > 
> > 
> > You're not subscribing to get an instant message, you're 
> > subscribing to get information about your prepaid units.
> > 
> > Why is it unsolicited? 
> > 
> > /Hisham
> > 
> > > -----Original Message-----
> > > From: Niemi Aki (NET/Espoo) 
> > > Sent: Tuesday, September 03, 2002 10:47 AM
> > > To: Khartabil Hisham (NMP/Helsinki); [email-masked]; Kiss 
> > Krisztian
> > > (NRC/Tampere); [email-masked]
> > > Subject: RE: [Sip] use of MESSAGE method for passing display 
> > > information
> > > to the user
> > > 
> > > 
> > > This application seems rather different from the presence 
> > > type notifications because it seems these notifications are 
> > > unsolicited. So to me MESSAGE seems like a perfect fit. I 
> > > don't have to "subscribe" in order to receive instant 
> > messages either.
> > > 
> > > So by saying "Notification package" perhaps you mean a new 
> > > MIME type specifically for these unsolicited notifications?
> > > 
> > > Cheers,
> > > Aki
> > > 
> > > > -----Original Message-----
> > > > From: ext [email-masked] 
> > > > [mailto:[email-masked]]
> > > > Sent: Tuesday, September 03, 2002 10:26 AM
> > > > To: [email-masked]; Kiss Krisztian (NRC/Tampere); [email-masked]
> > > > Subject: RE: [Sip] use of MESSAGE method for passing display 
> > > > information
> > > > to the user
> > > > 
> > > > 
> > > > I guess it could be done that way, but you might find that 
> > > > others would prefer some sort of Notification package for 
> > > > this type of thing.
> > > > 
> > > > /Hisham
> > > > 
> > > > > -----Original Message-----
> > > > > From: ext Drage, Keith (Keith) [mailto:[email-masked]]
> > > > > Sent: Monday, September 02, 2002 8:02 PM
> > > > > To: Kiss Krisztian (NRC/Tampere); Drage, Keith (Keith); 
> > > [email-masked]
> > > > > Subject: RE: [Sip] use of MESSAGE method for passing display 
> > > > > information
> > > > > to the user
> > > > > 
> > > > > 
> > > > > With hindsight, I drafted the last paragraph of my original 
> > > > > message badly.
> > > > > 
> > > > > Rather than try to paraphrase again, I will select a direct 
> > > > > quote from the message draft abstract:
> > > > > 
> > > > > The MESSAGE method is an extension to the Session 
> > > > Initiation Protocol
> > > > >    (SIP) that allows the transfer of Instant Messages.  
> > > > > MESSAGE requests
> > > > >    carry the content in the form of MIME body parts.  
> > > > > 
> > > > > My concern is not over how such a body should be coded. The 
> > > > > questions is does such a usage to carry "Please top up your 
> > > > > units or your call may be terminated prematurely" qualify as 
> > > > > an Instant Message, i.e. is it within the semantics of 
> > > > > MESSAGE to perform this function.
> > > > > 
> > > > > Keith
> > > > > 
> > > > > > -----Original Message-----
> > > > > > From: [email-masked] 
> > [mailto:[email-masked]]
> > > > > > Sent: 02 September 2002 17:43
> > > > > > To: [email-masked]; [email-masked]
> > > > > > Subject: RE: [Sip] use of MESSAGE method for 
> passing display 
> > > > > > information
> > > > > > to the user
> > > > > > 
> > > > > > 
> > > > > > 
> > > > > > Keith,
> > > > > > 
> > > > > > > Within 3GPP, there is a requirement for 
> > intermediate servers 
> > > > > > > to pass textual information for display to the 
> > user. This may 
> > > > > > > be related to a dialog or not.
> > > > > > > 
> > > > > > > A typical example may be (in the case of a prepay user):
> > > > > > > 
> > > > > > > "Please top up your units or your call may be terminated 
> > > > > > prematurely".
> > > > > > > 
> > > > > > > There are a number of methods that are defined which 
> > > > > > > essentially convey body information between User Agents 
> > > > > > > (INFO, NOTIFY, MESSAGE, PUBLISH?).
> > > > > > > 
> > > > > > > Some of these would appear more suitable that others for 
> > > > > > > passing this information. 
> > > > > > > 
> > > > > > > Of the existing methods, MESSAGE would appear to be 
> > the most 
> > > > > > > suitable (and indeed is the one selected by some of the 
> > > > > > > experts involved). However the internet draft 
> specifically 
> > > > > > > talks about the body being an "Instant Message".
> > > > > > 
> > > > > > draft-ietf-sip-message-06 states that the body can 
> be of ANY 
> > > > > > MIME type:
> > > > > > "The body of the request will contain the message to be 
> > > delivered.
> > > > > >    This body can be of any MIME type, including 
> message/cpim."
> > > > > > 
> > > > > > Regards,
> > > > > > Krisztian
> > > > > > 
> > > > > > 
> > > > > > > Rather than get into a situation similar to that which 
> > > > > > > affects INFO (i.e. people seem to have 
> implemented various 
> > > > > > > applications on INFO and IETF experts say INFO is not 
> > > > > > > appropriate for that application), could I request an 
> > > > > > > exchange of views on the applicability or not of 
> > MESSAGE for 
> > > > > > > this type of information, and if not, what solution would 
> > > > > > > otherwise be suggested.
> > > > > > > 
> > > > > > > Note that the information would normally be 
> > expected to come 
> > > > > > > from some network based entity (acting as a UA). 
> > When related 
> > > > > > > to a dialog, the source may well be some B2BUA 
> between the 
> > > > > > > two end UAs involved in the dialog.
> > > > > > > 
> > > > > > > Keith Drage
> > > > > > > _______________________________________________
> > > > > > > Sip mailing list  
https://www1.ietf.org/mailman/listinfo/sip
> > > > > > This list is for NEW development of the core SIP Protocol
> > > > > > Use [email-masked] for questions on 
> > > current sip
> > > > > > Use [email-masked] for new developments on the 
> > > > application of sip
> > > > > > 
> > > > > 
> > > > _______________________________________________
> > > > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > > > This list is for NEW development of the core SIP Protocol
> > > > Use [email-masked] for questions on 
> current sip
> > > > Use [email-masked] for new developments on the 
> > application of sip
> > > > 
> > > _______________________________________________
> > > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > > This list is for NEW development of the core SIP Protocol
> > > Use [email-masked] for questions on current sip
> > > Use [email-masked] for new developments on the 
> application of sip
> > > 
> > 
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Tue, 3 Sep 2002 15:02:47 -0700

> this is going to be only during the calls.
is it? what if I have 2 phones using the same pool of credits.  do you 
want a notification that you are running out of credits on both phones 
or just the one?

thanks,
-rohan