Subject: RE: [Sip] TEL-URL questions

From: Igor Slepchin <[email-masked]>
Date: Thu, 19 Sep 2002 11:24:12 -0400

I actually did not mean that these parameters should be copied when
converting SIP URLs into TEL URLs (I believe they should not be). What I was
trying to say is that even if they do appear in TEL URL used in a SIP
message for whatever reason, their meaning is not defined in SIP.

Thank you,
Igor Slepchin

> -----Original Message-----
> From: Christer Holmberg [mailto:[email-masked]]
> 
> I guess one issue with that solution is that in the future 
> parameters with the
> same names may be defined also for Tel-Url, but they may have 
> a completely
> separate function from the Sip-Uri parameter with the same 
> name. So, by simply
> moving the parameters from one Uri to anther could problems, 
> or at least
> unwanted behaviour.
> 
> The other solution would of course to discard the Sip-Uri 
> parameters, when the
> Sip-to-Tel mapping... Would that cause any problems?
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 19 Sep 2002 22:52:05 +0300

Hi,

> message for whatever reason, their meaning is not defined in SIP.

I guess that sounds fine to me.

In fact, if they did appear in a TEL-URL, I guess we would put them in the user
part of the SIP-URI, as we do with all other TEL-URI parameters...

Regards,

Christer Holmberg
Ericsson Finland