Subject: [Sip] Handling UNSUBSCRIBE before Subscription is completed

From: Sarit Galanos Mekler <[email-masked]>
Date: Tue, 17 Sep 2002 16:22:34 +0300

Hello,

draft-ietf-sip-events does not specify how a server should handle an
UNSUBSCRIBE request that
is received before the SUBSCRIBE process was completed.

In other words, If the server receives a SUBSCRIBE request and before it
responds with a final response
an UNSUBSCRIBE is received for the same dialog. 

Should the server reject the UNSUBSCRIBE?

Regards,
Sarit Galanos.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Tan Ya-Ching ICM N PG U ID A 1 <[email-masked]>
Date: Tue, 17 Sep 2002 16:14:24 +0200

| In other words, If the server receives a SUBSCRIBE request 
| and before it responds with a final response
| an UNSUBSCRIBE is received for the same dialog. 

RFC 3265 does not expect provisional response for SUBSCRIBE, so before the
notifier responds with a final response, there is no dialog created yet and
no unSUBSCRIBE can possibly be received for the same dialog.

Regards,
Ya-Ching