Subject: RE: [Sip] use of MESSAGE method for passing display information to the user

From: [email-masked]
Date: Wed, 4 Sep 2002 11:05:23 +0300

How useful can this be when I'm talking on the phone and I get an Instant Message with text telling me that I'm running out of credit? How often do you stop talking on the phone just to read your SMS? The most likely scenario is that your phone call will be cut short, then you go and read your IM and only then you find out what the contents of the IM were.

I think this type of information should be conveyed by a special tone that the phone plays or by a light going red of the phone. Perhaps implementation specific. The point is that we can't standardise that "your running out of credit" type of IM MUST be rendered to the user.

Having said that, I agree that MESSAGE is the choice if contents of a request are to be rendered to a user. But if I, as a phone manufacturer want my phone to flash a red light when suck IM is received, then I can't.

/Hisham

> -----Original Message-----
> From: ext Ben Campbell [mailto:[email-masked]]
> Sent: Tuesday, September 03, 2002 7:09 PM
> To: Drage, Keith (Keith)
> Cc: [email-masked]'
> Subject: Re: [Sip] use of MESSAGE method for passing display 
> information
> to the user
> 
> 
> This seems to me to be an entirely appropriate use of page 
> mode MESSAGE. 
> Specifically, I would interpret a message, sent by an 
> automaton, that is 
> intended to be rendered for and interpreted by a human being 
> in a timely 
> manner, to fall into the category of "instant message."
> 
> 
> 
> Drage, Keith (Keith) wrote:
> > Within 3GPP, there is a requirement for intermediate 
> servers to pass textual information for display to the user. 
> This may be related to a dialog or not.
> > 
> > A typical example may be (in the case of a prepay user):
> > 
> > "Please top up your units or your call may be terminated 
> prematurely".
> > 
> > There are a number of methods that are defined which 
> essentially convey body information between User Agents 
> (INFO, NOTIFY, MESSAGE, PUBLISH?).
> > 
> > Some of these would appear more suitable that others for 
> passing this information. 
> > 
> > Of the existing methods, MESSAGE would appear to be the 
> most suitable (and indeed is the one selected by some of the 
> experts involved). However the internet draft specifically 
> talks about the body being an "Instant Message".
> > 
> > Rather than get into a situation similar to that which 
> affects INFO (i.e. people seem to have implemented various 
> applications on INFO and IETF experts say INFO is not 
> appropriate for that application), could I request an 
> exchange of views on the applicability or not of MESSAGE for 
> this type of information, and if not, what solution would 
> otherwise be suggested.
> > 
> > Note that the information would normally be expected to 
> come from some network based entity (acting as a UA). When 
> related to a dialog, the source may well be some B2BUA 
> between the two end UAs involved in the dialog.
> > 
> > Keith Drage
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> > 
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Juha Heinanen <[email-masked]>
Date: Wed, 4 Sep 2002 11:46:20 +0300

could you please move this discussion to sipping list.

-- juha

---

From: Ben Campbell <[email-masked]>
Date: Wed, 04 Sep 2002 08:28:47 -0500

> Having said that, I agree that MESSAGE is the choice if contents of a request are to be rendered to a user. But if I, as a phone manufacturer want my phone to flash a red light when suck IM is rece…

Hmm. My phone plays a tone and turns on an indicator whenever it gets 
SMS. I think this is just a matter of phone user interface design.