Subject: RE: [Sip] use of MESSAGE method for passing display information t o the user

From: Adam Roach <[email-masked]>
Date: Tue, 3 Sep 2002 13:29:55 -0500

As long as MESSAGE carries content which is intended to be
rendered to the party to whom it is addressed, I assert
that it is serving its intended purpose. The purposes
you describe below meet these criteria compeletely.

Ignoring the other problems with using INFO, it does not
meet your requirement that the information to be conveyed
may not be related to a dialog.

NOTIFY would require definition of event packages for
every sort of information you'd want to convey, which is
probably not what you want. On the other hand, there is
already work ongoing for message waiting indication. For
this sort of notification in particular, it would make
great sense for 3GPP to use SUBSCRIBE/NOTIFY.

PUBLISH is meant for publication of event package state 
information to an event agent, not general publication
of data. Its use in this context would be gross
misapplication of that method. (If you want a mechanism
for general publication of data, you need to check out
WEBDAV).

/a

> -----Original Message-----
> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: Monday, September 02, 2002 10:40
> To: [email-masked]'
> Subject: [Sip] use of MESSAGE method for passing display 
> information to
> the user
> 
> 
> Within 3GPP, there is a requirement for intermediate servers 
> to pass textual information for display to the user. This may 
> be related to a dialog or not.
> 
> A typical example may be (in the case of a prepay user):
> 
> "Please top up your units or your call may be terminated prematurely".
> 
> There are a number of methods that are defined which 
> essentially convey body information between User Agents 
> (INFO, NOTIFY, MESSAGE, PUBLISH?).
> 
> Some of these would appear more suitable that others for 
> passing this information. 
> 
> Of the existing methods, MESSAGE would appear to be the most 
> suitable (and indeed is the one selected by some of the 
> experts involved). However the internet draft specifically 
> talks about the body being an "Instant Message".
> 
> Rather than get into a situation similar to that which 
> affects INFO (i.e. people seem to have implemented various 
> applications on INFO and IETF experts say INFO is not 
> appropriate for that application), could I request an 
> exchange of views on the applicability or not of MESSAGE for 
> this type of information, and if not, what solution would 
> otherwise be suggested.
> 
> Note that the information would normally be expected to come 
> from some network based entity (acting as a UA). When related 
> to a dialog, the source may well be some B2BUA between the 
> two end UAs involved in the dialog.
> 
> Keith Drage
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Adam Roach <[email-masked]>
Date: Tue, 3 Sep 2002 19:58:12 -0500

> If you 
> want this message to be handled differently than other messages, it 
> needs to be different.

You mean like "Priority: Urgent" or something like that?

/a