Subject: [Sip] URI's in To and StartLine in ACK Messages

From: ABDUL SATTAR SHAIK <[email-masked]>
Date: Sat, 21 Sep 2002 18:53:23 +0530

Hi
Consider Scenario
UAC -> UAS

UAC sends  INVITE with URI 's   [email-masked] in both startline and To
Header Field.

After receiving  OK, UAC sends  ACK with URI   [email-masked] in To
Header Field
    and [email-masked]   in Startline. Whether UAS  should  accept ACK
or reject  with   error. 

Thanks
Abdul Sattar

---

From: Rohan Mahy <[email-masked]>
Date: Mon, 23 Sep 2002 15:09:09 -0700

Hi,

In future, when you want to ask questions about how to interpret the SIP 
specification, please send your question instead to sip-
[email-masked].

 >This list is for NEW development of the core SIP Protocol
 >Use [email-masked] for questions on current sip
 >Use [email-masked] for new developments on the application of sip

To answer your specific question, there is no requirement that the 
request-URI has to be the same in both INVITE and ACK.  The request-URI 
for the ACK is typically copied from the Contact header in the 2xx 
response to the INVITE.

thanks,
-rohan

On Saturday, September 21, 2002, at 06:23 AM, ABDUL SATTAR SHAIK wrote:\
> Hi
> Consider Scenario
> UAC -> UAS
>
>
> UAC sends  INVITE with URI 's   [email-masked] in both startline 
> and To Header Field.
>
> After receiving  OK, UAC sends  ACK with URI   [email-masked] in 
> To Header Field
>     and [email-masked]   in Startline. Whether UAS  should  accept 
> ACK or reject  with   error.
>
> Thanks
> Abdul Sattar                                
>