Subject: RE: [Sip] B2BUA question.

From: "Padhye, Chinmay" <[email-masked]>
Date: Wed, 6 Nov 2002 18:39:54 -0800

Hello,

	Thanks for the reply.

	So the B2BUA logical entity is a combination of "ONLY" the UAC and UAS logical entities. Is this an accurate statement?  

Regards,

Chinmay

-----Original Message-----
From: Bert Culpepper [mailto:[email-masked]]
Sent: Wednesday, November 06, 2002 6:23 PM
To: Padhye, Chinmay
Cc: [email-masked]
Subject: Re: [Sip] B2BUA question.

Hi,

I'll provide my opinion on why this term was included in RFC3261, other 
folks may provide different/better reasons.

The previous RFC defined UAC, UAS, Registar, Proxy, and Redirect Server 
logical entities.  As services (both legacy and new) were designed using 
SIP, it was determined that a combination of defined logical entities 
was needed to implement the services and still be compliant with the 
specification.  This particular combination became common enough that (I 
presume) the authors thought it should be mentioned in the new RFC, to 
avoid mis-interpretation.

Regards,
Bert

Padhye, Chinmay wrote:

> Hello,
> 
>     This is from the definition of B2BUA from RFC 3261 -
> 
>     'Since it is a concatenation of a UAC and UAS, no explicit definitions are needed for its behavior."
>     
>     Since the behavior of a B2BUA is the same as the behavior of a UAC/UAS, what was the need for defining a new logical entity - B2BUA? I am trying to understand the motivation behind adding this definition in the RFC.
> 
> Regards,
> 
> Chinmay
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 07 Nov 2002 10:03:50 +0200

Hi,

I do not understand what you mean by "ONLY", but I will take a stab at a
response anyway. If by "ONLY" you mean that it does not implement other
protocols, the answer is no. A B2BUA can receive a SIP request acting as
a SIP UAC, send an LDAP query acting as an LDAP client, and then send a
SIP request acting as a SIP UAC.

A B2BUA handles two dialogs, and it behaves as a UA for both dialogs.
The B2BUA typically uses information in requests or responses in one
dialog to create requests or responses in the other one. An example of a
B2BUA is a 3rd party call controller.

Regards,

Gonzalo

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip