Subject: Re: [Sip] Regarding SIPS

From: [email-masked]
Date: Mon, 18 Nov 2002 11:05:38 +0530

Hi

Here is one scenario where we can expect this to occur.

Supposed  sip: atlanta.com , sips: bilboxi.com be pre-configured route-set at
ClientA
and let sip:[email-masked] be the request uri.
Now when the request reaches atlanta.com, after processing route header, the top
most route
header will be sips, but is received the request on other than TLS.

but why doubt is why it is MUST for atlanta.com to record-route.

waiting for ur response.

thanks in advance
ajay kumar kasam

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Mon, 18 Nov 2002 21:43:57 +0530

Hi

Thanks a lot for the response.
I would love to know the reason for making the record-routing mandatory in the
discussed scenerio.

      If the Request-URI contains a SIPS URI, or the topmost Route header
      field value (after the post processing of bullet 6) contains a
      SIPS URI, the URI placed into the Record-Route header field
      MUST be a SIPS URI. Furthermore, if the request was not
      received over TLS, the proxy MUST insert a Record-Route header
      field

With Regards
Ajay Kumar

Jonathan Rosenberg <[email-masked]> on 11/18/2002 08:45:42 PM

To:   Ajay Kumar Kasam/HSSBLR@HSSBLR
cc:   Leonardo Rico <[email-masked]>, [email-masked]

Subject:  Re: [Sip] Regarding SIPS

inline.

[email-masked] wrote:
>
> Hi
>
> According to the RFC 3261,
>
>      If the Request-URI contains a SIPS URI, or the topmost Route header
>      field value (after the post processing of bullet 6) contains a
>      SIPS URI, the URI placed into the Record-Route header field
>      MUST be a SIPS URI. Furthermore, if the request was not
>      received over TLS, the proxy MUST insert a Record-Route header
>      field
>
>
> How can this scencario occur.

Remember, this is a proxy.

A request arrives without any sips URIs anywhere. It comes in over UDP.
Now, the proxy runs its translation service, and finds that it needs to
proxy the request to a sips URI. An example where this can happen is if
I do a REGISTER like this:

REGISTER sip:domain.com SIP/2.0
To: sip:[email-masked]
Contact: sips:1.2.3.4

-Jonathan R.

--
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com