Subject: RE: [Sip] The fate of session timer?

From: "Stevens, Del" <[email-masked]>
Date: Fri, 15 Nov 2002 08:23:39 -0500

Christer,

The draft currently states, and I agree, that if the session timer expires
prior to receiving a 200 response to the refresh, the UA SHOULD send a BYE.
Of course, the UA expecting a refresh SHOULD also send a BYE if a refresh is
not received prior to the session timer expiring. This ensures that all UAs
and Proxies "involved" in the session will perform appropriate cleanup.

Del

> -----Original Message-----
> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Thursday, November 14, 2002 12:39 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Sip] The fate of session timer?
> 
> 
> 
> Hi,
> 
> > >Please also remember that this mechanism will allow your UA
> > >to find out if the remote party has LOST state of the call.
> >
> > What was the purpose of session-timer again? We need to 
> define a scope and then abide by it.
> 
> I guess one issue is what the UA shall do if it doesn't 
> receive the refresh. Shall it simply
> clean its internal call state, or shall it also send a BYE, 
> to make sure that possible call
> state is also cleared in intermediate proxies?
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 15 Nov 2002 16:42:17 +0200

Hi,

I think we are talking about separate issues here. I am not talking about the
case where the session timer expires prior to the receiving of a 200 OK
response. I am talking about what may happen during the session setup, when the
initial INVITE may be forked to multiple proxies in different legs.

Regards,

Christer Holmberg
Ericsson Finland