Subject: [Sip] Termination of SUBSCRIPTION

From: "tenwater" <[email-masked]>
Date: Mon, 18 Nov 2002 21:20:41 +0800

Hello, All

I have some doubt on the RFC3265, anybody can give me some advise.

1. receive fail response of refresh SUBSCRIBE request

RFC3265 P9 wrote:

========================================================================
If a SUBSCRIBE request to refresh a subscription fails with a non-481
   response, the original subscription is still considered valid for the
   duration of the most recently known "Expires" value as negotiated by
   SUBSCRIBE and its response, or as communicated by NOTIFY in the
   "Subscription-State" header "expires" parameter.
========================================================================

A. if this means Subscriber will not retry the refresh SUBSCRIBE request even if the response is 401 or 407 or 423?
B. after the time indicated by "Expires" elapsed, Subscriber will send a SUBSCRIBE(expires=0) or not? If not, CSF proxy itself have to start a timer as "Expires", else CSF proxy cannot know when a Subscription terminated.

2. receive fail response of NOTIFY request

after receive a response which cannot retry, Notifier will terminate the subscription as per P14 of RFC3265, so the same problem can occur as 1.B in CSF proxy.

For a session defined in RFC3261, they always send BYE to terminate a established session, why the subscription can be terminated silently? If a subscription timer will be defined as session timer?

Regards,
TenWater

-------------------------------------------------  This is a active spring.-----------------------------------------
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "tenwater" <[email-masked]>
Date: Mon, 18 Nov 2002 21:48:50 +0800

Hello, all

   Before UAC receive a non-100(18x or final response) or timeout of a request, UAC can send another request(non-INVITE and non-CANCEL) in same Call-ID or not? for example and just a assumption, UAC send a OPTIONS but no response received, UAC send another OPTIONS within the same Call-ID.

   anybody can give some suggestion. thanks.

Tenwater.

---

From: "A. N. Gautham" <[email-masked]>
Date: Wed, 20 Nov 2002 10:23:42 +0530

Hi,

	I have an answer to one of your questions.

On Mon, 18 Nov 2002 21:20:41 +0800

> 1. receive fail response of refresh SUBSCRIBE request

	No, it doesnot mean that the Subscriber will not refresh SUBSCRIBE request even if the response is 401 or 407 or 423. The retry is needed if the refresh is to succeed. The text in 3265 says that the failure of the refresh request with a code other than 481 means that the original subscription (effected by the previous SUBSCRIBE) continues to be valid for the duration of the most recently known "Expires" value.

> -------------------------------------------------  This is a active spring.-----------------------------------------

	Hope this helps.

Regards,
A. N. Gautham