Subject: RE: [Sip] SIP MIB module ID conflicts

From: "Zhang, Bo" <[email-masked]>
Date: Thu, 7 Nov 2002 16:33:31 -0500

Hello, all,

Besides the OID question, I'm a little confused on the port 
table in common MIB and the server table in UA MIB.

The row of the port table only specifies rcv and snd transport 
protocols. It does NOT contain IP address or port ID to be used 
for the port. How is the port used exactly?

It looks like that each row in the UA server table specifies a 
UAS that a UAC can contact. It is used for outbound proxy, right?

I would greatly appreciate it if anyone can help me out here.

Bo

-----Original Message-----
From: Kevin Lingle [mailto:[email-masked]]
Sent: Friday, November 01, 2002 7:23 AM
To: Zhang, Bo
Cc: [email-masked]'
Subject: Re: [Sip] SIP MIB module ID conflicts

"Zhang, Bo" wrote:
> 
> Hello, all,
> 
> I got a SIP MIB draft 04 version from
> 
> http://www.softarmor.com/sipwg/drafts/draft-ietf-sip-mib-04.txt.
> 
> I'm NOT sure if this is the latest. But in it, there is a conflict
> definition
> of Module ID. The sipTC and sipUAMIB both have module ID of
> { mib-2 9992 }. If this has already been fixed, could some one post
> the latest document?

bo,

-04 is the latest published version of the doc.
-05 is planned, but for several reasons has been
slow coming.

wrt the module id issues... those mib-2 oids are
placeholders anyway.  they are not official IANA
assigned numbers, so the conflict is not a big issue.
granted, they should be unique, but no one should be
attempting to implement these mibs as "mib-2 <anything>"
anyway.  they are draft mibs at this point.

i will make sure they have unique oids for the next
revision though.  

btw, we expect -05 revision to be the
last before we go to IESG for an rfc. -04 _was_ ready
for that, but the coming of RFC 3261 caused us to pause
(didn't expect to pause this long though;) and update
the mib draft to be inline with the new sip rfc.

thanks
kevin
> 
> Thanks,
> 
> Bo
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

-- 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
 Kevin R. Lingle       919.392.2029
 checkout: http://wwwin-eng.cisco.com/Eng/IOS/SNMP_WWW/mib-police/
 Sometimes I think I understand everything, then I regain consciousness.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Kevin Lingle <[email-masked]>
Date: Wed, 13 Nov 2002 11:17:23 -0500

bo,

i'm not able to reconstruct the history of this table very 
well.  the lack of ip address information seems to make the
table quite useless.  i'm guessing that it's intention was
to publicize all of the tcp/udp ports being used by the
sip entity, but i can't say i find a compelling reason for
this - as it's defined at least.

the port id is embodied in the table index object: sipPort.

we'll revisit this table for the next revision of the draft.
any suggestions you may have are welcome.

> UAS that a UAC can contact. It is used for outbound proxy, right?

yes, afiak that's correct.

kevin