Subject: RE: [Sip] The fate of session timer?

From: [email-masked]
Date: Wed, 13 Nov 2002 18:22:23 +0200

> -----Original Message-----
> From: ext Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Wednesday, November 13, 2002 2:40 PM
> To: Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sip] The fate of session timer?
> 
> 
> 
> 
> [email-masked] wrote:
>  > The current draft fulfils all the requests stated below, but there
>  > has been a couple of emails on this thread asking for 
> simplifications
>  > to the draft. That's why I asked for requirements.
>  >
>  > The simplification might start by examining the need for REQs 3-6.
>  >
>  > Also for REQ 1, what is the rationale behind a UAC or proxy
>  > requesting session timer to be started on the remote end? 
> Each entity
>  > only needs to take care of its own stale sessions 
> (something I tried
>  > to propose in my earlier email).
> 
> Well, certainly one UA will care that the other UA has 
> crashed. Session 
> timer allows a UAC or UAS to get refreshes in order to make that 
> determination.

This requires both ends to have support for session timer. Also, is it a safe assumption to make that if a UA doesn't send a session-timer refresh, then it has crashed?

In you earlier email, you pointed out that the sole purpose of session-timer is to clean up old sessions.

"I assert that session timer is really useful for one thing, which is to 
provide a means to cleanup old session state in UAs and proxies."

Why does my UA care about cleaning up old session at the remote side? or Is the purpose of this I-D already extended?

Regards,
Hisham

> As Adam points out, thats not strictly needed; 
> a UA can 
> simply send a re-INVITE or UPDATE whenever it wants to perform a 
> refresh. Doing it through session timer, however, avoids having both 
> sides sending UPDATEs or re-INVITEs to refresh the session, 
> and allows 
> for negotiation of a timer.

> 
> -Jonathan R.
> -- 
> Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 14 Nov 2002 10:10:32 +0200

Hi,

> Why does my UA care about cleaning up old session at the remote side? or Is the purpose of this I-D already extended?

I don't think your UA is supposed to clean up sessions on the remote side. The remote side will clean up its own sessions if it doesn't get a timer refresh from you, right?

Regards,

Christer Holmberg
Ericsson Finland