Subject: RE: [Sip] The fate of session timer?

From: [email-masked]
Date: Thu, 14 Nov 2002 11:52:56 +0200

Christer,

> -----Original Message-----
> From: ext Christer Holmberg [mailto:[email-masked]]
> Sent: Thursday, November 14, 2002 10:11 AM
> To: Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Sip] The fate of session timer?
> 
> 
> 
> Hi,
> 
> > > Well, certainly one UA will care that the other UA has
> > > crashed. Session
> > > timer allows a UAC or UAS to get refreshes in order to make that
> > > determination.
> >
> > This requires both ends to have support for session timer. 
> Also, is it a safe assumption to make that if a UA doesn't 
> send a session-timer refresh, then it has crashed?
> >
> > In you earlier email, you pointed out that the sole purpose 
> of session-timer is to clean up old sessions.
> >
> > "I assert that session timer is really useful for one 
> thing, which is to
> > provide a means to cleanup old session state in UAs and proxies."
> >
> > Why does my UA care about cleaning up old session at the 
> remote side? or Is the purpose of this I-D already extended?
> 
> I don't think your UA is supposed to clean up sessions on the 
> remote side. The remote side will clean up its own sessions 
> if it doesn't get a timer refresh from you, right?

Right, but what I'm saying is why does my UA have need to dictate to the remote UA when it can or cannot clean OLD sessions? I think its a local matter. 

/Hisham

> Regards,
> Christer Holmberg
> Ericsson Finland
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 14 Nov 2002 12:04:14 +0200

Hi,

> Right, but what I'm saying is why does my UA have need to dictate to the remote UA when it can or cannot clean OLD sessions? I think its a local matter.

In that case you don't use the session-timer in the first place. The whole idea of the mechanism is that the nodes can negotiate to send periodical
refreshes.

Please also remember that this mechanism will allow your UA to find out if the remote party has LOST state of the call.

Regards,

Christer Holmberg
Ericsson Finland