Subject: RE: [Sip] B2BUA & Max-Forwards

From: Adam Roach <[email-masked]>
Date: Wed, 4 Dec 2002 14:49:29 -0600

-----Original Message-----
From: Kedar Patil [mailto:[email-masked]]

> This discussion raises one more doubt for me, pls. clarify. 
>
> UA1------->BtoBUA---------->UA2 
>
> Is the BtoBUA a SIP endpoint from UA1's point of view?

Yes.

> In other 
> words, are the the "Require:" etc end-to-end headers sent by UA1, 
> meant for B2BUA or UA2? 

B2BUA.

> Is the UAS part in in BtoBUA is bound by the definition and rules 
> in 3261? 

Yes. I'll revise your drawing to more clearly show what is going on here.

UAC(a)--->UAS(b)===[application logic here]===UAC(b)--->UAS(c)

/a
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Nicky Song" <[email-masked]>
Date: Thu, 5 Dec 2002 10:08:01 +0800

> > Is the BtoBUA a SIP endpoint from UA1's point of view?
I'm confused. Isn't the "BtoBUA" a concept of the combination of UACs and UASs? I think from the UA1's point of view, it doesn't know whether its peer is a B2BUA or a normal single UA.