Subject: [Sip] Contact header for PSTN 2 IP call

From: Rinchen Tundup <[email-masked]>
Date: Mon, 23 Dec 2002 11:03:17 -0700

Hi,
I have a question ! What will be the contact header in the sip message
when an PSTN to IP call is made via a media gateway ? Since PSTN phone
is not a SIP entity and cannot have a SIP URI.
Should it be sip:[email-masked]? or something else?
pls help

Rinchen

--
Rinchen Tundup

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 23 Dec 2002 17:35:09 +0200

Hi,

The PSTN phone is not a SIP entity, but the media gateway is. In a
normal case I would assume the values of the userpart and host are as
you describe in your example.

Regards,

Christer Holmberg
Ericsson Finland

> Should it be sip:[email-masked]? or something else?

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Dean Willis <[email-masked]>
Date: Mon, 23 Dec 2002 16:11:27 -0600

On Monday 23 December 2002 12:03 pm, Rinchen Tundup wrote:
> Hi,
> I have a question ! What will be the contact header in the sip
> message when an PSTN to IP call is made via a media gateway ? Since
> PSTN phone is not a SIP entity and cannot have a SIP URI.
> Should it be sip:[email-masked]? or something
> else? pls help

Well, it generally is "whatever the media gateway wants it to be". I 
suspect it must satisfy two requirements -- it points at the gateway, 
and can be used by the gateway to identify the correct association.

The gateways I use at the office use sip:phone_no@hostname-o-fgateway or 
sip:phone_no@ip-address-of-gateway depending on which gateway and how 
it is configured.

--
Dean