Subject: RE: [Sip] B2BUA - Security

From: "Mahey, Sonit" <[email-masked]>
Date: Thu, 5 Dec 2002 12:14:12 -0500

I agree with Jonathan.

That brings up the question:
Is NAT traversal for encrypted SIP traffic addressed anywhere? 

- sonit

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Thursday, December 05, 2002 11:28 AM
> To: Pete Cordell
> Cc: Christian Huitema; [email-masked]
> Subject: Re: [Sip] B2BUA - Security
> 
> 
> 
> 
> Pete Cordell wrote:
> 
> > I would say that encrypting and / or integrity checking of SDP alone
> > achieves absolutely no security benefit.
> 
> Really?? Wow. I actually think it prevents the most 
> devastating attacks 
> against SIP. These include:
> 
> 1. modifying SDP in transit to point media streams to an intermediate 
> recording device, allowing attackers to establish wiretaps
> 
> 2. downgrading any SRTP keying done in SDP, so that the media 
> itself is 
> not encrypted or integrity protected (this came up during the mmusic 
> session in IETF as a driver for S/MIME)
> 
> 3. launching a DoS attack by sending everyones voice traffic to the 
> intended target. You get huge amplification gains here. Very 
> appealing 
> for hackers!
> 
> 
> 
> 
> > 
> > SDP really does two things.  It specifies transport 
> addresses and chosen
> > codecs.
> > 
> > Let's assume that you do encrypt the SDP and I can't read it.
> > 
> > I can have a good guess at the transport addresses in use 
> from many of the
> > other fields in SIP such as via lines, To, From, uri, 
> contact, route etc.
> 
> Confidentiality is only one property of security. I am much more 
> concerned about message integrity.
> 
> > (Put another way, encrypting SDP is another form of 
> security by obscurity.
> > And we all know what that means.)
> 
> I have no idea how you would arrive at such a conclusion. Security 
> through obscurity means that information is not cryptographically 
> protected, but encoded with a known process that is just a bit 
> complicated. By definition, this is not encryption. Perhaps you have 
> discovered some new flaws in encryption technology?
> 
> -Jonathan R.
> -- 
> Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 6 Dec 2002 16:36:12 -0800

In addition to Jonathan's approach to session policy, there is no 
reason a middlebox controller can't be a proxy if it:

1. opens pinholes referenced in a clear text or integrity protected SDP
2. rejects requests with no readable SDP (the UA could instead include 
a full SDP, with keying material, encrypted with SMIME, and an 
abbreviated copy which is only integrity protected).
3. rejects requests which use private addresses, and include in its 
response an offer with corresponding public addresses.

hope this helps.
thanks,
-rohan