Subject: [Sip] (No Subject)

From: "Jitender Arora" <[email-masked]>
Date: Mon, 09 Dec 2002 15:57:14 -0500

Hi ,

       Can we use REFER call transfer mechanism to , transfer the call from one PSTN subscriber to the other PSTN subscriber ( in the Net-2-Phone calls ).......

       I am talking of the Net-2-Phone Scenario ( say one guy sitting on PC, Using SIP Phone ) , is making a call to PSTN Phone .

       So we will be using the SIP on one side and ISUP ( just for example) on the PSTN side .........
 
       So will the following call flow valid , and can be used as a REFER call scenario :

       SIP PHONE/Proxy                  Switch                          PSTN
       INVITE F1 
        -------------------------------->
                                            IAM S1
                                           -------------------------------> ( PSTN Phone 1)
                 100 Trying F2
        <---------------------------------                                 
                                            ACM S2
                                           <-------------------------------- ( PSTN Phone 1)    
                 183 F3
         <--------------------------------
                                           ANM S3
                                           <-------------------------------- ( PSTN Phone 1)
                 200 O.K  F4       
         <-------------------------------- 

                  ACK F5
         --------------------------------->
                  INVITE ( Hold )F6
         ---------------------------------->
                   200 O.K F7
         <----------------------------------
                   ACK F8
          --------------------------------->
                REFER ( New PSTN URI )F9
          ---------------------------------->
                  202 ACCEPTED F10
          <---------------------------------
                                              IAM S4
                                            ------------------------------------> (PSTN Phone 2)
                                              ACM S5
                                            <------------------------------------  ( PSTN Phone2 )
                                              ANM S6
                                             <-----------------------------------  ( PSTN Phone 2)

                   NOTIFY F11
           <---------------------------------
                    200 OK  F12
           ---------------------------------->
                                              REL for first PSTN Subscriber S7
                                             --------------------------------------->(PSTN Phone 1)
                                              REL Confirm  S8
                                             <----------------------------------------- (PSTN Phone 1)

         Plese let me know if it is valid call flow ......

Regards,
jitender .

_____________________________________________________________
Get 25MB, POP3, Spam Filtering with LYCOS MAIL PLUS for $19.95/year.
http://login.mail.lycos.com/brandPage.shtml?pageId=plus&ref=lmtplus
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Bert Culpepper <[email-masked]>
Date: Tue, 17 Dec 2002 19:16:57 -0500

Standardization of mechanisms on sending DTMF in INFO has not occurred. 
    For SIP, the use of DTMF is seen as a means for user interaction 
with network-based applications.  To this end, work is ongoing on to 
define a framework and mechanisms for users to interact with 
applications in SIP.  See the I-Ds below for how this is expected to be 
supported.

http://www.ietf.org/internet-drafts/draft-culpepper-sipping-app-interact-reqs-02.txt
http://www.jdrosen.net/papers/draft-rosenberg-sipping-app-interaction-framework-00.txt
http://www.ietf.org/internet-drafts/draft-burger-sipping-kpml-00.txt
http://www.ietf.org/internet-drafts/draft-jennings-sip-app-info-00.txt

Regards,
Bert

sathish kumar wrote:

> Hi,
> 
> Pertaining to the SIP INFO method defined in RFC 2976 used for sending 
> mid call signaling information.
> 
> After establishment of Voice path between two user agents i wish to send 
> the DTMF digits from UAC to UAS.
> 
> 1. Can anyone tell me the format of sending the information (Header, 
> Message Body if any).
> 
> thanx and regards
> 
> sathises.
> 
> 
> ------------------------------------------------------------------------
> Do you Yahoo!?
> Yahoo! Mail Plus 
> <http://rd.yahoo.com/mail/mailsig/*http://mailplus.yahoo.com> - 
> Powerful. Affordable. Sign up now 
> <http://rd.yahoo.com/mail/mailsig/*http://mailplus.yahoo.com>