Subject: [Sip] INVITE transaction

From: Vijaya Venkatachalam <[email-masked]>
Date: Thu, 19 Dec 2002 13:19:00 -0500

Hi,

I have a question regarding the INVITE transaction
state machine.

It seems that in RFC 3261 - transaction state machine for
INVITE transactions, there is a potential for
the client side transaction to indefinitely be
in the "Proceeding" state since all timers
are cancelled on the reception of a 1xx response.

Can somebody tell me how the client side transaction
can come out of this state, if the server transaction on
the remote end dies?

Is it that the timer B is not cancelled and that only
timer A is cancelled when the 1xx is received or is
there some other means.

Appreciate a quick response.

Thanks,
Vijaya
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 24 Dec 2002 11:25:31 -0500

This is an application issue. It can decide to give up at any time and 
send CANCEL. We don't want to specify the maximum time a user will let 
the phone ring.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com