Subject: RE: [Sip] ABNF issue

From: [email-masked]
Date: Wed, 11 Dec 2002 15:57:04 +0200

> -----Original Message-----
> From: ext Christer Holmberg [mailto:[email-masked]]
> Sent: Wednesday, December 11, 2002 2:42 PM
> To: Rob Phillips
> Cc: Khartabil Hisham (NMP/Helsinki); [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: [Sip] ABNF issue

> 
> In this case, I think it is important to note that a SIP 
> header MUST start at the BEGINNING of a new line. 

Header fields can be extended over multiple lines by preceding each extra line with at least one SP or horizontal tab (HT).  

Also, in RFC2822:

"Messages are divided into lines of characters.  A line is a series of
   characters that is delimited with the two characters carriage-return
   and line-feed; that is, the carriage return (CR) character (ASCII
   value 13) followed immediately by the line feed (LF) character (ASCII
   value 10).  (The carriage-return/line-feed pair is usually written in
   this document as "CRLF".)

A message consists of header fields (collectively called "the header
   of the message") followed, optionally, by a body.  

...

Header fields are lines composed of a field name, followed by a colon
   (":"), followed by a field body, and terminated by CRLF.  A field
   name MUST be composed of printable US-ASCII characters (i.e.,
   characters that have values between 33 and 126, inclusive), except
   colon.  "

No header name is allowed a CR or LF in it,and certainly no sip header has CRLF included in its name.

Regards,
Hisham

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 11 Dec 2002 16:21:49 +0200

Hi,

> >In this case, I think it is important to note that a SIP header MUST start at the BEGINNING of a new line.
>

That's line folding, which is a separate issue. What I said was that the START of the header MUST be at the BEGINNING of a new
line, no matter if the rest of the header is then folded/extended over multiple lines.

> No header name is allowed a CR or LF in it,and certainly no sip header has CRLF included in its name.

I never said that the CRLF is part of the header name. My question was if the header name token could be proceeded by LWS, or
the header name token always be at the beginning of a new line.

Regards,

Christer Holmberg
Ericsson Finland

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 11 Dec 2002 11:23:45 -0800

Christer,

You specific question has been answered twice already, and I will 
answer it a third time.  If you still do not understand, please email 
one of the chairs privately and we will arrange for someone to explain 
it to you.

On Wednesday, December 11, 2002, at 06:21 AM, Christer Holmberg wrote:
> I never said that the CRLF is part of the header name. My question was 
> if the header name token could be proceeded by LWS, or

as rob@netrake said:
> 	RFC-3261 does not specifically ALLOW the name token to be proceeded 
> by LWS, i.e. the definition of message-header per ABNF is:
>
> 	message-header = (Accept / .... / extension-header) CRLF
>
> Therefore, the header name token MUST always be at the beginning of a 
> new line.

and as robert sparks said:
> The grammar answers that.
> extension-header starts with a token.

in other words, a SIP header ALWAYS starts with a token (all of the 
existing headers are tokens), which can NEVER contain leading 
whitespace.

thanks,
-rohan

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 12 Dec 2002 08:29:41 +0200

Hi,

> existing headers are tokens), which can NEVER contain leading

And I don't know how many times I've said this: I've NEVER claimed that a
header would start with anything else than a token. What I've been talking
about are general ABNF rules.

Anway, I have had a private discussion with Brian about this, so there is no
idea to continue it here. Rob also presented some assumptions we make in SIP,
and if everybody agrees on those I am happy.

Regards,

Christer Holmberg
Ericsson Finland