Subject: RE: [Sip] B2BUA & Max-Forwards

From: [email-masked]
Date: Fri, 6 Dec 2002 08:35:01 +0100

Hello,

"I don't get this.  Does two or more mean, for example, four?"
Two or more means exactly that: two or more. The exact number depends on
what the application is actually providing, and you cannot fixe it in
advance.

"but a pair of UAC/UAS concatenations"
OK, I get your point, you are thinking on a specific class of application
for bi-party communications. But this is only one case.

At the end, I start to agree with some other people:
- either we are able to provide a definition of a B2BUA independently of
what the B2BUA is actually doing
- or we drop the definition

Best regards
Juan Carlos

<[email-masked]> on 05/12/2002 19:54:26

To:   Juan-Carlos ROJAS/FR/ALCATEL@ALCATEL
cc:   <[email-masked]>
Subject:  RE: [Sip] B2BUA & Max-Forwards

Hi,

inline.

> "I am at the point where I agree with the sentiment raised by others,
> that we should remove the term b2bua entirely from the
> specification. It
> has caused more confusion than anything else."
>
> Yes, this is one possibility. An alternative (as I proposed
> in an earlier
> mail) is to complete the current definition in 3261 saying
> explicitly that
> :
> 1) A B2BUA handles two or more UAs, each one behaving as UAC/UAS, as
> described in 3261 for UAs

I don't get this.  Does two or more mean, for example, four?  And does that
in turn make it a B2BB2BUA? ;)

The only minor clarification I think might be in order for RFC3261 is that
it's not just a UAC/UAS concatenation, but a pair of UAC/UAS
concatenations.

However, the fact that the traffic in this thread alone equals to a year's
worth of emails on the SIMPLE list suggests that no clarification is enough
clarification.

So I agree with the other people in that getting rid of the definition
altogether is the best option.  After all, if it looks like a UA to the
outside world, it must be a UA.

> 2) The SIP protocol specification does not mandate for any
> behaviour of
> such B2BUA, i.e. on how to "link" (or "concatenate") two or more UAs.

Yes, probably the reason why the definition for a B2BUA is also useless.

Cheers,
Aki

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 6 Dec 2002 16:03:07 -0800

> what the application is actually providing, and you cannot fixe it in

think "starfish"

thx,
-r