Subject: Re: [Sip] different messages with same call-id before 100 is sent out

From: [email-masked]
Date: Mon, 2 Dec 2002 12:51:40 EST

In a message dated 12/2/2002 2:38:32 AM Eastern Standard Time, 
[email-masked] writes:

> Hi,
> 
> It has been explained several times why you cannot force the subsequent
> INVITEs to follow the rute that the first one followed. You can find the
> discussions in the archives or in the slides I presented in Australia.
> 
> Thanks,
> 
> 

[MAP] I understand that you can not "force" anything to take the same route, 
or even to arrive at the same egress point.

But my previous comments were generally the following:

1. Define the procedures for overlap based on a presumption that all INVITEs 
for one call will follow the same route.
2. Strongly "suggest" that the ingress point should not send the first INVITE 
until it has enough digits for proper routing (generally to the egress point).
3. The ingress clearly marks the first INVITE as incomplete and subsequent 
INVITEs (call id, seq number, or whatever) to indicate that they belong 
together
4. The egress doesn't handle anything that isn't correct, i.e., throws away 
an initial incomplete INVITE if it doesn't understand how to do overlap, 
stores it if it doesn't want to do overlap, or throws away a subsequent 
INVITE if it didn't get the previous.

I realize that 4. could be a problem if a subsequent INVITE looks just like a 
normal one and the egress GW knows nothing about handling overlap, that is, 
it doesn't understand that it is supposed to do what 4. says. But this is the 
whole point of my comments. There needs to be distinguishing information in 
the INVITE and if the egress GW doesn't understand the overlap procedures, 
then it shouldn't be doing it.

If SIP doesn't have a good way to tell the other end to ignore a message if 
it doesn't understand some specific part, then there is a bigger problem.

Mike Pierce
Artel

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 03 Dec 2002 11:01:09 +0200

Hi,

(I cannot "quote" your mail to answer more specifically because you sent
in in html format.)

Anyway, what you are proposing is a variant of what it has been proposed
a (large) number of times in the mailing list. It was also discussed in
the Australian IETF.

Thanks,

Gonzalo
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Prasanna Venkatesh <[email-masked]>
Date: Tue, 03 Dec 2002 14:31:12 +0530

One more query Gonzalo.
Can the draft define some behaviour on the UAS (egress GW) for out-of-order
messages?  There may be typical issues for SIP-T like, the first message
bore the IAM and a subsequent one had the SAM.  If they come out of order,
the egress GW's behaviour is confusing.
Regards,
Prasanna
Huawei Technologies

-----Original Message-----
From: Gonzalo Camarillo [mailto:[email-masked]]
Sent: Tuesday, December 03, 2002 2:31 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Sip] different messages with same call-id before 100 is
sent out

Hi,

Thanks,

Gonzalo

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 03 Dec 2002 11:30:15 +0200

Hi,

> bore the IAM and a subsequent one had the SAM.

All the INVITEs contain the IAM and all the subsequent SAMs.

Anyway, I will see if I can clarify the behavior in the draft so that it
is clearer.

Thanks,

Gonzalo

---

From: Prasanna Venkatesh <[email-masked]>
Date: Tue, 03 Dec 2002 15:06:47 +0530

Is this behaviour that all INVITEs contain all the IAMs and SAMs mentioned
in the draft.  I am very sorry if I have overlooked it.
regards,
Prasanna

-----Original Message-----
From: Gonzalo Camarillo [mailto:[email-masked]]
Sent: Tuesday, December 03, 2002 3:00 PM
To: Prasanna Venkatesh
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Sip] different messages with same call-id before 100 is
sent out

Hi,

Thanks,

Gonzalo

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 03 Dec 2002 12:38:07 +0200

Hi,

7th paragraph of section 3.3:

If the gateway is encapsulating ISUP messages as SIP bodies, it
  should place the IAM and all the SAMs received so far in this INVITE.

Regards,

Gonzalo

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip