Subject: [Sip] INFO Contact

From: FERRIERI Antonio <[email-masked]>
Date: Thu, 19 Dec 2002 19:17:56 +0100

Folks,
I'm a new entry in SIP world and I've a question on Contact Header:

 Does a Registar bind the Request-URI, in a Register message, to the URI in
Contact?
So, is not a Request-URI binded to the IP address in VIA field?
and If the contact Header is absent, what happens?

Thanks,
Antonio

=================================
"STRICTLY PERSONAL AND CONFIDENTIAL

This message may contain confidential and proprietary material for the sole
use of the intended recipient. Any review or distribution by others is
strictly prohibited. If you are not the intended recipient please contact
the sender and delete all copies.
The contents of this message that do not relate to the official business of
our company shall be understood as neither given nor endorsed by it."

=================================
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Sun, 22 Dec 2002 15:55:08 +0100

Hi Antonio,

in a REGISTER message,

the "To" Header Field contains the address of Record whose registration it to be created.

The "Contact" Field MAY be present in REGISTER REQUEST and it may contain "zero
or more values" containg address bindings.

If Contact Header is absent, the only contact address for the user is the Address present
in the "To" Header.

What do you mean about the binding between IP address in VIA field and the Request-URI?
I'm not understand the question and what do you mean.

ciao
Salvatore

personal mail: [email-masked]
work mail: [email-masked]
                [email-masked]
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip