Subject: [Sip] Contact in REGISTER

From: Loh Kok Jeng <[email-masked]>
Date: Wed, 18 Dec 2002 09:40:49 +0800

Dear all,

Suppose there is no binding at all for an Address-of-Record, and
the Registrar receives a REGISTER message with "Contact: *" for 
that particular address-of-record, how should the Registrar handle 
it?  Likewise, if the Contact header is missing, what should the 
Registrar do?  

In both cases, there is no additional contact information carried
in the REGISTER message.  So effectively the Registrar still doesn't
know the contact binding of the Address-of-Record.

Thanks.

regards,
KJ Loh
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Wed, 18 Dec 2002 09:49:43 +0530

Hi Loh,
     In both cases, the registrar should respond
with a 200 OK containing no Contacts. Whenever a
registrar responds to a REGISTER request it includes
the bindings that are currently known to it in the
response. (The second case that you refer to, is
equivalent to a query to the registrar to fetch the
current bindings).

Regards,
Subhash.
P.S.> Implementation related questions can be addressed
to [email-masked]

Loh Kok Jeng <[email-masked]> on 12/18/2002 07:10:49 AM

To:   [email-masked]
cc:    (bcc: Subhash Ullal Nayak/HSSBLR)

Subject:  [Sip] Contact in REGISTER

Dear all,

Thanks.

regards,
KJ Loh