Subject: AW: [Sip] B2BUA

From: Liebhart Rainer <[email-masked]>
Date: Thu, 5 Dec 2002 14:45:51 +0100

Henry,

unfortunately you are comparing apples and pears when stating that the telecom service failed for days after Sept 11, while Internet traffic continued smoothly. The mentioned "telefon service" consists of thousands of (real-time) calls to emergency centres while the Internet traffic consists mainly of requests to the Web pages of CNN and others (with bad response times) to retrieve *information* on the status of the catastrophe.

Rainer

-----Ursprüngliche Nachricht-----
Von: Pete Cordell [mailto:[email-masked]]
Gesendet: Donnerstag, 5. Dezember 2002 13:25
An: Henry Sinnreich
Cc: [email-masked]
Betreff: Re: [Sip] B2BUA

Henry,

The Internet has had a few famous outages as well.  Besides, if all the
telco traffic was put over IP, with today's level of QoS on the Internet, it
would have been brought to its knees also.

To say that one is all goodness and light and the other all evil doesn't do
us as a community any good as when customers find out there are problems
they tend not to believe anything else we say!

Only vapourware is flawless.  Most people know that.  Respect the
intelligence of your customer, or they will find somebody that does!!!

Pete.

----- Original Message -----
From: "Henry Sinnreich" <[email-masked]>
To: "'Phil Reynolds'" <[email-masked]>; <[email-masked]>
Sent: 04 December 2002 19:02
Subject: RE: [Sip] B2BUA

> >The telecoms people are clever enough to have thought
> >about that and build redundancy, fault tolerance and failover into
> their switches.
>
> This has proven unfortunately not to be the case on September 11 when
> telecom service failed for days, while Internet traffic continued
> smoothly. I suggest you to look at the central control model of the
> switch network versus the e2e architecture of the Internet. SIP enabled
> networks are also fully distributed and the e2e control principle
> maintained - that's why state in placed in SIP endpoints.
>
> I am not sure if a few words here can give full justice to the superior
> resilience of the Internet and to SIP enabled services,...
>
> Thanks, Henry
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Phil
> Reynolds
> Sent: Wednesday, December 04, 2002 7:37 AM
> To: [email-masked]
> Subject: RE: [Sip] B2BUA
>
>
> If a telephone switch crashes you loose all calls...  The telecoms
> people are clever enough to have thought about that and build
> redundancy, fault tolerance and failover into their switches.
> Maybe some of us IP-telecoms people have thought of similar techniques
> for SIP intermediaries?
> -----Original Message-----
> From: Jiri Kuthan [mailto:[email-masked]]
> Sent: 04 December 2002 12:32
> To: Christian Huitema; Roy, Radhika R, ALASO; [email-masked]
>
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [Sip] B2BUA
> [...snip...]
> I think there are more issues with B2BUA. A B2BUA's failure affects all
> current calls :-(
> -Jiri
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip Use
> [email-masked] for new developments on the application of sip
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 05 Dec 2002 12:16:51 -0600

Rainer, the fact is that people could communicate on 9/11/01 using IM
and SIP telephony from Columbia University, while the telecom phone
service, both landline and mobile was down for days.

There is very little or very much to comment on these facts.

Henry

> From: Liebhart Rainer [mailto:[email-masked]] 
> Sent: Thursday, December 05, 2002 7:46 AM
> To: 'Pete Cordell'; Henry Sinnreich
> Cc: [email-masked]
> Subject: AW: [Sip] B2BUA
> 
> 
> Henry,
> 
> unfortunately you are comparing apples and pears when stating 
> that the telecom service failed for days after Sept 11, while 
> Internet traffic continued smoothly. The mentioned "telefon 
> service" consists of thousands of (real-time) calls to 
> emergency centres while the Internet traffic consists mainly 
> of requests to the Web pages of CNN and others (with bad 
> response times) to retrieve *information* on the status of 
> the catastrophe.
> 
> Rainer
> 
> 
> The Internet has had a few famous outages as well.  Besides, 
> if all the telco traffic was put over IP, with today's level 
> of QoS on the Internet, it would have been brought to its knees also.
> 
> To say that one is all goodness and light and the other all 
> evil doesn't do us as a community any good as when customers 
> find out there are problems they tend not to believe anything 
> else we say!
> 
> Only vapourware is flawless.  Most people know that.  Respect 
> the intelligence of your customer, or they will find somebody 
> that does!!!
> 
> Pete.
> 
> > switch network versus the e2e architecture of the Internet. SIP 
> > enabled networks are also fully distributed and the e2e control 
> > principle maintained - that's why state in placed in SIP endpoints.
> >
> > I am not sure if a few words here can give full justice to the 
> > superior resilience of the Internet and to SIP enabled services,...
> >
> > Thanks, Henry
> >
> > redundancy, fault tolerance and failover into their switches. Maybe 
> > some of us IP-telecoms people have thought of similar 
> techniques for 
> > SIP intermediaries? -----Original Message-----
> > I think there are more issues with B2BUA. A B2BUA's failure affects 
> > all current calls :-( -Jiri
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>

---

From: Wilhelm Wimmreuter <[email-masked]>
Date: 05 Dec 2002 21:14:03 +0100

Hi Henry,
cant resist throwing my nonsense in as well

> There is very little or very much to comment on these facts.

Did you forget, that a qualified busy/congestion tone, even for
some days, does not reflect a system outage ;-)

 ... If required, call me on my SIP phone to sort that out. It
will work as usual :-)

Willi

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 05 Dec 2002 19:50:24 -0600

No "qualified busy/congestion tone" was experienced by any IM, e-mail or
SIP users.

Henry

> From: Wilhelm Wimmreuter [mailto:[email-masked]] 
> Sent: Thursday, December 05, 2002 2:14 PM
> To: Henry Sinnreich
> Cc: 'Liebhart Rainer'; 'Pete Cordell'; [email-masked]
> Subject: RE: [Sip] B2BUA
> 
> 
> Hi Henry,
> Did you forget, that a qualified busy/congestion tone, even 
> for some days, does not reflect a system outage ;-)
> 
>  ... If required, call me on my SIP phone to sort that out. 
> It will work as usual :-)
> 
> Willi
> 
> 
> 
> 
> 
>

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 6 Dec 2002 16:18:55 -0800

Hi Folks,

Let's please leave this flame war for the IEPREP mailing list, ok ;-)

thanks,
-rohan

On Thursday, December 5, 2002, at 05:45 AM, Liebhart Rainer wrote:

> Henry,
>
> unfortunately you are comparing apples and pears when stating that the 
> telecom service failed for days after Sept 11, while Internet traffic 
> continued smoothly. The mentioned "telefon service" consists of 
> thousands of (real-time) calls to emergency centres while the Internet 
> traffic consists mainly of requests to the Web pages of CNN and others 
> (with bad response times) to retrieve *information* on the status of 
> the catastrophe.
>
> Rainer
>
>
>> enabled
>> superior
>> all