Subject: [Sip] Replies to ACK

From: Jiri Kuthan <[email-masked]>
Date: Tue, 17 Dec 2002 14:58:15 +0100

I would like to verify with the mailing list whether negative replies to
ACKs are legal or not. 

Clearly, it makes no use to solicit positive reply for a "good" ACK and 
it is explicitely prohibited to challenge ACKs. However, what about "bad" 
ACKs? Let's say an ACK misses 'CallID' or has a broken r-uri -- should it 
be replied the same way as say BYE/INFO/FOOBAR requests? 

Some implementations do that and it helps upstream clients to understand 
what has gone wrong. Some implementations don't do that.

Can a spec-interpreter share with my an opinion on this?

Thanks,

-Jiri

--
Jiri Kuthan            http://iptel.org/~jiri/ 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Ravi Shiroor" <[email-masked]>
Date: Wed, 18 Dec 2002 09:15:25 +0530

ACK is a part of the three way handshake unlike other methods.
So I think it would not need a negetive reply to it.

Implementing a negetive reply to help an upstream client can
only be a debugging mechanism, but what then if the negetive
reply gets broken? Should we have a negetive reply for a broken
negetive reply?

regards,
ravi.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Jiri
> Kuthan
> Sent: Tuesday, December 17, 2002 7:28 PM
> To: [email-masked]
> Subject: [Sip] Replies to ACK
>
>