Subject: RE: [Sip] Replies to ACK

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 17 Dec 2002 14:54:03 -0000

I would have expected this to occur only if the request was so broken that it could not be recognised as an ACK and I am not sure whether this is possible.

I note that the security clauses of RFC 3261 explicitly preclude any challenge (401 or 407) to an ACK.

My understanding of section 17 4th paragraph [The client transaction is also responsible for receiving responses and delivering them to the TU, filtering out any response retransmissions or disallowed responses (such as a response to ACK)].is that if a proxy receives such a response, it would kill it at the client transaction, so the sender would probably not see the response anyway. This would imply to me that there is no advantage to sending a response to ACK even for fault detection purposes.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 

> -----Original Message-----
> From: Jiri Kuthan [mailto:[email-masked]]
> Sent: 17 December 2002 13:58
> To: [email-masked]
> Subject: [Sip] Replies to ACK
> 
> 
> I would like to verify with the mailing list whether negative 
> replies to
> ACKs are legal or not. 
> 
> Clearly, it makes no use to solicit positive reply for a 
> "good" ACK and 
> it is explicitely prohibited to challenge ACKs. However, what 
> about "bad" 
> ACKs? Let's say an ACK misses 'CallID' or has a broken r-uri 
> -- should it 
> be replied the same way as say BYE/INFO/FOOBAR requests? 
> 
> Some implementations do that and it helps upstream clients to 
> understand 
> what has gone wrong. Some implementations don't do that.
> 
> Can a spec-interpreter share with my an opinion on this?
> 
> Thanks,
> 
> -Jiri
> 
> 
> --
> Jiri Kuthan            http://iptel.org/~jiri/ 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 17 Dec 2002 18:56:33 +0200

Hi,

Since the ACK will stop the re-transmission of the final response, if the re-transmissions of the final responses keep coming it does indicate to the UAC that something (even if not exactly what) is wrong.

Regards,

Christer Holmberg
Ericsson Finland

---

From: Jiri Kuthan <[email-masked]>
Date: Tue, 17 Dec 2002 18:37:12 +0100

>Since the ACK will stop the re-transmission of the final response, if the re-transmissions of the final responses keep coming it does indicate to the UAC that something (even if not exactly what) is…
                                                                   ^^^^^^^^^^^^^^^^^^^^^^^^^
That's the primary argument, I think, some implementers have decided to send replies
to ACKs. (However surprising this technique may sound [to me too], I don't see it 
breaks the spec, except challenges are prohibitted.) An assertation "the r-uri which 
made it to me is bad" is certainly much more useful than one-bit diagnostic assertation 
"something is wrong".

-Jiri