Subject: Re: [Sip] B2BUA & Max-Forwards

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 04 Dec 2002 14:40:19 -0600

Kedar Patil wrote:
> This discussion raises one more doubt for me, pls. clarify.
> 
> UA1------->BtoBUA---------->UA2
 >
> Is the BtoBUA a SIP endpoint from UA1's point of view? In other
> words, are the the "Require:" etc end-to-end headers sent by UA1,
> meant for B2BUA or UA2?

As Adam pointed out in an earlier email in this thread, "A B2BUA cannot
transparently pass Require through. It must understand and invoke the
extension indicated." (rfc3261 says the same; see sec 20.32)  Having
said that, I realize that there exist what are called transparent B2BUAs
that pass e2e headers through without operating on them.  Time and
experience will decide if they are a boon or a bane; right now my
personal feeling is that a proxy is a far more better tool than a
transparent B2BUA.  It plays by the rules and is unlikely to break
e2e feature support.

> Is the UAS part in in BtoBUA is bound by the definition and rules
> in 3261?

Yes, it is a UA.

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Wireless Networks Group/Internet Software and Services
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Kedar Patil <[email-masked]>
Date: Wed, 4 Dec 2002 10:54:18 -0600

thanks,
= Kedar =

> -----Original Message-----
> From: Adam Roach [mailto:[email-masked]]
> Sent: Tuesday, December 03, 2002 6:37 PM
> To: 'Padma Suresh'; [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: [Sip] B2BUA & Max-Forwards
> 
> 
> -----Original Message-----
> From: Padma Suresh [mailto:[email-masked]]
>  
> > A B2BUA needs to propagate some of the headers received in a
> > request/response to the other endpoint. Example: Require...
> 
> No. As emphatically as possible: NO. This is completely wrong,
> and it appears to be a growing -- and dangerous -- misconception.
> 
> A B2BUA cannot transparently pass Require through. It must
> understand and invoke the extension indicated.
> 
>   "The Require header field contains a list of option tags, 
> described in
>    Section 19.2.  Each option tag defines a SIP extension that MUST be
>    understood to process the request."
> 
> A back to back user agent *is* a UAS, and *is* bound by this
> provision.
> 
> Whether the UAC portion then turns around and imposes the same
> requirement on the UAS it contacts is a local decision.
> 
> /a

---

From: "David R. Oran" <[email-masked]>
Date: Tue, 10 Dec 2002 07:36:47 -0500

--On Wednesday, December 04, 2002 10:54 AM -0600 Kedar Patil 
<[email-masked]> wrote:

> Is the BtoBUA a SIP endpoint from UA1's point of view?
Yes. Definintely.

> In other
It doesn't matter who they are "meant for". They MUST be processed and 
understood by B2BUA. Whatever UA2 sees is at the whim of the application on 
top of the UAS/UAC performing as the B2BUA.

> Is the UAS part in in BtoBUA is bound by the definition and rules
Yes. Emphatically.

>> requirement on the UAS it contacts is a local decision.

------------------------
David R. Oran
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720
Office: +1 978 264 2048
VoIP: +1 408 571 4576
Email: [email-masked]