Subject: RE: [Sip] B2BUA & Max-Forwards

From: "James Undery" <[email-masked]>
Date: Thu, 5 Dec 2002 13:21:36 -0000

Hi,

I think your confusion comes from mixing two email threads; the first statement in context says if a specific B2BUA demonstrates header transparency it doesn't change headers; the second statement is about B2BUAs in general and says they can do whatever they want (without commenting on the desirability of their actions).

Max-Forwards probably are an important case for your particular application, in general they may not be required (e.g. routing to an element you can guarantee not to proxy).

Your comment on Max-Forwards highlights well the difficulties faced in defining a B2BUA more specifically than the definition in 3261.

James 

> -----Original Message-----
> From: Pete Cordell [mailto:[email-masked]]
> Sent: 05 December 2002 12:10
> To: Dean Willis; [email-masked]
> Subject: Re: [Sip] B2BUA & Max-Forwards
> 
> 
> Dean,
> 
> Firstly, your statement that "The B2BUA doesn't change 
> headers that transit
> it." seems inconsistent with the statement "It does the same 
> thing as ...
> ANY 500-pound gorilla does".  I don't understand.
> 
> Secondly, I think max-forwards is a special case.  It is 
> important for the
> protection of SIP systems as it prevents loops.
> 
> Indeed, there is a major difference between a UAS and a B2BUA 
> and that is
> that the former terminates a request, and the latter 
> terminates a request
> AND ALSO forwards an associated request (or more).  The impact of this
> difference should be covered in the spec in the interests of 
> protecting
> other SIP systems.
> 
> Pete.
> 
> ----- Original Message -----
> From: "Dean Willis" <[email-masked]>
> To: "'Pete Cordell'" <[email-masked]>; <[email-masked]>
> Sent: 05 December 2002 01:23
> Subject: RE: [Sip] B2BUA & Max-Forwards
> 
> 
> > > One issue that the recent B2BUA discussion has raised in my
> > > mind is what a B2BUA (whatever its decided that should be)
> > > should do with Max-Forwards.
> >
> > It does the same thing as it does with any other header or 
> body part,
> > which is the same thing that ANY 500-pound gorilla does to 
> somebody's
> > body parts -- whatever it wants.
> >
> > What you're asking is "what is the transparency of this node with
> > respect to max-forwards", which is "#4 -- Header Transaprency" in my
> > top-10 list. The specification of a back-to-back user agent doesn't
> > mandate any level of transparency on this or any other header.
> >
> > --
> > Dean
> >
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Pete Cordell" <[email-masked]>
Date: Thu, 5 Dec 2002 15:48:27 -0000

James,

Thanks for your comments.

I think in general you CAN'T guarantee that an element you route to won't
proxy (or be a B2BUA).  And therefore loop detection is a problem.

Propagating Max-Forwards even when you know the precise routing should not
cause you any problems.

Pete.

----- Original Message -----
From: "James Undery" <[email-masked]>
To: "Pete Cordell" <[email-masked]>; "Dean Willis"
<[email-masked]>; <[email-masked]>
Sent: 05 December 2002 13:21
Subject: RE: [Sip] B2BUA & Max-Forwards

Hi,

I think your confusion comes from mixing two email threads; the first
statement in context says if a specific B2BUA demonstrates header
transparency it doesn't change headers; the second statement is about B2BUAs
in general and says they can do whatever they want (without commenting on
the desirability of their actions).

Max-Forwards probably are an important case for your particular application,
in general they may not be required (e.g. routing to an element you can
guarantee not to proxy).

Your comment on Max-Forwards highlights well the difficulties faced in
defining a B2BUA more specifically than the definition in 3261.

James