Subject: Re: [Sip] Why do we need 3-way handshake for INVITE transaction....

From: "Vishal Phirke" <[email-masked]>
Date: Fri, 30 May 2003 15:03:53 -0400

Apart from offer-answer mechanism, INVITE transactions differ from other
transactions in following ways:
1. They take more time and often an user intervention is required.
2. Invites can be forked. And if multiple destinations send 200 OK, you
don't want to end up with multiple connections. Instead, 3-way handshake
allows the decision of accepting one of them delayed till Ack is sent by
the originator of the request.
Hence, it is very important to do reliable handshake at the time of session
establishment.
-Vishal

                      "Nataraju A.B."                                                                      
                      <natarajuab@huawe        To:       [email-masked]                                      
                      i.com>                   cc:                                                         
                      Sent by:                 Subject:  [Sip] Why do we need 3-way handshake for INVITE   
                      [email-masked]         transaction....                                            
                      g                                                                                    

                      05/30/2003 02:04                                                                     
                      PM                                                                                   

Hello All,

I have a doubt why do we really need 3-way handshaking for INVITE
transacation.
whereas most of the others employ 2-way handshaking (BYE/200,
UPDATE/200...).

According to my knowledge one of the reason could be offer-answer mechanism
involved in INVITE transactions.

Thanx in advance,

Regards,
-Nataraju A.B.
 Huawei Technologies Ind Pvt Ltd,
 Bangalore-560008,
 +98455.95744

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Nataraju A.B." <[email-masked]>
Date: Sat, 31 May 2003 00:45:53 +0530

vishal,

does ur 2nd point mean that the SIP application  might select one of the 'n'
replies to the INVITE request (if it was not intenede for multi-party call).
even in this case it is logical to derive that application will selecet the
first response and reject the later 2xx responses OR will the application
wait for some time before sending the ACK back to callee.

Regards,
-Nataraju A.B.