Subject: [Sip] RE: SIP mobility in WLAN

From: "Santharam, Arun [NTWK SVCS]" <[email-masked]>
Date: Mon, 19 May 2003 13:34:33 -0500

If we follow the SIP implementation on Mobile IP then the SIP stack
should not have to bother about the mobility aspect. The SIP stack
should be notified of IP changes/handoff information (if relevant for
the SIP stack) by the underlying stack. This may prompt a SIP
registration and subsequent call flows.

My 2 cents ...
arun

> -----Original Message-----
> From: Rajarshi Chakraborty [mailto:[email-masked]] 
> Sent: Sunday, May 18, 2003 11:42 PM
> To: [email-masked]; [email-masked]; Santharam, Arun 
> [NTWK SVCS]; [email-masked]
> Cc: [email-masked]
> Subject: SIP mobility in WLAN
> 
> 
> Hi,
> 
> Where can I get call-flows for SIP session management in a 
> wireless LAN 
> (802.11)? 3GPP only addresses the issues for cellular 
> networks. Or are they 
> too trivial to be addressed specially? I am specially interested in 
> situations of handoffs (in this case, the IP changes as soon 
> as the host 
> shifts from the zone around one hotspot to another). Should 
> SIP bother at 
> all to detect IP changes or should the control be completely 
> outside SIP? I 
> mean should it be some other module that has the 
> responsibility of informing 
> the SIP stack in the mobile host about the IP changes, so 
> that the host may 
> then send a re-INVITE with a new SDP but the call still 
> remains active?
> 
> regards
> Rajarshi
> 
> 
> Rajarshi Chakraborty
> B-196, IIT Campus,
> Kharagpur,
> West Bengal, India
> PIN-721302
> 
> 
> 
> 
> 
> ----Original Message Follows----
> From: "Drage, Keith (Keith)" <[email-masked]>
> To: "'Ashish Naik'" <[email-masked]>,   "Santharam, 
> Arun [CC]" 
> <[email-masked]>,   "Sip@Ietf. Org" <[email-masked]>
> Subject: RE: [Sip] Session Mobility in SIP
> Date: Thu, 8 May 2003 14:42:24 +0100
> 
> Your best starting point to see the architecture is 3GPP TS 
> 23.228, with 
> reference to 3GPP TS 23.002 to see how these entities fit 
> together into the 
> entire 3GPP architecture.
> 
> The SIP protocol application is covered in 3GPP TS 24.229 
> with example flows 
> in 3GPP TS 24.228.
> 
> These documents may be found at:
> 
> ftp://ftp.3gpp.org/Specs/latest/Rel-5/ 
> <ftp://ftp.3gpp.org/Specs/latest/Rel-5/>
> 
> 3GPP uses these specifications over GPRS to provide mobility.
> 
> There is a parallel set of 3GPP2 specifications, 
> substantially of common 
> text, that uses the same architecture over mobile IP, instead 
> of GPRS. These 
> documents are currently in 3GPP2 comment and review.
> 
> regards
> 
> Keith
> 
> 
> 
> 
> Keith Drage
> Lucent Technologies
> Tel: +44 1793 776249
> Email: [email-masked]
> 
> -----Original Message-----
> From: Ashish Naik [mailto:[email-masked]]
> Sent: 08 May 2003 06:23
> To: Santharam, Arun [CC]; Sip@Ietf. Org
> Subject: RE: [Sip] Session Mobility in SIP
> 
> 
> ok. Is there any specific document on IETF and 3GPP that can 
> explain how it 
> is being addressed  ?
> 
> 
> Ragards,
> Ashish Naik
> CoE Mobile Computing
> -----------------------------------
> Phone 4018100 Ext 3070
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf 
> Of Santharam, 
> Arun [CC]
> Sent: Wednesday, April 09, 2003 9:42 PM
> To: Ashish Naik; Sip@Ietf. Org
> Subject: RE: [Sip] Session Mobility in SIP
> 
> 
> 
> Ashish,
> 
> 
> 
> Please find comments inline.
> 
> 
> 
> Thank you
> 
> arun
> 
> 
> 
> -----Original Message-----
> From: Ashish Naik [mailto:[email-masked]]
> Sent: Wednesday, April 09, 2003 4:01 AM
> To: Sip@Ietf. Org
> Subject: [Sip] Session Mobility in SIP
> 
> 
> 
> How is SIP going to address session mobility ? Is there any 
> initiative taken 
> up for this ?
> 
> 
> 
>  > This has been addressed in 3GPP standards. Please refer to 
> the 3GPP All 
> IP architecture specifications.
> 
> 
> 
> SIP is said to be a better alternative than Mobile IP. Can I 
> have some 
> latest development document references ?
> 
> 
> 
> 
> 
>  >  SIP is not going to replace Mobile IP. It is going to 
> leverage Mobile IP 
> for session management in 3G wireless networks.
> 
> 
> 
> 
> 
> Regards,
> Ashish Naik
> -------------------
> CoE Mobile Computing
> Phone: 4018100 Ext 3070
> 
> 
> 
> 
> *********************************************************
> Disclaimer
> 
> This message (including any attachments) contains
> confidential information intended for a specific
> individual and purpose, and is protected by law.
> If you are not the intended recipient, you should
> delete this message and are hereby notified that
> any disclosure, copying, or distribution of this
> message, or the taking of any action based on it,
> is strictly prohibited.
> 
> *********************************************************
> Visit us at http://www.mahindrabt.com
> 
> 
> 
> 
> *********************************************************
> Disclaimer
> 
> This message (including any attachments) contains
> confidential information intended for a specific
> individual and purpose, and is protected by law.
> If you are not the intended recipient, you should
> delete this message and are hereby notified that
> any disclosure, copying, or distribution of this
> message, or the taking of any action based on it,
> is strictly prohibited.
> 
> *********************************************************
> Visit us at http://www.mahindrabt.com
> 
> _________________________________________________________________
> Mobile, masti, magic! Cool ringtones & logos. 
> http://www.msn.co.in/mobile/ 
> Get noticed
> 
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Michael Thomas <[email-masked]>
Date: Mon, 19 May 2003 11:53:51 -0700 (PDT)

> registration and subsequent call flows.

I think it's a little bit more complicated than
this. As with most things, it often makes sense to
have logic at many different layers depending on
the actual situation you find yourself in. For
example, since there isn't route optimization for
IPv4, a reinvite with the new correct CoA would
rid yourself of the dog-leg through the home
agent. But it might complicate QoS reservations
and/or treatment, etc.

Which is a round about way of saying "it depends".

	 Mike

---

From: Henry Sinnreich <[email-masked]>
Date: Wed, 21 May 2003 10:48:02 -0500

> If we follow the SIP implementation on Mobile IP then the SIP 
> stack should not have to bother about the mobility aspect.

The other alternative is to have application layer mobility for SIP as
published in several papers at Columbia University and Telcordia. I
don't believe you need mobile IP for all scenarios or that is the best
option under all circumstances.

The last word on this may not be over yet.

Henry

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Santharam, Arun [NTWK SVCS]
> Sent: Monday, May 19, 2003 1:35 PM
> To: Rajarshi Chakraborty; [email-masked]; 
> [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: [Sipping] RE: SIP mobility in WLAN
> 
> 
> 
> If we follow the SIP implementation on Mobile IP then the SIP 
> stack should not have to bother about the mobility aspect. 
> The SIP stack should be notified of IP changes/handoff 
> information (if relevant for the SIP stack) by the underlying 
> stack. This may prompt a SIP registration and subsequent call flows.
> 
> My 2 cents ...
> arun
> 
> 
> > This message (including any attachments) contains confidential 
> > information intended for a specific individual and purpose, and is 
> > protected by law. If you are not the intended recipient, you should
> > This message (including any attachments) contains confidential 
> > information intended for a specific individual and purpose, and is 
> > protected by law. If you are not the intended recipient, you should
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>

---

From: Prabhas Ranjan Sinha <[email-masked]>
Date: Tue, 27 May 2003 06:59:49 -0400 (EDT)

> The last word on this may not be over yet.

Henry,
Could you please elaborate on it more w.r.t pros and cons or refer me to
to any publication which can talk about it ? I have read that people
forsee that Mobile IP could be the most suitable mechanism for mobility
across multiple subnets of WLAN network.

Prabhas

> > > ok. Is there any specific document on IETF and 3GPP that can

Prabhas
+++++++++++++
CSEL Technology Enterprise Programme
London Business School
Baker Street, London NW1 6DD
*****************************************
There is no wisdom greater than kindness.
*****************************************
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip