Subject: [Sip] Doubt about SIP Specific Event Notification behaviour

From: José Soler Lucas <[email-masked]>
Date: Thu, 22 May 2003 14:45:38 +0200

Hi everyone,
 
trying to imagine a service based on the SUBSCRIBE - NOTIFY methods of SIP
described in RFC 3265 I have came across a doubt that I was not able to find
a respose to through the different documents I have checked. Could anyone
out there please give me any hint on the matter?:
 
Imagine I have a SIP client that subscribes to a certain event happening in
a server. The subscription is acepted and performs properly. After a moment,
while the subscription is still active, there is an internal problem in the
server that prevents further NOTIFYes towards the subscribing client. The
question is:
 
a) Does the server send a 5xx message towards the client? or
b) Does the server send a NOTIFY with a "pending" status indicating a
temporal suspension of the subscription? or
c) Does the server send a NOTIFY with a "terminated" status forcing the end
of the subscription?
d) Should the server send rather [5xx] followed by
[NOTIFY(status=pending/terminated)]? 
 
If the answer is (a), what should the behavior of the client then be, to
assume the subscription as terminated?
 
Thanks in advance for your help.
Best regards,
 
josé

-------------------------------------------- 
José Soler Lucas, M.Sc.Telecom.E. 
PhD Student 
Networks Competence Area 
Research Center COM (Communications, Optics and Materials) 
Technical University of Denmark 
Building 343, DK 2800 Kgs. Lyngby, Denmark. 
Phone: +45 45 25 38 08 (direct) 
Fax:   +45 45 93 65 81 
E-mail: [email-masked] 
Web:  <http://www.com.dtu.dk/> http://www.com.dtu.dk/ 
---- 
Cellular: +45 22 27 48 22 
--------------------------------------------

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 31 May 2003 01:07:23 -0400

The spec doesnt call this out, since I have no idea why such a thing 
would happen. But the right thing to do is undoubtedly (c), have the 
server terminate the subscription by sending a NOTIFY with a 
terminated state.

-Jonathan R.

José Soler Lucas wrote:
> Hi everyone,
>  
> trying to imagine a service based on the SUBSCRIBE - NOTIFY methods of 
> SIP described in RFC 3265 I have came across a doubt that I was not able 
> to find a respose to through the different documents I have checked. 
> Could anyone out there please give me any hint on the matter?:
>  
> Imagine I have a SIP client that subscribes to a certain event happening 
> in a server. The subscription is acepted and performs properly. After a 
> moment, while the subscription is still active, there is an internal 
> problem in the server that prevents further NOTIFYes towards the 
> subscribing client. The question is:
>  
> c) Does the server send a NOTIFY with a "terminated" status forcing the 
> end of the subscription?
> Web: http://www.com.dtu.dk/
> ----

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Scientist                             Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip