Subject: Re: [Sip] Why do we need 3-way handshake for INVITE transaction....

From: "Vishal Phirke" <[email-masked]>
Date: Fri, 30 May 2003 18:13:24 -0400

I think the problem with the forking is, when an INVITE is forked and you
actually want to setup multiple calls.
In such a case application will send INVITE without SDP body and each 200
OK will carry an offer in SDP to which application can respond via using
ACK with separate media ports for each connection. If 3-way handshake is
not supported, setting up multiple calls with one INVITE is not possible.
-Vishal

                      "Arjun                                                                               
                      Roychowdhury"            To:       "Vishal Phirke" <[email-masked]>          
                      <[email-masked]        cc:       "Nataraju A.B." <[email-masked]>,          
                      >                         [email-masked], [email-masked]                           
                      Sent by:                 Subject:  Re: [Sip] Why do we need 3-way handshake for      
                      [email-masked]         INVITE transaction....                                     
                      g                                                                                    

                      05/30/2003 03:57                                                                     
                      PM                                                                                   

On 05/30/2003 03:03:53 PM, "Vishal Phirke" wrote:

> 2. Invites can be forked. And if multiple destinations send
> 200 OK, you
> don't want to end up with multiple connections. Instead, 3-way
> handshake
> allows the decision of accepting one of them delayed till Ack
> is sent by
> the originator of the request.
>

I dont think this is a valid reason for 3-way handshakes. By definition,
all 200 OKs are proxied back. Its upto the caller UA
to then send BYE/OK to callees that it does not want to talk to due to
forking. Therefore, the ACK is sent to all of them and doesnt
help in delaying the decision.

regds
arjun

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 31 May 2003 01:24:04 -0400

> not supported, setting up multiple calls with one INVITE is not possible.

This is not the case. The INVITE can contain an offer, and if forked, 
you get multiple answers. The caller then gets media from multiple 
sources to the same port, which it can disambiguate using SSRC. If it 
wants to move each dialog to a different port, it can then do a 
re-invite if it wants to.

The reason the three way handshake is needed has everything to do with 
the long delays in responding to an invite.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Scientist                             Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com