Subject: Re: [Sip] Why do we need 3-way handshake for INVITE transaction....

From: "Arjun Roychowdhury" <[email-masked]>
Date: Fri, 30 May 2003 15:57:13 -0400

On 05/30/2003 03:03:53 PM, "Vishal Phirke" wrote:

> 2. Invites can be forked. And if multiple destinations send 
> 200 OK, you
> don't want to end up with multiple connections. Instead, 3-way 
> handshake
> allows the decision of accepting one of them delayed till Ack 
> is sent by
> the originator of the request.
> 

I dont think this is a valid reason for 3-way handshakes. By definition, 
all 200 OKs are proxied back. Its upto the caller UA
to then send BYE/OK to callees that it does not want to talk to due to 
forking. Therefore, the ACK is sent to all of them and doesnt
help in delaying the decision.

regds
arjun

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Nataraju A.B." <[email-masked]>
Date: Sat, 31 May 2003 01:50:50 +0530

----- Original Message -----
From: "Arjun Roychowdhury" <[email-masked]>
To: "Vishal Phirke" <[email-masked]>
Cc: "Nataraju A.B." <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Saturday, May 31, 2003 1:27 AM
Subject: Re: [Sip] Why do we need 3-way handshake for INVITE transaction....

> help in delaying the decision.

[ABN] what could be the logic which the application might use to reject the
responses,
I mean which one out of 'n' 200-OK response for INVITE will be accepted and
rest all will be rejected.
The application only intended to contact the calle, but it does not have any
information about the callee information (which one to select).

will this be driven by a local policy ????

Regards,
-Nataraju A.B.