Subject: RE: [Sip] Question about resource management

From: [email-masked]
Date: Mon, 5 May 2003 21:59:19 +0300

Hi Maria,

> Krisztian, thanks a lot for your answer.
> 
> I have a further question on this same subject though:
> - Could the updated offer in the PRACK contain more than one 
> codec again?

If either the offerer or the answerer is only able to support the "single codec per media" case, then they should reduce in the first answer (answerer) or in the second offer (offerer).

> And, if the answer in the 200 OK (PRACK) still contains a 
> list of codecs,
> when will resource reservation happend then?

If both parties are able to support multiple codecs per media, then there is no need for the second offer-answer, resource reservation can be performed according to the result of the first offer-answer.
 
> Is any of the user agents (offerer or answerer) obliged to 
> reduce the list
> to a single codec at some point in the offer/answer model? 

Only, if one of them cannot support the multiple codecs per media. But, in any case, two offer-answer exchanges make the job.

Regards,
Krisztian

> 
> Thank you very much
> Regards
> Maria
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 02 May 2003 16:33
> To: Cuevas,MA,Maria,XGH4 R; [email-masked]
> Subject: RE: [Sip] Question about resource management
> 
> 
> Hi Maria, 
> 
> a quick clarification for the 3GPP call flows:
> according to the very latest changes to the last version of 
> the call flows
> document (3GPP TS 24.228 5.4.0): 
> - the offerer can start the resource reservation procedure right after
> receiving the answer in 183, if the answer is satisfactory, 
> i.e. it contains
> single codecs per media flows. In case there is a need to 
> include a second
> offer in PRACK in order to reduce to the "single codec per 
> media" case, the
> resource reservation can be started right after sending the PRACK.
> - the answerer can start the resource reservation procedure 
> right after
> having sent the answer in 183, if the answer contains single 
> codec per media
> flows. In case the first answer has multiple codecs per 
> media, the answerer
> should wait with resource reservation until generating the 
> second answer.
> 
> Regards,
> Krisztian
> 
> 
> > -----Original Message-----
> > From: ext [email-masked] [mailto:[email-masked]]
> > Sent: Friday, May 02, 2003 4:35 PM
> > To: [email-masked]
> > Subject: [Sip] Question about resource management
> > 
> > 
> > Dear all,
> > 
> > I have a question regarding resource management and in 
> > particular related to
> > at which point in the session establishment may resource 
> > reservation be
> > initiated. I would appreciate any comments on this.
> > 
> > I have noticed that the examples given in RFC 3312 seem to 
> > indicate that
> > resource reservation may be initiated as soon as an answer 
> > has been sent (by
> > the answerer) or received (by the offerer). At some point the 
> > RFC says:
> > 
> > "If the resource reservation mechanism used requires 
> participation of
> >    both user agents, the answerer SHOULD start resource reservation
> >    after having sent the answer and the offerer SHOULD 
> start resource
> >    reservation as soon as the answer is received.  If 
> participation of
> >    the peer user agent is not needed (e.g., segmented status 
> > type), the
> >    offerer MAY start resource reservation before sending 
> the offer and
> >    the answerer MAY start it before sending the answer."
> > 
> > My question is: if the answer (lets assume that it is 
> carried in a 183
> > response) is carrying a list of codecs taken from the initial 
> > offer (my
> > understanding is that this is possible under the 
> answer/offer model),
> > shouldn't both user agents wait for the updated (final) 
> > answer to be sent
> > and received (in the PRACK or the 200 OK to the PRACK) before 
> > initiating
> > resource reservation? 
> > 
> > Following on that, I have also noticed that 3GPP call flows 
> > as specified in
> > TS 24.228 show resource reservation happening after the 200 
> > OK for the PRACK
> > is sent and received. Couldn't the reservation start just 
> > after the PRACK
> > message (carrying the final answer) is sent/received?
> > 
> > So, when can we assume that resource reservation can start? 
> > Can we assume
> > that it can start as soon as a final offer is sent/received?
> > 
> > 
> > Thank you very much in advance.
> > Regards
> > Maria 
> > 
> > 
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> > 
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Hassan CHOUMAR <[email-masked]>
Date: Tue, 06 May 2003 12:21:32 +0300

Hello all
Anybody can help me to find information to buy the entities of SIP or
to download them free on the Internet.
Thank you in advance 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: 박승훈 <[email-masked]>
Date: Tue, 6 May 2003 20:48:16 +0900

Dear Hassan,
I got some of you want.

#1 SIP free server and simple test ua. (vocal)
http://www.vovida.org/applications/downloads/vocal/

#2 light weight SIP Stack  (osip)
http://www.gnu.org/software/osip/

#3 linux sip phone (using osip)
http://www.linphone.org

I hope these will help you.

Regards,
Surym
shp

---

From: Ranjit Avasarala <[email-masked]>
Date: Tue, 06 May 2003 17:34:47 +0530

U can refer http://www.sipcentre.com

Regards
Ranjit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hassan
CHOUMAR
Sent: Tuesday, May 06, 2003 2:52 PM
To: [email-masked]
Subject: [Sip] Question about entities SIP

Hello all
Anybody can help me to find information to buy the entities of SIP or to
download them free on the Internet. Thank you in advance 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip