Subject: RE: [Sip] UPDATE and P-Asserted-ID

From: "Elwell, John" <[email-masked]>
Date: Thu, 08 May 2003 09:21:53 +0100

Keith,

Thanks for your response. However, I do not wish to cover target refresh. As
I understand from section 12 of RFC3261, local and remote targets are
derived from Contact headers. The scenario I have in mind is where something
happens behind a gateway. However, the gateway remains the same and
therefore it does not need to generate a new Contact header.

John ([email-masked])

> -----Original Message-----
> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: 07 May 2003 19:11
> To: Elwell, John; [email-masked]'
> Subject: RE: [Sip] UPDATE and P-Asserted-ID
> 
> 
> I believe the thinking when the document was developed was 
> essentially to allow it in methods that either initiated a 
> dialog, or were sent outside of a dialog. There was therefore 
> no intent to cover reINVITE at that time, although I do not 
> think it was explicitly excluded in the RFC. I am not sure 
> how the BYE got added in respect of this, maybe someone else 
> can clarify. The NOTIFY is there in respect of a NOTIFY that 
> confirms a SUBSCRIBE dialog.
> 
> This would allow the exchange of identities between the end 
> users under these circumstances.
> 
> From what you are indicating, it looks like you would want to 
> extend the above to cover target refresh requests.
> 
> Keith
> 
> Keith Drage
> Lucent Technologies
> Tel: +44 1793 776249
> Email: [email-masked] 
> 
> > -----Original Message-----
> > From: Elwell, John [mailto:[email-masked]]
> > Sent: 07 May 2003 10:20
> > To: [email-masked]'
> > Subject: [Sip] UPDATE and P-Asserted-ID
> > 
> > 
> > In RFC3325 section 9.1 it indicates that P-Asserted-ID is not 
> > allowed in
> > UPDATE. Does anyone know the reason for this? A useful 
> > application would be
> > to indicate a changed asserted identity when a change of 
> > party occurs in a
> > legacy network (e.g., due to transfer). If not allowed in UPDATE, a
> > re-INVITE would need to be used, but this introduces an 
> extra message.
> > 
> > John Elwell ([email-masked])
> > 
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> > 
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Mon, 12 May 2003 16:11:36 -0700

John,

I believe you still should generate a new Contact header, even if you 
are only changing the display name.

thanks,
-rohan