Subject: Re: [Sip] problem with NAT

From: "Sujith Kumar" <[email-masked]>
Date: Tue, 27 May 2003 10:13:25 +0530

Hi Suresh,
             The sip registration should have a time out and after the time 
out, the sip client needs to register again. The SIP register timeout should 
be less than (or equal) the Transition table entry time out.
I hope, this will solve your problem,.

Regds,
Sujith

>From: suresh t <[email-masked]>
>To: [email-masked]
>Subject: [Sip] problem with NAT
>Date: Tue, 27 May 2003 03:44:49 +0100 (BST)
>
>hi all..
>
>i got one doubt reg. NAT traversal of the SIP
>messages...pls clarify me ASAP...
>
>suppose if the user1 is using local Ip address and
>registers with the proxy with Ip address and port(the
>proxy registers the NATed IP and port(dynamic)).
>
>and suppose it is a chat like application, the user2
>wants to connect user1 through some private protocol,
>which is using TCP, but after a long time...
>
>in this case, the translation table(NAT) in the Router
>
>of user1 is timed out and has been purged. then the
>user2 cannot access the user1's system.
>
>how can i solve the above problem..?
>
>ur suggestion is highly appreciated.
>
>thanks in advance
>suresh
>
>
>
>__________________________________________________
>It's Samaritans' Week. Help Samaritans help others.
>Call 08709 000032 to give or donate online now at 
>http://www.samaritans.org/support/donations.shtm
>_______________________________________________
>Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>This list is for NEW development of the core SIP Protocol
>Use [email-masked] for questions on current sip
>Use [email-masked] for new developments on the application of sip

_________________________________________________________________
Want free fuel? Get IOC Citibank card. 
http://server1.msn.co.in/msnleads/citibankcards/ioc.asp Drive your dreams!

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Ryan Kereliuk <[email-masked]>
Date: Mon, 26 May 2003 23:32:28 -0600

On Tue, May 27, 2003 at 10:13:25AM +0530, Sujith Kumar wrote:
> out, the sip client needs to register again. The SIP register timeout 
> should be less than (or equal) the Transition table entry time out.

Your comment is generally correct assuming a UA that uses UDP and supports
both symmetric signalling and very short REGISTER expiry times (and once
you add media into the picture it gets more complex).  Interop experience
shows that quite a few UAs don't support one or the other.

The original poster asked about TCP, however.  Unlike UDP, the NAT/PAT
bindings for TCP can be (and often are) torn down when the TCP state 
machine reaches a final state.  Unless you're using persistent and   
reusable connections you're going to run into trouble.

Let me point out the ICE draft, draft-rosenberg-sipping-ice-00.html,
which AFAIK is the latest attempt to reconcile SIP with the realities
of NAT/PAT.  I'm not sure what kind of traction it's getting but I think
it will be quite a while before something like this is part of common
SIP implementations.